Нил Стивенсон - Криптономикон (часть 1)

1 Нил Стивенсон

Существует удивительно близкая параллель между задачами физика и криптографа. Система, по которой зашифровано сообщение, соответствует законам Вселенной, перехваченные сообщения — имеющимся наблюдениям, ключи дня или сообщения — фундаментальным константам, которые надо определить. Сходство велико, но с предметом криптографии очень легко оперировать при помощи дискретных механизмов, физика же не так проста.
-Алан Тьюринг

Сегодня утром [Имельда Маркос] предложила очередное объяснение миллиардам долларов, которые, как считается, они с мужем, умершим в 1989 году, присвоили за время его президентства.
«Так совпало, что у Маркоса были деньги, — сказала она. — После Бреттон-Вудского* [Валютно-финансовая конференция в Бреттон-Вудсе была проведена в июле 1944 года. По ее решению были созданы Международный валютный Фонд и Международный банк реконструкции и развития.] соглашения он начал покупать золото в Форт-Нокс. Три тысячи тонн, потом 4000. У меня есть на них документы. 7000 тонн. Смешно: Америка его не поняла».
-«Нью-Йорк таймс», понедельник, 4 марта 1996

ПРОЛОГ

Визг шин. Завал вбок..
Срубили рощу бамбука —
Из нее — песнь войны.

...лучшее, на что капрал Бобби Шафто сейчас способен: он стоит на подножке грузовика, одной рукой держится за зеркало, в другой — «спрингфилд». Слоги по пальцам хрен посчитаешь. «Из нее» — два слога или три? Грузовик наконец решает не переворачиваться и грохается обратно на четыре колеса. Визг на мгновение стихает. Бобби по-прежнему слышит пение кули, но теперь к нему добавляется ружейный скрежет коробки передач — рядовой Уайли сбрасывает скорость. Неужто сдрейфил? Сзади, под брезентом, громыхают полторы тонны металлических шкафов, шифровальные книги сыплются лавиной, плещет бензин в баках электрического генератора станции «Альфа». Вот и сочиняй в наше время хайку. Электрический генератор — это сколько слогов, девять? Даже во вторую строчку не втиснешь!
— Людей давить можно? — спрашивает рядовой Уайли и жмет на клаксон раньше, чем Бобби Шафто успевает ответить. Сикх-полицейский прыгает через говновозку. Подмывает сказать: «Да хули они нам сделают, войну объявят?» — но старшему по званию положено думать головой, а не задницей, поэтому Шафто не рубит сплеча, а прежде оценивает ситуацию.
Шанхай, 16.45, пятница, 28 ноября 1941 г. Бобби Шафто и еще пяток морпехов в грузовике смотрят на Цзюцзянскую дорогу, куда только что вылетели с риском перевернуться. Справа собор, значит, они — в скольких? в двух? — кварталах от Банда, где их груз ждет канонерка Янцзыйского Речного Патруля. Одна загвоздка — в этих двух кварталах живут примерно пять миллионов китайцев.
Все они — бывалые горожане, не какая-нибудь темнота деревенская, в глаза не видевшая машин, — те бы, услышав клаксон, мигом брызнули с дороги. Некоторые, правда, отскакивают к домам, создавая впечатление, что грузовик движется быстрее, чем сорок три мили в час по спидометру.
Однако Бобби Шафто упомянул бамбуковую рощу не для красного словца, чтобы удивить своих в Окономовоке восточным колоритом. Перед грузовиком до хренища бамбука, десятки легких временных шлагбаумов преграждают дорогу к реке, потому что офицеры Азиатского флота ВМС США и 4-го полка МПФ спланировали этот маленький бросок без учета фактора пятницы. Как объяснил бы им Бобби Шафто — если б его удосужились спросить, — дорога пролегает через банковский район. Здесь вам и Гонконгский Банк, и Шанхайский, и, разумеется, Сити-банк, Чейз-Манхэттен-банк, Банк Америки, ББМЕ, Сельскохозяйственный банк Китая и еще куча занюханных провинциальных банков. Часть из них имеют контракты от недобитого китайского правительства на печатание денег. Дело, видать, не шибко прибыльное, поэтому деньги из экономии печатают на старых газетах. Можно разобрать прошлогодние новости и счет матчей в поло под яркими цифрами и картинками, превращающими куски резаной бумаги в легальное платежное средство.
Как известно каждому рикше и разносчику в Шанхае, контракт на печатание денег предполагает, что банк обеспечивает бумажки таким-то и таким-то количеством серебра; любой может войти в банк на Цзюцзянской дороге, шваркнуть на прилавок груду купюр и (при условии, что они отпечатаны этим банком) получить за них настоящее металлическое серебро.
Если бы Китай в это самое время не четвертовала Япония, правительство, вероятно, отправляло бы в банки аудиторов проверять, сколько в сейфах серебра, и все было бы чин чинарем. Однако сейчас за честностью банков следят только другие банки. Вот как это делается: в ходе нормальных деловых операций куча бумажек проходит через окошки (скажем) Чейз-Манхэттен-банка. Их уносят в заднюю комнату и сортируют, бросая в картонные коробки (примерно два квадратных фута, ярд глубиной, с веревками по четырем углам). Все деньги (скажем) Банка Америки сваливают в одну коробку, Сити-банка — в другую. Потом, под вечер пятницы, зовут кули. У каждого кули, или у каждой пары кули, есть свой длинный бамбуковый шест; кули без шеста — все равно что морпех без начищенного штыка. Они продевают шесты в петли по углам коробки, затем подлезают каждый под свой конец шеста и поднимают коробку. Кули должны шагать в такт, не то коробка раскачается и все высыпется. Поэтому, направляясь к банку, название которого указано на купюрах, они поют и переставляют ноги в такт песне. Шест длинный, кули далеко друг от друга, петь приходится громко, и, разумеется, каждая пара на улице поет свою песню, стараясь перекричать остальных, чтобы не сбиться с шагу.
В пятницу вечером, за десять минут до закрытия, двери многих банков распахиваются и входят поющие кули, как какой-нибудь хор в сраном бродвейском мюзикле, шваркают коробки с мятыми ассигнациями и требуют деньги на бочку. Все банки сводят расчеты в конце недели. Иногда они делают это одновременно, особенно в такой день, как 28 ноября 1941 года, когда даже простому морпеху Шафто ясно, что настоящее серебро лучше груды резаных бумаг.
Вот почему, хотя нормальные пешеходы, торговцы с тачками и озверевшие полицейские-сикхи, разбегаются с дороги и вжимаются в стены клубов, борделей и магазинов на Цзюцзянской дороге, Бобби Шафто и прочие морпехи по-прежнему не видят канонерки за горизонтальным лесом бамбуковых шестов. Не слышат гудков своего грузовика за пульсирующей пентатонической какофонией. Это не просто пятничная банковская лихорадка. Это последний расчет перед тем, как все восточное полушарие займется огнем. Миллионы обязательств на подтирках будут обменены или пропадут в следующие десять минут; настоящее серебро или золото перейдет из рук в руки или останется на месте. Своего рода финансовый Судный день.
— Господи, я не могу, — стонет рядовой Уайли.
— Капитан сказал ни хера не останавливаться, — напоминает Шафто. Он не советует Уайли давить кули, просто напоминает: если Уайли этого не сделает, им придется отвечать перед капитаном, который, между прочим, едет сразу за ними, в машине с вооруженными морпехами. А судя по тому, как капитан психовал по поводу станции «Альфа», ему уже хорошенько вставил не то какой-нибудь адмирал из Перл-Харбора, не то даже (барабанная дробь!) шишка из Штаба МПФ, Вашингтон, округ Колумбия.

Шафто и другие морпехи всегда знали, что станция «Альфа» — это кучка штабных морячков на крыше дома в Международном поселении, на утыканной антеннами платформе из деревянных поддонов. Постояв подольше, можно было увидеть, как антенны поворачиваются, целясь на что-то в море. Шафто даже сочинил об этом хайку:

Антенна ищет —
Собачий нос на ветру —
Тайны эфира.

Это его второе хайку — явно не уровень ноября 1941-го, — и он морщится, вспоминая слова.
Однако до сегодняшнего дня никто в морской пехоте понятия не имел, какая это важная штука. Их заставили увязывать в брезент тонну оборудования и несколько тонн бумаги, а потом тащить на улицу. В четверг разбирали и жгли насест вместе с частью книг и бумаг.
— Бля-я-я-я! — вопит рядовой Уайли. Только несколько кули убрались с дороги, остальные даже не видят грузовик. Со стороны реки доносится грохот, как будто Бог ломает о колено бамбуковый шест в милю толщиной. Через полсекунды на улице ни одного кули, лишь куча коробок да бамбуковые шесты подрагивают и звенят о мостовую, словно колокольчики на ветру. Над канонеркой — мохнатый гриб серого дыма. Уайли врубает максимальную скорость и газует. Шафто вжимается в дверцу, наклоняет голову и надеется, что каска времен Первой мировой не подкачает. Коробки с деньгами лопаются и рассыпаются под колесами. Шафто смотрит сквозь денежную пургу и видит исполинские бамбуковые шесты, кувырком летящие к набережной.

Листья Шанхая —
Двери в стальное небо.
Началась зима.

ПУСТОШИ

Давайте отложим вопрос о существовании Бога до следующей книги и просто примем, что каким-то образом на этой планете возникли самовоспроизводящиеся организмы и тут же начали изничтожать друг друга, либо до отказа заполняя жизненное пространство своими грубыми копиями, либо более прямыми методами, о которых нет надобности распространяться. Большей части это не удалось, их генетическое наследие кануло в никуда; однако некоторые выжили и размножились. Примерно через три миллиарда лет этой местами занятной, местами нудной фуги жора и соития в Мердо, штат Дакота, у Бланш, супруги конгрегационалистского пастора Бэньяна Уотерхауза, родился сын Годфри Уотерхауз IV. Подобно всем живым существам на земле, Годфри был по рождению отъявленной сволочью, ибо в некоем узкотехническом смысле происходил посредством череды менее эволюционно продвинутых особей от той первой самовоспроизводящейся хреновины, которая, учитывая число и разнообразие ее потомков, может по праву считаться самой отъявленной сволочью с начала времен. Всё и вся, кто не был отъявленной сволочью, сгинули.
Из всех смертельно опасных, меметически* [Меметический (по аналогии с «генетический») — передающийся посредством «мемов» — единиц культурной информации, которыми люди заражают друг друга. С точки зрения меметики, к ним относятся лозунги, заклинания, мелодии, мода и многое другое.] запрограммированных на убийство машин это были самые что ни на есть милые и приятные. Подобно своему тезке (Джону Бэньяну, пуританскому писателю, который большую часть жизни провел в тюрьме или в бегах), преподобный Уотерхауз не проповедовал долго на одном месте. Церковь каждые год-два перебрасывала его из одной дакотской деревни в другую. Вероятно, Годфри такая жизнь не привлекала, потому что посреди курса в Конгрегационалистском колледже Фарго он покинул лоно церкви и, к неизбывному горю своих родителей, предался мирской тщете — защитил докторскую степень по классической филологии в маленьком частном университете в Огайо. Ученые — народ такой же кочевой, что и проповедники. Годфри поехал туда, где требовался преподаватель латыни и греческого, — в Болжеровский христианский колледж, Вест-Пойнт, Виргиния. Здесь, на слиянии Маттапоная и Паманки, отвратительные миазмы огромной целлюлозно-бумажной фабрики пронизывали каждый ящик стола, каждый закуток, каждую страницу в книге. Молодая жена Годфри, урожденная Алиса Притчард, которая в детстве колесила со своим отцом-проповедником по просторам Восточной Монтаны, пахнущим шалфеем и снегом, блевала три месяца. Еще через шесть родился Лоуренс Притчард Уотерхауз.
У мальчика были странные отношения со звуками. Когда проезжал паровоз, его не раздражали гудки и звон. Однако если в дом залетал шершень и начинал с еле слышным гудением выписывать под потолком фигуры Лиссажу, Лоуренс плакал от боли в носу. А когда он видел что-нибудь страшное или чувствовал пугающий запах, то зажимал уши.
Среди звуков, которые ничуть его не раздражали, был и орган Болжеровского христианского колледжа. Сама церковь не стоила доброго слова, но орган, пожертвованный владельцем целлюлозно-бумажной фабрики, сделал бы честь собору. Это вполне устраивало органиста, считавшего, что некоторые атрибуты Бога (гнев и ревность в Ветхом Завете, величие и торжество в Новом) можно вложить в паству непосредственно через слух. Что от этого могут вылететь витражи, никого не волновало, их все равно в городе не любили, а дым от бумажной фабрики разъедал свинцовые переплеты. Однако, когда очередная престарелая дама после службы встала, пошатываясь от шума в ушах, и едко заметила пастору, что музыка чересчур драматична, органиста сменили.
Тем не менее он по-прежнему давал уроки. Учеников не допускали к органу, пока они не станут хорошо играть на пианино. Когда это объяснили Лоуренсу Притчарду Уотерхаузу, он за три недели разучил фугу Баха и записался на уроки органа. Поскольку ему было тогда пять лет, он не мог одновременно дотянуться до клавишей и до педалей, поэтому играл стоя, вернее — переходя от педали к педали.
Когда Лоуренсу было двенадцать, орган сломался. Фабрикант не предусмотрел пожертвований на ремонт, и учитель математики решил попробовать сам. Он был слаб здоровьем и нуждался в толковом помощнике. Вместе с Лоуренсом они сняли кожух. Впервые за все это время мальчик увидел, что происходит, когда он нажимает клавиши.
Для каждого регистра органа (блокфлейта, горн, пикколо) был отдельный ряд труб, от самой длинной до самой короткой. Длинные трубы воспроизводили низкие звуки, короткие — высокие. Верхушки труб располагались террасообразно. Их можно было бы очертить линией — не прямой, но восходящей кривой. Органист — учитель математики взял несколько расшатавшихся труб, карандаш, бумагу и помог Лоуренсу рассчитать, почему так получается. Когда Лоуренс это понял, ему показалось, будто учитель математики внезапно сыграл добрую часть «Фантазии и фуги соль минор» Баха на органе размером со спиральную туманность Андромеды — ту часть, где старик Иоганн Себастьян рассекает архитектуру вселенной одним неумолимо снижающимся аккордом; будто его ноги прошли через наслоения мусора и уперлись наконец в твердую землю. В частности, последние шаги объяснения напоминали падение ястреба сквозь бесчисленные слои невежества и заблуждения. Назовите это чувство завораживающим, щемящим или томительным в зависимости от вашего склада. Небеса разверзлись. Лоуренсу на миг предстали ангельские хоры, уходящие в геометрическую бесконечность.
Трубы торчали параллельными рядами из широкого плоского ящика со сжатым воздухом. Все трубы, издающие одну ноту, но принадлежащие к разным регистрам, выстраивались в ряд по оси. Все трубы одного регистра, но настроенные на разные тона, выстраивались в ряд по другой, перпендикулярной оси. Внизу находился плоский ящик со сжатым воздухом, а также механизм, подающий воздух в нужную трубу в нужное время. При нажатии» клавиши или педали все трубы, способные издавать соответствующую ноту, звучали, если при этом был открыт их регистр.
Механически все это осуществлялось предельно просто, ясно и логично. Раньше Лоуренс думал, что машина по меньшей мере так же сложна, как самая сложная исполняемая на ней фуга. Теперь он понял, что просто устроенная машина способна производить бесконечно сложный результат.
Регистры редко применялись поодиночке. Они обычно громоздились один на другой, дабы использовать преимущества доступных гармоник (опять сладкая математика!). Некоторые комбинации повторялись вновь и вновь — например, множество блокфлейт, разной длины, для тихой проскомидии. Для этого встроили тяги включения регистров в произвольных комбинациях. Органист мог заранее выбрать несколько вариантов регистровки. По одному нажатию кнопки пневматика открывала несколько регистров сразу; в то же мгновение орган становился другим инструментом с совершенно новыми возможностями.
На следующее лето Лоуренса и Алису колонизировал дальний родственник по эволюционной линии — отъявленная сволочь-вирус. Лоуренс отделался тенденцией почти незаметно приволакивать ногу. Для Алисы болезнь закончилась аппаратом искусственного дыхания. Позже, из-за невозможности как следует откашливать мокроту, она заболела воспалением легких и умерла.
Отец Лоуренса Годфри честно сознался, что не в силах управиться с легшим на него бременем. Он уволился из виргинского колледжа, переехал вместе с сыном в штат Миннесота, а именно в Мурхед, и купил домик по соседству с Бэньяном и Бланш. Позже он пошел преподавать в ближайшую среднюю школу.
На этой стадии взрослые, ответственные за Лоуренса, похоже пришли к молчаливому соглашению, что лучший (во всяком случае, самый простой) способ его воспитывать — это оставить в покое. Лоуренс ничего от них не требовал, разве что иногда задавал вопросы, на которые все равно никто ответить не мог. В шестнадцать, исчерпав возможности местной школьной системы, Лоуренс Притчард Уотерхауз сдал экзамены в Государственный Айовский колледж. Там, помимо прочего, был обязательный курс подготовки офицеров запаса ВМФ.
В Учебном корпусе офицеров запаса Айовского колледжа имелся оркестр, где с радостью узнали про музыкальные наклонности Лоуренса. Поскольку трудно вышагивать по палубе дредноута, играя на органе, ему выдали глокеншпиль и пару маленьких молоточков.
В то время, когда он не маршировал взад-вперед по пойме реки Сканк, издавая металлический звон, Лоуренс изучал механику. Учился он плохо, потому что связался с преподавателем-болгарином, Джоном Винсентом Атанасовым*. [Атанасов Джон Винсент (1903–1995), американский физик болгарского происхождения. Созданная им и Клиффордом Берри в 1937–1942 году машина для решения дифференциальных уравнений, хотя и не была программируемой, считается одним из прототипов компьютера.] Тот вместе со своим аспирантом, Клиффордом Берри, строил машину, которая по идее должна была решать некие особенно нудные дифференциальные уравнения.
Больше всего Лоуренсу мешала лень. Он считал, что было бы много проще, если бы вы, как Супермен с его рентгеновским зрением, видели за внешними наслоениями внутренний математический скелет. Как только вы поняли математическую суть, вы поняли все и можете теперь манипулировать ею сколько влезет при помощи всего лишь карандаша и салфетки. Он видел эту суть в изгибе серебряных пластин глокеншпиля, в несущей арке моста, в утыканном конденсаторами барабане машины Атанасова-Берри. Собственно молотить по глокеншпилю, возводить мост или выяснять, почему не работает машина, ему было неинтересно.
Соответственно обучение шло со скрипом. Правда, время от времени он выделывал на доске фокус, от которого у преподавателей подгибались колени, а соученики смотрели ошарашенно и враждебно. Пошла молва.
Тем временем бабушка Бланш, неведомо для Лоуренса, пустила в ход свои обширные церковные связи. Ее усилия увенчались успехом: Лоуренс получил стипендию от наследника компании по производству овсяных хлопьев. Стипендия была учреждена, чтобы отправлять конгрегационалистов со Среднего Запада в лучшие университеты страны сроком на один год. Видимо, считалось, что за это время они успеют повысить интеллектуальный коэффициент на несколько решающих процентов, но не успеют погрязнуть в пороках. Так Лоуренс оказался на втором курсе Принстонского университета.
Принстон — весьма почтенное заведение и попасть туда большая честь, однако никто не потрудился объяснить этого Лоуренсу, что было и плохо, и хорошо. Он принял стипендию с умеренной благодарностью, к большой досаде овсяного магната. С другой стороны, он легко освоился в Принстоне, напоминавшем ему лучшие уголки Виргинии. В городе были чудесные органы; дело портили только домашние задания по конструированию мостов и построению шестеренок. Как всегда, они в конце концов сводились к математике, а с ней Лоуренс расправлялся легко. Порой, впрочем, происходил затык, и тогда он шел в Файн-холл, на математический факультет.
По Файн-холлу бродила довольно разношерстая публика, многие говорили с британским или европейским акцентом. Административно не все они относились к Файн-холлу, многие были из отдельного учреждения, называвшегося ИПИ — Института перспективных чего-то-там. Однако все сидели в одном здании и все разбирались в математике, так что Лоуренса это различие не волновало.
Очень немногие шарахались от Лоуренса, когда тот подходил с вопросами, остальные были готовы по крайней мере его выслушать. Например: он придумал, как решить сложную задачу формы зубца для шестеренки, которая при нормальном инженерном подходе требовала огромного количества вполне разумных, но неэстетичных приближений. Решение Лоуренса давало точный результат. Одна беда — квинтильону людей с логарифмическими линейками потребовался бы квинтильон лет, чтобы его вычислить. Лоуренс разрабатывал принципиально иной подход, который в случае успеха свел бы число людей и лет к триллиону и триллиону соответственно. К сожалению, ему не удавалось заинтересовать Файн-холл прозаическими шестеренками, пока внезапно он не познакомился с энергичным англичанином (чье имя немедленно позабыл), который сам ими занимался. Англичанин хотел построить — надо же! — механическую счетную машину, конкретно — для вычисления определенных значений римановской дзета-функции

где s — комплексное число.
Лоуренсу казалось, что дзета-функция ничем не лучше и не хуже других математических задач, пока новый знакомый не убедил его, что она жутко важная и лучшие математики мира бьются над ней уже несколько десятилетий. В результате они просидели до трех утра, разбирая Лоуренсову задачу про шестеренки. Наутро Лоуренс гордо показал решение преподавателю, который отмел его за полной непрактичностью и поставил Лоуренсу плохую отметку.
После нескольких встреч Лоуренс наконец запомнил, что англичанина зовут Ал что-то-там дальше. Поскольку Ал был страстным велосипедистом, они часто ездили кататься по окрестностям и, проезжая по Нью-Джерси, разговаривали о математике, особенно о машинах, которые избавили бы их от нудной работы.
Однако Ал думал на эту тему дольше, чем Лоуренс, и пришел к выводу, что вычислительные машины нужны не только для экономии сил. Он разрабатывал принципиально иной вычислительный механизм, который решал бы вообще любую арифметическую задачу, которую можно записать. С чисто логической точки зрения он уже придумал все, что нужно для этой (пока гипотетической) машины, только еще ее не построил. Лоуренс так понял, что в Кембридже (это в Англии, откуда Ал родом) по-настоящему строить машины считают ниже своего достоинства, да и в Файн-холле тоже. Ал был страшно рад встретить человека, который думает иначе.
Однажды Ал вежливо попросил Лоуренса называть его настоящим полным именем, то есть Алан, а не Ал. Лоуренс извинился и сказал, что очень постарается запомнить.
Недели через две, когда они сидели у лесного ручья под Делавэрским ущельем, Алан сделал Лоуренсу довольно странное предложение с участием мужских штучек. Потребовались долгие методологические разъяснения, которые Алан изложил, сильно краснея и запинаясь. Он был очень тактичен и несколько раз подчеркнул, что не все на свете этим увлекаются и ему это прекрасно известно.
Лоуренс решил, что он, вероятно, как раз из тех, кто не увлекается.
На Алана произвело сильное впечатление, что Лоуренс вообще задумался. Он попросил прощения, что завел этот разговор. Они сразу вернулись к беседе о вычислительных машинах, и на их дружбе это никак не сказалось. Однако на следующую прогулку — с ночевкой в Сосновой пустоши — Алан позвал еще одного приятеля, немца Руди что-то-там-дальше.
Отношения Алана с Руди производили впечатление более близких, во всяком случае — более многогранных, чем у Алана с Лоуренсом. Лоуренс заключил, что на идею со штучками все-таки нашелся желающий.
Это заставило его задуматься. С эволюционной точки зрения какой смысл в людях, которые не хотят иметь потомства? Для этого должна быть своя, хитрая причина.
Единственное, что он смог предположить: теперь истреблять/подавлять друг друга стараются не отдельные особи, а группы людей — сообщества, и в сообществе хватает места для тех, кто не желает размножаться, лишь бы они занимались чем-то полезным.
Алан, Руди и Лоуренс ехали на юг, ища Сосновую пустошь. Поселки попадались все реже, конские загоны сменились чахлыми деревцами, которые, казалось, тянутся до самой Флориды, загораживая обзор, но не защищая от ветра. «Интересно, где Сосновая пустошь?» — раза два спрашивал Лоуренс. Он даже остановился на заправке, чтобы задать тот же вопрос. Спутники начали над ним подтрунивать.
— Где Соснофая пустошь? — вопросил Руди.
— Я бы искал пустынное с виду место, где много сосен, — задумчиво ответил Алан.
Поскольку машин не было, они ехали трое в ряд, Алан — посередине.
— Лес, каким бы его представил себе Кафка, — сказал Руди.
К этому времени Лоуренс уже сообразил, что они едут по Сосновой пустоши. Вот только кто такой Кафка?
— Математик? — предположил он.
— Какая жуткая мысль, — заметил Руди.
— Он — писатель, — сказал Алан. — Лоуренс, не обижайся, пожалуйста, но можно спросить: ты вообще различаешь чужие фамилии? Кроме родственников и ближайших друзей?
Лоуренс, по всей видимости, захлопал глазами.
— Я пытаюсь понять: это все отсюда, — Алан протянул руку и костяшками пальцев постучал Лоуренса по голове, — или ты иногда берешь какие-то идеи у других?
— В детстве я один раз видел ангелов в церкви, в Виргинии, — ответил Лоуренс, — но, думаю, они были из моей головы.
Однако позже Алан сделал новый заход. Они добрались до знаменитой сторожевой башни и увидели, что вся достопримечательность — одинокая винтовая лестница в никуда, под ней — небольшая площадка, усеянная битыми бутылками. Палатку разбили у озера, полного бурых, липнущих к телу водорослей. Оставалось только пить шнапс и говорить о математике.
Алан сказал:
— Послушай, Бертран Рассел и еще один тип по фамилии Уайтхед написали «Principia Mathematica».
— Сейчас ты меня точно подкалываешь, — сказал Уотерхауз. — Даже я знаю, что «Principia Mathematica» написал сэр Исаак Ньютон.
— Ньютон написал другую книгу, которая тоже называлась «Principia Mathematica»* [В русском переводе книга Ньютона называется «Математические начала», а книга Рассела — «Основания математики».], хотя на самом деле она не про математику, а про то, что мы теперь назвали бы физикой.
— Тогда почему он назвал ее «Principia Mathematica»?
— Различие между физикой и математикой было нечетким во времена Ньютона...
— А может быть, и в наше фремя, — сказал Руди.
— ...и это прямо относится к тому, о чем я собираюсь говорить, — продолжал Алан. — Я про расселовские «Основания математики», в которых они с Уайтхедом начали абсолютно с пустого места и выстроили все — всю математику — на небольшом числе основных принципов. И вот почему я тебе это говорю, Лоуренс... Эй, Лоуренс! Проснись!
— М-м-м?
— Руди, возьми палку — да, эту — и следи за Лоуренсом. Когда глаза у него начнут вот так стекленеть, тыкай его в бок.
— Мы не в английской школе, тут так нельзя.
— Я слушаю, — сказал Лоуренс.
— Из «ОМ» следует абсолютно радикальная вещь — все в математике можно выразить определенной последовательностью символов.
— Лейбниц сказал это много раньше! — возмутился Руди.
— Ну, Лейбниц предложил символы, которые мы используем в дифференциальном исчислении, но...
— Я не про это!
— И он изобрел матрицы, но...
— И не про это тоже!
— И он немного занимался двоичной системой, но...
— Это софсем другое!
— Ладно, Руди, говори, о чем ты.
— Лейбниц изобрел базовый алфавит — записал набор символов для логических выражений.
— Ну, я не знал, что в сферу интересов герра Лейбница входила формальная логика, но...
— А как же! Он хотел сделать то же, что Рассел и Уайтхед, только не для одной математики, а для всего на сфете!
— Поскольку ты, Руди, похоже, единственный на планете знаешь об этом начинании Лейбница, можем ли мы допустить, что его затея не увенчалась успехом?
— Ты можешь допускать все, что тебе угодно, Алан, — ответил Руди, — но я — математик и ничего не допускаю.
Алан оскорбленно вздохнул и наградил Руди многозначительным взглядом, который, как догадывался Уотерхауз, означал «я тебе это припомню».
— Если мне позволят продолжить, — сказал он, — я вообще-то хотел, чтобы вы согласились вот с чем: все в математике можно выразить последовательностью символов, — он взял палку, которой надо было тыкать Лоуренса, и начал писать на земле что-то вроде + = 3) v1?, — и мне глубоко безразлично, будут это символы Рассела, или Лейбница, или гексаграммы И-Цзина.
— Лейбниц восхищался И-Цзином! — страстно воскликнул Руди.
— Помолчи пока про Лейбница, Руди. Мы с тобой едем в поезде, сидим в вагоне-ресторане, мило болтаем, а этот поезд со страшной силой тянут локомотивы «Бертран Рассел», «Риман», «Эйлер» и другие. А наш друг Лоуренс бежит рядом с поездом, пытаясь от нас не отстать — не обязательно потому, что мы умнее, просто он — деревенский, и у него нет билета. И я, Руди, просто высовываюсь в окошко и пытаюсь втащить его в гребаный поезд, чтобы мы втроем могли мило болтать о математике, не слушая все время, как он пыхтит и отдувается.
— Ладно, Алан.
— Если ты не будешь перебивать, я скоро закончу.
— Но есть еще локомотив по имени Лейбниц.
— Ты считаешь, что я не отдаю должного немцам? Внимание, сейчас я упомяну человека с немецкой фамилией.
— Кто же это? Фон Тьюринг? — съязвил Руди.
— Фон Тьюринг будет потом. Вообще-то я имел в виду Гёделя.
— Какой он немец! Он австрияк!
— Боюсь, это теперь одно и то же.
— Не я придумал аншлюс, и нечего на меня так смотреть. Я ненавижу Гитлера.
— Про Гёделя я слышал, — вставил Уотерхауз, чтобы охладить спор. — Но можно немножко назад?
— Конечно, Лоуренс.
— Зачем это надо? Ну то, что сделал Рассел? Что не так в математике? Я хочу сказать, два плюс два — четыре, верно?
Алан взял две бутылочные пробки и положил на землю.
— Два. Раз-два. Плюс... — Он положил рядом еще две. — Еще два. Раз-два. Равняется четырем. Раз-два-три-четыре.
— Что в этом плохого? — спросил Лоуренс.
— Однако, Лоуренс, когда ты на самом деле занимаешься математикой, абстрактно, ты ведь не считаешь пробки?
— Я вообще ничего не считаю.
Руди объявил:
— Очень современный взгляд.
— В смысле?
— Долгое время подразумевалось, — сказал Алан, — что математика — своего рода физика пробок. Что любую математическую операцию, которую ты выполняешь на бумаге, как бы ни была она сложна, можно свести — по крайней мере, в теории — к перекладыванию реального счетного материала вроде пробок в реальном мире.
— Нельзя же взять две целые одну десятую пробки.
— Ладно, ладно, пусть будут пробки для целых чисел, а для таких, как две целые одна десятая — физические меры, например длина этой палки. — Алан положил палку рядом с пробками.
— Как насчет «?»? Нельзя отпилить палку длиной ровно «?» дюймов.
— «?» — из геометрии. Та же история, — вставил Руди.
— Да, считалось, что Евклидова геометрия на самом деле своего рода физика, что его прямые и все такое описывают свойства физического мира. Но... знаешь Эйнштейна?
— Я не очень запоминаю фамилии.
— Седой, с большими усами.
— А, да, — мрачно ответил Лоуренс. — Я подходил к нему с вопросом про шестеренки. Он сказал, что опаздывает на встречу.
— Он придумал общую теорию относительности — своего рода практическое приложение, но не Евклидовой, а Римановой геометрии...
— Тот же Риман, что твоя дзета-функция?
— Тот же Риман, другое направление. Не уводи нас в сторону, Лоуренс...
— Риман показал, что существует много-много геометрий, которые, не являясь Евклидовыми, в то же время внутренне непротиворечивы, — объяснил Руди.
— Ладно, давайте снова к «ОМ», — сказал Лоуренс.
— Да! Рассел и Уайтхед. Итак, когда математики начали играть со всякими корнями из минус единицы и кватернионами, это было уже не то, что можно перевести в палки и пробки. И все же они по-прежнему получали верные результаты.
— По крайней мере внутренне непротиворечивые, — уточнил Руди.
— О'кей. Значит, математика — больше, чем физика пробок.
— Так нам представляется, Лоуренс, но возникает вопрос: математика по правде или это только игра в символы? Другими словами: мы открываем Истину или просто балуемся?
— Она должна быть по правде, потому что, когда прикладываешь ее к физике, она работает! Я слышал про общую теорию относительности и знаю, что она подтверждена экспериментами.
— Большая часть математики не поддается экспериментальной проверке, — сказал Руди.
— Вся идея в том, чтобы укрепить связь с физикой, — произнес Алан.
— И при этом не баловаться.
— И для этого написаны «ОМ»?
— Рассел и Уайтхед свели все математические понятия к таким жутко простым вещам, как множества. Отсюда они перешли к целым числам и так далее.
— Но как можно свести к множествам, например, число «?»?
— Нельзя, — сказал Алан, — зато его можно выразить цепочкой цифр: три запятая один четыре один пять девять и так далее.
— То есть через целые числа, — сказал Руди.
— Нечестно! Само «?» — не целое!
— Но можно вычислить цифры «?», одну за другой, по некой формуле. И можно написать формулу вроде такой!
Алан нацарапал на земле:

— Я использовал ряд Лейбница, чтобы утешить нашего друга. Видишь, Лоуренс? Это цепочка символов.
— Цепочку символов вижу, — нехотя согласился Лоуренс.
— Можно идти дальше? Гёдель, всего несколько лет назад, сказал: «Послушайте! Вы согласны, что все в математике просто цепочка символов? Тогда вот!» И показал, что любую цепочку символов — вроде этой — можно превратить в целые числа.
— Как?
— Ничего сложного, Лоуренс, простой шифр. Произвольный. Вместо уродливой сигмы напиши число 538 и так далее.
— Очень близко к баловству.
— Нет, нет! Потому что Гёдель расставил ловушку. В формулу можно подставлять числа, да?
— Конечно. Как 2х.
— Да. Можно подставить на место x любое число, и формула его удвоит. Но если математическую формулу вроде этой для вычисления числа «?» можно закодировать числом, то ее можно подставить в другую формулу. Формулу в формулу!
— И это все?
— Нет. Потом он доказал, очень простым способом, что если формулы можно применить к формулам, то мы вправе сказать: «данное утверждение недоказуемо». Что страшно удивило Гильберта и других, ожидавших противоположного результата.
— Этого твоего Гильберта ты уже упоминал?
— Нет, Лоуренс, он появился в нашем разговоре только сейчас.
— Кто он?
— Человек, который задает трудные вопросы. У него их целый список. Гёдель ответил на один.
— А фон Тьюринг — на другой, — добавил Руди.
— Это еще кто?
— Это я, — сказал Алан. — Только Руди шутит. В Тьюринге вообще-то нет приставки «фон».
— Сегодня ночью будет. — Руди как-то странно взглянул на Алана. Будь Лоуренс повзрослее, он бы определил этот взгляд как «страстный».
— Ладно, не томи. На какой вопрос Гильберта ты ответил?
— Entscheidungsproblem* [Проблема разрешимости (нем.).], — сказал Руди.
— То есть?
Алан объяснил:
— Гильберт хотел знать, можно ли в принципе доказать истинность или ложность любого высказывания.
— Но Гёдель все изменил, — произнес Руди.
— Верно. После Гёделя вопрос стал звучать так: «Можно ли определить, доказуемо или нет некое — любое — конкретное высказывание?» Другими словами, есть ли механический процесс, посредством которого мы в состоянии отсеять доказуемые утверждения от недоказуемых?
— «Механический процесс», Алан, это вообще-то метафора...
— Ладно тебе, Руди. Мы с Лоуренсом не боимся механики.
— Усек, — сказал Лоуренс.
— Что значит «усек»? — спросил Алан.
— Твоя машина — не для дзета-функций, а другая, о которой мы говорили...
— Она называется Универсальная Машина Тьюринга, — сказал Руди.
— Вся эта хреновина нужна, чтобы отделять недоказуемые утверждения от доказуемых, верно?
— Вот для чего я придумал ее основную идею, — сказал Алан. — Так что на вопрос Гильберта ответ уже есть. Теперь я хочу на самом деле ее построить, чтобы обыграть Руди в шахматы.
— Ты еще не сообщил бедному Лоуренсу ответ, — напомнил Руди.
— Лоуренс сообразит, — сказал Алан. — Ему будет чем себя развлечь.

Скоро стало ясно, что Алан на самом деле хотел сказать: «Будет чем себя развлечь, пока мы займемся друг другом». Лоуренс засунул блокнот под брючный ремень, взял велосипед, отъехал ярдов на двести к сторожевой башне, поднялся по лестнице на платформу и сел спиной к заходящему солнцу, примостив на коленях блокнот, чтобы свет падал на страницу.
Сперва он не мог собраться с мыслями, потом его отвлекли сполохи на северо-востоке. Он подумал было, что это отблески заката на облаках, но свет шел явно из одного места и к тому же мерцал. Тогда Лоуренс предположил, что это молния, однако свет был недостаточно голубой и резко менялся под воздействием (надо полагать) каких-то могучих событий за горизонтом. Когда солнце скрылось за противоположным краем мира, свет на горизонте Нью-Джерси превратился в ровное сияние, того же цвета, что от фонарика, когда под одеялом смотришь на него через пальцы.
Лоуренс спустился с башни, сел на велосипед и покатил через Сосновую пустошь. Вскоре он выехал на дорогу, которая шла примерно в нужную сторону. Большую часть времени молодой человек вообще ничего не видел, даже дорогу, но часа через два отблески света легли на щебенку под колесами, и ручейки между сосен превратились в горящие трещины.
Дорога свернула не в ту сторону, и Лоуренс поехал напрямик через лес. Теперь было совсем близко, и он различал свет за редким сосняком — черные тощие стволы казались обгорелыми палками. Начался песок, сырой и плотный, а у велосипеда были толстые шины. Один раз пришлось остановиться и перебросить велосипед через колючую проволоку. За сосняком пошел совершенно ровный белый песок с кустиками аммофилы, и тут же путника ослепила низкая ровная стена огня на горизонте размером примерно с полную луну, когда та садится в море. Огонь был такой яркий, что ничего другого Лоуренс уже не видел и несколько раз въезжал в промоины. После этого он старался не смотреть прямо на огонь, тем более что глядеть по сторонам тоже было интересно. На плоской песчаной равнине высились циклопические постройки, грубые творения фараонов, а на обширных пространствах между ними — далеко разнесенные исполинские гномоны триангулированной стали, внутренние скелеты пирамид. Циферблат самых высоких солнечных часов очерчивали круговые рельсы диаметром несколько сот футов: две серебряные дуги бежали по блеклой земле, разрываясь там, где указывала время черная тень башни. Лоуренс проезжал здания поменьше; рядом с ними стояли овальные цистерны. Из клапанов наверху цистерн с шипением выходил пар, но не поднимался вверх, а стекал по стенкам и расползался по земле, кутая солончаковую траву в серебряные бушлаты. Тысяча матросов в белом стояли оцеплением вокруг длинного пламени. Один из них поднял руку и помахал Лоуренсу — остановись, мол. Лоуренс притормозил и уперся ногой в песок. Они с матросом некоторое время друг друга разглядывали, потом Лоуренс, не придумав ничего лучшего, сказал: «Я тоже из ВМФ». Матрос, видимо, принял какое-то решение. Он отсалютовал Лоуренсу и указал на маленькое строение сбоку от пламени.
На фоне зарева строение казалось глухой стеной, однако порой голубая вспышка магнезии выхватывала из темноты его окна, прямоугольные молнии, многократно отраженные в ночи. Лоуренс снова принялся крутить педали и поехал мимо строения, огибая толпу фетровых шляп, тычущих в блокноты солидными авторучками, фотографов с их огромными хромированными красавцами, ряды спящих, укрытых с головой простынями, потного человека с набриолиненными волосами, который мелом писал на черной доске немецкие фамилии. Наконец он объехал здание и почуял горячий запах масла, почувствовал жар на лице и увидел иссушенную, скорченную траву.
Ему предстал земной шар — не в живой коже континентов и океанов, а только голый скелет: взорванные меридианы стягивались к ядру оранжевого пламени. На фоне огня они казались тонкими и четкими, как чертеж, однако когда Лоуренс подъехал ближе, начала прорисовываться умная система шпангоутов и стрингеров, полая, как птичья кость. По мере удаления от полюсов они рано или поздно начинали отклоняться от курса, или гнулись, или просто ломались и висели в огне, дрожа, как сухие стебли. Идеальную геометрию нарушали также паутина тросов, сплетение электрических проводов. Лоуренс едва не наехал на разбитую бутылку и решил дальше идти пешком, чтобы поберечь шины. Он положил велосипед передним колесом на алюминиевую вазу, словно выточенную на токарном станке, — из нее свешивалось несколько обугленных роз. Трое матросов сцепили руки наподобие трона и несли человекоподобный кусок угля в чистейшем асбестовом одеянии. Их ботинки задевали разветвленную сеть канатов, тросов и проволоки, вызывая движение травы и песка в десятках ярдов впереди, справа, сбоку. Лоуренс начал очень осторожно переставлять ноги — сначала одну, потом другую, — стараясь проникнуться величием того, что видит. Из песка торчало нечто вроде ракеты, увенчанное зонтиком гнутых пропеллеров. Дюралевые стойки и трапы разлетелись на мили. На земле валялся раскрытый чемодан, и в нем, как в витрине провинциальной лавки, пара дамских туфель; рядом меню, обугленное в овал, дальше — покореженные стенные панели, как будто с неба рухнула целая комната. На одной стене была огромная карта мира, где от Берлина разбегались круги к далеким и близким городам, на другой, фотографической, знаменитый толстый немец улыбался среди цветов на фоне новехонького цеппелина.
Через некоторое время Лоуренс перестал видеть что-нибудь новое, сел на велосипед и поехал к Сосновой пустоши, но заблудился в темноте и добрался до сторожевой башни уже после рассвета. Впрочем, он ничуть не горевал, что сбился с дороги, потому что думал про машину Тьюринга. В конце концов он все-таки добрался до озера, где стояла палатка. Спокойная гладь алела в лучах рассвета, как лужа крови. Алан Матисон Тьюринг и Рудольф фон Хакльгебер спали на берегу, сложившись, как ложки, еще немного грязные после ночного купания. Пока Лоуренс разводил костерок и готовил чай, они проснулись.
— Решил задачку? — спросил Алан.
— Ты можешь превратить свою Универсальную Машину Тьюринга в любую машину, меняя регистровки.
— Что меняя?
— Прости, Алан. Я думаю о твоей УМТ как о своего рода органе.
— А.
— После этого машина может выполнять любые вычисления, какие тебе угодно, лишь бы лента была достаточно длинной. Но, черт возьми, Алан, сделать такую длинную ленту, на которой можно было бы писать и стирать, — жуткая морока. Машина Атанасова работала только до определенного размера, и тебе придется...
— Речь о другом, — мягко сказал Алан.
— Ладно, хорошо. Если у тебя есть такая машина, то каждую конкретную комбинацию регистров можно обозначить числом — цепочкой символов. А лента, которую ты в нее запускаешь, чтобы начать вычисление, — другая цепочка символов. Так что это снова Гёделево доказательство: если любую возможную комбинацию регистров и данных на ленте можно представить в виде цепочки чисел, значит, ты можешь поместить все возможные цепочки в большую таблицу, применить к ней Канторов диагональный процесс, и ответ: да, должны быть некоторые числа, которые нельзя пересчитать.
— A Entscheidungsproblem? — напомнил Руди.
— Доказать или опровергнуть формулу — после того, как ты зашифровал ее числом — значит просто рассчитать это число. Значит, ответ — нет! Некоторые формулы нельзя доказать или опровергнуть механическим процессом! Выходит, не так уж плохо быть человеком!
До этих слов Алан казался довольным, потом его лицо вытянулось.
— Ну вот, теперь ты делаешь непрошеные допущения.
— Не слушай его, Лоуренс! — сказал Руди. — Сейчас он заявит, что наш мозг — машина Тьюринга.
— Спасибо, Руди, — спокойно ответил Алан. — Лоуренс, я утверждаю, что наш мозг — машина Тьюринга.
— Но ты доказал, что есть целый ряд формул, с которыми машина Тьюринга не справляется!
— И ты это доказал, Лоуренс.
— А тебе не кажется, что мы можем то, чего не может машина Тьюринга?
— Гёдель с тобой согласен, Лоуренс, — вставил Руди, — и Харди тоже.
— Приведите пример, — попросил Алан.
— Невычислимой функции, с которой человек справится, а машина Тьюринга — нет?
— Да. Только не надо сентиментальной чепухи про творчество. Уверен, Универсальная Машина Тьюринга способна демонстрировать поведение, которое мы воспримем как творческое.
— Ну, не знаю... Буду думать.
Позже, когда они ехали к Принстону, Лоуренс спросил:
— Как насчет снов?
— Вроде твоих ангелов в церкви?
— Примерно.
— Просто шум в нейронах, Лоуренс.
— А еще мне вчера ночью приснилось, что горел цеппелин*. [Лоуренс стал свидетелем гибели «Гинденбурга». Этот цеппелин длиной 245 метров, символ величия фашистской Германии, совершал регулярные рейсы между Германией и Соединенными Штатами. 6 мая 1937 года при посадке в Нью-Джерси он загорелся. Погибли 36 человек.]

Вскоре защитившись и уехав в Англию, Алан прислал Лоуренсу пару писем. В последнем он сообщал просто, что больше не сможет писать «о серьезном», и просил не принимать это на свой счет. Лоуренс сразу догадался, что сообщество, к которому принадлежит Алан, приставило его к полезному делу — скорее всего вычислять, как бы их не съели заживо соседи. Интересно, какое применение найдет Америка ему?
Он вернулся в Айовский Государственный, подумывая перевестись на математический факультет, однако делать этого не стал. Все, с кем он советовался, говорили, что математика, как и ремонт органов, — дело замечательное, но надо подумать и о хлебе насущном. Лоуренс остался на инженерном и учился все хуже и хуже, пока в середине последнего курса деканат не порекомендовал ему заняться чем-нибудь полезным, скажем, ремонтом крыш. Лоуренс вылетел из колледжа в гостеприимные объятия ВМФ.

1 Следующая страница


Криптономикон (часть 1) 2

Ему дали тест на проверку умственных способностей. Первая задача по математике была такой: порт Смит на 100 миль выше по течению, чем порт Джонс. Скорость течения — 5 миль в час. Скорость лодки — 10 миль в час. За какое время лодка доберется из порта Смита в порт Джонс? За какое время она проделает обратный путь?
Лоуренс тут же понял, что задачка с подвохом. Нужно быть полным идиотом, чтобы предположить, будто течение увеличивает и уменьшает скорость лодки на 5 миль в час. Ясно, что 5 миль в час — всего лишь средняя скорость. Течение быстрее в середине реки, медленнее — у берегов; более сложные вариации следует ожидать на излучинах реки. По сути это вопрос гидродинамики, который решается с помощью хорошо известных дифференциальных уравнений. Лоуренс нырнул в задачку и быстро (или так ему казалось) исписал вычислениями десять листов. По ходу он осознал, что одна его посылка вместе с упрощенным уравнением Навье-Стокса приводит к очень занятной семейке частных дифференциальных уравнений. Он не успел очухаться, как доказал теорему. Если это не подтверждает его умственный уровень, то что тогда подтверждает?
Тут прозвенел звонок и собрали работы. Лоуренс сумел спасти черновик. Он отнес листок в казарму, перепечатал на машинке и отправил в Принстон одному из наиболее демократичных преподавателей математики, который тут же договорился о публикации в парижском журнале.
Лоуренс получил два свежих бесплатных оттиска несколько месяцев спустя, при раздаче почты на борту линкора «Невада». На корабле был оркестр, и Лоуренсу поручили играть в нем на глокеншпиле: тест показал, что ни на что более умное он не способен.
Почта прибыла как раз вовремя — еще чуть-чуть и было бы поздно. «Невада» вместе с некоторыми другими линкорами до сих пор базировалась в Калифорнии, но как раз сейчас они выдвигались на Гавайи, в какой-то Перл-Харбор, показать япошкам, кто главнее.
Лоуренс так и не понял, чего хочет в жизни; ясно, что служить ксилофонистом на военном корабле на Гавайях в мирное время — занятие далеко не худшее. Самое трудное было иногда сидеть или маршировать на страшной жаре да порой сносить фальшивые ноты товарищей. Оставалась куча свободного времени, которое Лоуренс тратил на разработку новых теорем в области теории информации. Они с Аланом и Руди набросали общий план того, что надо доказать или опровергнуть. Он часто думал, что делают Алан и Руди в Англии и Германии, но написать им не мог, поэтому работал сам по себе. Когда он не играл на глокеншпиле и не доказывал теоремы, появлялись бары и танцы. Уотерхауз опробовал свою штучку в действии, подцепил триппер, вылечился* [1940 год был удачен для экспериментов с венерическими заболеваниями — как раз в это время появился пенициллин для инъекций.], стал покупать презервативы — как и все моряки. Так трехлетние дети, потыкав в ухо карандашом, убеждаются, что это больно, и после не тычут.
Первый год пролетел для Лоуренса почти мгновенно. Нигде нет такого солнца и ленивого покоя, как на Гавайях.

NOVUS ORDO SECLORUM

[NOVUS ORDO SECLORUM – «Новый порядок веков» (лат.). Как и другие девизы на однодолларовой купюре, эти слова взяты из Вергилия (четвертая эклога «Буколик», где предсказывается наступление золотого века).]

— Филиппинцы — добрые, мягкие, отзывчивые люди, — говорит Ави, — и это хорошо, потому что многие из них носят под одеждой оружие.
Рэнди в Токийском аэропорту, бредет по трапу с медлительностью, которая бесит остальных пассажиров; все они провели последние полдня в алюминиевой трубе, закачанной керосином. Чемоданы на колесиках грохочут по специально сконструированному — в мелких бугорках, чтобы не скользил — полу и толкают Рэнди под колени. Рэнди держит возле уха новый мобильник. По идее он должен работать везде, кроме Соединенных Штатов. Это первый шанс его опробовать.
— Тебя отлично слышно, — говорит Ави. — Как полет?
— Нормально, — отвечает Рэнди. — На видеоэкране показывали анимированные карты.
Ави вздыхает.
— Теперь на всех авиалиниях такие.
— Между Сан-Франциско и Токио — только остров Мидуэй.
— И что?
— Он висит перед глазами час за часом. МИДУЭЙ. Я думал, рехнусь.
Рэнди заходит в посадочный сектор на Манилу и останавливается, засмотревшись на двухметровый телевизор с логотипом крупнейшей японской компании по производству бытовой электроники. На экране чудаковатый мультипликационный профессор и его очаровательный песик отмечают галочками все три пути передачи вируса СПИД.
— У меня для тебя кое-что есть, — говорит Рэнди.
— Валяй.
Рэнди смотрит на ладонь, где шариковой ручкой записана последовательность букв и цифр.
— AF 10 06 Е9 99 ВА 11 07 64 С1 89 ЕЗ 40 8С 72 55.
— Готово, — говорит Ави. — Это из «Ордо»?
— Да. Ключ я послал тебе мейлом из Сан-Франциско.
— Квартирный вопрос по-прежнему в стадии разрешения, — сообщает Ави, — так что я просто забронировал тебе номер в гостинице «Манила».
— Что значит «в стадии разрешения»?
— Филиппины — одна из постиспанских стран, в которых нет четкой грани между бизнесом и личными отношениями. Чтобы получить квартиру, нужно как минимум жениться на девушке из семьи, чью фамилию носит одна из главных улиц Манилы.
Рэнди занимает место в зале ожидания. Сотрудники аэропорта в невероятных фуражках вылавливают глазами филиппинцев с лишней ручной кладью, заставляют их заполнить бирки и сдать вещи. Филиппинцы закатывают глаза и с тоской смотрят в окно. Однако большая часть ожидающих — японцы, бизнесмены или туристы. Они смотрят поучительный видеоролик о том, как подвергнуться ограблению в чужой стране.
— Ух ты! — говорит Рэнди, глядя в окно. — Еще один 747-й на Манилу.
— В Азии ни одна уважающая себя компания не станет мараться обо что-нибудь меньше 747-го, — буркает Ави. — Если тебя попытаются запихнуть в 737-й или, Боже упаси, в «Эйрбас», беги, не останавливаясь, от посадочной стойки и звони мне на пейджер, чтобы я эвакуировал тебя вертолетом.
Рэнди смеется.
Ави продолжает:
— Теперь слушай. Гостиница очень старая, очень роскошная, но она у черта на куличках.
— Зачем строить роскошный отель у черта на куличках?
— Место историческое — у моря, на самом краю Интрамурос.
Рэнди хватает университетского испанского, чтобы перевести: «В стенах».
— В 1945-м японцы стерли Интрамурос с лица земли, — говорит Ави. — До основания. Все бизнес-отели и офисные здания — в новом районе Макати, гораздо ближе к аэропорту.
— А ты хочешь устроить наш офис в Интрамурос.
— Как ты угадал? — Ави слегка задет. Он гордится своей непредсказуемостью.
— Обычно я интуицией не блещу, — извиняется Рэнди, — но я тринадцать часов провел в самолете. Мои мозги были вывернуты наизнанку и повешены на просушку.
Ави начинает сыпать заготовленными оправданиями: в Интрамурос офисные площади дешевле. Ближе к министерствам. Макати, суперсовременный деловой район, изолирован от реальных Филиппин.
Рэнди пропускает все это мимо ушей.
— Ты хочешь работать в Интрамурос, потому что его стерли с лица земли, а ты одержим Холокостом, — тихо и без всякой подначки говорит наконец он.
— Да. А что? — отвечает Ави.

* * *

Рэнди смотрит в иллюминатор «Боинга-747» рейсом на Манилу, потягивает слабоалкогольный японский напиток, изготовленный из пчел (по крайней мере они нарисованы на банке), и жует что-то непонятное (стюардесса сказала: «японская еда»). Небо и океан одного цвета — синие до ломоты в зубах. Самолет летит так высоко, что сверху и снизу одинаковое бурление дождевых облаков. Облака вырастают над горячим Тихим океаном, будто внизу беспрерывно рвутся линкоры. Скорость и мощь, с которыми они набухают, пугающи. Облака причудливы и многообразны, как глубоководные организмы, и каждое, по убеждению Рэнди, не менее опасно для самолета, чем отравленный бамбуковый кол — для босоногого пешехода. Он вздрагивает, заметив на крыле красно-оранжевый круг — японскую «фрикадельку». Как будто попал в старый военный фильм.
Он включает ноутбук. Во «Входящих» скопилась уйма шифрованных сообщений от Ави. Это крохотные файлики, которые Ави в последние три дня кидал всякий раз, как у него возникала очередная мысль. Ясно, что у Ави портативное устройство, которое разговаривает с Интернетом по радио. Рэнди запускает программу, которая формально называется «Новус Ордо Секлорум», но которую все для краткости зовут просто «Ордо». Это довольно натужный каламбур, основанный на том, что задача «Ордо» как криптографической программы — составлять биты в Новом Порядке, а излишне любопытному правительству потребуются Века, чтобы их расшифровать. На экране возникает растровое изображение Великой пирамиды, на ее вершине медленно материализуется всевидящее око.
«Ордо» можно использовать двумя способами. Самое простое — расшифровать сообщения, записать на жесткий диск открытый текст и читать, когда вздумается. Проблема (если вы — параноик) в том, что любой, кто доберется до жесткого диска, сможет прочитать эти файлы. Манильские таможенники решат проверить комп на предмет детской порнографии. Или, обалдев от смены часовых поясов, Рэнди забудет ноутбук в такси. Поэтому он запускает «Ордо» в текущем режиме, когда открытый текст появляется в окне, а при закрытии окна стирается из памяти и с жесткого диска.
Тема первого сообщения от Ави: «Принцип 1».

Мы ищем, где работает математика. Что это значит? Что рост насел. круто пойдет вверх — это можно проследить просто по графикам, — а среднедушевой доход взлетит, как в Японии, на Тайване, в Сингапуре. Умножаем одно на другое и получаем экспоненциальный рост, на котором мы заработаем охуенные деньги еще до того, как перевалим сороковник.

Имеется в виду двухлетней давности разговор между Рэнди и Ави, когда Ави и впрямь рассчитал некое численное выражение для «охуенных денег». Это не постоянная величина, скорее ячейка в таблице, связанная с произвольным количеством постоянно колеблющихся экономических факторов. Иногда, работая на компьютере, Ави запускал таблицу в отдельном окошке в углу, чтобы постоянно видеть текущее значение «охуенных денег».
Второе сообщение, отправленное двумя часами позже, озаглавлено: «Принцип 2».

Два: выработать технологию, в которой никто не сможет с нами конкурировать. На данный момент это сетевые дела. В сетевых делах мы размазываем весь мир по стенке. Это даже не смешно.

На следующий день Ави отправил сообщение, озаглавленное просто «Еще». Наверное, забыл, сколько принципов уже сформулировал.

Еще принцип: на этот раз мы удерживаем контроль над корпорацией. То есть оставляем себе по меньшей мере 50% акций. Как можно меньше внешних вливаний, пока мы не наберем стоимость.

«Меня можешь не убеждать», — бормочет про себя Рэнди, читая дальше.

Это определяет характер бизнеса, которым мы займемся. Забудь про все, что требует больших начальных вложений.

Лусон — горы в черно-зеленых джунглях с прожилками рек, которые с тем же успехом могут оказаться грязевыми потоками. Там, где матросское сукно океана находит на солдатское сукно берега, вода пронзительно-бирюзовая, как в бассейне. Дальше к югу горы возделаны, полосы ярко-красной почвы — как свежие надрезы. Однако большая часть склонов покрыта растительностью, вроде тех зеленых катышков, которыми на моделях железных дорог покрывают холмы из папье-маше; на огромных пространствах — никаких признаков, что человечество существует. Ближе к Маниле склоны вырублены, усеяны постройками, располосованы высоковольтными линиями. Рисовые поля — как лужицы. Поселки лепятся вокруг центрального ядра — крестовой церкви под хорошей крышей.
Картина теряет четкость — самолет входит в слой смога над городом. Он запотевает, как исполинский стакан чая со льдом. Вода сбегает ручьями, собирается в пазах, брызжет с выдвинутых закрылков.
Вираж — и они над Манильским заливом в бесконечных ярко-алых разводах. Вода цветет. Нефтяные танкеры тащат за собой длинные радужные хвосты. Каждая бухточка забита узкими малайскими лодками, похожими на ярко раскрашенные доски для серфинга.
И вот уже посадочная полоса МАНА — Международного аэропорта Ниной Акино. Охранники и полицейские различного ранга с винтовками М-16 или помповыми ружьями, в бурнусах из носовых платков, пришлепленных к голове американскими бейсболками. Человек в ослепительно белой форме над гофрированным зевом трапа простирает руки с флуоресцентными оранжевыми жезлами, словно Христос, благословляющий грешный мир. Грозовой воздух тропического пекла начинает сочиться через вентиляцию в самолет. Все мокнет и обвисает.
Рэнди в Маниле. Он достает паспорт из нагрудного кармана рубашки. Там написано: РЭНДАЛЛ ЛОУРЕНС УОТЕРХАУЗ.

Вот как возникла корпорация «Эпифит».
— Приготовься вздрогнуть! — сказал Ави.
Номер высветился на пейджере, когда Рэнди сидел в кабаке у моря с друзьями своей девушки. В таком месте, где каждый день распечатывают на лазерном принтере новое меню (на имитации пергамента, 100% вторсырья), где люминесцентные соусы — словно тонкие линии осциллограмм, где подают экзотические продукты, ограненные наподобие драгоценных камней и уложенные в архитектурные шедевры. Весь обед Рэнди боролся с желанием, пригласить кого-нибудь из друзей Чарлин (любого, без разницы) на улицу и дать ему в морду.
Он взглянул на пейджер, ожидая увидеть привычный телефон компьютерного центра «Трех сестер». Номер Ави шарахнул его по мозгам, как число 666 — религиозного фанатика.
Через пятнадцать секунд Рэнди был на улице и засовывал карточку в телефон-автомат, словно убийца, проводящий опасной бритвой по шее пузатого политика.
— Повеления исходят свыше, — объявил Ави. — Сегодня они исходят от меня.
— Чего ты хочешь? — спросил Рэнди холодно, почти враждебно, чтобы скрыть сосущее волнение.
— Возьми билет до Манилы, — ответил Ави.
— Я должен прежде поговорить с Чарлин, — сказал Рэнди.
— Ты сам в это не веришь, — заметил Ави.
— Мы с Чарлин живем много лет...
— Десять. Ты на ней не женился. Иди за билетом.
(Через семьдесят два часа он будет в Маниле смотреть на Однотонную флейту.)
— Вся Азия гадает, когда Филиппины вылезут из дерьма, — сказал Ави. — Это произойдет еще до конца девяностых.
(Однотонная флейта — первое, что вы видите, пройдя паспортный контроль.)
— Меня осенило, когда я сошел с самолета в Международном аэропорту Ниной Акино. — Последние два слова слились у Ави в одно резкое восклицание. — Ты знаешь, что у них там отдельные коридоры?
— Догадываюсь, — ответил Рэнди. Параллелепипед слабообжаренного тунца сделал кульбит у него в желудке. Возникло извращенное желание купить двойной стаканчик мороженого. Рэнди путешествовал гораздо меньше, чем Ави, и довольно смутно представлял, о каких коридорах речь.
— Ну, знаешь, один для своих граждан, один для иностранцев. Может быть, еще один для дипломатов.
(Сейчас, дожидаясь, пока ему проштампуют паспорт, Рэнди видит все это своими глазами. В кои-то веки он не досадует на задержку. Соседний коридор — для ЗКР, и Рэнди их изучает. Это будущий рынок корпорации «Эпифит». По большей части молодые девушки, многие одеты по моде, но все равно с некоторой скромностью, привитой в католическом пансионе. Они устали от перелета, устали от долгого ожидания, они сутулятся, потом резко выпрямляются и вскидывают точеный подбородок, словно невидимая монахиня идет вдоль очереди, хлопая их линейкой по наманикюренным пальцам.)
Однако семьдесят два часа назад он толком не понял, о чем Ави говорит, поэтому сказал только:
— Да, видел.
— В Маниле отдельный коридор для возвращающихся ЗКР!
— ЗКР?
— Заморских контрактных работников. Филиппинцы устраиваются за рубежом, потому что сами Филиппины никак не вылезут из дерьма. Горничными и няньками в Саудовской Аравии, анестезиологами и медсестрами в Штатах, певичками в Гонконге, проститутками в Бангкоке.
— Проститутками в Бангкоке? — Там-то уж Рэнди был и слегка ошалел от мысли, что кто-то экспортирует шлюх в Таиланд.
— Филиппинки — самые красивые. — Ави понизил голос. — В них есть злость, поэтому они куда привлекательнее для заезжего бизнесмена-мазохиста, чем улыбающиеся тайские телки. — Оба понимали, что это полная лажа: Ави человек семейный и своего опыта в данной области не имеет. Рэнди не стал ему этим тыкать; умение Ави экспромтом гнать лажу — главный залог того, что они сделают охуенные деньги.
(Теперь, когда он здесь, есть соблазн угадать, кто из девушек в коридоре ЗКР — путаны. Однако Рэнди понимает, что все равно ошибется, поэтому расправляет плечи и направляется к желтой полосе.
На пути от паспортного контроля к ограждению правительство расставило стеклянные витрины с экспонатами, демонстрирующими величие домагеллановой культуры Филиппин. В первой из них piece de resistance*. [Основное блюдо (фр.).] резной деревянный инструмент с длинной аннотацией на тагальском. Ниже, мелкими буквами, английский перевод: «Однотонная флейта».)
— Филиппины природно ограждены, — продолжал Ави. — Знаешь, какая это редкость? Когда ты видишь природно огражденную среду, Рэнди, ты ныряешь в нее, как голодный хорек в трубу с сырым мясом.
Несколько слов про Ави. Семья его отца чудом выбралась из Праги: типичные центральноевропейские евреи, поистине уникальные только тем, что остались живы. Однако предки его матери были невероятно странные криптоевреи из Нью-Мексико; три сотни лет они жили в прерии, скрывались от иезуитов, стреляли гремучих змей и ели дурман вонючий; они выглядели, как индейцы, и разговаривали, как ковбои. Соответственно в отношениях с другими людьми Ави постоянно вибрировал, как струна. По большей части он держался очень вежливо и корректно, чем производил большое впечатление на бизнесменов — особенно японских, — но периодически взрывался, как будто ему прищемили хвост. Рэнди скоро к этому приспособился, вот почему Ави звонил ему в такие минуты.
— Успокойся! — сказал Рэнди, глядя, как мимо проехала на роликах загорелая девушка. — Природно огражденные, говоришь?
— Покуда Филиппины не вылезут из дерьма, у них будет куча ЗКР. Все они хотят общаться с родственниками. У филиппинцев очень прочные семейные узы. По сравнению с ними евреи — замкнутые эгоисты.
— О’кей. Ты лучше меня знаешь и тех, и других.
— Они сентиментальны и любвеобильны настолько, что легко вызывают у нас смех.
— Не ощетинивайся, — сказал Рэнди. — Я не собираюсь смеяться.
— Будешь смеяться, когда услышишь, как они по радио передают музыкальные приветы родным. Однако, если честно, в этом смысле нам есть чему у них поучиться.
— Сейчас ты близок к тому, чтобы читать мне проповедь.
— Прости, — совершенно искренне ответил Ави. Его жена вес четыре года их брака была почти беспрерывно беременна. Он с каждым днем становился все религиознее и ни в одном разговоре не мог обойти Холокост. Рэнди был холостяк на грани разрыва с подружкой.
— Я тебе верю. Ничего, если я возьму билет бизнес-класса?
Ави его не услышал, и Рэнди счел, что это означает «да».
— Покуда дела обстоят так, будет огромный рынок для пинойграмм.
— Пинойграмм?
— Бога ради, не произноси вслух!.. Пока мы говорим, я заполняю заявку на торговую марку. — Рэнди слышал стрекот на заднем плане — клавиши стучали с такой быстротой, словно Ави просто держит клавиатуру в бледных худых руках и трясет ее что есть мочи. — А если филиппинская экономика встанет на ноги, то мы увидим взрывной рост телекоммуникаций, как и в других брас.
— Брас?
— Бэ-эр-а-эс. Быстроразвивающихся азиатских странах. Так или иначе, мы в выигрыше.
— Я так понял, ты затеваешь что-то связанное с телекоммуникациями?
— В яблочко. — На заднем плане закашлялся и заплакал ребенок. — Мне надо идти, — сказал Ави. — У Шломо опять обострилась астма. Запиши отпечаток.
— Отпечаток?
— Моего ключа. Для электронной почты.
— «Ордо»?
— Ага.
Рэнди вытащил шариковую ручку и, не найдя бумаги, подставил ладонь.
— Пишу.
— 67 81 А4 АЕ FF 40 25 9В 43 0Е 29 8D 56 60 Е3 2F, — и Ави повесил трубку.
Рэнди вернулся в ресторан. По пути к столику он попросил официанта принести полбутылки хорошего красного вина. Чарлин услышала и нахмурилась. Рэнди по-прежнему думал про врожденную злость и не увидел в ее лице ничего похожего, только готовность поучать, как у всей их компании. Господи! Пора сваливать из Калифорнии, осознал он.

ВОДОРОСЛЬ

Держит ребенка —
Глаза светлее огня.
Оркестр — льдышки слез.

Четвертый полк морской пехоты марширует под музыку Джона Филипа Сузы, что для каждого морпеха должно быть второй натурой. Однако четвертый полк слишком долго стоял в Шанхае (а это не чертоги Монтесумы и не пляжи Триполи* [Суза Джон Филип (1854–1932), американский композитор, автор огромного количества маршей, в том числе официального марша морских пехотинцев США «Semper Fidelis» («Bepeн всегда!»), а также множества песен и оперетт. «От чертогов Монтесумы и до пляжей Триполи» — официальный гимн корпуса морской пехоты США; музыка Оффенбаха, автор слов неизвестен.]) — дольше, чем морпехам стоит оставаться на одном месте, и Бобби уже видел, как его сержант, некто Фрик, блюет от опиумной ломки.
Шафто идет рядом со взводом, якобы присматривая за ребятами, а на самом деле смотрит на Шанхай.
Шанхай смотрит на него и по большей части рукоплещет стоя. Конечно, есть уличные мальчишки, для которых вопрос чести — показать, что они не боятся морской пехоты. Эти корчат рожи, свистят, пускают шутихи, что тоже действует на нервы. Европейцы аплодируют. Целая шеренга русских танцовщиц из балета Дельмонте, все в пачках, посылают воздушные поцелуи. Большинство китайцев стоят с каменными лицами; как подозревает Бобби Шафто, это значит, что они до смерти перепуганы.
Хуже всего женщины с наполовину белыми детьми. Некоторые из них в истерике и, невзирая на приклады, бросаются на плотные шеренги морских пехотинцев. Однако большая часть стоит неподвижно, со светлоглазыми детьми на руках, высматривая в рядах и шеренгах виновную сторону. Все они слышали, что было в Нанкине, когда его заняли японцы, и понимают: вполне вероятно, что очень скоро от детей и от них самих останется лишь неприятное воспоминание в голове какого-то бойца американской морской пехоты.
Это действует на Шафто: он охотился на оленей в Висконсине и видел, как те ковыляют по снегу, истекая кровью. Он видел, как человек погиб во время учений на Пэррис-Айленд. Он видел груды тел в Янцзы после Инцидента на мосту Марко Поло, видел, как беженцы из Нанкина умирают от голода в шанхайских канавах. Он сам убивал людей, штурмовавших канонерку, которую его поставили защищать. И все же он не видел и не увидит ничего страшнее, чем окаменелые китаянки с белыми детьми на руках, не мигающие, даже когда рядом рвутся шутихи.
Так думает Шафто, пока не переводит взгляд на морпехов, которые смотрят в толпу и видят собственные лица, младенчески-пухлые, в грязных потеках слез. Для кого-то это шутка. Однако немало морпехов вышли сегодня из казарм здоровыми крепкими людьми и по пути к набережной лишились рассудка. Они этого не показывают, но Шафто видит: что-то сломалось.
Лучшие люди полка — в раздрае. Даже те, кто, как Шафто, не завел себе китаянок, оставляют позади многое: дома с горничными, чистильщиками обуви и кули, женщин и опиум практически задарма. Они не знают, куда их везут, но ясно, что их двадцать один доллар в месяц туда не доедет. Будут казармы, придется самим чистить себе ботинки. Они отрезаны от мира, которого больше не увидят, мира, в котором были королями. Теперь они снова морская пехота. Это по душе Шафто, которому нравится быть морпехом. Хотя многие в МПФ поседели, так и не полюбив службу.
Виновные ныряют в кубрик. Шафто остается на палубе. Канонерка отваливает от Банда и направляется к эсминцу «Августа» в фарватере.
Банд забит зеваками. На фоне пестрой толпы резко выделяется однотонная группа в военной форме. Японские солдаты пришли саркастически проститься с коллегами-янки. Шафто легко находит глазами самого высокого и плечистого. Гото Денго машет ему рукой.
Шафто снимает каску и тоже машет. Потом, под влиянием порыва — просто из куража — бросает каску в голову Гото Денго. Каска летит чуть в сторону, и Гото Денго сбивает с ног десяток товарищей, чтобы ее поймать. Судя по всему, им лестно и забавно быть сбитыми с ног Гото Денго.
Через двадцать секунд над живым космосом Банда проносится комета. Она подпрыгивает на деревянной палубе. Классный бросок. Гото Денго рукой сопровождает подачу. Это камень, обвязанный белой лентой. Шафто подбегает и наклоняется. Лента — та самая повязка в тысячу стежков (вроде бы он снимал такие с бесчувственных японцев, но ни разу не удосужился сосчитать стежки), какие самураи носят на счастье: в середине красный кружок — «фрикаделька», по сторонам что-то написано по-японски. Шафто отвязывает ленту от камня и вдруг понимает: это не камень, а граната! Однако добрый старый Гото Денго просто пошутил: чека не выдернута. Славный подарок на память.

Свое первое хайку (декабрь 1940) Шафто кое-как соорудил из Заповеди Морпеха:

Моя винтовка.
Таких много, но эта
Винтовка моя.

Хайку написано при следующих обстоятельствах. Шафто и остальной четвертый полк расквартировали в Шанхае, чтобы охранять Международное поселение и патрулировать Янцзы. Его взвод только что вернулся из Последнего Патруля — тысячемильной разведки боем через то, что осталось от Нанкина, до Уханя и назад. Морская пехота патрулировала Янцзы, начиная с Боксерского восстания, во времена гражданской войны и всего такого. Однако в конце 1940 года, когда нипы* [Так называют японцев морпехи, которые ни за что не произнесут три слога, если можно обойтись одним.] уже хозяйничали во всем северо-западном Китае, большие чины в округе Колумбия наложили в штаны и велели прекратить патрулирование.
Старые морпехи вроде Фрика уверяют, будто видят разницу между бандами: толпами голодных крестьян, националами, красными партизанами и хорошо организованными шайками. Для Шафто все они — вооруженные гады, которые хотят отхватить кусок от Янцзыйского Речного Патруля. Последний рейд был та еще прогулочка. Однако все позади, и они вернулись в Шанхай — самое безопасное место в Китае, в сто раз более опасное, чем самое опасное место Америки. Шесть часов назад они выгрузились с канонерки, забурились в кабак и только сейчас вышли на улицу, решив, что пора по девочкам. По пути им попался японский ресторанчик.
Бобби Шафто и прежде заглядывал туда через окно, смотрел на человека с ножом и пытался понять, чего тот хреначит. По всему выходило, что режет сырую рыбу, кладет на комочки риса и дает нипам по другую сторону стойки, а те едят и нахваливают.
Наверное, это был обман зрения, и рыбу заранее готовили в дальнем помещении.
Шафто мучился почти год. Когда кодла пьяных морпехов шла мимо, он замедлил шаг, чтобы еще раз взглянуть в окошко и, может быть, выяснить что-нибудь новое. Он мог поклясться, что рыба — ярко-алая, то есть совершенно точно сырая.
Приятель, Родc из Шрифпорта, увидел, куда он смотрит, и спросил, не слабо ли зайти. Другой рядовой, Говицки из Питсбурга, с ходу предложил пари.
Шафто цыкнул зубом и задумался. Он уже давно решил, что когда-нибудь непременно зайдет. Он — снайпер-разведчик, в его природе — откалывать такие штуки, однако его научили и другому: тщательно осмотреть местность, прежде чем в нее выдвинуться.
Ресторан был на три четверти полон японскими военными. У стойки, где повар резал явно сырую рыбу, наблюдалось заметное скопление офицеров — если у тебя только одна граната, надо бросать туда. Большую часть помещения занимали длинные столы, за которыми солдаты пили из дымящихся чашек лапшевый суп. На них Шафто обратил особое внимание, понимая, что это они будут лупить его вусмерть секунд через шестьдесят. Некоторые сидели поодиночке и читали. Несколько человек сгрудились в углу и слушали рослого малого, который рассказывал какую-то историю или анекдот.
Чем дольше Шафто оценивал обстановку, тем больше Родс и Говицки убеждались, что он и вправду войдет. Они зашумели и позвали других морпехов, которые уже ушли на квартал вперед, к борделю.
Шафто увидел, как они возвращаются. «А хули», — сказал он и вошел в ресторан. Позади раздались удивленные возгласы. В тот миг, когда Шафто перешагнул порог японского ресторана, родилась легенда.
Все нипы повернулись в его сторону. Если они и были удивлены, то не подали виду. Повар за стойкой начал выкрикивать какое-то ритуальное приветствие и осекся, заметив, кто вошел. Тип в дальнем углу — рослый, розовощекий — продолжал рассказывать свой анекдот.
Шафто кивнул всем и никому, подошел к ближайшему свободному стулу у стойки и сел.
Ребята думали дождаться, пока подойдет вся кодла, ввалиться в ресторан, опрокинуть несколько стульев и разлить суп. Однако Шафто перехватил инициативу и вошел один, как пристало снайперу-разведчику. И еще потому, что он — Бобби Шафто и хотел провести внутри несколько спокойных минут, пока не началась буча.
Разумеется, помогло, что он был в состоянии медленного вдумчивого опьянения, а не буянил. От него наверняка несло пивом (немцы в Цинтао варят пиво с совершенно висконсинским вкусом, а он тосковал по дому). Однако он не орал и не громил мебель.
Повар лепил свои кусочки и делал вид, будто не замечает Шафто. Офицеры у стойки некоторое время холодно его изучали, потом переключились на еду. Шафто оглядел ряды сырой рыбы на колотом льду за стойкой, обвел глазами ресторанчик. Тип в дальнем углу говорил короткими фразами, читая по блокнотику. Он произносил девять-десять слов, потом его слушатели переглядывались, улыбались или морщились, иногда даже хлопали. На похабщину было не похоже. Он говорил точно и выразительно.
Черт! Он читает стихи! Шафто не понимал слов, тем не менее, судя по звуку, это были стихи. Без рифмы, правда, но у нипов все не по-людски.
Он поймал на себе взгляд повара, прочистил горло — совершенно напрасно, потому что не знал японского. Показал пальцем на алую рыбу за стойкой, поднял два пальца.
Все изумились, что американец и впрямь сделал заказ. Напряжение чуточку разрядилось. Повар принялся за дело, соорудил два кусочка и уложил их на деревянную подставочку.
Шафто учили есть насекомых, откусывать головы цыплятам. Он решил, что справится. Взял кусочек пальцами, как нипы, съел. Оказалось, вкусно. Заказал еще два, другого сорта. Тип в углу по-прежнему читал стихи. Шафто съел свои кусочки и заказал еще. Почти на десять секунд, ощущая вкус рыбы на языке и слушая стихи, он почувствовал себя по-настоящему уютно и забыл, что всего лишь провоцирует безобразную драку на межрасовой почве.
Третий заказ выглядел иначе: на кусочках сырой рыбы лежали прозрачные лепестки чего-то мокрого и блестящего. Вроде промасленной оберточной бумаги. Шафто некоторое время пялил глаза, пытаясь уяснить, что это за фигня; ничего похожего он прежде не видел. Он огляделся. Нипы такого не ели, и понять, как с этим обращаться, было нельзя.
Черт, они же офицеры. Может, кто-нибудь хоть немного кумекает по-английски?
— Простите. Это что? — спросил Шафто, приподнимая пленочку.
Повар нервно посмотрел на него и повел глазами, взглядом опрашивая посетителей. Последовало недолго обсуждение. Наконец офицер в дальнем конце стойки, лейтенант флота, встал и заговорил с Шафто.
— Водоросль.
Шафто не понравился тон — враждебный и мрачный. Вместе с выражением лица это означало: «Где тебе, деревенщине, понять, вот и считай, что это водоросль».
Шафто сложил руки на коленях, несколько секунд разглядывал водоросль, потом поднял глаза на лейтенанта, по-прежнему бесстрастно его созерцавшего.
— Какая водоросль, сэр?
Посетители начали многозначительно переглядываться, словно семафоры заработали перед морским сражением. Чтение стихов прекратилось, из дальнего конца комнаты стали подходить солдаты. Тем временем лейтенант перевел вопрос Шафто остальным, и те принялись вдумчиво его обсуждать, словно важное политическое заявление Франклина Делано Рузвельта.
Лейтенант обменялся несколькими словами с поваром и снова взглянул на Шафто.
— Он говорит, расплатиться сейчас.
Повар протянул руку и потер большой и указательный пальцы.
За годы в Янцзыйском Речном Патруле Бобби Шафто приобрел титановые нервы и безграничную веру в товарищей, поэтому подавил желание обернуться и посмотреть в окно. Он и без того знал, что там: морпехи плечом к плечу, готовые за него умереть. Шафто почесал новую татуировку на руке — дракона. Скрип грязных ногтей по свежим рубцам отчетливо прозвучал в затихшем ресторане.
— Вы не ответили на мой вопрос, — сказал Шафто, с пьяной четкостью выговаривая слова.
Лейтенант перевел. Последовало новое обсуждение, на этот раз — короткое и решительное. Шафто понял: сейчас его вышвырнут. Расправил плечи.
Нипы молодцы: до того, как схватить Шафто, они высыпали на улицу и завязали бой с морпехами. Упреждающий маневр не дал ребятам ворваться в ресторан, что нарушило бы офицерскую трапезу, а в случае успеха еще и причинило бы немереный материальный ущерб. В следующий миг по меньшей мере трое ухватили Шафто сзади и выдернули со стула. Взлетая на воздух, Шафто успел поглядеть лейтенанту в глаза и спросить: «Насчет водоросли это что, параша?»
Примечательного в драке было лишь то, что Шафто успели вынести на улицу, прежде чем пошла настоящая свалка. Дальше началась обычная потасовка между американцами и нипами — Шафто в нескольких таких участвовал. Короче, американский мордобой против японской драчки.
Шафто скорее борец, чем боксер, и в этом было его преимущество. Большинство морпехов дрались на кулачках, в стиле маркиза Квинсбери, а против нипов это не работает. Шафто не обольщался насчет своего умения боксировать, он просто опускал голову и пер, как бык. Правда, он успевал несколько раз получить по шее, но потом, как правило, хватал противника и валил на мостовую. Дальше следовала пара ударов в челюсть, и противник просил пощады.
Едва его вынесли из ресторана, ребята бросились на обидчиков. Шафто остался один на один с нипом по меньшей мере своего роста, что вообще-то необычно. Кроме того, он был крепко сложен — не как борец сумо, скорее как регбист. Стервец оказался по-настоящему силен — Шафто понял, что дело плохо. Система боя у него была не американская и (как Шафто почувствовал на себе) включала нечестные приемы — захваты и быстрые удары в главные нервные центры. Пьяный зазор между мозгом и телом Шафто под этим натиском довольно скоро превратился в пропасть. Через некоторое время он лежал на мостовой, беспомощный, парализованный, глядя в пухлое лицо противника. Ба, да это тот самый, который в ресторане читал стихи. Классно дерется для поэта. Или наоборот.
— Это не водоросль, — сказал здоровенный нип. Лицо у него было, как у ловко напроказившего мальчишки. — По-английски это, может быть, тыква? — Он повернулся и пошел в ресторан.
Здесь легенда заканчивается. Остальные морпехи не знают: встреча Бобби Шафто и Гото Денго была не последней. У Шафто осталось множество вопросов по таким разным темам, как водоросли, поэзия и приемы рукопашного боя. Он без труда разыскал Гото Денго — просто заплатил китайским мальчишкам, чтобы следили за подозрительным японцем и сообщали, где тот бывает. Выяснилось, что Гото Денго с несколькими друзьями каждое утро в определенном парке упражняются в своей драчке. Шафто убедился, что завещание в порядке, написал последнее письмо родителям, братьям и сестрам в Окономовок, отправился в парк, заново представился удивленному Гото Денго и предложил себя в качестве живой боксерской груши. Нипов повеселила его ублюдочная самозащита, но восхитила стойкость, так что за небольшую цену в несколько сломанных ребер и пальцев Бобби Шафто прошел начальный курс японской драчки, которая зовется дзюдо. Со временем они стали вместе ходить в бары и рестораны. Шафто научился отличать четыре разновидности водорослей, три разновидности рыбьей икры и несколько оттенков нипской поэзии. Конечно, он не понимал, чего они лопочут, однако мог считать слоги, а как он понял, ничего больше в нипской поэзии нет.
Впрочем, от этих знаний не много проку, как и вообще от нипской культуры, потому что в скором времени ему предстоит их убивать.
В благодарность Бобби Шафто научил Гото Денго не подавать по-девчачьи. Многие нипы хорошо играли в бейсбол и веселились, когда их верзила-приятель позорно мазал. Шафто научил Гото Денго встать боком, развернуть плечи и дослать подачу. Последний год он внимательно следил за техникой броска у Гото Денго, вот почему картинка, как тот упирается ногами в каменные плиты Банда, разворачивается, кидает обмотанную лентой гранату и почти грациозно замирает на носке армейского ботинка, стоит перед глазами у Шафто до самой Манилы и позже.

Через два дня на борту становится ясно, что сержант Фрик разучился чистить ботинки. Каждый вечер он выставляет их на палубу рядом с кубриком — видимо, ждет, что кули начистит. И каждое утро они еще грязнее, чем раньше. Через некоторое время он начинает получать нарекания и наряды на картошку.
Само по себе это простительно. На заре службы Фрик охранял почтовые поезда, вел перестрелки с бандитами в зарослях чаппараля. В двадцать седьмом его спешно перебросили в Шанхай. Пришлось перестраиваться. Отлично. Теперь он на старой лоханке, построенной до Первой мировой, и ему хреново. Однако он не сносит тяготы с достоинством, которого морпехи ждут от морпеха. Раскис. Позволяет себя унижать. Злится. Многие в четвертом полку настроены точно так же.
Раз Бобби на палубе эсминца травит баланду с парой молодых ребят. Несколько «стариков» выстраиваются в хвост на юте. Судя по выражению лиц и жестам, у них прихватило животы.
Шафто слышит, как ребята переговариваются между собой.
— Что с морпехами? — спрашивает один. Товарищ печально качает головой, как врач над пациентом, у которого только что закатились глаза.
— Обазиатились, бедолаги, — говорит он.
Оба поворачиваются и смотрят на Шафто.
За ужином, в кают-компании, Бобби Шафто проглатывает еду в два раза быстрее обычного и подходит к столу, где сидят угрюмые «старики».
— Разрешите обратиться, сержант! — орет он. — Позвольте начистить вам ботинки, сержант!
У Фрика отвисает челюсть, виден кусок недожеванной говядины во рту.
— Чего-чего, капрал?
Кают-компания замолкает.
— Почтительно прошу разрешения начистить вам ботинки, сержант!
Фрик даже трезвый не отличается сообразительностью. Кроме того, они с товарищами пронесли-таки на корабль опиум — достаточно взглянуть на зрачки.
— Ну да, — говорит он и смотрит на других недовольных. Те немного удивлены, но находят происшествие забавным. Фрик расшнуровывает ботинки. Шафто берет их и через некоторое время возвращает начищенными. К этому времени Фрик успевает вообразить о себе невесть что.
— Отлично, капрал Шафто, — нагло говорит он. — Провалиться мне, если ты чистишь ботинки хуже моего кули.
Сразу после отбоя Фрик и его приятели становятся объектами мелких розыгрышей. Ночью происходят другие, более грубые шутки. Кого-то из «стариков» стаскивают с койки и колотят неизвестные злоумышленники. Наутро начальство устраивает им неожиданную проверку и выволочку. «Обазиатившиеся» весь следующий день держатся вместе и начеку.
К полудню до Фрика доходит, что все это сознательно спровоцировал Шафто своей выходкой. Он бежит к Бобби и пытается выбросить его за борт.
В последнюю секунду один из товарищей успевает предупредить Шафто. Тот оборачивается и отражает нападение. Фрик отлетает от борта и пытается схватить Шафто за яйца. Шафто тычет ему в глаза. Противники расходятся. Предварительные формальности окончены; дальше в ход пойдут кулаки.
Фрик и Шафто боксируют пару раундов. Собирается большая толпа морпехов. Фрик явно берет верх. Он обыкновенно плохо соображает, а сейчас и вовсе не в себе, но боксировать умеет. К тому же он на сорок фунтов тяжелее Шафто.
Шафто тянет, пока Фрик не разбивает ему губу в кровь.
— Далеко ли до Манилы? — орет Шафто.
Сержант Фрик обалдевает от вопроса и на секунду останавливается.
— Два дня, — отвечает один из корабельных офицеров.
— Черт, — говорит Бобби Шафто. — Как я с такой губой буду целовать мою девушку?
Фрик отвечает:
— Найдешь себе бабу подешевше.
Шафто этого и надо. Он опускает голову и бросается на Фрика, вопя, как нип. Фрик не успевает очухаться, как Шафто делает захват, которому научил его Гото Денго, добирается до шеи и давит, пока губы у Фрика не белеют, как перламутр. Тогда Шафто перебрасывает его за борт и держит за щиколотки. Фрик приходит в себя и кричит: «Сдаюсь!»
Срочно назначают дисциплинарное разбирательство. Шафто признают виновным по двум статьям: вежливость (начистил Фрику ботинки) и защита жизни морского пехотинца (себя) от опасного психа. Опасный псих отправляется прямиком на губу. Через несколько часов по воплям Фрика каждый морской пехотинец понимает, что такое опиумная ломка.
Вот почему сержант Фрик не видит, как корабль входит в Манильскую бухту. Шафто почти жалко сукина сына.
Остров Лусон весь день тянется по левому борту, едва различимый в дымке, изредка внизу видны пляжи и пальмы. Все морпехи здесь не по первому разу и узнают Центральную Кордильеру на севере и хребет Самбалес, сбегающий вниз к бухте Субик. Бухта Субик вызывает к жизни шквал непристойных анекдотов. Корабль не заходит в нее, а идет дальше на юг: мимо Батаана и к входу в Манильскую бухту. Корабль благоухает гуталином, тальком и лосьоном после бритья. Пусть четвертый полк — бабники и курят опиум, никто не станет отрицать, что они — самые бравые ребята во всем корпусе.
Проходят Коррехидор — остров, очертаниями напоминающий каплю воды на вычищенном ботинке, с мягкой округлостью посредине и обрывистыми склонами к морю. Or одного его конца отходит длинный костлявый сухой хвост. Морпехи знают, что остров изрыт туннелями и нашпигован орудиями, но единственный признак всех этих укреплений — кучки бетонных казарм на холмах, где живут артиллеристы. Над вершиной Топсайд торчит клубок антенн. Очертания их Шафто знакомы — на станции «Альфа» в Шанхае были такие же, их еще пришлось разбирать и перетаскивать в грузовик.
Исполинские известняковые обрывы уходят почти в море, у основания — вход в туннель, где сидят корректировщики огня и радисты. Рядом док; из гражданского транспорта выгружают припасы и складывают прямо на берегу. Морпехи отмечают это как явный признак близящейся войны. «Августа» бросает якорь в бухточке, оборудование в брезенте грузят на шлюпки вместе со штабными шанхайскими морячками.
После Коррехидора волны сразу становятся ниже. Зеленовато-бурые водоросли колышутся у поверхности, закручиваясь в причудливые завитки. От военных кораблей по спокойной воде стелются бурые плети дыма. Ветра нет, и они расползаются в зубчатые структуры вроде прозрачных горных хребтов. Корабль проходит мимо военной базы в Кавите. Берег здесь плоский, как блин, и низкий — если бы не пальмы, сливался бы с водой. Над землей возвышаются несколько ангаров и водокачек, а чуть дальше — кучка низких казарм. Манила — прямо по курсу, еще в дымке. Время к вечеру.
Внезапно дымка рассеивается. Воздух чист, как глаза ребенка, и почти час видна бесконечность. Они входят в область грозовых фронтов, часто прошитых молниями. Пухлые серые тучи — словно куски сланца между наковальнями. За ними громоздятся другие облака, розовеющие в свете заката. За ними — еще облака, упакованные во влажность, словно елочные игрушки — в папиросную бумагу, пространства синего неба, еще грозовые фронты, перебрасывающиеся молниями по двадцать миль длиной. Небеса, вложенные в небеса, вложенные в небеса.
В Шанхае было холодно, потом теплело день ото дня, временами даже парило. Однако к тому времени как взорам открывается Манила, легкий бриз проносится по палубе, и все морпехи разом издают вздох, как будто кончают в унисон.

Духи Манилы
Веют от пальмовых рощ.
Бедра Глории.

В контурах манильских черепичных крыш чувствуется смешение испанских и китайских кровей. Перед городом — набережная с променадом наверху. Гуляющие машут морским пехотинцам, некоторые посылают воздушные поцелуи. Свадьба спускается по ступеням церкви и через бульвар высыпает на набережную. Молодые фотографируются в нежном закатном свете. Мужчины в модных, просвечивающих филиппинских рубашках или в военной форме США. Женщины в красивых платьях. Морпехи кричат и свистят им, женщины оборачиваются, подбирая юбки, чтоб не споткнуться, и пылко машут в ответ. Морпехи шалеют и чуть не падают за борт.
Когда корабль входит в док, из воды вырывается серпик летучих рыб. Он скользит, как бархан по пустыне. Рыбки — серебристые продолговатые листики. Каждая входит в воду с металлическим щелчком; щелчки сливаются в резкий дрожащий звук. Серпик скользит под причал, огибает опору и пропадает в тени.
Манила, Жемчужина Востока, ранний воскресный вечер, седьмого декабря тысяча девятьсот сорок первого года. На Гавайях, по другую сторону линии смены дат, только что наступила полночь. У Бобби Шафто и его товарищей несколько часов свободы. Город современный, христианский, островок процветания в нищей Азии. Здесь почти как в Америке. При всей католической набожности в Маниле есть уголки, предназначенные специально для разгоряченных моряков. Достаточно сойти на сушу, повернуть направо — и вы где надо.
Бобби Шафто сворачивает налево, вежливо отделывается от легиона наэлектризованных проституток и направляется к темной громаде Интрамурос. Он останавливается лишь для того, чтобы купить букет у цветочницы в парке. И сам парк, и стена над ним заполнены гуляющими парочками. Мужчины по большей части в военной форме, женщины — в скромных, но эффектных платьях, крутят на плече парасольки.

Предыдущая страница 2 Следующая страница


3 Нил Стивенсон

Два кучера в наемных экипажах предлагают Шафто свои услуги, но тот отказывается. Извозчик просто домчит его быстрее, а он слишком взвинчен. Лучше остыть. Шафто проходит через ворота в стене и попадает в старый испанский город.
Интрамурос — лабиринт желтовато-коричневых каменных стен, резко встающих из узких улочек. Окна первого этажа забраны в чугунные клетки. Прутья вьются и распускаются изящными коваными листочками. Слуги с длинными дымящимися шестами только что зажгли газовые фонари; нависающие вторые этажи озарены светом. Из верхних окон несутся музыка и смех. Когда Шафто проходит через очередную арку во внутренний дворик, до него долетает запах цветов в саду.
Провалиться, если он может отличить один дом от другого. Он помнит название улицы — Магалланес, потому что Глория говорила, это то же, что Магеллан. И еще он помнит вид на церковь из окна Паскуалей. Он несколько раз обходит квартал, уверенный, что уже близко. Тут из окна доносится взрыв девичьего смеха. Шафто тянет на звук, как медузу в водозабор. Все сходится: то самое место. Девушки по-английски сплетничают о преподавателях. Глории не слышно, но Шафто почти уверен, что различил ее смех.
— Глория! — говорит он. Потом еще раз, громче. Если его и услышали, то не обратили внимания. Наконец он разворачивается и, как гранату, бросает букет за деревянные перила, через узкий просвет перламутровых ставней, в комнату.
Тишина в комнате, потом новый взрыв смеха. Перламутровые ставни раздвигаются с медленной, щемящей робостью. На балкон выпархивает девятнадцатилетняя девушка в форме студентки медучилища, белая, как лунное сияние на Северном полюсе. Длинные черные волосы распущены и колышутся на легком ветру. В последних отблесках заката лицо алеет, как уголья. Мгновение она прячется за букетом, зарывшись в розы, и глубоко вдыхает их аромат, потом из-за цветов выглядывают черные глаза. Девушка медленно опускает букет, показываются высокие скулы, точеный носик, умопомрачительный изгиб губ, зубки, белые, но соблазнительно неровные, почти различимые. Она улыбается.
— Охренеть, — говорит Бобби Шафто. — Твои скулы, бля, ну чисто бульдозер.
Она подносит палец к губам. При одной мысли, как что-то касается губ Глории, невидимое копье пронзает Шафто грудь. Она смотрит вниз, убеждается, что кавалер никуда не уйдет, и поворачивается спиной. Свет косо падает на талию и ниже, не показывая ничего, но предполагая ложбинку. Глория возвращается в комнату, ставни закрываются.
Внезапно полная комната девиц замолкает, лишь изредка раздается сдавленный смешок. Шафто прикусывает язык. Они все испортят. Мистер и миссис Паскуаль заметят тишину и насторожатся.
Гремит чугунный засов, открываются большие ворота. Привратник машет рукой. Шафто идет за стариком через черный сводчатый туннель каретного подъезда. Жесткие подошвы начищенных ботинок скользят по булыжнику. Лошадь в конюшне слышит запах лосьона и ржет. Сонная американская музыка — медленный танец с Радиостанции Вооруженных Сил — льется из приемника в каморке привратника.
Каменные стены внутреннего дворика заплетены цветущим виноградом. Чистенький, тихий, уютный мирок. Здесь уже почти дом. Привратник машет в сторону одной из лестниц наверх. По словам Глории, это антресуэло, полуэтаж; на взгляд Бобби Шафто — этаж не хуже другого. Он поднимается и видит впереди мистера Паскуаля, маленького лысого человечка с аккуратными усиками и в очках. Одет на американский манер: в рубашке без пиджака, просторных штанах и домашних тапочках. В одной руке бокал Сан-Мигеля, в другой — сигарета.
— Рядовой Шафто! С возвращением! — говорит он.
Значит, Глория решила на этот раз обставить все по правилам. Паскуали в курсе. Теперь между Бобби и его девушкой — долгая чинная беседа за чаем. Ничего, морпехи не пасуют перед препятствиями.
— Простите, мистер Паскуаль, я теперь капрал.
— Что ж, поздравляю! Я видел вашего дядю Джека на прошлой неделе. Он не сказал, что ждет вас.
— Это для всех неожиданность, сэр, — говорит Бобби Шафто.
Теперь они на балкончике, опоясывающем внутренний двор. На первом этаже живут только слуги и живность. Мистер Паскуаль ведет гостя к двери на антресуэло. Стены каменные, потолок — из крашеных досок. Они проходят через темный мрачный кабинет, где отец и дед мистера Паскуаля принимали управляющих с фамильных плантаций и гасиенд. На мгновение у Бобби вспыхивает надежда. На этом этаже несколько комнат, где в былые времена жили старшие слуги, холостые дядюшки и незамужние тетки. Теперь доходы с гасиенд не те, и Паскуали сдают эти комнаты студенткам медучилища. Может, мистер Паскуаль ведет его прямиком к Глории?..
Увы, это лишь глупое самообольщение распаленного мужчины. Вот они на лестнице из полированного дерева «нара». Шафто видит обитый жестью потолок, канделябры и внушительную фигуру миссис Паскуаль, заключенную в могучий корсет, который мог бы измыслить корабельный конструктор. Они поднимаются в антесалу. По словам Глории, это не для парадных приемов, а так, для случайных гостей, но такой роскоши Бобби нигде больше не видел. Повсюду вазы — вроде бы старинные, из Японии и Китая. Веет вечерний бриз. Шафто смотрит в окно и видит, будто в раме, зеленый купол собора с кельтским крестом наверху. Все как прежде.
Миссис Паскуаль подает ему руку.
— Миссис Паскуаль, — говорит Шафто, — спасибо за радушный прием.
— Садитесь, пожалуйста, — отвечает она. — Мы хотим услышать все.
Шафто садится в резное кресло у пианино, поправляет брюки на вставшем члене, проводит рукой по щеке — чисто ли выбрита. До щетины еще несколько часов. Над крышами с воем проносится авиаподразделение. Миссис Паскуаль на тагальском отдает распоряжения горничной. Шафто изучает ссадины на кулаках и думает, осознает ли миссис Паскуаль, на что напрашивается, когда просит рассказать все. Может быть, для затравки сойдет короткий рассказ о рукопашном бое с китайскими пиратами на Янцзы. В открытую дверь виден коридор и уголок домовой церкви: готические арки, золоченый алтарь, перед ним — вышитая подушечка, протертая до дыр коленями миссис Паскуаль.
Горничная вносит сигареты в лакированном ящичке, уложенные как артиллерийские снаряды. Часов тридцать шесть пьют чай и светски беседуют. Миссис Паскуаль хочет, чтобы ее в сотый раз заверили: все хорошо и войны не будет. Мистер Паскуаль твердо уверен в противоположном и по большей части мрачно отмалчивается. В последнее время их с Джеком Шафто дела идут успешно. Они бойко торгуют с Сингапуром. Однако вряд ли это надолго.
Входит Глория. Она сменила форму на платье. Шафто чуть не вываливается спиной в окно. Миссис Паскуаль официально возобновляет их знакомство. Бобби Шафто галантно целует Глории руку. И правильно делает: смятая записка перекочевывает из ее ладошки к нему в кулак.
Глория садится, и ей тоже подают чашку. Мистер Паскуаль восемьдесят седьмой раз спрашивает, виделся ли он уже с дядей Джеком. Шафто повторяет, что буквально сию минуту с корабля и дядю Джека навестит завтра утром. Он выходит в сортир, допотопный, с двумя дырками над ямой, уходящей, возможно, в самую преисподнюю. Разворачивает и читает записку, запоминает инструкции, рвет бумажку и бросает в очко.
Миссис Паскуаль дает юным влюбленным полчаса «наедине». Это значит, что Паскуали выходят из комнаты и заглядывают не чаще, чем каждые пять минут. Мучительно долгое и церемонное прощание. Шафто выходит на улицу, Глория машет ему с балкона.
Через полчаса они выделывают языками дзюдо на заднем сиденье наемного экипажа, мчащегося к ночным клубам Малате. Извлечь Глорию из дома Паскуалей оказалось парой пустяков для целеустремленного морпеха и взвода симпатичных медичек.
Видимо, Глория целуется с открытыми глазами, потому что внезапно она выскальзывает из объятий и кричит кучеру:
— Стойте! Пожалуйста, остановитесь, сэр!
— Что такое? — ошалело бормочет Шафто.
Вокруг ничего, только впереди чернеет каменная громада церкви. Бобби чувствует предупредительный укол страха. Впрочем, в церкви темно, нет ни филиппинок в длинных платьях, ни морпехов в парадной форме — значит, это не его свадьба.
— Я хочу тебе кое-что показать, — говорит Глория и выскакивает из экипажа. Шафто вынужден идти следом. Он сто раз проходил мимо церкви Святого Августина, но никогда не думал, что войдет внутрь, особенно — с подружкой.
Они у основания большой лестницы. Глория говорит:
— Видишь?
Шафто смотрит в темноту, думая, что там витраж — возможно, Бичевание Христа или Пронзение Копием...
— Смотри вниз. — Глория стучит ножкой по верхней ступеньке. Это одна цельная гранитная плита.
— Тонн на десять — двадцать потянет, — авторитетно заявляет Шафто.
— Привезли из Мексики.
— Да что ты?
Глория улыбается.
— Отнеси меня наверх.
На случай возможного отказа она слегка откидывается назад, и Шафто остается только подхватить ее на руки. Глория обнимает его за шею, чтобы приблизить лицо, но в сознании остается только прикосновение шелкового рукава к свежепобритой щеке. Шафто начинает подъем. Глория легонькая, но уже после четвертой ступеньки он ступает с натугой. Она наблюдает за ним с четырех дюймов — не устал ли. Бобби чувствует, что краснеет. Хорошо, что всю лестницу освещают лишь две свечи. Слева умильный Христос в терновом венце, с двумя параллельными потеками крови на щеках, а справа...
— Исполинские камни, по которым ты идешь, добыты в Мексике много столетий назад, когда никаких Соединенных Штатов еще не было. Манильские галеоны везли их в трюмах как балласт. — Она выговаривает по-испански, «бальяст».
— Охренеть можно.
— Когда приходил галеон, плиту вынимали из трюма и укладывали здесь, в церкви Святого Августина. Каждую новую плиту на прошлогоднюю. Пока через много, много лет лестница не была закончена.
Ему кажется, что гребаный подъем займет не меньше. Вершина увенчана статуей Христа в полный рост. Христос держит на спине крест — по виду ничуть не легче гранитной плиты. И вправду, кто Шафто такой, чтобы роптать?
Глория говорит:
— А теперь неси меня вниз, чтобы хорошенько запомнилось.
— По-твоему, у меня одно на уме, и я не запомню историю, если в ней нет симпатичной девушки?
— Да, — говорит Глория и смеется ему в лицо.
Он несет ее вниз, затем — пока еще чего-нибудь не удумала — на улицу, в экипаж.
Бобби Шафто не из тех, кто теряет голову в бою, однако остаток вечера проходит для него в лихорадочном сне. Из тумана выплывают лишь несколько впечатлений. Вот они выскакивают из экипажа у отеля на набережной. Все ребята таращатся на Глорию. Шафто грозно обводит их взглядом. Медленный танец с Глорией в бальном зале; ее бедра, одетые в шелк, постепенно оказываются между его ногами, она все сильнее приникает к нему всем телом. Они гуляют по набережной, под руку, в лунном свете. Видят, что идет отлив. Переглядываются. Он на руках несет ее с набережной на каменистый пляж.
К тому времени как Глория ему отдается, он уже почти без сознания, в каком-то фантастическом страстном сне. Они соединяются без колебаний, без тени сомнения, без всяких обременительных мыслей. Их тела сливаются спонтанно, как две капли воды на оконном стекле. Если Шафто и думает в этот миг, то лишь о том, что сейчас — вершина его жизни. Детство в Окономовоке, школьный бал, охота на оленей в Верхнем Мичигане, тренировочный лагерь на Пэррис-Айленд, кутежи и перестрелки в Китае, стычка с сержантом Фриком — древко пред острием копья.
Где-то гудят сирены. Сознание возвращается. Неужто он простоял всю ночь, прижимая Глорию к гранитной стене, в кольце ее ног? Не может быть. Прилив еще не начался.
— Что это? — Она отпускает его шею, гладит ему грудь.
Все еще поддерживая в ладонях, как в гамаке, ее теплый безупречный задик, Шафто отступает от стены, поворачивается и смотрит в небо. Там зажигаются прожекторы. И это не голливудская премьера.
— Война, детка, — говорит он.

ОПЫТЫ

В холле гостиницы «Манила» можно играть в футбол. Пахнет прошлогодними духами, редкими тропическими орхидеями и клопомором. Перед входом торчит металлодетектор, поскольку в отеле на пару дней остановился премьер-министр Зимбабве. В разных концах холла кучкуются рослые негры в дорогих костюмах. На глубоких мягких диванах дожидаются условленного сигнала японские туристы в бермудах, сандалиях и белых носках. Богатые маленькие филиппинцы потрясают цилиндрическими коробками картофельных чипсов, как племенные вожди — церемониальными булавами. Респектабельный старый портье обходит с пульверизатором линию обороны, разбрызгивая по плинтусу средство от насекомых. Входит Рэндалл Лоуренс Уотерхауз в сиреневой футболке, украшенной логотипом их с Ави рухнувшей хайтековской компании (одной из), свободных синих джинсах и разлапых, некогда белых кроссовках.
Едва покончив с формальностями в аэропорту, он понял, что Филиппины, как и Мексика, — страна, Где Встречают По Обувке. Он быстро проходит к регистрационной стойке, пока ослепительная девушка в темно-синих юбке и пиджачке не увидела его ноги. Двое посыльных ведут непосильный сизифов бой с его сумкой. Она размером и весом с хорошую тумбочку. «Здесь ты специальной литературы не найдешь, — сказал Ави. — Бери с собой все, что может понадобиться».
Номер Рэнди — спальня и гостиная с пятиметровыми потолками и коридор с несколькими дверями, за которыми прячется разнообразная сантехника. Все обшито каким-то тропическим деревом приятного золотистого оттенка. В северных широтах это бы смотрелось ужасно, а здесь создает ощущение уюта и прохлады. В обеих комнатах — большие окна; на рамах рядом со шпингалетами привинчены крохотные таблички с предупреждением о тропических насекомых. Окна снабжены многоуровневой системой защиты: невероятно тяжелые деревянные рольставни грохочут в пазах, как маневровый; вторые ставни (двухдюймовые перламутровые квадратики в решетке полированного дерева) катаются по собственным рельсам; дальше следуют тюль и, наконец, плотные светомаскировочные шторы — все на отдельных направляющих.
Рэнди заказывает большой кофейник, выпивает кофе и все равно засыпает на ходу, пока распаковывает вещи. Лиловые облака катятся с окрестных гор, ощутимо тяжелые, как грязевые потоки, и обращают полнеба в сплошную стену. Вертикальные разряды молний ритмично озаряют номер, словно за окном щелкают камерами папарацци. Внизу, в парке Рисаля, уличные торговцы бегут по тротуарам, спасаясь от дождя, который уже почти полтысячелетия лупит по черным стенам Интрамурос. Стены легко принять за природное образование — черные вулканические хребты торчат из травы, как зубы из десен. Видны полукруглые выступы с веером бойниц — когда-то весь сухой ров простреливался фланкирующим огнем.
Живя в Штатах, не увидишь ничего старше двух с половиной веков, и то за этим нужно ехать на восточное побережье. Аэропорты и такси повсюду одинаковы. Рэнди не чувствует, что он в другой стране, пока не увидит что-нибудь вроде Интрамурос. Он стоит и пялится, как идиот.

В это самое время по другую сторону Тихого океана, в прелестном викторианском городке между Сан-Франциско и Лос-Анджелесом, компьютеры зависают, жизненно важные файлы стираются, электронная почта проваливается в межгалактическое пространство, потому что Рэнди Уотерхауза нет на месте. В упомянутом городке три маленьких колледжа: один основан штатом Калифорния, два других — протестантскими деноминациями, которые для большинства нынешних преподавателей — как бельмо в глазу. Вместе три колледжа — «Три сестры» — составляют средней значимости научный центр. Их компьютерные системы объединены в одну. Они обмениваются преподавателями и студентами, время от времени проводят совместные конференции. В этой части Калифорнии полно пляжей, гор, секвойевых рощ, виноградников, площадок для гольфа; есть разветвленная сеть исправительных заведений. Здесь куча места в трех-четырехзвездочных отелях, а в «Трех сестрах», на круг, довольно аудиторий и залов, чтобы вместить несколько тысяч человек.
Когда, часов восемьдесят назад, позвонил Ави, в городке шла большая междисциплинарная конференция под названием «Промежуточная фаза (1939–1945 гг.) борьбы за мировое господство в двадцатом столетии (н.э.)». Выговаривать — язык сломаешь, поэтому для краткости конференцию окрестили «Война как текст».
Народ съехался из таких мест, как Амстердам и Милан. Оргкомитет конференции, куда входит и девушка Рэнди, Чарлин (с которой у них, похоже, все кончено), заказал плакат художнику из Сан-Франциско. Тот взял за основу черно-белое фото изморенного пехотинца времен Второй мировой — усталый взгляд, на нижней губе висит сигарета — и прогнал через ксерокс в таком режиме, чтобы полутоновой растр превратился в грубые комья наподобие искусанных собакой резиновых мячиков. В результате множества других преобразований светлые глаза солдата стали зловеще-белесыми, а сама фотография обрела пронзительную четкость. После этого художник добавил несколько цветовых пятен: алую губную помаду, синие тени для век, красную бретельку от лифчика в расстегнутом вороте гимнастерки.
Плакат с ходу получил какую-то премию, в результате попал в прессу и был освещен средствами массовой информации в качестве официального яблока раздора. Предприимчивый журналист разыскал солдата, изображенного на оригинальной фотографии, — это оказался орденоносный ветеран, штамповщик на пенсии, не только живой, но и очень бодрый. С тех пор как его жена скончалась от рака груди, он разъезжал на своем пикапчике по Дальнему Югу и помогал восстанавливать негритянские церкви, спаленные хулиганствующими расистами.
Художник сознался, что скопировал фотографию из книги и даже не пытался получить разрешение — самая концепция разрешений порочна, поскольку всякое творчество берет начало в другом творчестве. Видные адвокаты сошлись, как пикирующие бомбардировщики, в маленьком кентуккском городке, где безутешный вдовец сидел на крыше негритянской церкви, держа во рту гвозди, приколачивал листы фанеры и бормотал: «Без комментариев» полчищам репортеров на лужайке. После серии совещаний в городской гостинице орденоносец вышел в сопровождении одного из пяти самых прославленных адвокатов мира и объявил, что подает на «Трех сестер» в суд и скоро на месте университета останется дымящаяся земля. Выигранную сумму он пообещал разделить между негритянскими церквями, ветеранскими фондами и научными проектами в области рака груди.
Оргкомитет изъял плакат из обращения. На следующий день в Интернете появились тысячи пиратских копий. Их посмотрели миллионы людей, которым иначе не было бы до этого плаката никакого дела. Кроме того, оргкомитет подал в суд на художника, чье состояние можно было бы расписать на обратной стороне трамвайного билета: тысяча долларов в банке и долги (в основном студенческие займы) примерно на шестьдесят пять тысяч.
Все это случилось еще до начала конференции. Рэнди был в курсе, потому что Чарлин подрядила его обеспечить компьютерную поддержку — создать вебсайт и настроить почтовые ящики для гостей. Когда разразился скандал в прессе, электронная почта хлынула рекой, забив до отказа дисковое пространство, с которым Рэнди колупался последние несколько месяцев.
Начали прибывать участники. Многие из них останавливались в доме — просторном викторианском особняке, где Рэнди с Чарлин жили уже семь лет. Народ валил валом из Гейдельберга, Парижа, Беркли и Бостона. Все сидели у Рэнди и Чарлин на кухне, пили кофе и говорили про «спектакль». Рэнди сперва думал, что «спектакль» — это эпопея с плакатом, но разговоры не прекращались, и постепенно до него дошло, что слово употребляется не в привычном смысле, а как элемент некоего научного жаргона; оно несло в себе множество коннотаций, непонятных никому, кроме Чарлин и ее компании.
И она, и другие участники конференции свято верили, что ветеран, подавший на них в суд, принадлежит к худшему разряду людей. «Война как текст» для того и созвана, чтобы развенчать их, сжечь и выбросить пепел в мусорное ведро постисторического дискурса. Рэнди провел много времени в подобных компаниях, вроде бы притерпелся, однако время от времени у него от постоянно стиснутых зубов начинала болеть голова, он вставал посредине еды или разговора и уходил прогуляться в одиночестве — отчасти чтобы не ляпнуть чего-нибудь в сердцах, отчасти — в детской, но совершенно бесплодной попытке обратить на себя внимание Чарлин.
Он с самого начала знал, что эпопея с плакатом добром не кончится, и несколько раз предупреждал Чарлин и остальных. Они слушали холодно, по-медицински, как будто Рэнди — подопытное существо за зеркалом, прозрачным с одной стороны.

Рэнди борется со сном до наступления сумерек. Потом несколько часов лежит, силясь уснуть. Грузовой порт чуть севернее отеля, и всю ночь на бульваре Рисаля, под старой стеной, одна сплошная пробка грузовиков. Город — двигатель внутреннего сгорания. В Маниле явно больше поршней и выхлопных труб, чем во всем остальном мире, вместе взятом. Даже в два часа ночи неколебимая, казалось бы, громада отеля гудит и дребезжит от сейсмической энергии моторов на улице. От шума на гостиничной стоянке начинается перекличка противоугонных систем. Звук одной сигнализации включает другую и так далее. Рэнди мешает спать не столько шум, сколько полнейший идиотизм этой цепной реакции. Наглядный урок. Кошмарный, нарастающий снежным комом технологический сбой, из-за которого хакеры не могут уснуть ночью, даже когда не слышат результатов.
Он вынимает из мини-бара банку «Хайнекена», открывает ее легким движением руки и встает перед окном. На многих грузовиках — разноцветная иллюминация, еще ярче она на лихо выруливающих «джипни». Вид стольких людей за работой окончательно прогоняет сон.
От смены часовых поясов голова совершенно дурная и нет смысла браться за что-нибудь такое, где надо думать. Однако есть одно важное дело, где думать вообще не надо. Рэнди снова включает ноутбук. Экран — безупречный прямоугольник цвета разведенного молока или северной зари — словно парит в темноте. Свет рождается во флуоресцентных трубках, заключенных в поликарбонатный гробик компьютерного дисплея. Он пробивается к Рэнди через стеклянный экран, полностью покрытый сеткой крохотных транзисторов. Они либо пропускают фотоны, либо нет, либо пропускают волны только определенной длины, расщепляя белый свет на цвета. Включением и выключением транзисторов по определенной системе Рэнди Уотерхаузу передается смысл. Хороший кинорежиссер, перехватив контроль над ними на пару часов, мог бы поведать Рэнди целую историю.
К несчастью, ноутбуков вокруг много больше, чем стоящих кинорежиссеров. Контроль над транзисторами почти никогда не переходит к человеку; ими управляет программа. Когда-то Рэнди балдел от программ, теперь нет. Людей интересных найти трудно.
Возникают пирамида и глаз. Рэнди так часто пользуется «Ордо», что теперь компьютер загружает программу автоматически.
Последнее время ноутбук служит Рэнди для одной-единственной цели — общаться с другими людьми через электронную почту. Для общения с Ави он должен использовать «Ордо», который берет его мысли и превращает в поток битов, почти неотличимый от белого шума, чтобы отправить их Ави. В ответ от Ави приходит шум и преобразуется в его мысли. На данный момент у корпорации «Эпифит» нет других активов, кроме информации — идей, фактов, данных. Все это очень легко украсть, так что шифровать — разумная мысль. Другой вопрос, какая именно степень паранойи и впрямь оправдана.
Ави прислал ему зашифрованный е-мейл.

Когда доберешься до Манилы, сгенерируй пару ключей по 4096 бит, сбрось их на дискету и всегда носи ее при себе. Не держи их на жестком диске. Кто угодно может забраться в номер, когда тебя не будет, и украсть ключ.

Сейчас Рэнди открывает меню и выбирает пункт «Создание новой пары ключей».
Возникает диалоговое окно с несколькими опциями ДЛИНА КЛЮЧА: 768 бит, 1024, 1536, 2048, 3072 или «По выбору пользователя». Рэнди выбирает последнюю опцию и устало выстукивает: 4096.
Даже чтобы взломать 768-битный ключ, нужны огромные ресурсы. Добавьте бит, ключ станет 769-битным, но число возможных вариантов увеличится вдвое и задача станет еще более сложной. 770-битный ключ взломать еще труднее, и так далее. Используя 768-битный ключ, Рэнди и Ави могли бы хранить свою переписку в тайне от практически всего остального человечества на протяжении по меньшей мере ближайших нескольких лет. 1024-битный ключ многократно, астрономически труднее взломать.
Некоторые особо нервные пользуются 2048- или даже 3072-битными ключами. Это остановит лучших дешифровщиков мира на астрономический период времени, если не будут созданы запредельные технологии, скажем, квантовые компьютеры. Даже лучшие специалисты по защите информации редко закладывают в свои программы поддержку более длинных ключей. Ави потребовал использовать «Ордо», который считается лучшей криптографической программой в мире, именно потому, что может оперировать ключами произвольной длины — если вам охота ждать, пока он перелопатит все цифры.
Рэнди начинает печатать, не глядя на экран — он смотрит в окно на фары грузовиков и джипни. Печатает он одной рукой, расслабленно шлепая по клавиатуре.
В компьютере у Рэнди — таймер. Когда он нажимает клавишу, «Ордо» берет значение текущего времени с точностью до микросекунд. Рэнди ударяет по клавише в 03:05:56.935788, по следующей в 03:05:57.290664, то есть на 0,354876 секунд позже. Еще через 0,372307 снова. «Ордо» записывает интервалы и отбрасывает первые значащие цифры (в данном случае 35 и 37), поскольку они будут близки от события к событию.
«Ордо» требуется случайность. Ему нужны наименее значащие цифры — скажем, 76 и 07. Ему нужна целая куча случайных чисел, и ему нужно, чтобы они были очень, очень случайны. Он берет полученные случайные числа и пропускает их через хэш-функции, чтобы сделать еще более случайными. Он прогоняет результаты через статистические программы, проверяя, нет ли в них скрытых закономерностей. У него умопомрачительные стандарты случайности, и он требует, чтобы Рэнди тюкал по клавишам, пока не будет достигнут требуемый результат.
Чем более длинный ключ вы хотите сгенерировать, тем больше времени это займет. Рэнди хочет сгенерировать несуразно длинный ключ. Он написал Ави, в зашифрованном электронном письме, что если каждую частицу вещества во вселенной использовать для строительства одного космического суперкомпьютера, то на взлом 4096-битного ключа этому компьютеру потребуется время, превосходящее срок жизни вселенной.
«На современном уровне технологии — да, — без промедления отозвался Ави. — Но как насчет квантовых суперкомпьютеров? И что, если будут разработаны новые математические алгоритмы, облегчающие разложение на множители больших чисел?»
«Как долго ты хочешь хранить наши сообщения в тайне? — спросил Рэнди в последнем письме, которое отправил из Сан-Франциско. — Пять лет? Десять лет? Двадцать пять лет?»
Добравшись сегодня до гостиницы, он расшифровал и прочел ответ Ави. Строка по-прежнему висит у него перед глазами, как после стробоскопической вспышки.

Я хочу, чтобы они оставались в тайне, пока люди способны творить зло.

Компьютер наконец запищал. Рэнди снимает усталую руку с клавиатуры. «Ордо» вежливо предупреждает, что некоторое время может быть занят, и принимается за работу. Он прочесывает вселенную чистых цифр, ища два достаточно больших простых числа, которые при перемножении дали бы произведение длиной 4096 бит.
Если вы хотите, чтобы ваши тайны вас пережили, то, выбирая длину ключа, вы должны быть футурологом. Вы должны предвидеть, как будут в это время развиваться компьютеры. Вы должны разбираться в политике. Если весь мир превратится в одно большое полицейское государство, одержимое распутыванием старых тайн, то задача разложения на множители больших составных чисел может быть решена ударными темпами.
Так что длина ключа, которым вы пользуетесь, сама по себе своего рода шифр. Компетентный сексот, узнав, что Рэнди и Ави пользуются 4096-битным ключом, придет к одному из следующих выводов:
— Ави сам не понимает, что говорит. Такое можно исключить, ознакомившись хотя бы с частью его прежних достижений.
Или:
— Ави — клинический параноик.
Или:
— Ави либо крайне оптимистично смотрит на будущее компьютеров, либо крайне пессимистично на развитие политического климата, либо и то и другое вместе.
Или:
— Ави планирует больше чем на сто лет вперед.
Рэнди расхаживает по комнате, пока его компьютер несется через числовое пространство. Контейнеры на грузовиках украшены теми же логотипами, что на улицах Сиэтла при разгрузке корабля. Рэнди испытывает странное умиротворение, как будто, совершив безумный прыжок через Тихий океан, внес в свою жизнь некую зеркальную симметрию. Он попал из того места, где продукты потребляются, туда, где их производят, из страны, где передовым обществом онанизм возведен в культ, в страну, где на стекла автомобилей клеят плакатики «НЕТ КОНТРАЦЕПЦИИ!». У него возникает странное чувство, что это правильно. Так хорошо ему не было с тех пор, как двенадцать лет назад они с Ави затеяли свое первое гиблое дело.

Рэнди вырос в университетском городке на востоке штата Вашингтон, окончил государственный университет в Сиэтле и осел в тамошней библиотеке, точнее — в межбиблиотечном абонементе. Его обязанностью было обрабатывать требования, присланные из маленьких окрестных библиотек, и, наоборот, рассылать требования в другие библиотеки. Если бы девятилетний Рэнди Уотерхауз мог заглянуть в будущее и увидеть себя на рабочем месте, он бы возликовал. Дело в том, что главным орудием труда в межбиблиотечном абонементе служил скрепковыдиратель. В четвертом классе Рэнди увидел такой у своего учителя и был зачарован его устрашающим видом. Хитроумное устройство напоминало пасть фантастического робота-дракона. Рэнди нарочно неправильно скреплял выполненные задания и просил учителя расскрепить, чтобы лишний раз увидеть хищные жвалы в действии. Дошло до того, что он стащил скрепковыдиратель из церкви со стола, когда никто не видел, встроил в робота-убийцу из конструктора и терроризировал всю округу. Немало дешевых пластмассовых игрушек было перекушено адскими челюстями, прежде чем кражу обнаружили и Рэнди торжественно пристыдили перед Богом и людьми. Теперь, в межбиблиотечном абонементе, у Рэнди не просто лежало несколько таких в ящике стола — он еще и вынужден был орудовать ими по часу-два в день.
Библиотека Вашингтонского университета была хорошо укомплектована, поэтому читатели редко заказывали книги из других — только если свои экземпляры оказывались украдены или требовалось что-то необычайно редкое. В Межбибе (как ласково называли его Рэнди и другие коллеги) имелись свои постоянные посетители — люди, которые заказывали целую кучу редкостных книг. Эти люди были или нудные, или робкие, или то и другое вместе. Рэнди обычно доставались именно робкие зануды, поскольку он единственный из младших сотрудников не собирался куковать в библиотеке до конца жизни. Все понимали, что Рэнди, выпускник астрономического факультета с хорошим знанием компьютера, рано или поздно найдет себе что-нибудь получше: у его коллег таких устремлений не было. Вот почему Рэнди, с его широким кругозором и терпимым отношением к чужим странностям, оказывался очень кстати, когда в Межбиб приходил определенного типа читатель.
Рэнди и сам казался большинству нудным, робким и несколько задвинутым. Впрочем, задвинут он был не только на науке, но и на фантастических ролевых играх. Он сумел высидеть два года на тупейшей работе лишь потому, что все свободное время разыгрывал фантастические сценарии немыслимой глубины и сложности, так что его мозги, ненужные в Межбибе, работали с полной нагрузкой. Их компания встречалась каждую пятницу и порой играла до воскресенья. Кроме Рэнди, в нее постоянно входили Честер (который учился сразу на двух факультетах — техническом и музыкальном) и аспирант-историк Ави.
Когда новый магистрант по имени Эндрю Лоуб вошел в Межбиб с характерным блеском в глазах и вынул из потертого рюкзака трехдюймовую стопку аккуратно отпечатанных требований, его немедленно диагностировали и направили к Рэнди Уотерхаузу. Произошла встреча родственных душ, хотя Рэнди окончательно это понял, лишь когда книги для Лоуба начали прибывать на тележках из зала доставки.
Энди Лоуб писал работу об энергетическом балансе местных индейских племен. Человеческое тело тратит определенную энергию просто на то, чтобы двигаться и поддерживать собственную температуру. Ее величина растет на холоде или когда данное тело совершает работу. Единственный источник энергии — еда. Некоторые виды пищи энергетически богаче других. Например, форель очень богата белками, однако так бедна жирами и углеводами, что, если питаться ею одной, можно умереть с голода. Другие продукты содержат уйму энергии, но их так трудно добыть, что в смысле кВт-часов питаться ими невыгодно. Эндрю Лоуб хотел выяснить, чем исторически питались некоторые индейские племена северо-запада, сколько энергии они тратили на добывание пищи и что из нее получали. Он хотел проделать эти расчеты для прибрежных индейцев вроде селишей (имевших легкий доступ к всевозможным дарам моря) и для материковых вроде кайюсов (не имевших такого доступа) и, таким образом, установить связь между уровнем жизни и культурным развитием племен (прибрежные индейцы рисовали немыслимой сложности орнаменты, материковые иногда царапали на камнях примитивных человечков).
Для Эндрю Лоуба это было исследование на стыке наук. Для Рэнди — начало клевой игры. Задушил мускусную крысу — получай сто тридцать шесть энергетических очков. Упустил мускусную крысу — температура твоего тела упала еще на градус.
Эндрю был сама методичность, поэтому он просто штудировал все книги по данной теме, все книги, на которые в них ссылались, и так до четвертого-пятого колена; просматривал все, что было в библиотеке, и заказывал недостающее через Межбиб. Все его заказы проходили через стол Рэнди. Рэнди читал некоторые и пролистывал все. Он узнал, сколько ворвани должен съесть полярный исследователь, чтобы не протянуть ноги. Он изучил подробный состав армейских сухих пайков. Через некоторое время он начал бегать в копировальную и ксерить самое интересное.
Чтобы провести реалистичную ролевую игру, надо следить, сколько пищи герои получают и ценою каких затрат. Герои, идущие через пустыню Гоби в ноябре пятитысячного года до нашей эры, будут тратить больше времени на заботы о пропитании, чем, скажем, едущие через центральный Иллинойс в 1950-м.
Рэнди не первый это открыл. Было несколько невероятно тупых игр, где не приходилось думать о еде, но Рэнди с друзьями их презирали. В тех играх, в которых они участвовали, надо было тратить правдоподобное время на поиски еды для своих героев. Однако не так просто определить, что правдоподобно. Рэнди справился с задачей, сляпав вместе несколько базовых уравнений, взятых по преимуществу с потолка. Однако книги, статьи и диссертации, которые Эндрю Лоуб заказывал через Межбиб, содержали те самые исходные данные, нужные человеку с математическим складом ума, чтобы выстроить сложные правила игры на научной основе.
Смоделировать все физические процессы в каждом персонаже невозможно, особенно если в игре участвуют многотысячные армии. Даже грубая модель с использованием простейших уравнений и нескольких переменных требует чудовищного количества писанины, если выполнять ее на бумаге. Однако дело происходило в начале восьмидесятых, когда персональные компьютеры резко начали дешеветь. Компьютер мог бы автоматически ворошить большую базу данных и сообщать, сыт персонаж или голоден.
Одна загвоздка: Рэнди Уотерхауз работал в паршивой дыре с зарплатой, на которую компьютер не купишь.
Конечно, и эту проблему можно было бы обойти. В университете стояла куча компьютеров. Если бы Рэнди отвели машинное время, он мог бы написать программу и гонять ее бесплатно.
К несчастью, машинное время полагалось только студентам и преподавателям, а Рэнди ни тем, ни другим не был.
К счастью, примерно в это время он начал встречаться с аспиранткой по имени Чарлин.
Как бочкообразный технарь, младший библиотекарь, отдающий все свободное время заумным ролевым играм, закрутил со стройной и довольно симпатичной искусствоведкой, любительницей гребли и европейского кино? Видимо, это был случай, когда противоположности сходятся и взаимно дополняют друг друга. Познакомились они, ясное дело, в Межбибе, когда очень умный и собранный Рэнди помог очень умной, однако взбалмошной и нервной Чарлин разобраться с неряшливой кипой требований. Ему следовало сразу спросить, что она делает вечером, но он постеснялся. Второй и третий случай представились, когда начали приходить ее книги. Наконец он пригласил Чарлин в кино. Никого уламывать не пришлось: оба, как выяснилось, сгорали от нетерпения. Не успели они опомниться, как Рэнди дал Чарлин ключ от своей квартиры, а Чарлин ему — свой пароль к университетскому компьютеру. Все было просто блеск.
Университетская компьютерная сеть — лучше, чем совсем без компьютера. Увы, Рэнди почувствовал себя чайником. Как все другие университетские сети, она базировалась на операционной системе под названием UNIX, осваивать которую — все равно что взбираться на Матерхорн, чем дальше — тем круче, и никаких тебе клевых фичей, как на входивших тогда в моду персоналках. Рэнди студентом много ею пользовался и кое-что соображал, тем не менее, чтобы всерьез освоить программирование, требовалась уйма времени. С появлением Чарлин жизнь его изменилась, теперь изменилась еще больше — он забросил ролевые игры, перестал ходить в Общество творческих анахронизмов, а все свободное время проводил с Чарлин или за компьютерным терминалом. С Чарлин он делал то, на что никогда не раскачался бы сам — например, занимался спортом и посещал концерты. А за компьютером он осваивал новые навыки и что-то создавал.
Он помногу разговаривал с Эндрю Лоубом, который осуществлял в жизни то, что программировал Рэнди: исчезал на несколько дней, возвращался измотанный, с рыбьей чешуей на усах и засохшей звериной кровью под ногтями. Он уминал пару биг-маков, спал двадцать четыре часа кряду, потом встречался с Рэнди в баре (Чарлин не любила, когда он приходил в дом) и со знающим видом толковал о трудностях туземной жизни. Как-то они поспорили, ели индейцы некие особенно гадкие части определенных животных или выбрасывали. Эндрю говорил: «ели». Рэнди не соглашался. То, что они дикари, еще не означает, будто у них нет вкуса. Эндрю обозвал его романтиком. Наконец, чтобы разрешить спор, они отправились в горы, вооруженные только ножами и коллекцией хитрых ловушек, которые соорудил Эндрю. К концу третьего дня Рэнди начал всерьез подумывать о том, чтобы есть насекомых. «Q.E.D.»* [Quod erat demonstrandum — что и требовалось доказать (лат.).], — сказал Эндрю.
Так или иначе, через полтора года Рэнди закончил программу. Получилось классно; Ави и Честеру понравилось. Рэнди радовался, что сделал нечто настолько сложное и в то же время работающее, но понимал, что будущего у программы нет. Ему было стыдно: он угробил на пустяки столько времени и сил! Впрочем, если бы он не программировал, то убивал бы время за ролевыми играми или в Обществе творческих анахронизмов, так что на круг выходило одно и то же. Вообще-то даже хорошо, что он просидел это время за компьютером, потому что еще больше навострился программировать. С другой стороны, он работал под UNIX — не самый мудрый ход в период бума персоналок.
Честер и Рэнди порой посмеивались над Ави за самозабвенную любовь к ролевым играм. Ави возражал, что играет с единственной целью: понять, каково на самом деле жилось в древние времена. Он всегда был одержим исторической достоверностью. Хотя чего там — они все придумывали себе дурацкие оправдания, да и познания Ави часто оказывались кстати.
Вскоре после этого Ави защитился и пропал с горизонта. Через несколько месяцев он всплыл в Миннеаполисе, где устроился в крупное издательство, специализирующееся на фантастических ролевых играх. Он предложил купить у Рэнди программу за астрономическую сумму в тысячу долларов плюс небольшой процент от будущих продаж. Рэнди согласился в общих словах, попросил Ави выслать ему контракт и пошел искать Эндрю. Тот отыскался на крыше своего многоквартирного дома, где варил рыбьи потроха в берестяном котелке на жаровне для барбекю. Рэнди хотел сообщить хорошие новости и разделить с Эндрю прибыль. Закончилось это очень неприятным разговором на крыше, на ветру, под моросящим дождем.
Во-первых, Эндрю воспринял сделку куда серьезней, чем Рэнди. Для Рэнди это было неожиданное везение, подарок судьбы. Эндрю, сын адвоката, отнесся к ней как к слиянию двух крупных корпораций. Он задал кучу нудных и мелочных вопросов о контракте, который еще не существовал и даже в написанном виде вряд ли занял бы больше странички. Рэнди тогда не понимал, что, задавая столько вопросов, Эндрю как бы брал на себя роль менеджера, подразумевая, что они деловые партнеры.
Во-вторых, Эндрю не представлял, сколько времени и сил вбухал Рэнди в программу. Или (как задним числом догадался Рэнди) как раз, наоборот, представлял. В любом случае Эндрю вообразил, будто прибыль надо делить пополам — собачий бред, учитывая, что его реальный вклад был близок к нулю. Короче, Эндрю вел себя так, словно в проекте использованы все его исследования по рациону индейцев и это дает ему право на равную прибыль.
К тому времени как Рэнди удалось закончить разговор, голова у него шла кругом. Он вышел из дома с одним взглядом на реальность и столкнулся с совершенно иным, явно бредовым, однако два часа угроз со стороны Эндрю поколебали его уверенность. Промаявшись две ночи без сна, он решил отказаться от всей затеи. Какие-то жалкие несколько сот долларов не стоили таких мук.
Однако Эндрю (которого теперь представлял адвокат из папиной фирмы в Санта-Барбаре) горячо возражал. По словам адвоката, они создали коммерческий продукт; отказываясь продать его по рыночной стоимости, Рэнди вынимает деньги из кармана у Эндрю. Начался чисто кафкианский кошмар. Рэнди оставалось только сбегать в любимый паб, тянуть в уголке крепкое пиво (часто в компании Честера) и наблюдать, как развивается фантасмагория. Он понимал, что ненароком вляпался в чудовищную жуть, связанную с семьей Эндрю. Выяснилось, что родители Эндрю в свое время развелись и затеяли борьбу за Эндрю, своего единственного ребенка. Мамаша подалась в хиппи и примкнула к какой-то религиозной секте в Орегоне, прихватив Эндрю с собой. По слухам, в секте практиковалось развращение малолетних. Папаша нанял частных сыщиков, выкрал Эндрю и в доказательство любви принялся осыпать его материальными благами. Мать подала в суд. Отец нашел какого-то экстремального психотерапевта, который под гипнозом вытянул из Эндрю подавленные воспоминания о невыразимых и неправдоподобных ужасах.
Это лишь краткая сводка того, что Рэнди узнал в последующие годы. Позже он вынужден был согласиться, что жизнь Эндрю фрактально ужасна: любой ее маленький кусочек, если всмотреться попристальнее, окажется таким же сложным и жутким, как все целое.
Так или иначе, Рэнди ненароком вляпался в эту жизнь и в полной мере хлебнул ее жути. Ретивый молодой адвокат из папашиной конторы решил в качестве превентивного хода получить копии всех компьютерных файлов Рэнди, которые по-прежнему хранились в системе Вашингтонского университета. Нет надобности говорить, что он взялся за дело всерьез. В ответ на его угрожающее письмо юридический отдел университета проинформировал и адвоката Эндрю, и самого Рэнди, что всякий, создавший коммерческий продукт с использованием университетского компьютера, обязан отстегнуть половину прибыли. Теперь Рэнди атаковали письмами не одна, а две адвокатские фирмы. Эндрю грозился подать в суд: ведь из-за его, Рэнди, оплошности доля самого Эндрю уменьшилась вдвое!
В конце концов, чтобы выкарабкаться из этой истории, Рэнди сам вынужден был нанять адвоката. Финал обошелся ему в пять с небольшим тысяч долларов. Программа так и не продалась, да это было и невозможно: за ней тянулся такой шлейф исков, что легче было бы загнать ржавый «фольксваген», разобранный на детали и рассованный в конуры с бойцовыми собаками по всему миру.
Тогда он первый и последний раз в жизни задумался о самоубийстве — не то чтобы всерьез, но задумался.
Когда все кончилось, Ави прислал ему написанное от руки письмо: «Очень приятно было сотрудничать. Надеюсь, мы и впредь останемся друзьями, а если повезет, то и творческими партнерами».

ИНДИГО

Лоуренс Притчард Уотерхауз и остальные музыканты стоят на палубе «Невады». Утро. Они играют американский гимн и смотрят, как звездно-полосатый флаг взлетает на мачту. Внезапно небо наполняют сто девяносто самолетов непривычной конструкции. Одни летят низко, почти горизонтально, другие стремительно пикируют с высоты — до того стремительно, что вроде бы даже разваливаются: от них отлетают маленькие кусочки. Жуткое зрелище — учебные маневры закончились бедой. Однако самолеты успевают вывернуть со своей самоубийственной траектории. Отвалившиеся куски падают ровно и целеустремленно, а не кувыркаются, как обломки металла. Они сыплются повсюду, странным образом все больше на корабли. Это же страшно опасно! Они могут кого-нибудь зашибить! Лоуренс возмущен до глубины души.
На одном из кораблей происходит кратковременный феномен. Лоуренс поворачивается, чтобы рассмотреть. Он впервые видит настоящий взрыв и не сразу понимает, что это такое. Он может играть самые трудные партии с закрытыми глазами, а «Усеянное звездами знамя» куда легче выстукивать, чем петь.
Лоуренс все быстрее следит глазами — не за взрывом, а за двумя самолетами, летящими прямо на них, над самой водой. Каждый сбрасывает по длинному худому яйцу, потом хвостовые рули заметно поворачиваются, и самолеты, взмыв, проносятся над головой. Встающее солнце светит через стеклянные кабины. Лоуренс смотрит прямо в глаза одному из пилотов. Это какой-то азиатский джентльмен.
Невероятно реалистичные учения — надо же, выбрать этнически правильных пилотов и взрывать на кораблях пиротехнические снаряды! Молодцы! Последнее время здесь все было слишком расхлябанно.
Палуба содрогается с невероятной силой. Ощущение такое, будто спрыгнул с десятифутового уступа на сплошной бетон. Однако Лоуренс продолжает стоять на ватных ногах. Чепуха какая-то.
Оркестр уже доиграл гимн и теперь смотрит на представление. Повсюду гудят сирены — на «Неваде», на соседней «Аризоне», на берегу. Лоуренс не видит зенитного огня, не видит знакомых самолетов в воздухе. Бомбы продолжают рваться. Лоуренс подходит к борту и смотрит через несколько ярдов воды на «Аризону».
Еще один пикировщик сбрасывает снаряд, тот падает на палубу «Аризоны» и неожиданно исчезает. В палубе аккуратная дыра по форме бомбы, как в мультфильме, когда персонаж в панике прошибает стену или потолок. Пламя бьет из дыры за микросекунды до того, как вся палуба вспучивается, разламывается, превращается в сплошной шар огня и черноты. Что-то летит на Уотерхауза — он замирает, — проносится над ним, мимо, через него. В голове жуткий звук случайно задетой струны, не в лад, однако не лишенный некоторой сумбурной гармонии. Музыкальный или нет, звук оглушителен. Уотерхауз зажимает руками уши. Однако звук все равно здесь, звук повсюду, словно раскаленные спицы пронзают барабанные перепонки. Адский трезвон.
На шее Уотерхауза широкий ремень, сшитый с другим ремнем, на бедрах; ремни держат подставку, в подставку уперта нога глокеншпиля — лирообразной кирасы с пестрыми кистями на верхних углах. Странное дело — одна из кистей горит. С глокеншпилем еще что-то не так, но Лоуренс не видит, что именно, — глаза поминутно приходится вытирать от чего-то липкого. Он знает только, что глокеншпиль вобрал в себя огромное количество чистой энергии и достиг состояния, прежде за таким инструментом не замеченного: это пламенеющее, огненное, визжащее чудище, комета, архангел, древо вспыхнувшей магнезии, прижатое к его телу, упертое в его пах. Энергия передается по центральной оси, через подставку, в гениталии, что при других обстоятельствах было бы возбуждающе.

Предыдущая страница 3 Следующая страница


Криптономикон (часть 1) 4

Лоуренс некоторое время бесцельно бродит по палубе. Кто-то просит его помочь открыть люк. Только тут он сознает, что по-прежнему зажимает руками уши. Правда, иногда он одной рукой норовит протереть глаза — их по-прежнему заливает. Когда он окончательно разжимает уши, звон смолкает, самолетов больше не слышно. Ему хочется спуститься в трюм, потому что все опасное падало с неба и хорошо бы отгородиться от него чем-нибудь прочным, но большинство матросов думают наоборот. Вроде бы в них попали две не то торпеды, не то не торпеды, и они пытаются поднять пары. Офицеры и старшины, черные и красные от гари и крови, наперебой гоняют Лоуренса с разными, очень спешными поручениями, которых он не понимает отчасти и потому, что уши все время зажаты руками.
Примерно через полчаса ему приходит мысль избавиться от глокеншпиля, который только мешает. Глокеншпиль казенный, Лоуренсу строго приказано его беречь. Лоуренс очень серьезно относится к таким вещам еще с тех пор, как его допустили к органу в Вест-Пойнте, Виргиния. Однако сейчас, глядя, как горит и тонет «Аризона», он впервые говорит себе: «А ну его к чертям». Вытаскивает инструмент из гнезда и в последний раз в жизни оглядывает — больше ему никогда не придется держать в руках глокеншпиль. Ясно, что беречь уже нечего — к некоторым пластинам приварились куски черного покореженного металла. Отбросив последние угрызения совести, Лоуренс швыряет глокеншпиль за борт в общем направлении «Аризоны» — стальной военной лиры, под чье бряцанье идет ко дну тысяча человек.
Как раз когда она исчезает в пятне горящего мазута, налетает вторая волна бомбардировщиков. Зенитки наконец открывают огонь и осыпают снарядами окрестные жилые дома. По улицам бегают человекоподобные факелы, за ними — люди с одеялами.
До конца дня Лоуренс Притчард Уотерхауз и остальные ВМС борются с последствиями того, что различные двумерные структуры на этом и других кораблях, поставленные, дабы препятствовать смешению различных веществ (например, воздуха и мазута), получили пробоины. Некоторые конструкции, призванные (а) оставаться горизонтальными и (б) служить опорой для тяжелых предметов, также не отвечают своей цели.
Машинистам «Невады» удается раскочегарить пару котлов, и капитан пробует вывести ее из залива. Линкор немедленно подвергается массированной атаке со стороны пикирующих бомбардировщиков, которые хотят затопить «Неваду» в фарватере и окончательно перекрыть выход из бухты. Чтобы этого не случилось, капитан сажает «Неваду» на грунт. К сожалению, у нее одно общее свойство с другими кораблями ВМФ: она плохо приспособлена к боевым действиям из неподвижного положения, поэтому ее еще два раза атакуют пикирующие бомбардировщики.
В целом очень насыщенное утро. Лоуренс, музыкант без инструмента и четких обязанностей, больше, чем следует, пялится на самолеты и взрывы. Он вернулся к своим прежним мыслям о сообществах, которые стремятся друг друга пожрать. Пока японские бомбардировщики волна за волной с каллиграфической четкостью проносятся в небе, а цвет американских ВМС практически без сопротивления горит, взрывается и тонет, Лоуренс приходит к выводу: его сообществу кое-что придется переосмыслить.

В какой-то момент Лоуренс обжигает руку. Правую, что предпочтительно — он левша. К тому же он все явственнее осознает, что кусок «Аризоны» пытался снести ему часть черепа. По меркам Перл-Харбора это пустяки, и в госпитале его держат недолго. Доктор предупреждает, что кожа на руке может стянуться и ограничить движение пальцев. Как только Лоуренс в силах терпеть боль, он начинает играть «Искусство фуги» Баха на коленке все время, когда не занят чем-то другим. Можно вообразить, как старый Иоганн Себастьян сидит на скамейке холодным лейпцигским утром, один-два регистра блокфлейт открыты, толстый мальчишка-хорист качает меха, тихо сипит, выбиваясь из щелок, воздух, старец правой рукой бесцельно скользит по главному мануалу, трогая пожелтевшую, в мелких трещинках слоновую кость и подбирая мелодию, которой еще нет. Лоуренс повторяет движения Иоганна Себастьяна, хотя рука у него в бинтах, а вместо клавишей — перевернутый лоток, и музыку приходится мурлыкать себе под нос. Иногда он так увлекается, что дергает под одеялом ногой, нажимая невидимые педали; соседи ругаются.
Через несколько дней он выходит из госпиталя, как раз вовремя, чтобы заступить на новую службу — у него и у других музыкантов с «Невады» начинается военная жизнь. Очевидно, тем, кто в ВМС ведает распределением людских ресурсов, пришлось изрядно поломать голову. В смысле уничтожения японцев музыканты абсолютно бесполезны, после седьмого декабря у них нет даже боеспособного корабля, а многие и кларнеты растеряли.
Однако им не поручат давить на гашетку. Ни одна организация не в состоянии систематически убивать японцев, не печатая в большом объеме на машинке и не подшивая листы. Логично предположить, что человек, который играет на кларнете, не сумеет напортачить больше, чем любой другой. Уотерхауза и его товарищей прикомандировывают к одному из подразделений флота, отвечающих за делопроизводство.
Оно располагается в здании, не на корабле. Многие на флоте презирают тех, кто работает в здании. Лоуренс и некоторые другие салаги поспешили перенять эту манеру. Однако увидев, что происходит на корабле, когда на нем и вокруг детонируют сотни тонн взрывчатых веществ, Лоуренс и его товарищи умерили свой гонор. В здании, так в здании. Они прибывают на место несения службы, исполненные боевого духа.
Их новый командир, похоже, огорчен, и подобные чувства испытывает, судя по всему, остальное подразделение. Они ничуть не восхищаются парнями, которые до последнего времени служили на корабле и, более того, были очень близко ко всему, что горело, рвалось и т.п., причем не по чьему-нибудь недосмотру, а потому что злые люди нарочно это устроили. Хуже того, они явно считают, что Лоуренс с товарищами не достойны своих новых хрен знает каких обязанностей.
Мрачно, почти обреченно старший офицер и его подчиненные начинают рассаживать новоприбывших. Письменных столов на всех не хватает, а ведь каждому надо отыскать хотя бы стул за конторкой и крохотным столиком. В ход идет смекалка. Видно, что эти люди делают все от них зависящее в безвыходной ситуации.
Потом говорят о секретности. Очень долго. Музыкантов проверяют на умение правильно выбрасывать мусор. Это длится так долго, без всяких объяснений, что наводит на всякие мысли. Музыканты, сникшие было от холодного приема, обсуждают между собой, в какую операцию их включили.
Наконец однажды утром музыкантов собирают в классной комнате перед чистейшей доской. Лоуренс никогда не видел доску такой чистой. За последние несколько дней он вполне проникся паранойей секретности и понимает: это неспроста. В военное время к стиранию мела нельзя относиться шаляй-валяй.
Они сидят на маленьких стульях с прибитыми столиками — для правшей. Лоуренс кладет блокнот на колени, забинтованную правую руку — на столик и начинает играть «Искусство фуги», гримасничая и даже сопя от боли.
Кто-то дергает его за плечо. Лоуренс вскакивает и видит, что он единственный в комнате сидит: на палубе офицер. Лоуренс вскакивает и видит: офицер (если это офицер) одет не по форме. То есть совсем не по форме. Он в халате и курит трубку. Халат невероятно старый, но не застиранный, как больничный или гостиничный. Его явно не стирали давным-давно, а вот носили — в хвост и в гриву. Локти протерлись, правый рукав серый и лоснится — его много раз возили по листам бумаги, плотно исписанным чертежным карандашом. Махровая ткань как будто в перхоти, но не оттого, что у офицера сыплется с головы: чешуйки слишком крупные, слишком геометрические. Это картонные прямоугольнички и кружочки, выбитые из перфокарт и лент соответственно. Трубка давно погасла, однако офицер (или не офицер) и не думает ее зажигать. Трубка нужна, чтобы кусать; он вгрызается в чубук, словно пехотинец времен Войны Севера и Юга, которому ампутируют ногу.
Другой офицер (он удосужился побриться, принять душ и надеть форму) представляет человека в халате как каперанга Шойна, но Шойн в этом не участвует; он поворачивается к доске, спиной к слушателям. Халат у него на заду протерт до неприличия. Заглядывая в блокнот, он пишет на доске следующие числа:

К тому времени как на доске появляется четвертое или пятое число, волосы у Лоуренса на загривке уже шевелятся. После третьей группы он видит, что ни одно не превышает 26 — число букв в английском алфавите. Сердце у него колотится сильнее, чем когда японские бомбы неслись по параболе к сидящей на грунте «Неваде». Он вытаскивает из кармана карандаш. Бумаги под рукой нет, и он пишет цифры от 1 до 26 на поверхности стола.
К тому времени, как человек в халате дописывает последнюю группу цифр, Уотерхауз уже вовсю считает частоты встречаемости. Человек в халате говорит: «Вам это может показаться бессмысленным набором цифр, но для офицера японских ВМС они выглядели бы совершенно иначе». Потом он нервно смеется, грустно качает головой, решительно выставляет подбородок и выдает череду сильных выражений, ни одно из которых здесь неуместно.
Уотерхауз считает просто, сколько раз каждое число написано на доске. Получается вот что:

Самое интересное, что десять из возможных символов (1, 2, 4, 5, 7, 9, 10, 13, 24 и 26) не используются. В сообщении лишь 16 различных чисел. Если считать, что каждое из этих шестнадцати заменяет одну и только одну букву алфавита, то у сообщения (Лоуренс считает в уме) 111 136 315 345 735 680 000 возможных значений. Забавное число: начинается с четырех единиц, закачивается четырьмя нулями. Лоуренс хмыкает, утирает нос, считает дальше.
Чаще других встречается число 18. Вероятно, оно заменяет букву Е — самую распространенную в английском алфавите. Если 18 везде заменить на Е, то...
Ему придется переписать все сообщение, заменяя 18 на Е, и, возможно, совершенно впустую, если он угадал неправильно. С другой стороны, заставляя свой мозг читать 18 как Е — операция, которая представляется ему чем-то сходной с выбором новых регистров у органа, — он мысленно увидит на доске:

где только 10 103 301 395 066 880 000 возможных значений. Тоже забавное число из-за всех этих нулей и единиц — ничего не значащее совпадение.
— Искусство составления шифров называется криптографией, — говорит каперанг Шойн, — а искусство их взлома — криптоанализом. — Потом вздыхает, явно раздираемый противоречивыми чувствами, побеждает их и обреченно начинает обязательный разбор слов по корням, не то греческим, не то латинским. (Лоуренс не слушает, ему все равно, он только мельком видит на доске слово CRYPTO, написанное большими печатными буквами.)
Первая последовательность «19 17 17 19» необычна. 19, как и 8, второе по частоте встречаемости число в сообщении. 17 встречается в два раза реже. Не может быть четырех гласных или четырех согласных подряд (кроме как в немецком), то есть либо 17 — гласная, 19 — согласная, либо наоборот. Поскольку 19 встречается чаще (четыре раза), она скорее может оказаться гласной, чем 17 (которая встречается только дважды). После Е самая частая гласная — А. Пусть 17 — А, тогда получаем:

Что уменьшает число вариантов до всего лишь 841 941 782 922 240 000. Таким образом, поле возможных решений уже сужено на пару порядков!
Каперанг Шойн явно надорвался, рассказывая про корни. Почти мускульным усилием он заставляет себя перейти к историческому обзору КРИПТОЛОГИИ как союза криптографии и криптоанализа. Упоминает англичанина Джона Уилкинса и книгу «Криптономикон», которую тот написал много столетий назад, потом (видимо, не доверяя интеллектуальному уровню слушателей) перескакивает с Джона Уилкинса на Пола Ревира и его код «один с моря, два с суши»*. [Ревир, Пол (1735–1818) — борец за независимость Америки. За два дня до своей знаменитой ночной скачки, многократно воспетой в американской литературе, договорился о сигнале: на колокольне Старой Бостонской церкви должны были вывесить один фонарь, если англичане будут наступать с моря, и два — если с суши.] Даже отпускает математическую шуточку: это, мол, было одно из первых практических применений двоичной системы. Лоуренс честно гогочет и фыркает, саксофонист впереди сердито оборачивается.
Раньше Шойн говорил, что сообщение адресовано японскому флотскому офицеру — явная лажа, призванная заинтересовать музыкантов, которым до лампочки математика. В таком контексте естественно предположить, что первое слово в сообщении — ATTACK. В таком случае 17 — Т, 14 — С и 20 — К. Подставив, Лоуренс получает:

Все остальное настолько очевидно, что даже нет смысла записывать. Он вскакивает, не в силах усидеть, забывает про слабую ногу и с грохотом рушится через соседние столы.
— У вас что-то случилось, матрос? — спрашивает офицер в углу — один из тех, кто удосужился надеть форму.
— Сэр! Сообщение: «Атаковать Перл-Харбор декабря седьмого»! Сэр! — выпаливает Лоуренс и садится. Его колотит. Адреналин переполняет тело и мозг. Он мог бы задушить на месте двадцать борцов сумо.
Каперанг Шойн совершенно бесстрастен. Медленно сморгнув, он поворачивается к одному из подчиненных, который стоит у стены, сцепив руки за спиной.
— Дайте ему экземпляр «Криптономикона». И стол — поближе к кофеварке. А заодно присвойте сукину сыну очередное звание.

Насчет очередного звания оказалась не то такая военная шутка, не то очередное свидетельство умственного расстройства у каперанга Шойна. Не считая этой мелкой глупости, история Уотерхауза в следующие десять месяцев проста, как у сброшенной с пикирующего бомбардировщика бомбы. Преграды на его пути (одолеть «Криптономикон», взломать Метеорологический код ВМС Японии, взломать машинный шифр военного атташе, взломать Безымянный японский код армейского водного транспорта 3А, взломать код военного министерства Великой Восточной Азии) сдерживают его не больше, чем источенные червем деревянные палубы фрегата. Через пару месяцев он уже пишет новые главы в «Криптономикон».
О «Криптономиконе» говорят как о книге, но это не так. Это скорее все бумаги и заметки, скопившиеся в определенном углу в кабинете у каперанга Шойна за те примерно два года, что он работает на Станции Гипо* [«Гипо» у военных означает букву «Эйч». Сообразительный малый Уотерхауз догадывается, что должны существовать по меньшей мере еще семь: Альфа, Браво, Чарли и так далее.], как называется это место. Здесь все, что каперанг Шойн знает о дешифровке, то есть практически все, что известно Соединенным Штатам. Все мог бы уничтожить в минуты любой уборщик, вздумавший навести порядок. Вот почему офицеры Станции Гипо, коллеги Шойна, ввели строжайшие меры, запрещающие что-либо мыть или убирать в том крыле здания, где работает Шойн. Другими словами, они понимают, что «Криптономикон» жутко важен, и всячески его берегут. Некоторые и впрямь сверяются с этими заметками, расшифровывая японские сообщения или даже взламывая целые криптосистемы. Однако Уотерхауз первый, кто (поначалу) указывает на ошибки в записях Шойна, потом (вскоре) собирает кипу листов в нечто более упорядоченное и (со временем) начинает добавлять свое.
Однажды Шойн ведет его вниз, потом по длинному коридору без окон к стальной двери, которую сторожат дюжие мирмидоняне, и показывает вторую шикарнейшую штуку в Перл-Харборе — комнату, набитую техникой «Электрикал Тилл корпорейшн», которая используется для подсчета частот встречаемости букв в перехваченных японских сообщениях.
Самая же роскошная машина* [Допуская, что Алан не прав и человеческий мозг — не машина.] на станции «Гипо» — глубже в клоаке под зданием. Помещение, где она хранится, похоже на банковский сейф, только вдобавок начинено взрывчаткой, чтобы взлететь на воздух в случае японского вторжения.
Эту машину каперанг Шойн построил больше года назад для взлома японского шифра «Индиго». Судя по всему, к началу 1940 года каперанг Шойн был благополучным, уравновешенным молодым человеком, на которого вывалили огромные листы с цифрами, полученными станциями перехвата по всему Тихому океану (возможно, думает Уотерхауз, Альфа, Браво, Чарли и т. д.). Эти цифры — японские сообщения, зашифрованные, по косвенным признакам, с помощью машины. Однако про саму машину неизвестно ровным счетом ничего: используются ли в ней шестерни, поворотные переключатели, коммутаторная панель, их комбинация или какой-то иной механизм, до которого белые люди пока не додумались; сколько таких механизмов используется или не используется; как именно они работают. Кроме самого факта, что цифры эти, с виду совершенно случайные, переданы по радио (возможно, неправильно), у Шойна не было никаких, абсолютно никаких данных.
Тем не менее к середине 1940 года эта машина стояла в подвале на станции «Гипо». Стояла, потому что Шойн ее построил. Машина безошибочно расшифровывала каждое перехваченное японское сообщение с кодом «Индиго», а значит, являлась функциональным дубликатом японской шифровальной машины «Индиго», которую ни Шойн, ни какой другой американец не видел в глаза. Шойн построил ее, просто изучая громадные ряды по виду случайных цифр и применяя некий процесс индукции. Где-то по ходу дела он расшатал свою нервную систему и теперь примерно раз в две недели слетал с катушек.
К началу войны Шойн на инвалидности и глушит себя таблетками. Уотерхауз проводит с ним столько времени, сколько разрешают врачи, потому что убежден: все, что произошло в голове у Шойна между той минутой, когда на него вывалили груду цифр, и временем, когда он закончил строить машину, — пример невычислимой функции.
Примерно раз в месяц Уотерхаузу повышают допуск, пока он не достигает высочайшего мыслимого уровня (или так он по крайней мере думает), то есть Ультра-Мэджик. «Ультра» называют англичане сведения, полученные от взлома немецкой шифровальной машины «Энигма», «Мэджик» — американцы то, что дает им «Индиго». «Ультра-Мэджик» — переплетенная подшивка документов с чередующимися черными и красными абзацами на титульном листе. Параграф номер три гласит:
НЕ ПРЕДПРИНИМАТЬ НИКАКИХ ДЕЙСТВИЙ НА ОСНОВАНИИ ИЗЛОЖЕННОЙ ЗДЕСЬ ИНФОРМАЦИИ, НЕВЗИРАЯ НА ЛЮБЫЕ ВРЕМЕННЫЕ ВЫГОДЫ, ЕСЛИ В РЕЗУЛЬТАТЕ ТАКОВЫХ ДЕЙСТВИЙ НЕПРИЯТЕЛЬ СМОЖЕТ УСТАНОВИТЬ НАЛИЧИЕ ИСТОЧНИКА.
Вроде бы все ясно? Лоуренс Притчард Уотерхауз не так в этом уверен.
...ЕСЛИ В РЕЗУЛЬТАТЕ ТАКОВЫХ ДЕЙСТВИЙ НЕПРИЯТЕЛЬ СМОЖЕТ УСТАНОВИТЬ...
Примерно в это время Уотерхауз делает открытие относительно себя: ему лучше всего работается, когда не отвлекают посторонние мысли, то есть примерно день после семяизвержения. Так что в порядке исполнения долга перед Соединенными Штатами он начинает помногу бывать в борделях. Однако на жалованье ксилофониста особо не разбежишься, поэтому он ограничивается тем, что эвфемистично зовется массажем.
...В РЕЗУЛЬТАТЕ... ДЕЙСТВИЙ... УСТАНОВИТЬ...
Слова привязчивы, как триппер. Во время массажа он лежит на спине, закрыв руками лицо, и бормочет про себя. Что-то его грызет. Он знает: когда что-то вот так грызет, значит, он, вероятно, скоро напишет новую статью. Но прежде надо сделать кучу поденной умственной работы.
Его осеняет во время битвы за Мидуэй, когда они с товарищами проводят по двадцать четыре часа у машин ЕТК, расшифровывая переговоры Ямамото, сообщая Нимицу, где точно будет японский флот.
Какова вероятность, что Нимиц обнаружит флот случайно? Вот вопрос, который наверняка задаст себе Ямамото.
Все это (странное дело) — вопрос теории информации.
...ДЕЙСТВИЙ...
Что такое действие? Да что угодно. Это может быть нечто очевидное, скажем, разбомбить японский военный объект. Все согласятся, что это — действие. Однако изменить курс авианосца на пять градусов — или не изменить — тоже действие. Или выдвинуть к Мидуэю ровно такие силы, которые нужны, чтобы отбить японское нападение. Или что-то гораздо менее драматичное, скажем, отменить операцию. В определенном смысле действием может быть даже полное бездействие. Все это в какой-то мере рациональный ответ командования на ИЗЛОЖЕННУЮ ЗДЕСЬ ИНФОРМАЦИЮ, и любое из этих действий может быть замечено японцами. Насколько хорошо японцы умеют вычленять информацию из шума? Есть ли у них свои Шойны?
...СМОЖЕТ УСТАНОВИТЬ...
Что, если японцы догадаются? И при каких именно обстоятельствах они вычислят НАЛИЧИЕ ИСТОЧНИКА?
Предположим, действие не могло произойти, если бы американцы не взломали «Индиго», — тогда для японцев это четкое свидетельство его взлома. Наличие источника — машины, которую построил Шойн, — будет установлено.
Уотерхауз верит, что американцы — не идиоты. Но что, если все не так просто? Что, если действие крайне маловероятно без знания шифра? Что, если американцам слишком часто везет?
Насколько смело можно вести игру? Игральные кости со свинцом, в которых всегда выпадают шестерки, распознаются в несколько бросков. Кости, в которых шестерки выпадают на один процент чаще, чем в обычных, распознать труднее — их придется бросать много дольше.
Если японцы будут попадать в засаду, если их собственные засады будут обнаруживаться заранее, если их торговые корабли будут натыкаться на американские субмарины чаще, чем подсказывает обычная вероятность, — как быстро они это заметят?
Уотерхауз пишет докладную, теребит начальство вопросами. Потом, однажды, получает приказы.
Приказы приходят, зашифрованные группами по пять случайных с виду букв, отпечатанных на синей папиросной бумаге для совсекретных телеграмм. Сообщение зашифровано в Вашингтоне с использованием одноразового шифрблокнота — медленного и муторного, в теории, абсолютно стойкого шифра для наиболее важных сообщений. Уотерхаузу это известно, потому что он — один из двух человек в Перл-Харборе, допущенных к их расшифровке. Второй — каперанг Шойн, но он накачан транквилизаторами. Дежурный офицер открывает нужный сейф и достает сегодняшний одноразовый шифрблокнот — лист миллиметровки, покрытый пятерками чисел. Числа выбрал секретарь в Вашингтонском подвале, тасуя карточки или вытягивая фишки из шляпы. Один такой листок держит в руках Уотерхауз, с помощью другого зашифрованы приказы.
Уотерхауз берется за работу: вычитает шум из шифрограммы и получает открытый текст.
Первым делом он видит, что гриф на сообщении не «сов. секретно» и даже не «ультра», но что-то совершенно новое — «УЛЬТРА МЕГА».
Дальше предписывается, чтобы он — Лоуренс Притчард Уотерхауз, — тщательно уничтожив это сообщение, со всей возможной скоростью проследовал в Лондон. Ему будут предоставлены любые корабли, поезда, самолеты и даже подводные лодки. Оставаясь служащим ВМФ США, он получит дополнительный комплект форменной одежды — армейский — на случай, если это упростит ему задачу.
Главное — он никогда, ни при каких обстоятельствах не должен попадать в плен к неприятелю. В этом смысле война для Лоуренса Притчарда Уотерхауза внезапно заканчивается.

ПОТОМСТВО ОНАНА

Сеть вентиляционных шахт, огромная, как туннель под Ла-Маншем, и разветвленная, как всемирный Интернет, пронизывает толстые стены и потолки гостиницы. По приглушенному гулу можно догадаться, что где-то в ее недрах садятся реактивные самолеты, влачат цепи несчастные узники, извиваются клубки змей, кузнецы Железного Века молотят по наковальням. Рэнди знает, что система незамкнутая и сообщается с земной атмосферой, потому что внутрь сочатся уличные запахи. Вполне может быть, что в его комнату они попадают примерно за час. После двух недель в Маниле запахи служат для Рэнди чем-то вроде будильника. Он засыпает под запах выхлопных газов: транспортные условия в Маниле требуют, чтобы корабли загружались и разгружались строго по ночам. Манила раскинулась вдоль тихой спокойной бухты, которая служит неиссякаемым источником влажности; атмосфера — густая, полупрозрачная и теплая, как парное молоко — начинает светиться с восходом солнца. Полки бойцовых петухов в самодельных клетушках на каждой крыше, балкончике, в каждом дворе просыпаются и начинают кукарекать. Люди просыпаются и начинают жечь уголь. От запаха угольного дыма просыпается Рэнди.
Рэнди Уотерхауз в сносной физической форме, не более. Доктор, как заклинание, твердит, что надо сбросить двадцать фунтов, но не вполне понятно откуда — у него нет ни пивного брюха, ни жирных складок на талии. Вероятно, злосчастные фунты распределены по всему бочкообразному туловищу. Во всяком случае, так Рэнди говорит себе каждый день, стоя перед гостиничным зеркалом размером с рекламный щит. В их с Чарлин калифорнийском доме зеркал почти не было, и он едва не забыл, как выглядит. Сейчас он видит, что зарос атавистической шерстью. Борода блестит — в ней пробивается седина.
Каждый день Рэнди уговаривает себя сбрить бороду. В тропиках желательно по максимуму оголить кожу, потому что все время потеешь.
Раз, когда у них обедали Ави с женой, Рэнди сказал: «Я — борода, Ави — костюм», объясняя суть их деловых отношений, и дальше Чарлин понесло. Недавно она закончила статью, посвященную деконструкции бород. В частности, блистательно развенчала культуру ношения бород в американском высокотехнологическом сообществе — среди друзей Рэнди. Для начала она опровергла расхожее мнение, будто носить бороду — «естественнее» и проще, чем бриться; привела статистику, собранную научно-исследовательским отделом фирмы «Жиллетт», сколько времени ежедневно проводят в ванной бородатые и бритые мужчины. Разница оказалась в пределах погрешности. У Рэнди было множество возражений по поводу того, как собиралась эта статистика, но Чарлин не захотела слушать. «Это контринтуитивно», — заявила она.
От статистики Чарлин быстро перешла к сути: съездила в Сан-Франциско и закупила на несколько сот долларов порнографии для бритвенных фетишистов. Недели две Рэнди, возвращаясь домой, неизменно заставал ее перед телевизором с миской попкорна и диктофоном, за просмотром видеофильма, в котором острое лезвие скользит по влажной, намыленной коже. Она записала несколько длинных интервью с бритвенными фетишистами, которые подробно описали чувство наготы и уязвимости, вызываемое процессом бритья, и как это эротично, особенно пощечины или шлепки по свежевыбритой поверхности. В деталях сравнила изобразительный ряд бритвенно-фетишистского порно и рекламы бритвенных принадлежностей, которую крутят по общенациональным каналам во время футбольных матчей, и доказала, что они практически идентичны. (Пиратские кассеты с рекламой лезвий и крема для бритья можно купить в тех же магазинчиках, что и соответствующую порнуху.)
Чарлин собрала статистику по национальным отличиям в отращивании бород. У американских индейцев бород нет, у азиатов практически тоже. Африканцы — особый случай, потому что ежедневное бритье вызывает у них кожное раздражение. «Возможность по своей воле отпустить пышную бороду — естественная привилегия исключительно белых мужчин», — писала она.
Когда Рэнди прочел эту фразу, в голове у него включилась сирена и замигали красные лампочки.
«Однако это утверждение основано на определенной посылке. «Естественное» — социально сконструированный дискурс, не объективная реальность [множество ссылок]. Это вдвойне верно в случае «естественности» бород у определенного меньшинства американских мужчин. Homo sapiens эволюционировал в климатических зонах, где волосяной покров на лице не имел приспособительного значения. Появление групп, характеризующихся значительной бородатостью мужчин, возникает как адаптивная реакция на холодный климат. Этот климат не надвигался на ареалы обитания первобытного человека «естественным» образом, напротив, люди вторглись в географические регионы с преобладанием холодного климата. Географическая экспансия была чисто социо-культурным событием, следовательно, любую физическую адаптацию следует отнести к той же категории, в том числе и развитие лицевого волосяного покрова».
Чарлин опросила несколько сотен женщин. Все ответили, что предпочитают чисто выбритых мужчин бородатым или колючим. Короче, Чарлин доказала, что бородатость — просто один из элементов синдрома, тесно связанного с расистскими и сексистскими настроениями, и укладывается в общую картину эмоциональной закрытости, от которой так часто страдают партнерши белых мужчин, особенно технически ориентированных.
«Граница между Средой и Я — социальная кон[струкция]. Западная культура предполагает резкость и отчетливость такой границы. Борода — ее символ, метод дистанцирования. Сбрить бороду (или другие волосы на теле) значит символически уничтожить эту (в значительной степени показную) границу между Собой и Другим...»
И так далее. Статья была принята рецензентами на «ура» и вскоре опубликована в крупном международном журнале. На конференции «Война как текст» Чарлин делала доклад на смежную тему: «Небритость как явление в фильмах о Второй мировой войне». Работа о бородах произвела такой фурор, что три старейших университета страны наперебой предлагали Чарлин работу.
Рэнди не хотел переезжать на Восточное побережье. Хуже того, он носил бороду, из-за чего ему было страшно неудобно появляться с Чарлин. Он предложил ей выпустить пресс-релиз с заявлением, что каждый день бреет все остальное тело. Чарлин ответила, что не смешно. На середине перелета через Тихий океан он вдруг понял, что вся ее работа — иносказательное пророчество о будущем их отношений.
Теперь он собирается сбрить бороду. А может, заодно обрить наголо голову и грудь.
Он привык подолгу гулять. С точки зрения воинствующих поборников здорового образа жизни в Сиэтле и Калифорнии, это немногим лучше, чем (скажем) сидеть перед телевизором, курить одну за другой сигареты без фильтра и есть из бочонка околопочечный жир. Однако Рэнди продолжал каждый день совершать пешие прогулки, когда его друзья записывались в фитнесс-клубы и через месяц бросали. Для него это стало предметом гордости, и он не собирался отказываться от своих правил из-за того, что живет в Маниле.
Однако, черт возьми, здесь жарко. И без волос было бы лучше.

Из злополучной истории с программой Рэнди вынес два положительных момента. Во-первых, он понял, что не надо соваться в бизнес, пока хотя бы в общих чертах не поймешь, что это такое. Во-вторых, он крепко сдружился с Ави, который до конца сохранял порядочность и чувство юмора.
По совету адвоката (который к этому времени был главным его кредитором) Рэнди объявил личное банкротство и переехал с Чарлин в Центральную Калифорнию. Она защитилась и получила должность младшего преподавателя в одной из «Трех сестер». Рэнди поступил в соседнюю, думая защитить магистерскую по астрономии. Так он стал аспирантом, аспиранты же существуют не для того, чтобы учиться. Они нужны, чтобы избавить профессуру от утомительных повинностей, вроде того, чтобы учить студентов и заниматься наукой.
Через месяц Рэнди помог другому аспиранту справиться с простенькой компьютерной проблемой. Еще через месяц его остановил декан астрономического факультета и сказал: «А вы, оказывается, у нас компьютерный гений». В ту пору Рэнди был глуп и наивен. Он клюнул на лесть, хотя должен был похолодеть от ужаса.
Через три года он ушел с астрономического факультета без степени, с шестью сотнями долларов на банковском счете и хорошим знанием UNIX'a. Позже он подсчитал, что при растущих расценках на программирование факультет меньше чем за двадцать штук выдоил из него работы примерно на четверть миллиона долларов. Утешало одно: его знания уже не казались такими бесполезными. Астрономия компьютеризировалась, стало возможным управлять телескопом на другом материке или на орбите, набирая команды на клавиатуре и наблюдая за картинками на своем мониторе.
Рэнди теперь прекрасно разбирался в сетях. Годы назад он вряд ли нашел бы применение своим знаниям. Однако дело было на заре Всемирной Паутины, и время оказалось самое удачное.
Примерно тогда же Ави перебрался в Сан-Франциско и основал компанию, которая должна была превратить ролевые игры из университетской забавы в общедоступное развлечение. Рэнди взялся разработать техническую сторону. Он пытался сманить Честера, но тот уже трудился в крупной компании по разработке программного обеспечения в Сиэтле. Они с Ави взяли парня, работавшего в нескольких фирмах по производству видеоигр, потом еще пяток специалистов по железу и коммуникациям, набрали инвестиций, сделали рекламный прототип и, размахивая им, поехали в Голливуд. Там нашлись желающие дать десять миллионов долларов. После этого они сняли производственные площади в Гилрое, поставили там графические рабочие станции, наняли кучу толковых программеров, несколько художников, и работа закипела.
Через полгода их часто упоминали среди других восходящих звезд Силиконовой Долины. Фотографию Рэнди напечатал журнал «Тайм» в статье про Силивуд — растущий альянс Силиконовой Долины и Голливуда. Еще через год фирма рухнула.
То была эпопея, которую даже неинтересно рассказывать. В начале девяностых все верили, что технические гении Северной Калифорнии сольются в экстазе с творческими умами Калифорнии Южной, и родится нечто новое и блестящее. Вера эта основывалась на полном непонимании того, чем занимается Голливуд. На самом деле Голливуд — просто специализированный банк, консорциум крупных финансовых учреждений. Он нанимает творческую личность, обычно за бесценок, поручает ей создать продукт, а потом сбывает этот продукт по всему миру — в кино, на видео и как там еще можно — короче, на полную катушку. Цель — найти продукт, который будет приносить деньги долго после того, как творческой личности заплатят и скажут: вали, приятель. «Касабланка» собирает задницы на сиденья кинотеатров десятилетия после того, как Богарт получил гонорар и докурился до рака легких.
С точки зрения голливудских воротил технари Силиконовой Долины были всего лишь особо наивной разновидностью творческих личностей. Как только технология вышла на определенный уровень и появилась возможность продать ее крупной японской фирме, инвесторы нанесли Ави молниеносный и, судя по всему, любовно спланированный удар. Рэнди и остальным предложили выбор: они могут уйти сейчас и сохранить акции, пока те еще что-то стоят, а могут остаться. В таком случае их начнет саботировать пятая колонна, заранее внедренная на ключевые позиции. Одновременно свора адвокатов обложит их со всех сторон и потребует к ответу за промахи в руководстве, из-за которых дела фирмы круто пошли вниз.
Кое-кто из старой команды остался в качестве придворных евнухов. Большинство ушли сразу и тут же продали акции, понимая, что те будут только падать. Продажа технологии японцам выпотрошила и обескровила компанию, пустая кожура постепенно высохла и разлетелась по ветру.
До сих пор обрывки технологии то и дело всплывали в самых неожиданных местах, скажем, в рекламе новой платформы для видеоигр. У Рэнди всякий раз сжималось сердце. Когда все начало разваливаться, японцы пытались нанять его напрямую, и он даже заработал кое-какие деньги, летая на неделю-месяц консультантом. Однако у них не было того уровня программистов, чтобы удержать технологию на ходу, и ее потенциал остался нереализованным.
Так закончился для Рэнди второй опыт в бизнесе. Он заработал несколько сотен тысяч долларов и почти все вбухал в викторианский дом, где жили они с Чарлин. Деньги надо было куда-то девать, а вложение в дом создавало иллюзию безопасности, словно он только что добежал до заветной стенки в отчаянных салках с элементами боевого каратэ.
В следующие годы он администрировал компьютерную сеть «Трех сестер» — работа не денежная, но и не очень пыльная.

Рэнди всю жизнь без всякой злобы говорил людям, что они несут бред. В программировании без этого далеко не уедешь. Никто не обижался.
Приятели Чарлин точно обижались. И не на слова Рэнди, что они не правы, — нет, на само допущение, будто кто-то может быть прав или не прав. Поэтому в тот памятный вечер, когда позвонил Ави, Рэнди вел себя как обычно, то есть не участвовал в разговоре. В толкиновском, не в эндокринологическом или белоснежкином смысле, Рэнди — гном. У Толкина гномы — крепкие, немногословные, отчасти волшебные существа, которые проводят много времени в темноте, выковывая всякие красивые вещи, например Кольца Всевластия. Многие годы Рэнди успокаивал себя тем, что он — гном, до поры до времени спрятавший боевой топор и гостящий в Шире, среди болтливых хоббитов (приятелей Чарлин). Останься он в науке, эти люди с их разговорами казались бы ему значительными, однако там, откуда он пришел, никто давно не принимал их всерьез. Поэтому он просто молчал, потягивал вино, смотрел на прибой и старался не выдавать себя уж очень явно — то есть не мотать головой и не закатывать глаза.
Тут разговор коснулся Информационной Супермагистрали, и все взгляды, как прожекторы, обратились к Рэнди.
Доктор Г. Е. Б. Кивистик, пятидесятилетний профессор Йельского университета, имел что сказать по поводу Информационной Супермагистрали. Он только что прилетел из какого-то места, название которого звучало бы по-настоящему впечатляюще, если бы Кивистик не вворачивал его постоянно по поводу и без повода. Несмотря на финскую фамилию, он был британцем до мозга костей, какими бывают только небританские англофилы. Сюда он прибыл якобы на конференцию «Война как текст», на самом деле — чтобы переманить Чарлин к себе на работу. На самом-самом деле (как подозревал Рэнди) — чтобы ее трахнуть. Вероятно, это была неправда, и сие подозрение просто показывает, насколько Рэнди сдвинулся на этой почве. Доктора Г. Е. Б. Кивистика часто показывали по ящику. Доктор Г. Е. Б. Кивистик выпустил несколько книг. Короче, доктор Г. Е. Б. Кивистик излагал свои крайне негативные взгляды на Информационную Супермагистраль на протяжении куда большего числа эфирных часов, чем может получить человек, не обвиненный во взрыве детского сада.
Гном, гостящий в Шире, вероятно, частенько отсиживал бы на обедах, за которым нудные хоббиты важно вещают глупости. Этот гном умел бы тихо улыбаться про себя. Он знал бы, что всегда может вернуться в реальный мир, гораздо более обширный и сложный, чем представляется хоббитам, сразить парочку троллей и напомнить себе, что важно на самом деле.
По крайней мере так убеждал себя Рэнди, но в тот памятный вечер его заклинило. Отчасти потому что Кивистик был слишком велик и реален для хоббита — обладал куда большим влиянием во всамделишном мире, чем Рэнди когда-нибудь рассчитывал добиться. Отчасти потому, что чей-то муж, приятный, безобидный компьютерофил по имени Джон, решил поспорить с одним из утверждений Кивистика и схлопотал по носу. Запахло кровью.
Рэнди испортил отношения с Чарлин тем, что хотел детей. Дети — это проблемы; Чарлин, как и вся ее компания, проблем не выносила. Проблемы порождают разногласия. Высказанные разногласия — форма конфликта. Явный конфликт на людях — мужской способ общественного взаимодействия, фундамент патриархального общества и всех вытекающих бяк. Невзирая на это, Рэнди решил поспорить с доктором Г. Е. Б. Кивистиком по-мужски.
— Сколько бедных лачуг мы снесем, чтобы проложить Информационную Супермагистраль? — вопросил Кивистик. Эта мудрая мысль была встречена задумчивыми кивками.
Джон заерзал, как будто Кивистик бросил ему за шиворот кубик льда.
— Что это значит? — спросил он, улыбаясь, чтобы не выглядеть конфликтно-ориентированным патриархальным гегемонистом.
Кивистик в ответ поднял брови и огляделся, словно говоря: «Кто пригласил это ничтожество?» Джон попытался исправить тактическую ошибку. Рэнди зажмурился, чтобы не поморщиться. Джон столько на свете не живет, сколько Кивистик участвует в дискуссиях с действительно серьезными оппонентами.
— Ничего не придется сносить. Сносить-то нечего, — объявил Джон.
— Ладно, позвольте сказать иначе, — великодушно произнес Кивистик. Если некоторые идиоты не понимают, что ж, он готов снизойти до их уровня. — Сколько развязок соединят мировые гетто с Информационной Супермагистралью?
Все решили, что так гораздо понятнее. Браво, Геб! На бедного Джона никто не смотрел. Тот беспомощно взглянул на Рэнди, посылая сигнал бедствия.
Джон был хоббит, недавно побывавший за пределами Шира, и знал, что Рэнди — гном. Теперь он ломал Рэнди жизнь, призывая его вскочить на стол, сбросить домотканый плащ и выхватить двуручный топор.
Слова вырвались у Рэнди раньше, чем он успел усилием воли заткнуть себе рот.
— Информационная Супермагистраль — просто метафора! Может, хватит? — сказал он.
Наступила тишина. Все сидящие за столом поморщились в унисон. Обед был официально испорчен. Оставалось только обхватить руками щиколотки, вжать головы в колени и ждать, пока обвал прекратится.
— Это мало что говорит, — ответил Кивистик. — Все — метафора. Слово «вилка» — метафора для этого предмета. — Он поднял вилку. — Весь дискурс состоит из метафор.
— Это не повод использовать плохие метафоры, — сказал Рэнди.
— Плохие? Плохие? Кто решает, что плохо? — спросил Кивистик, убийственно изобразив ошалелого первокурсника. Раздались редкие смешки: всем хотелось разрядить обстановку.
Рэнди видел, что происходит. Кивистик выложил козырной туз: все относительно, есть просто различные точки зрения. Народ уже возобновил свои разговоры, считая, что конфликт исчерпан. И тут Рэнди заставил всех вздрогнуть.
— Кто решает, что плохо? — сказал он. — Я.
Даже доктор Г. Е. Б. Кивистик опешил. Он не понимал, шутит Рэнди или всерьез.
— Простите?
Рэнди не торопился отвечать. Он откинулся на стуле, потянулся, отхлебнул вина. Ему было хорошо.
— Все просто. Я прочел вашу книгу. Видел вас по телевизору. Я собственноручно отпечатал ваш послужной список, когда готовил материалы для конференции. Соответственно, я знаю, что вы не вправе высказываться по вопросам техники.
— А, — произнес Кивистик в притворном смущении. — Не знал, что это позволено лишь избранным.
— По-моему, ясно, — сказал Рэнди. — Если вы некомпетентны в определенном вопросе, то вашему мнению — грош цена. Когда я болею, я не прошу совета у слесаря, я иду к врачу. Если у меня вопросы про Интернет, я обращаюсь к специалистам.
— Забавно, как все технократы любят Интернет, — бодро заметил Кивистик, выдоив из собравшихся еще несколько смешков.
— Вы только что сделали явно неверное утверждение, — приятным голосом ответил Рэнди. — Многие специалисты по Интернету в своих книгах убедительно его критикуют.
Наконец-то он утер Кивистику нос. Всякое веселье исчезло.
— Следовательно, — сказал Рэнди, — возвращаясь туда, откуда мы начали, Информационная Супермагистраль — плохая метафора для Интернета, потому что я так говорю. На планете примерно тысяча человек знают Интернет так, как я, — по большей части мои знакомые. Никто из них не принимает эту метафору всерьез. Q. E. D.
— А, ясно, — произнес Кивистик немного запальчиво. Он увидел щель. — Значит, технократы должны нас научить, что и как думать о технологии?
Судя по выражению лиц, это был мощный удар возмездия.
— Не знаю точно, кто такие технократы, — сказал Рэнди. — Я — технократ? Я просто человек, который пошел в магазин, купил пару справочников по протоколу TCP/IP, на котором строится Интернет, и прочел. Потом я сел за компьютер, что в наше время может каждый, провозился несколько лет и теперь знаю об этом все. Значит ли это, что я — технократ?
— Вы принадлежали к технократической элите еще до того, как купили справочники, — объявил Кивистик. — Способность понять технический текст — привилегия. Она дается образованием, которое доступно лишь членам элиты. Вот какой смысл я вкладываю в слово «технократ».
— Я ходил в государственную школу, — парировал Рэнди. — Окончил государственный университет. Дальше я — самоучка.
Тут вмешалась Чарлин. С самого начала разговора она угрожающе поглядывала на Рэнди, однако он не обращал внимания. Теперь пришел час расплаты.
— А твоя семья? — спросила Чарлин ледяным тоном.
Рэнди набрал в грудь воздуха, перебарывая желание вздохнуть.
— Мой отец — инженер. Преподает в государственном колледже.
— А его отец?
— Математик.
Чарлин подняла брови. Почти все остальные — тоже.
— Я категорически против того, чтобы меня травили, обвешивали ярлыками и клеймили «технократом». — Рэнди сознательно использовал фразеологию притесняемых меньшинств, отчасти, чтобы сразить врага его же оружием, отчасти (думает он в три часа ночи, лежа в гостинице «Манила») из желания поговниться. Некоторые по привычке сделали постные лица — этикет требует сочувствия к притесненным. Остальные задохнулись от возмущения, слыша такие слова из уст уличенного белого мужчины-технократа.
— Ни у кого в моей семье не было ни власти, ни денег, — сказал Рэнди.
— Думаю, Чарлин говорит вот о чем, — вставил Томас (он прилетел из Праги с женой Ниной, жил у Рэнди дома и сейчас решил взять на себя роль миротворца). Он выдержал паузу, чтобы ласково переглянуться с Чарлин. — Вы принадлежите к привилегированной элите просто потому, что происходите из семьи потомственных ученых. Члены привилегированных элит редко осознают свои привилегии.
Рэнди закончил его мысль:
— Пока не приходят такие, как вы, и не объясняют, какие мы тупые и морально разложившиеся.
— Именно ложное самовосприятие, о котором говорит Томас, и делает властные элиты такими недоступными, — припечатала Чарлин.
— Ну, я не чувствую себя таким уж недоступным, — сказал Рэнди. — Я пахал как ишак, чтобы стать тем, кто я есть.
— Многие люди тяжело трудятся всю жизнь и ничего не достигают, — вставил кто-то.
Берегись! Начался обстрел!
— Что ж, я виноват, что имел наглость чего-то достичь, — ответил Рэнди, впервые с начала разговора начиная заводиться, — но я понял, что если много работать, заниматься самообразованием и шевелить мозгами, можно пробиться в жизни.
— Ну, это прямо из какого-нибудь нравоучительного романа века так девятнадцатого, — вставил Томас.
— И что? Если идея старая, это не значит, будто она неверная, — ответил Рэнди.
Небольшой ударный отряд с подносами взял стол в окружение. Официанты переглядывались, решая, можно ли вмешаться в конфликт и подать обед. Один из них осчастливил Рэнди тарелкой с вигвамом из почти сырого тунца. Миролюбивые силы перехватили контроль над разговором и разбились на кучки, в которых все со всеми усиленно соглашались. Джон посмотрел на Рэнди собачьими глазами, словно спрашивая: «Ты ведь это и ради себя тоже?» Чарлин старательно его не замечала, включенная в консенсус-группу с Томасом. Нина, напротив, старалась встретиться с Рэнди глазами, но Рэнди на нее не смотрел, опасаясь страстного взгляда «иди сюда», потому что хотел одного: как можно скорее выйти отсюда. Через десять минут зазвонил пейджер. Рэнди посмотрел вниз и увидел номер Ави.

ГАРЬ

После японской бомбежки американская база в Кавите, на берегу Манильской бухты, горит знатно. Бобби Шафто и остальной четвертый полк МПФ успевают налюбоваться пожаром, пока корабль украдкой скользит мимо. Из Манилы драпают ночью, как воры. Никогда в жизни он не чувствовал себя настолько оплеванным, и остальные морпехи тоже. Японцы уже высадились в Малайе и прут на Сингапур, как взбесившийся паровоз; обложили Гуам, Уэйк, Гонконг и хрен еще знает что. Всем ясно, что следующая цель — Филиппины. Казалось бы, полк морской пехоты здесь пригодится.

Предыдущая страница 4 Следующая страница


5 Нил Стивенсон

Однако Макартур, видать, считает, что может защитить Лусон в одиночку, стоя на стенах Интрамурос с кольтом сорок пятого калибра. Морскую пехоту сплавили. Куда — неизвестно. Многие охотнее ударили бы на Японию, чем оставаться здесь, с армией.
В ночь, когда началась война, Бобби Шафто впервые возвратил Глорию в лоно семьи.
Род Альтамира живет в Малате, милях в двух к югу от Интрамурос, недалеко от того места, где Шафто с Глорией провели свои полчаса у набережной. Город обезумел, такси поймать невозможно. Матросы, морпехи, солдаты высыпают из баров, ночных клубов, танцзалов и пачками хватают такси. Полное сумасшествие, просто какая-то субботняя ночь в Шанхае — как будто война уже здесь. В конце концов Шафто полдороги несет Глорию на себе, потому что ее туфли не предназначены для ходьбы.
Альтамира настолько многочисленны, что могли бы сами по себе составить этническую группу, но все живут в одном доме и практически в одной комнате. Раз или два Глория начинала объяснять Шафто, кто в каком родстве состоит. Так вот, у Шафто тоже много родственников — по большей части в Теннеси, — однако его фамильное древо можно уместить на тетрадном листке в мелкую клетку. Рядом с фамильным древом Альтамира оно смотрелось бы, как одинокий росток в джунглях. Филиппинские семьи, мало что большие и католические, еще и переплетены, как лианами, отношениями крестные-крестники. Только попроси, и Глория охотно, даже с жаром начнет рассказывать, кто из Альтамира кому кем приходится, и это будет только общий обзор. Мозги у Шафто, как правило, отключаются в первые же тридцать секунд.
Он вносит ее в дом, где гвалт стоит всегда, а не только накануне военного вторжения со стороны Японской империи. Тем не менее, когда Глория появляется на руках у морского пехотинца США в первый час после объявления войны, все ведут себя так, будто среди комнаты материализовался Христос с девой Марией через плечо. Повсюду пожилые женщины простираются ниц, словно пустили горчичный газ. Однако они просто возносят хвалу Господу! Глория ловко спрыгивает на высокие каблуки — слезы исследуют безупречную геометрию ее щек — и целует всех членов рода. Три часа ночи, но все дети на ногах. Шафто видит взвод мальчишек лет примерно от трех до десяти. Все они потрясают деревянными мечами и ружьями. Все таращатся на Шафто в умопомрачительной форме, и все как громом поражены; он мог бы забросить по баскетбольному мячу в рот каждому. Уголком глаза он видит пожилую женщину, состоящую с Глорией в немыслимо сложном родстве и уже со следами ее помады на щеке. Женщина движется наперехват с явным намерением облобызать. Шафто понимает, что вырвется сейчас или никогда. Не обращая внимания на женщину и по-прежнему глядя только на мальчишек, он замирает по стойке «смирно» и отдает честь. Мальчишки козыряют, вразнобой, но очень молодцевато. Бобби Шафто поворачивается на каблуках и строевым шагом выходит в дверь. Он думает, что вернется в Малате завтра, когда все немного успокоится, проведает Глорию и ее близких. Больше он ее не увидит.
Он возвращается на корабль. Все увольнения отменены. Ему удается поговорить с дядей Джеком, который подходит на моторке, так что можно перекрикиваться. Дядя Джек — последний из манильских Шафто. Эта ветвь семьи берет начало от Нимрода Шафто, из Теннесийских Добровольцев. Какой-то филиппинский повстанец под Кигуа прострелил Нимроду правую руку. Очнувшись в манильском госпитале, старый Нимрод, или Левша, как звали его с тех пор, понял, что ему нравится мужество филиппинцев, ради убийства которых пришлось изобрести новый мощный класс револьверов (кольт 45-го калибра). Более того, ему понравились их женщины. Нимрода тут же комиссовали. Выяснилось, что на военную пенсию по инвалидности в местной экономике много что можно сделать. Он занялся экспортной торговлей на берегу реки Пасиг, нашел себе жену — наполовину испанку, родил сына (Джека) и двух дочерей. Дочери со временем уехали в Штаты, в Теннеси, где Шафто обитали с тех самых пор, как в 1700-х освободились от кабального контракта, по которому попали в Америку. Джек остался в Маниле и унаследовал отцовское дело, но так и не женился. По манильским стандартам он неплохо зарабатывал и всегда оставался чем-то средним между просоленным морским волком и надушенным денди. С мистером Паскуалем они были партнерами лет сто. Так Бобби Шафто познакомился с мистером Паскуалем и так впервые увидел Глорию.
Когда Бобби Шафто сообщает последние слухи, у дяди Джека вытягивается лицо. Никто не хочет верить, что скоро на остров нападут японцы. Его следующие слова должны быть: «Пропади все пропадом, я сваливаю отсюда, пришлю открытку из Австралии». Вместо этого он говорит: «Через пару дней загляну тебя проведать».
Бобби Шафто прикусывает язык и не говорит, что думает, а именно, что он морпех, и на корабле, и сейчас война, а в военное время морпехи на корабле редко остаются на одном месте. Он просто стоит и смотрит, как дядя Джек пыхтит прочь на моторной лодке, снова и снова поворачиваясь, чтобы помахать модной панамой. Матросы вокруг Шафто смотрят, посмеиваясь, но с некоторым восхищением. Вода кишит шлюпками: все военное оборудование, которое не вмуровано в бетон, грузят на корабли и везут на Батаан или Коррехидор, а дядя Джек в бежевом костюме и панаме стоит в полный рост и с апломбом лавирует между шлюпками. Бобби Шафто провожает его глазами, пока моторка не исчезает за изгибом реки Пасиг, и думает, что он, наверное, последний в семье видит дядю Джека живым.
Несмотря на все приготовления, отбытие застигает его врасплох. Корабль среди ночи сходит со стапелей без традиционных прощальных церемоний. Считается, что в Маниле полно японских шпионов, а для нипов милое дело — потопить полный корабль опытных морских пехотинцев.
Манила исчезает в тумане. Мысль, что он с той ночи не видел Глорию, — словно медленное сверло дантиста. Как она там? Может, все постепенно устаканится, фронты определятся и он добьется назначения в эту часть света? Старый черт Макартур будет стоять насмерть, и даже если Филиппины падут, Франклин Делано Рузвельт не оставит их надолго в руках врагов. Если повезет, месяцев через шесть Бобби Шафто будет идти маршем по Тафт-авеню Манилы, вслед за оркестром; может, с одним-двумя пустяковыми боевыми ранениями. Колонна достигнет участка улицы, где, растянувшись почти на полмили, выстроились Альтамира. На середине пути толпа расступится, Глория выбежит, вспрыгнет ему на руки и покроет его жаркими поцелуями. Он внесет ее по ступенькам в маленькую уютную церковь, где священник в белом облачении будет ждать с улыбкой на лице... Грезы рассеиваются в грибе оранжевого пламени над американской военной базой. Она горела весь день, и сейчас просто рванула очередная цистерна с горючим. Жар чувствуется за мили. Бобби Шафто на корабле, в спасжилете на случай, если их торпедируют. В свете взрыва он оборачивается на товарищей. Все они, тоже в спасжилетах, с застывшими усталыми лицами, смотрят на пламя.
Манила в полумиле за кормой, но с тем же успехом до нее может быть тысяча миль.
Он помнит Нанкин и что устроили там японцы. Что было с женщинами.
Когда-то, давным-давно, был город, и он звался Манила. Там жила девушка. Ее имя и лицо лучше забыть. Бобби Шафто начинает забывать изо всех сил.

ПЕШЕХОД

«УВАЖАЙ ПЕШЕХОДА» — гласят уличные знаки в Маниле. Как только Рэнди их видит, он понимает, что дело плохо.
Первые две недели жизни в Маниле его работа заключалась в ходьбе. Он ходил по городу с портативной джи-пи-эской, замерял широты и долготы. В гостиничном номере шифровал данные и по электронной почте отправлял их Ави. Они становились частью интеллектуальной собственности компании «Эпифит». Ее активами.
Теперь, сняв офисное помещение, Рэнди упрямо ходит туда пешком. Он знает: стоит один раз взять такси, и с прогулками покончено.
«УВАЖАЙ ПЕШЕХОДА» — гласят знаки, но водители, среда обитания, местные правила землепользования, сама планировка города — все обливает пешехода заслуженным презрением. Рэнди больше бы уважали, если бы он ходил в офис на ходулях и в тюбетейке с пропеллером. Каждое утро портье спрашивает, вызвать ли такси, и всякий раз едва не падает в обморок, услышав отказ. Каждое утро перед отелем таксисты, облокотись на капот и куря, кричат ему: «Такси? Такси?» Когда он отказывается, они острят между собой на тагальском и громко хохочут.
На случай, если Рэнди еще не все понял, новенький белый с красным вертолет спускается над парком Рисаля, поворачивает раз или два на месте, как собака, выбирая лежку, и зависает недалеко от пальм прямо перед входом в гостиницу.
У Рэнди вошло в привычку идти к Интрамурос через парк Рисаля. Это не самый короткий путь. Самый короткий — через ничейную территорию, большой опасный перекресток, облепленный самодельными лачугами безработных (опасны машины, не безработные). С другой стороны, по пути через парк достаточно отбиться от легиона проституток. Впрочем, Рэнди это нетрудно. Проститутки не могут уяснить, почему богатый человек, живущий в гостинице «Манила», каждый день по собственной воле ходит пешком. Они отступились, сочтя его психом. Он перешел в разряд иррационального, того, что принимают на веру, а на Филиппинах эта категория практически безгранична.
Рэнди не мог взять в толк, откуда так воняет, пока не заметил в тротуаре большую прямоугольную дыру и, заглянув туда, не увидел стремительный поток нечистот. Тротуар просто закрывает канализацию. Доступ к ней обеспечивают бетонные плиты, в которые вмурованы стальные скобы. Сквоттеры прилаживают к скобам проволочные ручки, чтобы в любой момент поднять плиту и устроить общественную уборную. На плитах выдавлены инициалы, названия бригад или метка изготовителя; умение и проработанность деталей варьируют, но рвение неизменно на высоте.
Число ворот в Интрамурос ограничено. Рэнди каждый день рискует напороться на извозчика. Иным из них больше нечего делать, кроме как минут по пятнадцать тащиться следом, повторяя: «Сэр? Сэр? Такси?» Один так просто демонстрирует чудеса предприимчивости. Стоит его лошади поравняться с Рэнди, как она пускает струю. Моча, шипя и пенясь, бьет в мостовую. Капли попадают на штанины. Рэнди всегда ходит в длинных брюках, как бы ни было жарко.
Интрамурос — район на удивление дремотный, главным образом потому, что с войны так и лежит в руинах. Странно видеть заросшие сорняками пустыри посреди большого, густонаселенного города.
В нескольких милях южнее по направлению к аэропорту, среди красивых многоэтажных зданий раскинулся Макати: шикарные пятизвездочные отели по два на квартал, чистые и прохладные с виду офисные небоскребы, современное жилье. Здесь могла бы разместиться корпорация «Эпифит». Однако Ави с его извращенным чувством недвижимости пренебрег всем этим ради того, что по телефону назвал «колоритом». «Не люблю покупать или арендовать недвижимость, когда ее цена на пике», — сказал он.
Разбираться в мотивах Ави — все равно что чистить луковицу зубочисткой. Рэнди понимает, что все не так просто. Может быть, Ави оказывает услугу или платит за услугу арендодателю. Может быть, он начитался какого-нибудь гуру по менеджменту, который советует начинающим предпринимателям глубже вживаться в культуру страны. Впрочем, Ави не из тех, кто верит в такие книжки. Последняя гипотеза Рэнди, что все связано с линиями прямой видимости — широтами и долготами.
Иногда Рэнди ходит по старой испанской стене. Над Калле Виктория, где перед войной был штаб Макартура, она шириной с четырехрядное шоссе. Влюбленные прячутся в амбразурах, закрываясь зонтиками от посторонних глаз. Слева внизу ров шириною в пару городских кварталов, по большей части сухой. Безработные понастроили в нем лачуг. Там, где еще стоит вода, они ловят крабов или натягивают самодельные сети между пурпурными и малиновыми цветами лотоса.
Справа Интрамурос. Над россыпью камней торчат несколько зданий. Старинные испанские пушки наполовину ушли в землю. На камнях обитают тропические растения и безработные. Шесты для сушки белья и телевизионные антенны заплетены лианами и самодельной проводкой. Столбы электропередачи торчат под всевозможными углами, как покосившиеся деревья в лесу, некоторые сплошь облеплены стеклянными пузырями счетчиков. Через каждые несколько ярдов куча мусора дымится без всякой видимой причины.
Возле церкви за Рэнди увязываются дети. Они жалобно причитают, пока он не раздает им песо. Тогда они расплываются в улыбке и порой весело отвечают «Спасибо» на превосходном американском английском. Манильские нищие относятся к своему ремеслу без лишней серьезности, как будто заражены социальным грибком иронии, и постоянно прячут улыбку, не веря, что заняты чем-то настолько банальным.
Они не понимают, что он работает.
Идеи всегда посещали Рэнди чаще, чем он успевал их реализовать. Первые тридцать лет жизни он разрабатывал идеи, которые казались наиболее интересными, и бросал их, как только возникали новые, еще более многообещающие.
Теперь он снова в фирме и в некотором роде обязан работать продуктивно. Хорошие идеи рождаются с прежней частотой, но надо держать себя в руках. Если идея не нужна «Эпифиту», ее следует временно забыть. Если нужна — не бросаться в нее с головой, а разобраться, не додумался ли до этого кто-нибудь другой. Может, проще купить технологию? Нельзя ли поручить работу контрактному программисту в Штатах?
Он идет медленно, отчасти потому, что иначе его хватит инфаркт. Хуже того, он может провалиться в открытый канализационный люк или задеть электропроводку сквоттеров, которая затаившейся гадюкой болтается над головой. Постоянная опасность получить смертельный удар током или утонуть в жидком дерьме заставляет его то и дело смотреть вверх, вниз и по сторонам. Никогда еще Рэнди не оказывался настолько зажат между непредсказуемыми небесами и адской бездной. Манила пропитана религией, как Индия, и вся эта религия — католическая.
В северной части Интрамурос — маленький деловой район. Он втиснут между Манильским собором и фортом Сантьяго, построенным испанцами для защиты устья реки Пасиг. То, что это деловой район, можно понять по пучкам телефонных проводов. Как во всех быстроразвивающихся азиатских странах, трудно сказать, пиратские это провода или погано протянутые официальные. Наглядно видно, чем плох чисто количественный рост: пучки местами толще, чем в человеческий обхват. Столбы кренятся под их тяжестью, особенно на поворотах, где натяжение больше.
Все здания построены самым дешевым мыслимым способом: бетон заливают на месте в деревянные опалубки на собранные вручную решетки из стальных прутьев. Дома прямоугольные, серые, совершенно безликие. Поблизости несколько зданий повыше, в двадцать — тридцать этажей, ветер и птицы гуляют в выбитых окнах. Их так и не восстановили после сильного землетрясения в восьмидесятых.
Рэнди проходит мимо ресторанчика, перед которым торчит бетонная будка. Окна и двери забраны почерневшими стальными решетками, на крыше — выхлопные трубы дизельного генератора. Надпись по трафарету гордо гласит: «У НАС ВСЕГДА СВЕТЛО». Дальше послевоенное офисное здание, четырехэтажное — к нему тянется особо толстый пук телефонных проводов. На фасаде — логотип банка. Перед зданием — парковка. Два места у въезда загорожены корявыми табличками: «Только для бронированного автомобиля» и «Только для управляющего банком». На входе двое охранников сжимают толстые деревянные рукоятки помповых ружей — огромных, карикатурных, похожих на бутафорские. Еще один охранник за пуленепробиваемым стеклом с надписью: «Просьба сдать огнестрельное оружие».
Рэнди кивает охранникам и заходит в вестибюль. Там так же жарко, как и снаружи. Рэнди проходит мимо банка, мимо ненадежных лифтов, открывает стальную дверь и оказывается на узкой винтовой лестнице. Сегодня здесь темно. Электроснабжение в здании лоскутное: несколько систем сосуществуют в одном пространстве, контролируются разными щитами, часть работает от генератора, часть нет. Соответственно, свет гаснет то в одних помещениях, то в других. Где-то на верху лестницы чирикают птички, пытаясь перекричать противоугонную сигнализацию машин на стоянке.
Корпорация «Эпифит» арендует весь верхний этаж, хотя пока здесь обретается один Рэнди. Он отпирает дверь ключом. Слава богу, кондиционер работает. Не зря они платят за отдельный генератор. Рэнди отключает сигнализацию, идет к холодильнику и вынимает две литровые бутылки с водой. Его эмпирическое правило — после прогулки пить, пока не потянет в туалет. После этого можно думать обо всем остальном.
Он так вспотел, что не может сесть и должен ходить, чтобы прохладный воздух обтекал тело. Рэнди стряхивает капельки с бороды и совершает обход, выглядывая в окна и проверяя линии прямой видимости. Вытаскивает из-под одежды баллистический «набрюшник» и оставляет болтаться на ремне, чтобы кожа под ним могла дышать. В «набрюшнике» паспорт, девственная кредитная карточка, десять хрустящих стодолларовых купюр и дискета с 4096-битным ключом.
К северу он созерцает луга и укрепления форта Сантьяго, где трудятся фаланги японских туристов, документируя свой отдых с тщательностью судебных экспертов. Дальше река Пасиг, задыхающаяся под плавучим сором. Потом растущий район Киапо, высокие жилые дома и офисные здания, расцвеченные логотипами фирм и утыканные спутниковыми тарелками.
Останавливаться по-прежнему не хочется. Рэнди обходит офис по часовой стрелке. Интрамурос опоясан кольцом зелени — бывшим рвом. По его западному краю Рэнди только что шел. Восточный край усеян громоздкими неоклассическими зданиями министерств. Управление связи и телекоммуникаций — на повороте реки Пасиг, отсюда расходятся радиусами три моста в Киапо. За высотными зданиями Киапо и соседним районом Сан-Мигуэль — чересполосица крупных учреждений: вокзал, старая тюрьма, несколько университетов и президентский дворец Малаканьян выше по течению.
С этой стороны реки на первом плане Интрамурос (церкви в окружении сонной зелени), на втором — правительственные учреждения, колледжи и университеты, а дальше, в низине, затянутый дымкой город. Дальше на юг — деловой район Макати, в его центре — площадь на пересечении шоссе, которому вторит такой же перекресток еще южнее, перед аэропортом. За Макати — изумрудный город больших, окруженных газонами домов, здесь живут послы и президенты компаний. Продолжая обход, Рэнди видит набережную и бульвар Рохаса, обсаженный высокими пальмами. Манильская бухта забита кораблями, их корпуса — как бревна в боковом ограждении. Западнее — грузовой порт, ровные ряды складов на осушенной территории, плоской и неестественной, как кусок ДСП.
За кранами едва различим гористый силуэт полуострова Батаан. Если двигаться взглядом по его гребню, вдоль тропы, которой шли в 42-м японцы, можно увидеть нашлепку за южным концом. Это, должно быть, остров Коррехидор. Рэнди видит его впервые: сегодня на удивление чистый воздух.
В расплавленном мозгу всплывают обрывки исторических сведений. Галеон из Акапулько. Сигнальный огонь на Коррехидоре.
Он звонит Ави на мобильный. Ави, где-то в мире, отвечает. Судя по звукам, он в такси, в одной из тех стран, где водители до сих пор сигналят сколько душе угодно.
— Что у тебя?
— Линии прямой видимости, — говорит Рэнди.
— Фу-ух! — выдыхает Ави, как будто ему залепили мячом в живот. — Вычислил.

ГУАДАЛКАНАЛ

Тела рейдеров морской пехоты уже не расправляются под напором крови и воздуха. Вес снаряжения вплющивает их в песок, усилившийся прибой заметает илом, кометные хвосты крови расплываются в море красными ковровыми дорожками для акул. Лишь одна из них — исполинская ящерица, но все они одинаковой обтекаемой формы: утолщенные посередине, суживающиеся к концам.
Небольшой конвой японских катеров движется проливом, таща баржи с припасами, упакованными в стальные бочки. Сейчас Шафто и его взвод должны по плану поливать их из минометов. Потом американские самолеты накрыли бы катера огнем, японцы сбросили бы бочки в море, надеясь, что их прибьет волнами к Гуадалканалу, и драпанули.
Бобби Шафто отвоевался, не в первый и вряд ли в последний раз. Он обходит взвод. Волны бьют в колени, растекаются волшебным ковром пены и растительного вещества, скользящим по песку, так что кажется, будто почва убегает из-под ног. Шафто каждую минуту беспричинно оборачивается и плюхается на задницу.
Наконец он добирается до мертвого санитара и снимает с него все, помеченное красным крестом, поворачивается спиной к японскому конвою и смотрит на береговой склон. С тем же успехом он мог бы смотреть на гору Эверест из нижнего альплагеря. Шафто решает одолевать подъем на четвереньках. Волны то и дело догоняют его сзади, сладострастно пробегают между ног и плещут в лицо. Это приятно, к тому же помогает не рухнуть ничком и не уснуть прямо здесь, в зоне прилива.
Следующие несколько дней — стопка замусоленных, выцветших черно-белых фото, тасуемых снова и снова: пляж под водой, положение тел отмечено стоячими волнами. Берег пуст. Берег снова под водой. Берег в черных буграх, как ломоть домашней булки с изюмом, какую пекла бабушка Шафто. Пузырек с морфием наполовину занесен песком. Маленькие черные люди, по большей части голые, идут по пляжу, обшаривая трупы.
Эй, погодите! Шафто снова на ногах, сжимает «спрингфилд». Джунгли не хотят его отпускать; пока он лежал, ползучие плети успели обвить ноги. Когда он встает, таща за собой побеги, словно серпантин на торжественной встрече ветерана, солнце заливает его сиропом рвотного корня. Земля устремляется навстречу. Он разворачивается в падении, видит здоровенного мужика с винтовкой и плюхается мордой в сырой песок. В голове ревет прибой; студийная аудитория ангелов, которые по собственному опыту способны оценить хорошую смерть, рукоплещет стоя.
Маленькие руки перекатывают его на спину. Один глаз напрочь залеплен песком. Шафто смотрит вторым, видит над собой верзилу с винтовкой через плечо. У верзилы рыжая борода, так что вряд ли это японец. Но кто тогда?
Он щупает, как врач, и молится, как священник. Даже на латыни. Седые волосы сострижены почти под ноль, так что просвечивает загорелая кожа. Шафто оглядывает одежду, ища форменные нашивки. Надеется увидеть «Semper Fidelis», но вместо этого читает «Societas Eruditorum» и «Ignoti et quasi occulti».
— Игноти эт... что за херня? — спрашивает он.
— Скрытые и как бы сокровенные — примерно так, — отвечает Рыжий. У него странный акцент, отчасти австралийский, отчасти немецкий. В свою очередь изучает нашивки Шафто. — Что такое рейдер МПФ? Что-то новенькое?
— Тот же морпех, только еще хлеще, — говорит Шафто. Отчасти это бравада. Однако фраза переполнена иронией, как одежда Шафто — песком, потому что в данный исторический момент морпех — не просто лихой малый. Это лихой малый у черта на рогах (Гуадалканал), без еды и оружия (по милости, это вам любой морпех скажет, генерала Макартура, язви его в душу), использующий любые подручные средства, половину времени дурной от болезней и лекарств, призванных эти болезни побеждать. И в любом из этих смыслов рейдер морской пехоты (как говорит Шафто) — тот же морпех, только хлеще.
— Ты вроде десантника, что ли? — спрашивает Шафто, перебивая бормотания Рыжего.
— Нет. Я живу в горах.
— Да? И что ты там делаешь, Рыжий?
— Наблюдаю. И говорю по рации шифром. — Снова начинает бормотать.
— С кем ты говоришь, Рыжий?
— Сейчас по-латыни или по рации шифром?
— И то, и другое, наверное.
— По рации шифром — с нашими.
— С кем с нашими?
— Долго объяснять. Если выживешь, может, познакомлю с кем-нибудь из них.
— А сейчас по латыни?
— С Богом, — говорит Рыжий. — Соборую тебя, на случай, если не выживешь.
Тут Шафто вспоминает про остальных и почему хотел встать.
— Эй! Эй! — Силится приподняться, понимает, что это невозможно, пробует извернуться. — Эти сволочи грабят трупы.
Взгляд не фокусируется. Приходится выковыривать из глаза песок.
Вообще-то все прекрасно фокусируется. То, что казалось ему стальными бочками, стальные бочки и есть. Туземцы выкапывают их из песка руками, по-собачьи, и катят в джунгли.
Шафто отключается.
Когда он приходит в сознание, на берегу ряд крестов — палок, связанных лианами, опутанных цветами. Рыжий заколачивает их прикладом. Стальных бочек на берегу нет, туземцев почти тоже. Шафто нужен морфий. Он говорит об этом Рыжему.
— Если ты считаешь, что тебе нужен морфий, просто подожди. — Рыжий бросает винтовку туземцу, подходит к Шафто и взваливает его себе на спину. Шафто кричит от боли. Над головой проносятся несколько японских истребителей — «Зеро».
— Меня зовут Енох Роот, — говорит Рыжий. — Можешь звать меня «брат».

ГАЛЕОН

Как-то утром Рэнди поднимается рано, долго мокнет под горячим душем, потом встает перед зеркалом и зверски сбривает бороду. Он раздумывал, не поручить ли эту работу специалисту — парикмахеру в гостиничном холле, но сейчас его лицо откроется взглядам впервые за десять лет, и Рэнди хочет первым увидеть результат. Сердце бешено стучит, отчасти от первобытного страха перед лезвием, отчасти от предвкушения. Похоже на сцену из какого-нибудь слезливого старого фильма, где пациенту наконец снимают с лица бинты и протягивают зеркало.
Первое впечатление — сильнейшее дежа-вю, как будто последних десяти лет не было и сейчас их придется переживать заново.
Потом Рэнди замечает, что его лицо изменилось с тех пор, как последний раз дышало светом и воздухом. Странно: перемены не то чтобы к худшему. Рэнди никогда не считал себя красавцем и никогда особо не убивался. Однако сочащееся кровью лицо в зеркале гораздо симпатичнее того, что десять лет назад скрыла щетина. Похоже на взрослое.

Неделю назад они с Ави выложили свой план высокопоставленным чиновникам УСТ — Управления связи и телекоммуникаций. УСТ — общее название, которое бизнесмены лепят, как желтую бумажку для заметок, на любое правительственное учреждение, ведающее подобными вопросами в стране, куда их занесло на этой неделе. На Филиппинах оно на самом деле зовется как-то иначе.
Американцы вытащили Филиппины в двадцатый век (во всяком случае, помогли им туда выбраться) и выстроили аппарат центрального правительства. Интрамурос, мертвое сердце Манилы, окружено кольцом неоклассических зданий, примерно как в округе Колумбия. В одном из них, на южном берегу реки Пасиг, размещается УСТ.
Рэнди и Ави приезжают с большим запасом, потому что Рэнди, зная про манильские пробки, заложил целый час на двухмильную поездку на такси. Однако улицы оказались на удивление свободны, и теперь у них лишних двадцать минут. Они огибают здание и выходят к реке. Ави проверяет, на прямой ли видимости здание корпорации «Эпифит». Рэнди уже это проверил и просто стоит, скрестив руки и глядя на реку. Она от берега до берега забита плавучим сором. Это частью что-то растительное, но в основном — старые матрасы, подушки, куски пластмассы и пенопласта. Больше всего ярких полиэтиленовых пакетов. У воды консистенция рвотных масс.
Ави морщит нос.
— Что это?
Рэнди принюхивается и чувствует, помимо прочего, вонь горящего полиэтилена. Он указывает рукой вниз по течению.
— По ту сторону форта Сантьяго живут сквоттеры, — объясняет он. — Они вылавливают пакеты из реки и жгут вместо дров.
— Я был в Мехико две недели назад, — говорит Ави. — Там полиэтиленовые леса!
— Это как?
— Ветер несет из города полиэтиленовые пакеты, и они оседают на ветках, сплошь. Деревья умирают, потому что к листьям не попадают воздух и свет. Так и продолжают стоять в трепещущем разноцветном полиэтилене.
Рэнди скидывает блейзер, засучивает рукава. Ави словно не замечает жары.
— Значит, это форт Сантьяго. — говорит он и направляется к стене.
— Ты о нем слышал? — Рэнди вздыхает. Воздух такой горячий, что выходит из легких охлажденным на несколько градусов.
— Он есть на видео. — Ави помахивает кассетой.
— Ах да.
Вскоре они перед входом в форт. По обеим сторонам — высеченные из вулканического туфа стражники, испанцы с алебардами, в пышных штанах до колен и конкистадорских шлемах. Они стоят здесь скоро полтысячелетия, сотни тысяч тропических ливней отполировали до блеска каменные тела.
Ави интересует более короткий исторический интервал. Последняя война изуродовала стражников куда сильнее времени и погоды. Он вкладывает пальцы в дырки от пуль, как апостол Фома. Потом отступает на шаг и начинает шептать по-еврейски. Проходят два немца в сандалиях, с «хвостами» на затылке.
— У нас пять минут, — говорит Рэнди.
— Ладно. Потом вернемся.

В чем-то Чарлин права. Минут десять-пятнадцать после бритья кровь сочится из невидимых, безболезненных порезов у Рэнди на шее и на щеках. Мгновения назад эта кровь прокачивалась через желудочки его сердца или циркулировала в той части мозга, которая превращает Рэнди в разумное существо. Теперь выступила наружу, и ее можно стереть ладонью. Граница между Рэнди и внешней средой уничтожена.
Он вынимает большой тюбик сильнейшего солнцезащитного крема, мажет лицо, руки, шею и то место на макушке, где волосы начинают редеть. Потом надевает хлопчатобумажные брюки, мокасы, свободную рубашку и «набрюшник» с джи-пи-эской и парой других необходимых вещей, вроде рулончика туалетной бумаги и одноразового фотоаппарата, спускается в холл и бросает ключи на стойку. Служащие узнают его только со второго взгляда и расплываются в улыбке. Особенно довольны посыльные, может быть, потому, что на нем, в кои-то веки, хорошая обувь. Мокасы — супердорогие и супермодные, Рэнди всегда считал, что в таких ходят только богатые папенькины сынки, но сегодня это самое то.
Посыльные готовы распахнуть парадную дверь, однако Рэнди идет в другую сторону, через холл, мимо бассейна и дальше по пальмовой аллее к каменному парапету набережной. Внизу, в бухточке — гостиничный причал.
Катера еще нет, и Рэнди минуту стоит у парапета. С одной стороны в бухточку можно попасть из парка Рисаля. На скамейках развалились несколько филиппинских бомжей; сидят, смотрят на Рэнди. Рядом с волноломом стоит по колено в воде немолодой человек в семейных трусах и, сжимая заостренную палку, что-то напряженно высматривает в лениво набегающих волнах. Черный вертолет медленно описывает круги в сахарно-белом небе. Это музейный «Хью» времен гражданской войны, он трясется мелкой дрожью и яростно шипит, пролетая над головой.
Из дымки над заливом материализуется катер и на выключенном моторе скользит к причалу. Вода идет складками, как тяжелый ковер. На носу катера корабельным украшением стоит высокая стройная девушка с бухтой каната.

* * *

Большие спутниковые тарелки на крыше УСТ смотрят почти прямо вверх, как птичьи купальни возле английского загородного дома: настолько близка Манила к экватору. Цемент вываливается из дырок от пуль и шрапнели, замазанных после войны. В романских арках закреплены кондиционеры, с них капает вода, постепенно растворяя известняковую балюстраду. Известняк черный от какой-то органической слизи, в паучках от корневой системы мелких растений, чьи семена, возможно, занесли с пометом птицы, прилетающие сюда попить и искупаться, — бомжи воздушного царства.
В обшитом панелями конференц-зале дожидаются двенадцать человек, поровну разделенные на боссов за столом и мелкую сошку вдоль стен. Когда входят Ави и Рэнди, начинается кутерьма рукопожатий и обмена визитными карточками. Большая часть фамилий проносится сквозь краткосрочную память Рэнди, как сверхзвуковой истребитель — сквозь систему ПВО отсталой азиатской страны. Остается только стопка карточек в руке. Он раскладывает их на своем участке стола, как чудной старикан — пасьянс на подносе. Ави, разумеется, со всеми уже знаком — обращается запросто, знает про каждого все: имена и возраст детей, увлечения, группу крови, хронические заболевания, любимые книги, расписание светских мероприятий. Собеседники довольны и, слава богу, не обращают внимания на Рэнди.
Из полудюжины воротил трое — пожилые филиппинцы. Один из них — высокопоставленный чиновник УСТ. Второй — президент недавно созданной телекоммуникационной компании «ФилиТел», которая пытается конкурировать с традиционной монополией. Третий — вице-президент компании «24 часа»; ей принадлежит половина манильских универмагов и еще немало в Малайзии. Рэнди с трудом их различает, но, слушая Ави и применяя метод индукции, вскоре может сопоставить лица и визитные карточки.
С остальными проще: это двое американцев, из которых одна — женщина, и японец. На женщине сиреневые лодочки в тон жакету и юбке, того же цвета лак на ногтях. Такое впечатление, что она сошла с телевизионной рекламы накладных ногтей или домашнего перманента. Судя по карточке, это Мэри Энн Карсон, вице-президент «АВКЛА», Азиатский Венчурный Капитал, Лос-Анджелес. Как припоминает Рэнди, это вроде бы американская фирма, которая инвестирует в быстроразвивающиеся азиатские страны. Американец — блондин, с квадратным, как у отставника, лицом. Он собран и немногословен, что в компании Чарлин определили бы как враждебность вследствие подавленности, вызванной скрытым душевным расстройством. Представляет открытый Субикский порт. Японец (щуплый, большая голова в форме перевернутой груши, густые седеющие волосы, очки в тонкой металлической оправе) — вице-президент отделения компании-гиганта по производству бытовой электроники. Он часто улыбается и излучает спокойную уверенность человека, заучившего на память двухтысячестраничную энциклопедию этикета.
Ави почти сразу включает видеокассету, в которой на данный момент заключены семьдесят пять процентов активов корпорации «Эпифит». Ави заказал ее молодой, но сильно продвинутой мультимедийной студии в Сан-Франциско, чем обеспечил сто процентов поступлений студии за этот год. «Пироги крошатся, если резать их слишком тонко», — любит говорить Ави.

Начало пленки содрано с забытого телефильма: испанский галеон идет по бурному морю. Титры: «ЮЖНО-КИТАЙСКОЕ МОРЕ, 1699 ГОД Н. Э.» Саундтрек слизан с оригинальной монозаписи и преобразован в формат Долби. Очень впечатляет.
(«Половина инвесторов «АВКЛА» — заядлые яхтсмены», — объяснил Ави.)
Монтажный кадр (изготовлен мультимедийной компанией и вмонтирован без сучка без задоринки): просмоленный, усталый впередсмотрящий на марсе смотрит в бронзовую подзорную трубу и кричит по-испански: «Земля!»
Монтажный кадр: капитан галеона, бородатый, в истрепанном камзоле, выбегает из каюты и, словно китсовский Кортес, вперяет орлиный взгляд в горизонт.
— Коррехидор! — восклицает он.
Монтажный кадр: каменная башня на вершине зеленого тропического острова. Дозорный видит на горизонте (оцифрованный и вставленный) галеон, складывает руки рупором и кричит: «Галеон! Зажечь сигнальный огонь!»
(«Семья директора УСТ увлекается местной историей, — сказал Ави. — Они содержат на свои средства Филиппинский музей».)
С дружным криком испанцы (на самом деле — американские актеры мексиканского происхождения) бросают горящие головни на груду сухих дров, которая обращается в ревущую пирамиду огня, такую, что можно мгновенно зажарить быка.
Монтажный кадр: укрепления манильского форта Сантьяго (первый план — крашеный пенопласт, задний — компьютерная графика). Еще один конкистадор замечает вспыхнувший на горизонте огонь. «Mira! El galleon!* [Смотрите! Галеон! (исп.).]» — кричит он.
Монтажная нарезка: жители Манилы бегут к набережной посмотреть на сигнальный огонь. Среди них монах-августинец. Он поднимает четки и разражается церковной латынью. («Семья, основавшая «ФилиТел», пристроила часовню к Манильскому собору».) Чистенькое семейство китайских торговцев выгружает из джонки рулоны шелка. («У семьи, которая владеет сетью «24 часа», — китайские корни».)
Голос за кадром, низкий и убедительный, говорит по-английски с филиппинским акцентом. («Актер — брат человека, который крестил внука у директора УСТ».) Появляются субтитры на тагальском. («Политика УСТ — поддерживать национальный язык».)
«В эпоху расцвета Испанской империи важнейшим событием года было прибытие галеона из Акапулько, нагруженного серебром из американских рудников. На него закупали шелка и пряности в Азии. На нем строилось богатство и процветание Филиппин. О появлении галеона возвещал сигнальный огонь на острове Коррехидор, у входа в Манильский залив».
Алчная радость на лицах горожан сменяется (наконец-то!) трехмерным компьютерным изображением Манильского залива, полуострова Батаан и островков на его продолжении, в том числе Коррехидора, на котором дергается крупнопиксельный, плохо отрисованный огонь. Пучок желтого света простреливает через залив, как лазерный луч в «Стар трек». Камера скользит вдоль луча. Свет ударяет в стены форта Сантьяго.
«Сигнальный огонь применялся с глубокой древности. На языке современной науки свет — это электромагнитное излучение, которое распространялось по прямой через Манильский залив и несло в себе один бит информации. В эпоху информационного голода этот единственный бит означал для манильцев все».
Блюз. Монтажная нарезка современной Манилы. Супермаркеты и шикарные отели в Макати. Заводы, где собирают электронику, дети за компьютерами. Спутниковые тарелки. Корабли разгружаются в Субикском порту. Много улыбающихся лиц.
«Сегодня экономика Филиппин стремительно развивается. Как всякая быстро растущая экономика, она нуждается в информации — не в единичных битах, а в сотнях миллиардов битов. Однако технология передачи информации изменилась не так сильно, как может показаться».
Снова трехмерное компьютерное изображение Манильской бухты. На этот раз на Коррехидоре вместо огня — ультракоротковолновая рупорная антенна, излучающая ядовито-голубые синусоиды на город Манилу.
«Электромагнитное излучение — в данном случае ультракоротковолновое — распространяется вдоль линий прямой видимости и может быстро передавать большое количество информации. Современная криптография позволяет уберечь эту информацию от нежелательного прослушивания».
Монтажный кадр: снова впередсмотрящий на галеоне. «В прежние времена положение Коррехидора на входе в Манильскую бухту делало его естественным наблюдательным пунктом — местом, куда поступала информация о приближающихся кораблях». Монтажный кадр: с баржи травят в воду толстый осмоленный кабель, водолазы тянут цепочку оранжевых буйков. «Сегодня положение Коррехидора делает его идеальным для прокладки глубоководного оптоволоконного кабеля. Информация, идущая по этому кабелю из Тайваня, Гонконга, Малайзии, Японии и Соединенных Штатов, будет транслироваться прямо в сердце Манилы со скоростью света».
Снова трехмерная графика: подробно прорисованный вид Манилы. Рэнди знает его наизусть, потому что собирал данные для этой муры, когда ходил по городу с джи-пи-эской. Лучи битов от Коррехидора мчатся через залив прямой наводкой в антенну на крыше неприметного четырехэтажного строения между фортом Сантьяго и Манильским собором. Это здание корпорации «Эпифит», чье название и логотип скромно помещены на антенне. Другие антенны ретранслируют информацию на здание УСТ, небоскребы в Макати, правительственные учреждения в Кесон-Сити и базу ВВС к югу от города.

Служащие отеля перебрасывают с причала на катер покрытые ковровой дорожкой сходни. Как только Рэнди вступает на них, девушка протягивает руку. Рэнди тянется ее пожать.
— Рэнди Уотерхауз, — говорит он.
Девушка хватает его за руку и втаскивает на катер — не столько в качестве приветствия, сколько желая убедиться, что он не свалится за борт.
— Ами Шафто, — отвечает она. — «Глория» вас приветствует.
— Простите?
— «Глория». Эта посудина зовется «Глория». — Она говорит с нажимом, чеканя слова, как будто они общаются по трескучей рации. — Вообще-то это «Глория-IV», — продолжает девушка. Выговор у нее среднеамериканский, с еле заметным южным налетом и самой чуточкой филиппинского. Если бы Рэнди увидел ее где-нибудь на американском Среднем Западе, то мог бы и не заметить в разрезе глаз примесь восточной крови. У нее выгоревшие темно-русые волосы, как раз на короткий «хвост».
— Секундочку. — Она заглядывает в рубку и говорит с рулевым на смеси английского и тагальского. Рулевой кивает, оглядывается, начинает дергать рычаги. Гостиничные служащие убирают сходни. — Эй! — Ами через воду кидает каждому по пачке «Мальборо». Те ловят, улыбаются, благодарят. «Глория-IV» задом отходит от пристани.
Следующие несколько минут Ами расхаживает по палубе, что-то мысленно перебирая. Рэнди успевает насчитать еще четырех членов команды, кроме Ами и рулевого, — двух белых и двух филиппинцев. Все они возятся с мотором и водолазным снаряжением, занятые тем, что Рэнди, через множество технологических и культурных барьеров, опознает как ликвидацию затыков. Ами дважды проходит мимо, но не смотрит Рэнди в глаза. Это не робость. Язык ее телодвижений достаточно красноречив: «Мужчины имеют обыкновение пялиться на женщин, получая удовольствие от их внешности, волос, макияжа, духов и одежды. Я буду спокойно и вежливо этого не замечать, пока ты не насмотришься». Ами — длинноногая и длиннорукая, в запачканных краской джинсах, футболке и хай-тековских босоножках. Наконец она подходит к Рэнди, на мгновение встречается с ним глазами и тут же скучающе отводит взгляд.
— Спасибо, что взяли с собой, — говорит Рэнди.
— Пустяки.
— Мне стыдно, что я не дал на чай тем, на пристани. Можно возместить расходы?
— Можете возместить их информацией, — без колебаний отвечает Ами. Она поднимает руку и чешет голову. Острый локоть торчит вперед. Рэнди видит двухнедельную поросль под мышкой и краешек татуировки.
— Вы ведь зарабатываете информацией? — Ами всматривается в его лицо, ожидая, что он подхватит шутку и рассмеется, но Рэнди так сосредоточен, что даже не улыбается. Она отводит взгляд, на этот раз — с горько-ироническим выражением: ты не понимаешь меня, обычное дело, я давно привыкла и не обижаюсь. Она напоминает Рэнди знакомых американских лесбиянок — амазонистых, рукастых кошатниц и лыжниц, не обремененных высшим образованием.
Ами ведет его в каюту с большими окнами. Здесь работает кондиционер и стоит кофеварка. Стены обиты учрежденческим пластиком «под дерево», на них, в рамках — лицензии, сертификаты, увеличенные черно-белые фотографии людей и кораблей. Пахнет кофе, мылом, соляркой. Рэнди видит CD-проигрыватель, принайтовленный эластичным шнуром, и коробку из-под обуви с парой десятков компакт-дисков, в основном — авторские песни американской исполнительницы, принадлежащей к нетрадиционной, очень интеллектуальной и в то же время глубоко эмоциональной школе и сделавшей огромные деньги на популярности у тех, кто понимает, что значит быть непонятым*. [Очевидный парадокс, хотя на самом деле в этом нет ничего странного — оттого, что Рэнди сейчас не в Америке, он просто отчетливее воспринимает такие вещи.] Ами наливает и ставит на привинченный к палубе стол две кружки кофе, лезет в тесный карман джинсов, вытаскивает непромокаемый нейлоновый бумажник, вынимает две визитные карточки и толкает их через стол, одну за другой. Это явно ее забавляет — она улыбается про себя и тут же прячет улыбку, едва Рэнди успевает это заметить. На карточках — логотип «Семпер марин сервисис» и имя: «Америка Шафто».
— Вас зовут Америка? — спрашивает Рэнди.
Ами скучающе смотрит в иллюминатор, как будто боится, что он начнет делать далеко идущие выводы.
— Да.
— Где вы росли?
Кажется, ее увлек вид в иллюминатор: грузовые суда из Африки, Шанхая, Владивостока, Кейптауна, Монровии. Рэнди заключает, что смотреть на большие ржавые корпуса интереснее, чем разговаривать с Рэнди.
— Может, все-таки расскажете, в чем дело? — Ами поворачивается, подносит чашку к губам и наконец смотрит ему прямо в глаза.
Рэнди несколько ошарашен. Вопрос со стороны Ами довольно наглый. «Семпер марин сервисис» — самое нижнее звено в виртуальной корпорации Ави, одна из десятка водолазных фирм, куда они могли обратиться. Это все равно как если бы о твоих целях начал допытываться уборщик или таксист.
Однако она умная, необычная и очень привлекательная именно из-за явного нежелания нравиться. Она пользуется своим положением интересной девушки и соотечественницы, чтобы выторговать себе более высокий статус. Рэнди пытается осторожничать.
— Вас что-то беспокоит? — спрашивает он.
Ами отводит глаза, опасаясь, что создала у него неверное впечатление.
— Да нет. Мне просто любопытно. Люблю слушать истории. Водолазы всегда сидят и травят друг другу байки.
Рэнди отхлебывает кофе.
— В нашем деле никогда не знаешь, откуда возьмется следующая работа. Иногда у людей такие офигенные причины делать что-то под водой. Всегда интересно послушать. — Ами заключает: — Это кайф! — явно не нуждаясь в другой мотивировке.
Рэнди уверен, что она заговаривает ему зубы. И решает дать «материал для прессы».
— Все филиппинцы — в Маниле. Сюда должна стекаться информация. Иногда информацию трудно доставить в Манилу, потому что сзади горы, спереди — залив. Прокладывать кабель в бухте — жуткая морока...
Ами кивает. Разумеется, ей все это известно. Рэнди пропускает часть предисловия.
— Коррехидор — более удачное место. С Коррехидора можно передавать УКВ-сигнал по линии прямой видимости через залив на Манилу.
— Значит, вы продлеваете Северо-Лусонский кабель от Субика к Коррехидору?
— Две поправки по поводу того, что вы сейчас сказали, — говорит Рэнди и замолкает, чтобы поставить ответы в очередь исходящего буфера своей памяти. — Во-первых, осторожней с местоимениями. Что значит «вы»? Корпорация «Эпифит», в которой я работаю, создана, чтобы функционировать не самостоятельно, но в качестве некоего виртуального объединения наподобие...
— Я знаю, что такое эпифит, — перебивает Ами. — Что второе?
— Ладно, хорошо. — Рэнди слегка выбит из колеи. — Второе, что продление Северо-Лусонского кабеля — лишь первая связка. Со временем мы хотим протянуть на Коррехидор еще несколько кабелей.
В голове у Ами включается какой-то процесс. Смысл сказанного достаточно ясен. Для «Семпер марин» будет еще много работы, если они хорошо справятся с первой.
— Этим займется совместное предприятие, в которое входят, помимо нас, «ФилиТел», «24 часа» и японская компания по производству бытовой электроники.
— А при чем здесь «24 часа»? Это же универмаги.
— Они будут заниматься розницей — сбывать конечный продукт корпорации «Эпифит».
— То есть?
— Пинойграммы. — Рэнди успешно перебарывает желание сказать, что это защищенная торговая марка.
— Пинойграммы?
— Это будет так. Вы — заморский контрактный работник. Прежде чем уехать в Саудовскую Аравию, Сингапур, Сиэтл или куда еще, вы покупаете или берете у нас напрокат штучку — маленькую, не больше книги. В ней — видеокамера размером с наперсток, тонюсенький экран и уйма памяти. Комплектующие везут из самых разных мест в Субикский порт и собирают там на японском заводе. Все это не стоит практически ничего. Так или иначе, вы берете штучку с собой. Как только вам хочется пообщаться с родными, вы включаете штучку, наводите камеру на себя и записываете небольшую видеооткрытку. Она, в сильно сжатом виде, помешается в память. Потом вы подключаете штучку к телефонной розетке и происходит волшебство.

Предыдущая страница 5 Следующая страница


Криптономикон (часть 1) 6

— В чем волшебство? Видео отправляется по телефону?
— Точно.
— Но ведь видеотелефоны существуют уже давно?
— Вся фишка в нашем программном обеспечении. Мы не пытаемся отправить видео в реальном времени — это слишком дорого. Мы храним данные на центральном сервере и перекачиваем их, например, в ночные часы, когда трафик низкий и время дешево. В конце концов данные добираются до здания корпорации «Эпифит» в Интрамурос. Оттуда мы по беспроводной; технологии передаем их универмагам «24 часа» в Маниле. Магазину достаточно иметь для этого небольшую тарелку на крыше, декодер и бытовой видеомагнитофон. Пинойграмма пишется на обычную видеокассету. Мама заходит купить яиц или папа заскакивает за сигаретами, продавец говорит: «Вам пинойграмма» и вручает кассету. Они несут ее домой и узнают последние новости о детях. Потом возвращают кассету в «24 часа» для перезаписи.
Примерно на середине объяснений Ами схватывает основную мысль, поворачивается к иллюминатору и начинает языком, выковыривать из зубов остатки завтрака. Она делает это с деликатно закрытым ртом, но процесс явно занимает ее сильнее, чем пинойграммы.
Рэнди охватывает необъяснимое желание не утомлять Ами. Не то чтобы он на нее запал: пятьдесят на пятьдесят, что она лесбиянка. Просто она такая открытая, такая непосредственная, что ей можно говорить все, как равной.
Вот почему Рэнди не любит бизнес. Он хотел бы говорить всем все. Ему хочется дружбы.
— Попробую догадаться, — произносит она. — Ваше дело — программы.
— Да, — отвечает Рэнди, словно оправдываясь, — но программы во всем проекте — единственно интересное. Остальное — клепать номерные знаки.
Ами немного просыпается.
— Клепать номерные знаки?
— Наше с партнером выражение, — говорит Рэнди. — В любой работе есть творческая часть — разрабатывать новую технологию или что-нибудь в этом роде. Все остальное — девяносто девять процентов — заключение сделок, поиск инвестиций, деловые встречи, маркетинг и продажи. Мы называем это клепать номерные знаки.
Она кивает, глядя в окно. Рэнди подмывает сказать, что пинойграммы — всего лишь способ наладить приток денежных средств, чтобы перейти к пункту второму плана. Он уверен, что тогда Ами не будет смотреть на него как на нудного компьютерщика. Однако Ами резко дует на кружку, как будто гасит свечу, и говорит:
— О'кей. Спасибо. Думаю, три пачки сигарет это стоило.

КОШМАР

Бобби Шафто хорошо разбирается в кошмарах. Только что он, словно летчик из горящего самолета, катапультировался из старого заезженного кошмара в новехонький, экстра-класса. Кошмар, правда, какой-то недоделанный: в нем нет исполинской ящерицы.
Начинается с жара на лице. Если в одну цистерну слито столько горючего, сколько нужно пятидесятитысячетонному кораблю, чтобы идти по Тихому океану со скоростью двадцать пять узлов, и пролетающие нипские самолеты подожгли ее в несколько секунд, а ты стоишь настолько близко, что видишь торжествующие лица пилотов, то ощущаешь на лине именно такой жар.
Бобби Шафто открывает глаза, думая, что поднимает занавес сногсшибательного кошмара и сейчас начнутся «Торпедные бомбардировщики на 2.00!» (лидер проката) или «Атака с бреющего полета», семнадцатая серия.
Однако фонограмма кошмара почему-то не идет. Тихо, как в засаде. Он сидит на госпитальной койке, окруженный расстрельным взводом жарких прожекторов. Свет слепит, ничего не видно. Шафто моргает и фокусируется на струйке табачного дыма, которая растекается по воздуху, как мазут по воде тропической бухты. Пахнет соблазнительно.
Рядом с койкой сидит молодой человек. Шафто видит только несимметричный нимб там, где юпитер светит через бензиновый отлив взбитых волос. И красный уголек сигареты. Присмотревшись, Шафто различает силуэт военной формы. Не морпеховской. На погонах — лейтенантские полоски, как просвет в двери.
— Еще сигарету хотите? — спрашивает лейтенант. Голос у него хриплый, но жутко приятный.
Шафто смотрит на свою руку и видит зажатый между пальцев чинарик «Лаки страйк».
— Не вопрос, — с трудом выговаривает он. У него самого голос хриплый и замедленный, как у граммофона, когда кончается завод.
Чинарик заменяют на зажженную сигарету. Шафто подносит ее к губам. Рука в бинтах, под бинтами — раны, которые пытаются болеть. Однако что-то блокирует сигнал.
Ага, морфий. Неплохой кошмар, если в нем есть морфий.
— Готовы? — спрашивает голос. Черт возьми, Шафто где-то его слышал.
— Сэр! Не вопрос, сэр! — отвечает он.
— Вы это уже говорили.
— Сэр, если вы спрашиваете морпеха, хочет ли он еще сигарету или готов ли он, ответ один, сэр!
— Отлично. То, что надо, — говорит голос. — Мотор.
В кромешной тьме за юпитерами возникает стрекот. «Пошел мотор», — говорит другой голос.
Что-то большое снижается над Шафто. Тот вжимается в койку: эта штука больше всего похожа на зловещие яйца, какие откладывают в воздух японские пикирующие бомбардировщики. Однако она останавливается и зависает.
— Звук, — говорит другой голос.
Шафто всматривается и видит, что это не бомба, а микрофон на палке.
Лейтенант с начесом подается вперед, он стремится к свету, как замерзший путник в ночи.
Это же тип из кино. Как его... Ах да!
У Рональда Рейгана на коленях стопка карточек три на пять дюймов. Он берет новую.
— Что вы как самый молодой американский боец, отмеченный и Серебряной Звездой, и Военно-Морским Крестом, посоветуете морским пехотинцам, направляемым на Гуадалканал?
Шафто не задумывается. Воспоминание свежо, как вчерашний одиннадцатый кошмар: десять остервенелых нипов в «Желтолицые атакуют!»
— Уложить первым того, что с мечом.
— А. — Рейган поднимает нафабренные и подведенные брови, кивает начесом в сторону Шафто. — Пр-р-рекрасно! Их надо убивать первыми, потому что это офицеры?
— Нет же, твою мать! — орет Шафто. — Потому что у них мечи! На тебя когда-нибудь бежали с мечом, твою мать?!
Рейган отшатывается. Теперь он напуган, пот смывает с лица грим, хотя из окна с залива тянет прохладным ветерком.
Рейгану хочется скорее вернуться в Голливуд и закадрить старлетку. Однако надо торчать здесь, в Окланде, брать интервью у военного героя. Он перебирает карточки, откладывает штук двадцать подряд. Шафто никуда не торопится. Ему валяться на этой койке примерно до конца жизни. Он в одну затяжку вытягивает полсигареты, выпускает колечко дыма.
Во время ночного боя большие корабельные орудия выпускают кольца светящегося газа. Не толстые, как пончики, а тощие, они еще извиваются, как лассо. Тело Шафто пропитано морфием. Веки рушатся на глаза, нежа глазные яблоки, истерзанные табачным дымом и светом. Он вместе со взводом бежит навстречу приливу. Они — рейдеры морской пехоты и две недели преследуют по Гуадалканалу подразделение нипов, отстреливая их одного за другим. Им приказано выбраться в определенную точку на мысу и обстрелять из минометов «Токийский экспресс». Это достаточно безрассудная тактика, вполне в духе всей операции, которая с самого начала держалась на соплях. Рейдеры выбились из графика, потому что жалкая горстка нипов устраивала засады за каждым поваленным деревом, палила по ним всякий раз, как они огибали очередной мыс...
Что-то липкое касается лба — гример опять полез его мазать. Шафто снова в кошмаре, внутри которого развивается кошмар с ящерицей.
— Я рассказывал вам про ящерицу? — спрашивает он.
— Несколько раз. Все, еще минутку. — Рейган зажимает в пальцах новую карточку, торопясь переключиться на что-нибудь менее эмоциональнее. — Что вы с товарищами делаете по вечерам, когда закончены дневные бои?
— Сгребаем убитых нипов бульдозером и поджигаем, — говорит Шафто. — Потом берем по бутылю и идем на берег смотреть, как торпедируют наших.
Рейган морщится.
— Стоп! — говорит он тихо, но властно. Стрекот умолкает.
— Ну, как я был? — спрашивает Шафто, пока ему стирают с лица «Мейбеллин» и операторы пакуют оборудование. Юпитеры выключены, в окно льется серый калифорнийский свет. Вся сцена выглядит почти реально, будто это вовсе и не кошмар.
— Отлично, — говорит Рейган, не глядя ему в глаза. — Очень поднимает дух. — Он закуривает. — Можете спать дальше.
— Ха! — говорит Шафто. — Я спал все это время. Разве нет?

После госпиталя ему значительно лучше. Он получает двухнедельный отпуск, идет прямиком на вокзал и садится на первый поезд до Чикаго. Другие пассажиры узнают его по снимкам в газетах, угощают выпивкой, фотографируются с ним на память. Он часами смотрит в окно, за которым бежит Америка, и видит, как все красиво и чисто. Может быть, есть дикие места, и чащи, даже медведи гризли и пумы, но все упорядоченно, правила (не приставать к медвежатам, с вечера вешать съестные припасы на ветку) известны и напечатаны в справочнике бойскаута. На островах в Тихом океане слишком много всего живого, все оно постоянно жрет или пожирается другими, и как только ты там оказываешься, ты включаешься в процесс. Просто сидеть в поезде пару дней, в чистых белых носках, когда тебя не едят заживо — здорово прочищает голову. От силы раз — ну, может быть, два или три — ему по-настоящему надо запереться в туалете и вколоть себе морфий.
Однако стоит закрыть глаза, и он снова огибает последний мыс, плеща навстречу приливу. Волны сбивают людей с ног, бросают на скалы.
Наконец они огибают мыс и видят бухточку: крохотную выемку побережья, зажатую между скалами. Впереди сотня ярдов приливной полосы, за ней — обрыв. Надо преодолеть эту сотню ярдов, иначе унесет в море приливом...
Шафто — теннессийские горцы и, помимо всего прочего, рудокопы. Примерно в то время, когда Нимрод Шафто осел на Филиппинах, два его брата подались в Висконсин на свинцовые рудники. Один из них — дедушка Бобби — стал горным мастером. Иногда хозяин приглашал его в Окономовок, в свой летний домик на озере. Они отправлялись на лодке ловить щук. Часто к ним присоединялись соседи — владельцы банков и пивоварен. Так Шафто перебрались в Окономовок, бросили горное дело и стали егерями: водили богатых людей на охоту и на рыбалку. Семья тщательно сохраняла теннессийский выговор и некоторые другие традиции, к которым относилась и военная служба. Одна из сестер и два младших братишки Шафто по-прежнему жили с родителями, два старших брата служили в армии. Бобби не первый в семье получил Серебряную Звезду. Правда, Военно-Морского Креста до него еще никто не получал.
Бобби выступает перед окономовокскими бойскаутами. В качестве героя идет впереди городского парада. В остальное время практически не выходит из дома, разве что во двор, поиграть с братишками в мяч. Помогает отцу починить прогнивший причал. Все время таскаются старшеклассники. Скоро Бобби усваивает то, что давно знают отец, дед и дедовы братья: не надо рассказывать подробности. Никому не интересно слушать, как ты штыком выковыривал из ноги коренные зубы приятеля. Все эти подростки кажутся ему придурками. Единственный, кто его не раздражает, — прадедушка Шафто, девяносточетырехлетний, в абсолютно здравом уме. Он был под Питтсбургом, когда Бернсайд зарытой взрывчаткой пробил огромную брешь в рядах конфедератов и бросил своих людей в воронку, где их всех перебили. Он никогда про это не рассказывает, как Шафто — про ящерицу.
Вскоре отпуск заканчивается, ему устраивают торжественные проводы на вокзале. Он обнимает мать, обнимает сестренку, жмет руку отцу и братьям, снова обнимает мать и уезжает.
Бобби Шафто ничего не знает о своем будущем. Только то, что его произвели в сержанты, вывели из состава прежней части (невелика потеря, потому что из взвода он один остался в живых) и перевели в какое-то новоявленное подразделение в Вашингтоне, округ Колумбия.
Округ Колумбия — оживленное место, но, насколько Бобби Шафто известно, бои там не идут, так что отправили его не на фронт. Что ж, он свое отвоевал, норму убитых нипов перевыполнил, заслужил награды, получил ранения. Поскольку административного опыта у него нет, ему скорее всего поручат разъезжать по стране в качестве героя, поднимать дух и убеждать молодых людей записываться в Корпус.
Он прибывает, согласно приказу, в Казармы МПФ. Это старейшая база Корпуса, квартал на полпути от Капитолия к военно-морским складам. На зеленом прямоугольнике марширует оркестр, инструкторы проводят строевую подготовку. Шафто почти готов увидеть рядом цистерны со стратегическим запасом армейского глянца.
В кабинете два морских пехотинца: майор, его новый, номинальный командир и полковник, который выглядит и ведет себя так, будто тут родился. Опупеть можно, что два таких персонажа здесь, чтобы побеседовать с простым сержантом. Наверное, все дело в Военно-Морском Кресте. Хотя у них свои Военно-Морские Кресты — по два, по три на брата.
Майор представляет полковника в выражениях, которые ничего не проясняют. Полковник по большей части молчит — он здесь, чтобы наблюдать. Майор некоторое время теребит какие-то машинописные документы.
— Здесь говорится, что вы — гун-хо.
— Сэр! Так точно, сэр!
— И что бы это значило?
— Сэр, это китайское слово! Там есть один коммунист, Мао, у него армия. Мы с ними дрались, и не раз, сэр! Гун-хо — их боевой клич, значит «все вместе» или вроде того, сэр, и когда им вмазали, сэр, мы украли их боевой клич, сэр!
— Значит ли это, что вы обазиатились, как другие китайские морские пехотинцы, Шафто?
— Сэр! Напротив, сэр, как, думаю, видно из моего личного дела, сэр!
— Вы правда так думаете? — с сомнением говорит майор. — У нас тут рапорт о телеинтервью, которое вы дали одному солдату* [Уничижительное прозвище военного, который не имеет чести служить в Корпусе.], лейтенанту Рейгану.
— Сэр! Морпех извиняется за возмутительное поведение во время интервью, сэр! Морпех подвел себя и своих товарищей, сэр!
— Вы не хотите представить оправдания? Вы были ранены. Контужены. Накачаны морфием. Страдали от малярии.
— Сэр! Это не оправдание, сэр!
Майор и полковник обмениваются одобрительными кивками.
Все эти «сэр, есть, сэр», которые покажутся собачьей чушью любому мало-мальски вменяемому штатскому, исполнены для Шафто и офицеров глубокого и внятного смысла. Как у многих, у Шафто поначалу были нелады с субординацией. Конечно, он вырос в семье потомственных военных и многое впитал с детства, но в жизни это оказалось куда труднее. Теперь, пройдя все стадии воинского существования, кроме завершающих (насильственная смерть, трибунал, увольнение в запас), он понимает культуру в ее сути: как систему этикета, которая позволяет группе людей жить бок о бок многие годы, переправляться на край света и выполнять буквально черт-те какие задания, не прикончив друг друга в процессе и не рехнувшись окончательно. Крайняя формальность, с которой он обращается к офицерам, несет в себе важный подтекст: ваша забота, сэр, решить, что от меня требуется, моя забота, сэр, это исполнить. Все эти мои «гун-хо» означают, что, когда вы отдадите приказ, я не стану приставать к вам с вопросами, а вы, сэр, со своей стороны, не стойте над душой и не морочьте мне голову вонючей политикой, которой вы тут пробавляетесь. Такая готовность без колебаний выполнить приказ — тяжелейшее бремя ответственности для любого мало-мальски вменяемого офицера. Шафто не раз видел, как у зеленых лейтенантиков начинали гнуться коленки, когда видавший виды боец просто стоял перед ними и бодро отвечал: «Есть, сэр!»
— Лейтенант Рейган жаловался, что вы все время пытались рассказать ему историю про ящерицу, — говорит майор.
— Сэр! Так точно, сэр! Исполинская ящерица, сэр! Занятная история, сэр!
— Не важно, — говорит майор. — Вопрос в том, следовало ли рассказывать ее в данных обстоятельствах?
— Сэр! Мы двигались вдоль побережья, чтобы отрезать нипов от места высадки «Токийского экспресса», сэр!.. — начинает Шафто.
— Отставить!
— Сэр! Есть, сэр!
Наступает полная тишина, которую нарушает полковник:
— Мы показали ваши утверждения психиатрам, Шафто.
— Да, сэр!
— Они утверждают, что вся эта история с ящерицей — классический пример замещения.
— Сэр! Не будете ли вы так любезны объяснить, что это за штука, сэр?
Полковник краснеет, поворачивается к окну, смотрит на редкие машины.
— Ну, у них выходит, что никакой исполинской ящерицы не было. Что вы убили того япа* [Те, кто служил в Азии, сказали бы «нип». То, что полковник говорит «яп», означает, что он служил в Атлантике и/или в Карибском море.] в рукопашном бою. А воспоминание о ящерице — на самом деле ваше подсознание, которое вылезает наружу.
— Подсознание, сэр!
— Что у вас в голове есть подсознание, и оно дало вам силы убить япа голыми руками. А потом ваше воображение придумало исполинскую ящерицу в качестве объяснения.
— Сэр! Вы говорите, что ящерица просто моя фантазия, сэр!
— Да.
— Сэр! В таком случае позвольте узнать, как этот нип оказался наполовину обглодан, сэр!
Полковник кривится.
— Ну, сержант, к тому времени, как вас нашел береговой наблюдатель, вы пробыли в бухте с мертвыми телами три дня. А в тропиках, где жуки и все такое, уже нельзя сказать, обглодала его исполинская ящерица или по нему прогнали газонокосилку, если вы понимаете, о чем я.
— Так точно, сэр!
Майор возвращается к рапорту.
— Этот Рейган утверждает также, что вы неоднократно отпускали оскорбительные замечания в адрес генерала Макартура.
— Сэр! Так точно, сэр! Этот сукин сын ненавидит Корпус, сэр! Он хочет, чтобы нас всех перебили, сэр!
Майор и полковник переглядываются. Очевидно, они только что пришли к какому-то общему решению.
— Поскольку вы хотите продлить контракт, в нормальных обстоятельствах вас бы отправили разъезжать по стране, поднимать боевой дух и агитировать молодых людей вступать в Корпус. Однако история с ящерицей ставит на этом крест.
— Не понимаю, сэр!
— Отдел комплектования получил ваше личное дело. Они видели рапорт Рейгана. Они боятся, что на параде в День Поминовения в Малом Жопасрауне, Арканзас, вы внезапно начнете рассказывать про исполинскую ящерицу, перепугаете всех до потери пульса и подорвете военные усилия.
— Сэр! Разрешите...
— Не разрешаю, — говорит майор. — Я даже не буду касаться вашей одержимости генералом Макартуром.
— Сэр! Генерал гробит...
— Отставить!
— Сэр! Есть, сэр!
— У нас другое дело для вас, морпех.
— Есть, сэр!
— Вы поступаете в весьма исключительное подразделение.
— Сэр! Рейдеры морской пехоты и без того весьма исключительное подразделение весьма исключительного Корпуса, сэр!
— Я о том, что назначение будет... необычным. — Майор смотрит на полковника. Полковник сует руку в карман, бренчит монетами, трогает щеку, проверяя, чисто ли она выбрита.
— Назначение не совсем в Корпус морской пехоты, — говорит он. — Вы войдете в особое международное подразделение: взвод американских морских пехотинцев и рота британских ВДВ под общим командованием. Бывалые черти, каждый показал, что способен выполнить любое задание в любой обстановке. Это ведь верно вас описывает, морпех?
— Так точно, сэр!
— Это крайне необычная штуковина, — задумчиво говорит полковник, — такая, какая военному никогда бы в голову не пришла. Вы понимаете, о чем я, Шафто?
— Никак нет, сэр! Но я различаю сильный душок политики в кабинете, сэр!
Полковник легонько подмигивает, поворачивается к окну и смотрит на купол Капитолия.
— Эти политики бывают здорово привередливы. Все должно быть в точности так, как они сказали. Они не любят оправданий. Вам ясно, Шафто?
— Так точно, сэр!
— Корпусу пришлось побороться, чтобы нас в это включили. Все собирались отдать армии. Нам пришлось действовать через высокопоставленных людей, бывших флотских. Теперь назначение наше. Если мы его провалим, то на свою голову.
— Сэр! Мы его не провалим, сэр!
— Сукин сын Макартур гробит морских пехотинцев почем зря, потому что мы не всегда правильно разыгрываем политические игры. Если вы и ваше подразделение не отработаете без сучка без задоринки, ситуация станет еще хуже.
— Сэр! Морпех не подведет, сэр!
— Командовать будет лейтенант Этридж, выпускник Аннаполиса. Боевого опыта немного, но умеет вращаться в нужных кругах. Он будет осуществлять взаимодействие на политическом уровне. Ответственность за то, чтобы выполнить задание на местности, возлагается на вас, сержант Шафто.
— Есть, сэр!
— Вы будете работать в тесном сотрудничестве с британскими десантниками. Отличные парни. Но я хочу, чтобы вы и ваши ребята утерли им нос.
— Сэр! Непременно утрем, сэр!
— Ладно, тогда идите собираться, — говорит майор. — Вы отправляетесь в Северную Африку, сержант Шафто.

ЛОНДИНИУМ

Массивные британские монеты брякают в кармане, как оловянная посуда. Лоуренс Притчард Уотерхауз идет по улице. Он в форме кавторанга ВМФ США. Из этого не следует, что он капитан второго ранга или даже служит на флоте, хотя так оно и есть. А вот насчет США сомнений быть не может, потому что всякий раз, сходя с тротуара, он либо выпрыгивает из-под колес, либо замирает, со скрежетом переводя стрелки своих мыслей на другой путь и тратя уйму умственной энергии на попытку увидеть окружающее в большом зеркале. Здесь левостороннее движение.
Он знал об этом раньше. Видел фотографии. И Алан в Принстоне жаловался, что чудом до сих пор не попал под машину.
Тротуары соединяются под прямым углом, а не плавно изгибаются, как в Америке. Переход от тротуара к улице строго вертикальный. Если бы на голову Уотерхаузу поместили зеленую лампочку и наблюдали за ним сбоку во время затемнения, его траектория выглядела бы как прямоугольные импульсы на экране осциллографа — вверх, вниз, вверх, вниз. Происходи это в Америке, импульсы располагались бы равномерно, примерно по двенадцать на милю, потому что в его родном городе улицы образуют правильную решетку.

В Лондоне улицы извиваются, как им вздумается, и распределение импульсов выглядит случайным: иногда они сменяются часто, иногда редко.

Ученый, которому показали бы эти меандры, вероятно, отчаялся бы отыскать в них какую-нибудь закономерность; больше всего они походили бы на случайную последовательность, определяемую космическими лучами или распадом радиоактивного изотопа.
Другое дело, если этот ученый мыслил бы широко и оригинально.
Широты охвата можно достичь, поместив зеленую лампочку на голову каждого пешехода в Лондоне и записывая траектории в течение нескольких ночей. В результате получится толстая кипа миллиметровки с графиками, каждый из которых будет казаться совершенно случайным. Чем толще кипа, тем шире охват.

Оригинальность ума — отдельное дело. Никто не знает, в чем тут финт. Один посмотрит на кипу меандров и не увидит ничего, кроме шума. Другой ощутит странный трепет, не понятный тому, кто подобного не испытывал. Некий глубинный отдел мозга, настроенный на поиск закономерностей (или наличия закономерностей), проснется и прикажет тупой будничной части мозга смотреть на кипу миллиметровки. Сигнал слабый и не всегда осмысленный, но человек просиживает сутками, перебирая кипу бумаг, как аутист, расстилает их по полу, сортирует на кучки по некой неведомой системе, подписывает цифирки и буквы мертвых алфавитов, рисует стрелки, ищет похожие места, сопоставляет их между собой.
Однажды этот человек выйдет из кабинета с подробной картой Лондона, восстановленной по графикам прямоугольных импульсов.
Лоуренс Притчард Уотерхауз — один из таких людей.
Вот почему правительство его страны — Соединенных Штатов Америки — заставило Уотерхауза принести длиннейшую клятву секретности, исправно снабжало его обмундированием различных званий и родов войск, а теперь отправило в Лондон.
Он сходит с тротуара, рефлекторно смотрит налево. В правом ухе звон, визг мотоциклетных тормозов. Это всего лишь британский морской пехотинец на мотоцикле (Уотерхауз уже немного разбирается в знаках отличия), но за ним подкрепление — защитного цвета фургон с написанными по трафарету кодовыми номерами.
— Прошу прощения, сэр! — бодро говорит морской пехотинец и объезжает Уотерхауза, видимо, сообразив, что с задачей додавить союзника вполне справится фургон. Уотерхауз прыгает вперед, прямо под колеса несущегося с другой стороны черного такси.
Впрочем, последний отрезок пути от этой конкретной улицы до Вестминстера он преодолевает без риска для жизни, если не считать близости к хорошо организованной орде немцев, оснащенной лучшими в мире средствами массового уничтожения. Эта часть города похожа на некоторые плохо освещенные закутки Манхэттена. Вдоль узких улочек тянутся десятиэтажные здания. Иногда Уотерхауз видит в просветы между домами впечатляющие готические громады и осознает близость Величия. Как и на Манхэттене, все куда-то деловито спешат.
По военному времени каблуки у пешеходов подкованы, металлические набойки звякают на ходу. У каждого прохожего — примерно постоянная длина шага, он вызвякивает на ходу с точностью метронома. Закрепив микрофон в бровке, шпион мог бы записать какофонию звяканий, случайную на первый взгляд, как писк из счетчика Гейгера. Однако правильный человек способен извлечь сигнал из шума — вычислить соотношение мужчин и женщин, построить гистограмму длины ног...
Надо выбросить все это из головы и сосредоточиться на деле, которое пока еще скрыто мраком.
Над входом в станцию метро Сент-Джеймс-Парк сидит угловатая современная скульптура. Двадцать четыре часа в сутки она наблюдает за Бродвей-билдингс. Как все штабы разведки, которые видел Уотерхауз, здание страшно разочаровывает.
Это в конечном счете всего лишь здание — примерно десять этажей, сложенных из рыжего камня (три верхних составляет непомерно высокая мансарда), чуточка классического орнамента над окнами. Как все окна в Лондоне, они разделены клейкой лентой на восемь прямоугольных треугольников. Уотерхауз находит, что с классической архитектурой это согласуется лучше, чем, скажем, с готикой.
Он изучал физику и не верит, что от ударной волны, когда по соседству взорвутся несколько сот фунтов тринитротолуола, спасет клейкая лента. Скорее это суеверие, круги от сглаза на голландских коровниках в Пенсильвании. Может быть, вид ленты помогает людям сосредоточиться на войне.
На Уотерхауза это не действует. Он вдумчиво переходит улицу, думая о направлении движения, на случай, если из зданий за ним наблюдают. Входит, придерживает дверь стремительной девице в одежде военного покроя (которая всем своим видом показывает, что Уотерхауз ничего не добьется, просто подержав ей дверь), потом — утомленному библейскому старцу с длинными седыми усами.
Вестибюль надежно охраняется. У Лоуренса долго проверяют документы. Затем он, естественно, поднимается не на тот этаж, потому что в Англии они нумеруются по-другому. Все было бы куда смешнее, не происходи это в штабе военной разведки в разгар величайшей войны за всю историю человечества.
Нужный этаж, когда Уотерхауз наконец туда попадает, оказывается просто шикарным. Вообще в Англии шик во всем. Ничто не делается наполовину. Надо пройти милю, чтобы отыскать телефонную кабинку, зато уж выстроена она так, будто в недавнем прошлом немотивированный подрыв телефонных кабинок динамитом представлял собой реальную проблему для общества. А британский почтовый ящик, по всему, остановит немецкий танк. Ни у кого нет автомобиля, но уж если есть, так трехтонная махина ручной сборки. Идея, что можно штамповать машины на потоке, совершенно чужда здешнему сознанию: есть некий заведенный порядок, мистер Форд, которому надо следовать: ручная пайка радиаторов, выстругивание покрышек из цельного куска каучука и все прочее.
То же с официальными встречами. Уотерхауз всегда — Гость; ему еще ни разу не приходилось принимать людей у себя. Гость прибывает в незнакомое здание, сидит в приемной; миловидная, но неприступная особа женского пола предлагает кофеинсодержащий напиток, от которого положено отказаться, потом проводит его в Кабинет, где сидят Главный и Остальные. Знакомят по некоторой системе, в которой Гостю разбираться не обязательно, поскольку он функционирует в пассивном режиме и должен лишь отзываться на сигналы извне: пожимать протянутые руки, отказываться от кофеинсодержащих и (на этой стадии) алкогольных напитков, садиться, где и когда скажут. В данном случае Главный и все Остальные, кроме одного — британцы, выбор напитков слегка иной, Кабинет сложен из массивных глыб, как внутренняя гробница фараона, окна заклеены обычной неубедительной лентой. Фаза Предсказуемого Юмора короче, чем в Америке, фаза Светского Трепа — длиннее.
Уотерхауз перезабывал все их фамилии. Он всегда с ходу забывает фамилии, а даже если бы не забыл, они ничего ему не говорят, потому что перед ним не положили организационные схемы Министерства иностранных дел (которое ведает разведкой) и Военного ведомства. Все постоянно говорят «Вот и Хайс!», и когда он уже готов озираться в поисках Хайса, до него внезапно доходит, что так они произносят «Уотерхауз». Кроме того, в его мозг проникает только одна ремарка — когда кто-то из Остальных говорит о премьер-министре тоном, предполагающим короткое знакомство. А это даже не Главный. Главный гораздо старше и внушительнее. Поэтому Уотерхауз (хотя давно перестал слушать) остается под впечатлением, что по меньшей мере половина присутствующих недавно общались с Уинстоном Черчиллем.
Потом внезапно в разговоре мелькает определенное слово. Уотерхауз не слушал, но почти уверен, что в последние десять секунд кто-то сказал: «Ультра». Он моргает и выпрямляется.
Главный поднимает брови. Остальные озадачены.
— Кажется, несколько минут назад что-то говорили про кофе? — спрашивает Уотерхауз.
— Мисс Стенхоуп, кофе капитану «Вот и Хайсу», — говорит Главный в металлический селектор. Это один из полудюжины учрежденческих селекторов в Британской империи, зато цельнолитой, чугунный, весит сто фунтов и подсоединен к розетке с напряжением 420 вольт проводами толщиною в указательный палец. — И будьте так любезны принести чай.
Теперь Уотерхауз знает, как зовут секретаршу Главного. Что ж, это зацепка. Отталкиваясь от нее, он сможет путем разысканий восстановить фамилию Главного.
Судя по всему, это вернуло их в фазу Светской Болтовни. Американские боссы были бы раздосадованы, британцы же, напротив, демонстрируют явное облегчение. Мисс Стенхоуп просят принести и другие напитки.
— Вы в последнее время видели доктора Шеэна? — спрашивает Уотерхауза Главный с ноткой тревожной заботы в голосе.
— Кого? — Тут Уотерхауз понимает, что речь о каперанге Шойне, и что в Лондоне его имя произносят более правильно.
— Капитан Уотерхауз? — спрашивает Главный через несколько минут. Уотерхауз придумывает новую криптографическую систему, основанную на разном произношении слов, и довольно долго не произносит ни слова.
— Ах да! Я заскочил к нему перед отъездом. Конечно, когда он... э-э... малость не того, с ним запрещено говорить о шифрах.
— Разумеется.
— Беда в том, что, когда у тебя с человеком все общие дела насчет криптологии, трудно удержаться и не нарушить приказ.
— Да, весьма затруднительная ситуация.
— Мне кажется, он более-менее ничего. — Уотерхауз говорит не очень убежденно. В кабинете наступает приличествующая тишина.
— Когда он находился в более благоприятном состоянии, он восторженно писал о вашей работе над «Криптономиконом», — говорит один из Других, до сих пор по большей части молчавший. Уотерхауз решает, что это какая-то шишка в мире машинной криптологии.
— Мировой дядька, — говорит Уотерхауз. Главный использует это как отправную точку.
— Поскольку вы работали с машинами доктора Шойна, то входите в список «Мэджик». Теперь, когда наши страны договорились — по крайней мере в принципе — сотрудничать в области криптологии, это автоматически включает вас в список «Ультра».
— Понятно, сэр, — говорит Уотерхауз.
— «Ультра» и «Мэджик» в значительной степени симметричны. В обоих случаях вражеская держава разработала шифр, который считает абсолютно невзламываемым. В обоих случаях союзная держава взломала шифр. В Америке доктор Шойн и его команда раскололи «Индиго» и построили машину «Мэджик». У нас команда доктора Нокса взломала «Энигму» и построила «Бомбу». Здесь светилом был доктор Тьюринг, у вас — доктор Шойн, но он, как вы выразились, малость не того. Однако он утверждал, что вы вполне на уровне Тьюринга.
— Чертовское преувеличение, — говорит Уотерхауз.
— Вы учились с доктором Тьюрингом в Принстоне, так?
— Мы были там в одно время, если вы меня понимаете. Катались на велосипедах. Нас нечего сравнивать.
— Но ведь доктор Тьюринг учился в аспирантуре, а вы были простым второкурсником.
— Конечно. И все равно он гораздо сильнее меня.
— Вы чересчур скромны, капитан Уотерхауз. Многие ли студенты публикуют статьи в международных журналах?
— Мы просто катались на велосипедах, — упрямо повторяет Уотерхауз. — Эйнштейн даже говорить со мной не захотел.
— Доктор Тьюринг всерьез занимался теорией информации, — произносит не по годам изможденный тип с длинными седыми патлами. Уотерхауз мысленно определяет его как оксфордского профессора. — Вероятно, вы обсуждали с ним эти темы.
Профессор поворачивается к остальным и говорит профессорским тоном:
— Теория информации для механического калькулятора то же, что гидродинамика — для корабельного корпуса. — Потом оборачивается к Уотерхаузу и произносит чуть менее напыщенно: — Доктор Тьюринг продолжал работать в этом направлении после того, как исчез с вашего горизонта и вступил в область Засекреченного. В особенности его интересовало, сколько именно информации можно извлечь из случайных, на первый взгляд, данных.
Внезапно все в кабинете вновь обмениваются удовлетворенными взглядами.
— По вашей реакции я заключаю, — говорит Главный, — что и вы продолжали думать в этом же направлении.
Уотерхаузу интересно, какой была его реакция. Он отрастил клыки? Напустил слюней в кофе?
— Это хорошо, — говорит Главный раньше, чем Уотерхауз успевает ответить, — потому что нам это тоже в высшей степени интересно. Понимаете, сейчас, когда мы прилагаем усилия — подчеркну, предварительные и явно недостаточные усилия скоординировать действия американской и британской разведки, мы оказываемся в нелепейшей ситуации. Мы знаем все, капитан Уотерхауз. Мы читаем личные послания Гитлера военачальникам на местах зачастую раньше самих военачальников. Очевидно, что такое знание — мощнейшее оружие. Но так же очевидно, что оно не поможет выиграть войну, если мы не будем действовать в соответствии с полученным знанием. То есть если с помощью «Ультра» мы узнали, что из Таранто в Северную Африку вышел конвой с припасами для Роммеля, это знание бесполезно, если мы не потопим конвой.
— Ясно, — говорит Уотерхауз.
— Теперь, если десять конвоев вышли и все потоплены, даже те, что двигались ночью или в тумане, немцы спросят себя, как мы их нашли. Они поймут, что мы раскрыли шифр «Энигма», сменят его, и это оружие будет для нас утрачено. Смело могу сказать, что мистера Черчилля огорчит такой поворот событий.
Главный смотрит на Остальных, те важно кивают. У капитана Уотерхауза такое впечатление, что мистер Черчилль относится к этому вопросу весьма серьезно.
— Давайте изложим суть дела в терминах теории информации, — говорит профессор. — Информация течет к нам из Германии через систему «Ультра» в Блетчли-парке. Информация поступает туда в виде случайных на первый взгляд сигналов азбуки Морзе, которые передаются по радио. Но поскольку у нас есть очень умные люди, способные отыскать смысл во внешне случайной последовательности, мы получаем чрезвычайно важную информацию. Так вот, немцы пока не взломали наши главные шифры. Однако они могут наблюдать за нашими действиями — за маршрутами наших конвоев в Северной Атлантике, за перемещениями самолетов. Если конвои всякий раз обходят стороной немецкие подводные лодки, а наши бомбардировщики летят прямиком к немецким конвоям, то немец — я говорю об очень умном немце, о немце-ученом — понимает, что тут действует не случайность. Этот немец может отыскать корреляцию. Он увидит, что мы знаем больше, чем должны бы. Другими словами, с какого-то момента информация начинает течь от нас к немцам.
— Мы должны знать, где этот момент, — произносит Главный. — Знать точно. Чтобы создать впечатление случайности.
— Да, — говорит Уотерхауз, — и это должна быть такая случайность, чтобы обмануть кого-нибудь вроде Рудольфа фон Хакльгебера.
— Именно его мы и имели в виду, — подхватывает профессор. — Доктора фон Хакльгебера, с прошлого года.
— Ой! — радостно восклицает Уотерхауз. — Руди защитился?
Поскольку Руди призвали назад в объятия Тысячелетнего Рейха, Уотерхауз предполагал худшее: Руди в шинели, спит в сугробе где-нибудь под Ленинградом или вроде того. Однако, выходит, фашисты, способные ценить ум (если только этот ум — не еврейский), нашли ему кабинетную работу.
Наступает неловкое молчание. Кто-то из Других, пытаясь разрядить обстановку, шутит, что, если бы Руди догадались задержать в Нью-Джерси, не потребовалось бы вводить гриф секретности «Ультра-Мега». Никто не смеется, и Уотерхауз заключает, что дело обстоит именно так.
Ему показывают схему организации специального подразделения № 2701 ВВС Британии, куда включены все двадцать четыре человека в мире, допущенные к «Ультра-Мега». Верх украшают такие люди, как Уинстон Черчилль и Франклин Делано Рузвельт. Затем идут фамилии, которые кажутся Уотерхаузу смутно знакомыми: может быть, это как раз те, с кем он сейчас разговаривает. Под ними — некий Чаттан, молодой полковник британских ВВС, отличившийся (объясняют Уотерхаузу) в Битве за Британию.
На следующем уровне списка — Лоуренс Притчард Уотерхауз и две другие фамилии: капитан ВВС Британии и капитан МПФ США. Вбок отходит пунктирная линия к Алану Матисону Тьюрингу. В целом это, похоже, самое невероятное собрание людей, когда-либо возникавшее в недрах военной организации. В самом низу схемы располагаются две колонки по шесть фамилий, расположенные под капитанами британских ВВС и американской морской пехоты соответственно. Исполнительное крыло организации: как говорит один из сидящих в кабинете, «люди в забое», или, как поясняет Уотерхаузу единственный американец, «это там, где покрышка соприкасается с шоссе».
— Вопросы есть? — спрашивает Главный.
— Число выбрал Алан?
— Вы имеете в виду доктора Тьюринга?
— Да. Это он выбрал число 2701?
Такие детали явно на несколько уровней ниже статуса людей в Бродвей-билдингс. Они удивлены и немного оскорблены, как будто Уотерхауз попросил их написать под диктовку.
— Возможно, — говорит Главный. — Почему вы спросили?
— Потому что, — отвечает Уотерхауз, — 2701 это произведение двух простых чисел, 37 и 73, которые, будучи записаны в десятичной системе, представляют собой, как вы легко можете видеть, взаимную перестановку цифр.
Все лица обращаются к ученому, который явно пристыжен.
— Это лучше исправить, потому что именно такие вещи может заметить Рудольф фон Хакльгебер. — Он встает, вынимает из кармана авторучку с золотым пером и переправляют 2701 на 2702. Уотерхауз оглядывает собравшихся и приходит к выводу, что все довольны. Очевидно, именно таких салонных фокусов от него и ждут.

КОРРЕХИДОР

В Манильской бухте нет четкой границы между водой и влажным воздухом, только голубовато-серая пелена. «Глория-IV» с полчаса осторожно маневрирует между стоящими на якоре грузовыми судами, потом набирает скорость и устремляется к середине залива. Дымка немного рассеивается, Рэнди хорошо видит по правому борту Батаан: черные горы, по большей части окутанные мглой и испещренные облачными грибами восходящих термальных потоков. Пляжей почти нет, красные склоны обрываются к воде. По мере того как катер огибает полуостров, берег становится положе, видны зеленые луга. На самом конце полуострова — два известняковых утеса, которые Рэнди помнит по кассете Ави. Однако взгляд его прикован к Коррехидору в нескольких милях от полуострова.
Америка Шафто, или Ами, как она предпочитает зваться, большую часть времени проводит вне каюты, оживленно разговаривает с филиппинцами и американцами или сидит по-турецки на палубе, перебирает карты и бумаги. Она надела ковбойскую соломенную шляпу от солнца. Рэнди не торопится подставлять себя прямым лучам: бродит по каюте, потягивает кофе, рассматривает фотографии.
Он наивно ожидал увидеть много снимков, на которых водолазы укладывают кабель. «Семпер марин сервисис» прокладывают много кабеля, и прокладывают хорошо, Рэнди наводил справки, прежде чем заключить контракт. Однако, видимо, здесь не считают, что такую работу интересно снимать. На большей части фотографий — поиск затонувших сокровищ: ныряльщики, широко улыбаясь, демонстрируют облепленные ракушками вазы, словно хоккеисты — Кубок Стэнли.
Коррехидор с этого расстояния — выступающая из воды чечевица джунглей с тянущимся в одну сторону шельфом. Рэнди видел карты и знает, что на самом деле остров имеет форму сперматозоида. То, что отсюда кажется шельфом, на самом деле — хвост, который извивается к востоку, как будто сперматозоид хочет выплыть из Манильского залива, чтобы оплодотворить Азию.
Пробегает Ами, распахивает дверь каюты.
— Идемте в рубку, — говорит она, — посмотрите.
Рэнди идет за ней.
— Кто это на большинстве фотографий? — спрашивает он.
— В шрамах, с «ежиком»?
— Да.
— Мой отец. Дуг.
— Дуглас Макартур Шафто? — спрашивает Рэнди. Он видел это имя на контракте с «Семпер марин».
— Он самый.
— Бывший «Морской лев»* [«Морские львы» — подразделения сил специальных операций ВМС США, предназначенные для ведения разведки и диверсионных операций в портах на морском и речном побережье.]?
— Ага. Только он не любит, когда так говорят. Уж очень заезженно.
— Почему его имя и фамилия кажутся мне знакомыми?
Ами вздыхает.
— Он получил свои пятнадцать минут славы в тысяча девятьсот семьдесят пятом.
— Не могу вспомнить.
— Комстока знаете?
— Генерального прокурора Пола Комстока? Врага криптографии?
— Я про его отца, Эрла Комстока.
— Идеолога холодной войны? Организатора войны во Вьетнаме?
— Никогда не слышала, чтобы его так называли, но да, мы говорим об одном человеке. Может быть, вы помните, что в тысяча девятьсот семьдесят пятом Эрл Комсток выпал, или был вытолкнут, из горнолыжного подъемника в Колорадо и сломал руку.
— Ах да. Вроде вспоминается.
— Отец... — Ами кивает на одну из фотографий, — был на соседнем сиденье.
— Случайно или...
— Чисто случайно. Не преднамеренно.
— Это с какой стороны посмотреть, — говорит Рэнди. — Если Эрл Комсток часто катался на лыжах, довольно велика вероятность, что рано или поздно он оказался бы в пятидесяти футах над землей рядом с ветераном-вьетнамцем.
— Без разницы. Я просто хочу сказать, что мне неохота об этом говорить.
— Я с ним познакомлюсь? — спрашивает Рэнди, глядя на фотографию.
Ами закусывает губу и смотрит на горизонт.
— В девяноста процентах случаев его присутствие на борту означает, что происходит нечто необычное. — Она открывает люк и, придерживая крышку, показывает Рэнди на высокие ступеньки.
— А остальные десять?
— Ему скучно или он поссорился с подружкой.
Рулевой «Глории» занят своим делом и не обращает на них внимания, что Рэнди воспринимает как знак профессионализма. В рубке множество самодельных столов из толстой фанеры или старых дверей, все свободное место занято электроникой: здесь есть факс, машинка поменьше, выдающая сводки погоды, три компьютера, спутниковый телефон, несколько радиотелефонов на базах для подзарядки, эхолот и другие гидроакустические приборы. Ами подводит Рэнди к большому экрану, на котором что-то вроде черно-белого фото гористой местности. «Локатор бокового обзора, — объясняет она. — Незаменимая вещь для такого рода работы. Показывает, что на дне».
Ами смотрит на одном из компьютеров текущие координаты и что-то быстро прикидывает в уме.
— Эрнесто, пять градусов вправо, пожалуйста.
— Есть, мэм, — говорит Эрнесто и поворачивает на пять градусов вправо.
— Что вы ищете?
— Бесплатное приложение, — объясняет Ами. — Маленький бонус для наших клиентов — экскурсия с показом достопримечательностей. Видите? Вот. — Она мизинцем показывает что-то, секунду назад возникшее на экране.
Рэнди нагибается и всматривается. Явно антропогенное образование: мешанина прямых углов и прямых линий.
— Похоже на груду обломков.
— Так и есть, — отвечает Ами. — Когда-то это была значительная часть филиппинского национального достояния.
— Что?!
— Во время войны, — говорит Ами, — после Перл-Харбора, но до того, как японцы заняли Манилу, правительство опустошило казну. Все золото и серебро упаковали в ящики и вывезли на Коррехидор — якобы для сохранности.
— Что значит «якобы»?
Ами пожимает плечами.
— Это Филиппины. У меня такое чувство, что определенная часть ушла на сторону. Однако много серебра оказалось здесь. — Она выпрямляется и кивает на Коррехидор за окном. — Тогда считалось, что Коррехидор неприступен.

Предыдущая страница 6 Следующая страница


7 Нил Стивенсон

— Когда примерно?
— В декабре сорок первого — январе сорок второго. Так или иначе, скоро стало ясно, что Коррехидор падет. В начале февраля одна подводная лодка забрала золото, вторая — людей, которых нельзя было оставлять неприятелю, вроде дешифровщиков. На серебро подлодок не хватило. Макартур оставил Филиппины в марте. Ящики с серебром выносили ночью и бросали в море.
— Вы меня подкалываете?
— Лучше утопить, чем оставить японцам, правда?
— Да, наверное.
— Японцы подняли значительную часть серебра. Они взяли в плен американских водолазов на Батаане и Коррехидоре и заставили их работать. Однако пленные ухитрялись припрятать часть серебра и передать филиппинцам, которые тайком доставляли его в Манилу. Серебра было столько, что оно совершенно подорвало японские оккупационные деньги.
— Так что мы видим сейчас?
— Остатки ящиков, развалившихся от удара о дно, — говорит Ами.
— А после войны серебро еще оставалось?
— Конечно, — легко отвечает Ами. — Большую часть сбросили сюда, и его подняли водолазы, но что-то вывалили в других местах. Одно такое место отец нашел в семидесятых.
— Обалдеть! Ерунда какая-то.
— А что?
— Не поверю, что груды серебра так и лежат тридцать лет бери, кто хочет.
— Вы плохо знаете Филиппины, — говорит Ами.
— Я знаю, что это бедная страна. Почему бы не поднять серебро?
— Большая часть охотников за сокровищами в этой часта мира ищет добычу покрупнее, — говорит Ами, — или полегче.
Рэнди не унимается.
— По-моему, груда серебра на дне бухты — достаточно крупная и легкая добыча.
— Вовсе нет. Серебро не так дорого стоит. Ваза династии Сун, если ее поднять и очистить от ракушек, стоит дороже золота. Золота! А найти ее много легче — просто прощупываешь дно эхолотом. Затонувший корабль дает на экране характерную картинку. А старый ящик, разбитый, поросший кораллами и ракушками, больше всего похож на камень.
По мере того как они приближаются к Коррехидору, Рэнди видит, что хвост у острова корявый, из него там и сям торчат нагромождения каменных глыб. От толстой оконечности острова к кончику хвоста темная зелень джунглей постепенно сменяется более светлой растительностью, затем — красновато-бурой сухой почвой. Рэнди смотрит на один из скалистых выступов, который теперь венчает рупорная антенна, повернутая на восток, к зданию корпорации «Эпифит» в Интрамурос.
— Видите пещеры сразу над водой? — говорит Ами. Она, по всей видимости, жалеет, что завела речь о сокровищах, и теперь хочет сменить тему.
Рэнди с сожалением отводит взгляд от антенны, которой частично владеет, и смотрит туда, куда указывает девушка. Известняковый бок острова, круто уходящий в воду, изъеден дырами.
— Ага.
— Их пробили американцы для береговых орудий. Японцы расширили, и там помещались лодки-камикадзе.
— Обалдеть.
Рэнди слышит низкий горловой звук и, переведя взгляд, видит, что с ними поравнялась лодка. Она узкая и длинная, как каноэ, с балансирами по обоим бортам. На короткой мачте развеваются два флага; повсюду протянуты веревки, на них весело хлопает разноцветное постиранное белье. Посредине большой дизель без кожуха отравляет атмосферу клубами черного дыма. Ближе к носу несколько филиппинцев, включая женщин и детей, перекусывают под ярко-голубым тентом. На корме двое возятся с водолазным снаряжением. Один что-то держит у рта: микрофон. Рация на «Глории» хрипит по-тагальски. Эрнесто подавляет смешок, берет микрофон, коротко отвечает. Очевидно, это что-нибудь вроде: «Потом потреплемся. У нас в рубке клиент».
— Коллеги, — сухо поясняет Ами. По всему видно, что ей хочется отделаться от Рэнди и вернуться к работе.
— Спасибо за экскурсию, — говорит Рэнди. — Один вопрос.
Ами поднимает брови, стараясь выглядеть спокойной.
— Какую часть доходов «Семпер марин» дает охота за сокровищами?
— В этом месяце? В этом году? За десять лет? За все время существования фирмы?
— Без разницы.
— Год на год не приходится, — отвечает Ами. — Мы окупили «Глорию» и еще немного заработали вазами с затонувшего корабля. Но в иные годы весь доход давала работа, как эта.
— Другими словами, скучная работа, от которой тошнит? — спрашивает Рэнди. Выпаливает, не подумав. В нормальных обстоятельствах он лучше контролирует свои слова. Однако борода сбрита, границы «я» разрушены или что-то в таком роде.
Он думает, что Ами рассмеется или хотя бы подмигнет, но она воспринимает его слова совершенно серьезно. У нее классно получается каменное лицо.
— Смотрите на это как на клепку номерных знаков.
— Значит, на самом деле вы — охотники за сокровищами, — подводит итог Рэнди. — А номерные знаки клепаете, чтобы иметь приток денежных средств.
— Зовите нас охотниками за сокровищами, если хотите. Зачем вы пошли в бизнес, Рэнди? — Она поворачивается и выходит.
Рэнди смотрит ей вслед. Эрнесто тихо чертыхается, не столько со зла, сколько от изумления. «Глория» как раз огибает хвост Коррехидора, и становится видна вся южная сторона острова. На протяжении последней полумили хвост изгибается, образуя полукруглую бухту. В середине бухты стоит белый корабль, который Рэнди поначалу принимает за океанский лайнер с жесткими, разбойничьими обводами. Потом он видит на корме название и порт приписки: «РУИ ФАЛЕЙРО — САНТА-МОНИКА, КАЛИФОРНИЯ».
Рэнди подходит к Эрнесто, и они некоторое время вместе глядят на яхту. Рэнди о ней слышал, а Эрнесто, как все на Филиппинах, давно знает. Однако увидеть се своими глазами — совершенно другое дело. На юте, как игрушечка, стоит вертолет. На шлюпбалке кинжалом качается мощный гоночный катер, который в любую минуту можно спустить на воду. Смуглолицый мужчина в ослепительно белой форме драит медный поручень.
— Руи Фалейро был космографом Магеллана, — говорит Рэнди.
— Космографом?
— Мозгом операции. — Рэнди стучит себя по голове.
— Он приплыл сюда с Магелланом? — спрашивает Эрнесто.
Для всего остального мира Магеллан — человек, совершивший первое кругосветное плавание. Здесь каждому известно, что добрался он только до острова Мактан, где был убит филиппинцами.
— Когда Магеллан вышел в море, Фалейро остался в Севилье, — говорит Рэнди. — Он сошел с ума.
— Вы много знаете про Магеллана, да? — спрашивает Эрнесто.
— Нет, — отвечает Рэнди. — Я много знаю про Дантиста.

— Не разговаривай с Дантистом. Никогда. Ни о чем. Даже о технической стороне. Любой его технический вопрос — всего лишь пробный шар в деловой стратегии, до которой тебе — как Даффи Даку до теоремы Геделя.
Ави огорошил этим Рэнди однажды вечером, когда они обедали в ресторане в центре Макати. Ави отказывается говорить о чем-нибудь серьезном в радиусе мили от гостиницы «Манила»; он убежден, что каждый номер и каждый столик прослушиваются.
— Спасибо за доверие, — сказал Рэнди.
— Пойми, — ответил Ави, — я просто пытаюсь застолбить территорию — оправдать свое участие в проекте. Деловой стороной буду заниматься я.
— У тебя, часом, не мания преследования?
— Слушай сюда. У Дантиста примерно миллиард долларов своих и еще десять миллиардов под управлением. Все вонючие ортодонты в Южной Калифорнии ушли на пенсию в сорок лет, потому что Дантист за два или три года удесятерил их индивидуальные пенсионные счета. Хорошим людям деньги сами не плывут.
— Может, ему просто везло.
— Везло, да. Но это еще не значит, что он хороший человек. Я о том, что он инвестирует в крайне рискованные предприятия. Он играет в русскую рулетку на пенсионные сбережения вкладчиков, не ставя их в известность. Он вложил бы деньги в исламистов с Минданао, если бы считал, что захват заложников принесет хорошие дивиденды.
— Интересно, он понимает, что ему везло?
— Мне тоже интересно. Думаю, нет. Думаю, он считает себя орудием Божественного Провидения, как Дуглас Макартур.

«Руи Фалейро» — гордость быстроразвивающегося сиэтлского суперъяхтостроения. Рэнди почерпнул кое-какие сведения о яхте из рекламного буклета, выпущенного еще до того, как Дантист ее купил. Поэтому он знает, что вертолет и гоночный катер входили в сумму сделки, которая не разглашается. В убранстве яхты использовано, помимо всего прочего, десять тонн мрамора. В хозяйских каютах две уборные, М и Ж, отделанные соответственно черным и розовым мрамором, чтобы Дантист и Дива не толклись у одной раковины, готовясь к большому приему в бальном помещении яхты.
— Про Дантиста? — переспрашивает Эрнесто.
— Про Кеплера. Доктора Кеплера, — говорит Рэнди. — В Штатах некоторые люди называют его Дантистом. Люди, занятые в сфере высоких технологий. Эрнесто понимающе кивает.
— Такой человек мог выбрать себе любую женщину в мире, — говорит Эрнесто, — но он выбрал филиппинку.
— Да, — осторожно соглашается Рэнди.
— А в Штатах знают историю жизни Виктории Виго?
— Должен признаться, в Штатах она не так известна, как на Филиппинах.
— Конечно.
— Хотя некоторые ее песни очень популярны. Многим известно, что она выбилась из нищеты.
— А в Штатах знают про Дымную Горку? Про свалку в Тондо, где дети ищут себе еду?
— Некоторые — да. Еще больше узнают, когда фильм про Викторию Виго покажут по телевизору.
Эрнесто удовлетворенно кивает. Здесь всем известно, что выходит фильм про жизнь Дивы с ней самой в главной роли. Однако мало кто в курсе, что фильм заведомо убыточный, снимается на деньги Дантиста и пройдет по кабельному каналу в ночные часы.
Зато, наверное, все понимают, что самого интересного там не будет.

— В том, что касается Дантиста, — сказал Ави, — утешает одно. На Филиппинах он будет совершенно предсказуемый. Ручной. Даже смирный.
— Это почему?
— Виктория Виго — бывшая проститутка, верно?
— Ну, люди перемигиваются и толкают друг друга в бок по этому поводу, но я впервые слышу, чтобы такое сказали вслух, — ответил Рэнди, нервно озираясь.
— Поверь, с Дымной Горки другого пути нет. Проституцией здесь заправляют Болоболо — группа с Северного Лусона, которая пришла к власти вместе с Маркосом. Они контролируют эту сферу жизни: полицию, организованную преступность, местную политику, все такое. Соответственно Виктория Виго на крючке: у них есть фотографии и видеозаписи с тех времен, когда она была малолетней проституткой и снималась в порно.
Рэнди изумленно-брезгливо помотал головой.
— Откуда, черт возьми, ты это все знаешь?
— Не важно. Поверь мне, в определенных кругах это известно не хуже, чем значение числа «?».
— Только не в моих.
— Так или иначе, ее интересы связаны и всегда будут связаны с Болоболо. А Дантист будет послушно выполнять все, что скажет жена.
— Ты уверен? — усомнился Рэнди. — Он — акула бизнеса. Денег и влияния у него, вероятно, побольше, чем у Болоболо. Он волен поступать, как ему вздумается.
— Но не будет, — заявил Ави с полуулыбкой. — Он поступит так, как велит жена.
— Откуда ты знаешь?
— Послушай, — сказал Ави. — Кеплер, как большинство богатых, влиятельных людей, одержим властью, верно?
— Верно.
— Если ты настолько одержим властью, в какие сексуальные предпочтения это должно вылиться?
— Надеюсь никогда не узнать. Наверное, я хотел бы подавлять женщину.
— А вот и нет! — сказал Ави. — Секс гораздо сложнее, Рэнди. Секс — это то, где вылезают наружу подавленные желания. Люди сильнее всего заводятся, когда обнажаются их самые глубинные тайны...
— Черт! Кеплер — мазохист?
— Он такой гребаный мазохист, что прославился своим мазохизмом. По крайней мере, в восточноазиатской секс-индустрии. Сутенеры и хозяйки борделей в Гонконге, Бангкоке, Шенжене, Маниле — все имеют на него досье и точно знают, что ему нужно. Так он и познакомился с Викторией Виго. Он был в Маниле, прорабатывал сделку с «ФилиТел». Жил в отеле, которым владеют и который прослушивают Болоболо. Они изучали его случки, как энтомологи изучают спаривание муравьев. Они запрограммировали Викторию Виго — свою козырную карту, свою бомбу, своего сексуального Терминатора, — чтобы дать в точности то, что он хочет, потом направили в его жизнь, как ракету точного наведения, и бац! — истинная любовь.
— И он ничего не заподозрил? Меня удивляет, что он настолько увлекся шлюхой.
— Он не знал, что она шлюха! В этом-то вся красота плана! Болоболо подсадили ее консьержкой ему в отель! Скромную католическую школьницу! Началось с того, что она заказывала Кеплеру билеты в театр, а через год он лежит на своей гребаной мегаяхте с исполосованной задницей, прикованный наручниками к кровати, а она стоит рядом, и на пальце у нее обручальное кольцо размером с автомобильную фару — сто тридцать восьмая в списке самых богатых женщин планеты!
— Сто двадцать пятая, — поправил его Рэнди. — Акции «ФилиТел» недавно пошли вверх.

Следующие несколько дней Рэнди проводит, стараясь не столкнуться с Дантистом. Он остановился в маленькой частной гостинице на вершине острова, каждое утро пьет кофе с булочкой в компании американских и японских ветеранов. Они приехали сюда вместе с женами, чтобы (предполагает Рэнди) разобраться с чувствами, в миллион раз более глубокими, чем все, что когда-либо доводилось испытывать ему самому. «Руи Фалейро» постоянно на виду, и Рэнди может определить, на борту ли Дантист, наблюдая за вертолетом и катером.
Когда он думает, что все безопасно, то идет на берег под УКВ-антенной и смотрит, как водолазы Ами возятся с кабелем. Некоторые работают в прибрежной полосе, завинчивают вокруг кабеля секции металлических труб. Другие — милях в двух от берега, рядом с баржей, которая укладывает кабель непосредственно в илистый грунт с помощью исполинского приспособления, похожего на мясницкий нож.
Береговой отрезок кабеля тянется в новое железобетонное здание в ста метрах от верхней приливной отметки. Собственно, это одно большое помещение, набитое аккумуляторами, генераторами, кондиционерами и электронным оборудованием. За программы, которые на этом оборудовании крутятся, отвечает Рэнди, поэтому; он проводит большую часть времени в здании, глядя на монитор и стуча по клавиатуре. Отсюда тянутся провода к УКВ-башне.
Другой конец кабеля уходит туда, где в Южно-Китайском море качается на волнах буй. До него несколько километров. Буй отмечает конец Северо-Лусонского Кабеля, принадлежащего компании «ФилиТел». Если двигаться вдоль него, попадешь в здание на северной оконечности острова, куда подходит большой кабель с Тайваня. К Тайваню, в свою очередь, сходится целая подводная кабельная сеть. Передавать данные на Тайвань и с Тайваня просто и дешево.
В линии передачи, которой «Эпифит» и «ФилиТел» пытаются связать Тайвань и Манилу, только один зазор, и он уменьшается день ото дня, по мере того как баржа смещается к бую.

Когда они наконец сходятся, «Руи Фалейро» поднимает якорь и движется к месту встречи. Вертолет, гоночный катер и флотилия нанятых лодок курсируют между яхтой и берегом, доставляя из Манилы важных людей и прессу. Появляется Ави с двумя смокингами из шанхайского ателье («Все знаменитые гонконгские портные — беженцы из Шанхая»). Они с Рэнди разрывают оберточную бумагу, облачаются и едут в джипе с кондиционером к пристани, где дожидается «Глория».
Через два часа Рэнди впервые видит Дантиста и Диву в большом бальном зале «Руи Фалейро». Для Рэнди это прием как прием — он жмет людям руки, тут же забывает как их зовут, садится и в одиночестве принимается за еду и вино.
Единственное, что здесь необычно — на шканцах лежат два кабеля, каждый толщиной с бейсбольную биту. Если подойти к фальшборту, можно увидеть, как их концы уходят в пучину. Противоположные концы сходятся на столе посреди палубы, где техник, доставленный самолетом из Гонконга и облаченный в смокинг, мается со стыковкой. Еще он мается с тяжелого бодуна, но Рэнди ничуть не встревожен: он знает, что все это исключительно для понта и оба куска кабеля заканчиваются в воде рядом с яхтой. Настоящее соединение выполнено вчера, кабель лежит на дне, и по нему уже бегут биты.
На шканцах еще один человек. Он смотрит на Батаан и Коррехидор, одновременно наблюдая за Рэнди. Поймав взгляд Рэнди, кивает, как будто мысленно сверился с каким-то списком, встает и подходит. На нем парадная военная форма, флотский аналог смокинга. Он почти лыс, оставшаяся седина сострижена миллиметрах в пяти от головы. Когда он идет к Рэнди, несколько филиппинцев наблюдают за ним с явным любопытством.
— Здравствуйте, Рэнди. — Человек в форме жмет Рэнди руку, медали звякают друг о друга. На вид ему лет пятьдесят, но кожа — как у восьмидесятилетнего бедуина. На груди множество ленточек, в основном красно-желтых, что у Рэнди смутно ассоциируется с Вьетнамом. Над карманом пластиковая табличка: «ШАФТО».
— Не обманывайтесь, Рэнди, — говорит Дуглас Макартур Шафто. — Я не на действительной службе. Сто лет как в запасе. Однако форму имею право носить. И это гораздо проще, чем найти на меня смокинг.
— Рад познакомиться.
— Я тоже. Кстати, откуда ваш?
— Смокинг?
— Да.
— Заказали.
— Подруга?
— Партнер. Я временно без подруги.
— Значит, вы не обзавелись спутницей в Маниле. В отличие от нашего хозяина.
Рэнди смотрит в бальный зал на Викторию Виго. Если бы она сияла еще сильнее, со стен бы полезла краска, а подоконники начали оседать, как воск.
— Наверное, я слишком стеснительный или вроде того, — говорит Рэнди.
— Стеснительность не помешает вам выслушать деловое предложение?
— Отнюдь.
— Моя дочь полагает, что вы и наш хозяин намерены в будущем проложить еще несколько кабелей.
— В бизнесе редко что-то делают один раз, — говорит Рэнди. — Это затрудняет бухгалтерию.
— Вы уже знаете, что море здесь очень мелкое.
— Да.
— И знаете, что кабель нельзя прокладывать в мелкой воде без предварительной очень детальной локационной съемки морского дна.
— Да.
— Съемку хотел бы провести я.
— Понятно.
— Нет, не думаю, чтобы вам было понятно. Однако я хочу, чтобы вы поняли, поэтому объясню.
— Хорошо, — кивает Рэнди. — Позвать партнера?
— Идея, которую я намерен предложить, очень проста, и для ее восприятия не нужны два первоклассных специалиста.
— Отлично. Что за идея?
— Подробная съемка даст чертову уйму информации обо всем, что лежит па морском дне. Часть информации может оказаться ценной. Ценнее, чем вы ожидаете.
— А, — говорит Рэнди, — вы хотите сказать, это может быть то, что ваша фирма умеет обращать в капитал.
— Да, — отвечает Дуг Шафто. — Если вы наймете кого-нибудь из моих конкурентов, они, наткнувшись на такую информацию, используют ее сами, а вам ничего не скажут. Вы не узнает об их находках и не получите прибыли. Если вы наймете «Семпер марин сервисис», я буду сообщать обо всех находках. Вы и ваша фирма получите свою долю.
— M-м, — тянет Рэнди. Он пытается сделать каменное лицо, но понимает, что Дуг Шафто видит его насквозь.
— При одном условии, — говорит Дуг Шафто.
— Я подозревал, что будут условия.
— Любая стоящая приманка насажена на крючок. Это крючок.
— И в чем он состоит?
— Ни слова этому козлу. — Дуг Шафто поводит большим пальцем в сторону Хьюберта Кеплера. — Потому что если Дантист разнюхает, они с Болоболо все приберут к рукам и нам ничего не достанется. Есть даже шанс, что нас просто убьют.
— Ну, насчет «просто убьют» и впрямь стоит подумать, — говорит Рэнди, — но я передам партнеру ваше предложение.

ТУННЕЛЬ

Уотерхауз и несколько десятков незнакомцев стоят и сидят в необыкновенно узком, вытянутом помещении, которое раскачивается из стороны в сторону. В помещении длинный ряд окон, но свет через них не идет, только звук: грохот, дребезжание и скрежет. Все погружены в себя и молчат, как в церкви перед началом службы.
Уотерхауз стоит, держась за петлевидный отросток потолка, иначе полетит спиной. Последние две минуты он внимательно разглядывал плакат с инструкцией по надеванию противогаза. У него самого, как и у всех, противогаз с собой, в брезентовой сумке через плечо. Сумка, правда, не такая, как у всех, потому что она американская и военного образца. На нее косятся.
На плакате — светлоликая модница с золотисто-каштановыми волосами, которые явно химически размягчили и заново отформовали в дорогой парикмахерской. Стоит прямо, как по струнке, подбородок выставлен, локти согнуты, ладони сложены в ритуальном жесте: пальцы в стороны, большие — вертикально вверх. На уровне лица в хитросплетении защитного цвета тесемок болтается жутковатый комок. Поднятые большие пальцы — опорная конструкция тесемочной паутины.
Уотерхауз в Лондоне уже два дня и в курсе, что будет дальше. Он узнает эту позу где и когда угодно. Красавица изготовилась, чтобы сделать энергичное движение подбородком. Если столица подвергнется газовой атаке, верхушки массивных почтовых ящиков, покрытые специальной краской, почернеют и раздастся определенный сигнал. Двадцать миллионов больших пальцев взметнутся к ядовито-зеленым, отравленным небесам. Десять миллионов противогазов повиснут в воздухе. Десять миллионов подбородков рывком вдвинутся в маску. Уотерхауз почти слышит скрип, с которым нежная кожа красавицы втискивается в тугую черную резину.
Как только подбородок всунут, все в порядке. Надо еще аккуратно распределить тесемки на золотисто-каштановом перманенте и побыстрее добраться до закрытого помещения, но самое страшное позади. У британских противогазов впереди круглая плоская нашлепка, чтобы дышать, в точности как свиной пятачок. Ни одна женщина не согласилась бы, чтобы ее застали мертвой в такой штуке, если бы их не надевали на плакатах безупречные красавицы.
Что-то мелькает в темноте за окном. Поезд едет в той части подземки, где брезжит тусклый свет, обнажая стигийские тайны метро. Все в вагоне моргают, переглядываются, вздыхают. Вокруг на мгновение вновь материализовался мир. Фрагменты стены, металлические балки, пучки кабеля небесными телами проплывают в пространстве по мере того, как поезд ползет мимо.
Уотерхауз смотрит на кабели. Они тянутся параллельно и прикреплены к стене металлическими скобами — словно побеги некоего глубинного плюща, расползаются во мраке метро, тайком от обслуживающего персонала ищут, как бы пробиться наружу, к свету.
На улице, в Надземье, можно видеть, как первые цепкие усики карабкаются по древним стенам зданий. Неопреновые лианы, будто по отвесу, взбираются по вертикальной плоскости и проникают в дыры оконных рам, особенно тяготея к учреждениям, Иногда они заключены в трубы. Иногда хозяева их закрашивают Но у всех — общая корневая система, которая идет по туннелям и щелям подземелья, сходясь к исполинским коммутаторам в глубоких бетонных бункерах.
Поезд врывается в храм грязновато-желтого света, со стоном останавливается под сводами. Аляповатые иконы общенационального умопомешательства поблескивают в нишах и боковых приделах. Ангелоподобная женщина с противогазом — на одном конце морального континуума. На противоположном — дьяволица в узкой юбке посреди людной гостиной шпионски ухмыляется из-под накладных ресниц, ловя неосторожные слова наивных молодых офицериков.
Табличка на стене внушающим доверие официальным рубленым шрифтом утверждает, что это Юстон. Уотерхауз и большая часть остальных пассажиров выходят. Минут пятнадцать его рикошетит по станции. Он спрашивает, куда идти, путается, снова спрашивает. Наконец он в поезде на Бирмингем, который, по слухам, останавливается в месте под названием Блетчли.
Неразбериха происходит отчасти оттого, что с соседней платформы отходит другой поезд, который следует до конечной станции Блетчли без остановок. Почти все пассажиры этого поезда девушки в одежде военного покроя.
Люди в форме британских ВВС с пистолетами-пулеметами марки СТЭН проверяют документы у дверей поезда. Уотерхауза они не впускают.
Уотерхауз смотрит на девушек через желтый светофильтр окна: те разбиваются на кучки, достают вязанье, чтобы превратить клубки шотландской шерсти в перчатки и подшлемники для матросов в Северной Атлантике, пишут письма братьям в армию и родителям домой. Автоматчики стоят у дверей, пока все они не закрываются и поезд не отходит от платформы. По мере того как он набирает скорость, ряды девушек — вяжущих, щебечущих, пишущих — сливаются в то, что, наверное, грезится солдатам и матросам по всему миру. Уотерхаузу никогда не быть среди этих солдат, на передовой, лицом к лицу с неприятелем. Он вкусил от плода запретного знания. Ему запрещается быть там, где он может попасть в плен.

Поезд выбирается из ночи в краснокирпичное сухое русло и продолжает движение на север. Примерно три часа дня: поезд в Блетчли, вероятно, везет вечернюю смену.
Уотерхауз думает, что вряд ли будет работать по четкому графику. В вещмешке, который ему собрали, весь спектр интендантских возможностей: свитера, комплекты тропической формы, армейский и флотский, черная лыжная маска, презервативы.
Поезд нехотя расстается с городом и въезжает в предместье. Уотерхауза вжимает в сиденье — видимо, рельсы идут в гору. За выемкой, которая проделана в холме, как зарубка в полене, начинается территория лугов, усеянных маленькими белыми капсулами. Уотерхауз предполагает, что это овцы.
Разумеется, их распределение наверняка не случайно — скорее всего оно отражает особенности рельефа и химический состав почв, которым определяется вкус и питательность травы. С помощью аэрофотосъемки немцы могли бы, исходя из распределения овец, составить карту химического состава британских почв.
Поля обрамляют старые плетни, каменные ограды и, особенно выше, лес. Примерно через час лес подступает вплотную к поезду, скрывая склон, идущий полого вверх от железнодорожного полотна. Шипят тормоза, поезд тихонько останавливается у полустанка. Однако запасных путей и стрелок куда больше, чем предполагает размер станции. Уотерхауз встает, крепко упирается ногами, принимает стойку борца сумо и вступает в единоборство с вещмешком. Вещмешок явно берет верх — он выталкивает Уотерхауза на платформу.
Здесь сильнее обычного пахнет углем, неподалеку что-то гремит и лязгает. Уотерхауз смотрит вперед и видит множество железнодорожных путей, на которых разворачиваются тяжелые промышленные работы. Пока поезд трогается, он стоит и смотрит, как в депо Блетчли чинят паровозы. Уотерхаузу нравятся поезда.
Однако ему не для того выдали бесплатные комплекты одежды и билет до Блетчли, поэтому Уотерхауз вновь вступает в борьбу с вещмешком и затаскивает его на мост, перекинутый через железнодорожные пути. Он смотрит вперед и видит на перроне еще девушек из женской вспомогательной службы. Утренняя смена закончилась; на сегодня они свободны от работы которая состоит в беспрестанном перемалывании внешне произвольных букв и цифр. Не желая выглядеть смешным в их глазах, Уотерхауз наконец взваливает вещмешок на спину и, продев руки в лямки, под его напором преодолевает мост.
Девушки лишь самую малость заинтригованы появлением американского офицера. А может, они просто такие скромные. Во всяком случае, Уотерхауз заключает, что он один из немногих, но не первый. Вещмешок проталкивает его через крохотный вокзальчик, словно верзила-полицейский — скрученного в бараний рог пьянчугу через вестибюль двухзвездочной гостиницы.
Уотерхауза выбрасывает на полоску открытой местности вдоль шоссе. Прямо впереди — лес. Всякую мысль о том, что лес этот — приветливый, развеивают леденящие проблески вдоль опушки: в лучах низкого солнца видно, что вся граница леса утыкана острым металлом. Некое жерло, похожее на нору исполинского шершня, извергает наружу поток женщин-военнослужащих.
Если Уотерхауз замрет без движения, вещмешок уронит его навзничь, и он будет беспомощно трепыхаться, как перевернутый жук. Поэтому он устремляется вперед, через шоссе, на широкую тропу в лес. Теперь он в толпе девушек. По случаю окончания смены они накрасили губы. В военное время качественный материал идет на смазку для самолетных винтов; на губную помаду пускают отходы и ошметки. Чтобы скрыть ее невыразимое минерально-животное происхождение, нужна сильнейшая парфюмерная отдушка.
Это — запах войны.
Уотерхауз еще не видел Блетчли-парк, но знает главное. Он знает, что эти милые девушки, которые смену за сменой добросовестно скармливают машинам тонны непонятной галиматьи, убили больше людей, чем Наполеон.
Уотерхауз медленно, с извинениями, протискивается через встречную волну утренней смены. В какой-то момент он просто сдается, отступает на шаг в сторону, сгружает вещмешок в заросли плюща, закуривает и ждет, пока примерно сотня девушек пройдет мимо. Что-то тычет его в ногу: ветка дикой малины в острых колючках. На ней — тонюсенькая паутинка, радиально-лучистые нити поблескивают в закатном свете. Паучок в середине — невозмутимый британец, которому дела нет до неуклюжего янки с его вывертами.
Уотерхауз тянет руку и ловит в воздухе желтовато-бурый листок вяза. Он нагибается, зажимает сигарету в зубах и, двумя руками направляя лист, ведет зубчатым краем по радиальной, не клейкой, как он знает, нити. Лист, подобно смычку, заставляет паутину вибрировать. Паучок разворачивается мгновенно, как в плохо смонтированной киноленте. Уотерхауз так поражен стремительностью его движений, что даже отшатывается, потом снова проводит листом по нити. Паучок чувствует вибрацию и настороженно замирает.
Довольно скоро он возвращается в прежнее положение и больше не обращает на Уотерхауза никакого внимания.
Паучок по вибрации определяет, какое насекомое попало в сеть. Поэтому-то паутина устроена радиально, а паук сидит в центре. Нити — продолжение его нервной системы. Информация через паутину попадает к пауку и обрабатывается некоей внутренней машиной Тьюринга. Уотерхауз пробовал много разных уловок, но еще ни разу не сумел обмануть паука. Дурной знак!
Пока он занимался научными исследованиями, пересменок закончился. Уотерхауз вновь берется за вещмешок. В единоборстве они преодолевают еще ярдов сто по тропе, которая внезапно впадает в дорогу: как раз там, где ее перегораживают чугунные ворота на бестолковых обелисках красного кирпича. Часовые здесь — тоже бойцы ВВС со СТЭНами. Сейчас они изучают документы у мужчины в плащ-палатке и мотоциклетных очках: он только что подъехал на мотоцикле с контейнерами на багажнике. Контейнеры не очень полные, но закреплены основательно: в них тот самый боезапас, который девушки закладывают в пасть своих смертоносных машин.
Мотоциклисту машут: проезжай; он тут же сворачивает на узкую дорожку влево. Внимание переключается на Лоуренса Притчарда Уотерхауза, который после установленного обмена приветствиями предъявляет удостоверение и пропуск.
Ему не удается скрыть от часовых, что удостоверений — целая стопка. Их это не удивляет и не смущает — заметное отличие от всех часовых, с которыми Уотерхаузу приходилось иметь дело. Разумеется, у них нет допуска «Ультра-Мега», и сказать, что он здесь по поводу «Ультра-Мега», было бы серьезным нарушением режима. Судя по всему, они насмотрелись на людей, которые не могут назвать своей настоящей цели, и бровью не поводят, когда Уотерхауз выдает себя за сотрудника спецсвязи из четвертого или восьмого корпуса.
В восьмом корпусе расшифровывают флотские сообщения с кодом «Энигма». В четвертом анализируют расшифровки. Уотерхаузу не удалось бы долго выдавать себя за человека из четвертого корпуса, поскольку тамошним сотрудникам положено на самом деле разбираться во флотских вопросах. По всем параметрам он — сотрудник восьмого корпуса, которому положено знать одну только чистую математику.
Часовой изучает его документы, заходит в караулку и крутит телефонный диск. Уотерхауз неловко стоит, разглядывая оружие у часовых на плече. На его взгляд, это просто стальная труба с приделанным курком. Через прорезанное в трубке окошко видна сжатая пружина. Несмотря на то что к трубке в нескольких местах привинчены рукоятки, полное впечатление, что все это задумано и сделано троечником в школьной слесарной мастерской.
— Капитан Уотерхауз? Вас просят пройти в усадьбу, — говорит часовой, вернувшийся от телефона. — Идите прямо, ее нельзя не заметить.
Уотерхауз проходит футов пятьдесят и убеждается, что не заметить усадьбу действительно нельзя. Целую минуту он стоит, желая постичь замысел архитектора. Особенно изумляет количество фронтонов. Видимо, строители хотели воздвигнуть один большой дом, замаскировав его под десяток городских зданий, втиснутых в шесть акров Бекингемширских сельхозугодий.
Место очень ухоженное, однако и здесь по кирпичным стенам взбираются черные лианы. Корневая система, которую Уотерхауз видел в метро, распространилась под лесами и пастбищами и пустила вверх неопреновые побеги. Этот организм — не фототрофный, он тянется не к свету и солнцу. Он — инфотрофный. И тянется сюда по той же причине, по какой в это место съезжаются инфотрофные люди вроде Лоуренса Притчарда Уотерхауза и доктора Алана Матисона Тьюринга, поскольку в мире информации Блетчли-парк — все равно что Солнце в Солнечной системе. Армии, народы, премьер-министры, президенты и гении обращаются вокруг него, но не по стабильным планетарным орбитам, а по шальным эллипсам и гиперболам, как кометы или блуждающие астероиды.
Доктор Рудольф фон Хакльгебер не может увидеть Блетчли-парк, потому что это самый большой государственный секрет после «Ультра-Мега». Однако из своего берлинского кабинета, перебирая донесения Beobachtung Dienst* [«Служба наблюдения» (нем.) — дешифровальный орган немецких ВМС.], он может наблюдать обрывки траекторий и строить гипотезы, которые бы их объясняли. Если единственное логическое объяснение — что союзники взломали «Энигму», значит, подразделение 2702 не справилось с задачей.
Лоуренс протягивает документы и проходит между парой обшарпанных грифонов. Когда не видно фасада, усадьба очень даже ничего. Иллюзия нескольких домов позволила устроить много эркеров, что дает столь необходимый свет. Потолок в вестибюле поддерживают колонны и арки дешевого бурого мрамора, похожего на окаменелые нечистоты.
Здесь очень шумно: неумолчный звук, похожий на бурные аплодисменты, проникает через стены и двери вместе с горячим воздухом и едким запахом машинного масла. Это отличительные признаки электрических телетайпов. Судя по звукам и жару, в нижних помещениях их десятки.
Уотерхауз поднимается по обшитой деревом лестнице на этаж, который британцы зовут первым. Здесь тише и прохладнее. На этом этаже сидит большое начальство. Если в Блетчли действует обычный бюрократический распорядок, то первый визит сюда должен быть и последним. Уотерхауз находит кабинет полковника Чаттана, который (при виде фамилии на двери в памяти что-то щелкает) возглавляет списочный состав подразделения 2702.
Чаттан встает и протягивает руку. Он белобрысый, голубоглазый и, наверное, был бы сейчас розовощеким, если бы не глубокий пустынный загар. На нем парадная форма; британские офицеры шьют обмундирование на заказ, поскольку иного способа обзавестись им просто не существует. Уотерхауз не шибко разбирается в одежде, но даже он видит, что эту форму шила не мамаша по вечерам при свете камина. Нет. Чаттан где-то раскопал первоклассного портного. Однако когда он произносит фамилию «Уотерхауз», это не «Вот и Хайс», как в Бродвей-билдингс. «Р» звучит четко и раскатисто, «хаус» — протяжно и немного гнусаво. Черт его разберет, что за акцент.
Кроме Чаттана, в кабинете мужчина поменьше ростом в солдатской робе — свободной, но плотно охватывающей запястья и щиколотки. Она сшита из защитной шерстяной фланели и была бы очень жаркой, если бы не стабильная температура 13° в домах и на улице. Чаттан представляет человека в робе как лейтенанта Робсона. Он возглавляет один из взводов подразделения 2702 — воздушно-десантный. Коротко подстриженные усы щеткой, русые с проседью бакенбарды; держится бодрячком, во всяком случае, в обществе старших офицеров, и часто улыбается. Зубы у него радиально расходятся от десен, так что каждая челюсть похожа на банку из-под кофе, в которой взорвалась небольшая граната.
— Это тот, кого мы ждали, — объясняет Чаттан Робсону. — Кого нам не хватало в Алжире.
— Да! — говорит Робсон. — Добро пожаловать в подразделение 2701.
— 2702, — поправляет Уотерхауз.
Чаттан и Робсон слегка удивлены.
— 2701 не годится, потому что это произведение двух простых.
— Виноват? — говорит Робсон.
Что Уотерхаузу нравится в британцах: когда они ни черта не понимают в твоих словах, то хотя бы допускают, что дело в них самих. Робсон, судя по виду, выслужился из рядовых. Американец такого склада уже бы оскорбился и набычился.
— Каких? — спрашивает Чаттан. Это обнадеживает: он по крайней мере знает, что такое простые числа.
— 73 и 37, — говорит Уотерхауз.
На Чаттана это производит весьма глубокое впечатление.
— Да, ясно. — Он качает головой. — Надо будет хорошенько поддеть профессора по этому поводу.
Робсон так сильно склонил голову набок, что почти коснулся подсунутого под погон толстого шерстяного берета. Он сощурился и совершенно обескуражен. Американец на его месте потребовал бы немедленно объяснить ему всю теорию простых чисел, а выслушав, объявил бы ее собачьим вздором. Однако Робсон спрашивает только:
— Следует ли понимать, что мы меняем номер подразделения?
Уотерхауз нервно сглатывает. По лицу Робсона ясно, что это чертова морока для него и для подчиненных: закрашивать единицу, набивать по трафарету двойку, проводить новый номер через дебри армейской бюрократии. Куча лишней канители.
— 2702, — бросает Чаттан. В отличие от Уотерхауза он спокойно отдает трудные, непопулярные приказы.
— Хорошо. Сейчас мне придется заняться кое-какими делами, — говорит Робсон. — Очень приятно было познакомиться, капитан Уотерхауз.
— Взаимно.
Робсон снова пожимает Уотерхаузу руку и выходит.
— Тут для вас ордер в один из корпусов к югу от столовой, — говорит Чаттан. — Наш номинальный штаб — в Блетчли-парке, но мы предполагаем, что большую часть времени будем проводить в тех зонах боевых действий, где особенно активно используется «Ультра».
— Как я понимаю, вы были в Северной Африке? — говорит Уотерхауз.
— Да. — Чаттан поднимает брови, вернее, то место кожи, где они, вероятно, находятся — волоски прозрачны, словно капроновая нить. — Боюсь, все едва не закончилось совсем плохо.
— Попали в переделку?
— Я о другом, — говорит Чаттан. — Я про секрет «Ультра». Мы до сих пор не уверены, что он в целости. Однако профессор сделал кое-какие расчеты и говорит, что на этот раз, кажется, пронесло.
— Профессор — это доктор Тьюринг?
— Да. Вы знаете, что он лично вас рекомендовал?
— Когда пришли приказы, я примерно так и предположил.
— Тьюринг сейчас занят по меньшей мере на двух фронтах информационной войны, так что не может присоединиться к нашей теплой компании.
— Что произошло в Северной Африке, полковник Чаттан?
— Все еще происходит, — с улыбкой говорит Чаттан. — Наши морские пехотинцы по-прежнему в зоне боевых действий, расширяют колокол.
— Расширяют колокол?
— Ну, вы лучше моего знаете, что случайные величины чаще всего имеют колоколообразное распределение. Рост служащих, например. Подойдемте к окну, капитан Уотерхауз.
Из окна открывается вид на то, что когда-то было полого воздымающейся сельской местностью. За полоской леса Уотерхауз видит зеленые луга с редкой россыпью домиков: так, наверное, выглядел прежде сам Блетчли-парк.
Теперь он выглядит иначе. На протяжении полумили практически все пространство застроено или заасфальтировано. Сразу после усадьбы с ее затейливыми флигелями начинаются одноэтажные кирпичные строения. По сути это длинные коридоры с многочисленными поперечными нефами: +++++++, где новый + добавляется с той скоростью, с какой строители успевают класть кирпичи. (Уотерхауз походя думает, не видел ли Руди аэрофотоснимки этого места и не вывел ли из плюсиков математическую природу учреждения.) Проходы между домами извилистые, узкие, да еще и разрезаны надвое восьмифутовыми противоударными стенами, чтобы фрицам пришлось потратить как минимум по бомбе на каждый корпус.
— Вот в этом здании, — Чаттан указывает на строеньице неподалеку (жуткого вида бетонный сарай), — стоят «Бомбы» Тьюринга. Вычислительные машины, которые создал ваш друг профессор.
— Настоящие универсальные машины Тьюринга? — выпаливает Уотерхауз. Перед ним вспыхивает ослепительное видение, будто Блетчли-парк на самом деле — тайное королевство, в котором Алан сумел-таки воплотить свою великую мечту. Королевство, где правят не люди, а информация, где смиренные корпуса, составленные из плюсиков, суть вместилище Универсальных Машин, способных при надлежащей настройке выполнить любую счетную операцию.
— Нет, — говорит Чаттан с печальной, тихой улыбкой.
Уотерхауз шумно выдыхает.
— Может быть, они появятся через год-два.
— Может быть.
— Тьюринг, Уэлшман и другие построили «Бомбы» на основе разработок, сделанных польскими криптоаналитиками. Они состоят из вращающихся барабанов, которые с большой скоростью перебирают множество ключей к «Энигме». Уверен, профессор вам все объяснит. Но суть в том, что сзади у них большие штекерные панели, как на телефонном коммутаторе, и часть девушек заняты тем, что целый день вставляют штекеры в гнезда. Для этой работы требуются хорошее зрение, внимательность и рост.
— Рост?
— Вы заметите, что этим занимаются исключительно рослые девушки. Если немцы каким-то образом раздобудут данные обо всех работающих в Блетчли-парке и построят гистограммы их роста, они увидят нормальное колоколообразное распределение, характеризующее большинство служащих, с аномальным всплеском, вызванным тем, что для работы со штекерами набрали исключительно рослых девушек.
— Ясно, — говорит Уотерхауз. — И кто-нибудь вроде Руди — доктора фон Хакльгебера — заметит аномалию и задумается.
— Вот именно, — отвечает Чаттан. — А задача подразделения 2702 — группы «Ультра-Мега» — вбрасывать ложную информацию, чтобы сбить вашего друга Руди со следа. — Чаттан отворачивается от окна, идет к столу, открывает портсигар, плотно набитый свежим запасом, и ловким жестом предлагает Уотерхаузу сигарету. Тот берет, скорее за компанию. Чаттан протягивает зажженную спичку и, глядя через огонь Уотерхаузу в глаза, говорит: — Дальше давайте сами. Как бы вы скрыли от вашего друга Руди, что у нас здесь много высоких девушек?
— Предполагая, что у него уже есть личные данные?
— Да.
— Тогда поздно что-нибудь скрывать.
— Принято. Давайте допустим, что есть некий канал информации, по которому эти данные поступают отдельными порциями. Канал открыт и функционирует. Закрыть его мы не можем. Или предпочитаем не закрывать, поскольку само закрытие канала сообщит Руди нечто важное.
— Тогда так, — говорит Уотерхауз. — Мы фабрикуем личные данные и запускаем их в канал.
На стене у Чаттана в кабинете — небольшая доска. Это палимпсест* [Палимпсест — рукопись на пергаменте поверх смытого или соскобленного текста.], не очень хорошо стертый — видимо, доску запрещено мыть, чтобы не пропало что-нибудь важное. Уотерхауз, подойдя, видит наслоения выкладок, постепенно гаснущие во мраке, как луч света в глубоком космосе.
Почерк Алана. Уотерхауз почти физическим усилием заставляет себя не восстанавливать выкладки по призрачным следам на доске. Он нехотя отрывается от формул.
Уотерхауз чертит на доске оси абсцисс и ординат, потом проводит колоколообразную гауссову кривую. Справа от пика пририсовывает небольшой бугорок.

— Вот высокие девушки. Проблема в этом прогибе. — Он указывает на седловину между пиком и бугорком. Потом рисует новый пик, шире и выше, который бы их скрыл.

— Этого можно добиться, подбрасывая в канал Руди сфабрикованные данные о несуществующих девушках выше среднего роста, но ниже тех, которые обслуживают «Бомбы».
— Однако теперь вы роете себе новую яму, — говорит Чаттан. Он подался вперед на вертящемся стуле и, держа сигарету перед лицом, разглядывает Уотерхауза через неподвижное облако дыма.
Уотерхауз говорит:
— Новая кривая выглядит чуть лучше, потому что я заполнил провал, но она еще не вполне колокол. Она не выгибается по краям, как положено. Доктор фон Хакльгебер это заметит. Он поймет, что кто-то подбрасывает данные в канал. Чтобы этого избежать, я бы сфабриковал еще данные, добавив необычно большие и необычно малые величины.
— Сочинили бы исключительно низких и исключительно высоких девушек, — говорит Чаттан.

— Да. Тогда кривая изогнется по краям, как положено.
Чаттан по-прежнему смотрит на него выжидающе.
Уотерхауз говорит:
— Так добавление небольшого количества данных, которые по отдельности казались бы аномальными, создает впечатление абсолютной нормальности.
— Как я и сказал, — говорит Чаттан. — Сейчас, пока мы разговариваем, наш взвод в Северной Африке растягивает колокол. Придает ему абсолютно нормальный вид.

МЯСО

О'кей, рядовой первого класса Джеральд Готт из Чикаго, Иллинойс, за время своей пятнадцатилетней службы в рядах Вооруженных Сил США не хватал звания каждые день. Зато он классно вырезал отбивные. Он орудовал мясницким ножом ничуть не хуже, чем Бобби Шафто — штыком, и кто скажет, что армейский мясник, экономно разделывая тушу и досконально соблюдая все санитарные предписания, спас меньше жизней, чем стальноокий боец? Война — это не только убивать нипов, фрицев, даго. Война — это еще и убивать скот. И есть его. Джеральд Готт, боец на передовой, содержал свою морозильную камеру в хирургической чистоте; только справедливо, что в ней он и встретил свою смерть.

Предыдущая страница 7 Следующая страница


Криптономикон (часть 1) 8

Бобби Шафто сочиняет в голове это маленькое надгробное слово, дрожа от субарктической стужи в бывшей французской, а ныне американской морозильной камере, которая размерами и температурой легко могла бы потягаться с Гренландией. Кроме него, в камере — бренные останки нескольких стад и одного мясника. За короткую службу Шафто перевидал немало похорон и всегда изумлялся искусству, с каким полковые капелланы возносят трогательные хвалы покойному. По слухам, когда вояки получают белобилетников, у которых на месте мозги, их учат печатать на машинке и сажают в кабинете день за днем строчить такое фуфло. Неплохая работенка.
Замершие туши длинными рядами висят на крюках. Бобби Шафто с каждым шагом все больше напрягается, готовясь к тому, что предстоит увидеть. В каком-то смысле почти лучше, когда снаряд сносит приятелю голову вместе с нераскуренной сигаретой — пока вот так собираешься с духом, недолго рехнуться.
Наконец Шафто огибает ряд и видит на полу человека в обнимку со свиной тушей, которую явно намеревался разделать за мгновение до смерти. Покойник тут уже двенадцать часов, и температура его тела — минус двадцать градусов по Цельсию.
Бобби Шафто заставляет себя взглянуть на тело и набирает полную грудь холодного, пахнущего мясом воздуха. Складывает посиневшие руки в молитвенном и в то же время согревающем жесте. «Господи! — говорит он вслух. Эха нет — туши поглощают звук. — Прости этого морпеха за то, что он собирается сделать, и уж заодно обязательно прости его командиров, которых Ты в Своей безграничной мудрости соизволил над ним поставить, и прости их начальство за всю эту затею».
Шафто собирается продолжить, но решает, что грех тут не больше, чем закалывать нипов штыком. Ладно, к делу. Он подходит к сплетенным рядовому первого класса Джеральду Готту и Свинке — Ледяной Щетинке, пытается их разделить, но безуспешно. Тогда он садится и начинает разглядывать мясника. Готт — блондин. Глаза полузакрыты. Шафто светит в них фонариком и видит голубоватый отблеск. Готт — не хилого сложения, фунтов на двести двадцать потянет, а то и на двести пятьдесят. Жизнь при армейской кухне не способствует похуданию, а также (к несчастью для Готта) поддержанию сердечно-сосудистой системы в стабильно работающем состоянии.
Когда у Готта случился сердечный приступ, одежда на нем была сухая, поэтому, слава те господи, не прилипла к телу. Шафто в несколько движений срезает ее ножом V-44 «Гун-хо», заточенным, как бритва. Однако широкое девятисполовинойдюймовое лезвие V-44 не годится для ближнего боя, а именно для подмышек и паха, а Шафто строго приказано не поцарапать тело, поэтому он вынимает семисчетвертьюдюймовый обоюдоострый рейдерский стилет, как нарочно созданный для такого рода работы (хотя цельнометаллическая рукоятка через некоторое время начинает примерзать к потной ладони Шафто).
Лейтенант Этридж маячит сразу за дверью морозильной камеры. Шафто протискивается мимо него и направляется прямиком на улицу, не обращая внимания на несущееся вслед: «Шафто? Ну как?»
Останавливается, только выйдя из тени здания. Североафриканская жара омывает тело, как ванна с морфием. Он закрывает глаза и подставляет солнцу лицо, складывает ладони лодочкой. Тепло из горсти льется в руки, просачивается к локтям.
— Ну как? — снова спрашивает Этридж.
Шафто открывает глаза и смотрит по сторонам. Залив — голубой полумесяц с бесчисленными песчаными косами, которые вьются одна вокруг другой, словно диаграмма танцевальных шагов. Одна утыкана гнилыми пеньками древних бастионов, рядом еще дымится полузатонувший французский линкор. Повсюду с невероятной скоростью разгружаются корабли операции «Факел». Грузовые сетки взмывают над трюмами и шмякаются на пристань, как исполинские сопли. Грузчики таскают, грузовики возят, французские девушки курят американские сигареты, алжирцы предлагают сделки.
Между мясоразделочным цехом здесь, на горе, и кораблями раскинулся, насколько понимает Бобби, город Алжир. На его привередливый висконсинский взгляд город не столько выстроен, сколько разбросан по берегу приливом. Уйма площади отведена под защиту от солнца, поэтому у города наглухо задраенный вид — много красной черепицы, украшенной зеленью и арабами. Несколько современных бетонных зданий вроде мясоразделочного цеха воздвигли французы в припадке сноса трущоб. Однако тут еще сносить и сносить. Кандидат номер один — человеческий улей или муравейник слева от Шафто, касба* [Касба (арабск.) — крепость.] или как там ее зовут. Может, это район, может, одно огромное несуразное здание. Арабы набились туда, как студенческая кодла в телефонную будку.
Шафто оборачивается и смотрит на морозильную камеру. Здесь на горе, она представляет собой идеальную цель для атак с воздуха, но всем глубоко насрать — что за беда, если фрицы разбомбят гору мяса?
Лейтенант Этридж — почти такой же обгоревший, как Шафто — щурится.
— Блондин, — говорит Шафто.
— Отлично.
— Голубоглазый.
— Еще лучше.
— Муравьед. Не шампиньон.
— А?
— Не обрезан, сэр!
— Замечательно! Как насчет остального?
— Одна татуировка, сэр!
Шафто забавляет растущее волнение в голосе Этриджа.
— Опишите татуировку, сержант!
— Сэр! Распространенный армейский рисунок, сэр! Сердце, а в нем женское имя!
— Какое имя, сержант? — Этридж сейчас описается от волнения.
— Сэр! Имя на татуировке — Гризельда, сэр!
Лейтенант Этридж с шумом выпускает воздух. Женщины в покрывалах оборачиваются. В касбе какие-то малохольные придурки высовываются из длинных тощих башен и начинают завывать не в лад.
Этридж, чтобы успокоиться, до белизны сжимает кулаки. Потом севшим от волнения голосом говорит:
— Меньшая удача, чем эта, решала исход сражений!
— Вы мне рассказываете?! — отвечает Шафто. — Когда я был на Гуадалканале, сэр, нас зажало в бухточке и...
— Я не желаю слушать про ящерицу, сержант!
— Сэр! Есть, сэр!

* * *

Однажды, еще в Окономовоке, Бобби Шафто пришлось вместе с братом заносить по лестнице матрас. Тогда он и научился с уважением относиться к тяжелым, но мягким предметам. Готт, упокой Господи его душу, тяжелый, как сволочь, и большая удача, что он насквозь промерз. Под средиземноморским солнцем он довольно скоро размякнет. И не только.
Все подчиненные Шафто находятся в зоне действий подразделения — в пещере, пробитой в искусственном обрыве над доками. Такие пещеры тянутся на мили. Над ними — бульвар. Однако все подходы к этой конкретной пещере замаскированы брезентом, чтобы никто, даже войска союзников, не видел, что там делают: выискивают веши, на которых написано 2701, замазывают единицу и набивают по трафарету двойку. Первую операцию выполняют рядовые с банками зеленой краски, вторую — с черной и белой.
Шафто выбирает по человеку из каждой цветовой группы чтобы не стопорить работу. Солнце здесь зверское, однако в пещере, куда к тому же задувает с моря, жить можно. От теплых, свежепокрашенных поверхностей сильно воняет скипидаром. На Шафто этот запах действует умиротворяюще, потому что в бою ничего не красят, и в то же время отзывается в душе легким трепетом, потому что красят часто непосредственно перед боем.
Шафто собирается ознакомить трех избранных морпехов с заданием, но тут рядовой с черной краской на руках, Даньелс, смотрит через его плечо и ухмыляется.
— Как по-вашему, сержант, что лейтенант сейчас ищет? — спрашивает он.
Шафто, рядовой Нейтан (зеленая краска) и рядовой Бранф (белая) разом оборачиваются и видят, что лейтенант Этридж отвлекся. Он снова роется в мусорных бачках.
Этридж выпрямляется и как можно укоризненнее демонстрирует стопку резных фанерок.
— Сержант! Вы можете сказать, что это такое?
— Сэр! Стандартные трафареты армейского образца, сэр!
— Сержант! Сколько букв в алфавите?
— Двадцать шесть, сэр! — четко отвечает Шафто.
Рядовые Даньелс, Нейтан и Бранф переглядываются: сержант Шафто не лыком шит!
— А сколько всего цифр?
— Десять, сэр!
— А из тридцати шести букв и цифр сколько не использовано в этих трафаретах?
— Тридцать пять, сэр! Все за исключением цифры два, которая только и нужна для выполнения приказа, сэр!
— Вы забыли вторую часть моего приказа, сэр!
— Сэр! Так точно, сэр. — Без толку отпираться. На самом деле офицеры даже любят, когда ты забываешь приказ: они чувствуют, что много умнее и толковее тебя. Ощущают свою нужность.
— Второй частью моих приказов было: принять строжайшие меры к тому, чтобы не осталось никаких следов изменения!
— Сэр! Так точно, сэр! Теперь вспомнил, сэр!
Лейтенант Этридж, который поначалу было раскипятился, теперь немного успокаивается. Подчиненные, которые знают его всего шесть часов, с одобрением отмечают про себя, что лейтенант — человек отходчивый. Теперь он говорит спокойно и дружески, как свойский учитель старших классов. На нем армейские солнцезащитные очки, которые бойцы между собой называют «Отпор насильнику». Они удерживаются на голове широкой черной резинкой. Лейтенант Этридж выглядит в них умственно отсталым.
— Если вражеский шпион залезет в этот мусорный бачок, чем шпионы нередко занимаются, что он увидит?
— Трафареты, сэр.
— Если он сосчитает буквы и цифры, то заметит ли что-нибудь необычное?
— Сэр! Все они будут чистые, за исключением цифры два, которая отсутствует либо покрыта краской, сэр!
Лейтенант Этридж несколько минут молчит, чтобы подчиненные прониклись услышанным. На самом деле никто ни хера не понял. В воздухе сгущается гроза, но тут сержант Шафто поворачивается к рядовым.
— Живо, ребята, замазать на хер все эти сраные трафареты! — рявкает он.
Морпехи бросаются на мусорные бачки, словно на японские доты. Лейтенант Этридж, по всей видимости, удовлетворен. Бобби Шафто, набравший множество очков, ведет рядовых Даньелса, Нейтана и Бранфа наверх, к холодильнику, пока лейтенант Этридж не догадался, что он скомандовал наугад.
Все они успели побывать в смертельных боях, иначе не угодили бы в такую передрягу: посреди щедрого на опасности континента (Африка) в окружении врага (армии Соединенных Штатов Америки). Тем не менее, когда они заходят в морозильник и видят рядового первого класса Готта, все замолкают.
Рядовой Бранф складывает руки, украдкой трет их одна о другую.
— Господи... — начинает он.
— Отставить, рядовой, — говорит Шафто. — Я уже.
— О'кей, сержант.
— Пилу принеси! — говорит Шафто рядовому Нейтану.
Рядовые замирают.
— Для гребаной свиньи! — поясняет Шафто. Потом поворачивается к рядовому Даньелсу, который держит неприметный сверток, и говорит: — Разворачивай!
В свертке (который выдал Этридж) оказывается черный гидрокостюм. Ничего армейского, какая-то европейская модель. Шафто разворачивает его и осматривает по частям, пока рядовые Нейтан и Бранф расчленяют Ледяную Щетинку мощными движениями пилы.
Некоторое время работают молча, но тут вмешивается новый голос. «Господи...» — начинает он. Все поднимают головы. Рядом с ними стоит человек, молитвенно сложив руки. Слова, сгущенные в сакраментальное и зримое облако, скрывают его лицо. Форму и звание не различить, потому что на плечах у него армейское одеяло. Он походил бы на пророка — хоть сейчас на верблюда и в Святую Землю, — если бы не чисто выбритый подбородок и очки «Отпор насильнику».
— Иди ты... — говорит Шафто. — Без тебя помолились.
— Однако мы молимся о рядовом Готте или о себе? — спрашивает незнакомец.
Трудный вопрос. Рядовые Нейтан и Бранф перестают пилить, наступает полная тишина. Шафто бросает гидрокостюм и выпрямляется. У человека в одеяле очень короткий седой ежик или просто изморозь осела на лысине. Льдистые глаза смотрят на Шафто через метровые стекла очков «ОтНас», словно и впрямь ожидая ответа. Шафто делает шаг вперед и замечает на незнакомце пасторский воротничок.
— Вот вы нам и объясните, преподобный, — говорит Шафто.
Тут он узнает человека в одеяле и чуть не гаркает: «Ты-то какого хрена здесь?», но что-то его удерживает. Капеллан делает движение глазами, такое быстрое, что замечает лишь Шафто, который стоит с ним практически нос к носу. Оно значит: «Заткнись, Бобби, после поговорим».
— Рядовой Готт сейчас с Богом или куда там люди отправляются после смерти, — говорит Енох «зови меня брат» Роот.
— Это еще как? Разумеется, он с Богом. Черт возьми! «Куда там люди отправляются после смерти». Какой вы, на хер, капеллан?
— Думаю, такой, какой нужен подразделению 2702, — говорит капеллан. Лейтенант Енох Роот наконец отрывает глаза от Бобби Шафто и смотрит туда, где трудятся бойцы.
— Чего, ребята, — говорит он. — Смотрю, сегодня на ужин свининка?
Рядовые нервно хихикают и снова берутся за пилу.
Как только удается освободить Готта от свиной туши, все четверо морпехов хватают его за руки — за ноги. Готта волокут в разделочный цех, временно эвакуированный, чтобы его собратья по топору не разнесли слухов.
Поспешная эвакуация разделочного цеха после того, как одного из мясников нашли на полу мертвым, сама по себе может породить слухи. Легенда, наскоро сочиненная и запущенная лейтенантом Этриджем, такова: подразделение 2702 (вопреки очевидности) на самом деле элитная санчасть, а рядового Готта подкосила новая редкая форма североафриканского пищевого отравления. Может быть, ее даже нарочно оставили французы, немного обиженные на то, что потопили их линкор. Так или иначе, весь цех (гласит легенда) придется закрыть на день и вылизать дочиста. Тело Готта перед отправкой родным кремируют, чтобы опасная зараза не поразила Чикаго — всемирную столицу скотобоен, — где ее неисчислимые последствия способны повлиять на исход войны.
Для правдоподобия на полу установлен солдатский гроб. Шафто и его бойцы, не обращая на гроб внимания, натягивают на труп сначала жуткого вида плавки, потом — отдельные части гидрокостюма.
— Эй! — говорит Этридж. — Я думал, перчатки под конец.
— Сэр, мы наденем их сначала, с вашего разрешения, сэр! — говорит Бобби Шафто. — Поскольку пальцы отмерзнут первыми, и тогда капец, сэр!
— Хорошо, но прежде наденьте вот это, — говорит Этридж и протягивает наручные часы. Шафто взвешивает их на руке и присвистывает: это швейцарский хронометр в массивном корпусе чистого урана, механизм на множество камней тикает, как сердце маленького зверька. Шафто покачивает их на браслете из ловко пригнанных металлических пластин. Такой штуковиной можно оглушить щуку.
— Шикарно, — говорит Шафто, — только время не больно точно показывают.
— Для того часового пояса, куда мы направляемся, — говорит Этридж, — точно.
Шафто, утершись, берется за работу. Тем временем лейтенанты Этридж и Роот вносят свою лепту в общее дело. Они несут куски Ледяной Щетинки на гигантские весы. Получается тридцать килограммов, хотя Шафто, привыкшему к фунтам, это ничего не говорит. Енох Роот обнаруживает похвальный аппетит к физическому труду (что молча отмечают про себя рядовые): он приволакивает и бросает на весы еще тушу. Вместе выходит семьдесят. Дальше они доводят вес до ста тридцати, таская окорока из холодильника. Енох Роот, который похоже, накоротке с этой чудною системой мер, посчитал и, дважды проверив, установил, что вес Джеральда Готта в килограммах — сто тридцать.
Все мясо отправляется в гроб. Этридж захлопывает крышку вместе с несколькими мухами, которые пока не знают, на что себя обрекли. Роот с молотком в руках обходит гроб, заколачива здоровенные гвозди мощными, точными ударами Плотника из Назарета. Тем временем Этридж достает из портфеля свод инструкций. Шафто стоит близко и может прочесть большие печатные буквы на зеленой обложке.

ИНСТРУКЦИИ ПО ЗАПЕЧАТЫВАНИЮ ГРОБА

ЧАСТЬ III: ТРОПИЧЕСКИЙ КЛИМАТ
ТОМ II: ОПАСНАЯ ЭПИДЕМИОЛОГИЧЕСКАЯ ОБСТАНОВКА (БУБОННАЯ ЧУМА И Т.П.)

Два лейтенанта битый час выполняют инструкцию. Она не настолько сложна, однако Енох Роот все время находит синтаксические двусмысленности и начинает в них углубляться. Этридж сперва немного досадует, потом доходит до белого каления и, наконец, до крайнего прагматизма. Чтобы нейтрализовать капеллана, он изымает инструкцию и поручает Рооту по трафарету наносить на крышку фамилию «Готт» и лепить на нее красные наклейки с предупреждениями столь грозными, что от одних заголовков может хватить кондратий. Когда Роот заканчивает работу, открыть гроб имеет право только лично председатель Объединенного комитета начальников штабов генерал Джордж К. Маршалл, и то не раньше, чем получит разрешение главного военного врача и эвакуирует все живое в радиусе ста миль.
— Как-то капеллан смешно говорит, — замечает на определенном этапе рядовой Нейтан, ошалело слушая дебаты Роота — Этриджа.
— Ага! — восклицает рядовой Бранф, будто Нейтан проявил особую наблюдательность. — Что это за акцент?
Все взгляды обращаются к Шафто. Тот делает вид, что прислушивается, потом объявляет:
— Ну, ребята, я бы сказал, что предки Еноха Роота — голландские и, может быть, немецкие миссионеры на островах Тихого океана и что женились они на австралийках. Более того, думаю, родился он на территории, которую контролируют британцы, паспорт у него английский, его мобилизовали в начале войны, и сейчас он входит в состав АНЗАК*. [Австралийского и Новозеландского экспедиционного корпуса.]
— Ух ты! — восклицает рядовой Даньелс. — Если все это окажется правдой, плачу пять баксов.
— Идет, — отвечает Шафто.
Этридж и Роот заканчивают с гробом. Примерно в то же время морпехи натягивают на покойника последнюю деталь гидрокостюма. Ушла чертова куча талька, но в конце концов справились. Тальк — не американский; Этридж выдал им коробку какого-то европейского. Над некоторыми буквами на этикетке — две точки; Шафто знает, что это характерно для немецкого языка.
К воротам задом подъезжает грузовик. От него пахнет свежей краской (это грузовик подразделения 2702). В кузов загружают запечатанный гроб и одетого в резину мертвого мясника.
— Я останусь и проверю мусорные бачки, — говорит лейтенант Этридж. — Встретимся на взлетном поле через час.
Шафто представляет себе час в раскаленном грузовике с таким грузом.
— Обложить его льдом, сэр? — спрашивает он.
Этридж задумывается: цыкает зубом, смотрит на часы, сопит, хмыкает. Однако, когда он вновь открывает рот, ответ звучит вполне определенно:
— Нет. Для целей миссии существенно перевести его в размороженное состояние.
Рядовой первого класса Джеральд Готт и нагруженный мясом гроб занимают середину кузова. Морпехи сидят вдоль бортов, как почетный караул. Шафто смотрит через груду мертвечины на Еноха Роота, который старательно делает невозмутимый вид. Шафто понимает, что надо ждать, но утерпеть не может.
— Что вы здесь делаете? — спрашивает он.
— Подразделение перебрасывается, — говорит преподобный, — ближе к линии фронта.
— Мы только что с корабля, — отвечает Шафто. — Разумеется, мы приближаемся к линии фронта. Удаляться можно было бы только вплавь.
— Пока мы на колесах, — спокойно говорит Роот, — куда все, туда и я.
— Я не про это, — говорит Шафто. — Я про то, зачем подразделению капеллан?
— Вы не вчера в армии, — говорит Рост. — В каждой части должен быть капеллан.
— Дурной знак.
— Дурной знак иметь в части капеллана? Почему?
— Значит, эти жопотрясы считают, что будет много похорон.
— Вы придерживаетесь того мнения, что священник нужен только на похоронах? Занятно.
— И на свадьбах с крестинами, — говорит Шафто. Остальные морпехи давятся смехом.
— Не смущает ли вас несколько первое задание подразделения 2702? — спрашивает Енох Роот, выразительно глядя сперва на покойного Готта, потом на Шафто.
— Смущает? Послушайте, преподобный, на Гуадалканале я делал такое, по сравнению с чем все вот это — занятие для благовоспитанных школьниц, так их за ноги.
Остальные морпехи считают, что Шафто отбрил, так отбрил, однако Роот не унимается:
— А вы знаете, зачем делали это на Гуадалканале?
— Ясное дело! Чтобы остаться в живых.
— А сейчас зачем?
— Хер его знает.
— Раздражает вас это немножко? Или вы просто тупой солдафон, которому все до лампочки?
— Да, преподобный, тут вы меня поддели, — говорит Шафто и, помолчав, добавляет: — Признаюсь, малость любопытно.
— Пригодился бы в подразделении 2702 человек, способный ответить «зачем»?
— Наверное, — нехотя соглашается Шафто. — Просто дико как-то, что у нас капеллан.
— Почему дико?
— Потому что это такое подразделение.
— Какое? — спрашивает Роот не без некоего садистского удовольствия.
— Не положено говорить, — отвечает Шафто. — Да я и не знаю.
С горы вьются исполинские серпантины и, пройдя через ряд полосатых арок, спускаются к железнодорожным путям. «Стоишь тут, на хер, как в лотке пинболла», — говорит Б. Шафто, глядя вверх, туда, откуда они только что приехали, и воображая, что может скатиться из касбы. Они едут на юг вдоль железнодорожных путей и оказываются на территории отвалов, угольных куч, дымовых труб. Шафто — бойскаут с Великих озер — узнает все словно через какую-то бесконечную межкультурную зубчатую передачу. Грузовик останавливается перед «Societe Algerienne d'Eclairage et de Force»* [Алжирская компания по освещению и электроснабжению (АКОЭ) (фр.).] — уродливым колоссом с двумя дымовыми трубами, перед которым навалена самая высокая угольная куча. Они у черта на куличках, но их явно ждут. Здесь — как и повсюду, где бы ни появилось подразделение 2702, — проявляется странный Эффект Раздувания Званий. Гроб заносят в здание АКОЭ два лейтенанта, капитан и майор под присмотром полковника! Рядовых вообще не видать; Шафто, простой сержант, с тревогой гадает, какую работу найдут ему. Одновременно сказывается Эффект Отсутствия Проволочек — там, где Шафто ожидает бумажной волокиты по меньшей мере на полчаса, выбегает офицер, машет руками, и гроб пропускают.
Араб с красной консервной банкой на голове тянет на себя стальную дверцу; оттуда вырываются языки пламени, он сбивает их черной кочергой. Офицеры направляют гроб в дверь и толкают вперед, словно досылая снаряд в ствол шестнадцатидюймового карабина. Араб с жестянкой на голове захлопывает дверцу (кисточка на жестянке бешено прыгает) и, еще не опустив щеколду, принимается завывать, как те придурки в касбе. Офицеры все очень довольны и пишут в книжечки свои имена.
После всех этих довольно странных событий грузовик отъезжает от «Societe Algerienne d'Eclairage et de Force» и снова ползет по серпантину в Алжир. Подъем такой крутой, что его приходится одолевать на первой скорости. Торговцы с печками на колесах не только не отстают, но еще и успевают печь на ходу лепешки. Трехногие псы бегают и дерутся под коленвалом. Кроме того, подразделение 2702 одолевают местные в красных жестянках, которые рвутся играть на гитарах из канистр, продавцы апельсинов, заклинатели змей и голубоглазые малые в бурнусах, которые предлагают какие-то бурые комки, без обертки и этикетки. Их, как градины, можно классифицировать по аналогии с фруктами или спортивным инвентарем. Обычно они размером от вишни до бейсбольного мяча. В какой-то момент капеллан под влиянием порыва меняет плитку «Херши» на комок размером с бейсбольный мяч.
— Это что, шоколад? — спрашивает Бобби Шафто.
— Был бы шоколад, — отвечает Роот, — этот тип не стал бы менять его на «Херши».
Шафто пожимает плечами.
— Может, это говенный шоколад.
— Или говно! — выпаливает рядовой Нейтан. Всем ужасно смешно.
— Слышали про Марию-Хуанну? — спрашивает Роот.
Шафто — образцовый боец и вожак — перебарывает желание ответить: «Слышал?! Да я ее греб!»
— Это то же самое, только в концентрированном виде, — говорит Енох Роот.
— А вы-то откуда знаете, преподобный? — спрашивает рядовой Даньелс.
Преподобный ничуть не смущен.
— Я здесь насчет Бога, да? Мне положено знать религиозную сторону?
— Так точно, сэр!
— Так вот, была некогда такая мусульманская группа — гашишины, они ели эту штуку и шли убивать. И так в этом преуспели, что даже прославились, а их название в несколько измененном виде — асассины — вошло во все европейские языки в значении «убийцы».
Наступает уважительное молчание. Потом сержант Шафто говорит:
— Так хули мы ждем?
Они съедают по кусочку; Шафто как старший среди рядового и сержантского состава — больше всех. Ничего не происходит.
— Если мне и хочется кого убить, так только типа, который толкнул нам это говно, — говорит он.

Лётное поле, в одиннадцати милях от города, работает более чем с проектной нагрузкой. Вокруг растут маслины и виноград, но дальше — горы, а за ними — песчаное пространство, равное по площади Соединенным Штатам Америки, причем сдается, что весь этот песок в воздухе и летит к аэродрому. Бесчисленные самолеты, по большей части «дакоты», они же «дугласы», вздымают огромные тучи пыли, которая оседает на языке и забивает ноздри. До Шафто не сразу доходит, что сухость в глазах и во рту лишь отчасти вызвана пылью. Слюна густеет, как замазка.
Подразделение настолько секретное, что на аэродроме никто даже не знает о его существовании. Здесь полно британцев. В пустыне британцы носят шорты, поэтому Шафто хочется потянуть их за нос. Он перебарывает это желание. Однако его явная враждебность к людям в шортах, равно как и просьбы указать дорогу к подразделению, настолько секретному, что его нельзя даже назвать, ведут к непониманию, недоверию и вообще подрывают дух англо-американского добросоюзничества.
Впрочем, тут сержант Шафто соображает, что все, связанное с подразделением, должно быть где-нибудь в стороне, под черным брезентом. Как и в других армейских частях, в подразделении 2702 что-то в недостатке, что-то в избытке. По всей видимости, в их распоряжение попала примерно половина брезента, изготовленного за прошлый год в Соединенных Штатах. Когда Шафто упоминает этот факт и начинает развивать свою мысль, на лицах у рядовых появляется странное выражение. Наконец Енох Роот говорит: «Сперва исполинская ящерица, теперь черный брезент. Некоторым может показаться, что вы малость тронутый».
— Сейчас я вам расскажу про тронутых, — говорит Шафто и рассказывает, не забывая упомянуть лейтенанта Этриджа с его мусорными бачками. К концу рассказа все подразделение уже собралось по дальнюю сторону растянутого брезента. Ребята напряжены, за исключением новобранца, который, как одобрительно замечает Шафто, начинает понемногу отходить. Лежа на дне грузовика в черном гидрокостюме, он скорее переваливается, чем подпрыгивает на ухабах.
Тем не менее он еще не вполне отмяк, так что его несложно вытащить и загрузить в «Дуглас» — небольшой самолет, переделанный для военных целей и (на скептический взгляд Шафто) утративший летные качества за счет двух огромных грузовых люков, разрезающих корпус почти пополам. Этот конкретный самолет столько летал над чертовой пустыней, что с винтов, капота и передней части крыльев песком содрало всю краску; отполированный металл блестит, словно приглашение для всех пилотов люфтваффе на три мили вокруг. Хуже того, из обшивки фюзеляжа, главным образом вокруг кабины пилота, торчат антенны. И не какие-нибудь штыревые, а здоровенные решетки для барбекю. «Эх, сюда бы ножовку», — думает Шафто. Антенны смутно похожи на те, которые он таскал по лестнице со станции «Альфа» в Шанхае. Впрочем, все воспоминания перемешались. Когда он пытается их восстановить, то видит одно: каменная лестница в Маниле, окровавленный Христос спускается по ступенькам, таща на спине двухполосный коротковолновый диполь. Понятно, что быть этого не могло.
Хотя они на оживленном аэродроме, Этридж отказывается продолжать операцию, пока в небе хоть один самолет. Наконец он командует: «Все, ПОШЛИ!» Морпехи в грузовике приподнимают тело. Тут Этридж кричит: «Нет, ПОГОДИТЕ!», и тело шмякают на пол. На пятый раз это уже не смешно. Наконец Джеральда Готта накрывают черным брезентом и заносят в самолет. Через несколько минут они в воздухе. Подразделение 2702 направляется на встречу с Роммелем.

ЦИКЛЫ

Начало ноября 1942-го, и хренова туча всего происходит повсюду, одновременно. Сам Зевс бы не разобрался, даже если бы мобилизовал кариатид — сказал бы, забудьте, что мы вам говорили, просто бросайте свой груз. Под грохот рушащихся храмов он отправил бы их (вместе с теми наядами и дриадами, которых удалось наскрести) на краткосрочные курсы и, облачив в ладные бесполые формы СУАОВ — Службы управления архивами олимпийского всевидения, — засадил бы заполнять перфокарты три на пять дюймов. Пусть бы даже все кариатиды со своим хваленым терпением сутки напролет, напялив зеленые козырьки, простаивали перед машинами Холлерита и перфосчитывателями ЭТК — все равно Зевс не сумел бы охватить ситуацию. Он бы впал в ступор и не знал, кого из смертных поражать молниями и к кому из связисточек или солдатиков бить клинья.
Лоуренс Притчард Уотерхауз сам теперь олимпиец не хуже других. У Франклина Делано Рузвельта, Уинстона Черчилля и еще нескольких человек в списке «Ультра-Мега» тот же уровень допуска, но у них другие дела и заботы. Они не могут бродить по всемирной столице информационных потоков, заглядывать через плечо переводчикам и читать свежие расшифровки, когда те — щелк-щелк-щелк — выползают из ТАЙПЕКСов. Они не могут бегать от здания к зданию, собирая воедино сюжетные нити мирового повествования, пока девушки в одиннадцатом корпусе переключают провода из гнезда в гнездо, сплетая сеть, в которую послания Гитлера попадают, едва выйдя в эфир.
Вот, например, что знает Уотерхауз: битва под Эль-Аламейном выиграна, Монтгомери стремительно гонит Роммеля на запад, через Киренаику, к далекому оплоту Оси в Тунисе. Однако все не настолько в ажуре, как может показаться. Если бы Монти оценил важность информации, поступающей по каналам «Ультра», он бы действовал решительнее, окружал и брал в плен изолированные подразделения итальянцев и немцев. Однако он этого не делает, и Роммель отступает организованно, готовясь дать новое сражение, а в Блетчли-парке кроют Монти последними словами за нежелание воспользоваться бесценными, однако недолговечными сокровищами разведданных.
А сейчас в Северо-Западную Африку перебросили чертову уйму народа. Это называется операция «Факел», ее цель — зажать Роммеля между молотом (английскими войсками) и наковальней (американскими войсками). Или, если Монти не поторопится, наоборот. Операция кажется блестяще организованной, но это не так: Америка впервые наносит серьезный удар через Атлантику, поэтому на корабли загрузили абсолютно всех. Сотрудники радиоразведки, строя из себя десантников, театрально бежали к берегу по пояс в воде. Также в высадке участвовал американский контингент подразделения 2702 — аварийная команда, составленная из отборных морских пехотинцев, прошедших огонь, воду и медные трубы.

Часть из них получила свой боевой опыт на Гуадалканале — никому прежде не нужном островке в юго-западной части Тихого океана, где Японская империя и Соединенные Штаты Америки спорят — посредством оружия — за право построить военную авиабазу. Судя по первым сообщениями, японская армия за время пребывания в Восточной Азии несколько утратила форму. Оказывается, изнасиловать все женское население Нанкина или перебить штыками беззащитных филиппинских крестьян еще не значит набраться боевого опыта. Японская армия по-прежнему пытается придумать, как бы, скажем, убить сто американских морских пехотинцев, не потеряв на этом пятьсот своих.
Другое дело — японские ВМС. Они свое дело знают. У них есть Ямамото. Их торпеды действительно взрываются, попав в цель, в отличие от американских, которые, слегка поцарапав краску японских кораблей, виновато идут ко дну. Ямамото только что сделал очередную попытку уничтожить американский флот у островов Санта-Крус, потопил «Хорнет», проделал аккуратную дыру в «Энтерпрайзе». Однако он потерял треть своих самолетов. Наблюдая, как японцы несут потери, Уотерхауз гадает, сообразил ли кто-нибудь в Токио взять счеты и прикинуть кое-какие цифры.
Союзники тоже считают и напуганы до потери пульса. В Атлантике сейчас сто немецких подлодок, они ведут действия главным образом из Лорьяна и Бордо. То, что там происходит, уже не битва, а вакханалия убийства в масштабах «Лузитании»*. [Английский пассажирский лайнер «Лузитания» был торпедирован немецкой подводной лодкой 7 мая 1915 года. Из 1959 человек пассажиров и команды 1198 утонули.] За последний месяц немцы потопили кораблей в общей сложности на миллион тонн. Попробуй осознай!.. Положим, тонна — примерно автомобиль. Уотерхауз пытается представить себе, что Америка и Канада сбросили в середину Атлантики миллион автомобилей. Бултых!
Проблема в Акуле.
Немцы зовут ее «Тритон». Это новая шифросистема, используемая исключительно на флоте. «Энигма», но не обычная, трехдисковая. Ту поляки научились взламывать два года назад, а в Блетчли-парке процесс поставили на поток. Однако меньше года назад у южного берега Исландии села на мель немецкая подводная лодка. Сотрудники Блетчли-парка хорошенько ее прочесали и нашли «Энигму» с выемками для четырех, а не для трех дисков!
Когда первого февраля заработали четырехдисковые «Энигмы», вся Атлантика почернела. С тех самых пор Алан и другие не покладая рук бились над этой задачей. Загвоздка была в том, что они не знали, как подсоединен четвертый диск.
По счастью, несколько дней назад захватили еще одну немецкую подводную лодку, в восточной части Средиземного моря. Полковник Чаттан, оказавшийся поблизости, и еще несколько сотрудников Блетчли рванули туда сломя голову. Они нашли четырехдисковую «Энигму», а это хоть не сам код, но по крайней мере ключ к его взлому.
Гитлер, видать, совершенно в себе уверен — собрался отдохнуть в Альпах. Что не помешало ему прибрать к рукам последние остатки Франции — похоже, операция «Факел» задела его за живое, и он окончательно оккупировал вишистскую Францию. Одновременно он отправил еще десять тысяч солдат и соответствующее количество припасов через Средиземное море в Тунис. Уотерхауз воображает, что сейчас можно добраться от Сицилии до Африки, просто прыгая с одного немецкого транспорта на другой.
Разумеется, будь это так, его работа была бы куда легче. Союзники топили бы суда сколько душе угодно, и ни один голубоглазый тевтон на фронте информационной войны не повел бы арийской бровью. Однако на самом деле судов мало и расположены они редко. Насколько именно мало и редко — это параметры уравнений, которые они с Аланом Матисоном Тьюрингом всю ночь пишут на доске.
Часов через десять — двенадцать этого занятия, когда наконец снова встает солнце, остается разве что сесть на велосипеды и прокатиться с ветерком.

Они въезжают на холм, и перед ними открывается лес, расцвеченный всеми цветами пламени. Полусферические кроны кленов словно вспучиваются в огне, добавляя впечатлению реализма. У Лоуренса возникает нелепое желание выпустить руль и зажать уши! Однако воздух под деревьями приятно прохладен, синее небо не пятнают столбы черного дыма, спокойствие и тишина леса самым разительным образом отличаются от того, что вспомнилось Лоуренсу.
— Кудах-тах-тах! — Алан Тьюринг изображает квохтание рассерженной курицы. Странные звуки кажутся еще чуднее из-за того, что он в противогазе, который, впрочем, почти сразу сдвигает на лоб. — Как же они любят себя слушать! — (Речь об Уинстоне Черчилле и Франклине Рузвельте.) — Да и друг друга тоже, до определенного момента. Однако голос по сравнению с печатным текстом — жутко избыточный канал информации. Если взять текст и пропустить его через «Энигму» — которая, в сущности, довольна проста, — то привычные закономерности вроде преобладания буквы «Е» практически исчезают. — Тут он снова натягивает противогаз, чтобы подчеркнуть следующее утверждение. — А вот голос можно искажать самым чудовищным образом, и он все равно будет понятен слушателю.
Тут на Алана нападает приступ чихания, да такой, что чуть не лопаются защитного цвета ремешки на затылке.
— Наше ухо привыкло отыскивать знакомые сочетания, — предполагает Лоуренс. Он без противогаза, потому что (а) немцы не проводят здесь газовую атаку, (б) в отличие от Алана он не страдает сенной лихорадкой.
— Прости. — Алан резко тормозит и спрыгивает с велосипеда. Он отрывает заднее колесо от дороги, раскручивает его свободной рукой и быстрым движением дергает цепь. Потом внимательно созерцает механизм, прерываясь только для того, чтобы несколько раз чихнуть.
В цепи у велосипеда Тьюринга дефектное звено. В заднем колесе погнута одна спица. Когда звено задевает спицу, цепь сваливается и падает на дорогу. Это происходит не при каждом обороте колеса — иначе велосипед проще было бы выкинуть. Это происходит при определенном взаимном расположении цепи и колеса.
Исходя из разумного предположения, что доктор Тьюринг находится в хорошей спортивной форме и развивает скорость примерно 25 км/час, а радиус колеса — примерно треть метра, если бы дефектное звено задевало гнутую спицу при каждом обороте колеса, то цепь сваливалась бы каждую третью долю секунды.
На самом деле цепь не сваливается, пока гнутая спица не заденет дефектное звено. Теперь допустим, что вы описываете положение заднего колеса традиционной буквой Q. Ради простоты договоримся: если колесо начинает вращаться из положения, в котором гнутая спица может задеть дефектное звено (разумеется, только если дефектное звено находится там, где его можно задеть), то Q = 0. Если в качестве единицы измерения используются градусы, то за один поворот колеса Q принимает все значения вплоть до 359, прежде чем вернуться к нулю, когда гнутая спица вновь может сбросить цепь. Теперь предположим, что положение цепи вы описываете переменной С по очень простому принципу: нумеруя все звенья цепи. Дефектному звену ставится в соответствие число 0, следующему 1 и так далее до l – 1, где l — общее число звеньев в цепи. Опять-таки ради простоты примем, что в положении, в котором дефектное звено может задеть гнутую спицу (при условии, что спица — там, где ее можно задеть), С = 0.
Чтобы вычислить, когда с велосипеда доктора Тьюринга свалится цепь, все, что нам надо знать про велосипед, — это значения Q и С. Эти два числа определяют состояние велосипеда. У велосипеда столько возможных состояний, сколько существует возможных значений (Q, С), но только в одном из этих состояний, а именно (0, 0), цепь свалится на дорогу.
Предположим, мы начинаем с этого состояния, т. е. (Q = 0, С = 0), но цепь не свалилась, потому что доктор Тьюринг (прекрасно зная состояние своего велосипеда в каждый конкретный момент времени) остановился посреди дороги и едва избежал столкновения со своим другом и коллегой Лоуренсом Притчардом Уотерхаузом, поскольку противогаз блокирует его периферическое зрение. Доктор Тьюринг немного прокрутил цепь вперед, одновременно оттягивая ее вбок, чтобы не задела за гнутую спицу. Теперь он снова садится на велосипед и начинает крутить педали. Окружность его колеса примерно два метра, значит, когда он проехал два метра по дороге, колесо совершило полный оборот и вернулось в состояние Q = 0, в котором, как мы помним, гнутая спица может задеть дефектное звено.
Что с цепью? Ее положение, определяемое как С, начинается с 0, достигает единицы, когда в фатальную позицию перемещается следующее звено, потом двойки и так далее. Цепь движется синхронно с зубцами звездочки в центре заднего колеса. У звездочки п зубцов, так что после второго полного оборота заднего колеса Q снова = 0, но С теперь = 2n. В следующий раз С = 3п и так далее. Однако не забывайте, что цепь — не бесконечная прямая линия, а замкнутая петля, имеющая всего l позиций; при С = l, она возвращается к началу цикла, и С снова принимает нулевое значение. Так что при вычислении С следует прибегнуть к арифметике остатков: то есть если в цепи сто звеньев (l = 100), а общее число перемещенных звеньев — 135, то значение С не 135, а 35. Как только вы получаете число, больше или равное l, вы просто последовательно вычитаете l, пока результат не станет меньше l. Математики обозначают эту операцию mod l. Так что последовательные значения С, всякий раз как заднее колесо возвращается в положение Q = 0, равны:

Сi = п mod l, 2n mod l, 3n mod l, ..., in mod l
где i = (1, 2, 3, ... 8 ?),

меньше или больше в зависимости от того, насколько близкое к бесконечности время Тьюринг намерен ехать на велосипеде. Через некоторое время Уотерхаузу начинает казаться, что они и впрямь едут бесконечно.
Цепь сваливается, когда велосипед достигает состояния (Q = 0, C = 0). В свете вышесказанного это происходит, когда l (которое просто означает число оборотов, совершенных задним колесом) достигает некоего гипотетического значения, при котором in mod l = 0, или, говоря по-человечески, когда некое число, кратное п (такое, как, например, 2n, 3n, 395n или 109 948 368 443n), оказывается в то же время кратным l. Вообще-то это может быть любое из так называемых общих кратных, но с практической точки зрения важно только первое — наименьшее общее кратное, или НОК, поскольку именно оно будет достигнуто первым и вызовет падение цепи.
Если, скажем, у звездочки двадцать зубцов (n = 20), а в цепи сто звеньев (l = 100), то после первого поворота колеса мы имеем С = 20, после двух поворотов С = 40, потом 60, 80 и 100. Однако поскольку мы ищем остаток от деления на 100, значение надо изменить на ноль. Таким образом, после пяти оборотов колеса мы достигли состояния (Q = 0, С = 0) и цепь Тьюринга сваливается. За пять оборотов колеса он проезжает всего десять метров, поэтому при таких значениях l и n велосипед практически бесполезен. Разумеется, все это верно лишь в том случае, если Тьюринг такой дурак, чтобы начать движение из состояния спадения цепи. Если же он начинает крутить педали, когда велосипед находится в состоянии (Q = 0, С = 1), то С принимает значения 21, 41, 61, 81, 1, 21, ... и так до бесконечности, и цепь не свалится никогда. Однако это вырожденное состояние, где «вырожденное» для математика означает «невыносимо скучное». В теории, если Тьюринг будет всякий раз выставлять нужное состояние, прежде чем бросить велосипед на улице, никто не сможет его украсть — цепь свалится через первые же десять метров.
Если же в цепи Тьюринга сто одно звено (l = 101), то после пяти оборотов мы имеем С = 100, а после шести С = 19, тогда

С = 39, 59, 79, 99, 18, 38, 58, 78, 98, 17, 37, 57, 77, 97, 16, 36, 56, 76, 96, 15, 35, 55, 75, 95, 14, 34, 54, 74, 94, 13, 33, 53, 73, 93, 12, 32, 52, 72, 92, 11, 31, 51, 71, 91, 10, 30, 50, 70, 90, 9, 29, 49, 69, 89, 8, 28, 48, 68, 88, 7, 27, 47, 67, 87, 6, 26, 46, 66, 86, 5, 25, 45, 65, 85, 4, 24, 44, 64, 84, 3, 23, 43, 63, 83, 2, 22, 42, 62, 82, 1, 21, 41, 61, 81, 0.

Так что состояние (Q = 0, С = 0) не будет достигнуто и цепь не свалится, пока колесо не совершит сто один оборот. За сто один оборот велосипед Тьюринга успевает проехать по дороге пятую часть километра, что совсем не так плохо. Значит, велосипед работающий. Однако в отличие от вырожденного случая его нельзя привести в такое состояние, чтобы цепь не спадала совсем. Это легко доказать, просмотрев приведенный список значений С и убедившись, что все возможные значения — все числа от одного до ста — в нем присутствуют. Это означает, что с какого бы значения С Тьюринг ни начал крутить педали, рано или поздно он придет к фатальному С = 0 и цепь свалится.
Разница между вырожденным и невырожденным случаем заключена в свойствах использованных чисел. Комбинация (п = 20, l = 101) принципиально отличается от комбинации (п = 20, l = 100). Главная разница в том, что 20 и 101 — «взаимно простые», т. е. у них нет общих делителей. Это означает, что их наименьшее общее кратное, их НОК — большое число и равняется собственно l x n, т. е. 20 x 101 = 2020. А вот НОК ста и двадцати — всего 100. У велосипеда с l = 101 длинный период — он проходит через множество различных состояний, прежде чем вернуться к исходному, а у велосипеда с l = 100 — короткий, всего из нескольких состояний. Предположим, что велосипед Тьюринга — шифромашина, основанная на алфавитной замене, т. е. заменяет каждую из двадцати шести букв английского алфавита какой-то другой буквой. А открытого текста может стать Т шифртекста, В — F, С — М и так дальше до Z. Сам по себе такой шифр до смешного прост, взломать его — детская забава. Однако предположим, что схема замены меняется от буквы к букве. Первая буква открытого текста шифруется с помощью одного алфавита замены, вторая — с помощью другого, третья — с помощью третьего и так далее. Это называется полиалфавитный шифр.
Предположим, что велосипед Тьюринга генерирует свой алфавит для каждого из состояний. Тогда состоянию (Q = 0, С = 0) будет соответствовать, например, такой алфавит замены:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Q G U W В I Y T F K V N D O H E P X L Z R C A S J M

а состоянию (Q = 180, С = 15) — такой:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
B O R I X V G Y P F J M T C Q N H A Z U K L D S E W

Никакие две буквы не будут зашифрованы одним и тем же алфавитом замены, пока велосипед не вернется в исходное состояние (Q = 0, С = 0) и цикл не пойдет с начала. То есть это периодическая полиалфавитная система. Теперь, если период у машины короткий, она часто повторяет саму себя и в качестве шифровальной системы тоже годится исключительно для детской забавы. Чем длиннее период (чем больше взаимно простых чисел в него встроено), тем реже используется один и тот же алфавит замены и тем выше устойчивость шифра.
Трехдисковая «Энигма» — система именно такого типа (то есть периодическая полиалфавитная). Ее барабаны подобно приводу в велосипеде Тьюринга заключают в себе циклы в циклах. Ее период равен 17 576, то есть алфавит замены, которым зашифрована первая буква сообщения, не повторится до 17 577-й буквы. Однако в «Акуле» немцы добавили четвертый барабан, увеличив период до 456 976. В начале каждого сообщения диски ставятся в различные, случайным образом выбранные исходные положения. Поскольку ни в одном немецком сообщении нет 450 000 знаков, «Энигма» никогда не повторяет один и тот же алфавит замены в пределах отдельного сообщения. Вот почему немцы считают ее неуязвимой.
Над головами пролетает звено транспортных самолетов, направляясь, по всей видимости, к аэропорту в Бедфорде. Самолеты издают странно музыкальный диатонический гул, словно волынки, играющие две мелодии разом. Это напоминает Лоуренсу об еще одном феномене, связанном с велосипедным колесом и шифрмашиной «Энигма».

Предыдущая страница 8 Следующая страница


9 Нил Стивенсон

— Ты знаешь, почему самолеты так гудят? — спрашивает он.
— Нет, если задуматься. — Тьюринг снова сдвигает противогаз на лоб. Челюсть у него немного отвисла, глаза смотрят в разные стороны. Уотерхауз его зацепил.
— Я заметил в Перл-Харборе. У самолета — звездообразный двигатель, — говорит Лоуренс. — Соответственно, в нем должно быть нечетное число цилиндров.
— Как одно из другого следует?
— Если число будет четным, цилиндры окажутся один напротив другого, развернутые на сто восемьдесят градусов, а это не работает механически.
— Почему?
— Не помню. Не работает, и все.
Алан поднимает брови. Он явно не убежден.
— Это как-то связано с кривошипами, — защищается Уотерхауз.
— Не уверен, что соглашусь.
— Просто допусти. Считай это граничным условием, — говорит Уотерхауз. Однако Алан уже ушел в свои мысли — наверное, изобретает звездообразный двигатель с четным числом цилиндров.
— В любом случае, если посмотришь, у них у всех цилиндров нечетное число, — продолжает Лоуренс. — Поэтому шум выхлопа накладывается на гудение винта и получается двухтоновой звук.
Алан снова садится на велосипед. Некоторое время они едут молча. Собственно, они и до этого не столько разговаривали, сколько подкидывали друг другу идеи и давали время подумать. Это очень производительный способ общения; он устраняет значительную часть избыточности, на которую жаловался Алан в случае Рузвельта и Черчилля.
Уотерхауз думает о вложенных циклах. Он уже решил, что человеческое общество действует по этому самому принципу* [У него нет никаких определенных фактов на этот счет, просто идейка кажется занятной.], и теперь пытается понять, похоже оно на велосипед Тьюринга (некоторое время работает безотказно, потом внезапно цепь сваливается, отсюда — мировая война), как «Энигма» (долго непонятно скрипит, потом вращающиеся диски выстраиваются, как в игровом автомате, и наступает всеобщее счастье, или, если предпочитаете, Апокалипсис), или просто как самолетный мотор (крутится себе и крутится, ничего особенно не происходит, кроме шума).
— Смотри, сзади! Вон там! — Алан резко тормозит. Это просто шутка, чтобы Лоуренсу пришлось сделать крутой поворот на узкой дороге.
Они прислоняют велосипеды к дереву и снимают с багажников оборудование: сухие батареи, макетные платы, палки, саперный инструмент, мотки провода.
— Я скоро в Америку, работать над проблемой шифрования голоса в лабораториях компании «Белл», — говорит Алан.
Лоуренс невесело смеется.
— Мы с тобой как те корабли у Лонгфелло, которые встретились в ночи, помигали сигнальными огнями и снова разошлись.
— Мы пассажиры на этих кораблях, — поправляет Алан. — Это не случайность. Ты здесь именно потому, что я уезжаю. До сих пор всю работу подразделения 2701 тянул я.
— Теперь это подразделение 2702, — говорит Лоуренс.
Алан расстроен.
— Заметил, значит.
— Очень неосторожно с твоей стороны, Алан.
— Наоборот! — говорит Алан. — Что подумает Руди, если заметит, что во всей армии союзников нет ни одного подразделения, номер которого был бы произведением двух простых чисел?
— Ну, это зависит от того, насколько часто такие числа встречаются и сколько других чисел не использовано, — говорит Лоуренс и начинает решать первую часть задачи. — Опять риманова дзета-функция. Везде она вылезает.
— Вот это по мне! — говорит Алан. — Разумный, деловой подход. Не то что у них.
— У кого?
— Вот здесь. — Алан останавливается и смотрит на деревья, которые, на взгляд Уотерхауза, ничем не отличаются от соседних. — Вроде они. — Он садится на упавший ствол и начинает доставать из рюкзака оборудование. Лоуренс садится рядом и тоже развязывает рюкзак. Он не знает, как работает устройство — это изобретение Алана, — и исполняет роль хирургической медсестры: по мере надобности подает инструмент и материалы. Доктор говорит без умолку, поэтому не просит подать нужную вещь, а смотрит на нее пристально и хмурится.
— У кого по-твоему? У придурков, которые используют информацию, полученную из Блетчли-парка.
— Алан!
— Не придурки, скажешь? Возьми Мидуэй! Идеальный пример.
— Ну, я был рад, когда мы выиграли сражение, — осторожно замечает Лоуренс.
— А тебе не показалось немного странным, немного удивительным, немного явным, что после всех блестящих обманных маневров Ямамото этот ваш Нимиц в точности знал, где именно его искать? В одном определенном месте всего Тихого океана?
— Ладно, — говорит Лоуренс. — Я возмутился, докладную написал. Наверное, из-за нее сюда и попал.
— Так вот, мы, англичане, ничуть не лучше.
— Да?
— Если бы ты узнал, что мы творим в Средиземном море, ты бы ужаснулся. Это скандал. Преступление.
— Что мы там творим? — спрашивает Лоуренс. — Я говорю «мы», а не «вы», потому что теперь мы союзники.
— Да, да, — нетерпеливо отвечает Алан. — Так утверждают. — Он замирает, проводит пальцем вдоль цепей схемы, рассчитывая в уме индуктивности. — Ну, мы топим конвои. Немецкие конвои. Топим направо и налево.
— Конвои для Роммеля?
— Да. Немцы грузят топливо, танки и боеприпасы в Неаполе и отправляют суда на юг. Мы их топим. Топим почти все, потому что взломали итальянский шифр C38m и знаем, когда они выходят из Неаполя. А последнее время мы топим вообще все суда с припасами, которые особенно нужны Роммелю, потому что взломали его шифр «Зяблик» и знаем, что он настойчивей всего требует.
Тьюринг щелкает на своем изобретении тумблером. Пыльный конус из черной бумаги, привязанный к плате бечевкой, противно верещит. Конус — это репродуктор, надо думать, из радиоприемника. Алан берет ручку от метлы с длинной проволочной петлей на конце (вдоль палки к плате тянется провод) и проводит ею на уровне пояса, пока петля, как лассо, не повисает перед Лоуренсом. Репродуктор вопит.
— Отлично. Реагирует на твою пряжку, — говорит Алан.
Он ставит конструкцию на сухие листья, роется в нескольких карманах и, наконец, вытаскивает листок, на котором печатными буквами написано несколько строчек. Лоуренс узнал бы листок где угодно: это дешифровальная ведомость.
— Что там у тебя, Алан?
— Я записал подробные инструкции, положил в пузырек из-под амфетамина и спрятал под мостом, — говорит Алан. — На прошлой неделе я забрал пузырек и расшифровал инструкции. — Он машет листочком в воздухе.
— Какой шифровальный системой ты пользовался?
— Моей собственной. Хочешь, попытайся взломать.
— А почему решил выкопать именно сейчас?
— Это была предосторожность на случай немецкого вторжения, — говорит Алан. — Теперь, когда вы вступили в войну, нас точно не оккупируют.
— И много ты зарыл?
— Два серебряных слитка, Лоуренс, каждый на сумму примерно сто двадцать пять фунтов. Один должен быть совсем близко.
Алан встает, вынимает из кармана компас, поворачивается лицом к северу и расправляет плечи. Потом поворачивается на несколько градусов.
— Не помню, учел ли я магнитное склонение, — бормочет он. — Точно! Ладно, все равно. Сто шагов на север. — Алан углубляется в лес. За ним идет Лоуренс, которому поручено нести металлоискатель.
Доктор Тьюринг может ехать на велосипеде и, не прерывая разговора, считать обороты педалей. Точно так же он может считать шаги и разговаривать. Впрочем, не исключено, что он просто давно сбился со счета.
— Если все, что ты говоришь, правда, — произносит Лоуренс, — то мы наверняка допрыгались. Руди должен был сообразить, что мы взломали их коды.
— Существовала неофициальная система, которую можно считать предшественницей подразделения 2701, или 2702, или как там мы его называем, — говорит Алан. — Когда мы хотим потопить конвой, то посылаем самолет-разведчик. Разумеется, наблюдение — не настоящая его цель, мы и без того знаем, где конвой. Цель — пролететь так близко, чтобы его заметили. Тогда с корабля отправляют радиограмму, что их засек самолет службы наблюдения. Когда мы после этого их топим, немцы не удивляются — во всяком случае, не настолько удивляются, чтобы понять истинное положение дел.
Алан останавливается, сверяется с компасом, поворачивает на девяносто градусов и начинает идти на запад.
— По-моему, это мертвому припарки, — говорит Лоуренс. — Насколько вероятно, что союзный разведчик, посланный наугад, случайно заметит все до одного конвои?
— Я уже подсчитал и готов поспорить на любой из моих серебряных слитков, что Руди подсчитал тоже, — отвечает Тьюринг. — Вероятность очень мала.
— Значит, я прав, — говорит Лоуренс, — и, судя по всему, мы допрыгались.
— Может быть, еще нет. Пока все на волоске. На прошлой неделе мы потопили конвой в тумане.
— В тумане?
— Туман висел весь день. Засечь конвой с воздуха было нельзя. Эти кретины все равно его потопили. У Кессльринга, ясное дело, закрались подозрения. Тогда мы сфабриковали сообщение (зашифрованное кодом, который, мы точно знаем, нацисты вскрыли) к вымышленному агенту в Неаполе, в котором благодарили за информацию о конвое. С тех самых пор гестапо прочесывает портовые районы Неаполя — ищет нашего человечка.
— Значит, пока пронесло.
— Да. — Алан резко останавливается, забирает у Лоуренса металлоискатель и начинает водить петлей по поляне. Петля постоянно задевает о ветки и гнется, так что ее приходится выпрямлять, но упорно молчит, если только Алан для проверки не подносит ее к пряжке у Лоуренса на ремне.
— Дело страшно тонкое, — задумчиво произносит Алан. — Некоторые офицеры ПСС в Северной Африке...
— ПСС?
— Подразделений спецсвязи. Они передают данные «Ультры» в полевые штабы и следят, чтобы их там уничтожили. Так вот, некоторые из них, узнав из «Ультры», что в обеденное время будет немецкий авианалет, пришли в столовую с касками. Когда авианалет произошел в указанное время, многих заинтересовало, как они догадались прихватить каски.
— Безнадега какая-то, — вздыхает Лоуренс. — Почему же немцы до сих пор не догадались?
— Нас это удивляет, потому что мы знаем все и наши каналы связи свободны от шума, — говорит Алан. — У немцев каналов связи меньше, а шума в них больше. Если мы не будем постоянно делать явные глупости, скажем, топить конвои в тумане, они никогда не получат однозначного доказательства, что мы взломали «Энигму».
— Забавно, что ты помянул «Энигму», — говорит Лоуренс, — потому что этот канал содержит огромное количество шума, из которого мы ухитряемся извлекать массу полезной информации.
— Именно поэтому я и беспокоюсь.
— Ладно, я, как могу, постараюсь одурачить Руди.
— Ты-то справишься. Я беспокоюсь из-за тех, кто выполняет операцию на местах.
— Полковник Чаттан представляется вполне надежным. — Лоуренс понимает, что успокаивать Алана бесполезно. У него просто такое настроение. Раз в два или три года Уотерхауз проявляет светский такт, и сейчас как раз такой случай: он меняет тему. — Значит, займешься секретной телефонией для Рузвельта и Черчилля?
— В теории. Сомневаюсь, что из этого выйдет что-нибудь практическое. В лабораториях «Белл» есть система, основанная на том, что форму сигнала разбивают на несколько диапазонов... — И Алан углубляется в рассказ о телефонных компаниях. Он выдает развернутый доклад о теории информации в приложении к человеческому голосу, и о том, как это влияет на телефонию. Хорошо, что у Тьюринга такая большая тема для изложения: лес большой, и он явно не помнит, где зарыл серебро.
Необремененные слитками серебра, друзья едут назад в сумерках, которые в этих северных широтах наступают на удивление рано. Они по большей части молчат: Лоуренс переваривает то, что Алан наболтал про подразделение 2702, конвои, лаборатории «Белл» и избыточность голосового сигнала. Каждые несколько минут их обгоняет мотоцикл с шифровками в багажном контейнере.

НА ВЫСОТЕ

Все, что годится для переброски скота, Бобби Шафто в разное время испробовал на себе — телячьи вагоны, открытые бортовые машины, форсированные марши по пересеченной местности. Теперь военные придумали этим радостям воздушный аналог — Самолет с Тысячью Имен: «Дуглас», DC-3, «старый толстяк», С-47, «номер три», «дакота», «дуг». Голые алюминиевые ребра фюзеляжа пытаются забить Бобби до смерти, но он пока отбивается. Главное, не заснуть.
Рядовых затолкали во второй самолет. В этом — лейтенанты Этридж и Роот вместе с рядовым первого класса Готтом и сержантом Бобби Шафто. Лейтенант Этридж подгреб под себя все, что было в отсеке мягкого, устроил гнездышко в передней части самолета и пристегнулся. Некоторое время он делал вид, что читает документы. Потом стал смотреть в иллюминатор. Сейчас он уснул и храпит так, что, кроме шуток, заглушает моторы.
Енох Роот забился в дальнюю, узкую часть фюзеляжа и читает две книги разом. Шафто думает, что это очень типично: книги наверняка говорят совершенно разные вещи, и капеллану нравится их стравливать — есть же любители играть в шахматы за обоих игроков сразу. Наверное, когда живешь на горе, а туземцы вокруг не знают ни одного из десятка языков, которыми ты владеешь, поневоле научишься спорить с самим собой.
В обоих бортах самолета — ряды маленьких квадратных иллюминаторов. Шафто смотрит направо и видит горы, покрытые снегом. Он в панике: неужели они сбились с пути и летят над Альпами? Однако слева по-прежнему Средиземное море. Постепенно его сменяет каменистая местность, заросшая чахлым кустарником, из которого торчат каменные столбы вроде «Башни Дьявола» в Вайоминге, потом остаются только камни и песок или песок без камней. Там и сям без всяких видимых причин песок морщится барханами. Черт возьми, они все еще в Африке!
Безобразие, почему не видно львов, жирафов и носорогов?.. Шафто идет высказать претензию пилотам. Может, удастся перекинуться с земляками в картишки. Или из переднего окна кабины видно что-нибудь такое, о чем можно будет написать домой.
Полный облом. Ничего в переднее окно не видно. Во всей вселенной есть только море, небо, песок. Каждый морпех знает, какое скучное это море. Песок и небо — немногим лучше. Впереди облачная гряда — какой-то там атмосферный фронт. И все.
Шафто успевает в общих чертах ознакомиться с планом полета, прежде чем карту убирают подальше от его глаз. Судя по всему, они летят над Тунисом. Бред какой-то. Когда Шафто интересовался последний раз, Тунис был под немцами и даже оставался их главным оплотом в Северной Африке. Судя по плану, они намерены лететь над проливом между Бизертой и Сицилией, потом на восток, к Мальте.
Припасы и подкрепления доставляют Роммелю через этот самый пролив и выгружают в Бизерте или Тунисе. Отсюда Роммель может ударить на восток, по Египту, или на запад, по Марокко. Несколько недель назад восьмая британская армия задала ему жару под Эль-Аламейном (это как раз в Египте), и с тех самых пор он отступает к Тунису. Недавно в Северной Африке высадились американцы, но пока ему здорово удается сражаться на два фронта, насколько Шафто угадывает промеж строк информационных радиосводок — уж больно они становятся бодрыми, как только речь заходит о Роммеле.
Все это означает, что под ними, в Сахаре, развернуты и готовы к бою крупные силы. Может быть, прямо сейчас идет сражение. Однако Шафто ничего такого не видит, только за редким караваном стелется пыль, словно дым вдоль бикфордова шнура.
Поэтому Шафто беседует с пилотами, пока по их взглядам не замечает, что говорит уже очень долго. Видать, эти гашишины убивали свои жертвы, забалтывая их до смерти.
На картишки рассчитывать нечего. Пилоты молчат, как в рот воды набрали. Приходится ввалиться в кабину и чуть ли не схватиться за рычаги, чтобы вытянуть из них хоть слово. Говорят они как-то странно. Только тут до Шафто доходит, что они не земляки, а друзья. Они — англичане.
Прежде чем убраться в грузовой отсек, он успевает заметить еще одно: оба пилота вооружены до зубов, как будто рассчитывают уложить человек двадцать — тридцать по пути от самолета в сортир и обратно. Шафто успел повидать таких психов, и ему это не нравится. Уж очень напоминает Гуадалканал.
Он находит место на дне грузового отсека рядом с рядовым первого класса Готтом и ложится. Крошечный револьвер на поясе мешает лежать на спине. Шафто перекладывает его в карман Теперь главное неудобство — зачехленный рейдерский стилет упрятанный между лопаток. Хочется лечь на бок, но с одной стороны казенный полуавтоматический кольт, которому он не доверяет, с другой — свой проверенный шестизарядник. Приходится разместить это все на полу, вместе с запасными обоймами, патронташами и разнообразными принадлежностями.
Кроме того, приходится отстегнуть от левой лодыжки нож «Гун-хо», незаменимый при расчистке джунглей, вскрытии кокосовых орехов и обезглавливании нипов, а от правой — короткоствольный крупнокалиберный пистолет, который Шафто носит для равновесия. Остаются только гранаты в передних карманах, потому что на животе он лежать не собирается.
Они огибают мыс как раз вовремя, чтобы их не унесло приливом. Впереди илистое дно бухточки. С одной стороны ее ограничивает мыс, который они только что обогнули, с другой, в нескольких ярдах впереди — следующий, до тошноты похожий, с третьей — вертикальный обрыв. Даже если бы он не был покрыт непроходимыми джунглями, взобраться все равно бы не удалось из-за крутизны. Морпехи заперты в бухте до следующего отлива.
У нипского пулеметчика вдоволь времени, чтобы перестрелять их всех.
Они сразу узнают звук очереди и падают в ил. Шафто быстро оглядывается. Те, что лежат на спине или на боку, вероятно, мертвы. Те, что на животе, — вероятно, живы. Большая часть лежит на животе. Сержант явно мертв — пулеметчик первым делом целил в него.
Пулемет у нипа — или нипов — один, но патронов хоть отбавляй. Их доставляет «Токийский экспресс», который беспрепятственно курсирует проливом Слот. Пулеметчик не спеша прочесывает бухту, быстро переключая огонь на тех морпехов, которые пытаются шевельнуться.
Шафто вскакивает и бежит к обрыву.
Наконец он видит вспышки. Они показывают, куда направлено пулеметное дуло. Когда они удлиненные, то на кого-то другого. Когда становятся короче, это значит, что ствол разворачивается к Бобби Шафто...
Черт, не рассчитал. В нижней правой части живота жуткая боль. Ил заглушает крики: каска и ранец-рюкзак вдавливают его мордой в жидкую грязь.
Кажется, он теряет сознание. Но ненадолго. Пулемет по-прежнему трещит, значит, кто-то из ребят еще жив. Шафто с трудом поднимает голову, пересиливая вес каски, и видит между собой и пулеметом бревно — отполированный волнами плавник, далеко выброшенный штормом.
Можно бежать к бревну — или не бежать. Шафто решает бежать. Это всего несколько шагов. На полпути он понимает, что успеет. Приходит наконец второе дыхание — он делает стремительный рывок и падает за бревном. Десяток пуль глухо шмякаются о древесину, на Шафто сыплются мокрые волокнистые щепки. Бревно гнилое.
Плохо, что Шафто не может посмотреть вперед или назад, не приподнявшись над бревном. Других морпехов не видно, не слышно криков. Он решает взглянуть, где там пулеметчик. За растительностью почти ничего не видно, но похоже, огневая точка где-то в пещере, футах в двадцати над отмелью. Шафто не так далеко от обрыва — расстояние преодолевается в одну перебежку. Однако лезть на обрыв — верная смерть. Вряд ли пулемет можно наклонить настолько, чтобы стрелять вниз, но тебя закидают гранатами или расстреляют из винтовки, пока будешь карабкаться по камням.
Другими словами, время для винтовочного гранатомета. Шафто перекатывается на спину, вытаскивает из полотняной амуниции ребристую металлическую насадку, прилаживает ее к винтовочному стволу, пытается прикрутить... Пальцы проскальзывают на чертовой гайке. Тыловое умники! Не догадались поставить здесь гайку-барашек! Крути — не крути, без толку. Все вокруг в крови, но боли нет. Шафто трет пальцами по песку, чтобы не скользили, закручивает проклятую гайку.
Из подсумка извлекается осколочная граната Марк-II, она же «ананас», за ней — гранатометное приспособление M1 с боевым зарядом. Одно вставляется в другое, выдергивается чека, все вместе забивается в ствол винтовочного гранатомета. Наконец Шафто лезет в специально помеченный патронташ, роется в гнутых и сломанных сигаретах, находит холостой патрон, который и заряжает в «спрингфилд».
Он ползет вдоль бревна, чтобы выстрелить с неожиданного места — тогда, может быть, не срежут голову очередью. Наконец поднимает всю эту систему-ниппель, упирает приклад в песок (при стрельбе в режиме гранатомета отдача такая, что запросто сломает ключицу), направляет ее на врага, жмет на курок. Гранатометное приспособление M1 с грохотом вылетает, оставляя позади целую скобяную лавку ненужных деталей, словно душа, покинувшая грешное тело. «Ананас» взмывает ввысь, без чеки и предохранителя, химический запал горит так, что вся эта штука светится изнутри. Шафто не промахнулся, граната летит в цель. Он уже готов поздравить себя, но тут граната отлетает назад, катится с обрыва и взрывает соседнее гнилое бревно. Нины предусмотрели такую возможность и натянули противогранатную сетку.
Шафто лежит на спине в мокрой грязи, снова и снова твердит слово «бля». Все бревно содрогается, что-то похожее на мох-сфагнум сыплется на лицо. Пули постепенно вгрызаются в гнилушку. Бобби Шафто приносит молитву Всевышнему и готовится лечь грудью на амбразуру.
Одуряющий треск пулеметной очереди смолкает, слышатся крики. Голос вроде незнакомый. Шафто приподнимается на локте и понимает, что крики несутся со стороны пещеры.
Он смотрит в большие, небесно-голубые глаза Еноха Роста.
Капеллан оставил свой уютный уголок в дальней части самолета и сидит на корточках перед иллюминатором, цепляясь за что попало. Бобби Шафто, который во сне перекатился на живот, смотрит в иллюминатор противоположного борта. Он должен видеть небо, но за иллюминатором стремительно проносится бархан. На Шафто накатывает тошнота. Даже мысли нет о том, чтобы сесть.
Яркие пятна света стремглав носятся по грузовому отсеку, как шаровые молнии, но — и поначалу это совсем не очевидно — они бегают по стенам, как луч от фонарика. Шафто может проследить эти лучи, потому что воздух постепенно наполняется влажной дымкой от какой-то распыленной гидравлической жидкости. Пока он спал, какой-то кретин проделал в обшивке самолета ряд круглых дырочек. В них светит солнце, разумеется, с одной стороны, однако самолет все время мотает туда-сюда.
Шафто соображает, что с самого пробуждения лежит на потолке, потому и на животе. Когда это окончательно доходит до сознания, его выворачивает.
Яркие пятна разом исчезают. Очень нехотя Шафто решает выглянуть в иллюминатор и видит одну серость.
Похоже, он на полу. Во всяком случае, он рядом с покойником, а тот пристегнут.
Шафто лежит несколько минут, просто дышит и думает. Воздух свистит через дырки в фюзеляже, да так, что раскалывается голова.
Кто-то — какой-то псих — идет по самолету. Это не Роот — капеллан в своем уголке, изучает ссадины на лице, полученные во время воздушной гимнастики. Шафто поднимает глаза и видит, что это один из английских летчиков.
Англичанин снял шлемофон и защитные очки. У него черные волосы и зеленые глаза. Ему лет тридцать пять, старик. Лицо корявое, утилитарное — все выпуклости и отверстия имеют определенное назначение; это лицо сконструировал тот же человек, который создал винтовочный гранатомет. Простое, честное лицо, ни в коем случае не красивое. Пилот опускается на колени и светит фонариком на Джеральда Готта. Лоб озабоченно хмурится; обращение с пациентом безупречно.
Наконец летчик откидывается спиной на гофрированную обшивку фюзеляжа.
— Слава богу, — говорит он, — в него не попало.
— В кого? — спрашивает Шафто.
— В этого. — Летчик похлопывает по мертвому телу.
— А меня проверять не будешь?
— Незачем.
— А почему? Я покамест живой.
— В тебя не попало, — уверенно говорит летчик. — Если бы попало, ты бы выглядел, как лейтенант Этридж.
Впервые Шафто решает повернуться. Он привстает на локте и обнаруживает, что дно самолета в чем-то красном и липком.
Он заметил розовую дымку в грузовом отсеке и решил, что произошла утечка какой-то гидравлической жидкости. Однако гидравлическая система исправна, и на полу разлито не масло. Это та самая красная жидкость, что так часто фигурирует в его кошмарах. Она льется из уютного гнездышка, которое соорудил себе лейтенант Этридж, и лейтенант больше не храпит.
Останки лейтенанта Этриджа больше всего похожи на то, что лежало сегодня утром в разделочном цехе. Шафто не хочет сплоховать перед британским летчиком, к тому же он на удивление спокоен. Может быть, все дело в облаках — они всегда действуют на него умиротворяюще.
— Ядрена вошь, — говорит он. — Эти немецкие двадцатимиллиметровые — не фунт изюма.
— Ага, — говорит летчик. — Теперь надо, чтобы нас засек конвой, и можно доставлять груз.
Несмотря на всю загадочность фразы, в ней хоть что-то говорится о планах подразделения 2702. Шафто встает и идет вслед за летчиком. Оба деликатно переступают через мягкие потроха, которые, по всей видимости, отлетели от Этриджа.
— В смысле, союзный конвой? — спрашивает Шафто.
— Союзный? — передразнивает летчик. — Где мы, черт возьми, найдем тебе союзный конвой? Это Тунис.
— Тогда что значит — «чтобы нас засек конвой»? Чтобы мы засекли конвой, да?
— Извини, приятель, — говорит летчик. — Мне некогда.
Шафто оборачивается и видит, что лейтенант Енох Роот стоит над относительно большим куском Этриджа и роется в его портфеле. Шафто делает преувеличенно строгий вид и обличающе грозит пальцем.
— Послушай, Шафто, — кричит Роот. — Я просто исполняю приказы. Принимаю у него командование.
Он вытаскивает небольшой сверток в желтой пластиковой обертке, проверяет содержимое и вновь укоризненно смотрит на Шафто.
— Да пошутил я, — говорит Шафто. — Помнишь? Помнишь, когда я подумал, что те ребята курочат покойников? На берегу?
Роот не смеется. То ли он злится, что купился на розыгрыш, то ли не любит шуток по поводу мародерства. Роот несет сверток к другому покойнику, тому, что в гидрокостюме. Заталкивает сверток в гидрокостюм.
Потом садится возле тела и задумывается. Думает он долго. Шафто смотрит как зачарованный. Наблюдать за Енохом Роотом, когда тот думает, так же интересно, как смотреть на восточную танцовщицу, которая трясет сиськами.
Они выходят из облаков, и освещение снова меняется. Солнце садится, алое в сахарской дымке. Шафто выглядывает в иллюминатор и вздрагивает. Под ними конвой, по темной воде от каждого корабля расходятся две четкие белые волны, каждая с одного бока подсвечена садящимся солнцем.
Самолет ложится на одно крыло и описывает медленный вираж над конвоем. Слышатся далекие чпок-чпок-чпок. Черные цветы распускаются и гаснут в небе. Шафто понимает, что по ним бьют из зениток. Потом самолет снова уходит в облака и становится почти совсем темно.
Впервые после долгого перерыва Шафто смотрит на Еноха Роота. Тот снова в своем уголке, читает при карманном фонарике. На коленях у него раскрытый сверток с бумагами. Это тот самый сверток, который Роот забрал у Этриджа и затолкал Джеральду Готту в гидрокостюм. Шафто решает, что встреча с конвоем и зенитный обстрел доконали капеллана и тот вытащил сверток, чтобы его изучить.
Роот поднимает голову, их взгляды встречаются. Он не испуган и не пристыжен. В глазах — ледяное спокойствие.
Шафто несколько секунд смотрит на капеллана. Если смутится или испугается, значит, он — немецкий шпион. Однако нет — Енох Роот не работает на немцев. И на союзников тоже. Он работает на Высшую Силу.
Шафто еле заметно кивает. Взгляд Роота смягчается.
— Они все погибли, Бобби, — кричит он.
— Кто?
— Островитяне, которых ты видел на Гуадалканале. Так вот почему Роот болезненно реагирует на шутки по поводу мародерства.
— Прости, — говорит Шафто и подсаживается ближе, чтобы не кричать. — Как это вышло?
— Когда мы принесли тебя ко мне, я передал сообщение моему связному в Брисбене, — говорит Роот. — Зашифровал его специальным кодом. Так и так, подобрал рейдера морской пехоты, который, возможно, выживет, заберите его, пожалуйста.
Шафто кивает. Он помнит, что слышал много точек и тире, но был в отключке из-за лихорадки, морфия или что там у Роота в коробке из-под сигар.
— Они ответили, — продолжает Роот, — мол, мы не можем сюда попасть, но, пожалуйста, доставь его туда-то и туда-то, там вас встретят другие рейдеры. Так, ты помнишь, мы и поступили.
— Да, — говорит Шафто.
— Пока все хорошо. Но когда я передал тебя твоим и вернулся, оказалось, что у меня побывали японцы. Перебили всех островитян, которых смогли отыскать. Сожгли дом. Сожгли все. Понаставили мин, я еле выбрался.
Шафто кивает. Он видел, что делают японцы.
— Меня вывезли в Брисбен, и я стал вонять по поводу кодов. Понимаешь, японцы взломали наш код, иначе бы они меня не нашли. Вонял я довольно долго, и наконец мне сказали: «Ты британский подданный, ты священник, ты врач, ты умеешь держать винтовку, ты знаешь азбуку Морзе, а главное, ты всех здесь заколебал, так что — вперед!» И не успел я опомниться, как оказался в Алжире, в морозильной камере.
Шафто отводит глаза и кивает. Роот понимает, что сержанту известно не больше, чем ему.
Позже Роот снова заворачивает пакет, но не убирает в портфель, а заталкивает Готту в гидрокостюм.
Потом они снова выходят из облаков, рядом с освещенным луной портом, и летят над океаном так медленно, что даже Шафто, который ни хрена не разбирается в самолетах, понимает, что сейчас заглохнут моторы. Они открывают боковую дверь «дакоты» и выбрасывают тело рядового первого класса Готта в океан. Для Окономовокского пруда это был бы грандиозный всплеск, для океана — так себе.
Через час или чуть позже тот же «Дуглас» садится на посадочную полосу в разгар воздушной бомбардировки. Они вылезают из «старого толстяка» в конце полосы, рядом с другим «С-47», и бегут вслед за пилотами. По лестнице, вниз, точнее — в бомбоубежище. Теперь они ощущают, но не слышат разрывы бомб.
— Добро пожаловать на Мальту, — говорит кто-то. Шафто оглядывается и видит вокруг людей в американской и британской военной форме. Американцы знакомые — это взвод рейдеров МПФ из Алжира, они летели во второй «дакоте». Британцы незнакомые. Шафто решает, что это те самые авиадесантники, о которых говорили в Вашингтоне. Единственное, что у всех общего, — число 2702 где-нибудь на одежде.

НЕРАЗГЛАШЕНИЕ

Ави подъезжает вовремя — его дорогой, но в меру навороченный японский спортивный автомобиль тормозит на крутой дороге, разбитой трещинами в мозаику асфальтовых плит. Рэнди смотрит на него с балкона второго этажа, с высоты почти пятидесяти футов. На Ави брюки от хорошего летнего костюма, белая хлопковая рубашка, темные очки, широкополая парусиновая шляпа.
Дом одиноко вздымается над калифорнийскими лугами в нескольких километрах от Тихого океана. Прохладный ветер набегает волнами, как океанский прибой. Выйдя из машины, Ави первым делом надевает пиджак.
Он вытаскивает из небольшого багажника под капотом два здоровенных лэптопа, заходит в дом без стука (здесь он впервые, но бывал в похожих), разыскивает в одной из комнат Рэнди с Эбом и выгружает из сумок примерно на пятнадцать тысяч долларов компьютерных прибамбасов. Все это выстраивается на столе. Ави запускает оба компьютера и, пока идет загрузка, подключает их к сети, чтобы не садились батарейки. Наружная проводка в разъемном виниловом корпусе с заземленными силовыми розетками через каждые пятьдесят сантиметров зверски привинчена к каждому дюйму стен; дыры в стенах, в панелях, в первобытных оп-артовских картинках на контактной фотобумаге, в выгоревших плакатах группы «Грейтфул Дэд» и даже в дверном косяке.
Один из лэптопов подключен к портативному принтеру. Ави загружает в него несколько листов бумаги. Второй выдает на экран несколько строк, пищит и замирает. Рэнди подходит и с интересом смотрит на экран. На нем приглашение:

FILO

Рэнди знает, что это сокращенное имя загрузчика, программы, которая позволяет выбрать операционную систему.
— Finux, — буркает Ави в ответ на незаданный вопрос Рэнди.
Рэнди набирает «Finux», нажимает «ввод».
— Сколько у тебя здесь операционных систем?
— Windows 95 для игрушек и на случай, если надо будет одолжить компьютер какому-нибудь «чайнику», — говорит Ави. — Windows NT — для всякой офисной ерунды. BeOS — для программирования и медийных штук. Finux — для печатания в промышленных масштабах.
— Какую сейчас?
— BeOS. Хочу показать несколько картинок. Полагаю, проектор есть?
Рэнди смотрит на Эба, который единственный из всех троих здесь живет. Эб кажется больше своего роста, возможно, из-за взрывной шевелюры — почти метровой, светлой в рыжину, густой и волнистой. Волосы постоянно сваливаются в толстые жгуты и обычной резинке их не удержать — Эб завязывает «хвост» бечевкой, если вообще завязывает. Сейчас он машинально чертит на экране маленького компьютера, такого, на котором можно рисовать световым пером. Обычно серьезные программеры такими не пользуются, но Эб (вернее, его гикнувшаяся компания) писал для этой модели софт, поэтому у него их целая куча. Кажется, что он полностью погрузился в свое занятие, тем не менее он чувствует на себе взгляд Рэнди и поднимает голову. У Эба светло-зеленые глаза и пышная рыжая борода, которую он периодически сбривает — обычно когда у него серьезный роман. Сейчас борода у Эба примерно сантиметровой длины, что подразумевает недавний разрыв и готовность к новым приключениям.
— Проектор? — спрашивает Рэнди.
Эб закрывает глаза, осуществляет доступ к памяти, снова открывает их, встает и выходит из комнаты.
Из принтера начинает выползать лист. Сверху, по центру, напечатано «СОГЛАШЕНИЕ О НЕРАЗГЛАШЕНИИ». Следом ползут другие строчки. Рэнди видел их или похожие столько раз, что глаза у него сразу стекленеют. Он отворачивается. Единственное, что изменилось, это название фирмы: «КОРПОРАЦИЯ ЭПИФИТ(2)».
— Классные очки.
— Думаешь, дикие? Погоди, увидишь, какие я надену, когда зайдет солнце. — Ави роется в сумке и вынимает устройство, похожее на очки без стекол, но с кукольными галогенными лампами над каждым глазом. От них тянется проводок к батарейке, которая крепится на поясе. Ави щелкает выключателем на батарейке, лампочки вспыхивают бело-голубым светом.
Рэнди поднимает брови.
— Это чтобы не менять часовые пояса, — объясняет Ави. — Я привык к азиатскому времени. Через два дня мне снова туда. Не хочу перестраиваться.
— Значит, шляпа и черные очки...
— ...имитируют ночь. Эта штука имитирует день. Понимаешь, наш организм настраивает внутренние часы по свету. Кстати, закрой, пожалуйста, жалюзи.
Окно выходит на запад, на бухту Хаф-Мун-Бей. Ранний вечер, солнце сияет вовсю. Рэнди некоторое время любуется видом, потом опускает жалюзи.
Эб входит с проектором, как Беовульф, потрясающий отрубленной рукою чудовища. Он ставит проектор на стол и направляет на стену. Экран не нужен, потому что поверх внешней проводки развешаны белые доски, исписанные яркими маркерами. Некоторые закорючки обведены в кривые рамки с пометкой «НЕ СТИРАТЬ!» или просто «НС!» На той, что перед проектором, — список покупок, номер факса в России, пара доменных имен и несколько слов на немецком, написанных, надо думать, самим Эбом. Доктор Эберхард Фёр изучает это все и, не обнаружив пометки «НС!», стирает губкой.
В комнату, оживленно ругая какую-то отстойную компанию в Берлингейме, входят еще двое. Первый — худощавый, темноволосый, похож на героя вестерна и даже носит черную шляпу. Второй — упитанный блондин, как будто только что с собрания Ротари-клуба. Общего у них одно — серебряные браслеты на запястье.
Рэнди достает из принтера соглашения и раздает каждому по два экземпляра с заранее впечатанными именами и фамилиями: Рэнди Уотерхауз, Эберхард Фёр, Джон Кантрелл (в черной шляпе) и Том Говард (полный блондин). Когда Джон и Том тянутся за листками, свет, сочащийся сквозь жалюзи, вспыхивает на браслетах. На каждом выгравированы медицинская эмблема и какой-то текст.
— Эти выглядят иначе, — замечает Рэнди. — Опять поменяли текст?
— Да! — говорит Джон Кантрелл. — Версия 6.0 — только на прошлой неделе выпустили.
В любом другом месте такие браслеты означали бы, что у Тома и Джона что-то опасное для жизни, скажем, аллергия на антибиотики. Врач, вытащивший их из разбитого автомобиля, увидел бы браслеты и выполнил указания. Однако здесь, в Силиконовой Долине, все иначе. На одной стороне браслетов написано:

В СЛУЧАЕ СМЕРТИ СМ.
ИНСТРУКЦИЮ ПО БИОСТАЗИСУ
НА ДРУГОЙ СТОРОНЕ
ВЫПОЛНИ ИНСТРУКЦИЮ
ПОЛУЧИШЬ $ 100 000

а на другой:

ПОЗВОНИТЬ ЗА УКАЗАНИЯМИ
1–800-NNN-NNNN
ВВЕСТИ 50 000 ЕД ГЕПАРИНА ВНУТРИВЕННО
ПОДДЕРЖИВАЯ СЕРДЕЧНО-ЛЕГОЧНУЮ ДЕЯТЕЛЬНОСТЬ
ОХЛАДИТЬ ЛЬДОМ ДО 10°С
ПОДДЕРЖИВАТЬ РН 7,5
НЕ ПРОВОДИТЬ ВСКРЫТИЯ!
НЕ БАЛЬЗАМИРОВАТЬ!

Это рецепт заморозки мертвого — или почти мертвого — человека. Люди, которые носят такие браслеты, верят, что так можно заморозить мозг и другие нежные ткани, не разрушая их. Через несколько десятилетий, когда развитие нанотехнологии сделает возможным бессмертие, их, если все будет хорошо, разморозят. Джон Кантрелл и Том Говард верят, что с определенной степенью вероятности будут продолжать разговор спустя миллион лет.
Наступает тишина. Все изучают соглашения, выхватывая взглядом привычные пункты. Они на круг подписали, наверное, сотню таких соглашений. Здесь это все равно что предложить гостю чашечку кофе.
Входит женщина с хозяйственными сумками, улыбается, просит извинить за опоздание. Берил Хаген похожа на добрую тетушку, ее легко представить в фартуке с яблочным пирогом в руках. За двадцать лет она была главным бухгалтером двадцати маленьких высокотехнологических компаний. Десять закрылись, все за исключением второй — не по вине Берил. Шестой была Вторая Попытка Рэнди. Одну поглотил «Майкрософт», одна стала процветающей независимой компанией. На этих двух Берил заработала достаточно, чтобы выйти на пенсию. Она консультирует и пишет книги, одновременно подыскивая что-нибудь интересное, чтобы вернуться к активной работе. Ее присутствие в комнате означает, что «Эпифит(2)» — не полное фуфло. А может, она просто не хочет обижать Ави. Рэнди обнимает Берил, отрывая ее от пола, потом протягивает два экземпляра соглашения.
Ави отсоединяет экран от большого лэптопа и кладет его на проектор, так что свет, проходя через жидкокристаллический экран, проецирует изображение на доску. Это обычный рабочий стол: пара окон и несколько ярлыков. Ави обходит всех, собирает соглашения, просматривает, возвращает каждому его экземпляр, остальные убирает в карман компьютерной сумки. Он начинает печатать на клавиатуре, в окошке бегут буквы.
— Как вы все знаете, — бормочет Ави, — корпорация «Эпифит», которую я для краткости буду называть «Эпифит (1)», это делавэрская компания, которой полтора года. Акционеры — я, Рэнди и «Спрингборд-капитал». Мы занимаемся телекоммуникационным бизнесом на Филиппинах. Если захотите, потом расскажу подробнее. В итоге нашей деятельности мы в курсе некоторых новых возможностей, которые открываются в этой части света. «Эпифит(2)» — калифорнийская компания, ей три недели. Если все пойдет по задуманному, «Эпифит (1)» вольется в нее по схеме передачи акций, которую слишком занудно сейчас объяснять.
Ави нажимает «ввод». На рабочем столе открывается новое окно. Это цветная карта, отсканированная из атласа, высокая и узкая. Большая часть — океанская синева. На верхнем краю — изрезанная береговая линия с несколькими городами: Нагасаки, Токио. Шанхай в верхнем левом углу. Филиппинский архипелаг прямо посередине. На север от него Тайвань, на юг — цепочка островов, образующих прерывистый барьер между Азией и обширным куском суши, на котором стоят такие названия, как Дарвин и Большая Песчаная пустыня.
— Вероятно, для вас это выглядит дико, — говорит Ави. — Как правило, такие презентации начинаются со схемы компьютерной сети, или с блок-диаграммы, или чего-то похожего. Обычно мы не имеем дело с картами. Мы так привыкли работать с чистыми абстракциями, что нам странно выйти в реальный мир и что-то сделать на самом деле.
Однако я люблю карты. У меня весь дом в картах. Я уверен, что знания и умения, которые мы все получили — особенно знакомство с Интернетом, — применимы здесь. — Он стучит по Доске. — На большом мокром шаре, населенном миллиардами людей.
Вежливые смешки. Ави проводит рукой по трекболу, нажимает клавишу большим пальцем. Появляется новая картинка: та же карта с яркими линиями, которые тянутся через океан, петляют от города к городу, примерно повторяя береговую линию.
— Существующие глубоководные кабели. Чем толще линия, тем больше труба, — говорит Ави. — А теперь, что не так с этой картинкой?
Несколько толстых линий тянутся на восток от Токио, Гонконга и Австралии — надо полагать, к Соединенным Штатам. Через Южно-Китайское море, разделяющее Филиппины и Вьетнам, прочерчена еще одна толстая линия, но она не связана с этими двумя странами: она идет к Гонконгу и продолжается вдоль китайского побережья к Шанхаю, Корее и Токио.
— Поскольку Филиппины в центре карты, — говорит Джон Кантрелл, — думаю, ты сейчас скажешь, что почти нет толстых линий к Филиппинам.
— Почти нет толстых линий к Филиппинам! — провозглашает Ави. Он указывает на единственное исключение: линию, которая идет от Тайваня к Северному Лусону и, вдоль побережья, к Коррехидору. — За исключением одной, в которой участвует «Эпифит (1)». Но дело в другом. Вообще очень мало толстых линий, соединяющих Австралию с Азией. Куча данных путешествует из Сиднея в Токио через Калифорнию. Это незаполненная ниша для бизнеса.
Берил перебивает его.
— Ави, пока ты в это не ввязался, — говорит она скорбно и предостерегающе, — я должна сказать, что прокладка глубоководного кабеля — не такое дело, в которое можно запросто влезть.
— Берил права! — отвечает Ави. — Средства на прокладку таких кабелей есть только у «Эй-Ти энд Ти», «Кейбл энд Вайрелесс» и «Кокусаи Денсин Денва». Это сложно. Это дорого. Требует крупных НВЗ.
Аббревиатура означает «невосполнимые затраты» — средства на технико-экономическое обоснование, которые будут выброшены в унитаз, если идея не вытанцуется.
— Так о чем ты думаешь? — спрашивает Берил.
Ави щелкает по следующей карте. Она во всем повторяет предыдущую, только на ней нанесены новые линии: целая серия связок между островами. Густая сеть из коротких звеньев по всей длине Филиппинского архипелага.
— Ты хочешь подсоединить Филиппины к Сети через существующую связь с Тайванем, — вставляет Том Говард в героической попытке закоротить цепь рассуждений, которая, по всему, обещает быть очень длинной.
— На Филиппинах скоро грянет информационный бум, — говорит Ави. — Правительство не лишено недостатков, но в целом это демократия западного образца. В отличие от большинства азиатов филиппинцы используют ASCII. Почти все говорят по-английски. Давние связи с Соединенными Штатами. Рано или поздно они станут крупными игроками на рынке информации.
Вмешивается Рэнди:
— Мы уже там закрепились. Знаем обстановку в бизнесе. И у нас стабильный приток денежных средств.
Ави щелкает по новой карте.
Трудно понять, что это такое. Вроде бы карта рельефа обширной местности, на которой высокогорные участки перемежаются редкими плато. Судя по тому, что Ави показал ее посреди презентации без всякой подписи и объяснений, это — задачка на сообразительность. Все замолкают, щурятся. Никто не собирается просить подсказки. Эберхард Фёр, мастер решать головоломки, первым находит решение.
— Юго-Восточная Азия при высохшем океане, — говорит он. — Высокий хребет справа — Новая Гвинея. Холмы — вулканы Калимантана.
— Классно, да? — спрашивает Ави. — Радарная карта. По данным американских военных спутников. Практически ничего не стоит.
На этой карте Филиппины — не цепочка изолированных островов, а наиболее высокие области огромного вытянутого плато, обрамленного глубокими желобами. Чтобы попасть с Лусона на Тайвань, надо спуститься в глубокий ров, окаймленный высокими кряжами, и следовать вдоль него на север на протяжении трехсот миль. А вот к югу от Лусона, где Ави предлагает проложить сеть межостровных кабелей, все мелкое и плоское.
Ави снова щелкает. Подводные части окрашиваются прозрачной синевой, острова — зеленым. Потом он увеличивает ту часть карты, где Филиппинское плато протягивает два отростка к Калимантану, почти целиком охватывая синий ромб протяженностью триста пятьдесят миль.
— Море Сулу, — объявляет Ави. — Не имеет никакого отношения к знаковому азиату в «Стар трек».
Никто не смеется. Они здесь не для того, чтобы зубоскалить, они изучают карту. Трудно разобраться во всех этих архипелагах и морях, даже умным людям с хорошим пространственным воображением. Филиппины образуют правую верхнюю границу моря Сулу, Северный Калимантан (часть Малайзии) — нижнюю левую, архипелаг Сулу — нижнюю правую, а верхняя левая граница — исключительно длинный и тощий филиппинский остров под названием Палаван.
— Это напоминает нам, как искусственны и глупы государственные границы, — говорит Ави. — Море Сулу — бассейн посреди большого плато, на котором лежат Калимантан и Филиппины. Поэтому, подключая Филиппины, легко одновременно подключить и Калимантан, проложив короткий кабель вдоль моря Сулу. Вот так.
Ави щелкает, компьютер рисует новые цветные линии.

Предыдущая страница 9 Следующая страница


Криптономикон (часть 1) 10

— Ави, зачем мы здесь? — спрашивает Эберхард.
— Очень глубокомысленный вопрос, — отвечает Ави.
— Мы знаем, как работают такие компании, — говорит Эб. — Начинаем с голой идеи. Для этого и нужно соглашение о неразглашении — чтобы защитить твою идею. Разрабатываем ее вместе — вкладываем свои мозги — и получаем за это акции. Результат нашей работы — софт. Его можно защитить копирайтом, торговой маркой, даже патентом. Это интеллектуальная собственность, она стоит определенных денег. Мы владеем ею сообща, через акции. Потом мы продаем часть акций инвестору. На эти деньги нанимаем людей, которые создают продукт, продвигают его на рынок и все такое. Так работает система, но мне начинает казаться, что ты этого не понимаешь.
— Почему ты так решил?
Эб озадаченно оглядывается.
— Что мы можем сюда внести? Где здесь то, куда мы могли бы приложить мозги и получить нечто, привлекательное для инвестора?
Все смотрят на Берил. Она согласно кивает.
Том Говард говорит:
— Слушай, Ави. Я умею разрабатывать крупные компьютерные установки. Джон написал «Ордо», он знает все о криптографии. Рэнди — спец по Интернету, Эб — по всяким заумным штучкам, Берил — по финансам. Однако, насколько мне известно, в подводном кабеле все мы — ни в зуб ногой. Как ты собираешься продавать нас инвестору?
Ави кивает.
— Все так, — соглашается он. — Нам надо быть идиотами, чтобы тянуть кабель через Филиппины. Это работа для «ФилиТел», с которым «Эпифит (1)» создал совместное предприятие.
— Даже если бы мы были идиотами, — говорит Берил, — мы бы все равно далеко не ушли, потому что никто не даст нам денег.
— По счастью, об этом можно не беспокоиться, — парирует Ави. — Всю работу за нас уже делают. — Он поворачивается к доске, вынимает красный светящийся маркер и проводит жирную черту между Лусоном и Тайванем. Его рука как будто в проказе: на нее проецируется рельеф морского дна. — КДД предвидит экономический рост на Филиппинах и уже тянет сюда кабель. — Перемещается ниже и начинает рисовать короткие связки между островами. — А «ФилиТел» при финансовой поддержке «АВКЛА» — Азиатский Венчурный Капитал, Лос-Анджелес — прокладывает кабель на Филиппинах.
— При чем здесь «Эпифит (1)»? — спрашивает Том Говард.
— В той мере, в какой они хотят использовать эту сеть для интернет-трафика, им нужны маршрутизаторы и всякие сетевые штучки, — объясняет Рэнди.
— Повторяю мой вопрос: зачем мы здесь? — спокойно, но твердо говорит Эб.
Ави некоторое время работает маркером. Он обводит островок в углу моря Сулу, в середине пролива между Калимантаном и длинным тощим Филиппинским островом под названием Палаван. Пишет печатными буквами: СУЛТАНАТ КИНАКУТА.
— Кинакута в течение какого-то времени управлялась белыми султанами. Долгая история. Потом стала немецкой колонией, — говорит Ави. — Тогда Калимантан еще звался Борнео и входил в голландскую Ост-Индию, а Палаван — как и остальные Филиппины — принадлежал сперва испанцам, потом американцам. Так что это был немецкий оплот в этих краях.
— Немцам всегда доставались самые паршивые колонии, — скорбно замечает Эб.
— После Первой мировой войны Кинакуту передали японцам вместе со множеством других островков дальше к востоку. Все эти острова вместе зовутся Мандатными, потому что Япония управляла ими по мандату Лиги Наций. Во время Второй мировой войны японцы использовали Кинакуту как плацдарм для нападения на голландскую Ост-Индию и Филиппины. Там была база ВМФ и аэродром. После войны Кинакута вновь, как до немцев, обрела независимость. Население — мусульмане и этнические китайцы по краям, анимисты — в центральной части. Власть султана сохранялась всегда, даже под немцами и японцами, которые признавали султана, но отводили ему чисто декоративную роль. На Кинакуте есть запасы нефти, но они оставались непромышленными, пока не появились новые технологии добычи, а цены не взлетели из-за арабского эмбарго. Примерно тогда же на трон взошел нынешний султан. Сейчас он очень богат — не как султан Брунея, который, кстати, приходится ему троюродным братом, — но богат.
— Султан поддерживает вашу компанию? — интересуется Берил.
— Не так, как ты думаешь, — говорит Ави.
— А как? — нетерпеливо спрашивает Том Говард.
— Вот смотрите. Кинакута входит в ООН. Это такое же независимое государство и член мирового сообщества, как Англия или Франция. Причем очень даже независимое благодаря нефти. Форма правления — монархия. Законы издает султан, однако лишь после долгого обсуждения с министрами, которые определяют политику и предлагают законопроекты. В последнее время я много общался с министром связи и телекоммуникаций, помогал ему составить новый законопроект, который касается всех телекоммуникаций, идущих через территорию Кинакуты.
— О господи! — восклицает Джон Кантрелл. Он потрясен.
— Один бесплатный пакет акций мужчине в черной шляпе! — говорит Ави. — Джон Кантрелл разгадал секретный план. Джон, не объяснишь ли, в чем суть, остальным участникам конкурса?
Джон снимает шляпу и проводит рукой по длинным волосам. Потом снова надевает шляпу, вздыхает.
— Ави предлагает создать информационный рай, — говорит он.
По комнате проносится восхищенный гул. Ави ждет, когда он уляжется, и говорит:
— Маленькая поправка. Информационный рай создаст султан. Я предлагаю заработать на нем деньги.

УЛЬТРА

Лоуренс Притчард Уотерхауз идет в бой, вооруженный четвертушкой листа британской писчей бумаги, на которой отпечатаны некие слова, делающие ее ПРОПУСКОМ в Блетчли-парк. Фамилию, имя и некоторые другие данные вписал фиолетовой авторучкой какой-то великосветский офицер, слова ВСЕ ОТДЕЛЫ обведены, печать на них размазана в алый поцелуй уличной девки — бездумная небрежность куда более убедительна, чем кропотливая четкость подделки.
Лоуренс огибает усадьбу и выходит на узкую дорожку между основным зданием и кирпичными гаражами (его бабушка и дедушка сказали бы — конюшнями). Самое подходящее место, чтобы выкурить сигарету. Дорожка густо обсажена деревьями. Садящееся солнце еще достаточно высоко, чтобы простреливать через мелкие дефекты в оборонительном периметре горизонта, узкие красные лучи бьют Уотерхаузу в глаза, пока он расхаживает взад-вперед по дорожке. Невидимый луч в нескольких футах над головой золотит незаметную обычно антенну — медную проволоку, протянутую от усадьбы к ближайшему кипарису. Она вспыхивает в точности как паутинка, с которой Уотерхауз развлекался в день своего приезда.
Солнце скоро сядет окончательно, оно уже село в Берлине, как и на большей части адской империи, которую Гитлер выстроил на пространстве от Кале до Волги. Время радистам браться за работу. Радиоволны, как правило, не огибают углов. Это серьезная проблема, если хочешь завоевать мир, который, как назло, круглый, поэтому твои действующие армии — за горизонтом. Однако если ты используешь короткие волны, то информация отражается от ионосферы. Это работает гораздо лучше, когда солнце не забивает атмосферу широкополосным шумом. Вот почему радисты и те, кто их подслушивает (в Британии это Служба Игрек), — существа ночные.
Как заметил сейчас Уотерхауз, усадьба снабжена антенной-другой. Однако Блетчли-парк — большой и жадный паук, чтобы прокормить его, нужна паутина размером с государство. Черные провода, взбирающиеся по стенам зданий, запах и шум телетайпов свидетельствуют, что по крайней мере часть этой паутины — из медной проволоки. Другую часть составляют более грубые материалы, такие как бетон и асфальт.
Распахиваются ворота, на дорожку круто выворачивает зеленый мотоцикл, его два цилиндра трещат так, что у Лоуренса щиплет в носу. Он пропускает мотоциклиста, потом некоторое время идет следом, пока тот не исчезает из виду. Не беда, скоро появятся новые, по мере того как нервная система Вермахта проснется и Служба Игрек начнет ловить ее сигналы.
Мотоциклист проехал в ворота между двумя старыми зданиями. Над воротами небольшой купол с флюгером и часами. Уотерхауз проходит в них и оказывается на зеленом пятачке, сохранившемся, вероятно, от тех времен, когда Блетчли-парк был бесценным бекингемширским поместьем. Слева продолжается ряд конюшен. На крыше, заляпанной птичьим пометом, несколько фронтонных окон. Все здание трепещет от голубей. Прямо напротив — хорошенький тюдоровский домик красного кирпича, единственное отрадное зрелище среди всех этих архитектурных уродов. Справа от него — одноэтажное здание, из которого поступает странная информация — горяче-маслянистый дух телетайпов, хотя стука не слышно, только высокий механический гул.
Открывается дверь конюшни, выходит человек с большой, но явно легкой коробкой. Судя по воркованью, в ней голуби. Голуби, которые живут за фронтонными окнами, не дикие, а почтовые. Носители информации, нити паутины, раскинутой Блетчли-парком.
Уотерхауз направляется к зданию, от которого пахнет машинным маслом, и заглядывает в окно. Вечереет, окна начинают светиться, выдавая информацию немецким самолетам-разведчикам, поэтому во дворе суетится сторож, закрывая тяжелые ставни.
По крайней мере взгляд Уотерхауза улавливает какую-то информацию: по другую сторону окна люди собрались у машины. По большей части они в штатском, и у них давно не было времени на расчески, бритвы и крем для обуви. Эти люди сосредоточены на работе, которая как-то связана с большой машиной. Она состоит из стальных труб, как поставленная на попа кровать. На трубы кое-где надеты металлические барабаны диаметром с тарелку и толщиною примерно в дюйм. От барабана к барабану тянется бумажная лента — метров десять, не меньше.
Один из людей поправляет резиновый приводной ремень на барабане, отступает на шаг и делает знак рукой. Другой щелкает выключателем, и барабаны разом начинают вращаться. Лента скользит через систему. Пробитые в ней дырки несут данные, которые сливаются в одну серую полосу. Лента перематывается так быстро, что как будто растворяется в сером дыму.
Нет, не как будто. Из вращающихся барабанов идет самый настоящий дым. Лента тянется через машину так быстро, что вспыхивает на глазах у Лоуренса и людей в комнате, которые спокойно наблюдают за процессом, словно она горит очень необычно и интригующе.
Если в мире есть машина, способная считывать информацию с такой скоростью, то Уотерхаузу ничего о ней не известно.
Черные ставни захлопываются. В последний миг Уотерхауз успевает заметить еще один агрегат в уголке комнаты: стальную раму с ровными рядами серых цилиндров.
В темноте через двор проносятся два мотоциклиста с выключенными фарами. Уотерхауз некоторое время трусит за ними и попадает из живописного старого дворика в мир корпусов, выстроенных за последние год-два. Они чем-то напоминают здание Пентагона, возведенное Военным Министерством по ту сторону реки от Капитолия, и олицетворяют тупую потребность в пространстве, не пропущенную через какие-либо эстетические и просто человеческие соображения.
Уотерхауз доходит до перекрестка, где, как ему показалось, свернули мотоциклисты, и упирается в стену. Под влиянием порыва он взбирается на нее и усаживается. Отсюда вид не лучше. Уотерхауз знает, что вокруг, в этих корпусах, работают тысячи людей, но не видит никого из них. Указателей тоже нет.
Он по-прежнему пытается разобраться в том, что видел через окно.
Лента бежала так быстро, что задымилась. Нет смысла так гнать ленту, если машина не может считывать информацию с той же скоростью — превращать узор дырочек в электрические импульсы.
Но зачем, если эти импульсы никуда не попадут? Человеческий мозг не в силах воспринимать цепочку букв, мелькающих с такой скоростью. Ни один известный Уотерхаузу телетайп не успеет их напечатать.
Смысл есть в одном случае: если эти люди строят машину. Механический калькулятор. Способный вбирать данные и как-то их обрабатывать. Производить какие-то вычисления — вероятно, связанные со взломом кодов.
Тут Уотерхауз вспоминает ряды одинаковых серых цилиндров в углу комнаты. С торца они похожи на какие-то боеприпасы, но уж слишком гладкие и глянцевые. Уотерхауз понимает, что они выдуты из стекла.
Это вакуумные трубки. Причем их сотни. Больше вакуумных трубок, чем Уотерхауз когда-либо видел в одном месте.
Люди в комнате строят машину Тьюринга!

Коли так, неудивительно, что они спокойно смотрели на горящую ленту. Эта полоска бумаги — технологическая ровесница пирамид — всего лишь вместилище информации. Когда она проходит через машину, информация считывается и превращается в последовательность чисто двоичных данных. Прах еси и в прах возвратишься, информация же переходит из физического плана в математический, в более высокий и чистый мир, где действуют иные законы. Законы, часть которых нащупали доктор Алан Матисон Тьюринг, доктор Джон фон Нейман, доктор Рудольф фон Хакльгебер и некоторые другие, с которыми Уотерхауз общался в Принстоне. Законы, о которых сам Уотерхауз кое-что знает.
Как только вы перевели данные в царство чистой информации, вам нужен лишь инструмент. Плотник работает с деревом и носит при себе ящик — там все, чем меряют, разрезают, сглаживают, соединяют. Математик работает с информацией, ему нужен свой инструментарий.
Эти инструменты создаются, один за другим, уже не один год. Например, компания, выпускающая кассовые аппараты и пишущие машинки — «Электрикал Тилл корпорейшн», — разработала классное устройство, чтобы сводить в таблицы большое количество данных на перфокартах. Преподаватель Уотерхауза в Айове пытался решать дифференциальные уравнения по одному, потом изобрел машину, которая решала бы их автоматически, сохраняя информацию на усаженном конденсаторами барабане и пропуская ее через определенный алгоритм. Располагая достаточным количеством времени и вакуумных трубок, можно построить машину, которая суммирует колонки цифр, другую — чтобы вести каталоги, третью — чтобы расставлять слова по алфавиту. В любом уважающем себя учреждении могли бы стоять такие: чугунные, пышущие жаром махины с эмблемами таких фирм, как ЭТК, «Сименс», «Холлерит», — каждая для своей определенной задачи. В точности как у плотника есть стусло, шиповочная пила и молоток-гвоздодер.
Тьюринг придумал нечто иное, принципиально новое.
Он сказал, что математикам в отличие от плотников нужен только один инструмент. Тьюринг понял, что можно построить метамашину, способную в разных конфигурациях решать любые мыслимые задачи в области информации. Устройство-Протей, способное превращаться в любое устройство, какое только может тебе понадобиться. Как орган, который становится новым инструментом, стоит установить новую комбинацию регистров.
Подробности пока туманны. Это не чертеж настоящей машины, скорее мысленный эксперимент, который Тьюринг поставил, чтобы разрешить абстрактную головоломку из совершенно непрактичного мира чистой логики. Уотерхаузу это прекрасно известно. Однако, сидя на противоударной стене в темном перекрестке Блетчли-парка, он не может избавиться от одной мысли: в машине Тьюринга, если бы она существовала, обязательно использовалась бы лента. Она проходила бы через машину. Несла бы информацию, нужную машине для работы.
Уотерхауз смотрит в темноту и мысленно выстраивает машину Тьюринга. В памяти всплывают другие детали. Лента, как он теперь вспомнил, шла бы через машину Тьюринга не в одном направлении, а скользила туда-сюда. И машина Тьюринга не просто читала бы ленту, она бы стирала метки и добавляла новые. Дырки в бумажной ленте явно не сотрешь. А лента в той машине за окном явно двигалась в одну сторону. Как ни горько Уотерхаузу признавать, рама с трубками, которую он сейчас видел, — не машина Тьюринга. Это что-то попроще, инструмент узкого назначения, как перфосчитыватель Холлерита или барабан Атанасова.
И все же она больше, диковиннее, страшнее, чем все, что Уотерхауз до сих пор видел.
Мимо с ревом проносится ночной поезд из Бирмингема — везет к морю патроны. Как раз когда его грохот затихает вдали, к воротам подъезжает мотоциклист. На то время, пока проверяют документы, мотор смолкает, потом тарахтенье слышится в аллее. Уотерхауз встает на стену и внимательно смотрит, как мотоциклист проносится мимо, к корпусу в паре кварталов от перекрестка. В открытую дверь бьет свет, груз переходит из рук в руки. Дверь закрывается, мотоцикл с треском несется обратно к воротам.
Уотерхауз слезает со стены и в темноте (ночь безлунная) бредет к корпусу. Останавливается перед входом, прислушивается. Потом собирается с духом и толкает деревянную дверь.
Здесь жарко, как в душегубке, окна наглухо закрыты ставнями, машинные запахи мешаются с испарениями человеческих тел. Людей много, в основном женщины за исполинскими пишущими машинками. В приоткрытую дверь Уотерхауз видит, что это помещение — шлюз для бумажных листков, примерно три на четыре дюйма, доставляемых, надо думать, мотоциклистами. У входа их сортируют и складывают в проволочные корзины, потом относят девушкам за исполинскими машинами.
Один из немногих мужчин встает и направляется к Уотерхаузу. Он примерно одних с Лоуренсом лет, чуть за двадцать. На нем форма британской армии. Он держится как распорядитель на свадьбе, который следит, чтобы даже никому не ведомых родственников из других городов встретили честь по чести. Очевидно, военный из него такой же, как из Уотерхауза. Неудивительно, что вокруг столько колючей проволоки и автоматчиков.
— Добрый вечер, сэр. Чем могу служить?
— Добрый вечер. Лоуренс Уотерхауз.
— Гарри Паккард. Рад знакомству. — Он не знает, кто такой Уотерхауз, потому что допущен к «Ультра», а не к «Ультра-Мега».
— Я тоже. Полагаю, вы захотите взглянуть на это. — Уотерхауз протягивает волшебный пропуск.
Паккард внимательно изучает листок, потом фокусируется на особо интересных частностях: подписи в углу, смазанной печати. Война превратила Гарри Паккарда в машину для считывания и обработки бумаг; он выполняет свою обязанность несуетно и спокойно. Потом просит извинить, набирает телефонный номер, с кем-то говорит — судя по выражению лица и позе, с кем-то важным. Уотерхауз не слышит слов за стуком и гудением пишущих машин, но видит удивление и даже растерянность на юношески-открытом, розовом лице Паккарда. Слушая, тот раз или два искоса глядит на Уотерхауза. Потом произносит что-то вежливо-успокоительное и вешает трубку.
— Ладно. Так что вы хотели увидеть?
— Я пытаюсь выяснить в целом, как течет информация.
— Что ж, в таком случае здесь вы в самом начале — в верховьях. Наши истоки — Служба Игрек: военные радиоперехватчики и радисты-любители, которые слушают немцев и поставляют нам это. — Паккард берет из мотоциклетного контейнера листок бумаги и протягивает Уотерхаузу.
Это бланк с прямоугольными рамками наверху. В них вписаны дата (сегодняшняя) и время (два часа назад), а также некоторые другие сведения вроде радиочастоты. Большую часть бланка занимает пустое пространство, на котором торопливыми печатными буквами накарябано:

YWBP ROJHK DHAOB QTMDL TUSHI
PIJS LLENJ OPSKY VZPDL EMAOU
AMOG ТМОАН ЕС

а перед всем этим две группы по три буквы.

YUН АВG

— Это с нашей станции в Кенте, — объясняет Паккард. — Сообщение «Зяблик».
— То есть... от Роммеля?
— Да. Перехват из Каира. «Зяблик» имеет первоочередную срочность, поэтому сообщение лежит наверху.
Паккард ведет Уотерхауза по центральному проходу, между рядами машинисток. Одна девушка только что освободилась, Паккард протягивает ей листок. Девушка кладет бумагу рядом с машинкой и начинает печатать.
Поначалу Уотерхауз решил, что все эти агрегаты воплощают британские представления о том, как надо делать электрические пишущие машинки — размером с обеденный стол, двухсотфунтовая чугунная махина с мотором десять лошадиных сил, за высокими заборами с автоматчиками. Теперь он видит, что это нечто куда более сложное. Вместо валика здесь большая шпулька, на которую намотана бумажная лента — yже, чем та, которая бежала через машину за окном, и без дырочек. Всякий раз, как девушка нажимает клавишу, копируя напечатанную на листе букву, на ленте появляется новая. Но не та, которая стояла на листке.
Буквы на ленте гласят:

EINUNDZWANZIGSTPANZERDIVISIONBERICHTET
KEINEBESONDEREEREIGNISSE*

[ДВАДЦАТЬПЕРВАЯТАНКОВАЯДИВИЗИЯСООБЩАЕТ
ОСОБЫХСОБЫТИЙНЕТ (нем.).]

— Чтобы получить эти установки, вы должны взламывать код, который меняется каждый день?
Паккард улыбается.
— В полночь. Если задержитесь здесь... — он смотрит на часы, — еще на четыре часа, то увидите, как от Службы Игрек начнут поступать новые сообщения, которые на выходе из Тайпекса дадут полную белиберду, потому что фрицы меняют все свои шифры с двенадцатым ударом часов. Вроде как карета Золушки, которая превращалась в тыкву. Тогда мы анализируем новые перехваты с помощью «Бомб» и определяем новый шифр дня.
— Сколько времени это занимает?
— Если повезет, мы взламываем шифр к двум-трем утра. Чаще после обеда или вечером. Иногда не взламываем совсем.
— Глупый вопрос, но я хотел бы выяснить до конца. Эти Тайпексы, которые выполняют механическую дешифровку, — совершенно не то, что «Бомбы», которые на самом деле взламывают код?
— «Бомбы» по сравнению с Тайпексами — принципиально иной, невероятный уровень сложности, — подтверждает Паккард. — Почти что думающие машины.
— Где они стоят?
— В одиннадцатом корпусе. Но сейчас они не работают.
— Понятно, — говорит Уотерхауз. — До полуночи, пока карета не превратится в тыкву и вам не потребуется взломать завтрашние установки «Энигмы».
— Да.
Паккард подходит к маленькой деревянной дверце в одной из стен корпуса. Рядом с ней — серый офисный лоток с привинченными по краям петлями, в которые продета веревка. Другая веревка висит из закрытой дверцы. Паккард кладет новую расшифровку на груду уже скопившихся на лотке и открывает дверцу. За ней — черный туннель, ведущий из здания.
— Готово, тяни! — кричит он.
— Тяну! — через мгновение отзывается голос. Веревка натягивается, лоток исчезает в туннеле.
— Отправился в тройку, — объясняет Паккард.
— Значит, мне туда же, — говорит Уотерхауз.

Третий корпус всего в нескольких ярдах, за обязательной противоударной стеной. «ОТДЕЛ НЕМЕЦКОЙ АРМИИ» — написано на двери, в отличие от «ФЛОТА», который в четверке. Пропорция мужчин к женщинам здесь значительно выше. В военное время странно видеть в одном помещении столько здоровых, крепких мужчин. Некоторые в форме наземных или воздушных сил, некоторые в штатском, есть даже один флотский офицер.
Середину помещения занимает большой стол в форме подковы, у стены другой, прямоугольный. Все стулья заняты, все, сидящие за столами, погружены в работу. Дешифровки поступают в корпус на лотке и передаются от стула к стулу по некой сложной схеме, которую Уотерхауз может понять только в общих чертах. Кто-то объясняет ему, что «Бомбы» взломали сегодняшний код только в конце дня, и все расшифровки из шестого корпуса поступили в последние два часа.
Уотерхауз решает пока считать этот корпус математическим черным ящиком — сосредоточиться только на информации, которая поступает сюда и отсюда, не вникая во внутреннее устройство. Блетчли-парк в целом тоже своего рода черный ящик — в него поступают случайные буквы, из него — стратегические разведданные, и большинству получателей «Ультра» безразлично его внутреннее устройство. Уотерхауз здесь, чтобы выяснить, существует ли еще один вектор информации, направленный отсюда, скрытый в сигналах телетайпа и поступках союзного командования. И не указывает ли этот вектор па Рудольфа фон Хакльгебера?

КИНАКУТА

Кто бы ни прокладывал воздушный маршрут на подлете к новому аэропорту султана, он явно в сговоре с Кинакутской Торговой палатой. Если вам, как Рэнди Уотерхаузу, посчастливится сидеть у иллюминатора левого борта, вид из самолета будет похож на рекламный буклет.
Густо-зеленые склоны Кинакуты встают из почти неподвижной синевы и тут же взмывают ввысь: горные вершины присыпаны снегом, хотя остров всего в семи градусах от экватора. Сразу понятно, что имел в виду Ави, когда говорил о мусульманском населении по краям и анимистах в центре. Что-то похожее на современный город можно построить только в равнинной части, которая охватывает остров непрерывной, почти плоской полосой — бежевая оправа исполинского изумруда. Она шире всего на северо-восточном краю острова, где широкая пойма главной реки переходит в аллювиальную дельту, на милю-две вдающуюся в море Сулу.
Рэнди перестает считать нефтяные вышки за десять минут до того, как в иллюминаторе показывается город Кинакута. Сверху они похожи на горящие надолбы, сброшенные в прибойную полосу, чтобы остановить морскую пехоту. Самолет снижается; теперь это скорее фабрики на сваях, увенчанные трубами, в которых сжигают попутный газ. Возникает жутковатое чувство, что пилот летит между огненными столбами, способными зажарить «Боинг-777», как голубя, на лету.
Город Кинакута куда более современный, чем все, что можно увидеть в Америке. Рэнди пытался о нем читать, но нашел совсем мало: пару заметок в энциклопедии, несколько мимолетных упоминаний в связи со Второй мировой войной, злые, хотя в целом хвалебные статьи в «Экономист». Пустив в ход изрядно подзабытые навыки межбиблиотечного абонемента, он раскопал в Библиотеке Конгресса единственную книгу, полностью посвященную Кинакуте, и заказал ксерокопию. Это воспоминания очевидца, которых столько появилось после войны, ни разу не переизданные. Читать пока было некогда, и пятисантиметровая стопка страниц мертвым грузом лежит в сумке.
Ни одна из виденных им карт не дает представления о современном городе Кинакута. Все, что было тут во время войны, снесли. Реку направили в новое русло. Гору под названием Пик Элиза срыли, а обломки сгребли бульдозерами в океан, так что получилось несколько квадратных миль суши, большую часть которых занял аэропорт. Взрывы были такими громкими, что вызвали протест со стороны правительств Филиппин и Малайзии, в сотнях миль от Кинакуты. «Гринпис» возмущался, что султан распугивает китов в центральной части Тихого океана. Рэнди ожидал увидеть на месте Кинакуты дымящуюся воронку, но ничего подобного. Остатки Пика Элиза аккуратно замостили и по приказу султана воздвигли на нем Техноград. У тамошних стеклянных небоскребов, как и у остальных в городе, — островерхие крыши. Такими были традиционные здания, которые давно снесены и пошли на строительство насыпи. Единственное архитектурное сооружение, которому на вид больше десяти лет, — дворец султана, но он по-настоящему древний. В окружении голубых стеклянных небоскребов он смотрится вмерзшей в лед красновато-бежевой мошкой.
Как только Рэнди видит дворец, все встает на свои места. Он наклоняется и с риском схлопотать замечание от стюардессы вытаскивает из-под кресла ксерокопию. На первой странице — карта Кинакуты тысяча девятьсот сорок пятого года, дворец султана — точно посередине. Рэнди начинает крутить карту, как запаниковавший водитель — баранку автомобиля. Вот река. Вот Пик Элиза, где у японцев были локаторы и подразделение радиоразведки. Вот бывшее взлетное поле японских Вспомогательных Воздушных Сил Флота. До последнего времени здесь располагался Кинакутский аэродром. Теперь это стайка желтых кранов над синей туманностью железных конструкций, освещенной изнутри белыми созвездиями сварки.
И вдруг что-то совсем из другого мира — клочок изумрудной зелени длиной в пару городских кварталов, обнесенный каменной стеной. У одного края тихий прудик (самолет летит так низко, что Рэнди может сосчитать кувшинки), крохотный синтоистский храм черного камня, бамбуковый чайный домик. Рэнди прижимается носом к стеклу и поворачивает голову, пока изумрудный пятачок не скрывается за высотным домом прямо под крылом самолета. На микросекунду он видит, как в отрытом окне кухни стройная женщина заносит над кокосовым орехом топорик.
Садику место на тысячу миль севернее, в Японии. Когда до Рэнди доходит, что это такое, волосы у него на загривке встают дыбом.
Он сел в самолет два часа назад, в Международном аэропорту Ниной Акино. Рейс задержали, у него было достаточно времени, чтобы рассмотреть попутчиков: трех белых, включая самого Рэнди, и два десятка малайцев (из Кинакуты или с Филиппин). Все остальные пассажиры — японцы. Некоторые, судя по виду, бизнесмены, но большинство — организованная тургруппа, которая прошла в посадочный зал ровно за сорок пять минут до назначенного времени отлета и выстроилась позади девушки с табличкой в руке. Пенсионеры.
Их цель — не Техноград, и не какой-то определенный островерхий небоскреб в деловой части города. Они направляются в японский садик за стеной, разбитый над братской могилой в том месте, где 23 августа 1945 года приняли смерть три с половиной тысячи японских солдат.

ЙГЛМСКИЙ ДВОРЕЦ

Уотерхауз стройными колоннами движется по тихому проулку, щурясь, читает бронзовые таблички на белых каменных домиках:

ОБЩЕСТВО УНИФИКАЦИИ ИСЛАМА И ИНДУИЗМА
АНГЛО-САМОЕДСКИЙ СОЮЗ
ОБЩЕСТВО ДРУЖБЫ «ЧАН ЦЗЕ»
КОРОЛЕВСКИЙ КОМИТЕТ ПО БОРЬБЕ С ИЗНОСОМ МОРСКИХ КРИВОШИПОВ
АНТИВАЛЛИЙСКАЯ ЛИГА
БОЛДЖЕРОВСКАЯ АССОЦИАЦИЯ ПО РАСПРОСТРАНЕНИЮ СТРЕКОЗ-СТРЕЛОК
АБ'ИДИНЕНИЕ ЗА РИФОРМУ АНГЛИЙСКАВА ПРАВАПИСАНИЯ
ОБЩЕСТВО ЗАЩИТЫ ГЛИСТОВ
ЦЕРКОВЬ ВЕДАНТИЧЕСКОГО ЭТИКО-КВАНТОВОГО СОЗНАНИЯ
ИМПЕРСКАЯ СЛЮДЯНАЯ КОЛЛЕГИЯ

Поначалу он принимает Йглмский дворец за сельскую промтоварную лавку. Над тротуаром, как боевой таран триремы, нависает эркер, в нем выставлены: безголовый женский манекен в чем-то, связанном, по-видимому, из пряденой стали (дань аскетизму военного времени?), кучка серой грязи с воткнутой в нее лопатой и еще один манекен (относительно новый, втиснутый в самый угол) в форме британского военно-морского флота, с фанерным контуром винтовки в руках.
Неделю назад Уотерхауз нашел в книжной лавке возле Британского музея источенный червями экземпляр «Большой Йглмской Энциклопедии», с тех пор таскает его в портфеле и впитывает по странице-две, как сильнодействующее лекарство. Главенствующих тем — три, они выпирают из каждого абзаца, как Три Схры — из Внешнего Йглма. Две из них — шерсть и гуано, хотя на древнем самобытном йглмском языке они зовутся иначе. Тут имеет место та самая лингвистическая гиперспециализация, которая, как уверяют, есть у эскимосов для снега, у арабов — для песка. «Большая Йглмская Энциклопедия» никогда не использует английские слова «шерсть» и «гуано», кроме как в уничижительном смысле, для грубых подделок, экспортируемых всякими там шотландиями в наглой попытке сбить с толку наивного покупателя. Уотерхаузу пришлось прочесть энциклопедию почти от корки до корки и применить все свои дешифраторские навыки, чтобы методом сопоставления понять, о чем речь.
Теперь он столько о них знает, что поневоле любуется как гордо выставлены напоказ в сердце космополитического рода кучка гуано и женщина в шерстяной одежде*. [Он решил использовать английские слова, чтобы не выставлять себя на посмешище, пытаясь произнести йглмские.] Наряд на женщине беспросветно серый, в полном соответствии с йглмской традицией, считающей краски для шерсти порочным шотландским новшеством. Верхняя часть ансамбля — свитер, по виду — валяный. При ближайшем рассмотрении становится ясно, что он связан, как любой другой свитер. Йглмские овцы вывелись путем тысячелетнего массового вымирания в условиях сурового климата. Их шерсть славится густотой, штопорообразным волокном и полной устойчивостью к любому процессу химического распрямления. В изделиях она напоминает войлок, что энциклопедия считает главным ее достоинством, для описания которого существует целый обширный словарь.
На третью тему «Большой Йглмской Энциклопедии» намекает второй манекен в витрине.
К каменной кладке у входа прислонен старикашка в форме добровольных сил местной самообороны. Наряд включает в себя короткие штанишки и толстенные гольфы из определенной разновидности йглмской шерсти, подвязанные под коленями толстой шнуровкой с переплетением на кельтский манер. (Почти на каждой странице энциклопедия повторяет, что йглмиане — не кельты, но изобрели все лучшее, что есть в кельтской культуре.) Такие подвязки — непременный атрибут йглмианина; мужчины носят их под брюками. Обычно на их изготовление идут длинные, тонкие хвосты скрргов, наиболее многочисленных представителей местной фауны. Энциклопедия сообщает, что «С. — мелкие млекопитающие отряда грызунов, семейства мышиных, которые широко распространены на островах. Питаются по преимуществу яйцами морских птиц и способны очень быстро размножаться при наличии этой или другой пищи. Йглмиане восхищаются мужественными зверьками и берут за образец их упорство и жизнестойкость».
Уотерхауз несколько минут курит и разглядывает подвязки. Внезапно манекен шевелится. Уотерхауз думает, что он кренится от налетевшего ветра, но тут понимает, что старичок живой и вовсе не падает, а переступает с ноги на ногу.
Дедуля замечает Уотерхауза, мрачно улыбается и произносит несколько слов на своем языке, который, как уже ясно, еще менее английского приспособлен для передачи стандартным алфавитом.
— Хэлло, — говорит Уотерхауз.
Дедок произносит что-то еще более длинное и сложное. Уотерхауз (сейчас он в своей стихии; мозг извлекает смысл из случайного набора звуков, пользуясь избыточностью сигнала) понимает, что дедуля говорит на английском с сильным местным акцентом, и заданный вопрос звучит: «Из какой части Америки вы приехали?»
— Моя семья много переезжала, — говорит Уотерхауз. — Скажем, из Северной Дакоты.
— А-а, — неопределенно отвечает дедок и плечом наваливается на дверь. Через некоторое время та начинает двигаться, кованые петли зловеще скрипят, поворачиваясь в дюймовых отверстиях. Наконец дверь натыкается на некую непреодолимую преграду. Дедуля по-прежнему удерживает ее всем телом, наклонясь под сорок пять градусов к горизонту. Уотерхауз быстро заскакивает внутрь. Крохотную прихожую украшает скульптурная композиция: две нимфетки колошматят убегающую каргу. Внизу табличка: «Выносливость и Жизнестойкость прогоняют Нужду».
Операция повторяется несколько раз. Каждая следующая дверь легче, но богаче украшена. Как выясняется, первая прихожая была на самом деле четвертой с конца, и проходит немало времени, прежде чем им удается и впрямь проникнуть внутрь Йглмского дворца. К этому времени они настолько углубляются в здание, что Уотерхауз уже почти готов увидеть проезжающий мимо поезд метро. Вместо этого он оказывается в обшитой деревом комнате без окон; хрустальная люстра светит мучительно-ярко, однако ничего толком не освещает. Ноги глубоко уходят в ворсистый ковер. Дальние рубежи комнаты защищены массивным столом, за которым восседает дородная дама. Расставленные там и сям виндзорские стулья черного дерева, несмотря на свою хлипкость, кажутся опасными туземными капканами.
На стенах — масляные полотна. С первого взгляда Уотерхауз разделяет их на те, у которых высота больше длины, и остальные. Высокие картины — это портреты джентльменов, страдающих, судя по всему, тяжелым генетическим дефектом, влекущим изменение формы черепа. Широкие — пейзажи или, не менее часто, марины, все сплошь угрюмые и бесприютные. Йглмские живописцы так любят местную сине-зеленовато-серую краску* [Получаемую, согласно БЙЭ, из лишайника.], что накладывают ее лопатой.
Уотерхауз пробивается по зыбучему ворсу ковра к столу. Дама пожимает ему руку и собирает лицо в легкий намек на улыбку. Следует долгий обмен любезностями, из которого Уотерхауз запоминает только: «Лорд Уайдаболот скоро вас примет» и «Чаю?»
На вопрос про чай Уотерхауз отвечает «Да», поскольку ему кажется, что дама (чью фамилию он забыл) не вполне отрабатывает свой хлеб. Она с явным неудовольствием отрывается от стула и пропадает в более глубоких и узких частях здания. Дедуля уже вернулся на свой пост возле двери.
На стене за столом висит фотография короля. Уотерхауз не знал (пока полковник Чаттан осторожно ему не напомнил), что полный титул Его Величества не просто Милостью Божьей король Англии, но М. Б. король Соединенного королевства Великобритании, Северной Ирландии, острова Мэн, Гернси, Джерси, Внешнего и Внутреннего Йглма.
Рядом — фотография поменьше, человека, с которым ему сейчас предстоит встретиться. Энциклопедия, изданная несколько десятилетий назад, лишь вкратце говорит о нем и его семье, так что Уотерхаузу пришлось проделать дополнительные изыскания. Человек на фотографии связан с Виндзорами невероятно запутанным родством, описать которое можно лишь с помощью расширенного набора генеалогических терминов.
Он родился графом Генрихом-Карлом-Вильгельмом-Отто-Фридрихом фон Юберзецензихафенштадтом, но в 1914 году изменил свое имя на Найджел Сент-Джон Глумторпби, лорд Уайдаболот. На фотографии он выглядит до последнего дюйма фон Юберзецензихафенштадтом и абсолютно не затронут черепным дефектом более ранних портретов. Лорд Уайдаболот не связан родством с первоначальными герцогами Йглма, семьей Мур (англизированное название йглмского клана Мнихррг). Этот род пресекся в 1888 году в результате совершенно невероятной комбинации шистосомоза, самоубийств, ран, полученных на Крымской войне, шаровых молний, дефектных пушек, падений с лошади, неправильно законсервированных устриц и внезапных шквалов.
Чай все не приносят, лорд Уайдаболот тоже не слишком торопится разгромить фашистов, поэтому Уотерхауз обходит комнату, делая вид, что интересуется картинами. На самой большой побитые-порубленные римляне несолоно хлебавши выбираются на негостеприимный скалистый берег, а море швыряет им вслед останки разбитых кораблей. На переднем плане — римлянин, не утративший благородства, несмотря на полученную головомойку. Он устало сидит на высоком камне, держа ослабелой рукой сломанный меч, взгляд его устремлен за бурный пролив на сияющий райский остров. Остров густо покрыт высокими деревьями, цветущими лугами и зелеными пастбищами, тем не менее по Трем Схрам в нем угадывается Внешний Йглм. Склоны венчают грозные замки; на светлом, почти карибском берегу реют пестрые знамена защитников, которые (надо полагать) только что хорошенько всыпали римлянам. Уотерхауз не утруждается взглянуть на табличку, он и так знает сюжет: неудачная и, вероятно, апокрифическая попытка Юлия Цезаря распространить власть Рима на Йглмский архипелаг, самая дальняя в географическом смысле и самая опрометчивая из его затей. Сказать, что йглмцы не забыли этого эпизода — все равно что назвать немцев малость обидчивыми.
— Где Цезарь не прошел, чего искать Гитлеру?
Уотерхауз оборачивается на голос и видит невысокого роста Найджела Сент-Джона Глумторпби, лорда Уайдаболота, герцога Йглмского. Уотерхауз вприпрыжку одолевает ковер, чтобы пожать ему руку. Хотя полковник Чаттан и объяснил, как обращаться к герцогу, Уотерхауз сейчас так же не в силах вспомнить все эти светлости и милости, как и воспроизвести на память график герцогского родства. Он решает строить фразы таким образом, чтобы не обращаться по имени и не употреблять местоимений. Это будет занятная игра. Поможет убить время.
— Грандиозная картина, — говорит Уотерхауз. — Впечатляет.
— Вы найдете сами острова не менее замечательными и по той же самой причине, — уклончиво молвит герцог.
Следующий раз Уотерхауз возвращается к действительности уже у герцога в кабинете. Видимо, по дороге происходит рутинный обмен любезностями, но такие вещи не обязательно пропускать через мозг. Предлагают чай. Уотерхауз во второй или третий раз говорит «да», но чай так и не материализуется.
— Полковник Чаттан в Средиземном море, — объясняет Уотерхауз, — и меня прислали вместо него, чтобы я, не теряя времени на обсуждение технических деталей, выразил признательность за щедрое предложение разместиться в замке.
Вот! Ни одного местоимения, ни одной оплошности.
— Не стоит благодарности! — Герцог воспринимает эти слова как оскорбление своему великодушию. Он говорит неторопливым, важным распевом, как человек, который мысленно листает немецко-английский словарь. — Даже не касаясь... моего собственного... патриотического долга... это уже почти... жутко модно... отдавать бравым ребятам... свою буфетную.
— Многие знатные британские семьи внесли вклад в победу над врагом, — соглашается Уотерхауз.
— Располагайтесь... на здоровье! — говорит герцог. — Чувствуйте себя... как дома! Без всякого... стеснения! Устраивайте там... что вам надо! Замок выдержал... тысячи йглмских зим, выдержит... и вас.
— Мы надеемся очень скоро разместить там небольшое подразделение, — любезно сообщает Уотерхауз.
— Можно ли... узнать... чтобы удовлетворить мое собственное... любопытство... какого рода? — Герцог недоговаривает фразу.
Уотерхауз готов к вопросу — готов настолько, что даже делает небольшую паузу, якобы размышляя, можно ли это сказать.
— Вэ-Че-Эр-Пе.
— Простите?
— ВЧРП. Высокочастотная радиопеленгация. Метод, позволяющий засечь удаленную радиостанцию при помощи триангуляции с нескольких точек.
— Я думал... что вам известно... где расположены... все немецкие радиостанции...
— Да, за исключением движущихся.
— Движущихся?! — Герцог сильно морщит лоб, воображая исполинскую станцию — здание, башню и все прочее, — нагруженную на четыре железнодорожных платформы, как Большая Берта, и влекомую по степи украинскими бурлаками.
— Вспомните про подводные лодки, — деликатно говорит Уотерхауз.
— А! — восклицает герцог. — А! — Он откидывается в скрипучем кожаном кресле и мысленно представляет совершенно новую картину. — Они... всплывают и посылают... радиограммы, верно?
— Да.
— А вы... перехватываете и читаете?
— Если бы так! — вздыхает Уотерхауз. — Увы, немцы направили весь свой прославленный математический гений на создание абсолютно невскрываемых шифров. Мы не знаем, что они передают. Однако при помощи радиопеленгации мы можем узнать, откуда они ведут передачу и соответственно проложить курс наших конвоев.
— А.
— Так что мы предполагаем установить на крыше замка большие вращающиеся антенны и разместить там специалистов по радиопеленгации.
Герцог хмурится.
— Предусмотрена ли... надежная защита... от молний?
— Естественно.
— Вы в курсе... что уже в августе... можно ожидать... пургу?
— Сообщения Королевской Йглмской метеостанции дают вполне ясную картину.
— Вот и отлично! — восклицает герцог, расчувствовавшись. — Располагайтесь! И задайте им... перцу!

«ЭЛЕКТРИКАЛ ТИЛЛ КОРПОРЕЙШН»

Судя по всему, союзники намерены уничтожить страны Оси, раздавив их грудой промышленных товаров. Подтверждение этому — пирс в Сиднее, на котором громоздятся ящики и стальные бочки, доставленные морем из Америки, Британии, Индии и гниющие здесь, потому что Австралия еще не придумала, как их переварить. Это не единственный пирс в Сиднейском порту, заставленный до отказа. Однако, поскольку именно он ни на что другое не годен, штабеля здесь громоздятся выше, а сами они старше, ржавее, сильнее изъедены крысами, гуще покрыты коркой морской соли и чаячьего помета.
Между штабелями идет человек, стараясь не перепачкаться в птичьем дерьме. Он в форме майора американской армии, с тяжелым портфелем в руке. Его фамилия Комсток.
В портфеле различные удостоверения личности, документы и письмо из штаба генерала Макартура в Брисбене. Все вышеперечисленное Комстоку пришлось показывать австралийским часовым. Часовые, с винтовками и в пробковых шлемах, попадаются на каждом шагу и, несмотря на дряхлые лета, производят странно внушительное впечатление. Они не понимают ни одного из знакомых майору диалектов английского языка, он не понимает их, но все они могут прочесть то, что написано в бумагах.
Садится солнце, и просыпаются крысы. Майор провел в доках весь день. Он уже насмотрелся на войну и вояк, поэтому знает, что нужное окажется на последнем пирсе, то есть как раз на этом. Если бы он начал с этого конца, оно оказалось бы на противоположном, и наоборот. Тем больше оснований быть внимательным. Оглядевшись по сторонам и убедившись, что рядом нет текущих бочек с авиационным топливом, он закуривает. Война — это ад, сигареты чуть скрашивают существование.
Сиднейский залив дивно хорош на закате, но Комсток смотрел на него весь день и больше смотреть не может. За отсутствием другого дела он открывает портфель. Там прочитанный роман в бумажной обложке. Еще там папка с пожелтевшими, ломкими осадочными слоями ископаемой летописи, разобрать которую в силах лишь археолог. Это история о том, как Генерал, оставив Коррехидор и добравшись до Австралии в апреле, заказал некое оборудование, как заявку переслали в Америку и долго футболили по бесконечным коридорам военной и штатской бюрократии; как требуемое оборудование изготовили, отгрузили, доставили на корабль; и наконец, некоторые свидетельства тому, что упомянутое судно было в Сиднее семь месяцев назад. Подтверждений, что искомое оборудование с корабля выгрузили, не обнаружилось, но корабли в портах, как правило, разгружаются, и Комсток пока исходит из допущения, что так было и в данном случае.
Докурив сигарету, майор Комсток возобновляет поиски. На некоторых бумагах в папке указаны магические цифры, которыми должны быть помечены нужные ящики; по крайней мере с таким допущением он утром взялся за поиски. Если это не так, то придется начинать сначала и проверять каждый ящик в Сиднейском порту. Для того чтобы прочесть маркировку на ящиках, надо протискиваться в узкую щель между штабелями и счищать с досок въевшуюся грязь. Майор уже перемазался не хуже морпеха на передовой.
Добравшись до конца пирса, он замечает штабель из ящиков одной давности, судя по тому, что соляная корка на них одинаково толстая. Под ними лужи дождевой воды, грубо обструганные доски сгнили. Сверху они покоробились и разошлись от солнца. Где-то на ящиках должны быть номера, но взгляд Комстока цепляет другое. Сердце у него прыгает, как у осажденного пехотинца, увидевшего звездно-полосатый флаг на ветру. Ящики помечены гордыми инициалами компании, в которой Комсток (как и большинство его товарищей по оружию в Брисбене) работал, пока их всех скопом не забрили в армейскую радиоразведку. Буквы выцвели, но он узнал бы их где угодно. Они составляют эмблему, символ, визитную карточку «ЭТК» — «Электрикал Тилл корпорейшн».

КРИПТА

Аэропорт стилизован под составленные в ряд малайские общественные дома. Свежепокрашенный телетрап вытягивается, как исполинская минога, и присасывается неопреновым ртом к борту самолета. Пожилые японские туристы не трогаются с мест, оставляя проход бизнесменам и словно говоря: «Идите вперед, те, кого мы тут навещаем, никуда не торопятся».

Предыдущая страница 10 Следующая страница


11 Нил Стивенсон

Пока Рэнди идет по трапу, влага из воздуха и конденсат реактивного топлива в равных пропорциях оседают на его коже. Лицо потеет. По счастью, аэропорт, несмотря на внешнее сходство с малайскими бунгало, внутри не уступает самым современным аэропортам мира. Кондиционированный воздух шибает в голову. Рэнди ставит сумки на пол и минуту стоит, собираясь с мыслями, под исполинской картиной кисти Лероя Неймана* [Нейман, Лерой, самый знаменитый ныне живущий американский живописец, официальный художник пяти Олимпиад. Пишет в яркой, на грани кича, экспрессионистской манере. Среди его работ — портреты спортсменов, эстрадных знаменитостей, президентов.], изображающей султана во время игры в конное поло. Зажатый возле иллюминатора в коротком и тряском полете, он так и не сходил в туалет, поэтому теперь направляется прямо туда и журчит с такой силой, что из писсуара доносятся тирольские переливы.
Рэнди, абсолютно счастливый, делает шаг назад и замечает человека, отступающего от соседнего писсуара. Это японский бизнесмен, летевший в одном с ним самолете. Месяца два назад Рэнди вообще не смог бы помочиться в его присутствии, а сейчас просто не заметил, что кто-то рядом есть. Для Рэнди всегда было страшной проблемой пописать при посторонних, но недавно он отыскал чудодейственное средство: не воображать себя доминирующей особью, а просто уйти в свои мысли настолько, чтобы не замечать окружающих. Если ты не можешь отлить при чужих, значит, ты чересчур озабочен тем, как занять достойное место в жизни.
— Высматривали строительный участок Министерства информации? — спрашивает бизнесмен. Ему носить темно-серый в мелкую полоску костюм так же естественно, как Рэнди — футболку с пятой конференции хакеров и шорты.
— Ой! — выпаливает Рэнди, злясь на себя. — Совсем забыл, что надо его высматривать.
Оба смеются. Японец виртуозным движением извлекает визитную карточку. Рэнди, чтобы достать свою, приходится лезть в бумажник. Они меняются карточками, как принято в Азии — двумя руками одновременно. Ави заставлял Рэнди отрабатывать этот трюк, пока у того не стало получаться почти правильно. Оба кланяются, отчего в соседних компьютеризированных писсуарах автоматически с грохотом сливается года. Открывается дверь, входит престарелый нип во главе сребровласого полчища.
Отставной американский сержант Шон Дэниел Макги в своих военных воспоминаниях, фотокопию которых Рэнди таскает в сумке, называет японцев нипами. Это грубая расистская кличка. С другой стороны, все зовут американцев — янки. Назвать японца нипом — то же самое? Или это все равно что назвать китайца китаезой? В многочасовых переговорах, в мегабайтах электронной почты, все без исключения — Рэнди, Ави, Джон Кантрелл, Том Говард, Эберхард Фёр и Берил — время от времени сокращали «японец» до «яп» — точно так же, как они говорят «операционка» вместе «операционная система». Но, разумеется, яп — тоже отвратительная расистская кличка. Наверное, все дело в том, с каким чувством ты это произносишь. Если просто хочешь сказать короче — не кличка. А вот если в тебе клокочет расовая ненависть, чем временами грешит Шон Дэниел Макги, то все совсем иначе.
Данного конкретного японца, согласно карточке, зовут ГОТО Фурудененду («Фердинанд Гото»). Рэнди в последнее время немало бился над организационными схемами некоторых крупных японских компаний и уже знает, что новый знакомый носит загадочный титул вице-президента по особым проектам в «Гото инжиниринг». Еще Рэнди усвоил, что организационные схемы крупных японских компаний — полная туфта, и должность может не значить решительно ничего. Вероятно, куда примечательнее фамилия — та же, что у основателя фирмы.
Карточка Рэнди представляет его как Рэндалла Л. УОТЕРХАУЗА («Рэнди»), вице-президента по развитию сетевых технологий корпорации «Эпифит».
Гото с Уотерхаузом выходят из уборной и идут по пиктограммам с изображением багажа, которые тянутся через весь аэропорт, как хлебные крошки.
— У вас сейчас другое время? — бодро спрашивает Гото, следуя (как предполагает Рэнди) тексту английского учебника. У него приятная внешность и обезоруживающая улыбка. С виду ему за сорок; впрочем, японцы старятся по совершенно иному алгоритму, так что кто его знает.
— Нет, — говорит Рэнди. Как всякий программист, он отвечает на такие вопросы неудачно — коротко и правдиво. Разумеется, Гото на самом деле безразлично, какое у него время. Ави, будь он здесь, использовал бы вопрос по назначению — как начало ни к чему не обязывающей болтовни. До тридцати Рэнди страдал из-за своей неловкости, теперь ему плевать. Очень может быть, скоро он станет ею гордиться. Сейчас, ради общего дела, он решает напрячь какие-никакие светские навыки.
— Я прилетел в Манилу несколько дней назад и успел перестроиться.
— Успешно ли идут ваши дела в Маниле? — отстреливается Гото.
— Да, очень хорошо, спасибо, — врет Рэнди, который уже успел мобилизоваться. — А вы прямиком из Токио?
Улыбка на лице Гото застывает.
— Да.
Это, по сути, покровительственный ответ. Штаб-квартира «Гото инжиниринг» — в Кобе, значит, он никак не мог лететь через Токио. Тем не менее Гото ответил «да», поскольку за время короткой заминки осознал, что говорит с янки, для которого «Токио» означает «Япония» или «откуда вы там взялись».
— Простите, — говорит Рэнди. — Я хотел сказать, из Осаки. Гото ослепительно улыбается и отвешивает легчайший поклон.
— Да! Я сегодня из Осаки.
На выдаче багажа Уотерхауз и Гото разделяются, обмениваются улыбками на паспортном контроле и вновь сталкиваются на выходе. Кинакутцы в кипенно-белых кителях с золотым шитьем и белых перчатках бросаются на пассажиров, предлагая везти в отель.
— Вы тоже остановились в «Фут Меншн»? — спрашивает Гото. Это самый большой и самый шикарный отель в Кинакуте. На самом деле Гото знает ответ заранее: завтрашние переговоры расписаны, как запуск космического челнока.
Рэнди в нерешительности. К тротуару только что подкатил самый большой «мерседес-бенц», какой он видел в жизни. Стекла автомобиля не просто запотели — по ним буквально ручьями бежит вода. Водитель в ливрее «Фут Меншн» выскакивает наружу, чтобы погрузить в автомобиль мистера Гото и его багаж. Достаточно сделать шаг, и Рэнди мигом домчат до шикарного отеля, где можно будет принять душ, завалиться голым на кровать и смотреть телевизор, потягивая французское вино по сто долларов за бутылку, сходить в бассейн, сделать массаж.
В этом-то, собственно, и проблема. Его уже и так разморило от экваториальной жары. Рано расслабляться. Он на ногах всего шесть или семь часов. Надо работать. Усилием воли он удерживает себя на месте. От натуги его прошибает такой пот, что все в радиусе нескольких метров должно бы окутаться влажной дымкой.
— Очень бы хотелось поехать с вами, но у меня еще пара дел.
Гото понимает.
— Может быть, выпьем вечером по рюмочке.
— Оставьте мне сообщение, — говорит Рэнди.
«Мерседес» трогается с ускорением в семь g, Гото машет рукой из-за тонированного стекла. Рэнди поворачивается на сто восемьдесят, заходит в «Данкин Донатс», где принимают валюты восьми государств, и насыщается. Потом снова выходит наружу и делает едва заметное движение в сторону стоянки. Таксист всем телом бросается вперед и срывает у него с плеча сумку.
— Министерство информации, — говорит Рэнди.
Только время может показать, так ли султанату Кинакута необходимо исполинское сейсмо-вулкано-цунами-термоядерноустойчивое Министерство информации с подземными этажами, наполненное компьютерами и коммутаторами. Однако султану показалось, что это круто. Он пригласил каких-то озабоченных немцев спроектировать здание, и «Гото инжиниринг», чтобы его построить. Разумеется, по части знания природных катастроф японцы кого хошь переплюнут, за исключением, возможно, некоторых народов, которых к строительству не привлечешь по причине полного вымирания. Кроме того, они, как и немцы, кое-что знают о бомбежках.
Разумеется, есть субподрядчики и немерено консультантов. Ави каким-то образом уболтал местных чиновников и отхватил для «Эпифита(2)» жирный заказ на системную интеграцию. Это значит собрать вместе то, что сделали другие, и следить за установкой компьютеров и прокладкой линий.
Дорога к строительному участку на удивление коротка. Город Кинакута не так и велик, а султан проложил достаточно восьмирядных шоссе. Такси проносится по насыпному полуострову, огибает останки пика Элиза, минует два въезда в Техноград и сворачивает на никак не отмеченную дорогу. Внезапно они оказываются в хвосте у пустых самосвалов — японских бронтозавров, с большим и гордым логотипом «ГОТО». Навстречу ползут такие же самосвалы, только полные. Таксист выруливает на правую полосу и с полмили едет мимо колонны, преодолевая подъем — у Рэнди один раз закладывает уши. Дорога проложена в ущелье. Вскоре ее стискивают головокружительные зеленые склоны, которые, как губка, пропитаны вечным туманом. Сквозь дымку иногда проблескивают яркие краски — цветы или птицы, Рэнди сказать не может. Контраст между мглистой зеленью и дорогой, разъезженной шинами размером со средний дом, ошеломляет. Невозможно понять, где ты.
Такси останавливается. Шофер повернулся и смотрит выжидательно. В первый миг Рэнди думает, что тот сбился с дороги и ждет указаний. Дальше дороги нет. Посреди мглистого леса, как по волшебству, раскинулась автостоянка. Рэнди видит современные вагончики с логотипами японских, американских, немецких фирм, десятка два легковушек и несколько автобусов. Все признаки крупного строительства налицо, плюс несколько дополнительных, скажем, над мусорным контейнером дерутся два сексуально озабоченных самца мартышки. Нет только самого котлована. Просто стена джунглей в конце дороги, такая зеленая, что кажется почти черной.
— Вас подождать? — спрашивает таксист.
Рэнди смотрит на счетчик и быстро пересчитывает местные деньги в доллары. Получается, что поездка обошлась ему в десять центов. «Да», — говорит он и вылезает из машины. Довольный таксист откидывается на спинку сиденья и закуривает.
Рэнди стоит и некоторое время смотрит на вход в пещеру, отчасти потому, что зрелище того стоит, отчасти потому, что из устья веет приятным холодом. Потом идет через стоянку к вагончику с надписью «Эпифит».
Там сидят три молодые кинакутки, которые видят его впервые, тем не менее отлично знают, кто он такой, и всячески демонстрируют свою радость. Для защиты от арктической стужи кондиционеров у них поверх белых блузок накручены длинные куски цветастой материи. Все они — воплощение деловитости и расторопности. По всей Юго-Восточной Азии Рэнди встречает девушек, которым бы возглавлять «Дженерал Моторс» или что-нибудь в таком роде. Они быстро сообщают о его прибытии по рациям и сотовым, извлекают на свет сапоги, каску, мобильник, все — с его фамилией. Через пару минут дверь вагончика открывает молодой кинакутец в каске и грязных сапогах, представляется Стивом и ведет Рэнди ко входу в пещеру. Вглубь уходит дощатый пешеходный настил, освещенный цепочкой зарешеченных фонарей.
Первые метров сто они идут по совершенно прямой штольне шириною в два самосвала и пешеходную дорожку. Рэнди ведет рукой по стене. Она грубая и пыльная, а не гладкая, как в природной пещере. Заметны свежие следы буров.
Эхо подсказывает, что впереди что-то изменится, и вскоре Стив выводит Рэнди в собственно пещеру. Она так велика, что десяток исполинских самосвалов может стоять в круг, одновременно загружаясь породой. Рэнди поднимает глаза, ища кровлю, однако видит лишь голубоватые огни, как в спортзале, метрах в десяти над головой. Дальше — мгла.
Стив отправляется кого-то искать. Рэнди остается один и пробует сориентироваться. На это требуется определенное время.
Стены частью естественные гладкие, частью — грубые. Это те места, где инженеры задумали расширить пещеру, а проходчики осуществили их замысел. Соответственно отдельные участки пола тоже гладкие и не совсем ровные. Местами его пробурили и взорвали, чтобы сровнять, местами досыпали щебенкой.
Главное помещение выглядит почти законченным. Здесь разместятся офисы Министерства информации. Две другие пещеры, глубже в горе, еще расширяют. В одной будет генераторная, в другой — системный блок.
Из бокового отверстия выходит пухлый блондин в белой каске — Том Говард, вице-президент компании «Эпифит» по системным технологиям. Он снимает каску, машет Рэнди и подзывает его рукой.
Туннель, ведущий в системное помещение, достаточно большой, чтобы по нему проехала легковая машина, хотя не такой гладкий и ровный, как главная штольня. Почти всю его ширину занимает ленточный транспортер, нагруженный влажной серой породой. По сложности и цене он так же далеко ушел от обычного транспортера, как тактический истребитель F-15 «Игл» от биплана времен Первой мировой. Рядом с ним можно говорить, но невозможно слушать, поэтому Том, Рэнди и кинакутец, назвавшийся Стивом, метров сто идут молча, пока не оказываются в следующей выемке.
Здесь мог бы разместиться небольшой одноэтажный дом. Транспортер идет через середину пещеры и пропадает в следующем отверстии — порода ползет из дальних недр горы. Разговаривать за грохотом по-прежнему невозможно. Пол залит бетоном, через каждые несколько метров торчат трубки, из которых свешиваются оранжевые провода — оптоволокно.
В стене есть еще отверстие — видимо, от этой пещеры ответвляются несколько боковых. Том ведет Рэнди туда и почти сразу предостерегающе берет за локоть: впереди пятиметровый колодец, вниз уходит деревянная лестница.
— То, что ты сейчас видел, — главная коммутаторная, — говорит Том. — Когда ее закончат, получится самый большой маршрутизатор в мире. В соседних комнатах мы разместим компьютеры и систему хранения. По сути — самый большой в мире RAID с большим-пребольшим кешем.
RAID означает избыточный массив недорогих дисков — способ надежно и дешево хранить большое количество информации. Как раз то, что нужно для информационного рая.
— Мы пока еще расширяем соседние помещения, — продолжает Том, — и кое на что там наткнулись. Думаю, тебе будет интересно. — Он поворачивается и начинает спускаться по лестнице. — Ты знаешь, что в войну у японцев здесь было бомбоубежище?
У Рэнди в кармане — отксеренная карта из книги. Он вынимает ее и подносит к лампочке. Разумеется, высоко в горах отмечен «ВХОД В БОМБОУБЕЖИЩЕ И КОМАНДНЫЙ ПУНКТ».
— И командный пункт? — спрашивает Рэнди.
— Ага. Откуда ты знаешь?
— Межбиблиотечный абонемент, — отвечает Рэнди.
— Мы не знали, пока не попали сюда и не нашли старую электропроводку. Ее пришлось убирать, чтобы проложить нашу.
Рэнди начинает спуск.
— Колодец был засыпан камнями, — говорит Том, — но мы видели, что вниз тянутся провода и, значит, внизу что-то есть.
Рэнди нервно глядит наверх.
— Засыпан камнями? Тут что, был обвал?
— Нет, — отвечает Том, — его завалили японцы. Десятки наших рабочих две недели разбирали камни вручную.
— И куда вели провода?
— К лампочкам, — говорит Том. — Обычная электропроводка — не линии связи.
— Тогда что они хотели здесь спрятать? — спрашивает Рэнди. Он уже на нижних ступенях и видит пещеру размером примерно с комнату.
— Сейчас увидишь. — Том щелкает выключателем.
Пещера примерно с гараж на одну машину. Пол ровный, гладкий. У стены — деревянный стол, стул и шкаф, все в пятидесятилетней серовато-зеленой плесени. И еще металлический ящик, покрашенный защитной краской, с японскими иероглифами на крышке.
— Я его взломал, — говорит Том. Он подходит к ящику и откидывает крышку. Внутри, до самого верха, книги.
Рэнди смотрит ошалело.
— А ты думал — золотые слитки? — смеется Том.
Рэнди садится на пол, обхватывает колени и, раскрыв рот, смотрит в ящик.
— Тебе плохо? — спрашивает Том.
— Тяжелое, тяжелое дежа-вю, — говорит Рэнди.
— От этого?
— Да, — отвечает Рэнди. — Я их уже видел.
— Где?
— У бабушки на чердаке.

Рэнди выбирается из лабиринта пещер на стоянку. Воздух приятно согревает, но, не успев добраться до вагончика, он уже обливается потом. Рэнди возвращает сапоги и каску, прощается с тремя сотрудницами и снова дивится их вниманию. Впрочем ничего странного: он не какой-нибудь чужак. Он — акционер, важное лицо в компании, на которую они трудятся. Кормилец или эксплуататор, это уж как вам угодно.
Рэнди идет через стоянку — очень медленно, чтобы не раскочегарить метаболическую топку. Рядом с такси, на котором он приехал, стоит другое; водители высунулись в окошки и треплются.
Почти у самого такси Рэнди оборачивается на пещеру. В черном зеве стоит человек, крошечный рядом с исполинскими самосвалами Гото. Седой, сгорбленный, жилистый, в спортивном костюме и сандалиях он выглядит довольно подтянуто. Стоит спиной к Рэнди, лицом к пещере. В руках — длинный букет цветов. Старик словно врос в грязь.
Вагончик «Гото инжиниринг» открывается. Молодой японец в белой рубашке, полосатом галстуке и оранжевой каске сбегает по ступеням и быстро идет к старику. На почтительном расстоянии он останавливается и кланяется. Рэнди довольно мало общался с японцами и не знает тонкостей этикета, но ему сдается, что это исключительно глубокий поклон. Молодой человек подходит к старику и жестом приглашает его в вагончик. Старик, по всей видимости, растерян — наверное, в его время пещера выглядела иначе, — однако позволяет увести себя с дороги, по которой ездят самосвалы.
Рэнди садится в такси и говорит: «Фут Меншн».
Он наивно думал, что будет читать воспоминания Шона Дэниела Макги неторопливо, вдумчиво, с начала до конца. Размечтался! По дороге к отелю он вытаскивает из сумки ксерокопию начинает безжалостно листать страницы. Большая часть книги не имеет отношения к Кинакуте — это про то, как Макги сражался на Новой Гвинее и Филиппинах. Макги — не Черчилль, зато обладает некой легкостью слога, так что даже самые банальные истории читаются с интересом. Надо думать, его рассказы пользовались большим успехом у барной стойки; наверняка сотни подвыпивших сержантов убеждали Макги записать это все, если он когда-нибудь доберется живым до Южного Бостона.
Он добрался, но в отличие от других американцев с большим опозданием. Его перебросили в султанат Кинакуту, где в то время находились примерно четыре тысячи японских солдат. Этим объясняется одна особенность книги. В большинстве военных мемуаров День Победы над Германией или Японией происходит на последней странице или по крайней мере в последней главе, потом герой возвращается в свой город и покупает «бьюик». Однако у Макги после Дня Победы — еще добрая треть страниц. Когда Рэнди пролистывает все до августа 1945-го, у него на коленях остается пугающе толстая стопка. Видимо, сержанту Макги было что излить на бумагу.
К тому времени война давно переместилась ближе к Японии. Как многие другие гарнизоны, оставшиеся не у дел, японцы на Кинакуте занялись разведением огородов в ожидании редких подводных лодок, которыми командование вывозило самые ценные грузы и самых нужных специалистов, например авиамехаников. Когда по радио прозвучал призыв Хирохито сложить оружие, гарнизон подчинился дисциплинированно и (надо полагать) с большой радостью.
Оставался пустячок: найти, кому сдаться. Союзники готовились вторгнуться в Японию и далеко не сразу нашли время для гарнизонов вроде кинакутского. Макги весьма желчно описывает сумятицу в Маниле. Здесь автор теряет выдержку, а повествование — художественность. Он начинает брюзжать. Через двадцать страниц автор высаживается на Кинакуте и стоит навытяжку, пока их капитан принимает капитуляцию японского гарнизона. Выставляет часовых у входа в пещеру, в которой укрылись несколько несгибаемых самураев. Организует разоружение японцев, которые измождены до последней крайности. Оружие и боеприпасы топят в море, одновременно доставляют еду и медикаменты. Макги помогает саперам натянуть колючую проволоку вокруг летного поля, превращенного в лагерь для интернированных.
Рэнди проглядывает все это по диагонали. Внезапно его взгляд цепляют слова «пронзали», «крики», «чудовищный». Он возвращается на несколько страниц назад и начинает читать внимательно.
Предыстория такова: начиная с 1940-го японцы согнали тысячи туземцев с гор острова на жаркие, нездоровые берега. Эти рабы расширяли пещеры под бомбоубежище и командный пост, улучшали дорогу на вершину пика Элиза, где разместилась станция слежения, укрепляли берег и как мухи мерли от малярии, речной лихорадки, дизентерии, недоедания и непосильного труда. Те же туземцы или их безутешные соплеменники наблюдали из редутов высоко в горах, как Шон Дэниел Макги и другие американцы разоружают японцев и сгоняют на летное поле. Весь следующий день, пока часовые делили время между пьянством и сном, туземцы в джунглях готовили копья, а едва луна прожектором осветила спящих японцев, разом высыпали из леса. Здесь Макги начинает сыпать такими словами, как «орда», «саранча», «ревущее полчище», «черный легион, вырвавшийся из ада», «вопящая масса», и другими, от которых не может отделаться. Туземцы аккуратно разоружили и уложили на землю часовых, однако трогать их не стали, потом закидали ветками колючую проволоку и хлынули на летное поле. Рассказ занимает двадцать страниц. Это, помимо прочего, история о том, как один добродушный сержант из Южного Бостона заработал нервное расстройство на всю жизнь.
— Сэр?
До Рэнди постепенно доходит, что дверца открыта, а такси стоит под навесом гостиницы «Фут Меншн». Дверцу придерживает худощавый молодой посыльный, не похожий на тех кинакутцев, которых Рэнди встречал до сих пор. Именно так Шон Дэниел Макги описывает горных туземцев.
— Спасибо, — говорит Рэнди и не забывает дать ему щедрые чаевые.
Комната обставлена мебелью, которая разработана в Скандинавии, но собрана в Кинакуте из древесины исчезающих пород. За окнами — горы, однако с балкончика видно кромку воды, разгружающийся контейнеровоз и почти весь мемориальный садик, разбитый японцами на месте резни.
Рэнди ждут несколько сообщений и факсов, по большей части от членов корпорации «Эпифит». Все здесь и сообщают, в каких комнатах разместились. Рэнди распаковывает сумки, принимает душ и отправляет рубашки в стирку. Потом удобно устраивается за столом, включает ноутбук и открывает бизнес-план корпорации «Эпифит(2)».

ЯЩЕРИЦА

Бобби Шафто и его товарищи выехали прокатиться с ветерком.
По Италии.
Италия! Охренеть можно! Что творится?
Не его ума дело. Его дело расписано во всех мелочах. Так подробно пришлось объяснять, потому что в этом во всем нет ни хрена смысла.
В доброе старое время на Гуадалканале командир говорил ему: «Шафто, уничтожь этот дот», — и дальше Шафто был сам себе хозяин. Мог идти, бежать, ползти. Мог подкрасться с ранцевым подрывным зарядом или стоять в сторонке и поливать точку из огнемета. Не важно, лишь бы достичь цели.
Цель нынешней миссии выше разумения Бобби Шафто. Его, лейтенанта Еноха Роота, трех других морпехов, включая радиста, и трех друзей из английских ВДВ будят посреди ночи и гонят в последний мальтийский док, еще не уничтоженный люфтваффе. Там ждет подлодка. Они забираются внутрь и часа так двадцать четыре режутся в карты. Идут все больше на поверхности, где подлодки развивают намного большую скорость, хотя иногда погружаются — видимо, так надо.
Когда их следующий раз выпускают на плоский верх субмарины, снова глухая ночь. Они в бухточке у каменистого, изрезанного берега — это все, что Шафто может разглядеть в лунном свете. Их ждут два грузовика. Команда открывает люки в палубе субмарины, начинается разгрузка. В первый грузовик земляки из МПФ США забрасывают мешки с мусором. Тем временем друзья из британских ВДВ вытащили из другого отсека субмарины ящики и что-то собирают во втором грузовике с помощью гаечного ключа и крепких словечек. Собранный агрегат накрывают брезентом раньше, чем Шафто успевает хорошенько его рассмотреть, но, судя по виду, это такая штука, которую предпочтительно направлять от себя.
Два чернявых усача слоняются но берегу, курят и препираются с капитаном подлодки. После разгрузки им отдают несколько ящиков. Чернявые вскрывают два ящика на пробу и, по-видимому, остаются довольны.
До сих пор Шафто не знает даже, на каком они материке. Когда он увидел берег, то решил, что в Северной Африке. Глядя на чернявых, решает, что в Турции.
Наконец встает солнце, и Шафто (лежа в кузове едущего грузовика на мешках с мусором и выглядывая из-под брезента) видит дорожные указатели и церкви. Испания или Италия. Наконец мелькает указатель «ROMA». Значит, Италия. Стрелка направлена прочь от встающего солнца, значит, они к югу или юго-востоку от Рима. Кроме того, они южнее какого-то Неаполя.
Однако Шафто не слишком часто выглядывает наружу. Это не поощряется. Водитель грузовика болтает по-местному, порой он останавливается перекинуться с кем-нибудь парой слов. Иногда разговор похож на дружеский треп. Иногда — на спор по поводу правил дорожного этикета. Иногда он более тихий. Постепенно до Шафто доходит, что водитель дает взятки на блокпостах. Это что ж такое? Два грузовика вражеских солдат, укрытых всего-навсего брезентом, преспокойно едут через воюющую страну? Страну, где у власти фашисты? Какая халатность!.. Ему хочется вскочить, отбросить брезент и сделать итальяшкам втык. Чтоб хорошенько выскребли здесь все зубной щеткой! Вконец разболтались. Нипы, что ни говори, уж если объявляют войну, то по крайней мере воюют без дураков.
Ладно, хрен с ними, с итальянцами, пусть живут. Вправлять им мозги было бы нарушением приказов, которые Шафто помнил назубок, пока мысль, что они и впрямь едут по вражеской территории, не вышибла у него из башки все остальное. И если бы эти приказы не исходили непосредственно от полковника Чаттана, Бобби им не поверил бы.
Они встанут лагерем и будут довольно долго играть в карты. Радисту тем временем скучать не придется. Эта фаза операции должна продлиться примерно неделю. В какой-то момент их постараются уничтожить немцы или, может быть, итальянцы, если вдруг раскачаются. Когда это случится, они должны будут послать радиограмму, сжечь лагерь, выехать на такое-то поле, которое сойдет за аэродром, и ждать, пока их заберут британские летчики.
Шафто поначалу не поверил ни одному слову — решил, что это такой британский юмор, подначка для начала разговора. Он вообще плохо понимает англичан, поскольку (по его личным наблюдениям) у них и у американцев несколько разное представление о юморе. Говорят, юмор еще есть у некоторых жителей Восточной Европы, но Шафто ни с кем из них не знаком, и потом им сейчас скорее всего не до смеха. Так или иначе, трудно понять, всерьез англичанин или подкалывает.
Все предположения, что это розыгрыш, рассеиваются после выдачи оружия. Для организации, чья цель — убивать, армия выдает его исключительно неохотно. А если и выдает, то полное говно. Морпехи сами выписывают себе «томми» из Америки: начальство хочет, чтобы они убивали, но не дает из чего!
Однако подразделение 2702 — совсем другая песня. Даже рядовым раздают «томпсоны». А на случай, если кто-то еще не поверил в серьезность задания, — ампулы с цианидом. Последний скепсис развеивает лекция полковника Чаттана о том, как правильно застрелиться. («Удивительно, сколько вполне толковых ребят запарывают эту внешне простую процедуру».)
Теперь до Шафто доходит, что у приказов есть невысказанное примечание: да, кстати, если какие-нибудь итальянцы, которые на самом деле заправляют в Италии, настоящие всамделишные фашисты, с которыми мы воюем, если кто-нибудь из них вас заметит и почему-либо захочет сорвать наш маленький план (понимать который вам вовсе не обязательно) — непременно убейте их. А если не получится, пожалуйста, убейте себя, поскольку вы наверняка справитесь с этим лучше фашистов. И не забудьте лосьон для загара!
Вообще-то задание Шафто скорее по душе. Уж во всяком случае, здесь не хуже, чем на Гуадалканале. Что сбивает с толку (думает он, поудобнее устраиваясь на мешках с загадочным мусором и выглядывая из-под брезента), так это полное непонимание цели.
Ребята из взвода то ли все убиты, то ли нет; Шафто вроде бы по-прежнему слышит крики, но их трудно различить за гулом прибоя и несмолкающим треском очередей. Тут до него доходит, что кто-то наверняка жив, иначе зачем бы нипам стрелять.
Он ползет к тому концу бревна, который ближе к пулемету, делает несколько глубоких вдохов, привстает и прыгает через бревно! Теперь он явственно видит устье пещеры, лисий хвост огня разрезан в мозаику противогранатной сеткой. Все на удивление тихо. Шафто оглядывается и видит неподвижные тела.
Черт! Живых на берегу нет, японцы просто расстреливают боезапас, чтобы не вытаскивать ленту. Шафто морпех, он понимает.
Дуло разворачивается — его засекли. Он как на ладони. Можно нырнуть в листву, но нипы прочешут ее огнем, и ему все равно крышка. Бобби Шафто расставляет ноги, наводит на пещеру кольт сорок пятого калибра и жмет на курок. Ствол пулемета смотрит в точности на него.
Но не стреляет.
Кольт щелкает. Магазин пуст. Все тихо, слышны только гул прибоя и крики. Шафто убирает кольт, выхватывает револьвер.
Кричат незнакомым голосом.
Имперский морской пехотинец выскакивает из пещеры, на уровне глаз Шафто. Правый зрачок Бобби, мушка и нип оказываются на одной линии. Шафто успевает дважды нажать на курок и почти наверняка попадает.
Имперский морской пехотинец запутывается в противогранатной сетке и падает Шафто под ноги.
Через мгновение из пещеры выпрыгивает второй — даже не с криком, а с каким-то бессвязным всхлипом.
Он неудачно прыгает и ломает голень — Шафто слышит хруст. Тем не менее нип бежит к морю, нелепо припадая на сломанную ногу. На Шафто он даже не смотрит. Кровь хлещет у него из шеи и плеч. Видно, как на бегу болтаются куски мяса.
Бобби прячет револьвер в кобуру. Надо бы сорвать с плеча винтовку и пристрелить нипа, но он слишком ошарашен.
Что-то красное мелькает в устье пещеры. Шафто поднимает глаза, но не может ничего разобрать в зрительном шуме джунглей.
Снова мелькает что-то красное, раздвоенное, как язык у рептилии.
Движущийся кусок живых джунглей вываливается из пещеры и чешет по склону вниз, сминая верхушки растений.
Оно на берегу. Шпарит на четырех лапах, низко к земле. На мгновение замирает и поводит языком в сторону имперского морского пехотинца, который вприскочку ковыляет через прибойную полосу ярдах в пятидесяти впереди.
Песок взметается, как дым из-под горящих шин гоночного автомобиля. Ящер покрывает расстояние до нипа в одну, две, три секунды, хватает его под колени, валит в прибой. Тащит покойника на берег. Укладывает рядом с мертвыми американцами, обходит раза два и начинает есть.
— Сержант! Приехали! — зовет рядовой Фланаган. Еще не проснувшись, Шафто отмечает, что голос у рядового Фланагана спокойный, значит, на них не напали.
Шафто открывает глаза в тот самый миг, когда с открытого кузова срывают брезент, и видит над собой голубое итальянское небо, разорванное по краям ветками деревьев.
— Бля! — говорит он.
— Чего такое, сержант?
— Я всегда так говорю, когда просыпаюсь, — отвечает Шафто.

Новый дом оказывается старым каменным амбаром на оливковой ферме, или плантации, или как там называется место, где выращивают оливки. В Висконсине про такой сразу бы сказали, что он заброшенный. Как здесь, Шафто не знает. Крыша частично просела под непомерным весом глиняной черепицы, окна и двери сорваны с петель и распахнуты всем ветрам. Дом большой, и после нескольких часов работы кувалдой один из грузовиков удается загнать внутрь, чтобы его не заметили с воздуха. Из второго выгружают мешки с мусором, и водитель-итальянец уезжает на нем в неведомом направлении.
Капрал Бенджамин, радист, лезет на оливы и опутывает весь двор медной проволокой. Друзья отправляются на рекогносцировку, земляки начинают разбрасывать мусор. Это, в частности, итальянские газеты за несколько месяцев. Все они развернуты, страницы перепутаны, сложены как попало. Какие-то статьи вырезаны, какие-то обведены или отмечены карандашом. Приказы Чаттана постепенно всплывают у Шафто в мозгу. Он складывает газеты в угол амбара — старые вниз, новые сверху.
Целый мешок наполнен основательно докуренными бычками. Марка европейская, Шафто ее не знает. Он ходит с мешком, как сеятель, и горстями разбрасывает чинарики, по большей части там, где кто-нибудь и впрямь будет работать: под столом у капрала Бенджамина и под козлами, которые они сколотили, чтобы есть и играть в карты. То же с салатом из винных и пивных пробок. Равное количество пивных и винных бутылок закатывается по углам амбара. Бобби работа нравится. Он бросает бутылки сильно, как квортербек из «Стил Бэй Паркер» отважным крайним форвардам.
Десантники возвращаются, и происходит смена — земляки идут знакомиться с местностью, друзья выгружают остальной мусор. Побродив с час, сержант Шафто, рядовые Фланаган и Кюль выясняют, что оливковое ранчо расположено на длинной, вытянутой с севера на юг полоске земли. На западе круто уходит вверх коническая гора, подозрительно смахивающая на вулкан. На востоке через несколько миль начинается море. На севере — непроходимые заросли колючего кустарника, на юг продолжаются сельхозугодия.
Чаттан велел отыскать место для секретки, по возможности ближе к амбару. К закату Шафто определяется: каменистый выступ на склоне вулкана, в получасе от дома и метров на пятьсот выше.
На обратном пути он едва находит амбар, так здорово он спрятан. Десантники закрыли светомаскировкой все дырки, даже провалы в крыше, и вполне уютно разместились внутри. Разбросанный мусор (к бычкам и пробкам теперь прибавились куриные перья и кости, апельсинная кожура и прядки отстриженных волос) создает впечатление, что они тут по меньшей мере год. В этом, видимо, весь смысл.
Примерно треть жилплощади отхватил себе капрал Бенджамин. Он включил радиопередатчик, тепло светятся лампы. Кроме того, у него куча бумажек. Часть, подобно окуркам, липовая. Однако после ужина, когда солнце заходит не только здесь, но и в Лондоне, он садится и начинает выстукивать морзянкой.
Шафто, как и все остальные, знает азбуку Морзе. Друзья и земляки сидят за столом, готовясь всю ночь резаться в карты, и одним ухом ловят стук ключа, однако слышат сплошную галиматью. В какой-то момент Шафто подходит и заглядывает Бенджамину через плечо. Нет, он не спятил, все так и есть:

XYHEL ANAOG GFQPL TWPKI AOEUT

и так далее, страница за страницей.
На следующий день они роют сортир и до половины наполняют его двумя бочками стандартного армейского образца стопроцентно чистого патентованного говна. Согласно приказу Чаттана, они льют говно порциями, перемежая комканными обрывками итальянских газет, дабы создать впечатление, что оно попало сюда естественным образом. Если не считать интервью лейтенанту Рейгану, это худшая небоевая работа, которую Шафто когда-либо поручала Родина. Он объявляет отдых до конца дня всем, кроме капрала Бенджамина, который до двух ночи выстукивает галиматью.
На следующий день они принимаются за наблюдательный пункт: ходят туда-сюда, туда-сюда, протаптывают тропинку, оставляя рядом армейского образца срач. Рядовые Фланаган и Кюль заносят на гору вьючник и прячут его за камнями. Во вьючнике — книги с силуэтами итальянских и немецких кораблей, такие же справочники по самолетам, бинокли, подзорные трубы, фотопринадлежности, пустые блокноты и карандаши.
Хотя Бобби Шафто и заправляет этим спектаклем, ему никак не удается улучить минуту наедине с лейтенантом Енохом Роотом. Роот избегает его с самого памятного полета на «Дугласе». Наконец, примерно на пятый день, Шафто припирает его к стенке — уходит вместе с несколькими рядовыми к амбару, оставив Роота в секретке, потом неожиданно возвращается.
При появлении Шафто Роот вздрагивает, но не слишком огорчается. Он закуривает итальянскую сигарету, предлагает вторую Шафто. Тот, к своей досаде, обнаруживает, что из них двоих нервничает он сам. Роот по обыкновению спокоен.
— О'кей, — говорит Шафто, — что ты увидел? Когда смотрел в бумаги, которые мы подложили мертвому мяснику?
— Они все были на немецком, — отвечает Роот.
— Бля!
— По счастью, — продолжает Роот, — я немного знаю этот язык.
— Ах да. У тебя ведь мать немка?
— Да, она была врач при миссии, — говорит Роот. — На случай, если это несколько развеет твое предубеждение против немцев.
— А отец — голландец.
— Верно.
— И чего их понесло на Гуадалканал?
— Помогать страждущим.
— Ясно.
— Итальянский я тоже немного знаю. В Церкви его слышишь довольно часто.
— Охренеть! — восклицает Шафто.
— Однако мой итальянский сильно испорчен латынью, которую отец заставил меня выучить. Местным жителям он, наверно, показался бы несколько архаичным. Я бы говорил, как алхимик семнадцатого века или кто-то в таком роде.
— Или как поп? На это бы они клюнули.
— Если припрет, — соглашается Енох, — попробую завести клерикальный разговор, и посмотрим, что из этого выйдет.
Они выпускают дым и смотрят на широкий водный простор впереди. Шафто знает, что это называется Неаполитанский залив.
— Ладно, — говорит Шафто, — так что было в тех бумагах?
— Много подробной информации о военных конвоях из Палермо в Тунис. Похищенной, вероятно, из немецких секретных источников.
— Старых конвоях или...
— Конвоях, которые только должны выйти, — спокойно отвечает Роот.
Шафто тушит окурок и некоторое время молчит. Потом произносит: «Мудрено, бля», — встает и идет к амбару.

ЗАМОК

Как раз когда Лоуренс Притчард Уотерхауз сходит с поезда, какой-то гад выплескивает ему в лицо ведро соленой воды со льдом. Мерзавцев много, водяная канонада продолжается без остановки. Тут он понимает, что никого рядом нет. Это просто неотъемлемое свойство местной атмосферы, как туман в Лондоне.
Лестница на виадук, ведущий к зданию вокзала, защищена стенами и крышей, так что получается исполинская органная труба, она резонирует в инфразвуковом диапазоне от ударов воды и ветра. Как только Уотерхауз вступает на лестницу, в лицо перестает хлестать, и он может уделить должное внимание феномену.
Влага и воздух взбиты штормом в пену, лишенную явных закономерностей. Микрофон, подвешенный в воздухе, зарегистрировал бы белый шум — полное отсутствие информации. Однако шум, ударяя в длинную трубу лестницы, вызывает физический резонанс, который ухо Лоуренса воспринимает как низкий гул. Труба извлекает закономерность из шума! Эх, сюда бы Алана!
Уотерхауз голосом подбирает интервалы к основному тону: октаву, квинту, кварту, большую терцию и так далее. Каждый из этих звуков вызывает в трубе больший или меньший резонанс Это звукоряд медных духовых инструментов. Ему удается сносно воспроизвести сигнал горниста. Получается вполне узнаваемая побудка.
— Как мило!
Уотерхауз стремительно оборачивается. За его спиной дама втаскивает на лестницу саквояж размером с тюк сена. Она немолода и сложена, как шкаф. Несколько секунд назад, в поезде, у нее на голове был пышный городской перманент. Соленая вода сбегает по лицу и шее под плотное платье серой йглмской шерсти.
— Мэм, — говорит Уотерхауз и втаскивает саквояж на лестницу. Они оба вместе с багажом оказываются на узком крытом мосту, ведущем через пути к вокзалу. В боковых стенах — окна; Уотерхауз смотрит через струящуюся по стеклам полудюймовую толщу влаги на Атлантический океан, и ему плохеет. Океан — в нескольких метрах и явно хочет подобраться еще ближе. Возможно, это обман зрения, но кажется, что волны вздымаются вровень с мостом, хотя до земли не меньше двадцати футов. Каждая весит не меньше, чем все товарные составы Великобритании, вместе взятые. Хочется рухнуть плашмя и стравить. Лоуренс зажимает уши.
— Вы — музыкант? — спрашивает дама.
Уотерхауз оборачивается. Дама внимательно оглядывает его форму, ища знаки отличия, потом поднимает лицо и улыбается, как добрая бабушка.
В этот миг до Уотерхауза доходит, что она — немецкая шпионка. Мама родная!
— Только в мирное время, мэм, — говорит он. — Сейчас люди с хорошим слухом нужны для другого.
— А! — восклицает дама. — Так вы слушаете?
Уотерхауз улыбается.
— Пип! Пип! — говорит он, изображая радар. (Вообще-то речь о радиопеленгаторе. Как-то Алан увидел это слово с опечаткой — радиопедератор, и с тех пор, услышав его, начинает неудержимо каламбурить.)
Дама в восхищении.
— Меня зовут Харриет Йррт. — Она протягивает руку.
— Хью Хьюз.
— Очень приятно.
— Взаимно.
— Вам, вероятно, надо будет где-то остановиться. — Дама притворно краснеет. — Простите. Я лишь предположила, что вам на Внешний.
Внешний означает Внешний Йглм. Сейчас они на Внутреннем.
— Вы совершенно правы, — отвечает Уотерхауз.
Как все другие географические названия на Британских островах, сочетания Внутренний и Внешний Йглм — историческое недоразумение, восходящее корнями к какому-то древнему и, вероятно, забавному эпизоду. Внутренний Йглм по-настоящему даже не остров — он связан с материком песчаной косой, заливаемой приливом; теперь здесь дамба, по которой проложены шоссе и железнодорожные рельсы. Внешний Йглм отстоит от Внутреннего на двадцать миль.
— Мы с мужем держим небольшой пансион, — говорит миссис Йррт, — и будем очень рады, если вы у нас остановитесь.
Так Уотерхауз оказывается у Йрртов. Вместе с мистером и миссис Йррт он проводит весь вечер у единственного источника тепла — угольного тостера, вмурованного на место камина. Время от времени мистер Йррт открывает дверцу и подсыпает щепотку угля. Миссис Йррт носит еду и тянет из Уотерхауза секретные сведения. Она примечает его слегка асимметричную походку и выясняет, что он болел полиомиелитом. Он органист, а у них в гостиной есть фисгармония — она упоминает об этом.

Первый раз Уотерхауз видит Внешний Йглм в шпигат. Собственно, он даже не знает, зачем этот шпигат нужен, кроме как чтобы туда блевать. Еще до отплытия команда парома подробно проинструктировала его и полдюжины остальных пассажиров насчет блева. Суть состояла в том, что, если перегнуться через борт, вас наверняка смоет волной; лучше встать на четвереньки и целить в шпигат. Однако чаще он видит в отверстие не воду, а какую-нибудь далекую точку на горизонте, или чаек в небе, или отчетливый трезубый силуэт Внешнего Йглма.
Зубья, называемые Схры, это базальтовые останцы. Поскольку идет Вторая мировая война, а Внешний Йглм ближе всего к Битве за Атлантику, сейчас они усеяны антеннами и белыми пунктами радиосвязи. Есть и четвертая Схра, поменьше, ее легко принять за обычный холм. Она высится над единственным портом Внешнего Йглма (он же единственное поселение на острове, если не считать военно-морскую базу в противоположном конце). Четвертую Схру венчает замок, номинально принадлежащий Найджелу Сент-Джону Глумторнби-Уайдаболоту — новая штаб-квартира подразделения 2702.
Весь город можно обойти за пять минут. Разъяренный петух гоняет по главной улице заморенную овцу. На Схрах лежит снег, здесь же это просто серое крошево, неотличимое от мостовой, пока в него не наступишь и не упадешь копчиком. Энциклопедия все пишет с большой буквы: Город, Замок, Гостиница, Паб, Пристань. Уотерхауз посещает Сортир, дабы избавиться от последствий качки, и выходит на Улицу. Подъезжает Автомобиль, он же Такси. Уотерхауз садится и по пути мимо Парка замечает Памятник (древние йглмиане колошматят окаянных викингов). Перехватив его взгляд, Водитель сворачивает в Парк, дабы показать скульптуру во всей красе.
Это одна из тех многофигурных композиций, которые несут в себе целый рассказ, и занимает соответствующую площадь. Пьедестал вырублен из местного базальта и покрыт с одной стороны письменами, в которых Уотерхауз по картинкам в энциклопедии узнает йглмские руны. На непросвещенный взгляд они выглядят бессмысленной последовательностью рубленных Х-ов, I, L, прямых и перевернутых V, дефисов и звездочек. Однако это неиссякаемый источник гордости для...
— Мы не покорились римлянам с их Юлием Цезарем, — говорит таксист, — и алфавит их не приняли.
«Большая Йглмская Энциклопедия» посвятила рунам пространную статью. Автор берет настолько воинственный тон, что читать почти физически больно. «Вопреки измышлениям английских исследователей, обычай йглмиан избегать на письме плавных линий и закруглений не только не свидетельствует о дикости, но придает начертанию особую строгую красоту. Это исключительно функциональный способ письма для местности, где после уничтожения англичанами лесов подавляющая часть образованного грамотного сословия страдает хроническим обморожением».
Чтобы получше рассмотреть композицию, Уотерхауз опускает мутное стекло. Холодный ветер в лицо окончательно прогоняет морскую болезнь; у него даже мелькает мысль, как бы войти в контакт со Шлюхой.
Тут он, увы, соображает, что Шлюха, если у нее есть хоть капля мозгов, — на противоположной стороне острова, там, где военно-морская база.
— А это кто сбоку? — спрашивает Уотерхауз, указывая на угловую часть композиции, где жалкая, растоптанная личность в железном ошейнике с обрывком цепи трусливо взирает на лихую сечу, учиненную дюжими йглмскими молодцами. Уотерхауз знает ответ, но соблазн спросить слишком велик.
— Кха! — Таксист как будто откашливает мокроту. — Думаю, он с Внутреннего Йглма.
— Конечно.
Беседа разбередила в таксисте мстительную злость, которую можно остудить только быстрой ездой. К замку ведет обледенелый серпантин с десятком смертельно опасных поворотов. Уотерхауз рад, что не идет пешком, но от стремительных виражей на скользкой дороге его снова укачивает.
— Кха! — говорит таксист после десятиминутного молчания (к этому времени три четверти подъема уже позади). — Они римлян чуть не поклонами встречали. Перед викингами стелились. Не удивлюсь, если сейчас там немцы!
— Кстати, — перебивает Уотерхауз. — Остановитесь, пожалуйста. Дальше я пойду пешком.
Таксист обескуражен, но сдается, когда Уотерхауз объясняет, что в противном случае придется долго чистить салон, и даже завозит вещмешок на Схру и оставляет на вершине.
Подразделение 2702 в лице Лоуренса Притчарда Уотерхауза, ВМФ США, прибывает в замок пятнадцатью минутами позже. По дороге он успевает еще раз повторить свою легенду, чтобы войти в образ. Чаттан предупредил, что в замке будут слуги, которые все видят и обо всем судачат. Проще всего было бы отослать их на материк, но это значит обидеть герцога, благородно предоставившего замок вместе с прислугой. «Вам придется, — сказал Чаттан, — выработать модус вивенди». Уотерхауз посмотрел в словаре, что это означает «образ жизни», и согласился.

Предыдущая страница 11 Следующая страница


Криптономикон (часть 1) 12

Замок — груда обломков размером с Пентагон. С подветренной стороны имеются крыша, электропроводка и прочее украшательство вроде дверей и окон. В этой части замка (других Уотерхауз пока осмотреть не успел) можно забыть, что ты на Внешнем Йглме, и воображать себя в более зеленых и благодатных краях вроде Горной Шотландии.
На следующий день он вместе с дворецким, Гхнксом, делает вылазку в прочие части здания и, к своей радости, обнаруживает что попасть туда можно не иначе как через двор: все внутренние переходы замурованы, чтобы остановить сезонную миграцию скрггов, юрких длиннохвостых зверьков, которые считаются символом острова. Сегментация, при всех своих неудобствах, хороша с точки зрения секретности.
И Уотерхауз, и Гхнкс облачены в дубовые одежды из натуральной йглмской шерсти, у дворецкого при себе гальванический люцифер. Это нечто весьма древнее. Когда Уотерхауз вынимает флотский фонарик, Гхнкс (ему самому лет сто) только снисходительно улыбается. Тихим голосом, словно заглаживая серьезное нарушение этикета, он объясняет, что гальванический люцифер несравненно лучше, поэтому дальнейший разговор о фонарике только доставит всем лишнее смущение. Он ведет Уотерхауза в особую каморку сразу за кладовкой, расположенной через одно помещение за комнатой, которая непосредственно примыкает к буфетной. Каморка предназначена исключительно для гальванического люцифера и всего, что к нему прилагается. Сердце устройства составляет дутая сферическая колба объемом примерно с галлонную кружку. Гхнкс, у которого то ли гипотермия, то ли болезнь Паркинсона на ранней стадии, прилаживает к шару стеклянную воронку. Снимает с полки оплетенную бутыль. На бутыли надпись: «ЦАРСКАЯ ВОДКА», внутри плещется ярко-оранжевая жидкость. Гхнкс вынимает притертую стеклянную пробку, обнимает бутыль, наклоняет ее вперед, и оранжевая жидкость через воронку булькает в сферическую колбу. Попадая на стол, она прожигает в нем новые дыры вдобавок к тысячам старых. От них поднимается что-то очень похожее на дым и страшно едкое. У Лоуренса начинает першить в легких.
Гхнкс выстругивает электрод из цельного куска графита. В колбу с царской водкой опущены аноды, катоды и прочее, все это на зажимах из чистого золота. От колбы тянутся толстые провода в асбестовой обмотке ручного плетения. Они уходят в рабочую часть гальванического люцифера — медную миску, закрытую линзой Френеля, как на маяке. Выстругав электрод нужных размера и формы, Гхнкс заталкивает его в боковое отверстие миски и небрежно щелкает франкенштейновским рубильником. Искра вспыхивает на контактах, как шутиха.
В первый миг Уотерхауз думает, что стена рухнула и прямо на них светит солнце. Однако Гхнкс просто включил гальванический люцифер и теперь поворачивает бронзовый винт, так что скоро свет становится в десять раз ярче. Пристыженный Уотерхауз прячет фонарик в пижонский чехол на поясе и первым выходит из комнаты. Гхнкс идет следом. Уотерхауз чувствует на затылке жар гальванического люцифера. «Старушка будет светить часа два», — важно сообщает Гхнкс.
Им и впрямь удается выработать модус вивенди: Уотерхауз ногой открывает старую дверь, Гхнкс из соседнего помещения обводит комнату лучом света, как огнеметом, отчего скрргы десятками и сотнями с писком пускаются наутек. Уотерхауз осторожно забирается внутрь, обычно перелезая через обломки крыши или верхнего этажа, и быстро осматривается, прикидывая, сколько нужно сил, чтобы приспособить это помещение для более эволюционно развитых организмов.
Ползамка в разное время сгорело при пожарах, учиненных берберийскими пиратами, молниями, Наполеоном и курением в постели. Берберийские пираты потрудились основательнее других (возможно, просто хотели согреться), а может, в этой части замка у стихий было больше времени довершить начатое огнем. Так или иначе, Уотерхауз находит место, где не очень много придется разгребать и где с помощью брезента и досок можно быстро выгородить нужную площадь. Это помещение в прямо противоположной стороне от жилой части замка, то есть открыто зимним штормам, зато скрыто от любопытных взглядов прислуги. Уотерхауз измеряет его шагами, потом возвращается к себе, оставив Гхнкса разбирать гальванический люцифер.
Он составляет план будущих работ, пустив в ход дотоле невостребованные инженерные навыки. Затем пишется заявка на материалы, которая, естественно, включает в себя множество цифр: 100 8' 2x4 и так далее. Уотерхауз переписывает все это словами: сто восьми футовых два на четыре. Это можно понять превратно, поэтому он формулирует иначе: СТО ДОСОК ДВА НА ЧЕТЫРЕ ДЮЙМА ДЛИНОЙ ВОСЕМЬ ФУТОВ.
Потом вынимает листок, похожий на бухгалтерскую ведомость, разделенный вертикальными линиями на графы по пять колонок. В эти колонки переписывает сообщение:

TWOBY FOURB OARDS ONEHU NDRED
COUNT LENGT HEIGH TFEET*

[СТОДО СОКДВ АНАЧЕ ТЫРЕД ЮЙМАД
ЛИНОЙ ВОСЕМ ЬФУТО В (англ.).]

и так далее. Он использует только каждую третью строку.
С самого отъезда из Блетчли-парка Уотерхауз носит при себе несколько листков папиросной бумаги, ложась спать, прячет под подушку. Сейчас он вынимает их и берет один. Если не считать серийного номера наверху, там только аккуратно отпечатанные на машинке буквы

АТНОР COGNQ DLTUI CAPRH MULEP

и так далее до самого низа.
Листок этот отпечатала в Блетчли-парке миссис Тенни, пожилая супруга викария. У миссис Тенни странная работа Она берет два листа папиросной бумаги, закладывает между ними копирку и вставляет в печатную машинку. Перед нею устройство, как в лототроне прозрачная сфера с двадцатью пятью шарами, на каждом — буква (весь алфавит за исключением J — она в шифровках заменяется на I). Прокрутив сферу предписанное число раз, миссис Тенни закрывает глаза и наугад вынимает шар. Прочитывает букву, печатает ее, кладет шар на место, закрывает крышку и повторяет процедуру. Время от времени в комнату заходят серьезные люди, обмениваются с миссис Тенни любезностями и забирают готовые листки. Дальше их переправляют таким, как Уотерхауз, а также людям в куда более опасных обстоятельствах по всему миру Это зовется одноразовый шифрблокнот.
Уотерхауз переписывает буквы из одноразового блокнота в пустые строки под своим сообщением:

TWOBY FOURB OARDS ONEHU NDRED
АТНОР COGNQ DLTUI CAPRH MULEP

Теперь свободной остается только каждая третья строчка.
Наконец он возвращается в начало ведомости и начинает рассматривать буквы по две. Первая буква сообщения — Т. Первая буква одноразового шифрблокнота, сразу под ней — А.
А — первая буква алфавита. Для Уотерхауза, который шифрует уже черт-тe сколько, она — синоним цифры 1. Точно так же Т для него равняется 19. Складывая 1 и 19, получаем 20, то есть букву U. Поэтому в первой колонке под С Уотерхауз пишет U.
Следующая вертикальная пара W и Т, или 22 и 19. При обычном арифметическом сложении они дали бы 41, но это число слишком велико и не имеет буквенного соответствия. Однако Уотерхауз давно не считает, как обычные люди. Он натренировался мыслить арифметикой остатков, точнее — целочисленным делением на 25 (число букв английского алфавита без J). Это значит, что все делится на 25 и берется только остаток. 41 разделить на 25 будет 1 и 16 в остатке. Отбрасываем единицу, 16 превращается в букву Q. Ее Уотерхауз и пишет во второй колонке. В третьей колонке О и Н дают 14 + 8 = 22, то есть W. В четвертой В и О, это 2 + 14 = 16, то есть Q. В пятой Y и P, 24 + 15 = 39. 39 разделить на 25 равно 1 и 14 в остатке. Или, как думает об этом Уотерхауз, 39 сравнимо с 14 по модулю 25. Буква для 14 — О. В итоге первая шифргруппа выглядит так:

TWOBY
АТНОР
UQWQО*

[Вот как выглядел бы этот процесс на русском. Пусть строчка из шифрблокнота будет

АРВОХ ВЕКОС МТНСА ХУРЕК ВТРНМ

Тогда в первых двух строках записывается

СТОДО СОКДВ АНАЧЕ ТЫРЕД ЮЙМАД
АРВОХ ВЕКОС МТНСА ХУРЕК ВТРНМ

Первая буква сообщения — С. Первая буква одноразового шифрблокнота, сразу под ней — А.
А — первая буква алфавита, синоним цифры 1. С равняется 18. Складывая 1 и 18, получаем 19, то есть букву Т. Поэтому в первой колонке под С Уотерхауз пишет Т.
Следующая вертикальная пара Т и Р, или 19 и 17. При обычном арифметическом сложении они дали бы 36, но это число слишком велико и не имеет буквенного соответствия. Делим на 32 (число букв русского алфавита без Ё), получаем 1 и 4 в остатке. Отбрасываем единицу, 4 превращается в букву Г. Ее Уотерхауз и пишет во второй колонке. В третьей колонке О и В дают 15 + 3 = 18, то есть С. В четвертой Д и О, это 5 + 15 = 20, то есть У. В пятой О и X, 15 + 22 = 37. 37 разделить на 32 равно 1 и 5 в остатке. Другими словами, 37 сравнимо с 5 по модулю 32. Буква для 5 — Д. В итоге первая шифргруппа выглядит так:

СТОДО
АРВОХ
ТГСУД
]

Сложив случайную последовательно АТНОР с осмысленной последовательностью TWOBY, Уотерхауз получил недешифрируемую абракадабру. Закодировав так все сообщение, он берет новый листок и переписывает на него только шифртекст UQWQO и так далее.
Герцог предоставил в его распоряжение литой телефонный аппарат. Уотерхауз снимает трубку, звонит барышне, просит соединить его с военно-морской базой и буква за буквой диктует шифртекст радисту. Тот записывает и говорит, что сообщение будет отправлено немедленно.
Очень скоро полковник Чаттан в Блетчли-парке получит сообщение, начинающееся с UQWQO. У Чаттана хранится второй экземпляр одноразового шифрблокнота, отпечатанного миссис Тенни. Он перепишет шифртекст в ведомость, пропуская по две строки, а ниже — буквы из одноразового шифрблокнота:

UQWQO
АТНОР

Уотерхауз складывал, он будет вычитать. U минус А это 20 — 1 = 19, то есть Т. Q минус Т — это 16 — 19 = -3, то есть 22 — буква W. И так далее. Расшифровав все сообщение, он примется за дело, и, рано или поздно, сто досок два на четыре появятся на Пристани.

ЗАЧЕМ

Бизнес-план корпорации «Эпифит» не толст и не тонок, а примерно в дюйм толщиной. Внутренние страницы Ави распечатал на портативном принтере: четко, глянцево, с большим интервалом. Шероховатую бумагу для обложки изготовили из рисовой шелухи, бамбуковых очесов, дикорастущей конопли и чистейшей ледниковой воды седые умельцы в заоблачном пещерном храме на острове, куда могут добраться лишь экстремал-альпинисты с Западного побережья, натренированные дышать разреженным горным воздухом. Импрессионистскую карту Южно-Китайского моря нанесли на нее воссозданные по молекулам каллиграфы династии Мин, обмакивая кисточки из гривы единорога в тушь, которую слепые монахи-затворники вручную растирают из сажи, полученной при сжигании частиц Истинного Креста.
Само содержание бизнес-плана подчинено логической структуре, взятой прямиком из «Оснований математики». Предприниматели рангом пониже покупают программы для составления бизнес-планов — пакеты стереотипных текстов с пустыми графами. Ави и Берил составили столько бизнес-планов, что могут строчить их с чистого листа. Бизнес-планы Ави выглядят примерно так:
ЗАДАЧА: В [название компании], по нашему глубочайшему убеждению, [делать то-то и то-то, что мы собрались делать] и увеличивать прибыль акционеров — не просто взаимодополняющие виды деятельности; они неразрывно связаны.
ЦЕЛЬ: Увеличить прибыль акционеров [делая то-то и то-то].
ПРЕДУПРЕЖДЕНИЕ (отпечатано на отдельном листке, красным по желтому): Чтобы приблизиться к этому документу, вы должны быть умны, как Иоганн Карл Фридрих Гаусс, ловки, как слепой чистильщик сапог из Калькутты, непреклонны, как генерал Уильям Текумси Шерман, богаты, как английская королева, непрошибаемы, как фанаты «Ред Сокс», и способны в случае надобности принять командование средней подлодкой с ядерными ракетами. В противном случае уничтожьте его как высокорадиоактивные отходы и обратитесь к квалифицированному хирургу с просьбой ампутировать вам обе руки по локоть и удалить оба глаза. Это предупреждение необходимо, потому что однажды, лет сто назад, одна маленькая старушка из Кентукки вложила сто долларов в компанию по производству сухофруктов, которая обанкротилась и вернула ей только девяносто девять. С тех пор мы у правительства под колпаком. Если вы пренебрегли вышесказанным, читайте дальше на свой страх и риск — вы точно останетесь без единого цента и до конца жизни будете отбиваться от термитов в лепрозории на берегу Миссисипи.
Все еще читаете? Отлично. Теперь, когда мы отпугнули слабаков, давайте перейдем к делу.
КРАТКОЕ СОДЕРЖАНИЕ: Мы соберем [столько-то денег], потом [сделаем то-то и то-то] и увеличим прибыль акционеров. Хотите подробности? Читайте дальше.

ВСТУПЛЕНИЕ: [Этот тренд], о котором знает каждая собака, и [тот тренд], такой невероятно заумный, что вы сейчас, вероятно, впервые о нем прочли, вместе с [во-о-он теми трендами], которые на первый взгляд кажутся совершенно несвязанными, привели нас к (защищенному коммерческой тайной, патентом, авторским правом и торговой маркой) прозрению, что мы можем увеличить прибыль акционеров [делая то-то и то-то]. Нам потребуется $ [ крупная сумма] и [довольно скоро] мы превратим ее в $ [еще более крупная сумма], если только не [рак на горе свистнет].
ДЕТАЛИ:
Стадия 1: Приняв обеты трезвости и безбрачия, сменив все наше материальное достояние на холщовое рубище, мы (см. прилагающиеся резюме) переедем в скромный комплекс из поломанных картонных коробок в центральной части пустыни Гоби, где земля настолько дешевая, что нам еще станут приплачивать, и прибыль акционеров начнет расти еще до начала настоящей работы. На дневном рационе, состоящем из горсти сырого риса и чашки воды, мы начнем [делать то-то и то-то].
Стадии 2, 3, 4, ... n — 1: Мы будем [делать то-то и то-то], неизменно увеличивая в процессе прибыль акционеров, если только [Земля не столкнется с метеоритом диаметром в тысячу миль, в каковом случае некоторые допущения придется пересмотреть: см. табл. 397–413].
Стадия n: Еще не высохнут чернила на наших нобелевских дипломах, как мы конфискуем имущество конкурентов и тех идиотов, которые вложились в их жалкие фирмы. Самих конкурентов мы продадим в рабство. Вся прибыль поступит акционерам, которые вряд ли это заметят, потому что, как явствует из табл. 265, компания к тому времени будет круче Британской империи эпохи расцвета.
ТАБЛИЦЫ: [Множество листов, заполненных убористыми цифирками и снабженные для наглядности графиками, которые все экспоненциально взлетают до небес, если не считать некоторых псевдослучайных колебаний, введенных для большего правдоподобия.]
РЕЗЮМЕ: Посмотрите «Великолепную семерку», там есть все, что необходимо о нас знать. По-хорошему вы должны сами приползти на коленях и со слезами выпрашивать привилегию платить нам зарплату.

Для Рэнди и остальных участников корпорации бизнес-план — Тора, график работы, философский трактат, динамический, живой документ. Его таблицы — палимпсесты, связанные с банковскими счетами и финансовыми документами компании, они автоматически обновляются при поступлении или списании денег. Этим занимается Берил. Ави занимается словами — основным, абстрактным планом и конкретными частностями, которые наполняют таблицы. Все это тоже меняется от недели к неделе, по мере того, как Ави получает сведения из статей в азиатском «Уолл-стрит джорнал», разговоров с правительственными чиновниками в засиженных мухами шенженских караоке-барах, материалов космофотосъемки и заумных технических журналов по оптоволоконным технологиям. Кроме того, Ави переваривает все, что предлагают Рэнди и другие участники корпорации, и вносит это в бизнес-план. Раз в квартал они фиксируют текущее состояние бизнес-плана, слегка лакируют его и рассылают инвесторам.
План № 5 будет разослан на первую годовщину компании. Предварительный черновик пришел недели две назад по электронной почте, и Рэнди не стал его читать, сочтя, что и так все знает. Однако в последнее время он по кое-каким намекам сделал вывод, что прочитать все-таки стоит.
Поэтому врубает ноутбук, подключает его к телефонной розетке, открывает программу удаленного доступа и набирает калифорнийский номер. Дозванивается с ходу — отель современный, а в Кинакуте современная телефонная связь.
В маленьком, душном, постоянно темном, пахнущем нагретой пластмассой закутке посреди безликого офиса, снимаемого компанией «Новус Ордо Секлорум Системс инкорпорейтед» и зажатого между юридической конторой и турбюро в банальнейшем здании диско-эры на одной из улиц Лос-Альтоса, штат Калифорния, просыпается модем и выдавливает из себя шум. Сигнал путешествует по дну Тихого океана в виде вспышек в стеклянной нити, такой прозрачной, что, будь океан из такого же материала, с Гавайев была бы видна Калифорния. Информация попадает в компьютер Рэнди, который в ответ тоже выплевывает шум. Модем в Лос-Альтосе вместе примерно с пятью другими присоединен к задней панели писишного системного блока, который работает день и ночь вот уже восемь месяцев. Семь месяцев назад отключили монитор, потому что он только зря жрал электричество. Потом Джон Кантрелл, который сам и поставил компьютер в офисе компании, забрал монитор, поскольку одному из программистов, работающих над новой версией «Ордо», потребовался второй экран. Через некоторое время Рэнди отключил мышь и клавиатуру, потому что без монитора в систему может попасть только плохая информация. Теперь слабо жужжащий белый обелиск стоит без всякого человеческого интерфейса, только зеленый светодиод одноглазо пялится на темный пейзаж пустых коробок из-под пиццы.
Однако есть толстый коаксиальный кабель, соединяющий его с Интернетом. Компьютер Рэнди некоторое время общается с ним в терминах PPP-протокола, то есть соединения «точка с точкой», а затем тоже становится частью Интернета; он может посылать информацию в Лос-Альтос, и одинокий компьютер, который зовут Надгробие, или, для краткости, просто Гроб, перенаправит ее в сторону нескольких десятков миллионов других машин.
Гроб, или tombstone.epiphyte.com (под таким именем его знает Интернет), влачит жалкое существование почтовых ящиков и кэша для файлов. Он не делает ничего такого, с чем тысячи он-лайновых сервисов не справились бы лучше и дешевле. Однако Ави, с его гениальной способностью воображать наихудшие мыслимые сценарии, потребовал, чтобы у них была собственная машина и чтобы Рэнди и остальные строчка за строчкой прочли исходники ядра операционки на предмет дырок в защите. В каждой витрине каждого книжного магазина Сан-Франциско и окрестностей громоздятся тысячи экземпляров трех книг о том, как знаменитый хакер перехватил контроль над парой известных он-лайновых сервисов. Соответственно, если корпорация «Эпифит» будет пользоваться этими сервисами для секретных файлов, они не смогут с чистым сердцем сказать акционерам, что приняли все необходимые меры безопасности. Отсюда tombstone.epiphyte.com.
Рэнди вводит логин, пароль и проверяет почту: сорок семь сообщений, в том числе двухдневной давности от Ави (avi@epiphyte.com), у которых в теме стоит: epiphyteBizPlan.5.4.ordo. Бизнес-план корпорации «Эпифит», пятый вариант, четвертая версия, в формате, который может прочесть только [Новус] Ордо [Секлорум], программа, принадлежащая одноименной компании, но написанная, в своей основе, Джоном Кантреллом.
Рэнди велит компьютеру загрузить файл. Это надолго, и он прокручивает остальную почту, смотрит отправителя, тему, размер, пытаясь для начала прикинуть, что можно убить, не читая.
Два сообщения выделяются тем, что заканчиваются на aol.com. Это такое место, где живут родители с детьми, но не студенты и не компьютерщики. Оба письма от адвокатши, которая пытается уладить их с Чарлин финансовый раздел по возможности без обид. У Рэнди сразу подскакивает давление, миллионы капилляров в мозгу опасно вздуваются. Однако файлы коротки, темы выглядят не страшно. Он успокаивается и решает пока об этом не думать.
Пять сообщений посланы с серверов, названия которых ему до боли знакомы. Это та университетская компьютерная сеть, которую Рэнди прежде администрировал. Админы, принявшие у него бразды правления, раньше задавали вопросы вроде «Где лучше всего заказывать пиццу?» или «Куда ты запрятал скрепки?» Теперь они шлют куски кода, написанные несколько лет назад, с вопросом: «Это ошибка или что-то жутко умное, до чего я не могу допереть?» На них Рэнди тоже решает пока не отвечать.
Еще десяток писем от друзей, часть просто повторяет сетевую байку, которую Рэнди читал уже раз сто. Еще с десяток от партнеров по корпорации «Эпифит», в основном насчет того, кто когда прилетает на завтрашние переговоры в Кинакуту.
Остается еще десяток сообщений в категории, которой не существовало неделю назад, пока не вышел свежий номер журнала «Тьюринг» со статьей про Кинакутский информационный рай и фотографией Рэнди на обложке. Ави старательно пропихивал эту статью, рассчитывая помахать ею перед инвесторами па грядущих переговорах. «Тьюринг» настолько красочный журнал, что его и смотреть-то невозможно без очков сварщика, поэтому редактор потребовал картинку. Фотографа отрядили в Крипту, но она оказалась неинтересной по колориту. Начался переполох. Фотограф вылетел в Манилу и застиг Рэнди на палубе, рядом с мотком оранжевого кабеля, на фоне курящегося вулкана. На прилавках журнал должен был появиться только в следующем месяце, но в Сети статью вывесили неделю назад и тут же принялись активно обсуждать в рассылке Тайных Обожателей. Это такое место, куда крутые программеры вроде Джона Кантрелла заходят поговорить о последних хэш-алгоритмах и генераторах псевдослучайных чисел. Поскольку на фотографии был Рэнди, его ошибочно приняли за идейного вдохновителя. В итоге почтовый ящик наполнился совершенно новыми сообщениями: непрошеными советами и критикой фанатов криптографии со всего мира. Сейчас во «Входящих» было четырнадцать таких писем, восемь от человека, или людей, который (которые) подписываются «адмирал Исороку Ямамото».
Есть соблазн не открывать их совсем, но загвоздка в том, что значительная часть Тайных Обожателей раз в десять умнее Рэнди. Можете когда угодно подписаться на их рассылку и увидеть, как математик из России килобайт за килобайтом ругается с математиком из Индии по поводу какой-то заумной частности в теории простых чисел, а восемнадцатилетний сосунок из Кембриджа каждые несколько дней влезает с еще более заумным объяснением, почему оба не правы.
Письма от такого рода людей Рэнди старается по крайней мере проглядывать. Тип, который подписывается адмирал Исороку Ямамото, или числом 56 (шифр, означающий Ямамото), немного его смущает. Впрочем, если люди политически с приветом, это не мешает им сечь в математике.

Кому: randy@tombstone.epiphyte.com
От: 56@laundry.org
Тема: информационный рай
У тебя размещен где-нибудь открытый ключ? Я бы хотел переписываться с тобой по мылу, но не хочу, чтобы нас читал Пол Комсток :) Если захочешь ответить, мой открытый ключ:

—НАЧАЛО МАССИВА ОТКРЫТОГО КЛЮЧА ОРДО —
(строки и строки абракадабры)
— КОНЕЦ МАССИВА ОТКРЫТОГО КЛЮЧА ОРДО —
Идея информационного рая хороша, однако имеет некоторые ограничения. Что, если Филиппинское правительство перекроет ваш кабель? Что, если добрый султан передумает, решит национализировать ваши компьютеры, прочтет все файлы? Нужен не ОДИН информационный рай, а целая СЕТЬ — более устойчиво. Как Интернет устойчивее одного компьютера.
Подписано:
Адмирал Исороку Ямамото, который подписывает свои сообщения

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(строки и строки абракадабры)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

Рэнди закрывает письмо, не отвечая. Ави не хочет, чтобы они общались с Тайными Обожателями — неровен час кто-нибудь начнет вопить, что сперли его идеи. Поэтому в таких случаях отправляется стандартная отписка, за которую Ави заплатил десять тысяч долларов юристу по интеллектуальной собственности.
Следующее сообщение он читает только из-за обратного адреса:

От: root@pallas.eruditorum.org

В компьютерах, работающих под UNIX'oм, «root» — самый богоподобный из всех пользователей: он может читать, стирать и редактировать любые файлы, запускать любые программы, подключать новых пользователей и отсоединять старых. «Root» в заголовке письма — все равно что «Президент» или «Генерал». Рэнди сам был рутом в системах, из которых иные стоили десятки миллионов долларов, и профессиональная вежливость требует хотя бы открыть письмо.

Я прочел о Вашем проекте.
Зачем Вы это делаете?

и массив цифровой подписи Ордо.
Похоже, кому-то вздумалось затеять философский диспут. Спорить с анонимным незнакомцем в Сети — гиблое дело; обычно рано или поздно выясняется, что это школьник, располагающий неограниченным свободным временем. Однако «root» в адресе означает, что это либо администратор крупной компьютерной системы, либо (что вероятнее) у него на столе стоит Финукс бокс. Даже домашний пользователь Финукса на голову выше среднего дилетанта, болтающегося в Сети.
Рэнди открывает терминальное окно, печатает:

whois eruditorum.org

и через секунду получает массив текста от InterNIC:

eruditorum.org (Societas Eruditorum)

и почтовый адрес: а/я в Лейпциге, Германия.
Дальше перечислены несколько контактных номеров. У всех международный код Сиэтла. Однако первые три цифры после международного кода кажутся Рэнди знакомыми: это шлюз службы переадресации, популярной у людей, которые много путешествуют — она перебрасывает вашу голосовую почту, факсы и все такое туда, где вы сейчас находитесь.
Прокрутив дальше, Рэнди находит:

Последнее обновление: 18 ноября 1998
Запись создана: 1 марта 1990

«90» сразу бросается в глаза. По интернетовским меркам это доисторическая дата. Она означает, что Societas Eruditorum здорово всех опередили, особенно для Лейпцига, который тогда входил в состав Восточной Германии.

Domain servers in listed order:
NS. SF. LAUNDRY.ORG

...и доменное имя laundry.org, службы, которой Тайные Обожатели пользуются, чтобы посылать анонимные сообщения, которые невозможно отследить.
Это абсолютно ничего не дает, но Рэнди не может успокоиться на том, что отправитель — скучающий старшеклассник Надо, наверное, послать символический ответ. Однако есть риск, что все это выльется в какое-нибудь деловое предложение, скорее всего от вшивой высокотехнологической фирмочки, которая ищет деньги.
В последней версии бизнес-плана наверняка объясняется, зачем «Эпифит(2)» строит Крипту. Можно скопировать кусок и вставить в ответ. Формулировки скорее всего расплывчатые, для ублажения акционеров; может быть, это отпугнет неизвестного. Рэнди щелкает по значку «Ордо» — пирамида и глаз. На экране открывается маленькое текстовое окно с приглашением. У «Ордо» есть графический интерфейс, но Рэнди презирает меню и кнопки. Он печатает:

>decrypt epiphyteBizPlan.5.4.ordo

и компьютер отвечает:

удостоверьте свою личность: введите пароль или «bio» для выбора биометрического подтверждения.

Чтобы расшифровывать файл, «Ордо» нужен закрытый ключ, все 4096 битов. Ключ хранится у Рэнди на жестком диске. Однако враги могут пробраться в номер и прочесть содержимое жестких дисков, поэтому ключ тоже зашифрован. Для его расшифровки «Ордо» нужен ключ к ключу. Этот второй ключ (единственная уступка Кантрелла удобству пользователя) представляет собой фразу: цепочку слов, которую легче запомнить, чем 4096-значное двоичное число.
Рэнди последний раз менял пароль, когда читал какие-то очередные военные мемуары. Он печатает:

> с хриплыми криками «банзай» пьяные японцы толпой хлынули из окопов; их штыки и мечи сверкали в свете наших прожекторов.

и нажимает «ввод». «Ордо» отвечает:

неверный пароль.
заново введите пароль или «bio» для выбора биометрического подтверждения.

Рэнди чертыхается и еще несколько раз вводит ключевую фразу, слегка меняя пунктуацию. Все без толку.
В отчаянии, а также от любопытства он вводит:

bio

и программа отвечает:

невозможно отыскать файл биометрической конфигурации. Обратись к Кантреллу :-/

Это нечто странное. В «Ордо» нет встроенной биометрической авторизации, и сообщения об ошибке не отсылают к Джону Кантреллу или кому другому. Очевидно, Кантрелл написал плагин, небольшой встраиваемый модуль, для своих друзей из «Эпифита(2)».
— Отлично, — говорит Рэнди и набирает номер Кантрелла. Отель современный. Он попадает на голосовую почту. Кантрелл не поленился оставить информативное сообщение.
«Это Джон Кантрелл из «Новус Ордо Секлорум» и корпорации «Эпифит». Для тех, кто дозвонился по универсальному номеру и соответственно не знает, где я: так вот, я в гостинице «Фут Меншн» в султанате Кинакута — посмотрите в подробном атласе. Сейчас четыре часа дня, вторник, двадцать второе марта. Я скорее всего в «Ядре и картечи».

Гостиничный бар «Ядро и картечь» оформлен в пиратской тематике, что совсем не так пoшло, как может показаться со слов. Помимо других музейных раритетов, его украшают несколько бронзовых пушек, по всей видимости, настоящие. Джон Кантрелл сидит за угловым столиком и вместе с черной ковбойской шляпой отлично вписывается в обстановку. На столике — открытый ноутбук и супница, в каких здесь подают ромовый пунш. Метровая соломинка соединяет супницу и Кантрелла. Джон тянет пунш и печатает. От стойки за ним ошалело наблюдают четыре китайских бизнесмена слегка бандитского вида; при появлении Рэнди с ноутбуком в той стороне проносится гул: теперь их двое!
Кантрелл поднимает голову и улыбается, что у него всегда выходит довольно зверски. Они с Рэнди торжественно жмут друг другу руку, чувствуя себя Стэнли и Ливингстоном, хотя всего лишь прилетели на «Боинге».
— Классный загар, — ехидно замечает Кантрелл, только что не крутя ус.
Рэнди, застигнутый врасплох, вздрагивает, дважды начинает говорить, потом в свое оправдание только трясет головой. Оба хохочут.
— Я загорел на палубе, — говорит Рэнди, — а не в гостиничном бассейне. Последние две недели я только и делал, что затыкал дырки.
— Надеюсь, ничего такого, что угрожало бы прибыли акционеров, — с каменной миной выдает Кантрелл.
Рэнди говорит:
— Тебе, вижу, загорать не пришлось.
— С моей стороны все отлично, — отвечает Кантрелл. — Как я и предсказывал, куча Тайных Обожателей хочет работать над информационным раем.
Рэнди заказывает «Гиннесс».
— Еще ты предсказывал, что половина из них окажется разгильдяями или шизиками.
— Я ж их не на работу брал, — парирует Кантрелл. — Всякой заумью занимался Эб, так что несколько временных затыков мы проскочили.
— Крипту видел?
Кантрелл поднимает бровь и безупречно изображает параноидальный испуг.
— Точь-в-точь бункер Объединенного Командования ПВО в Колорадо-Спрингс, — шепчет он.
— Ага! — Рэнди смеется. — Гора Шайенн.
— Слишком уж она большая, — замечает Кантрелл. Они с Рэнди думают об одном и том же.
Поэтому Рэнди нарочно говорит наоборот:
— У султана все с размахом. Большие конные портреты в большом аэропорту.
Кантрелл мотает головой.
— Министерство информации — серьезный проект. Султан не с потолка его взял. Идею родили технократы.
— Я слышал, при активном участии Ави.
— Да на здоровье. Главное, что за этим стоят люди вроде Мохаммеда Прагасу, выпускники Стэнфорда, Оксфорда и Сорбонны. Все до последнего винтика спроектировали немцы. Крипта — не очередной памятник султану.
— Да, не просто гигантомания, — соглашается Рэнди, вспоминая прохладный машинный зал, который Том Говард строит в тысяче футов под тропическим лесом.
— Значит, этому размаху должно быть рациональное объяснение.
— Может, оно есть в бизнес-плане? — предполагает Рэнди.
Кантрелл пожимает плечами. Он тоже еще не читал.
— Первый план был последним, который я проштудировал от корки до корки. Год назад, — сознается Рэнди.
— Хороший был план* [Кантрелл имеет в виду, что первый бизнес-план принес им миллион долларов стартового капитала от венчурной фирмы из Сан-Матео под названием «Спрингборд Груп».], — говорит Кантрелл.
Рэнди меняет тему.
— Пароль забыл. Надо сделать эту твою биометрию.
— Здесь слишком шумно, — говорит Кантрелл. — Она слушает твой голос, разлагает на всякие Фурье-шмурье, запоминает некоторые ключевые цифры. Сделаем потом у меня в номере.
Рэнди чувствует, что надо объяснить, почему он в последнее время не смотрел электронную почту.
— Совсем закрутился в Маниле с «АВКЛА» и всеми делами.
— Что такое?
— Работа простая, — говорит Рэнди. — Есть большой кабель от Тайваня к Лусону. На каждом конце по маршрутизатору. Есть серия коротких межостровных кабелей, которые «АВКЛА» прокладывает на Филиппинах. Как ты понимаешь, каждый кабель начинается и заканчивается маршрутизатором. Моя задача так их запрограммировать, чтобы данные бесперебойно поступали с Тайваня в Кинакуту.
Кантрелл отводит взгляд, боясь, что заскучает. Рэнди чуть не хватает его за грудки, потому что это вовсе не скучно!
— Джон! Ты — крупная компания по обслуживания кредитных карточек!
— О'кей. — Кантрелл с некоторым беспокойством смотрит на Рэнди.
— Ты хранишь свои данные на Кинакуте. Тебе надо загрузить терабайт важнейшей информации. Твои зашифрованные данные со скоростью гигабайт в секунду качаются себе с Филиппин на Тайвань, а оттуда в Штаты... — Рэнди делает паузу и встряхивает бутылкой, нагнетая напряжение. — И тут возле Себу переворачивается паром.
— И?
— Через десять минут сто тысяч филиппинцев одновременно хватаются за телефон.
Кантрелл кроме шуток хлопает себя по лбу.
— Черт!
— Дошло-таки! Я конфигурировал сеть так, чтобы при любом возможном раскладе данные по-прежнему качались в кредитную компанию. Может быть, медленнее, но качались.
— Теперь я понимаю, что тебе пришлось попотеть.
— Поэтому меня волнуют главным образом маршрутизаторы. Они вообще-то хорошие, однако не настолько мощные, чтобы обслуживать такую Крипту или оправдать ее экономически.
— У Ави и Берил выходит, — говорит Кантрелл, — что коммуникационные услуги Крипте будет предоставлять не только «Эпифит».
— Но мы тянем сюда кабель с Палавана.
— Окружение султана развило бурную деятельность, — говорит Кантрелл. — Ави и Берил отделываются общими словами, но я побеседовал с Томом, погадал на кофейной гуще и предполагаю, что на Кинакуту тянут еще кабель, а то и два.
— Ни фига себе, — говорит Рэнди. Это все, что приходит ему в голову. — Ни фига себе. — Он залпом выпивает половину «Гиннесса». — Похоже на правду. Получилось с нами, получится и с другими операторами связи.
— Нас использовали в качестве катализатора, — говорит Кантрелл, — чтобы привлечь других.
— Ну... вопрос такой: по-прежнему ли нужен кабель с Палавана?
— Ага, — говорит Кантрелл.
— В смысле нужен?
— Нет. Я хотел сказать, ага, это вопрос.
Рэнди задумывается.
— Вообще-то с точки зрения твоей фазы операции это может быть и к лучшему. Большая Крипта — больше работы в перспективе.
Кантрелл поднимает брови. Он понимает, что Рэнди наверняка обидно. Тот откидывается на спинку стула и говорит:
— Мы и раньше спорили, стоит ли возиться с прокладкой кабеля и маршрутизаторами на Филиппинах.
Кантрелл отвечает:
— В бизнес-плане всегда утверждалось, что кабель на Филиппинах выгодно тянуть вне зависимости от Крипты.
— Почему так утверждалось в бизнес-плане, понятно, — говорит Рэнди, — чтобы оправдать наше участие.
Больше слов не требуется. Они некоторое время пристально смотрят друг на друга, отключившись от всего остального в баре, потом разом откидываются назад, потягиваются и смотрят по сторонам. И вовремя. В бар как раз входит Гото Фурудененду с толпой, как полагает Рэнди, инженеров-строителей — подтянутых, аккуратно подстриженных японцев лет тридцати-сорока. Рэнди улыбкой приглашает Гото за столик, потом машет официанту и заказывает несколько больших бутылок ледяного, аж зубы сводит, японского пива.
— Кстати, — вспоминает Рэнди, — меня одолевают Тайные Обожатели.
— Умные, маниакально одержимые люди — костяк криптологии, — заявляет Кантрелл, — хотя многие из них плохо разбираются в бизнесе.
— Или, наоборот, слишком хорошо, — говорит Рэнди, чувствуя легкий осадок раздражения: он пришел в «Ядро и картечь» отчасти и для того, чтобы ответить на вопрос, заданный root@eruditorum.org («Зачем Вы это делаете?»), но так ничего и не выяснил. Скорее еще больше запутался.
Тут к ним подсаживаются Гото с компанией. Одновременно входят Эберхард Фёр и Том Говард. Происходит обмен карточками в количестве число сочетаний из эн по два. По-видимому, этикет требует, чтобы все основательно накачались. Рэнди поставил японцам пива, они не хотят уступать в щедрости. Столики сдвигаются, воцаряется атмосфера всеобщего дружелюбия. Эб считает, что тоже должен заказать каждому пива. Скоро все вырождается в караоке. Рэнди встает и поет: «Ты, я и собака Бу». Хороший выбор, потому что песня не требует особого чувства. Или певческих данных.
В какой-то момент Том Говард наклоняется к Кантреллу, чтобы лучше кричать в ухо, и кладет лапищу на спинку его стула. Одинаковые евтропийские браслеты с надписью «Привет, доктор, заморозь меня так-то и так-то» вызывающе блестят. Рэнди боится, что японцы заметят и начнут задавать вопросы, на которые еще поди ответь. Том что-то напоминает Кантреллу (есть люди, которых все всегда зовут по фамилии). Кантрелл кивает и украдкой смотрит на Рэнди. Рэнди ловит его взгляд. Кантрелл виновато опускает глаза и начинает крутить в руках бутылку с пивом. Том продолжает с любопытством глядеть на Рэнди. Наконец все трое встают и перебираются в другой угол, подальше от караоке.
— Значит, ты тоже знаешь Эндрю Лоуба, — говорит Кантрелл с некоторым боязливым уважением, как если бы Рэнди когда-то голыми руками убил человека и ни разу об этом не обмолвился.
— Да, — говорит Рэнди, — насколько вообще можно знать такого персонажа.
Кантрелл с чрезмерным вниманием изучает пивную этикетку с обещанием каких-то призов. Том подхватывает разговор:
— У вас был какой-то общий бизнес?
— Вообще-то нет. А можно спросить, откуда вы в курсе? В смысле, как вы вообще услышали про Эндрю Лоуба? Из-за истории с Дигибомбером?
— Да нет, позже. Энди стал заметной фигурой в кругах, где вращаемся мы с Томом, — говорит Кантрелл.
— Я могу представить себе Энди только в кругу робинзонов-любителей или людей, верящих, что над ними в детстве совершали ритуальное насилие.
Рэнди произносит фразу механическим голосом, как телетайп, выдающий прогноз погоды. Наступает пауза.
— Это позволяет восполнить кой-какие пробелы, — говорит наконец Том.
— Что ты подумал, когда ФБР устроило обыск в его хижине? — спрашивает Кантрелл. К нему вновь вернулась способность улыбаться.
— Не знал, что и думать, — отвечает Рэнди. — Помню, смотрел в новостях, как федералы выносят из шалаша коробки с вещественными доказательствами, и думал, что в этих бумагах есть и мое имя. Но в ходе следствия оно так и не всплыло.
— ФБР на тебя вышло? — спрашивает Том.
— Нет. Думаю, они просмотрели бумаги, быстро убедились, что Энди — не Дигибомбер, и вычеркнули его из списка подозреваемых.
— Ну так вот, вскоре после этого Энди Лоуб объявился в Сети, — говорит Кантрелл.
— Верится с трудом.
— Мы тоже сперва не поверили. Я хочу сказать, мы получали его манифесты — отпечатанные на серой бумаге из вторсырья вроде туалетной.
— Какими-то органическими чернилами на водной основе, которые сшелушивались, как черная перхоть, — добавляет Том.
— Мы еще шутили, что Энди нам все запорошил своей парашей, — говорит Кантрелл. — Когда какой-то Энди Лоуб начал размещать тирады в рассылке Тайных Обожателей и в новостной группе Евтропии, мы подумали, что это розыгрыш. Решили, что кто-то с блеском пародирует его стиль.
— Но все продолжалось день за днем, потом начались дискуссии, и тут мы поняли, что это и впрямь он, — говорит Том.
— И как это совмещается с его ненавистью к технике?
Кантрелл:
— Он говорит, что всегда считал компьютеры средством разобщения людей и атомизации общества.
Том:
— Однако оказавшись подозреваемым номер один в деле Дигибомбера, поневоле ознакомился с Интернетом, который, соединив компьютеры вместе, в корне их изменил.
— О господи! — вырывается у Рэнди.
— И он думал про Интернет, занимаясь тем, чем там занимается Энди Лоуб, — продолжает Том.
Рэнди:
— Сидя голым по шею в горном ручье и свертывая шеи мускусным крысам.
Том:
— И пришел к выводу, что компьютеры — это средство объединения общества.
Рэнди:
— И что именно Энди Лоуб его объединит?
Кантрелл:
— Ну, примерно так.
Рэнди:
— Выходит, он стал евтропийцем?
Кантрелл:
— Не совсем. Скорее он обнаружил в рядах евтропийцев трещину, о которой мы не подозревали, и возглавил группу отколовшихся.
Рэнди:
— Мне казалось, что евтропийцы — убежденные индивидуалисты и либертарианцы.
— Да, да! — говорит Кантрелл. — Однако основное положение евтропианства — что технология сделала нас постлюдьми. Что Homo sapiens плюс технология — совершенно новый вид: бессмертный, вездесущий благодаря Сети и движущийся к всемогуществу. Так вот, первыми об этом заговорили либертарианцы.
Том:
— Однако идея привлекла самых разных людей, в том числе Энди Лоуба. В один прекрасный день он прорезался и начал вещать про коллективный разум.
— И, ясное дело, тут же получил отлуп от большинства евтропийцев, для которых это как красная тряпка, — говорит Кантрелл.
Том:
— Не унявшись, он постепенно обзавелся сторонниками. Похоже, значительная часть евтропийцев не так уже держится за либертарианство. Идея коллективного разума им понравилась.
— И теперь Энди — вожак этой фракции? — спрашивает Рэнди.
— Наверное, — отвечает Кантрелл. — Они откололись и создали свою группу новостей. Последние месяцев шесть мы о них не слышали.
— Как же вы узнали про Энди и меня?
— Он по-прежнему иногда проявляется в рассылке Тайных Обожателей, — объясняет Том. — В последнее время они активно обсуждают Крипту.
Кантрелл говорит:
— Как только он узнал, что этим занимаетесь вы с Ави, он накатал двадцать-тридцать килобайт убористым шрифтом. Не в самом хвалебном тоне.
— О черт. Чего ему еще? Он выиграл дело. Оставил меня без штанов. Зачем пинать мой труп? — Рэнди стучит себя в грудь. — Ему чего, на работу ходить не надо?
— Он теперь вроде как адвокат, — сообщает Кантрелл.
— Ха! Воображаю.
— Он нас обличает, — говорит Том. — Капиталистический грабеж. Атомизация общества. Создание безопасных условий для наркодельцов и клептократов «третьего мира».
— Ну, по крайней мере тут он угадал. — Рэнди доволен, что получил наконец ответ на вопрос, зачем они строят Крипту.

РЕТРОГРАДНЫЙ МАНЕВР

Сио — гиблая трясина. Те, кто уже отдал жизнь за Императора, вытесняют тех, кто еще только собирается. Каждый день из-за солнца вылетают странные двухвостые американские самолеты, убивают солдат шквальным огнем, одуряющими разрывами бомб. Поэтому они спят в открытых могилах и выползают лишь ночью. Однако в окопах гнилая вода кишит всякой враждебной живностью, а с заходом солнца зуб на зуб не попадает из-за холодных дождей. Все в двадцатой дивизии знают, что не выберутся живыми с Новой Гвинеи. Вопрос, что лучше: сдаться австралийцам на пытки и смерть? Взорвать себя гранатой? Сидеть здесь, где днем убивают бомбы, ночью — малярия, дизентерия, озерная лихорадка, холод и истощение? Или идти двести миль через горы и реки в Маданг, что самоубийственно даже в мирное время, при наличии еды и лекарств?..
Приказ именно таков. В Сио прилетел генерал Адати — первый свой самолет за несколько недель, — приземлился на изрытом колеями септическом поле, которое зовется тут летным, и приказал уходить через горы. Полк за полком хоронит мертвецов, собирает остатки оборудования и скудные припасы, дожидается темноты и движется к горам. Путь можно найти по запаху — дизентерийной вони и смраду трупов, которые передовые полки оставляют за собой, как хлебные крошки.

Предыдущая страница 12 Следующая страница


13 Нил Стивенсон

Командование остается до последнего, и с ним связисты: без мощного радиопередатчика и шифровального оборудования генерал — не генерал, дивизия — не дивизия. Наконец и они сворачиваются и начинают разбирать передатчик на возможно более мелкие части. Дивизионный передатчик — огромный, мощный, такой, чтобы пробивал до ионосферы. В нем есть генератор, трансформаторы и другие железки, которые невозможно сделать более легкими. Связистам свои бы скелеты перетащить через горы и вздувшиеся реки, так они поволокут на горбу разобранный передатчик, канистры с горючим, трансформаторы...
Еще есть огромный жестяной чемодан с кодовыми книгами. Даже сухие, они непомерно тяжелы, а сейчас еще и намокли. Тащить на себе — немыслимо. Инструкция требует сжечь.
Связистам двадцатой дивизии не до шуток, даже черный солдатский юмор им сейчас чужд. Если их еще может что-нибудь рассмешить, так это идея жечь намокшие книги в болоте под проливным дождем. Если бы полить авиационным топливом... но столько топлива просто нет. К тому же на столб дыма слетелись бы P-38, как комары на человеческое тепло.
Жечь и не надо. На Новой Гвинее все само гниет и разлагается со свистом; долговечны лишь камни и осы. Связисты отрывают от книг обложки, чтобы потом предъявить начальству, остальное заталкивают в чемодан и закапывают на берегу особенно зловредной реки.
Идея не очень удачная. Однако они долго пробыли под бомбежкой. Даже если тебя не задевает осколками, ударная волна — это каменная стена, мчащаяся со скоростью семьсот миль в час. В отличие от настоящей каменной стены она проходит сквозь тело, как вспышка света сквозь стеклянную статуэтку. По пути она перестраивает все в организме вплоть до митохондрий, нарушает каждый процесс в каждой клетке и, кроме прочего, те связи в мозгу, которые отвечают за отсчет времени и жизненный опыт. Несколько взрывов, и сознание превращается в бессмысленный клубок оборванных нитей. Связисты уже в меньшей степени люди, чем когда уходили на фронт. От них нельзя ждать рассудительности. Они закидывают чемодан грязью не для того, чтобы надежно его спрятать, а скорее ритуально, из уважения к странной информации в книгах.
Взвалив на плечи железяки и рис, солдаты бредут к горам. Тропу, протоптанную товарищами, на глазах затягивают джунгли. Версты — тела, смрадные поля сражений между ошалевшими полчищами неизвестных науке микробов, насекомых, зверей и птиц.

ВЧРП

Мачту пеленгатора устанавливают раньше, чем над новой штаб-квартирой подразделения 2702 успевают настелить крышу, антенну закрепляют раньше, чем подводят к ней электричество. Уотерхауз старательно делает вид, что его это тревожит. Он дает рабочим понять: грандиозные танковые бои в африканской пустыне — конечно, модно и романтично, однако главное сражение войны (забывая, как всегда, про Восточный фронт) — это Битва за Атлантику. Чтобы выиграть Битву за Атлантику, надо топить немецкие подлодки; чтобы топить, их надо прежде найти, и хорошо бы не старым испытанным способом, когда наш конвой входит в их гущу и взлетает на воздух. Короче, братцы, антенна должна заработать как можно скорее.
Уотерхауз — не актер, но когда вторая пурга за неделю сносит антенну и он всю ночь ее чинит при свете гальванического люцифера, нужного эффекта, похоже, удается достичь. Прислуга замка всю ночь носит ему горячий чай с бренди, а строители, увидев утром залатанную антенну, громко кричат «ура!» Они настолько уверены, что спасают наших ребят в Северной Атлантике, что, узнав правду, скорее всего разорвали бы его в клочки.
Легенда про пеленгатор до смешного правдоподобна. Настолько, что, работай Уотерхауз на немцев, у него бы закрались подозрения. Антенна узконаправленной модели. Она ловит сильный сигнал, когда развернута к передатчику, слабый — во всех остальных случаях. Оператор дожидается, пока подводная лодка выйдет на связь с другими, и крутит антенну, добиваясь наиболее сильного сигнала: направление антенны дает пеленг. Два-три пеленга взятых с разных станций, позволяют методом триангуляции определить координаты подлодки.
Чтобы создать видимость, станция должна работать двадцать четыре часа в сутки, и это чуть не доканывает Уотерхауза в первые недели 1943 года. Остальные бойцы подразделения 2702 не прибывают в срок, и спектакль целиком ложится на его плечи.
Все в радиусе десяти миль — то есть практически все гражданское население Йглма, или, другими словами, весь йглмский народ — видят, как на мачте появилась антенна. Они не дураки; по крайней мере некоторые понимают: если антенна не крутится, то хрен от нее толку. Если она не крутится, значит, не работает. А в таком случае что, скажите на милость, творится в замке?
Значит, Уотерхауз должен крутить антенну. Он живет в часовне: спит (если вообще спит) в гамаке, натянутом на опасной высоте от пола (скрргы, как выяснилось, исключительно хорошо прыгают).
Если он будет спать днем, городские зеваки увидят, что антенна не поворачивается. Это плохо. Однако если он будет спать ночью, когда немцы отражают радиосигналы от ионосферы, связывая подлодки в Северной Атлантике с базами в Бордо и Лорьяне, по-настоящему серьезный наблюдатель (скажем, страдающий бессонницей слуга или немецкий шпион, притаившийся с биноклем в скалах) заподозрит, что неподвижная антенна — всего лишь ширма. Поэтому Уотерхауз спит пару часов на рассвете и пару на закате, а это не на пользу здоровью. Когда же он просыпается, ему совершенно нечего делать, кроме как просиживать за пультом восемь-двенадцать часов кряду, смотреть, как клубится морозный пар изо рта, вертеть антенну и вслушиваться — в тишину!
Он честно признает, что это свинство: жалеть себя, когда другие гибнут на фронте.
Ладно, так чем же заняться, чтобы не сойти с ума? Свои действия он знает назубок: направить антенну примерно к Западу и поворачивать туда-сюда по убывающей дуге, якобы ловя подводную лодку, потом на время оставить так и не сколько раз присесть для согрева. Он сменил флотскую форму на одеяние из теплой йглмской шерсти. Время от времени, через совершенно непредсказуемые промежутки, врывается кто-нибудь из слуг с кружкой бульона или чая или просто узнать, как дела, и сообщить, как им все тут гордятся. Раз в день он пишет стопку галиматьи — якобы результаты — и отсылает на военно-морскую базу.
Остальное время Уотерхауз думает о бабах и о математике. Одно мешает другому. Особенно после того, как пятидесятилетнюю многопудовую повариху Бланш прихватывает не то водянка, не то подагра, не то какая-то еще шекспировская хворь, и на ее место берут молоденькую, хорошенькую Маргарет.
От Маргарет голова окончательно идет кругом. Когда совсем невмоготу, он направляется в уборную (куда слуги не могут ворваться в неподходящий момент) и берет дело в свои руки. Однако Уотерхауз еще на Гавайях узнал, что самому — не то, что по-настоящему. Эффект слишком скоротечный.
Пока эффект еще сказывается, он успевает всерьез вгрызться в математику. Алан передал ему кое-какие свои заметки по избыточности и энтропии в связи с шифрацией голоса, которой занимается в Нью-Йорке. Уотерхауз прочитывает их и доказывает несколько симпатичных лемм, которые, увы, нельзя отослать Алану, не пренебрегая здравым смыслом и режимом секретности. Покончив с этим, берется за теоретическую криптологию. Поработав в Блетчли-парке, он понял, как мало пока разработана эта наука.
Немецкие подлодки слишком много болтают между собой, и командование немецкого флота отлично об этом знает. Спецотделы давно требовали усилить секретность и своего добились: немцы взяли на вооружение четырехдисковую «Энигму», чем на год посадили весь Блетчли-парк в лужу...
Чтобы принести Уотерхаузу еду, Маргарет должна идти через двор. Щеки ее успевают раскраснеться от мороза, пар изо рта окутывает лицо шелковой вуалеткой...
Лоуренс, прекрати! Тема сегодняшней лекции — четырехдисковая «Энигма», которую немцы зовут «Тритон», а союзники — «Акула». Используется со 2 февраля прошлого (1942) года, и только 30 октября, когда нашли севшую на мель немецкую подводную лодку U-559, в Блетчли-парке появились данные, необходимые, чтобы взломать код. Две недели назад, 13 декабря, Блетчли-парк наконец расколол «Акулу», и внутренние переговоры немцев вновь стали для союзников открытой книгой.
Первым делом выяснилось, что немцы взломали коды торгового флота и весь год знали, где точно искать конвои.
Все это Лоуренсу Притчарду Уотерхаузу передали несколько дней назад в сообщении, зашифрованном с помощью одноразового блокнота. Передали, потому что возник вопрос из области теории информации, то есть по его части: как скоро можно заменить взломанные коды, не показав немцам, что мы раскололи «Акулу»?
Уотерхаузу не надо долго ломать голову, чтобы понять: игра крайне рискованная. Единственный выход: сфальсифицировать некий инцидент, объяснивший бы немцам, почему мы внезапно разуверились в своих кодах. Он пишет записку Чаттану и начинает шифровать ее с помощью одноразового блокнота.
— У вас ничего не случилось?
Уотерхауз вскакивает и стремительно поворачивается. Сердце бешено стучит.
Это Маргарет. Она стоит, окутанная вуалью собственного дыхания, поверх платья и фартучка — серое шерстяное пальто, на руках, которые держат поднос с чаем и булочками, — серые вязаные варежки. Шерстью не закрыты только лицо и щиколотки. Щиколотки точеные; Маргарет не считает зазорным носить высокие каблуки. Лицо никогда не видело прямых солнечных лучей и вызывает в памяти взбитые девонширские сливки, посыпанные розовыми лепестками.
— Ой, позвольте я возьму! — выпаливает Уотерхауз и бросается вперед с неловкостью, рожденной страстью и переохлаждением. Забирая у Маргарет поднос, он нечаянно сдергивает одну варежку, и та падает на пол. «Простите!» — восклицает Уотерхауз и тут понимает, что никогда прежде не видел ее рук. На пальцах, которые он так неосторожно подставил холоду, — красный лак. Маргарет подносит руку ко рту, согревая ее дыханием. Огромные зеленые глаза смотрят спокойно и выжидательно.
— Простите?
— У вас ничего не случилось?
— Нет. А что?
— Антенна, — говорит Маргарет. — Уже час не крутится.
Уотерхауз едва не падает от растерянности.
Маргарет по-прежнему дышит на ладонь. Уотерхауз видит только зеленые глаза, которые теперь смотрят искоса, с шаловливым прищуром. Маргарет бросает взгляд на гамак.
— Спали на работе, да?
Первый порыв Уотерхауза — оправдаться, сказать правду, что он думал про баб и шифры, поэтому забыл про антенну. Однако Маргарет предложила более удачное объяснение.
— Виноват, — признается он. — Вчера засиделся допоздна.
— Чай вас взбодрит, — обещает Маргарет. Она снова смотрит на гамак и надевает варежку. — Как оно?
— Что оно?
— Спать в гамаке. Удобно?
— Очень удобно.
— А можно мне попробовать?
— M-м. Туда трудно взобраться — очень высоко.
— Ну вы ведь взобрались? — напоминает она с укоризной. Уотерхауз заливается краской.
Маргарет подходит к гамаку и сбрасывает туфли. Уотерхаузу больно смотреть, как она стоит босыми ногами на каменном полу не согревавшемся с тех пор, как берберийские корсары последний раз устроили здесь пожар. Ногти на ногах у нее тоже покрашены красным лаком.
— Мне ничуть не трудно, — говорит Маргарет. — Я — фермерская дочка. Подсадите!
Контроль над ситуацией окончательно потерян. Язык окостенел. Уотерхауз подходит, наклоняется, подставляет ладони. Маргарет встает на них, запрыгивает в гамак и с хихиканьем исчезает под ворохом теплых одеял. Гамак качается посреди часовни, как кадило, распространяя слабый аромат лаванды. Качается раз, другой. Пятый, десятый, двадцатый. Маргарет молчит и не шевелится. Уотерхауз стоит, как вмурованный. Впервые за несколько недель он не знает, что сейчас будет, и совершенно от этого теряется.
— Сказка, — мечтательно произносит Маргарет, потом из-под краешка серого одеяла наконец выглядывает ее личико. — Ой! — вскрикивает она и падает обратно на спину. От резкого движения гамак ведет в сторону.
— Что случилось? — упавшим голосом спрашивает Уотерхауз.
— Я боюсь высоты! — восклицает она. — Простите, Лоуренс, я должна была вас предупредить. Ничего, если я буду называть вас Лоуренс? — По голосу ясно, что отказ смертельно ее обидит. А разве может Уотерхауз обидеть миленькую, босоногую, беспомощную девушку, которая к тому же страшно напугана высотой.
— Конечно. Обязательно, — говорит он, однако прекрасно понимает, что мяч по-прежнему на его стороне поля. — Не могу ли я вам как-то помочь?
— Я была бы очень признательна, — отвечает Маргарет.
— Ну если бы вы слезли мне на плечи или что-нибудь в таком роде... — предлагает Уотерхауз.
— Нет, все равно боюсь.
Остается одно.
— Вы не поймете меня превратно, если я залезу наверх, чтобы помочь?
— Это было бы так благородно с вашей стороны! — восклицает она.
— В таком случае...
— Но я настаиваю, что бы вы прежде исполнили свой долг!
— Простите?
— Лоуренс, — говорит Маргарет, — когда я вылезу из этого гамака, я пойду на кухню мыть пол, который и без того, спасибо, совершенно чист. У вас, с другой стороны, важная работа, которая может спасти жизни сотням моряков! А вы уже и так, нехороший мальчик, заснули на работе. Я не разрешаю вам лезть наверх, пока не исправитесь.
— Что ж, — говорит Уотерхауз, — вы не оставляете мне выбора. Долг зовет.
Он расправляет плечи, поворачивается на каблуках и строевым шагом идет к столу. Скрргы уже доели почти все булочки, но он наливает себе чаю и продолжает шифровать письмо Чаттану: ТОЛЬКО ГРУБЫЙ СИЛОВОЙ ПОДХОД ПОМЕСТИТЕ КОДОВЫЕ КНИГИ НА КОРАБЛЬ ОТПРАВЬТЕ ЕГО С МУРМАНСКИМ КОНВОЕМ ДОЖДИТЕСЬ ТУМАНА И ВРЕЖЬТЕСЬ В НОРВЕГИЮ.
Шифровка с помощью одноразового блокнота — дело не быстрое. Делить на двадцать пять с остатком Уотерхауз может во сне, но не когда у него сперма из глаз брызжет.
— Лоуренс? Чем ты занят? — спрашивает Маргарет из гамака, который наверняка с каждой секундой становится все теплее и уютнее.
Уотерхауз украдкой поглядывает на ее сброшенные туфли.
— Готовлю донесение, — отвечает он. — Что проку от наблюдений, если их не отсылать?
— Верно, — задумчиво тянет Маргарет.
Сейчас самое время затопить железную печурку. Уотерхауз кладет немного драгоценного угля, ведомость и только что использованный листок из одноразового шифрблокнота.
— Сейчас станет тепло.
— Замечательно, — отзывается Маргарет. — Я вся дрожу.
Лоуренс воспринимает это как сигнал к началу спасательной операции. Через пятнадцать секунд он в гамаке с Маргарет. Оба ничуть не удивлены, что там очень тесно. Некоторое время они барахтаются, наконец Маргарет оказывается сверху, одна ее нога между ног Лоуренса.
Она потрясена, обнаружив, что у него стоит, и пристыжена что сразу не догадалась о его муках.
— Бедненький!.. Конечно! Какая же я нечуткая! Тебе наверняка здесь так одиноко! — Она целует его в щеку, что хорошо, поскольку он совершенно ошеломлен и не в силах пошевелиться.
— Мы, гражданские, должны всемерно помогать нашим защитникам, — объявляет Маргарет и тянется рукой, чтобы расстегнуть ему ширинку.
Потом она набрасывает на голову серое шерстяное одеяло и ныряет в новую позицию. Лоуренс Притчард Уотерхауз ошеломлен тем, что происходит дальше. Он из-под полуприкрытых век смотрит в потолок часовни и благодарит Бога, пославшего ему явную немецкую шпионку и ангела милосердия в одной очаровательной упаковке.
Когда все позади, он открывает глаза и глубоко вдыхает холодный атлантический воздух. Все вокруг выглядит необыкновенно четким. Очевидно, с помощью Маргарет его производительность на криптологическом фронте достигнет невиданных высот — если только он убедит ее приходить снова.

СТРАНИЦЫ

На ипподроме «Аскот» в Брисбене давно уже не скачут лошади. На поле — мельтешение хаки, трава вытоптана солдатскими ногами. Сортиры перемежаются с палатками полевых кухонь. Три смены в день проходят по беговой дорожке мимо притихших пустых конюшен. На поле, где разминались лошади, как грибы выросли два десятка сборных бараков из гофрированного железа. Январь, жара, люди за радиоприемниками, пишущими машинками или стопками перфокарт сидят без рубашек.
Давно позади то время, когда на длинной веранде дома на Генри-стрит жеманились мамзели, а джентльмены, возвращаясь со скачек, сквозь белые перила смотрели на их прелести, проверяли бумажники, забывали о приличиях, поворачивались на каблуках и взбирались по широкой лестнице. Теперь тут живут офицеры и чокнутые математики: на первом этаже все больше австралийцы, на втором — все больше американцы и несколько счастливчиков-британцев, которых вывезли из Сингапура, чтобы генерал Ямасита, Тигр Малайи и покоритель этого города, не взял их в плен и не расколол на предмет секретной информации.
Сегодня в бывшем борделе царит суета: гараж, где собрались все с допуском «Ультра», гудит от вентиляторов и только что не светится от жара человеческих тел. В гараже лежит ржавый жестяной чемодан, заляпанный речным илом, под которым почти не разобрать японских иероглифов. Успей японский шпион заметить чемодан по пути из порта в гараж борделя, он бы узнал имущество радиоподразделения двадцатой дивизии, затерянной сейчас в джунглях Новой Гвинеи.
Новоприбывшим, перекрикивая вентиляторы, сообщают, что чемодан нашел австралийский сапер. Отряд прочесывал брошенный лагерь двадцатой дивизии на предмет мин, и на берегу реки металлодетектор взбесился.
Кодовые книги уложены аккуратными рядами, как золотые слитки. Они мокрые, плесневелые, без обложек, но по меркам военного времени в отличном состоянии. Голые по пояс потные мужчины вынимают их одну за другой, как нянечки в роддоме — новорожденных младенцев, и несут за столы, где отрезают размокшие корешки и вешают страницы на протянутых бельевых веревках. В горячем потоке воздуха от вентиляторов бумага начинает отдавать влагу, распространяя ново-гвинейскую вонь, так что в полумиле по ветру прохожие морщат нос. Шкафчики, все еще пахнущие французскими духами, пудрой, лаком для волос и спермой, перерываются в поисках бечевки, новые и новые шнуры протягиваются поверх и поперек старых, но места для мокрых листов по-прежнему не хватает. Каждый лист представляет собой таблицу: в одной ячейке катакана, хирагана или иероглифы, в другой — арабские цифры и ромадзи. Целые страницы перекрестных ссылок — мечта криптографа, мука для обычного человека.
Приходит фотограф в сопровождении помощников, нагруженных километрами пленки. Он знает, что каждую страницу нужно сфотографировать как можно качественнее. В первое мгновение малярийный дух чуть не сбивает его с ног, потом он обводит взглядом гараж и видит уходящие в бесконечность ряды страниц. Они белеют и сворачиваются, высыхая, таблицы проступают рельефно, как перекрестия бомбовых прицелов, визирные нити перископов, наводящихся сквозь облака и туман на японские транспортные суда, наполненные топливом с Северного Борнео и перегретым паром.

ТАРАН

— Сэр! Не скажете ли, куда мы направляемся, сэр?
Лейтенант Монкберг тяжело, судорожно вздыхает, его грудная клетка ходит, как жестяной барак под ураганным ветром. Он не очень спортивно отжимается, вынимая голову из унитаза или толчка, как это называют здесь, на полуразвалившейся грузовой лоханке. Лейтенант отрывает кусок туалетной бумаги, которую в Европе явно делают из наждака, и вытирает рот, прежде чем поднять глаза к люку. В люке, держась за край, стоит сержант Роберт Шафто.
Шафто должен держаться крепко, потому что вес снаряжения на спине равен весу его тела. Все выдано старательно упакованным.
Можно было оставить как есть, но это не по-бойскаутски. Бобби Шафто распаковал все, разложил на палубе, осмотрел и перепаковал по новой.
Это дало ему кое-какую информацию. Конкретно Шафто узнал, что бойцам подразделения 2702 предстоит провести ближайшие три недели в таком месте, где главной задачей будет не околеть от холода. А в промежутке укокошить довольно много вооруженных гадов. Скорее всего фрицев.
— В Н-н-норвегию. — Лейтенант Монкберг выглядит так жалко, что Шафто думает, не предложить ли ему немного м-м-морфия. От этой мысли накатывает легкая тошнота, зато отступает куда более сильная тошнота от качки. Тут он вспоминает, что лейтенант Монкберг — офицер, чей долг посылать Шафто на смерть, и пусть лучше засунет палец себе в задницу.
— Сэр! Какое у нас задание в Норвегии, сэр?
Монкберг раскатисто рыгает.
— Врезаться и бежать, — говорит он.
— Сэр! Врезаться куда, сэр?
— В Норвегию.
— Сэр! Бежать куда, сэр?
— В Швецию.
Шафто нравится эта мысль. Опасный путь через кишащие немецкими подлодками воды, столкновение с Норвегией, отчаянный рывок через оккупированные фашистами снега — не великая плата за то, чтобы окунуться в самый большой и чистый кладезь настоящей шведской пизды.
— Шафто! Очнись.
— Сэр! Есть, сэр!
— Вы заметили, как мы одеты?
Лейтенант хочет сказать, что все они в гражданке или форме моряков торгового флота. Личные жетоны у них забрали.
— Сэр! Так точно, сэр!
— Нельзя, чтобы фрицы или даже наши узнали, кто мы на самом деле.
— Сэр! Так точно, сэр!
— Вы, возможно, спрашиваете себя: если мы должны выглядеть, как гражданские, на черта мы таскаем с собой пистолеты-пулеметы Томпсона, гранаты, взрывчатку и все такое.
— Сэр! Это был бы мой следующий вопрос, сэр!
— На этот счет у нас разработана легенда. Идемте со мной.
В Монкберге внезапно просыпается рвение. Он встает с коленей и ведет Шафто по переходам и трапам в трюм.
— Вам известно, что это за корабли?
Шафто смотрит непонимающе.
— Другие корабли, вокруг нас. Мы в центре конвоя.
— Сэр! Так точно, сэр! — не очень уверенно отвечает Шафто. Их доставили на эту дырявую галошу несколько часов назад, с тех пор никто из бойцов на палубе не был. Кроме того, в темноте и тумане все равно ничего не видать.
— Мурманского конвоя, — продолжает Монкберг. — Все эти корабли везут Советскому Союзу оружие и припасы. Понятно?
Они в грузовом трюме. Монкберг включает свет. Вокруг ящики. Много ящиков.
— В каждом — оружие, в том числе пистолеты-пулеметы, гранаты, взрывчатка и все такое. Понял, куда я клоню?
— Никак нет, сэр! Не понимаю, куда вы клоните!
Монкберг подходит близко. До неприятного близко. Говорит заговорщицки:
— Смотри, мы — команда торгового корабля, идущего в Мурманск. Опускается туман. Мы случайно отбиваемся от конвоя. И бац! — врезаемся в долбаную Норвегию. Мы на территории, занятой фашистами. Нам надо прорваться в Швецию! Секундочку, говорим мы себе, ведь между нами и шведской границей — чертова туча немцев. Стоит вооружиться до зубов. А кто может вооружиться до зубов, если не команда торгового корабля, набитого оружием и боеприпасами? Мы бежим в трюм, торопливо вскрываем несколько ящиков и вооружаемся.
Шафто смотрит по сторонам. Ни один из ящиков не вскрыт.
— Потом, — говорит Монкберг, — мы оставляем корабль и пробиваемся в Швецию.
Наступает долгая тишина. Наконец Шафто выдавливает из себя:
— Сэр! Так точно, сэр!
— Так давай взламывай!
— Сэр! Есть, сэр!
Шафто начинает проникаться духом разрушения. Чем взламывать ящики? Лома поблизости не видать. Он выходит из трюма в коридор. Монкберг дышит в спину и подгоняет:
— Ты в спешке! Фрицы близко! Тебе надо вооружиться! Думай о жене и детях в Глазго, Лаббоке или откуда ты там!
— Окономовок, штат Висконсин! — возмущается Шафто.
— Нет, нет, не по-настоящему! По легенде, в которой ты моряк торгового флота, греби его вперегреб!.. Смотри, Шафто! Смотри! Спасение близко!
Шафто оборачивается. Монкберг указывает на шкаф с надписью «ПО».
Шафто распахивает дверцу и видит, помимо прочего, здоровенный топор, с каким пожарные бегают по горящим домам.
Через тридцать секунд он снова в трюме, рубит сплеча ящик, наполненный патронами сорок пятого калибра.
— Живей! Не смотри, куда рубишь! — орет Монкберг. — Некогда церемониться! Ты в панике!
Он вырывает топор, размахивается что есть мочи, попадает мимо ящика. Шафто отскакивает на безопасное расстояние. Монкбергу удается со второго захода учесть пеленг, расстояние и войти в контакт с ящиком. Летят щепки.
— Вот так! — Монкберг через плечо оглядывается на Шафто. — Чтоб был разгром! Хаос! — По-прежнему глядя на Шафто, он заносит топор и одновременно переступает на кренящейся палубе, промахивается и разрубает себе лодыжку.
— Твою мать, — медленно, без всякого выражения говорит Монкберг, зачарованно разглядывая ногу.
Шафто подходит взглянуть, чего там такого интересного.

Часть левой икры аккуратно надрублена. Шафто светит фонариком, видит кровеносные сосуды и жилы, торчащие по обе стороны мясной раны, как половинки взорванных мостов и трубопроводов по двум берегам ущелья.
— Сэр! Вы ранены, сэр! — говорит Шафто. — Разрешите позвать лейтенанта Роота.
— Нет! Оставайся здесь и работай! — приказывает Монкберг. — Роота я сам найду. — Он двумя руками сдавливает ногу над раной, кровь хлещет на палубу. — Шикарно, — задумчиво говорит Монкберг. — Добавляет правдоподобия. — Ему приходится раза три повторить приказ, прежде чем Шафто нехотя возвращается к ящикам. Монкберг, прыгая на здоровой ноге, несколько раз обходит трюм, заливая все кровью, потом отправляется искать Роота. Последние его слова: — Помни! Все должно быть вверх дном!
Однако эпизод с раной подействовал на Шафто сильнее любых понуканий. Вид крови пробудил воспоминания о Гуадалканале и более недавних приключениях. Последняя доза морфия уже почти не действует, ощущения те еще. Кроме того, его по-настоящему укачало, и Шафто пытается прогнать тошноту тяжелой работой.
Короче, он крушит топором, как берсерк, плохо соображая, что происходит.
Лучше бы подразделение 2702 оставалось на берегу — предпочтительно на теплом берегу, где они провели две солнечные недели, в Италии.
Поначалу пришлось изрядно поработать, говно из бочки переливать и все такое. Зато остальное время (исключая последние часы) было просто как увольнение на берег, только без баб. Каждый день по очереди ходили в секретку, смотрели на Неаполитанский залив в бинокли и подзорные трубы. Каждую ночь капрал Бенджамин выстукивал морзянкой белиберду.
Однажды ночью он получил радиограмму и некоторое время ее расшифровывал. Потом сообщил Шафто новость:
— Немцы знают, что мы здесь.
— То есть как знают?
— Знают, что мы уже полгода наблюдаем отсюда за Неаполитанским заливом.
— Да мы тут меньше двух недель.
— Завтра они начнут прочесывать округу.
— Так сваливаем отсюда на хер, — сказал Бобби Шафто.
— Полковник Чаттан приказал ждать, — объявил Бенджамин, — пока не узнаем точно, что немцы знают.
— Но я знаю, что немцы знают, — удивился Шафто. — Ты сам мне сейчас сказал.
— Нет, нет, нет, — возразил Бенджамин, — пока не узнаем, что немцы знают, как если бы нам не было известно из радиограммы полковника Чаттана.
— Издеваешься?
— Приказы. — В качестве доказательства Бенджамин продемонстрировал расшифрованную радиограмму.
Как только село солнце, в небе послышался рев самолетов-разведчиков. Шафто был готов и позаботился, чтобы подчиненные тоже были готовы. Друзей он отправил разведать узкие места на пути отступления, а сам лег на спину и стал смотреть на самолеты.
Знает ли он, что немцы знают?
С самого утра два британских друга ходили за ним как приклеенные. Шафто наконец взглянул в их сторону и кивнул. Те живенько побежали в амбар. Через мгновение оттуда донесся лязг гаечных ключей.
Блядские самолеты заполнили все небо — довольно убедительная косвенная улика, что немцы знают. Поскольку Шафто ясно видел эти самолеты, он мог бы утверждать: знают. Однако Чаттан приказал не трогаться с места, «пока вас определенно не заметят», и понимай, как хочешь.
Один из самолетов проносился все ближе. Он летел совсем низко над землей, прочесывая за вираж узкую полоску. Когда самолет приближался, Шафто хотелось заорать. Бред какой-то. Хотелось пустить ракету и покончить с этим раз и навсегда.
Наконец, ближе к вечеру, Шафто, лежа на спине в тени оливы, смог пересчитать заклепки на брюхе немецкого самолета: «хеншеля» Hs-126* [У Шафто в последнюю пару недель не было другого занятия, кроме как играть в червы колодой «Знай врага», поэтому он легко определил модель немецкого самолета-разведчика.], с одним стреловидным крылом над фюзеляжем (чтобы не закрывать нижний обзор) и огромным растопыренным шасси.
Один фриц сидел под стеклянным колпаком и вел самолет, другой, в очках, свесился из открытой кабины и поводил пулеметом на турели. Он только что не заглянул Шафто в глаза, потом похлопал пилота по спине и указал вниз.
«Хеншель» заложил крутой вираж и снова пронесся над их позицией.
— Готово. — Шафто встал и пошел к покосившемуся амбару. — Все! — крикнул он. — Исполняйте!
Друзья в кузове грузовика, под брезентом, орудовали гаечными ключами. Шафто взглянул в их сторону и увидел блестящие детали «виккерса», разложенные на куске чистой белой материи. Где, черт возьми, они раздобыли чистую белую материю? Наверное, берегли для сегодняшнего дня. И какого хрена они раньше не привели «виккерс» в порядок? Потому что им приказано собирать пулемет в спешке, в последнюю минуту.
Капрал Бенджамин замялся, одна рука на ключе.
— Сержант, вы уверены, что они о нас знают?
Все глаза устремились на Шафто. В последнее время он заработал репутацию человека, от которого можно ждать всякого.
Шафто повернулся на каблуках и прошел несколько ярдов до середины поляны. Слышно было, как бойцы подразделения 2702 пихаются в дверях, чтобы не пропустить зрелище.
«Хеншель» вернулся на новый заход и летел теперь так близко к земле, что можно было бы кинуть камень в фонарь кабины.
Шафто снял с плеча «томми», передернул затвор, упер приклад в плечо и дал очередь.
Некоторые ворчат, что у «томми», мол, недостаточная убойная сила, но Шафто явственно видел, как от мотора отлетела какая-то фигня. «Хеншель» почти сразу потерял управление. Он накренился, крыло встало вертикально, качнулся, перевернулся брюхом вверх, потерял и без того малую высоту и шмякнулся на оливы в какой-нибудь сотне ярдов от амбара, но не занялся огнем в ту же секунду — обидно, честное слово.
Среди бойцов наступила полная тишина. Слышались только точки и тире — капрал Бенджамин, получив ответ на вопрос, отправлял краткое сообщение. На этот раз морзянка была понятна: МЫ ОБНАРУЖЕНЫ ТЧК ИСПОЛНЯЕМ ПЛАН ТОР.
В качестве своего первого вклада в план «Тор» грузовик выехал из амбара и встал под деревьями. Бойцы залезли в кузов. Закончив, капрал Бенджамин бросил рацию и забрался следом.
В качестве своего первого задания по плану «Тор» Шафто несколько раз прошел по амбару взад-вперед, примерно по той же схеме, что самолет-разведчик. В руке он нес перевернутую канистру с керосином.
Вылив две трети керосина, он поставил канистру посреди амбара. Вырвал чеку, бросил гранату в керосин и выбежал наружу. Грузовик уже трогался. Ребята подхватили Шафто за руки и втащили в кузов. Он устроился сзади и с удовлетворением увидел, как амбар охватило вполне приличное пламя.
— О'кей, — объявил Шафто. — Нам предстоит убить несколько часов.
Все в грузовике, за исключением десантников, которые по-прежнему возились с «виккерсом», переглянулись, словно спрашивая: «Я не ослышался?»
— Э-э... сержант, — спросил наконец один. — Не объясните нам, в каком смысле убить время?
— Самолет прилетит не сразу. Приказ.
— Чего-то стряслось или?..
— Нет. Все отлично. Приказ.
Больше ребята допытываться не стали, хотя продолжали переглядываться. Наконец заговорил лейтенант Енох Роот:
— Вы, наверное, спрашиваете себя, почему нельзя было убить несколько часов сначала, а только потом засветиться и рвануть прямо к самолету.
— Ага! — Земляки и друзья дружно закивали.
— Хороший вопрос, — заметил Енох Роот таким тоном, будто знает ответ, и каждому в грузовике захотелось двинуть ему по шее.
Фрицы успели оцепить местность. Когда подразделение 2702 подъехало к первому перекрестку, фрицы уже лежали мертвехонькие, осталось только притормозить, чтобы рейдеры морской пехоты выбрались из засады и прыгнули в кузов.
Фрицы на втором перекрестке вообще не знали, зачем они здесь. Шафто, несмотря на множество лингвистических и культурных барьеров, понял: у вермахта свои накладки, кто-то кому-то чего-то не так передал. Подразделение 2702 открыло огонь из-под брезента и уложило фрицев на месте или разогнало по кустам.
С фрицами на следующем перекрестке этот номер не прошел: они перегородили дорогу грузовиками и легковушками, а сами засели сзади, выставив вперед дула. Дула, правда, автоматные. К этому времени «виккерс» был собран, откалиброван, настроен, осмотрен и заряжен. Сдернули брезент. Рядовой Микульский, угрюмый стокилограммовый английский поляк, открыл огонь из «виккерса» одновременно с фрицами.
В старших классах Бобби Шафто попал на профподготовку и большую часть времени провел в школьных мастерских. Само собой, ему иногда приходилось распиливать большие куски металла или дерева на меньшие. В мастерской были для этого разные пилы, похуже и получше. То, что заколеблешься кромсать ножовкой, можно разрезать электропилой. Опять-таки от определенных материалов маленькие электропилы нагреваются или их заедает и надо брать пилу побольше. Однако, даже орудуя самой большой электропилой, Бобби Шафто всегда чувствовал, что инструмент работает с натугой. Пила замедлялась, коснувшись материала, вибрировала, нагревалась, а если слишком сильно давить, могла и застрять. И вот однажды летом Шафто попал на лесопилку, где была пилорама. Вместе со сменными лезвиями, запчастями, ремонтным оборудованием и сводом инструкций она занимала целое помещение. Короче, настоящая инфраструктура — Шафто и не знал, что такое бывает. Сама пилорама была размером с автомобиль. Восьмизубые шестерни, крутившие лезвие, выглядели так, будто их сняли с паровоза. Чтобы изготовить полотно, надо было отмотать примерно полмили гибкой стальной ленты и соединить концы. Когда ты включал рубильник, земля начинала мелко дрожать, словно от приближающегося товарняка, а дальше лезвие медленно и неудержимо набирало скорость, зубья исчезали, превращались в поток адской энергии, натянутой между столом и механизмом. Про несчастные случаи с пилорамой рассказывали шепотом. И самое замечательное: пилорама не только разрезала что угодно быстро и хладнокровно, но и словно не ощущала этого. Она не чувствовала, что человек пропускает через нее бревна. Никогда не застревала, не перегревалась.
После школы Шафто обнаружил, что у огнестрельного оружия много общего с пилами. Винтовки и автоматы стреляют, однако дают отдачу, нагреваются, пачкаются, заклинивают. Другими словами, стрелять они могут, однако с определенной натугой, которая их рано или поздно доканывает. «Виккерс» в кузове отличался от остального стрелкового оружия, как пилорама от остальных пил. «Виккерс» охлаждался водой. У него был радиатор — инфраструктура, как у пилорамы — и целая команда обслуги. Как только эту махину запускали, она могла стрелять сутками без передышки, только подавай ленты. После того как рядовой Микульский открыл огонь из «виккерса», несколько бойцов подразделения 2702, не желая отставать, принялись постреливать по немцам из «томми», но выходило до того жалко, что они перебрались в канаву, закурили и стали смотреть, как «виккерс» методично убирает с дороги заграждение. Сперва Микульский тщательно поливал немецкие машины, поводя «виккерсом» вправо-влево, как огнетушителем. Потом сосредоточился на определенных частях заграждения, за которыми могли укрываться люди, и разнес машины так, что стала видна другая сторона. Он срезал несколько придорожных деревьев, за которыми, возможно, прятались фрицы, затем выкосил примерно пол-акра травы.
К этому времени стало видно, что несколько фрицев отбежали за пригорок справа от дороги и постреливают оттуда, поэтому Микульский направил ствол круто вверх и дал очередь в небо. Пули, как минометные снаряды, посыпались по другую сторону пригорка. Ему не сразу удалось подобрать нужный угол, но потом он методично удобрил пулями все поле, как человек, поливающий свой газон. Один из друзей даже прикинул на коленке, как долго Микульскому придется стрелять, чтобы достичь нужной плотности — скажем, пуля на квадратный фут. Когда вся территория оказалась засеяна свинцом, Микульский вновь переключился на грузовики, добиваясь, чтобы оставшиеся куски можно было при желании убрать с дороги руками.
Когда он наконец прекратил обстрел, у Шафто было такое чувство, будто надо сделать запись в судовом журнале, как при благополучном возвращении в порт. Минуя заграждение, они ненадолго притормозили поглядеть. Хрупкий металл немецких моторов разбился вдребезги и, как в разрезе, виднелись блестящие поршни и коленвалы, истекающие бензином и маслом.
Они проехали по обломкам и скоро оказались в малонаселенном районе, идеальном для воздушных обстрелов. Первые два самолета Микульский и его «виккерс» разнесли на куски. Вторая пара уничтожила грузовик, пулемет и рядового Микульского за один заход. Больше никто не пострадал: все сидели в канаве, наблюдая, как Микульский играет в вышибалы с двумя «мессершмиттами» и в конечном счете проигрывает.
К этому времени стемнело. Дальше подразделение двинулось пешком, неся останки Микульского на носилках. Напоролись на немецкий патруль, в перестрелке двоих друзей ранило, одного пришлось нести. Наконец добрались до пшеничного поля, отметили фальшфейерами посадочную полосу для «Дугласа», который аккуратно сел, забрал всех и без приключений долетел до Мальты.
Здесь их впервые познакомили с лейтенантом Монкбергом.
Едва доложившись, они погрузились на очередную подводную лодку, которая взяла курс в места неизвестные или по крайней мере неназванные. Однако, обнаружив в своих вещмешках пудовые шерстяные свитера, ребята примерно сообразили, куда направляются. Несколько дней клаустрофобии спустя они на грузовозе.
Судно — такая развалюха, что они называют его не иначе как «говновоз» и развлекаются, подставляя слово «говно» в различные флотские выражения: «Будешь говняшки драить!» или «Уж не сговнились ли мы с курса?» и так далее.
Сейчас, в говнотрюме, Бобби Шафто вдохновенно изображает разгром. Раскидывает винтовки и «томпсоны» по палубе. Вскрывает коробки с патронами сорок пятого калибра и разбрасывает вокруг. Находит лыжи — им ведь понадобятся лыжи, верно? Ставит несколько мин, просто чтобы попугать фрицев, которые будут осматривать говновоз. Вскрывает несколько ящиков с гранатами. У них недостаточно раскуроченный вид, поэтому Шафто вытаскивает часть гранат, выносит наверх и швыряет за борт. Заодно бросает несколько лыж: глядишь, прибьет к берегу в довершение хаоса, на радость лейтенанту Монкбергу.
Шафто идет по палубе с охапкой лыж, и тут что-то возникает в тумане. Шафто, само собой, пригибается. Его так часто обстреливали с воздуха, что пригибается он резко, роняет лыжи на палубу и чуть не падает вместе с ними. Тем не менее он все же удерживает равновесие и вглядывается в туман. Что-то прямо впереди, выше мостика и (в отличие от «зеро» и «мессеров») не пикирует стремительно, а просто висит на месте. Как облако в небе. Как будто туман сгустился в комок наподобие маминого картофельного пюре. Комок постепенно светлеет, края проступают все отчетливее, Шафто различает что-то зеленое.
Эй, минуточку! Он смотрит на зеленый склон с заснеженным полем посередине.
— Ложись! — орет он и бросается на палубу.
Он надеется на мягкое соприкосновение с земной корой, как на моторке: подходишь к пляжу, в последнюю минуту глушишь мотор, вытаскиваешь его из воды и плавно въезжаешь на песчаную подушку.
Как бы не так! Говновоз куда быстроходнее обычной рыбачьей моторки и не въезжает на песок, а с размаху впечатывается в гранитную скалу. Слышится классный грохот, нос задирается кверху, и Шафто со страшной скоростью скользит на животе по обледеневшей палубе.
Он боится, что соскользнет в море, но успевает дотянуться до якорной цепи, которая вполне эффективно гасит его скорость. Под палубой примерно десять тысяч больших и мелких предметов тоже находят себя различные стопоры.
Наступает короткая и почти мирная интерлюдия чуть ли не полной тишины. Затем слышатся возмущенные крики исключительно малочисленной команды: «ОСТАВИТЬ ГОВНОСУДНО! ОСТАВИТЬ ГОВНОСУДНО!»
Бойцы подразделения 2702 бегут к шлюпкам. Шафто знает, что они справятся без него, поэтому идет в рубку искать прибабахнутых, с которыми не соскучишься: лейтенантов Роота и Монкберга, а также капрала Бенджамина.
Первым ему на глаза попадается обмякший капитан, который наливает себе виски. В лице ни кровинки. Бедолагу сдернули с привычного рейса и велели вмазаться в скалу. Он до сих пор не очухался.
— Здорово у вас это получилось, сэр. Поздравляю, — говорит Шафто, не зная, что сказать, и поворачивается на голоса из сигнальной рубки.
Действующие лица: капрал Бенджамин с Книгой, похож на пастора, укоряющего нерадивых прихожан видом Библии, которую те не раскрывали давным-давно; лейтенант Монкберг, возлежит на стуле, раненая нога покоится на столе; лейтенант Роот латает ее.
— Мой долг... — начинает капрал Бенджамин.
Монкберг рявкает:
— Твой долг, капрал, исполнить мой приказ!
При столкновении все медицинские припасы лейтенанта Роота разлетелись по палубе. Шафто начинает собирать их и расставлять, особенно зорко высматривая закатившиеся пузырьки.
Бенджамина трясет от ярости. Он наугад открывает Книгу и поднимает ее над головой. Там строка за строкой, страница за страницей случайных букв.
— Это, — возглашает Бенджамин, — КОДЫ союзного ТОРГОВОГО ФЛОТА! Экземпляр ЭТОЙ КНИГИ находится на КАЖДОМ СУДНЕ КАЖДОГО КОНВОЯ в Северной Атлантике! С ее помощью корабли ПЕРЕДАЮТ СВОИ КООРДИНАТЫ! Вы ПОНИМАЕТЕ, что БУДЕТ, если ЭТА КНИГА попадет в руки к НЕМЦАМ?!
— У меня приказ, — говорит лейтенант Монкберг.
Они продолжают в том же духе примерно минуту, пока Шафто ползает по полу в поисках рассыпанных медикаментов. Наконец он видит, что искал: пузырек закатился под шкаф, чудом не разбившись.
— Сержант Шафто! — Вопреки обыкновению у лейтенанта Роота почти командирский голос. Шафто машинально вытягивается по стойке «смирно».
— Сэр!
— У лейтенанта Монкберга скоро кончится наркоз, поэтому отыщите и принесите мне пузырек с морфием.
— Есть, сэр! — Шафто — морпех, а значит, исполняет приказ, даже когда тело требует не подчиниться. Тем не менее пальцы сводит так, что Рооту приходится силой вырывать пузырек.
Бенджамин и Монкберг схлестнулись насмерть и не замечают этой маленькой сценки.
— Лейтенант Роот! — Голос Бенджамина дрожит от волнения.
— Да, капрал, — рассеянно отвечает Роот.
— У меня есть основания полагать, что лейтенант Монкберг — немецкий шпион. Следует немедленно отстранить его от командования и арестовать!
— Сука! — орет Монкберг. Неудивительно: Бенджамин только что обвинил его в измене, за которую грозит расстрел. Однако нога в крепких руках Роота, не рыпнешься.
Роот абсолютно невозмутим. Кажется, ему даже по душе столь чудовищное обвинение. Гораздо интереснее поговорить на серьезную тему, чем придумывать, куда бы еще приставить слово «говно».
— Ты у меня под трибунал пойдешь, падла! — вопит Монкберг.
— Капрал Бенджамин, какие у вас основания для подозрений? — убаюкивающим голосом вопрошает Енох Роот.
— Лейтенант не позволяет мне исполнить долг и уничтожить кодовые книги! — Бенджамин совершенно вне себя.
— У меня четкий и определенный приказ полковника Чаттана! — апеллирует к Рооту Монкберг. Шафто изумлен. Монкберг явно считает Роота компетентным судьей. А может, он напуган и ищет союзника. Офицеры всегда стоят друг за дружку против нижних чинов.
— У вас есть письменный экземпляр приказа, с которым я мог бы ознакомиться? — спрашивает Роот.
— Не думаю, что нам стоит вести этот разговор здесь и сейчас. — Тон у Монкберга по-прежнему просительный.
— Как, по-вашему, быть? — Роот протягивает шелковую нить через обесчувствленную плоть Монкберга. — Мы на мели. Скоро здесь будут немцы. Мы либо оставляем книги, либо уничтожаем. Решать надо сейчас.
Монкберг оседает на стуле.
— Вы можете показать письменные приказы? — спрашивает Роот.
— Нет. Они были отданы устно, — отвечает Монкберг.
— И в них определенно упоминались кодовые книги?
— Да. — Монкберг словно дает показания в суде.
— И в приказах говорилось, что книги должны попасть к немцам?
— Да.
Тишина. Роот завязывает один шов и начинает новый. Потом говорит:
— Скептик вроде капрала Бенджамина предположил бы, что насчет кодовых книг вы все выдумали.
— Если я подменил приказы, меня можно расстрелять, — говорит Монкберг.
— При условии, что вы и кто-нибудь из свидетелей доберетесь до дружественной территории и сличите заметки с полковником Чаттаном, — спокойно замечает лейтенант Роот.
— Чего за херня? — По трапу вбегает один из десантников. — Мы, бля, давно в шлюпках! — Лицо, красное от холода и волнения, ошалело ворочается по сторонам.
— Отвали, — говорит Шафто.
Десантник замирает.
— Ладно, сержант.
— Иди вниз и скажи ребятам, чтобы заткнули хлебало.
— Сейчас, сержант! — Десантник исчезает.

Предыдущая страница 13 Следующая страница


Криптономикон (часть 1) 14

— Как подтвердят обеспокоенные бойцы в шлюпках, — продолжает Енох Роот, — вероятность того, что вы и какие-то свидетели доберетесь до дружественной территории, убывает с каждой минутой. Тот факт, что вы нанесли себе рану, существенно осложняет наше спасение. Либо нас захватят в плен, либо вы предложите вас бросить, и таким образом тоже попадете к немцам. В обоих случаях, допуская, что вы — немецкий шпион, вы избежите трибунала.
Монкберг не верит своим ушам.
— Но это произошло случайно, лейтенант Роот! Я разрубил себе ногу блядским топором! Вы же не думаете, что я нарочно?
— Очень трудно определить, — скорбно отвечает Роот.
— Самое безопасное — просто уничтожить кодовые книги, — встревает Бенджамин. — Согласно инструкции. За это под трибунал не отдают.
— Но это погубит все задание! — визжит Монкберг.
Роот на мгновение задумывается.
— Кто-нибудь погиб, — спрашивает он, — оттого что враг завладел нашими тайными шифрами и прочел наши сообщения?
— Ясное дело, — отвечает Шафто.
— Кто-нибудь из наших погиб, — продолжает Роот, — оттого что враг не завладел нашими секретными шифрами?
Вопрос на засыпку. Капрал Бенджамин первый приходит к решению, но даже ему нужно время подумать.
— Конечно, нет! — выпаливает он.
— Сержант Шафто? У вас есть свое мнение? — Роот пригвождает Шафто серьезным и трезвым взглядом.
Шафто говорит:
— В этих делах с шифрами хрен разберешься.
Очередь Монкберга.
— Я... наверное... наверное, могу придумать гипотетическую ситуацию, в которой кто-то погибнет.
— А вы, лейтенант Роот? — спрашивает Шафто.
Роот долго молчит, только работает иголками. Проходит несколько минут. Может быть, меньше. Все нервничают из-за немцев.
— Лейтенант Монкберг пытается убедить нас, что для сохранения жизни союзных солдат мы должны сегодня оставить немцам шифровальные книги союзного торгового флота. — При звуке голоса лейтенанта Роота все вздрагивают. — На самом деле в подобном случае мы должны использовать своего рода калькуляцию смерти, поэтому настоящий вопрос: спасет ли это больше жизней, чем погубит?
— Дальше без меня, падре, — говорит Шафто. — Математику я не осилил.
— Тогда давайте начнем с известного: передача шифров приведет к гибели людей, поскольку немцы смогут выследить и потопить наши конвои. Верно?
— Верно! — подхватывает капрал Бенджамин. Похоже, Роот склоняется на его сторону.
— Это будет верным, — продолжает Роот, — пока союзники не сменят шифры, что, надо думать, произойдет очень скоро. Итак, в минусе у нас несколько конвоев, потопленных за короткий отрезок времени. Что в плюсе? — Роот, не отрывая взгляда от раны, задумчиво поднимает брови. — Каким образом передача шифров может спасти человеческие жизни? Ну, это умонепостижимо.
— Чего-чего? — переспрашивает Шафто.
— Предположим, например, что из Нью-Йорка выходит секретный конвой с тысячами солдат и новым оружием, которое переломит ход войны и спасет тысячи людей. Предположим, он использует новую систему шифров, и немцы не узнают о нем, даже заполучив кодовые книги. Немцы сосредоточат усилия на известных конвоях, потопят, может быть, несколько сотен моряков. Тем временем тайный конвой проскочит незаметно, доставит бесценный груз и тысячи людей будут спасены.
Снова долгое молчание. Слышно, как остальные бойцы подразделения 2702 перекрикиваются в шлюпках, вероятно, ведут свой собственный спор: если бросить на хер офицеров, можно ли будет это расценить как мятеж.
— Я выдвинул лишь гипотезу, — говорит Роот, — однако видно, что уравнение смерти может, хотя бы теоретически, дать положительный ответ. Более того, подумав, я прихожу к выводу, что отрицательной стороны может не быть совсем.
— То есть как?! — восклицает капрал Бенджамин. — Разумеется, есть отрицательная сторона.
— Вы исходите из того, что немцы не знают наши коды. — Роот направляет окровавленный указательный палец на том белиберды у Бенджамина в руках. — Однако они топят наши конвои направо и налево. Очень может быть, что коды давно взломаны. В таком случае, если они попадут к немцам, никакого вреда не будет.
— Но это противоречит вашей теории о секретном конвое! — говорит Бенджамин.
— Секретный конвой был Gedankenexperiment* [Мысленный эксперимент (нем.).], — объясняет Роот.
Капрал Бенджамин закатывает глаза; похоже, он и впрямь знает, что такое Gedankenexperiment.
— Если код действительно взломан, зачем рисковать нашими жизнями, чтобы ПЕРЕДАТЬ ЕГО НЕМЦАМ?
Роот задумывается.
— Не знаю.
— Так что вы думаете, лейтенант Роот? — спрашивает Бобби Шафто несколько томительных минут спустя.
— Думаю, несмотря на мой Gedankenexperiment, объяснение капрала Бенджамина, что лейтенант Монкберг — немецкий шпион, более правдоподобно.
Бенджамин облегченно вздыхает. Монкберг, оцепенев от ужаса, таращится на Роота.
— Однако неправдоподобное случается сплошь и рядом, — продолжает Роот.
— Ой, бога ради! — орет Бенджамин и хлопает ладонью по Книге.
— Лейтенант Роот? — говорит Шафто.
— Да, сержант Шафто?
— Лейтенант Монкберг поранился случайно. Я видел.
Роот заинтересованно смотрит Шафто в глаза.
— Точно?
— Да, сэр. Все произошло совершенно случайно.
Роот разрывает упаковку стерильного бинта и начинает обматывать Монкбергу ногу; кровь проступает быстрее, чем он успевает накрутить следующий слой, однако постепенно Роот все же берет верх и повязка остается чистой.
— Кажется, пора принимать ответственное решение, — объявляет Роот. — Мы оставим кодовые книги на корабле, как сказал лейтенант Монкберг.
— Но если он — немецкий агент... — начинает Бенджамин.
— Тогда ему капец, как только мы доберемся до своих, — отвечает Роот.
— Однако вы сами сказали, что у нас мало шансов туда добраться.
— Мне не следовало так говорить, — винится Енох Роот. — Это были глупые и необдуманные слова. Не отвечающие истинному духу подразделения 2702. Убежден, что мы доберемся до Швеции и доставим туда лейтенанта Монкберга.
— Вот это по-нашему! — одобряет Монкберг.
— В любом случае, если лейтенант Монкберг начнет саботировать, или предложит, чтобы его бросили, или каким-то иным образом увеличит риск нашего пленения, мы сможем с уверенностью сказать, что он — немецкий агент.
Монкберг окончательно опупевает.
— Так сваливаем отсюда к чертовой матери! — кричит он и встает, шатаясь от потери крови.
— Погодите! — говорит сержант Шафто.
— Что еще, Шафто? — Монкберг снова чувствует себя командиром.
— Как мы узнаем, что он увеличивает риск нашего пленения?
— В каком смысле, сержант Шафто? — спрашивает Роот.
— Может, это будет не очевидно, — объясняет Шафто. — Может, в лесу немецкая засада и лейтенант Монкберг выведет нас прямо на нее.
— Молодчина, сержант! — радуется капрал Бенджамин.
— Лейтенант Монкберг, — объявляет Енох Роот, — как исполняющий обязанности судового врача, отстраняю вас от командования по медицинским показаниям.
— Каким показаниям?! — в панике вопит Монкберг.
— Вы потеряли много крови, а та кровь, что у вас осталась, отравлена морфием, — объясняет Енох Роот. — Командование переходит к следующему по старшинству, он и будет решать, куда нам двигаться.
— Кроме вас, других офицеров нет! — говорит Шафто. — Только капитан, но он не может быть капитаном без корабля.
— Сержант Шафто! — гаркает Роот, настолько реалистично изображая морпеха, что Шафто и Бенджамин замирают по стойке «смирно».
— Сэр! Есть, сэр! — отвечает Шафто.
— Это первый и последний приказ, который я отдам, так что слушай внимательно! — объявляет Роот.
— Сэр! Есть, сэр!
— Сержант Шафто! Доставь меня и остальное подразделение в Швецию!
— Сэр! Есть, сэр! — орет Шафто и строевым шагом выходит из каюты, оттеснив лейтенанта Монкберга плечом. Два лейтенанта и капрал выходят следом, оставив в рубке кодовые книги.
Поваландавшись полчаса в шлюпках, подразделение 2702 высаживается в Норвегии. Нижняя граница снегов проходит на высоте пятидесяти футов над уровнем моря; по счастью, Бобби Шафто умеет стоять на лыжах. Друзья-десантники тоже; им даже удается соорудить что-то вроде волокуши для лейтенанта Монкберга. Через несколько часов они уже в лесах и движутся на восток. С самой высадки им не встретилось ни одного человека, ни немца, ни норвежца. Сыплет снег, заметая их следы. Лейтенант Монкберг ведет себя хорошо — не требует, чтобы его бросили, не пускает ракеты. Шафто думает, что дорога в Швецию будет наиболее легким заданием подразделения 2702. Самое трудное, как всегда, понять, на кой ляд это все нужно.

БДИТЕЛЬНОСТЬ

Карты Юго-Восточной Азии закрывают все стены и даже окно, придавая номеру Ави сходство с подземным бункером. Это первое за два месяца общее собрание акционеров корпорации «Эпифит». Ави Халаби, Рэнди Уотерхауз, Том Говард, Эберхард Фёр, Джон Кантрелл и Берил Хаген набились в номер. Кто-то роется в мини-баре, доставая закуску и выпивку. Кто-то сидит на кровати. Эберхард скрестил босые ноги на полу и примостил ноутбук на табуретку. Ави сложил руки на груди, прикрыл глаза и прислонился спиной к дверцам домашнего развлекательного центра из красного дерева исчезающих пород. На нем ослепительно белая рубашка, отглаженная и накрахмаленная до хруста. Пятнадцать минут назад он был в майке, которую перед тем не снимал сорок восемь часов.
Рэнди думает, что Ави заснул в неортодоксальной стоячей позе. Однако...
— Взгляните на карту, — вдруг тихо говорит Ави. Открывает глаза и поводит ими в сторону карты, не утруждаясь повернуть голову. — Сингапур, южная оконечность Тайваня и самая северная точка Австралии образуют треугольник.
— Ави, — серьезно произносит Эберхард, — любые три точки образуют треугольник.
Обычно от Эберхарда не ждут, что он разрядит атмосферу юмором, но сейчас по рядам акционеров пробегает легкий смешок. Ави улыбается; не потому, что ему смешно, просто шутка свидетельствует о высоком моральном духе.
— Что в центре треугольника?
Все снова смотрят на карту. Правильный ответ: «Точка посредине моря Сулу», но ясно, что Ави имеет в виду другое.
— Мы, — отвечает Рэнди.
— Верно, — подхватывает Ави. — Кинакута — идеальный электронный перекресток. Самое место для большого маршрутизатора.
— Без рекламы, пожалуйста, — просит Рэнди.
Ави невозмутимо продолжает:
— На самом деле так даже лучше.
— Как? — резко спрашивает Эб.
— Мне стало известно, что появились другие кабельные люди. Группа из Сингапура, а также консорциум из Австралии и Новой Зеландии. Иными словами: мы были единственными поставщиками услуг связи для Крипты. Теперь, как я понимаю, мы одни из трех.
Том Говард победно улыбается; он работает в Крипте и, вероятно, догадался раньше других. Рэнди и Кантрелл переглядываются.
Эб резко выпрямляется.
— Как давно вам об этом известно?
Рэнди видит досаду на лице Берил. Она не любит, когда в ней сомневаются.
— Вы не обидитесь, если мы с Эбом на секундочку выйдем? — Рэнди поднимается.
Доктор Эберхард Фёр недоуменно вздрагивает и тоже встает.
— Куда мы?
— Ноутбук оставь, — говорит Рэнди и ведет его в холл. — Дальше не пойдем.
— В чем дело?
— Так. — Рэнди тихонько, чтобы не захлопнулась, прикрывает дверь. — Люди вроде Ави и Берил, которые давно в бизнесе, предпочитают говорить с глазу на глаз — как сейчас мы. И, как правило, ничего не записывают.
— Объясни.
— Ну, это теория информации. При самом худшем раскладе, если дойдет до суда...
— До какого суда? Ты о чем?
Эб родился в маленьком городке на границе с Данией. Отец преподавал в университете математику, мать — английский. Появись он в родном городе со своими патлами, народ бы шарахался. Тем не менее Эб, подобно большинству соотечественников, по-прежнему свято верит, что все надо делать честно, открыто и логично.
— Не пугайся, — говорит Рэнди, — ничего такого не ожидается. Однако сейчас в Америке судятся все, кому не лень, и очень многие деловые начинания заканчиваются исками. В таком случае любой документ могут изъять. Вот почему Ави и Берил не записывают ничего, что плохо прозвучит в суде. Более того, от каждого могут потребовать свидетельства под присягой. Поэтому разговор с глазу на глаз предпочтительнее.
— Без свидетелей? Ясно.
— Я знал, что ты поймешь.
— Все равно они должны были нам потихоньку сказать.
— Ави и Берил молчали, потому что хотели все сперва проработать между собой. Другими словами, они оберегали нас, а не обманывали. Теперь они официально сообщают нам новости.
Подозрения Эберхарда рассеялись. Сейчас он злится, а это хуже. Как многие технари, он может полезть на рожон, если заподозрит других в отсутствии логики. Рэнди поднимает ладони, как будто сдаваясь.
— Допускаю, все это кажется бредом, — говорит он.
Эб упрямо смотрит в пустоту.
— Ты согласен, что в мире много иррациональных людей и бредовых ситуаций?
— Ja-a-a, — осторожно тянет Эб.
— Чтобы мы с тобой программировали и получали за это деньги, кто-то должен нас нанять, верно?
Эб задумывается.
— Да.
— Это предполагает, на определенном уровне, общение с работодателями, временами неприятное. А также с юристами, рекламщиками, маркетологами. Если это попытаемся делать мы с тобой, то скоро чокнемся. Верно?
— Скорее всего да.
— Поэтому хорошо, что есть такие люди, как Ави и Берил, потому что они — наш интерфейс. — В голове у Рэнди возникает образ времен холодной войны. Он выставляет вперед руки с растопыренными пальцами. — Как бокс, в котором работали с плутонием, такой, с перчатками. Ясно?
Эб кивает. Обнадеживающий знак.
— И все равно это совсем не то, что компьютерная программа. Ави и Берил могут только фильтровать и смягчать иррациональную природу внешнего мира, поэтому иногда они должны делать вещи, которые кажутся диковатыми.
Взгляд у Эба становится все более и более отрешенным.
— Интересно было бы подойти к этому как к задаче из области теории информации, — замечает он. — Каким образом информация может перемещаться между узлами внутренней сети, — (Рэнди понимает, что Эб имеет в виду «между людьми в маленькой корпорации»), — но не существовать для внешнего мира?
— В каком смысле «не существовать»?
— Как может суд изъять документ, который, с его точки зрения, никогда не существовал?
— В смысле, что надо все шифровать?
Эб слегка раздосадован его тупостью.
— Это мы уже делаем. Однако все равно можно доказать, что документ определенного размера был отправлен в такое-то время, по такому-то адресу.
— Анализ трафика.
— А если заглушить его? Почему бы не заполнить жесткий диск случайными байтами, чтобы отдельные файлы стали неразличимы? Они затеряются, как полосатый тигр в зарослях тростника. Или можно постоянно обмениваться случайным шумом.
— Дороговато будет.
Эберхард отмахивается.
— Канал дешев.
— Боюсь, это пока девичьи мечты, — говорит Рэнди. — Хотя в будущем, возможно, так и будет.
— Вся наша дальнейшая жизнь — в будущем, так что программу нужно разработать прямо сейчас.
— Ладно, — говорит Рэнди. — Может, продолжим этот разговор в другой раз?
— Конечно.
Они возвращаются в комнату. Том, на правах кинакутского старожила, рассказывает:
— Пятифутовые с желтовато-бурыми пятнами на бирюзовом фоне безопасны и прекрасно подходят для домашнего содержания. Шестифутовые с буровато-желтыми пятнами на изумрудном фоне смертельно ядовиты: умираешь через десять минут после укуса, если раньше не покончишь с собой от невыносимых мучений.
Все это, чтобы показать Рэнди и Эбу: в их отсутствие дела не обсуждали.
— Ладно, — говорит Ави. — Суть в том, что Крипта будет потенциально куда больше, чем мы предполагали, и это хорошая новость. Однако остается один момент.
Ави знаком с Рэнди сто лет и знает, что тот не обидится.
Все глаза устремляются на Рэнди, и Берил подхватывает разговор. Она назначила себя заботиться о чужих чувствах, потому что все другие участники корпорации бестактные и черствые. Берил говорит трагически:
— Работа, которую Рэнди делает на Филиппинах, и делает замечательно, теперь не имеет для нас решающего значения.
— Ну и ладно, — говорит Рэнди. — По крайней мере я хоть загорел впервые за десять лет.
Все страшно рады, что Рэнди не надулся. Том сразу берет быка за рога:
— Можем ли мы порвать с Дантистом? Раз и навсегда?
Ритм разговора внезапно сбивается, как в дискотеке, когда вырубают электричество.
— Трудно сказать, — говорит наконец Ави. — Мы смотрели контракты, но они составлены адвокатами Дантиста.
— Кто-то из его партнеров — адвокат? — спрашивает Кантрелл.
Ави нетерпеливо пожимает плечами.
— Его партнеры. Инвесторы. Друзья, соседи, партнеры по гольфу. Его сантехник и тот, наверное, адвокат.
— Проблема в том, что он прославился своим сутяжничеством, — говорит Рэнди.
— Есть и другая проблема, — вставляет Берил. — Если мы все-таки придумаем, как расстаться с «АВКЛА», мы потеряем живые деньги. Отрицательные последствия будут куда хуже, чем предполагалось вначале.
— Какие последствия? — спрашивает Том. Он всегда копает до самой сути.
— Придется искать деньги на текущие расходы, — говорит Ави. — Разбавлять наши акции.
— Насколько? — спрашивает Джон.
— До утраты контрольного пакета.
Магическая фраза порождает эпидемию вздохов, стонов и ерзанья у руководящих сотрудников корпорации «Эпифит», которые сообща владеют более чем пятьюдесятью процентами акций. Все взгляды устремляются на Рэнди.
Наконец он встает и предупреждающе вскидывает руки.
— Ладно, — произносит Рэнди. — Что мы имеем? В бизнес-плане без конца говорится, что филиппинская сеть выгодна сама по себе — что она может выделиться в независимое предприятие и все равно приносить доход. Насколько мне известно, это по-прежнему так?
Ави задумывается, прежде чем выдать тщательно взвешенные слова:
— Истинность этого утверждения осталась прежней.
Иронические аплодисменты. Молодец, Ави! Что бы мы без него делали?
— Ладно, — говорит Рэнди. — Значит, продолжаем работать с Дантистом. Пусть его проект для нас несущественен, зато есть надежда наскрести деньги и не продавать акции. Мы сохраним контроль над компанией. С другой стороны, если мы разорвем контракт с «АВКЛА», партнеры Дантиста затаскают нас по судам — они ничем не рискуют и ничего не теряют. Мы увязнем в тяжбах. Придется лететь в Лос-Анджелес и давать показания. Мы потратим уйму денег на адвокатов.
— И можем даже проиграть, — добавляет Ави.
Все смеются.
— Значит, надо и дальше работать с Дантистом, — заключает Рэнди, — хоть нам это и в лом.
Все молчат.
Не то чтобы они не соглашались с Рэнди — наоборот. Просто Рэнди занимается Филиппинами, ему расхлебывать последствия сегодняшнего решения. Лучше, чтобы он вызвался сам, а не по принуждению. Это он и делает сейчас, прилюдно и театрально. Остальные актеры: Ави, Берил, Том, Джон и Эб. Публика: миноритарные акционеры корпорации «Эпифит», Дантист, будущие судьи. Спектакль канет в неизвестность, если кто-нибудь не вчинит им иск, и участникам сегодняшнего совещания не придется свидетельствовать под присягой.
Джон решает копнуть немного глубже.
— «АВКЛА» финансирует Филиппины на свой риск, да?
— Да, — авторитетно заявляет Ави, обращаясь непосредственно к гипотетическому судье. — Раньше компании, которые прокладывали кабель, заранее продавали мощности, чтобы собрать капитал. «АВКЛА» кладет кабель на свои средства. По окончании работ они будут единственными владельцами и мощности продадут тому, кто предложит больше.
— Деньги не «АВКЛА», у них столько нет, — говорит Берил. — «НОХГИ» отстегнула им толстую пачку долларов.
— Кто отстегнул? — спрашивает Эб.
— «Ниигата Оверсиз Холдинг Груп, инкорпорейтед», — хором отвечают три голоса.
Эб смотрит озадаченно.
— «НОХГИ» проложила кабель от Таиланда к Лусону, — поясняет Рэнди.
— Я, собственно, к чему, — продолжает Кантрелл. — Если Дантист тянет кабель на свой страх и риск, всякая задержка со сроками чревата для него серьезным убытком. Мы должны выполнить свои обязательства.
Джон говорит гипотетическому судье на процессе «Дантист против корпорации «Эпифит»:
— «Мы точно следовали условиям нашего соглашения с «АВКЛА».
Но это совсем не так хорошо прозвучит на другом гипотетическом процессе — «Спрингборд Груп» против корпорации «Эпифит». Поэтому Ави спешит добавить:
— Мы тщательно проработали вопрос и убедились, что на данном этапе наши обязательства по отношению к Дантисту и собственным акционерам полностью совпадают. Выполняя одни, мы одновременно выполняем другие.
Берил закатывает глаза и облегченно вздыхает.
— Значит, продолжаем работать на Филиппинах, — говорит Рэнди.
Ави спрашивает официально, как будто Рэнди держит руку на бесплатной гостиничной Библии:
— Рэнди, ты действительно в силах полностью выполнить наши обязательства по контракту с Дантистом?
— Это следует обсудить отдельно, — произносит Рэнди.
— До завтра потерпит? — спрашивает Ави.
— Конечно. Пока не горит.
— Простите, я в туалет, — говорит Ави.
Этим сигналом они неоднократно пользовались в прошлом. Ави встает и выходит. Через мгновение Рэнди говорит: — «Я тоже» и выходит следом.
Он с изумлением видит, что Ави и впрямь писает. Под влиянием момента Рэнди расстегивает ширинку и пристраивается рядом. Только в середине процесса до него доходит, какая это победа.
— В чем дело? — спрашивает Рэнди.
— Сегодня утром я менял в холле деньги, — говорит Ави. — И угадай, кто собственной персоной вошел в отель. Прямо из аэропорта.
— Черт, — говорит Рэнди.
— Сам Дантист.
— Не на яхте?
— Яхта идет следом.
— С ним еще кто-нибудь?
— Нет, но могут подтянуться.
— Зачем он здесь?
— Должно быть, прослышал.
— Черт. Меньше всего я хотел бы завтра на него налететь.
— А что?
— Ничего особенного.
— Ничего такого, что потом смогут объявить твоим недосмотром?
— Думаю, нет, — говорит Рэнди. — Просто на Филиппинах все довольно хитро, и надо это обсудить.
— Ладно, — кивает Ави. — Если завтра столкнетесь, ради бога, ни слова о делах. Ограничься погодой.
— Усек, — отвечает Рэнди и застегивает ширинку. Однако на самом деле он думает: какого черта я столько просиживал штаны в университете, если могу вот так?
Это напоминает ему еще об одном деле.
— Ах да. Я получил чудной е-мейл.
Ави немедленно спрашивает:
— От Энди?
— Как ты догадался?
— Ты сказал «чудной». А что, е-мейл правда от него?
— Не знаю. Может, нет. Не в этом смысле «чудной».
— Ты ответил?
— Не я. Dwarf@siblings.net.
— Погоди. Siblings.net — это система, которую ты администрировал?
— Да. У меня там некоторые привилегии. Я открыл себе почтовый ящик с именем dwarf — гном. Доказать, что это я, невозможно. Отправил этому типу анонимный е-мейл примерно в таком духе: пока не доказано обратное, я буду думать, что вы — мой старый враг.
— Или новый.

СТРЕЛА

Юный Лоуренс Притчард Уотерхауз в гостях у бабушки с дедушкой пашет поле. Лемех плуга выворачивает чернозем и выкладывает в две гряды, неровные вблизи, но математически стройные и прямые, как граммофонные дорожки, если смотреть издали. Из одной гряды торчит каменная лодочка. Юный Уотерхауз наклоняется и берет ее. Это кремнёвый наконечник индейского копья.
U-553 — черное стальное копье, торчащее милях в десяти к северу от Йглма. Серые валы вздымают ее и бросают вниз, но в целом она остается на месте, поскольку сидит на подводной скале, которую местные называют Риф Цезаря, или Горе Викинга или Смерть Голландца.
В прерии наконечники могут прятаться в любом природном субстрате: почве, речном иле, в сердцевине дерева. У Лоуренса талант их находить. Как получается, что он идет по полю, усеянному камнями от последнего оледенения, и находит наконечники стрел? Как человеческий глаз различает крошечный искусственный предмет во взвихренном хаосе природы, иголку информации в стоге шума? Наверное, это внезапная искра на контакте умов. Наконечник — человеческое, отделенное от человека: органика разложилась, камень остался. Кристалл воли. Мозг выхватывает не форму, а смертоносную целесообразность. Вот почему юный Уотерхауз находил наконечники. Вот почему летчики обнаружили сегодня U-553. Вот почему радисты Beobachtung Dienst научились понимать якобы искаженную речь Черчилля и Франклина Делано Рузвельта по телефону. Однако в криптографии такой номер не проходит. Это большая помеха для всех, кроме американцев и британцев, которые разработали математические методы поиска наконечников в щебне.
Риф Цезаря разворотил днище носового отсека U-553, сама лодка осталась торчать над водой. Она едва не проскочила по инерции, но застряла посередине, словно исполинские качели. Носовая часть почти целиком заполнена водой. Лодка без команды, значит — ничейная. «Чур моя!» — сказал Британский Военно-Морской флот. Рядом дежурят эсминцы, чтобы ее не торпедировала какая-нибудь другая немецкая подлодка.
Уотерхауза спешно выдернули из замка. Сейчас свинцовой завесой спустились сумерки, а волчья стая охотится по ночам. Он в рубке маленького сторожевого корабля, у которого даже в слабую качку гидродинамика как у пустой бочки из-под бензина. Внизу Уотерхауз блевал бы без передышки, поэтому стоит наверху, расставив ноги, согнув колени и двумя руками держась за фальшборт. Лодка надвигается. На боевой рубке — число 553 и белый медведь с пивным бокалом в лапе.
— Занятно, — говорит Уотерхауз полковнику Чаттану. — Пять-пять-три — произведение двух простых чисел: семь и семьдесят девять.
Чаттан выдавливает одобрительную улыбку, но видно, что это простая вежливость.
Остальное подразделение наконец-то прибыло. Бойцы успешно завершили задание в Норвегии и направлялись на Йглм, когда сообщили о севшей на риф U-553. Встреча с Уотерхаузом произошла прямо на корабле — ребята не успели даже присесть, не то что распаковать вещи. Уотерхауз несколько раз сказал, что им понравится на Йглме, и не знает, о чем говорить дальше. У команды сторожевого корабля нет допуска «Ультра-Мега», а все, о чем могли бы говорить Чаттан с Уотерхаузом, подпадает под этот гриф. Поэтому он и суесловит о простых числах.
Лейтенанта морской пехоты и большую часть рядовых оставили обустраиваться на Йглме. С Уотерхаузом на подводную лодку отправляются полковник Чаттан и сержант по имени Роберт Шафто.
Шафто — жилистый, с бугристыми мышцами, светлые волосы сострижены почти под ноль, отчего большие голубые глаза кажутся еще больше. У него крупный нос, крупный кадык, крупные рытвины от прыщей и несколько шрамов возле глазниц. Крупные черты в сочетании с ладным телосложением по-настоящему впечатляют; на него трудно не оглядываться. По-видимому, это человек сильных чувств, но еще более сильной самодисциплины. Когда кто-то говорит, Шафто, не мигая, смотрит ему в глаза. Когда все молчат, он смотрит на горизонт и думает. Когда он думает, то беспрестанно перебирает пальцами. У всех остальных пальцы при деле, за что-нибудь цепляются, но Шафто просто стоит на палубе, словно в очереди в киношку. Они с Уотерхаузом, в отличие от Чаттана, в теплой одежде, которую позаимствовали на сторожевике.
Всем присутствующим уже известно, что немецкий капитан, последним покидая подлодку, захватил «Энигму» с собой. С британских самолетов, все еще круживших в небе, видели, как он опасно наклонился со спасательного плотика и швырнул диски в огромную, с гору, волну. Сама машинка тоже отправилась за борт.
Немцы знают, что поднять ее невозможно. Они не знают другого: никто и не будет ее искать, поскольку в месте, под названием Блетчли-парк, уже знают про четырехдисковую «Энигму» все, что требуется. Британцы тут только для видимости, на случай, если кто-нибудь наблюдает.
Уотерхауз не ищет «Энигму». Он ищет кремнёвые наконечники.
Сторожевой корабль сперва приближается к подлодке с наветренной стороны, потом капитан, подумав, огибает корпус субмарины и заходит с подветренной. Так, соображает Уотерхауз, ветер будет гнать их от рифа. Снизу подлодка выглядит толстощекой. Часть, которой положено при всплытии быть над водой, серая и узкая, как нож. Часть, которой положено быть под водой, широкая и черная. Смелые британские моряки уже высадились на лодку и подняли над боевой рубкой английский военно-морской флаг. Вероятно, они подошли на вельботе с малой осадкой. Он болтается рядом, привязанный паутиной тросов; закрепленные на бортах автомобильные покрышки не дают ему биться о субмарину.
— Здесь мы определенно в неевклидовом пространстве, — шутит Уотерхауз. Чаттан подается вперед и прикладывает ладонь к уху. Уотерхауз продолжает: — Более того, оно зависит от времени и должно рассматриваться не в трех, а в четырех измерениях.
— Простите?
Еще чуть-чуть, и они сами наскочат на риф. Моряки запускают ракету, которая натягивает между кораблями веревку, потом некоторое время наводят переправу. Уотерхауз боится, что его заставят по ней идти. Вернее, не столько боится, сколько досадует: он думал, что до конца войны уже не будет подвергаться опасности. Чтобы скоротать время, смотрит на подлодку и моряков: те выстроились в цепочку и по рукам передают бумаги и книги в боевую рубку, а оттуда в вельбот. Боевая рубка, утыканная орудийными дулами, антеннами и перископами, похожа на замысловатого паука.
Уотерхауза и Шафто действительно отправляют на U-553 в какой-то вроде тележке, скользящей по натянутому тросу. Матросы надели на них спасжилеты: теперь, если их сразу не разобьет о камень, они не захлебнутся, а только умрут от переохлаждения.
Когда Уотерхауз на середине переправы, под ним проходит подошва волны. Он глядит в разверстую бездну и видит Риф Цезаря в темно-синем меху ракушек. Можно спуститься и встать там. На мгновение. Потом тысячи тонн ледяной воды рушатся в пустоту, вздымаются и наподдают ему под зад.
Он глядит на U-553, которая зловеще нависает сверху. Первое впечатление, что это скорее дуршлаг, чем боевой корабль. На корпусе, словно татуировка, ряды удлиненных прорезей, закрученные, как линии обтекания. Металл выглядит на удивление хлипким. Потом Уотерхауз заглядывает в прорези — свет проходит насквозь, от других прорезей, в палубе — и различает изогнутый силуэт прочного корпуса, куда более мощного, чем наружный. У лодки два бронзовых трехлопастных винта, примерно ярд в поперечнике, покореженных от столкновения бог знает с чем. Сейчас они в воздухе, и Уотерхауз, глядя на них испытывает то же нелепое смущение, что в Перл-Харборе при виде оголенных гениталий у мертвецов. Горизонтальные и вертикальные рули торчат из корпуса ниже винтов, а у верхней части кормы видны две грубые металлических плиты, наподобие люков. Уотерхауз соображает, что из них-то и выходят торпеды.
Последние двадцать футов он пролетает на страшной скорости. Восемь рук ловят его за разные части тела и переносят в относительную безопасность: на палубу подлодки, сразу за боевой рубкой, под зенитным орудием. На корме торчит Т-образная стойка, от ее концов к ограждению рубки туго натянуты леера, чтобы держаться.
По примеру флотского офицера, который, судя по всему, назначен его опекать, Уотерхауз лезет вверх — то есть в сторону кормы, — держась за один леер, как за перила, спускается в люк на корме и оказывается внутри. Через мгновение за ним сбегает Шафто.
Хуже места Уотерхауз не видел в жизни. Подобно сторожевому кораблю, с которого они только что сошли, подводная лодка плавно приподнимается на волне, но потом, в отличие от корабля, с грохотом рушится на скалу, чуть не опрокидывая тебя навзничь. Ощущение, что ты в мусорном баке, по которому лупят кувалдой. U-553 до половины заполнена густой кашей из дешевого вина, дизтоплива, электролита и нечистот. Поскольку лодка наклонена, месиво глубже всего в носовой части, но при каждом ударе о скалу цунами прокатывается к корме. По счастью, Уотерхауза уже не мутит: он в том трансцендентном состоянии, когда его мозг больше обычного разлучен с телом.
Офицер ждет, пока гул уляжется, и неожиданно тихо спрашивает:
— Что именно вы хотели бы осмотреть, сэр?
Уотерхауз по-прежнему пытается сориентироваться, водя фонариком. Общая картина не складывается, в кружке света возникают только отдельные трубы и провода. Наконец он решает не двигаться и быстро-быстро чертит фонариком. Проступает картина: они в узком лазе, явно спроектированном инженерами для инженеров, чтобы обеспечить доступ к нескольким милям труб и проводов, втиснутых в узкий пережим.
— Нас интересуют бумаги капитана, — говорит Уотерхауз. Лодка снова уходит в пустоту; он прислоняется к чему-то скользкому, зажимает руками уши, закрывает глаза, рот и выдыхает через нос, чтобы жижа не попала внутрь. Опирается он на что-то холодное, твердое и круглое. Уотерхауз светит фонариком и видит, что оно медное. Чирканье лучом выхватывает из мрака какой-то медный космический корабль, зажатый под (если он не ошибается) койкой. Уотерхауз едва не выставляет себя круглым идиотом, спросив, что это такое, но тут узнает торпеду.
В следующую тихую интерлюдию он спрашивает:
— Есть здесь что-нибудь вроде личной каюты, где...
— В носовой части, — отвечает офицер. Нельзя сказать, чтобы это звучало обнадеживающе.
— Бля! — говорит сержант Бобби Шафто.
Это его первое слово примерно за полчаса. Он плещет вперед, и британский офицер вынужден спешить следом. Палуба снова уходит из-под ног, они останавливаются и разворачиваются, чтобы волна фекалий ударила не в лицо, а в спину.
Начинается спуск. Каждый шаг — неравный бой со здравым смыслом и осторожностью, а шагов надо сделать много. То, что Уотерхауз счел пережимом, продолжается, не расширяясь — видимо, до самого носа. Наконец они находят предлог остановиться: каюту или угол каюты футов четыре на шесть. Здесь койка, откидной столик и шкафчик из настоящего дерева. Вместе с фотографиями семьи и друзей это создает почти домашнее впечатление, которое, впрочем, начисто портит портрет Адольфа Гитлера на стене. Уотерхауз возмущен такой безвкусицей, потом вспоминает, что они на немецкой подводной лодке. Паводок нечистот под косым углом разрезает каюту примерно пополам. Наверху плавают бумаги и другой бюрократический детрит. Готический шрифт вызывает у Лоуренса смутную ассоциацию с Руди.
— Соберите все, — говорит Уотерхауз, но Шафто и офицер уже сгребают мокрое папье-маше и засовывают в парусиновый мешок.
Капитанская койка в кормовой или верхней части каюты. Шафто откидывает ее, заглядывает под матрас и подушку, ничего не находит.
Откидной столик в наиболее затопленном конце. Уотерхауз бредет к нему, стараясь не оступиться. Нащупывает ногой ящик, как слепой, шарит руками в жидких помоях. Ему удается вытащить несколько коробочек и передать Шафто. Тот вытряхивает содержимое в мешок. Скоро становится ясно, что в столе больше ничего нет.
Лодка взлетает и рушится вниз. Жижа прокатывается вперед, на мгновение обнажая что-то в углу каюты, видимо, закрепленное у носовой переборки. Уотерхауз делает шаг вперед.
— Это сейф! — Он поворачивает диск. Тяжелый. Хороший сейф. Немецкий. Шафто и британский офицер переглядываются.
В люке появляется британский матрос.
— Сэр! — докладывает он. — Поблизости замечена еще одна немецкая подлодка.
— Мне пригодился бы стетоскоп, — задумчиво произносит Уотерхауз. — Здесь есть лазарет?
— Только аптечка, — отвечает британский офицер. — Где-нибудь плавает.
— Сэр! Есть, сэр! — Шафто исчезает. Через минуту он возвращается, держа над головой немецкий стетоскоп. Бросок. Уотерхауз ловит стетоскоп в воздухе, вставляет в уши и под жижей прикладывает мембрану к сейфу.
Ему это не совсем в новинку. Из мальчиков, которые помешаны на замках, нередко вырастают мужчины, помешанные на криптографии. Бакалейщик в Мурхеде, Миннесота, разрешил маленькому Уотерхаузу играть с сейфом. К изумлению бакалейщика, Лоуренс подобрал комбинацию и сделал об этом школьный доклад.
Этот сейф куда лучше, чем у бакалейщика. Поскольку Уотерхауз все равно не видит диска, он закрывает глаза.
Словно в полусне, он слышит крики, как будто происходит что-то ужасно важное. Может быть, кончилась война. Тут у него вырывают головку стетоскопа. Уотерхауз открывает глаза и видит, что сержант Шафто поднес мембрану ко рту, как микрофон. Шафто спокойно смотрит ему в лицо и говорит в стетоскоп:
— Сэр, торпеды в воде, сэр.
После этого разворачивается и выходит, оставив Уотерхауза одного.
Уотерхауз успевает подняться по трапу к боевой рубке и уже видит диск серовато-черного неба, когда вся лодка вздрагивает. Прокатывается гул. Волна нечистот выбрасывает его наверх, на палубу субмарины, товарищи подхватывают и заботливо удерживают от падения в океан.
Движение U-553 на волнах изменилось. Она подпрыгивает гораздо сильнее, как будто хочет соскочить с рифа.
Уотерхаузу требуется примерно минута, чтобы сориентироваться. Кажется, он поранился. Определенно какая-та ерунда с левой рукой, на которую он приземлился.
Пробегает мощный луч: свет прожектора со сторожевого корабля. Матросы матерятся. Уотерхауз приподнимается на здоровом локте и заглядывает в корпус подводной лодки, следуя за лучом прожектора. Лодка распорота под ватерлинией, рваные края дыры торчат внутрь. Вонючая жижа вытекает в Атлантический океан.
— Бля! — Сержант Шафто срывает со спины маленький, но увесистый заплечный мешок, растягивает завязки. Британские матросы светят ему фонариком.
Уотерхауз, в полубреду, с трудом верит своим глазам: Шафто вытащил связку аккуратных буровато-желтых цилиндриков толщиной в палец и длиной дюймов по шесть. Еще он вынул всякую мелочевку, в том числе моток жесткого красного шнура.
— Черт, — говорит британский офицер. — Взрывать будет.
Он задумывается только на мгновение; лодка снова приподнимается на волне и скребет днищем по рифу — возможно, сползает.
— Оставить судно!
Почти все перебираются в вельбот, Уотерхауза отправляют назад на тележке. Примерно на середине пути к сторожевому кораблю он скорее ощущает, чем слышит взрыв.
Остаток пути он практически ничего не видит, и даже на сторожевике перед глазами по-прежнему плывет. Некто по имени Енох Роот хочет непременно осмотреть его руку и голову, для чего надо спуститься вниз. До сих пор Уотерхауз понятия не имел, что повредил голову, и это неудивительно: голова — то место, которым соображают; если она повреждена, как это сообразить?
— Вас наградят по меньшей мере «Пурпурным сердцем», — говорит Енох Роот небрежно, как будто плевать хотел на ордена, но допускает, что для Уотерхауза это большое дело. — И, вероятно, очередную награду получит сержант Шафто, мать его за ногу.

МОРФИУМ

Шафто по-прежнему видит это слово, стоит закрыть глаза. Лучше бы он сосредоточился на деле: как ловчее заложить взрывчатку под кницы, соединяющие сейф с субмариной. «MORPHIUM» напечатано на желтой этикетке. Этикетка наклеена на стеклянный пузырек. Стекло темно-малиновое, как все вокруг, когда тебя ослепят мощным лучом света.
Харви, матрос, вызвавшийся на подмогу, все время светит ему фонариком в глаза. Это неизбежно. Шафто неудобно заклинен под сейфом, пытается приладить капсюли скользкими, онемевшими от холода пальцами. Это вообще было бы невозможно, не попади в лодку торпеда: до тех пор сейф был полностью покрыт жидким дерьмом. Теперь оно слилось.
Харви никуда не заклинен, его швыряет при каждом пароксизме лодки, которая бьется, как выброшенная на берег акула, и со всей дури пытается соскочить с рифа. Луч фонарика постоянно чиркает Шафто по глазам, он моргает и видит бесчисленные малиновые пузырьки с надписью МОРФИУМ.
— Черт! — орет он.
— Что-то не так, сержант? — спрашивает Харви.
Харви не понимает. Он думает, что Шафто чертыхается из-за какой загвоздки со взрывчаткой. Со взрывчаткой загвоздки нет. Загвоздка с Шафто.
Он был прямо там. Уотерхауз отправил его за стетоскопом, и Шафто бегал по субмарине, пока не нашел деревянный ящичек. Открыл его, увидел кучу медикаментов. Порылся, ища то, что нужно Уотерхаузу. Пузырек лежал на самом виду, прямо перед глазами. Шафто касался его рукой. Видел этикетку в луче фонарика.
МОРФИУМ.
Однако не схватил. Будь там написано МОРФИЙ, схватил бы в ту же секунду, но там было МОРФИУМ. Только через полминуты до него дошло, что лодка, бля, немецкая, слова наверняка другие, и на девяносто девять процентов МОРФИУМ — тот же МОРФИЙ. Когда до него дошло, он уперся ногами в палубу и протяжно застонал. За грохотом волн никто не услышал. Потом двинулся дальше и отдал Уотерхаузу стетоскоп. Выполнил свой долг, потому что он — морской пехотинец.
Взрывом отрывать сейф от переборки — не его долг. Просто идея, возникшая в голове. Его учили взрывать; почему бы не пустить знания в ход? Шафто взрывает сейф не потому, что он — морской пехотинец, а потому, что он — Бобби Шафто. И еще потому, что это хороший повод вернуться за морфием.
Подлодка дергается, Харви летит на палубу. Шафто ждет, пока лодка замрет на месте, цепляется за что-то руками и выползает из-под сейфа. Сейчас главная опора на ноги, но нельзя сказать, что он стоит. В таком месте максимум везения — ухватиться за что-нибудь прежде, чем грохнешься задом. Харви не успел, Шафто пока держится.
— Поджигаю! — кричит Шафто. Харви вскакивает. Шафто помогает ему тычком в спину. Харви сворачивает налево и бежит вверх, к боевой рубке. Шафто поворачивает налево и бежит вниз. К носу. К сундуку Дэви Джонса, как моряки зовут смерть. К ящику с морфием.
Куда он запропастился? Прошлый раз плавал в жиже. Может быть — жуткая мысль, — выпал в пробоину от торпеды?.. Шафто минует несколько переборок. Наклон все круче; под конец он спускается спиной вперед, как по приставной лестнице, цепляясь за трубы, провода и цепи, на которых висят койки. До чего ж эта лодка длинная.
Странный способ убивать. Шафто не уверен, что одобряет подводные лодки. Он закалывал китайских бандитов штыком. Одного ударил прикладом по голове, кажется, насмерть. На Гуадалканале убивал нипов из разных видов огнестрельного оружия, сбрасывал на них камни, разводил костры у входа в пещеру, в которой они укрылись, подкрадывался в джунглях и перерезал глотку, обстреливал их позиции из миномета; одного сбросил с обрыва в море. Разумеется, он давно знал, что убивать врагов в схватке один на один вроде как не модно. Не то чтобы он много об этом думал. «Виккерс» в Италии заставил немного задуматься. Теперь он в самой знаменитой машине для убийства, и что видит? Клапаны. Вернее, штурвалы, чтобы эти клапаны открывать и закрывать. Целые переборки заняты железными колесами, от двух дюймов до больше фута в диаметре, сидящими густо, как ракушки на скале. Они выкрашены черной и красной краской, отполированы до блеска человеческими ладонями. А где не штурвалы, там рубильники, огромные, как в кинокартинах про Франкенштейна. Есть большой поворотный переключатель, наполовину зеленый, наполовину красный. И совсем нет окон. Только перископ, в который вдвоем уже не заглянешь. Значит, для этих ребят война — сидеть задраенными в герметической бочке с дерьмом и штурвалами, включать рубильники по команде и, может быть, иногда узнавать от офицера, что сейчас они опять убили кучу народа.
Вот он, ящичек, — на койке. Шафто хватает его и открывает. Все внутри перемешалось, малиновых пузырьков много, он пугается, что придется читать все жуткие немецкие этикетки, но через секунду находит МОРФИУМ, хватает, прячет в карман.
Уже на пути к боевой рубке его бросает на палубу очередным ударом волны. Шафто долго катится кубарем в глубь лодки, прежде чем успевает за что-то схватиться. Все черно: он потерял фонарик.
Шафто близок к панике. Вообще-то он не паникер, просто весь как на иголках, потому что действие морфия кончается. Мощная голубая вспышка наполовину слепит глаза, раньше, чем он успевает зажмуриться. Внизу что-то шипит. Бобби двигает левой рукой, ее что-то держит: петля от фонарика, которую он, оказывается, сообразил натянуть на запястье. Свет скребет по стальной решетке, на которой Шафто распростерт, как мученик на жаровне. Новая голубая вспышка, расчерченная в черную клетку, опять шипение. Пахнет электричеством. Шафто несколько раз ударяет фонариком по решетке и тот, поморгав, зажигается вновь.

Предыдущая страница 14 Следующая страница


15 Нил Стивенсон

Решетка сделана из прутьев примерно в палец толщиной, идущих где-то через два дюйма. Шафто лежит на ней и смотрит в трюм, который, будь лодка в нормальном положении, находился бы внизу. В трюме все вверх дном: тщательно упакованный в ящики и составленный в штабеля груз раздербанен в окрошку из битого стекла, щепок, провианта, взрывчатки и стратегических руд. Все разбавлено водой и ходит волнами при каждом скачке мертвой подводной лодки. Идеальный серебряный шарик падает через решетку, блестит в свете фонарика и разбивается о дно трюма. Потом второй. Шафто смотрит вверх: на него катится град серебристых шариков. Разбились ртутные столбы, которыми измеряли давление.
Снова ослепительная голубая вспышка: могучий электрический разряд. Шафто снова смотрит через решетку и видит, что в трюме полно огромных металлических тумб, из которых торчат гигантские клеммы. Время от времени мокрый мусор замыкает контакты и трюм озаряет дуга; тумбы — это аккумуляторы, которые позволяют лодке двигаться под водой.
Пока сержант Роберт Шафто лежит мордой на холодной решетке и глубоко дышит, набираясь решимости для рывка, лодку швыряет так, что он чудом не улетает вниз, в затопленный нос. Месиво в аккумуляторном трюме волной прокатывается вниз, набирая по пути скорость, и с пугающей силой ударяет в переборку; слышно, как вылетают заклепки. Сейчас в луче фонарика виден весь трюм, до самого дна. Шафто видит расколотые ящики, маленькие, как для чего-то очень тяжелого. В щели между разошедшимися досками видны желтые бруски, когда-то уложенные аккуратно, а теперь рассыпанные. Именно так Шафто представлял себе золотые слитки. Одна неувязочка: их слишком много. Не может быть столько золотых слитков. Это как в детстве в Висконсине, когда он перевернул гнилушку и увидел тысячи муравьиных яиц, семя будущего в черной почве.
На миг возникает искушение. Такие деньжищи — не сосчитать. Если только добраться до этих слитков...
Видимо, взрывается тротил, потому что Шафто на мгновение глохнет. Все, пора сваливать. Он забывает про золото; морфий — неплохая добыча для одного дня. Пробирается по решетке в коридор. Из капитанской каюты валит дым. Переборки выгнуло взрывной волной.
Сейф оторвался! А трос, который они к нему привязали, цел Видимо, за него тянут сверху, потому что трос натянут, как сволочь. Сейф зацепился за какую-то корявую преграду. Приходится его освобождать. Сейф дергается, ползет вперед, натыкается на что-то еще. Шафто идет за ним по коридору, по трапу боевой рубки и, наконец, вылезает из люка. В лицо летят ветер и крики «ура!»
Меньше чем через пять минут подлодка рушится в море. Шафто представляет себе, как она кубарем катится с рифа в подводный каньон, рассыпая золотые слитки и шарики ртути, как волшебный порошок в черной воде. Шафто снова на сторожевом корабле, все хлопают его по спине и поздравляют. Хочется одного: отыскать укромное место и открыть малиновый пузырек.

КОСТЮМ

Рэнди выглядит положительным и собранным: что значит костюм!
Всем уши прожужжали, что компьютерщики не любят наряжаться. Ави выяснил, что хорошая одежда может быть очень комфортной — скажем, брюки от костюма куда удобнее джинсов. Кроме того, он достаточно терся среди компьютерщиков, чтобы понять: раздражает не столько костюм, сколько необходимость одеваться. То есть не просто напяливать брюки с пиджаком, но и выбирать их, вовремя отдавать в чистку, следить за модой — задача непосильная для людей, которые надевают костюм раз в пять лет.
Значит, так: у Ави в одном из компьютеров есть таблица с обхватом груди, длиной шагового шва и прочими мерками каждого из сотрудников. За пару недель до ответственного мероприятия он просто отправляет это все факсом портному в Шанхай. Костюм прибывает курьерской почтой ровно за двадцать четыре часа до срока и по пневматической трубе отправляется в гостиничную прачечную. Сегодня утром, когда Рэнди выходил из душа, постучал коридорный и внес отглаженный костюм с рубашкой и галстуком. Рэнди это все надел (десятый ксерокс с плохой схемы полувиндзорского узла прилагался). Костюм сидит как влитой. Теперь Рэнди ждет в холле, смотрит, как убывают цифры на электронном табло лифта, и украдкой разглядывает себя в большом зеркале. Рэнди в костюме — это такая хохма, которой должно хватить по крайней мере до конца ленча. Он размышляет об утренней электронной почте.

Кому: dwarf@siblings.net
От: root@eruditorum.org
Тема: Re: Зачем?
Дорогой Рэнди!
Надеюсь, Вы не обидитесь, если я буду называть Вас Рэнди, поскольку это совершенно очевидно Вы, несмотря на анонимность. Мысль удачная. Восхищен Вашей осторожностью.
По поводу того, что я могу оказаться Вашим «старым врагом»: очень грустно, что у Вас, такого молодого, уже есть старые враги. Или Вы о недавно приобретенном враге преклонного возраста? На ум приходят несколько кандидатов, однако я предполагаю, что Вы подразумевали Эндрю Лоуба. Я — не он. Вам это было бы очевидно, если бы Вы в последнее время посещали его сайт.
Зачем Вы строите Крипту?
Подписано:

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т. д. и т. п.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

Смотреть на цифры и гадать, какой из лифтов придет первым, совсем не увлекательно, но все же лучше, чем просто стоять без дела. Один застрял этажом выше, слышно, как заливается аварийный сигнал. В Азии многие бизнесмены, особенно китайские, считают шиком полностью оккупировать один лифт: телохранители посменно дежурят в кабине, вдавив пальцем кнопку открывания дверей и не обращая внимания на возмущенный трезвон.
Дзинь. Рэнди поворачивается на каблуках (попробуйте выполнить этот маневр в кроссовках!). Снова он поставил не на ту лошадь. Выиграл лифт, который только что был на самом верху. Рэнди делает шаг к зеленому огоньку. Двери открываются. Рэнди смотрит прямо в глаза Хьюберту (Дантисту) Кеплеру, доктору стоматологии.
Или вы о недавно приобретенном враге преклонного возраста?
— Доброе утро, мистер Уотерхауз! Когда вы вот так стоите с открытым ртом, то напоминаете мне пациента.
— Доброе утро, доктор Кеплер. — Рэнди слышит свои слова, как с другого конца километровой канализационной трубы, и тут же вновь прокручивает их в голове, проверяя, не выдал ли корпоративных тайн и не дал ли доктору Кеплеру повода вчинить иск.
Двери начинают закрываться, и Рэнди приходится всунуть между ними ноутбук.
— Осторожнее! Уверен, это дорогостоящее оборудование, — говорит Дантист.
Рэнди чуть не брякает: «У меня эти ноутбуки летят, как у трансвестита капроновые чулки» (или, может, больше в тему было бы «как крошка гнилого зуба из-под сверла бормашины»), но тут же мысленно зажимает себе рот. В компьютере у него корпоративная информация, собственность «АВКЛА». Если Дантист решит, что Рэнди наплевательски к ней относится, то распердится исками.
— Э-э... приятная неожиданность, — заикаясь, говорит Рэнди.
На докторе Кеплере очки размером с ветровое стекло «кадиллака» 1959 года. Это специальные стоматологические очки, отполированные, как зеркало паломарского телескопа, и покрытые суперотражающим слоем, чтобы вы видели в них исключительно свою пасть, насаженную на стержень горячего света. Глаза самого Дантиста таятся в глубине, как воспоминания детства. Это косящие серо-голубые глаза со стигийскими зрачками, полуприкрытые, словно их обладателю все в мире давно прискучило. В уголках сморщенных губ постоянно поигрывает улыбка: улыбка человека, который одновременно думает, как выплатить очередную страховку на случай врачебной ошибки, и ковыряется стальной фомкой в основании вашего мертвого премоляра, но прочел в специальном журнале, что врачей, которые улыбаются, пациенты чаще посещают и реже привлекают к суду.
— Скажите, — говорит он, — не получится ли у нас сегодня немного поболтать?
Сплюньте, пожалуйста.
Спасительный звонок! Кабина останавливается на первом этаже, виден вестибюль «Фут Меншн», облицованный мрамором исчезающих пород. Посыльные, замаскированные под свадебные торты, снуют туда-сюда, как на колесиках. Футах в десяти от лифта — Ави, рядом два роскошных костюма, из которых торчат головы Джона Кантрелла и Эберхарда Фёра. Все трое поворачиваются к лифту. При виде Дантиста лица у Эба и Джона становятся как у актеров в дешевом вестерне, только что получивших в лоб из мелкашки. У Ави, напротив, вид человека, который неделю назад напоролся на ржавый гвоздь, а сейчас почувствовал первое роковое шевеление столбняка.
— У нас сегодня напряженный день, — говорит Рэнди. — Ответ: да, если будет время.
— Хорошо. Ловлю на слове, — говорит доктор Кеплер. — Доброе утро, мистер Халаби. Доброе утро, доктор Фёр. Доброе утро, мистер Кантрелл. Приятно видеть вас такими джентльменами.
Приятно, что вы ведете себя по-джентльменски.
— Мы тоже очень рады, — говорит Ави. — Я так понимаю, мы сегодня еще увидимся?
— О да, — отвечает Дантист, — вы будете видеть меня весь день.
Боюсь, процедура будет долгой. Он поворачивается и молча идет по вестибюлю к кожаным креслам, почти скрытым за взрывами ярких тропических цветов. Сидящие в креслах по большей части молоды и хорошо одеты; при виде босса они вытягиваются во фрунт. Рэнди насчитывает двоих мужчин и трех девушек. Один — явный телохранитель, но и девушки, которых за глаза зовут Парками, Фуриями, Грациями, Норнами или Гарпиями, по слухам, тоже прошли курс спецподготовки и вооружены до зубов.
— Это кто? — спрашивает Джон Кантрелл. — Его ассистентки?
— Не смейся, — отвечает Ави. — В бытность свою зубным врачом он завел штат женщин для предварительной обработки пациентов, и это сформировало его парадигму.
— Издеваешься? — говорит Рэнди.
— Ты знаешь, как бывает. Когда ты приходишь к зубному врачу, ты на самом деле не видишь зубного врача, верно? Тебя встречает кто-то другой, верно? Всегда есть элитная категория деловитых тетечек, которые снимают зубной камень, чтобы врачу не возиться, и делают рентген. Сам врач сидит в кабинете и смотрит снимки — он имеет дело с абстрактным черно-белым изображением на маленьком куске пленки. Если он видит дырки, то приступает к делу. Если нет, выходит, произносит пару вежливых фраз и отправляет тебя домой.
— Так зачем он здесь? — спрашивает Эберхард Фёр.
— В том-то и суть! — говорит Ави. — Когда он входит, ты не знаешь, зачем он здесь: просверлить тебе дырку в черепушке или рассказать про свой отпуск на Гавайях.
Все взгляды обращаются к Рэнди.
— Что произошло в лифте?
— Я... ничего! — выпаливает Рэнди.
— Вы обсуждали филиппинский проект?
— Он просто сказал, что хочет со мной побеседовать.
— Гадство, — говорит Ави. — Значит, прежде надо побеседовать нам.
— Знаю. Поэтому и обещал поговорить, если выдастся свободная минута.
— Постараемся, чтоб у тебя сегодня свободная минута не выдалась. — Ави задумывается на минуту и продолжает: — Он совал руку в карман?
— А что? Думаешь, мог вытащить револьвер?
— Нет, — говорит Ави. — Просто мне кто-то сказал, что Дантист носит при себе скрытый магнитофон.
— Как переодетый полицейский? — недоверчиво переспрашивает Кантрелл.
— Ага, — говорит Ави таким тоном, будто это самое обычное дело. — Цифровой магнитофон размером со спичечный коробок. Может быть, с проводком и микрофоном под рубашкой. Может быть, нет. Так или иначе, ты не знаешь, когда он тебя записывает.
— А это не противозаконно? — спрашивает Рэнди.
— Я не юрист, — отвечает Ави. — Что важнее, не кинакутский юрист. Но для гражданского иска это не важно: если он потянет нас в суд, то сможет предъявить любые свидетельства.
Они смотрят через вестибюль. Дантист косолапо стоит на мраморе, скрестив руки на груди и опустив подбородок — выслушивает доклад подчиненных.
— Может, он и совал руку в карман, не помню, — говорит Рэнди. — Это не важно. Мы говорили в общем. И коротко.
— Он может проанализировать запись на приборе и по напряжению в голосе определить, когда ты врешь. — Джон явно наслаждается неограниченным разгулом паранойи. Это его стихия.
— Не беспокойся, — парирует Рэнди, — я его заглушил.
— Как? — спрашивает Эб. Он не расслышал иронии, поэтому удивлен и заинтригован. По лицу видно, что Эб рвется поговорить о чем-нибудь умном.
— Я пошутил, — объясняет Рэнди. — Если Дантист проанализирует запись, он увидит один равномерный стресс.
Ави и Джон смеются. Эб расстроен.
— А, — говорит он. — Я думал, что мы, если бы захотели, могли бы полностью заглушить его устройство.
— Магнитофон — не радио, — замечает Джон. — Как его можно заглушить?
— Метод Ван Эйка, — поясняет Эб.
Тут из кафе выходит Том Говард с замусоленным номером «Саут Чайна Морнинг Пост» под мышкой, а из лифта — Берил в парадном платье и боевой раскраске. Мужчины прячут глаза, притворяясь, будто ничего не произошло. Все здороваются и обмениваются пустяковыми фразами. Потом Ави смотрит на часы и говорит: «Пошли к султану», как будто предлагает заглянуть в «Макдоналдс».

ВЗЛОМЩИК

Уотерхаузу приходится оберегать сейф: Шафто рвется взорвать его толом, а Чаттан намерен отправить в Лондон, экспертам из Бродвей-билдингс. Уотерхауз хочет еще раз испробовать силы, просто из интереса.
Чаттан прав. У подразделения 2702 есть четкая и определенная задача. Взлом сейфов с немецких подводных лодок в нее не входит. Кстати, лазить на брошенные подводные лодки за сейфами и шифровками — тоже не их задача. Просто рядом не было больше никого с допуском «Ультра-Мега», а U-553 сидела так ненадежно, что Блетчли-парк не успевал прислать специалистов. Желание Уотерхауза вскрыть сейф никак не связано с задачей подразделения 2702, его собственными обязанностями или даже стремлением скорей разгромить фашистов. Просто Лоуренс Притчард Уотерхауз не может иначе. Это императив, его, как приказы, не обсуждают. На тележке, мчащейся по натянутому тросу, под ветром и дождем, с развороченными рукою и головой, не зная, доберется до корабля или рухнет в бездну, он еще помнил нервными окончаниями пальцев бесконечно малое дрожание диска под жидким месивом. Пока Енох Роот штопал его на борту сторожевика, Уотерхауз мысленно прикидывал, как может быть устроен сейфовый замок. А когда остальные бойцы подразделения 2702 без задних ног повалились на койки, в гамаки и спальные мешки на полу домовой церкви Йглмского замка, Уотерхауз, в бинтах и с рукой на перевязи, отправился по коридорам благоустроенной части замка в поисках бритвенных лезвий и куска графита.
Бритвы он находит в мусорном ведре, графит крадет из каморки, в которой Гхнкс держит гальванический люцифер. Все это вместе с бруском канифоли и паяльной лампой, относит в домовую церковь. Рядовой и сержантский состав разместился, как пристало морякам, в нефе, что по-гречески означает «корабль». Офицеры — в трансепте. Чаттан занял весь южный придел, Уотерхауз, Роот, лейтенанты британских ВДВ и МПФ США подвесили койки в северном. Малая толика немереных запасов брезента отделяет алтарь, Святую Святых, где когда-то пребывали Тело и Кровь Христовы. Теперь там стоит «халликрафтерс» модели S-27, пятнадцатиламповый супергетеродиновый приемник со сверхсовременными лампами-желудями, который ловит УКВ в диапазоне от 27 до 143 Мгц и принимает AM, FM и радарное излучение. Еще у него есть измеритель уровня сигнала, который был бы полезен, занимайся они и впрямь высокочастотной радиопеленгацией.
За брезентом горит свет, на стуле перед алтарем храпит морской пехотинец. Уотерхауз будит его и отправляет спать. Морпех пристыжен: он должен был бодрствовать и убедительно крутить антенну.
Сам радиоприемник практически не используется; его включают, когда входит посторонний. Все деревянные финтифлюшки с алтаря (если когда-то и были) уничтожены огнем, сгнили или растащены острозубыми скрггами на строительство гнезд. Остался прямоугольный базальтовый монолит, совершенно ровный, если не считать следов тёски. Идеальная подставка для сегодняшнего эксперимента.
Уотерхауз, с ущербом для поясницы, водружает сейф на алтарь. Сейф цилиндрический, как отрезок орудийного ствола. Уотерхауз ставит его на попа: круглая дверца с круглым диском смотрит в потолок, словно незрячий глаз; радиальные риски — точь-в-точь радужка.
За диском — механизм, который приводит Уотерхауза в бешенство. Каким-то образом вращая диск, он должен добиться такого положения, в котором дверца откроется. Вот, собственно, и все. То, что дверца до сих пор не открыта, — личное оскорбление. Чем крохотный — меньше кубического фута — объем внутри сейфа отличен от пространства, в котором Уотерхауз перемешается без помех? Что там, черт возьми, такое?
Канифоль похожа на плохой янтарь, пузырчатый, но все равно красивый. Уотерхауз зажигает горелку и проводит пламенем по краю бруска. Канифоль размягчается, плавится, капает на крышку сейфа, рядом с диском, образуя лужицу размером примерно с серебряный доллар.
Уотерхауз быстро погружает в нее лезвия опасным краем вверх, параллельно, на расстоянии чуть меньше дюйма, и придерживает их, пока холодный металл не выпьет тепло и канифоль снова не затвердеет. Он подложил зубочистки, чтобы тупые края не касались металла и не получился контакт.
Он припаивает к лезвиям проволочки и тянет их через алтарь к рации. Берет кусок графита, кладет на лезвия, как перемычку.
После этого снимает с приемника заднюю панель и начинает ковыряться внутри. Поменять надо не так и много: он хочет сделать устройство, которое преобразует электрические импульсы в звук и направляет в наушники, что, собственно, и делает приемник. Однако источник сигнала уже не передатчик на немецкой подлодке, а ток, идущий по проводу в левое лезвие, по графитовой перемычке, в правое лезвие и обратно по другой проволочке.
Чтобы все это заработало, требуется определенное время. Всякий раз, упираясь в очередной тупик, Уотерхауз начинает звереть. Тогда он встает и крутит антенну, якобы ища немецкую подлодку. Тем временем его осеняет, и он возвращается к работе.
Примерно на рассвете он слышит визг в наушниках — бакелитовых чашечках, соединенных приспособлением, похожим на примитивный хирургический инструмент. К приемнику от них тянутся перекрученные черная и красная проволочки. Уотерхауз убавляет громкость и надевает наушники.
Он кладет палец на сейф и слышит неприятный гул в ушах, проводит по холодному металлу и слышит скрежет. Любая вибрация заставляет дрожать графитовую перемычку, замыкая и размыкая цепь, модулируя ток. Лезвия и графит — это микрофон, и микрофон работает даже слишком хорошо.
Уотерхауз снимает руку с сейфа и некоторое время вслушивается. Слышно шебуршание скрргов, растаскивающих провиант подразделения. Слышно, как бьют волны о берег, как подпрыгивают на Дороге лысые шины Такси. У Такси не отрегулирован Развал. Слышно, как Маргарет — шырк-шырк-шырк — трет пол на кухне, и у спящих морпехов екает сердце; как трутся льдины у берегов Исландии и крутятся винты приближающегося конвоя. Лоуренс Притчард Уотерхауз подключен к Вселенной с полнотой, какую бессилен обеспечить даже Блетчли-парк.
В центре этой Вселенной — сейф с подводной лодки U-553, ее ось проходит через центр диска. Уотерхауз снова кладет на него руку, предварительно убавив громкость, чтобы не лопнули барабанные перепонки. Диск поворачивается с усилием, но плавно, как на воздушном демпфере. Однако остается трение. Его не ощущают замерзшие пальцы Уотерхауза, но в наушниках оно грохочет горным обвалом.
Когда замок щелкает, звук такой, будто Уотерхауз поднимает щеколду на главных вратах ада. Несколько раз приходится начинать по новой: он не знает, сколько чисел в комбинации и в какую сторону крутить сначала. Однако опытным путем начинает вырисовываться закономерность, и постепенно он приходит к следующей комбинации: 23 вправо — 37 влево — 7 вправо — 31 влево — 13 вправо.
Слышится смачный лязг, и Уотерхауз нутром чует, что можно снимать наушники. Он поворачивает колесико рядом с диском. При этом убираются радиальные собачки, запирающие дверцу. Он тянет ее вверх, осторожно, чтобы не порезаться о лезвия, и смотрит внутрь.
Разочарование, которое он при этом испытывает, никак не связано с содержимым сейфа. Это разочарование от того, что задача решена и он вернулся к базовому состоянию тоски и легкого раздражения, в котором живет, когда не взламывает замки или шифры.
Уотерхауз засовывает руку в сейф и нащупывает металлический брусок размером с булочку для хот-дога. Это для него не новость: они трясли сейф, словно дети — коробку с рождественским подарком, слышали, как что-то со звоном перекатывается, и гадали, чего бы там могло быть.
Брусок холодный и так сильно забирает тепло, что держать его почти больно. Уотерхауз трясет рукой, чтобы восстановить циркуляцию, вытаскивает брусок и бросает его на алтарь. Тот дважды подпрыгивает, звеня — самый музыкальный звук, который стены часовни слышали за много столетий, — и остается латунно блестеть в свете электрических лампочек (в часовню уже провели свет). Яркие отблески бьют в глаза Уотерхаузу, который много недель живет на сером и ненастном Йглме, ходит и спит в хаки и черном. Он зачарован красотой и яркостью бруска на грубом черном базальте еще до того, как мозг опознает в нем золотой слиток.
Из слитка получается мировое пресс-папье — весьма кстати, потому что в часовне сквозняк, а содержимое сейфа — листки папиросной бумаги, разлетающиеся от малейшего дуновения. Листки расчерчены бледными горизонтальными и вертикальными линиями, ячейки заполнены от руки печатными буквами, расположенными в группах по пять.
— Ба, что вы нашли! — говорит тихий голос.
Уотерхауз поднимает голову и смотрит в пугающе спокойные глаза Еноха Роота.
— Да. Шифровки, — отвечает Уотерхауз. — Не «Энигма».
— Я про другое, — говорит Роот. — Про корень всего зла. — Он пытается взять брусок, но пальцы соскальзывают. Тогда он берется покрепче и отрывает слиток от алтаря. Что-то цепляет его взгляд; он поворачивается к лампочке и сосредоточенно хмурится, как гранильщик алмазов.
— Здесь иероглифы, — говорит Роот.
— Простите?
— Китайские или японские. Нет, китайские — клеймо шанхайского банка. И цифры — проба и серийный номер. — Для миссионера он неожиданно подкован в таких вопросах.
До этой секунды слиток ничего для Уотерхауза не значил — просто образчик химического элемента вроде свинцового грузила или банки с ртутью. Однако мысль, что он может нести информацию, занятна. Просто необходимо встать и поглядеть. Роот прав: на слитке клеймо с маленькими восточными значками. Крохотные грани иероглифов вспыхивают под лампочкой — искры, проскакивающие через пространство между двумя странами Оси.
Роот кладет слиток на алтарь, быстро идет к столу, где лежит всякая канцелярия, берет лист папиросной бумаги и карандаш. Возвращается к алтарю, кладет тонюсенький лист на слиток и возит по нему боковой стороной грифеля, так что бумага чернеет везде, кроме тех мест, где вдавлены иероглифы или цифры. Через несколько секунд у него в руках идеальная копия клейма. Он складывает листок и убирает в карман, а карандаш возвращает на стол.
Уотерхауз давно вернулся к изучению шифровок из сейфа. Все они составлены одним почерком. Из месива в каюте они с Шафто выловили целую кипу разных бумаг, и капитанский почерк Уотерхауз знает; эти листки писал кто-то другой.
Ясно, что зашифрованы они не с помощью «Энигмы». Шифровки «Энигмы» начинаются с двух групп по три буквы в каждой, указывающей, как ставить диски. Ни на одном из листков таких букв нет, значит, использована какая-то другая система. Как у любого современного государства, у Германии уйма шифров, для одних используются книги, для других — машины. В Блетчли-парке взломали большую часть и тех, и других.
Однако поупражняться всегда приятно. Теперь, когда прибыло все подразделение 2702, на свидания с Маргарет рассчитывать не приходится. Шифры на листках — идеальная головоломка, чтобы заполнить зияющую пустоту, оставшуюся после вскрытия сейфа. Уотерхауз тоже заимствует несколько листков бумаги и час или два кропотливо копирует шифры, по два, по три раза проверяя каждую шифргруппу, чтобы не ошибиться.
С одной стороны, это ужасно муторно. С другой — шанс на самом нижнем уровне проштудировать шифртекст. Умение увидеть закономерность в хаосе бесполезно, если прежде не погрузиться в хаос. Если закономерности есть, он их сейчас не увидит Но, может быть, если цифры пройдут перед глазами и через руку с карандашом, подсознание включится в работу и выдаст подсказку — или само решение — недель этак через несколько, когда он будет бриться или крутить антенну.
Краем сознания он воспринимает, что Чаттан и остальные проснулись. Рядовых и сержантов в Святая Святых не пускают, но лейтенанты столпились вокруг и пялятся на слиток.
— Взламываете шифр? — Чаттан вразвалку подходит к столу. Он держит кружку с кофе двумя руками, чтобы согреть ладони.
— Снимаю копию, — говорит Уотерхауз и, поскольку тоже не чужд некоторой хитрецы, добавляет: — На случай, если оригиналы погибнут при перевозке.
— Очень предусмотрительно, — кивает Чаттан. — Кстати, вы, часом, не припрятали где-нибудь второй слиток?
Уотерхауз давно общается с военными и не ловится на подначку.
— Характер звуков, возникавших при покачивании сейфа, явно указывал на наличие внутри только одного металлического предмета, сэр.
Чаттан, хохотнув, прикладывается к кружке.
— Интересно, удастся ли вам взломать шифр, капитан Уотерхауз. Готов держать пари, что да.
— Спасибо за доверие, но пари явно проигрышное, сэр, — говорит Уотерхауз. — Скорее всего в Блетчли-парке его уже раскололи.
— Почему вы так думаете? — рассеянно спрашивает Чаттан. Вопрос из уст человека с допуском «Ультра-Мега» настолько глупый, что Уотерхауз теряется.
— Сэр, в Блетчли-парке взломали практически все немецкие военные и правительственные коды.
Чаттан притворно корчит разочарованную гримасу.
— Фи, Уотерхауз, как ненаучно! Вы делаете допущения.
Уотерхауз прокручивает разговор назад, пытаясь понять смысл упрека.
— Вы предполагаете, что шифр может быть не немецкий? Или что он не военный и не правительственный.
— Я лишь предостерегаю вас от допущений, — говорит Чаттан. Уотерхауз все еще обдумывает услышанное, когда к ним подходит лейтенант Робсон, командир взвода английских десантников.
— Сэр, — говорит он. — Надо бы сообщить в Лондон комбинацию.
— Комбинацию? — тупо переспрашивает Уотерхауз. Вне контекста слово практически ничего ему не говорит.
— Да, сэр, — четко отвечает Робсон. — К сейфу.
— А. — Уотерхауз смутно раздражен вопросом. Чего ради записывать комбинацию, если все нужное для взлома под рукой? Куда лучше иметь алгоритм вскрытия сейфов, чем одно частное решение. — Не помню. Забыл.
— Забыли? — переспрашивает Чаттан. Он делает это ради Робсона, который, похоже, со всей силы прикусил язык. — Может, вы ее записали, прежде чем забыть?
— Нет, — говорит Уотерхауз, — хотя помню, что она состояла исключительно из простых чисел.
— Это сужает круг поиска, — бодро замечает Чаттан. Однако Робсон, похоже, не удовлетворен.
— И состояла из пяти чисел, что занятно, поскольку...
— Пятерка — тоже простое число, — ловит на лету Чаттан. Уотерхаузу приятно, что его командир демонстрирует признаки дорогого и качественного образования.
— Хорошо, — цедит сквозь зубы Робсон. — Так и доложу в Лондон.

СУЛТАН

Великий визирь Кинакуты ведет их в приемную своего шефа, султана, и оставляет на несколько минут в конце длинного конференц-стола, для изготовления которого истребили несколько видов редких тропических деревьев. Основатели корпорации «Эпифит» наперегонки торопятся сострить по поводу размеров султанского офиса. Новый дворец, куда их привели, выстроен буквой «П» и с трех сторон охватывает экзотический сад вместе с древним и величественным старым дворцом. В конференц-зале десятиметровый потолок; стены, выходящие сад, целиком стеклянные. Впечатление такое, будто смотришь сквозь стенки террариума на макет древнего восточного дворца. Рэнди не большой знаток архитектуры, и ему решительно не хватает слов. Он мог бы сказать только, что это гибрид Тадж-Махала и храмов Ангкора.
Чтобы попасть сюда, они долго едут по пальмовой аллее, идут через сводчатый мраморный вестибюль, затем их проверяют металлоискателем, усаживают, поят чаем и просят разуться. Слуга в тюрбане поливает им руки теплой розовой водой из узорчатого кувшина, потом они еще с полмили тащатся по мрамору и восточным коврам. Как только за визирской задницей захлопывается дверь, Ави говорит:
— Чую мухлеж.
— Мухлеж? — ехидничает Рэнди. — По-твоему, это декорации? Думаешь, этот стол из ДСП?
— Все настоящее, — кисло признается Ави. — Просто когда тебя так обхаживают, значит, хотят ошеломить.
— Я ошеломлен, — говорит Рэнди. — Признаю. Ошеломлен.
— В переводе на обычный язык это значит «я сделаю какую-нибудь глупость», — говорит Ави.
— А разве мы будем что-нибудь делать? Это ведь не такие переговоры, на которых что-нибудь делают?
— Если ты о подписании контрактов и передаче денег, то ничего такого не будет. Однако произойдет многое.
Дверь снова открывается, великий визирь вводит группу японцев. Ави понижает голос:
— Просто помните, что вечером мы снова будем в отеле, а султан останется здесь, и сама встреча превратится в воспоминание. То, что у султана большой сад, решительно ничего не меняет.
Рэнди начинает злиться: все это настолько очевидно, что напоминать — просто оскорбительно. Однако отчасти он злится из-за того, что Ави видит его насквозь. Ави постоянно советует ему не быть романтиком. Однако если б не романтика, его бы здесь не было.
Отсюда вопрос: зачем здесь сам Ави? Может, из-за собственных, тщательно скрываемых романтических обольщений? Может, потому он и видит Рэнди насквозь? И предостерегает не коллег, а самого себя?
Вообще-то новоприбывшие не японцы, а китайцы — вероятно, с Тайваня. Великий визирь ведет их к назначенным местам. Стол такой огромный, что со своего конца они могли бы вести с эпифитовцами перестрелку, а вот разговаривать — только с помощью рупора. Несколько минут они делают вид, будто сад и старый дворец им хоть в малой степени интересны. Затем компактный, крепко сбитый дядечка лет пятидесяти резко поворачивается к эпифитовцам и быстро идет, таща за собой свиту. Это похоже на компьютерную модель, в которой черная дыра проходит через галактику, увлекая по пути звезды. Лицо знакомое, оно не раз мелькало в деловых журналах, но не настолько часто, чтобы Рэнди запомнил фамилию.
Не будь Рэнди компьютерщиком, ему бы пришлось выступить вперед и через силу разводить церемониальную волынку. По счастью, все это автоматически достается Ави. Он делает шаг навстречу тайваньцу, они обмениваются рукопожатиями и визитными карточками. Однако китаец смотрит сквозь Ави на других членов корпорации «Эпифит». Рэнди его явно не устраивает.
— Который тут Джон Кантрелл? — спрашивает он, остановив взгляд на Эберхарде Фёре.
Джон облокотился на подоконник — возможно, пытается определить, каким параметрическим уравнением отписывается изгиб лепестков восьмифутовой плотоядной лианы. Он оборачивается.
— Джон Кантрелл, — говорит Эб.
— Гарвард Ли. Вы не получили мои электронные письма?
Гарвард Ли! Теперь Рэнди вспомнил. Основатель «Гарвард Ли Компьютер Компани», среднего размера тайваньской фирмы по производству домашних компьютеров.
Джон ухмыляется.
— Я получил примерно двадцать электронных писем от неведомого лица, назвавшегося Гарвардом Ли.
— Это был я! Не понимаю, почему вы зовете меня неведомым лицом? — Гарвард Ли исключительно резок, но не видно, чтобы он обиделся по-настоящему. Вот кому явно не приходится бороться с романтизмом перед деловой встречей.
— Терпеть не могу электронную почту, — говорит Джон.
Гарвард Ли некоторое время смотрит ему в глаза.
— В каком смысле?
— Идея хороша. Исполнение дурно. Люди не соблюдают элементарных предосторожностей. Когда приходит письмо якобы от Гарварда Ли, они думают, что оно и впрямь от Гарварда Ли. Однако это письмо — всего лишь последовательность намагниченных секторов на вращающемся диске. Кто угодно может его подделать.
— А! Вы пользуетесь алгоритмом электронной цифровой подписи.
Джон задумывается.
— Я не отвечаю на электронные письма, не подписанные цифровым образом. Алгоритм ЭЦП — один из методов. Хороший, но не обязательно лучший.
Примерно на середине Гарвард Ли начинает согласно кивать.
— Какие-то структурные недочеты? Или вас смущает пятьсотдвенадцатибитная длина ключа? Устроил бы вас тысячадвадцатьчетырехбитный ключ?
Примерно на пятом предложении разговор между Ли и Кантреллом уносится за горизонт его криптографических познаний и Рэнди отключается. Ли — маньяк криптографии! Он лично всё это изучил — не просто велел подчиненным сделать выписки из соответствующих книг, а сам разобрал уравнение за уравнением.
Том Говард ухмыляется до ушей. Эберхард оживлен. Берил прячет улыбку. Рэнди отчаянно пытается сообразить, что тут смешного. Ави замечает его растерянность и, повернувшись спиной к тайваньцу, трет большим пальцем об указательный — деньги.
Ну да, конечно!
В начале девяностых Гарвард Ли выпустил несколько миллионов компьютеров и установил на них «Windows», «Word», «Excel», но как-то запамятовал выписать чек корпорации «Майкрософт». Примерно через год «Майкрософт» прищучил его в суде и выиграл огромную компенсацию. Гарвард Ли объявил себя банкротом — на счету, дескать, полный голяк. С тех самых пор «Майкрософт» пытается доказать, что у него где-то в загашнике припрятана пара миллиардов.
Ясное дело, Гарвард Ли напряженно думает, куда бы вложить деньги, чтобы до них не добрались ребятки из «Майкрософт». Есть старые испытанные методы: счет в швейцарском банке, подставные фирмы, крупные строительные инвестиции в самый глухой уголок Китая, золотые слитки в сейфе. Такие номера прошли бы со средним правительством, но «Майкрософт» в десять раз хитрее, в сто раз агрессивнее среднего правительства и не связан никакими определенными правилами.
Гарварду Ли нужны электронные деньги. Не та фигня, на которую ты, не светя электронную карточку, покупаешь в Сети футболки. Ему нужна железобетонная система, основанная на мощной криптографии, базирующаяся в офшорном информационном раю, и нужна позарез. Вот почему он бомбардирует Джона электронными письмами.
Том Говард подходит к Рэнди.
— Интересно, это просто Гарвард Ли или он думает, что открыл новый рынок?
— Возможно, и то, и другое, — предполагает Рэнди. — Вероятно, он знает еще людей, которые не отказались бы от приватного банка.
— Ракеты.
— Да. — (Китай постреливает по Тайваню баллистическими ракетами, как громила на Диком Западе, целящий под ноги положительному герою, чтобы тот поплясал.) — На Тайване случались банковские обвалы.
— В определенном смысле, — говорит Том, — эти ребята много ученее нас, потому что у них никогда не было надежной валюты.
Они с Рэнди глядят на Джона: он сложил руки на груди и вещает о пси-функции Эйлера; Гарвард Ли энергично кивает, а его придворные программеры лихорадочно записывают. Ави стоит в сторонке и смотрит на сад, словно у него в голове возможные следствия расцветают, идут в рост и сплетаются, как буйство тропической флоры.
Другие делегации вслед за великим визирем вливаются в помещение и столбят участки конференц-стола. Входят Дантист и его Норны, Фурии, Ассистентки или кто там они такие. Есть еще группа белых, говорящих с австралийским акцентом, все остальные — азиаты. Одни беседуют между собой, другие, выставив подбородки, смотрят на Кантрелла и Ли. Рэнди, в свою очередь, изучает их. Присутствуют две категории азиатов: в хороших и плохих костюмах. У плохо одетых азиатов короткие седые стрижки, желтая от никотина кожа и внешность киллеров. Они в плохих костюмах не потому, что не могут позволить себе хороших, им просто начхать. Эти из Китая. У азиатов в хороших костюмах ухоженные прически, парижские очки, чистая кожа, приклеенная улыбка. Они в основном из Японии.
— Давайте прямо сейчас обменяемся ключами, чтобы писать друг другу по электронной почте, — говорит Ли и делает знак помощнику. Тот подбегает к столу и открывает ноутбук. «Что-то что-то Ордо», — говорит Ли на кантонском. Помощник крутит трекбол и щелкает.
Кантрелл бесстрастно смотрит на стол. Садится на корточки, заглядывает под столешницу. Ощупывает край руками.
Рэнди нагибается и тоже заглядывает вниз. Конференц-стол — высокотехнологичный, пронизанный проводами, чтобы гости могли подключать ноутбуки прямо к нему, а не тянуть кабели через всю комнату и не драться из-за розеток. Значит, вся столешница нашпигована проводкой. Кабелей, соединяющих ее с внешним миром, не видно — наверное, они уходят через полые ножки в пустотелый пол. Джон ухмыляется, поворачивается к Ли, качает головой.
— В иных обстоятельствах я бы сказал «да», — отвечает он. — Однако при вашем уровне потребности в безопасности это неподходящее место для обмена ключами.
— Я не собирался пользоваться телефоном, — говорит Ли. — . Можно обменяться ключами на дискетах.
Джон стучит по дереву.
— Не важно. Попросите кого-нибудь из ваших сотрудников прочесть про ван-эйковский перехват. Ван Эйк, Вим ван Эйк, человек, который первый это продемонстрировал, — повторяет он программеру, который записывает. Потом, чувствуя, что Ли нужно краткое резюме, добавляет: — Есть способ прочесть внутреннее состояние компьютера, ловя побочное электромагнитное излучение модулей.
— А-а-а... — Ли выразительно переглядывается с помощниками, как будто получил ответ к давно мучившей их загадке.
Кто-то кричит в дальнем конце помещения — не в том, откуда входили гости, а в противоположном. Это человек, одетый примерно как визирь, хотя и не так пышно. В какой-то момент он переходит на английский — на тот диалект этого языка, которым пользуются бортпроводницы иностранных авиалиний, так часто повторяющие «пристегните ремни», что все сливается в один насморочный всхрюк.
Начинают входить низкорослые кинакутцы в хороших костюмах. Они садятся в торце стола, достаточно широком, чтобы вместить композицию Тайной Вечери. На месте Христа — особенно большое кресло. Наймите бритого финского дизайнера в очках без оправы, дипломированного специалиста по семиотике и архитектуре, выдайте ему чек на неограниченную сумму, поручите сконструировать трон и получите такое. Сзади отдельный стол для мелкой сошки. Фон составляет произведение искусства весом в несколько тонн: каменный фриз, ампутированный от каких-то развалин глубоко в джунглях.
Гости машинально дрейфуют к своим местам и остаются стоять. Великий визирь обводит их взглядом. В помещение проскальзывает маленький человечек и останавливается, словно не замечая собравшихся. У него прилизанные волосы, впечатление полноты минимизировано уловками парижских кутюрье. Он опускается в большое кресло. Рэнди в ужасе от такого нарушения этикета, пока не соображает: это и есть султан.
Все садятся. Рэнди придвигает кресло и плюхается. Кожаная обивка ловит зад, как бейсбольная перчатка — мяч. Первый порыв — включить ноутбук, однако в такой обстановке нейлоновая сумка и пластмассовый корпус кажутся дешевым ширпотребом. И вообще, что за студенческая привычка все записывать! Ави сказал, что ничего не произойдет, все будет сказано между строк. К тому же нельзя забывать о ван-эйковском перехвате. Кантрелл скорее всего просто накручивал Гарварда Ли, но Рэнди немного напуган. Он вынимает стопку миллиметровки — инженерский ответ блокноту — и одноразовую шариковую ручку с тонким кончиком.
У султана оксфордский английский, отдающий красным перцем и чесноком. Он говорит примерно пятнадцать минут.
В комнате несколько десятков живых тел, каждое — большой мешок с потрохами и жидкостями под таким напором, что проткни — брызнет на несколько метров. Каждое выстроено на арматуре из двухсот шести костей, соединенных исключительно ненадежными суставами, которые обычно скрипят, хрустят и щелкают. Вся конструкция обтянута мясом, раздута пульсирующими воздушными мешками, пронизана гордиевой канализацией, в которой булькают кислота и сжатый газ, насыщенные ферментами и растворителями. Их вырабатывают вонючие куски генетически запрограммированного мяса, расположенные по всей длине гибких шлангов. Куски пищи конвульсивно проталкиваются по склизкому лабиринту, разлагаясь на газ, жидкость и твердое вещество, которые надо регулярно выводить наружу, иначе человек отравится и умрет. Сферические, наполненные гелем емкости поворачиваются в слизистых шарнирах. Бесчисленные фаланги ресничек отбиваются от посторонних частиц, закукливая их в клей, чтобы потом выбросить. В каждом теле мышца гонит нескончаемый, циркулирующий поток сжатой жижи. И, несмотря на все это, пока султан говорит, тела не издают ни одного звука. Такое можно объяснить лишь властью мозга над телом и, в свою очередь, властью культурного воспитания над мозгом.
Хозяин старается вести себя по-султански: очертить горизонты и наметить направления, не увязая в управленческой трясине. Главная мысль (по крайней мере как представляется вначале): Кинакута всегда была перекрестком, местом встречи культур. Коренное малайское население. Фут и его династия Белых Султанов. Филиппинцы со своими испанскими, американскими, японскими правителями. Мусульмане на западе. Англосаксы на юге. Различные южно-азиатские культуры на востоке. Китайцы, по своему обыкновению, везде. Японцы, когда им приходила такая охота. И (хотите считайте, хотите нет) неолитические племена в глубине острова.
Поэтому современным кинакутцам более чем естественно проложить толстые оптоволоконные кабели во все стороны, включиться во все национальные телекоммуникационные сети, до которых смогут дотянуться, и стать своего рода цифровым базаром.
Гости серьезно кивают. Какая глубина прозрения! Как мудро султан соединяет древнюю традицию и современные технологии!
Однако это всего лишь поверхностная аналогия, продолжает султан.
Гости кивают еще энергичнее: разумеется, все, только что сказанное, полная мура. Некоторые строчат в блокнотах, чтобы не упустить мысль.
В конечном счете, говорит султан, географическое положение уже не имеет значения в сетевом мире. Киберпространство не знает границ.
Все усиленно кивают, кроме, с одной стороны, Джона Кантрелла, с другой — седых китайцев.
Однако это просто щенячьи кибервосторги. Что за бред! Разумеется, географическое положение и границы очень важны! Тут комната погружается в полумрак — невидимый механизм, встроенный в стекло, перекрывает льющийся в окна свет: жидкокристаллические жалюзи или что-то в таком роде. Из пазов, хитро замаскированных в потолке, выдвигаются экраны. Это спасает позвонки некоторых гостей, которые грозят переломиться от усиленных кивков. Черт возьми, важна география или нет? Где же окончательный вывод? Это не оксфордский дискуссионный клуб! К делу!
Султан вываливает на них графику: карта мира в одной из тех политкорректных проекций, в которых Америка и Европа кажутся обледенелым рифом в арктических широтах. На карту наложена сеть прямых линий, соединяющих крупные города. По мере того как султан говорит, они сгущаются, почти скрывая и сушу, и океан.
Так, говорит султан, обычно представляют себе Интернет: децентрализованная сеть, соединяющая любые две точки, без пережимов или, если хотите, узких мест.
Ан нет! Появляется новая графика: та же карта с иным рисунком линий. Теперь мы имеем сеть в пределах страны, иногда — континента. Однако между странами и особенно между континентами линий раз, два и обчелся. Ничего общего с сетью.
Рэнди смотрит на Кантрелла. Тот легонько кивает.
— Многие интернетчики убеждены, что Интернет надежен, потому что линии связи протянулись по всей планете. На самом деле, как видно на схеме, почти весь межконтинентальный трафик идет через небольшое число «бутылочных горлышек». Обычно их контролирует и отслеживает местное правительство. Очевидно, что всякое интернет-начинание, для которого нужна свобода от правительственного вмешательства, изначально обречено по причине фундаментальных структурных изъянов.
...свобода от правительственного вмешательства...
Рэнди не верит своим ушам. Будь султан нечесаным хакером и говори он в компании криптоаналитиков, это звучало бы нормально. Однако султан сам — правительство, а его слушатели — типичный истеблишмент.
Вроде этих стриженных под машинку китайцев! Они кто такие, черт возьми? Только не надо уверять, будто они не правительство Китая в том или ином смысле.
— Пережимы — лишь одна из структурных преград на пути создания свободного, суверенного киберпространства, не зависящего от географии, — заливается султан.
Суверенного?
— Другое препятствие — чересполосица законов и даже законодательных систем в области невмешательства в частную жизнь, свободы слова и телекоммуникаций.
Новая карта. Каждая страна раскрашена и заштрихована по немыслимо сложному принципу. Легенда внизу мало что объясняет. Виски сразу сжимает острая боль. В этом, разумеется, весь смысл карты.
— Каждая законодательная система сложилась из поправок, вносимых на протяжении столетий судебной и законодательной властью, — продолжает султан. — При всем уважении, они мало отвечают современным требованиям конфиденциальности.
Снова становится светло, в окна проглядывает солнце, экраны бесшумно втягиваются в потолок, и гости с некоторым изумлением обнаруживают, что султан стоит. Он подходит к большой и (разумеется) богато украшенной доске для го, на которой в сложном порядке расставлены черные и белые камешки.
— Быть может, приведу для сравнения го — хотя с тем же успехом подошли бы шахматы. В силу особенностей нашей истории мы, кинакутцы, одинаково хорошо владеем и той, и другой игрой. Вначале расстановка фигур проста и понятна. Однако игра развивается. Игроки, каждый в свой черед, принимают маленькие решения, каждое из которых понятно даже новичку. Однако в результате этих ходов расположение фигур меняется так, что лишь сильнейшие умы — или мощнейшие компьютеры — способны его постичь. — Говоря это, султан задумчиво смотрит на доску. Поднимает голову, поочередно заглядывает в глаза каждому из собравшихся. — Аналогия ясна. Законодательство в области свободы слова, телекоммуникаций и криптографии — результат череды простых, рациональных решений. Тем не менее, сегодня они настолько сложны, что никто не способен понять их даже в пределах одной страны, не говоря уже обо всем мире.

Предыдущая страница 15 Следующая страница


Криптономикон (часть 1) 16

Султан замолкает и в задумчивости подходит к доске. Гости давно перестали кивать или записывать. Никто больше не разводит видимость, все слушают, гадая, что будет дальше.
Однако султан молчит. Он кладет руку на доску и резким движением смахивает камешки. Они сыплются на ковер, скачут по паркету, гремят по столу.
По крайней мере пятнадцать секунд длится тишина. Султан замер как изваяние. Внезапно его лицо проясняется.
— Время начать с начала, — говорит он. — Это очень трудно в большой стране, где законы сочиняют законодатели и толкуют суды, где за ними тянется хвост исторических прецедентов. Однако здесь — султанат Кинакута. Я — султан и говорю, что закон здесь будет предельно прост: полная свобода информации. Я отказываюсь от всякой административной власти над информационными потоками внутри страны и через ее границы. Ни при каких обстоятельствах правительство не будет совать нос в информационные потоки или использовать свою власть для ограничения этих потоков. Таков новый закон Кинакуты. Приглашаю вас, господа, им воспользоваться. Спасибо.
Султан поворачивается и под аплодисменты выходит из зала. Вот вам, ребята, основные правила. Можете начинать игру.

Доктор Мохаммед Прагасу, кинакутский министр информации, встает со своего места по правую руку от трона и принимается охмурять дальше. Если у султана выговор британский, то у него — американский: он защитил диплом в Беркли и диссертацию в Стэнфорде. Рэнди знает многих, кто учился и работал с ним в те годы. По их рассказам, Прагасу ходил в джинсах и футболке, а по пиву и пицце ударял, как любой немусульманин. Никто понятия не имел, что он — троюродный брат, и у него на счету несколько сот миллионов долларов.
Но то было десять лет назад. На встречи с эпифитовцами он приходит в костюме, держится строго, но без чинов: доктор Прагасу любит, чтобы его называли «Праг». Все встречи начинаются с обмена последними анекдотами. Потом Праг справляется об однокурсниках, большая часть которых работает в Силиконовой Долине. Интересуется, что знающие люди говорят о биржевых перспективах самых крутых хайтечных компаний. Вспоминает свои бурные деньки в Калифорнии, потом переходит к делу.
Никто из них не видел Прага в его настоящей стихии. Трудно сохранить серьезную мину — кажется, что твой однокурсник взял напрокат костюм и теперь выделывается на собрании бизнесменов. Однако торжественность доктора Прагасу впечатляет, чтобы не сказать давит.
Китайцы на противоположном конце стола — точь-в-точь маоистский вариант гранитного монумента с горы Рашмор; невозможно поверить, что они улыбнулись хоть раз в жизни. Все слушают синхронный перевод в наушниках, соединенных через чудо-стол с целой бойлерной переводчиков.
Внимание Рэнди рассеивается. Слушать Прага скучно: он говорит про технические вещи, до боли знакомые, и пытается разъяснить их через простейшие аналогии, понятные даже в переводе на пекинский, кантонский, японский или какой там еще. Рэнди начинает разглядывать гостей.
Вот делегация с Филиппин. Одного, пожилого толстяка, Рэнди точно когда-то видел, но не может вспомнить фамилию. Еще один участник переговоров входит позднее, без сопровождающих, и его сажают отдельно в дальнем конце помещения. Это может быть филиппинец с большой долей испанской крови, но скорее — латиноамериканец, или южноевропеец, или просто американец с соответствующими этническими корнями. Не успев сесть, он достал мобильник, набрал длинный-предлинный номер и что-то хрипло зашептал в трубку. Он постоянно косится на собравшихся, оглядывая каждого по очереди и шепча короткие описания в телефон. Сразу бросается в глаза его настороженность. Однако в этом человеке есть еще и мрачная надменность, которую Рэнди не замечает, пока черные глаза не упираются в него, как стволы. Рэнди от неожиданности не успевает отвести взгляд, и некая странная информация поступает ему от человека с сотовым телефоном по лучам черного света из черных глаз.
Рэнди понимает, что он и другие члены корпорации «Эпифит(2)» попали к разбойникам.

РИКОШЕТ

В день, когда Гото Денго проигрывает войну, над морем Бисмарка висит жаркая хмарь. Американские бомбардировщики снижаются и идут на бреющем полете. Гото Денго на верхней палубе: их вывели размяться и подышать. От свежего воздуха, не пахнущего сортиром и блевотой, накатывает эйфория. Очевидно, то же и с остальными, потому что самолеты летят довольно долго, прежде чем на кораблях начинают гудеть сирены.
Воины Императора должны быть в эйфории постоянно — таков их несгибаемый дух. Гото Денго стыдно, что у него он возникает только на свежем воздухе. Другие не сомневаются или по крайней мере не показывают своих сомнений. Когда он сбился с пути? Может, в Шанхае, где набрался чуждых идей? Или это было у него изначально — старинное семейное проклятие?
Транспорты очень тихоходны, обычные жестянки с воздухом. Орудия на всех самые жалкие. На эсминцах сопровождения звучит боевая тревога. Гото Денго стоит у фальшборта и смотрит как команда эсминца занимает боевые посты. Орудийные жерла извергают синее пламя и черный дым, звук пальбы слышен с большой задержкой.
У американских бомбардировщиков явно что-то не в порядке. Может, заблудились в тумане, или топливо на исходе, или их сверху атакуют «зеро». Так или иначе, ясно, что их цель — не конвой: американские самолеты бомбят с большой высоты. Бомбы всегда летят мимо, потому что у американцев плохие прицелы и необученные экипажи. Нет, самолеты в небе — обычное совпадение, которых столько случается на войне; конвой со вчерашнего дня шел под сплошной облачностью.
Солдаты вокруг Гото Денго победно кричат. Какая удача, что сбившиеся с пути американские самолеты угодили прямо под зенитки их эсминцев сопровождения! Доброе предзнаменование для поселка Кулу: половина тамошних юношей на палубе и может полюбоваться зрелищем. Они вместе росли, вместе ходили в школу, в двадцать лет вместе прошли военную подготовку, вместе призвались в армию. Сейчас они вместе направляются на Новую Гвинею. Несколько минут назад их всех вместе вывели на палубу. Все вместе они увидят, как американские самолеты рассыплются фейерверком огня.
Гото Денго, в свои двадцать шесть, один из стариков. Его перевели из Шанхая воспитывать молодежь. Он обводит взглядом знакомые с детства лица: упоенные счастьем, цветущие, словно сакура, в сером мире облаков, океана, крашеной стали.
Новая радость озаряет лица односельчан. Гото Денго поворачивается. Один из бомбардировщиков решил для уменьшения веса отбомбиться прямо в океан. Ребята из Кулу улюлюкают. Американский самолет, сбросив полтонны бесполезной взрывчатки и сам себя выхолостив, взмывает вверх, годный теперь исключительно в качестве мишени. Парни из Кулу глумятся над летчиком. Японец на его месте хотя бы протаранил эсминец!
Гото Денго почему-то смотрит не на самолет, а на бомбу. Она не валится из самолетного брюха, а описывает плавную дугу над волнами, словно воздушная торпеда. Он затаивает дыхание, боясь, что она так и не рухнет в океан, а будет скользить по воздуху прямо к эсминцу. Однако вновь военная удача улыбается войскам Императора: бомба проигрывает борьбу с земным тяготением и зарывается в волны. Гото Денго отводит взгляд.
Однако какой-то фантом мельтешит на краю зрения. Гото Денго вновь поворачивает голову. Брызги пены от упавшей бомбы еще расходятся по воде, но дальше стремительно несется черная точка: может быть, вторая бомба с того же самолета. На этот раз Гото Денго смотрит внимательнее. Кажется, что бомба не падает, а взлетает: видимо, обман зрения. Нет, неправда: она медленно теряет высоту, уходит в воду и тоже оставляет за собой два хвоста брызг.
И тут бомба вновь взмывает над водой. Гото Денго, инженер по образованию, умоляет законы физики совладать с этой штуковиной, чтобы она пошла ко дну, как положено большой металлической чушке. Она и впрямь снижается — лишь для того, чтобы взмыть снова.
Она скачет, как плоские камешки, которые ребята из Кулу пускали на поверхности деревенского пруда. Гото зачарованно наблюдает ее прыжки. Снова военная фортуна представила ему возможность увидеть редчайший спектакль, затеянный, очевидно, исключительно ему на потеху. Он тянет удовольствие, как сигарету, случайно обнаруженную в кармане. Скок. Скок. Скок.
Прямо в бок эсминцу. Орудийная башня взлетает в воздух, кувыркаясь в полете. Достигнув апогея, она замирает и полностью скрывается в гейзере пламени из машинного отделения.
Парни из Кулу по-прежнему поют, отказываясь верить своим глазам. Что-то вспыхивает на краю зрения. Гото Денго успевает повернуться и увидеть, как взрыв в погребе боеприпасов переламывает другой эсминец пополам, словно сухой сук. Крохотные черные точки скок-скок-скокают теперь по всему океану, словно блохи по мятым простыням в шанхайском борделе.
Пение обрывается. Все смотрят молча.
Американцы в разгар войны выдумали совершенно новый способ бомбометания и применили его без сучка без задоринки. Мысль Гото Денго спотыкается, как пьяный в кренящемся вагоне. Американцы поняли, что не правы, признали ошибку и выдвинули новую идею. Ее приняли и одобрили по всей цепочке командования. Теперь с ее помощью убивают противника.
Ни один воин с мало-мальским понятием о чести не может быть таким изворотливым. Таким гибким. Какая потеря лица для офицеров, которые учили подчиненных метать бомбы с большой высоты! Что с ними сталось? Наверное, покончили с собой или брошены в тюрьму.
Американские морские пехотинцы в Шанхае тоже были не настоящие воины. Все время приспосабливались. Как Шафто. Шафто подрался с японскими солдатами на улице и проиграл, а проиграв, решил, что позаимствует новую тактику — у Гото Денго. «Американцы — не воины, — говорят все. — Торгаши, но не воины».
Под палубами солдаты по-прежнему поют и кричат. Они понятия не имеют, что происходит на самом деле. Гото Денго на мгновение отводит взгляд от рвущихся и тонущих эсминцев и берет курс на ящик со спасательными жилетами.
Самолеты улетели. Он обводит глазами конвой и не видит ни одного боеспособного эсминца.
— Надеть спасжилеты! — кричит Гото Денго. Похоже, никто не слышит. Он идет к ящику. — Эй! Надеть спасжилеты! — На случай, если остальные оглохли, он вытаскивает жилет и поднимает над головой.
Все отлично слышат. На него смотрят так, будто он сделал что-то ужасное — ужаснее всего, что они видели в последние пять минут. Какие такие спасательные жилеты? Зачем?
— На всякий случай! — кричит он. — Чтобы сразиться за Императора в другой раз! — Последняя фраза звучит довольно фальшиво.
Парень, с которым они в детстве жили через два дома, подходит, вырывает у Гото Денго спасательный жилет и бросает в океан. Презрительно меряет Гото Денго взглядом, поворачивается, идет прочь.
Другие кричат и указывают пальцами: летит вторая волна самолетов. Гото Денго идет к поручню, чтобы встать рядом с товарищами, но от него отшатываются. Американские самолеты атакуют без помех и уносятся прочь, оставив скачущие бомбы.
Гото Денго смотрит, как бомба несется к нему, и видит намалеванную на ней надпись: «Получай, Тодзё!»
— Сюда! — кричит он, поворачивается спиной к бомбе и снова идет к ящику со спасательными жилетами. На этот раз несколько человек идут следом. Тех, кто не идет — примерно пять процентов населения поселка Кулу, — катапультирует в море взрывом бомбы. Деревянная палуба выгибается горбом. Одному из кульчан двухметровой щепкой пропарывает живот. Гото Денго и примерно десять солдат на четвереньках добираются до ящика и хватают спасательные жилеты. Он бы не сделал этого, если бы еще раньше в душе не проиграл войну. Воин должен стоять до погибели. Солдаты ползут к ящикам только потому, что он так приказал.
Пока они надевают пояса и добираются до фальшборта, успевают взорваться еще две бомбы. Большинство солдат под палубой наверняка погибли. Фальшборт резко уходит вверх: Гото Денго подтягивается и забрасывает на него ногу. Борт стоит почти горизонтально. Корабль переворачивается! Еще четверо успели ухватиться, остальные катятся вниз и пропадают в дымной пучине. Гото Денго запрещает себе думать о том, что видят глаза, пытается действовать чутьем. Он стоит на боку корабля и, глядя в сторону кормы, видит крутящийся вхолостую винт. Поворачивается, бежит вверх. Остальные четверо сзади. Американский самолет проносится на бреющем полете. Гото не понимает, что их обстреливают, пока очередь не разрезает одного солдата пополам и не разносит другому колено, так что полноги повисает на нескольких хрящах. Гото Денго забрасывает раненого на плечо и поворачивается, чтобы снова бежать вверх, но бежать уже некуда. Он и еще двое стоят на стальной выпуклости метрах в полутора от воды. Гото Денго оборачивается раз, другой, ища, куда бежать, но вокруг только вода. Она сердито булькает и пенится — из развороченного корпуса выбиваются воздух и дым. Гото Денго смотрит на стальной пузырь под ногами и видит, что тот пока совершенно сух. Потом море Бисмарка со всех сторон приливает к его ногам и начинает подниматься. Через мгновение стальная плита, секунду назад так основательно давившая на подошвы, рушится вниз. Под весом раненого Гото проваливается в океан. Ноздри вместо воздуха хватают мазут. Он выбирается из-под раненого и с криком выныривает на поверхность. Нос и пазухи в черепе полны мазутом. Он успел наглотаться, и тело судорожно выталкивает мазут через все дырки — чихая, отхаркивая из легких. Гото проводит рукой по лицу: оно в мазуте. Глаза открывать нельзя. Он трет лицо рукавом, но гимнастерка тоже насквозь в мазуте.
Надо нырнуть и оттереть лицо, чтобы снова видеть, но пропитанная мазутом одежда удерживает на плаву. Легкие наконец очистились, он ловит ртом воздух, пахнущий мазутом. Однако летучие компоненты дизтоплива уже попали в кровь и, как огонь, разбегаются по жилам. Ощущение, что по коже головы ведут раскаленным шпателем. Другие вопят; Гото Денго понимает, что тоже вопит. Китайские рабочие в Шанхае для кайфа нюхали бензин и вопили вот так же.
Рядом отчаянно кричат. Гото Денго слышит приближающийся треск, будто рвут на бинты простыню. Жар ударяет в лицо раскаленной сковородой. Он ныряет и уходит на глубину. При этом одна нога на мгновение оказывается над водой и ее пришпаривает между ботинком и краем штанины.
Он плывет вслепую в океане дизельного топлива. Внезапно температура и вязкость окружающей жидкости меняются. Спасательный жилет тянет вверх: видимо, он в воде. Гото делает еще несколько гребков и начинает тереть глаза. Судя по давлению на уши, глубина небольшая, может быть, метра два от поверхности. Наконец решается открыть глаза. Руки освещены призрачным мерцающим светом и кажутся ярко-зелеными: наверху проглянуло солнце. Гото Денго переворачивается на спину и смотрит прямо вверх. Над ним озеро бушующего огня.
Он через голову срывает спасательный жилет, тот стремительно вырывается вверх и вспыхивает, как комета. Пропитанная мазутом одежда неумолимо тянет вверх, Гото срывает гимнастерку и отпускает ее к поверхности. Ботинки тянут вниз, штаны вверх, чем достигается определенное равновесие.

Он вырос на рудниках.
Кулу стоит на северном побережье Хоккайдо, у пресноводного озера, там, где горные реки сливаются перед самым впадением в Охотское море. С одной стороны озера круто дыбятся горы, нависая над холодным серебристым ручьем, что бежит из леса, где живут только обезьяны и демоны. На этом краю озера есть островки. Если копать на островах или в горах, найдешь жилы медной руды, иногда — цинк, свинец, даже серебро. Этим кульчане и занимаются спокон веков. Памятник им — лабиринт выработок, уходящих под землю — не по прямой, а следуя простиранию самых богатых жил.
Иногда выработки ныряют глубоко под озеро. Пока рудники действовали, воду откачивали, а выбрав жилы, предоставили ей полную свободу. Есть пещеры и туннели в горах, куда забираются лишь те мальчишки, которым хватает духу нырнуть в холодную воду и проплыть десять, двадцать, тридцать метров.
В детстве Гото Денго исследовал их все, некоторые даже нашел сам. Рослый, упитанный, он прекрасно держался на воде и отлично плавал. Правда, не дольше всех мог пробыть под водой. Он даже не был самым отважным (самые отважные не надели спасательных жилетов и встретили смерть, как пристало воинам).
Он плавал туда, где не бывал никто, потому что единственный из всех мальчишек Кулу не страшился демонов. Отец, горный инженер, ходил с ним в горы, где эти демоны якобы обитали. Они с отцом спали под звездами. К утру одеяла покрывались инеем, порой их еду крали медведи. Но никогда — демоны.
Другие ребята считали, что демоны живут в некоторых затопленных выработках, вот почему те, кто туда заплывает, не возвращаются. Однако Гото не боялся демонов и плыл, страшась только холода, воды и темноты, которые сами по себе были достаточно опасны.
Сейчас ему надо только притвориться, что огонь — каменная кровля выработки. Гото плывет дальше. Однако он не вдохнул как следует перед нырком и теперь близок к панике. Поднимая глаза, видит, что вода горит лишь на отдельных участках.
Оказывается, он на большой глубине. В штанах и ботинках плыть трудно. Возится со шнурками, но они завязаны двойным узлом. Вытаскивает нож, чиркает по шнуркам, сбрасывает ботинки, потом штаны вместе с исподним. Убеждает себя не паниковать еще десять секунд. Сгибается, обхватывает руками колени. Естественная плавучесть постепенно берет верх. Он знает, что поднимается сейчас к поверхности, как пузырь. Свет ярче. Надо просто ждать. Он выпускает нож, который только мешает всплытию.
Спину холодит ветерок. Гото резко распрямляется из позы эмбриона, вскидывает голову, хватает ртом воздух. Пятна горящего мазута совсем близко и растекаются по воде, как по твердой поверхности. Снизу пламя голубое, почти невидимое, кверху желтеет и завивается черным дымом. Гото Денго на спине отплывает от горящего щупальца.
Сверху проносится серебристый призрак, так низко, что чувствуется тепло выхлопа и можно прочесть английские предупреждающие надписи на брюхе. Концы крыльевых пулеметов искрятся, выбрасывают алые черточки.
Американцы расстреливают уцелевших. Некоторые пытаются нырнуть, но пропитанная мазутом одежда выталкивает их на поверхность, ноги вхолостую молотят воздух. Гото прежде убеждается, что рядом нет горящего пятна, потом медленно поворачивается, как антенна радара, высматривая самолет. П-38 летит низко, целит в него. Гото Денго набирает в грудь воздуха и ныряет. Под водой хорошо и тихо, стук пуль по воде — словно стрекот исполинской швейной машинки. Несколько очередей зарываются в океан, оставляя хвосты пузырей, замедляются почти до полной остановки в метре-двух от поверхности, разворачиваются вертикально вниз и тонут, как бомбы. Гото Денго плывет за одной, ловит ее в кулак. Пуля все еще тепла Можно было бы сохранить на память, но карманы остались штанах, а руки нужны, чтобы плыть. Мгновение он смотрит на пулю, серебристо-зеленую в подводном свете, только что с американского завода.
Как эта пуля попала из Америки ко мне в руку?
Мы проиграли. Война кончена.
Надо вернуться домой и всем рассказать.
Я должен быть, как отец, рационалистом, объяснять жизнь односельчанам, согнутым под гнетом суеверий.
Он выпускает пулю и смотрит, как она идет ко дну вслед за всеми кораблями и молодыми людьми Кулу.

ФОТОРОБОТ

Эй, это незрелый рынок!
Настоящее осмысление еще не началось — Рэнди по-прежнему сидит в конференц-зале, а мероприятие только набирает разгон.
Естественно, первые клиенты не станут постоянными.
Теперь выступает Том Говард, объясняет свою работу. Рэнди нечем заняться, и он воображает вечерний спор в «Ядре и картечи».
Это как Дикий Запад, сперва несколько необузданный, но потом все устаканится и будет как в Калифорнии.
Почти все делегации прихватили с собой крутых парней — инженеров и специалистов по безопасности. Им обещано вознаграждение, если они найдут изъяны у Тома в системе. Время от времени эти ребята встают и дают залп.
Через десять лет вдовы и мальчишки-газетчики будут иметь счет в киберпространстве.
«Великолепный» — не то слово, которое обычно применимо к Тому Говарду: он сильный, угрюмый, без всякого светского лоска и нимало этого не стыдится. По большей части он отмалчивается с видом скучающего сфинкса, и легко забываешь, какие у него золотые мозги.
Однако в эти конкретные полчаса жизни Тому Говарду важно быть великолепным. Он фехтует с Семью Самураями — самыми головастыми высокооктановыми учеными и самыми бдительными спецами по безопасности, каких только произвела Азия. Один за другим они бросаются в бой, а он срубает им головы и укладывает на стол, словно пушечные ядра. Несколько раз Том вынужден остановиться и задуматься секунд на шестьдесят, прежде чем нанести следующий удар. Раз просит Эберхарда Фёра что-то просчитать на компьютере. Иногда ему приходится прибегнуть к криптографической экспертизе Джона Кантрелла или взглянуть на Рэнди — кивнет тот или мотнет головой. Однако постепенно он вырубает их всех.
На протяжении схватки Берил вымученно улыбается. Ави просто держится за подлокотники; костяшки его пальцев сперва голубые, потом белые, потом розовые и приобретают здоровый оттенок в последние десять секунд, когда ясно, что самураи бегут без оглядки. Рэнди хочется выпустить обойму в потолок и что есть мочи заорать: «Йо-хо!»
Вместо этого он слушает — на тот случай, если Том забурится в дебри плезиохронного протокола, откуда только Рэнди сможет его вытащить. Заодно можно рассматривать остальных гостей. Однако мероприятие длится часа два, и все лица уже до боли знакомы.
Том вытирает саблю о штанину и гулко шлепается большим задом в кожаное кресло. Вбегают служители с чаем, кофе, пакетиками сахара/сливок. Доктор Прагасу встает и представляет Джона Кантрелла.
Батюшки-светы, что деется? Покуда вся повестка дня крутится вокруг корпорации «Эпифит».
Доктор Прагасу, закорешившись с калифорнийскими компьютерщиками, сватает их своим знакомым богатеям, вот что.
С деловой точки зрения, о большем и мечтать нечего. Однако Рэнди немного смущает одностороннее движение информации. К концу встречи шайка сомнительных личностей будет знать о корпорации «Эпифит» все, а эпифитовцы по-прежнему будут пребывать в неведении. Без сомнения, именно такова их цель.
Рэнди решает взглянуть на Дантиста. Доктор Хьюберт Кеплер сидит с той же стороны стола, прочесть выражение его лица невозможно. Ясно, что Кантрелла он не слушает. Дантист прикрыл рукой рот и уставился в одну точку. Его валькирии лихорадочно обмениваются записочками, словно двоечницы на контрольной.
Кеплер удивлен не меньше Рэнди, а он явно не из тех, кто любит сюрпризы.
Каким образом Рэнди может увеличить прибыль акционеров прямо сейчас? Интриги — не его специальность, этим пусть занимается Ави. Рэнди открывает ноутбук и начинает программировать.
Программировать — слишком громкое слово. У каждого эпифитовца в ноутбуке есть крохотная видеокамера для удаленных конференций. На этом настоял Ави. Камера практически невидима: просто отверстие миллиметра два в диаметре над дисплеем Линзы у нее нет. Это камера в самом древнем смысле слова камера обскура. В одной стенке — дырочка, в другой — кремниевая сетчатка.
У Рэнди есть исходники программ для телеконференций. Канал связи используется достаточно разумно. Программа смотрит на идущий через дырочку поток фреймов (отдельных кадриков) замечает, что, хотя общее количество информации в них достаточно велико, различие между соседними фреймами минимально. Иное дело, будь фрейм 1 — говорящая голова, фрейм 2, через долю секунды — открытка с Гавайев, фрейм 3 — схема электрической цепи, а фрейм 4 — увеличенный стрекозиный глаз. Однако на самом деле каждый фрейм — говорящая голова одного и того же человека. Меняется только ее поворот и выражение, и то самую малость. Программа, экономя бесценную полосу, вычитает каждый следующий фрейм из предыдущего (поскольку для компьютера изображение — просто большое число) и пересылает только остаток.
Значит, в программе куча встроенных возможностей для сравнения изображений. Рэнди не надо все это сочинять. Ему просто надо ознакомиться с существующими программами, узнать, какая из них что делает. На это уходит примерно пятнадцать минут щелканья трекболом.
Потом он пишет программку под названием «Фоторобот», которая каждые несколько секунд получает изображение от камеры, сравнивает его с предыдущим и, если разница достаточно велика, сохраняет в файл. Зашифрованный файл со случайным, бессмысленным именем. «Фоторобот» не открывает окон, не выдает собственных сообщений; узнать, что оно крутится, можно только, набрав команду UNIX'a:
ps
и нажав «ввод». Тогда система выдаст длинный список текущих процессов, и где-то в списке будет «Фоторобот».
На случай, если кто-нибудь до этого додумается, Рэнди дает программе ложное имя: VirusScanner. Запускает программу, потом проверяет ее директорию и убеждается, что там только что сохранился графический файл: один фоторобот Рэнди. Пока он сидит почти неподвижно, больше снимков не сохранится: узор света, представляющий лицо Рэнди на дальней стенке камеры обскуры, практически не меняется.
В мире высоких технологий ни одна деловая встреча не может обойтись без компьютерной демонстрации.
Кантрелл и Фёр разработали прототип программы электронных расчетов, просто чтобы показать пользовательский интерфейс и встроенную защиту.
— Через год, вместо того чтобы идти в банк и говорить с человеком, вы просто запустите эту программу из любого места в мире, — заявляет Кантрелл, — и свяжетесь с Криптой. — Он краснеет, представив, как это слово через переводчиков вползает в уши гостей. — Так мы называем систему, которую создает Том Говард.
Ави на ногах, готовый устранить кризис.
— Ми фу, — говорит он, обращаясь непосредственно к китайцам, — более удачный перевод.
У китайцев явно падает с души камень, двое даже улыбаются, слыша пекинский диалект из уст Ави. Тот поднимает лист бумаги с китайскими иероглифами* [Первый, mu, означает «тайна», второй, fu, несет двойное значение: с одной стороны, «символ» или «знак», с другой — «даосская магия».]:

Мучительно сознавая, что чудом остался цел, Кантрелл хрипло продолжает:
— Мы подумали, что вы захотите увидеть программу в действии. Сейчас я покажу ее на экране, а в перерыве можете подойти и попробовать самостоятельно.
Рэнди запускает программу. Его компьютер подключен к видеоразъему под столом, так что султанские спецы смогут проецировать то, что видит Рэнди, на небольшой экран в дальнем конце зала. На дисплее — демоверсия программы электронных расчетов, однако программа «Фоторобот» по-прежнему работает в фоновом режиме. Рэнди придвигает ноутбук Джону (на жестком диске сейчас должен появиться портрет Джона Кантрелла).
— Я могу написать лучшую из возможных криптографических программ, но грош ей цена без надежной системы верификации пользователя. — К Джону отчасти вернулась обычная самоуверенность. — Как компьютер узнает, что вы — это вы? Пароль легко угадать, украсть или подделать. Компьютер должен знать о вас что-то уникальное, как отпечаток пальца. Обычно ему предлагается взглянуть на какую-то часть вашего тела — например сосуды сетчатки вашего глаза, или услышать отчетливый звук вашего голоса и сравнить с данными, записанными в памяти. Такого рода технология зовется биометрией. В корпорации «Эпифит» работает один из лучших в мире специалистов по биометрии. Доктор Эберхард Фёр создал систему распознавания почерка, которая считается непревзойденной. — Джон некоторое время продолжает панегирик. У Эба и остальных скучающий взгляд — все читали его резюме. — Сейчас мы покажем вам распознавание голоса, но программа представляет собой заменяемый модуль, так что можно перейти на другую систему по выбору пользователя, скажем, считывание геометрии руки.
Джон показывает, как работает программа. В отличие от большинства демоверсий она и впрямь работает, а не зависает. Он даже пытается обмануть ее, записав и прокрутив свой голос на приличном портативном магнитофоне. Однако программу не проведешь. Это впечатляет китайцев. До сих пор они выглядели как содержимое контейнера за музеем восковых фигур после выставки, посвященной Культурной революции.
Не все такие маловеры. Гарвард Ли — целиком на стороне Джона Кантрелла, а филиппинский тяжеловес, похоже, спит и видит, как бы вложить свои деньги в Крипту.
Перерыв! Двери распахиваются. За ними обеденный зал с буфетной стойкой у дальней стены — оттуда тянет запахами карри, кайенского перца, чеснока и бергамота. Дантист садится за один стол с эпифитовцами, но почти не разговаривает, а сидит с постной миной, смотрит, жует и думает. Когда Ави спрашивает о его впечатлениях, Кеплер спокойно отвечает: «Встреча была информативная».
Три грации эпилептически дергаются. Очевидно, в словаре Дантиста «информативная» — исключительно бранное слово. Оно означает, что Кеплер узнал на встрече нечто такое, чего не знал, когда туда направлялся. В его системе ценностей это непростительное упущение разведки.
Мучительная тишина. Потом Кеплер говорит:
— Однако не лишенная интереса.
Белозубые ассистентки испускают глубокий вздох. Значит, Кеплер досадует, что его держали в неведении, но одновременно почуял новые деловые возможности. Интересно, что хуже: подозрительность Дантиста или его алчность? Скоро выяснится. Рэнди, с его дурацкой откровенностью, едва не ляпает: «Для нас встреча тоже была информативной», но сдерживается, заметив, что Ави этого не сказал. Прибыли акционеров такие слова не увеличат. Лучше не показывать карты, пусть Кеплер гадает, знали они наперед или нет.
Рэнди выбрал место так, чтобы видеть в открытую дверь конференц-зал и свой ноутбук. Один за другим члены других делегаций заходят в зал и запускают демоверсию: записывают свой голос и смотрят, как он распознается. Некоторые особо продвинутые набирают команды на клавиатуре, может быть, даже ps. Хотя у Рэнди все настроено так, что сильно не напортишь, ему больно видеть, как чужие люди тычут пальцами в его клавиатуру.
Это ощущение грызет Рэнди всю вторую половину встречи, посвященную связи Кинакуты с остальным миром. Ему бы слушать, потому что разговор касается, в частности, филиппинского проекта. Но он не слушает, а изводится из-за клавиатуры, заляпанной чужими пальцами, потом из-за того, что это его так сильно задело, а значит — бизнесмен из него никудышный. Клавиатура, строго говоря, не его, а корпорации «Эпифит». Если для увеличения прибыли акционеров надо, чтобы сомнительные азиаты рылись в его файлах, он должен это только приветствовать.
Собрание расходится. Эпифитовцы и японцы обедают вместе, Рэнди устал и рассеян.
Примерно в девять вечера он прощается и уходит в номер, мысленно сочиняя ответ root@eruditorum.org, в том духе, что, мол, потребность велика, и лучше эту нишу займем мы, чем полная и откровенная сволочь. Однако не успевает компьютер загрузиться, как появляется Дантист в белом махровом халате, распространяя запах водки и гостиничного мыла. Он вторгается в ванную Рэнди (нет, акционеров), наливает себе стакан воды. Стоит у окна (оно оплачено акционерами, как и все в номере) и с минуту хмуро взирает на японское кладбище.
— Вы осознаете, кто эти люди? — спрашивает он наконец. Биометрический анализ выявил бы в его голосе недоверие, недоумение и, может быть, немного издевки.
А может, он просто пытается взять Рэнди на пушку. Может, он и есть root@eruditorum.org.
— Да, — врет Рэнди.
После встречи Рэнди рассказал про «Фоторобот». Ави похвалил его за изобретательность, распечатал снимки на своем принтере и «Федеральным экспрессом» отправил сыщику в Гонконг.
Кеплер поворачивается и скептически оглядывает Рэнди.
— То ли я, ребята, чего-то про вас не знаю, — говорит он, — то ли вы решили прыгнуть значительно выше головы.
Будь это первая бизнес-попытка Рэнди, он бы сейчас наложил в штаны. Будь это вторая попытка — немедленно уволился бы и завтра утром улетел в Калифорнию. Однако это уже третья и он кое-как сохраняет видимость спокойствия. Свет сзади, так что Кеплер, возможно, не очень хорошо видит его лицо. Рэнди выпивает глоток воды и, набрав в грудь воздуха, спрашивает:
— Каковы перспективы наших отношений в свете сегодняшней встречи?
— Речь не о дешевых услугах связи для Филиппин — если такая цель впрямь когда-нибудь ставилась, — мрачно говорит Кеплер. — Поток данных через Филиппины теперь приобретает совершенно иное значение. Возможности огромные. С другой стороны, у нас серьезные конкуренты: австралийцы и сингапурцы. По силам ли нам конкурировать с ними, Рэнди?
Вопрос прямой и простой, самого опасного свойства.
— Мы бы не стали рисковать деньгами акционеров, если б считали иначе.
— Предсказуемый ответ, — фыркает Кеплер. — Мы поговорим по-настоящему, Рэнди, или пригласим пиарщиков и обменяемся пресс-релизами?
В своих прежних бизнес-попытках Рэнди бы на этом месте окочурился. Сейчас он говорит:
— Я не готов обсуждать это.
— Рано или поздно придется, — цедит Дантист. Зубы мудрости придется когда-нибудь удалить.
— Естественно.
— А пока подумайте вот о чем, — говорит Кеплер, поворачиваясь к двери. — Что мы можем предложить в плане телекоммуникационных услуг, чтобы обскакать австралийцев и сингапурцев? Потому что по ценам мы с ними конкурировать не можем.
Это третья бизнес-попытка Рэнди, и он не выпаливает: избыточность.
— Мы, разумеется, будем над этим работать, — говорит он.
— Звучит, как отповедь. — Кеплер, ссутулившись, выходит в коридор и, обернувшись, добавляет. — Встретимся завтра в Крипте. — Подмигивает. — Или в Склепе. Или в Роге Изобилия, как там это по-китайски.
Ошарашив Рэнди столь неожиданным человеческим проявлением, он идет прочь.

ЯМАМОТО

Тодзё и его свора армейских дебилов фактически сказали ему: «Расчистил бы ты Тихий океан, а то нам нужен безопасный коридор шириной где-нибудь так десять тысяч миль, чтобы осуществить наш планчик по захвату Южной Америки, Аляски и всей Северной Америки к западу от Скалистых гор. Просьба исполнить как можно скорее. А мы пока окончательно разделаемся с Китаем».
К этому времени они уже управляли страной. Убили всех, кто мешал, втерлись в доверие к Императору — попробуй только скажи, что планчик — дерьмо, что американцы по-настоящему разозлятся и сотрут их с лица земли. Адмирал Исороку Ямамото, честный слуга Императора, пораскинул умишком, составил план, отправил пару суденышек через половину земного шара и стер Перл-Харбор с лица земли. Подгадал точно к объявлению войны. Сказать по правде, сработал очень даже неплохо.
Позже в кабинет вполз один из адъютантов — с тем отвратительным раболепным видом, который напускают на себя подчиненные, когда собираются по-настоящему испортить тебе настроение, — и сообщил, что из-за неразберихи в вашингтонском посольстве эти остолопы передали декларацию об объявлении войны, когда американский флот уже шел ко дну.
Армейским придуркам хоть бы хны — промашка вышла, пустяки, с кем не бывает. Исороку Ямамото давно отчаялся объяснить им, что американцы жутко обидчивые. Этого не понять японцам, которые научаются глотать обиды раньше, чем глотать твердую пищу. Даже если объяснить Тодзё и его тупоголовым кретинам, что американцы разозлились, те только посмеются. Ну и что америкашки нам сделают? Запустят в физиономию тортом? Ха, ха, ха! Передайте саке и позовите еще гейшу!
В бытность свою в Америке Исороку Ямамото играл с янки в покер, дымя, как паровоз, чтобы заглушить запах их мерзкого лосьона для бритья. Разумеется, янки чудовищно грубы и неотесанны, не надо быть тонким наблюдателем, чтобы это заметить. Они бессовестно обчищали Ямамото за карточным столом, однако адмирал извлек для себя кое-какие полезные сведения: понял, что эти веснушчатые увальни бывают исключительно хитры. Ладно бы грубые и тупые — этих несложно понять.
Однако сочетание грубости и ума — невыносимо; вот почему рыжие гориллы отвратительны вдвойне. Ямамото по-прежнему пытается внушить свою мысль партнерам по большому японскому плану завоевать весь земной шар от Карачи до Денвера. Многие моряки повидали мир и сами во всем убедились, но армейские лишь резали китайцев и насиловали их женщин. Они думают, америкашки такие же, только более рослые и вонючие. Разуйте глаза, убеждает их Ямамото, Земля не просто большой Нанкин. Будь его воля, он бы издал приказ: каждый армейский офицер на время перестает резать первобытных дикарей в джунглях и отправляется в Тихий океан обменяться парочкой залпов с американским оперативным соединением. Тогда, может быть, они бы поняли, во что вляпались.
Вот о чем думает Ямамото вскоре после рассвета в Рабауле, протискиваясь вместе с ножнами в узкую дверцу бомбардировщика «Мицубиси G4M». Янки зовут самолеты этого типа «Бетти». Удивительная пошлость! Они и свои самолеты называют женскими именами, рисуют голых баб на священных орудиях войны! Будь у американцев самурайские мечи, они, наверное, покрывали бы их лаком для ногтей.
Поскольку самолет — бомбардировщик, оба пилота втиснуты в кабину над основной трубой фюзеляжа. Нос самолета — тупой купол металлических конструкций, идущих как параллели и меридианы, трапецоиды между ними закрыты прочным стеклом. Самолет развернут к востоку, стеклянный нос пылает неестественно яркими химическими отблесками зари. У японцев ничего не бывает случайно; надо думать, самолет повернут к Восходящему Солнцу для поднятия боевого духа. Адмирал забирается в кабину и пристегивается в таком месте, чтобы удобно было смотреть через стекло, как взлетает его «Бетти» и вторая, адмирала Угаки.
С одной стороны — бухта Симпсона, одна из лучших якорных стоянок в Тихом океане, асимметричное U в обрамлении четкой решетки улиц, среди которой, как бельмо в глазу, английский крикетный овал. С другой стороны, за хребтом — море Бисмарка. Где-то там покоятся несколько тысяч японских солдат, засоленных в покореженных корпусах транспортных кораблей. Еще несколько тысяч спаслись на спасательных плотах, но все их оружие и припасы пошли ко дну, так что теперь это только лишние рты.
И так уже почти год, с самого Мидуэя, когда американцы не клюнули на обманные маневры Ямамото, указывающие в сторону Аляски, а — на тебе! — отправили все оставшиеся авианосцы наперерез его флоту. Черт. Черт. Черт. Черт. Черт. Черт. Черт. Ямамото грызет ноготь на большом пальце, прямо через перчатку.
Теперь эти вонючие мужланы топят все до одного транспорты, которые армия шлет в Новую Гвинею. Дьявол! Их самолеты-разведчики повсюду — всегда появляются в нужное время и — ату! — над императорскими конвоями смыкаются кровавые клещи «конфедератов».
Два самолета летят на юго-восток, над оконечностью Новой Ирландии, к Соломонову морю. Впереди разбросаны Соломоновы острова — мохнатые нефритовые кочки посреди океана, в шести тысячах пятистах футах внизу. Две кочки поменьше, одна побольше. Место их следующей посадки — Бугенвиль.
Необходимо совершать инспекционные облеты, поднимать боевой дух на передовой. У Ямамото есть дела поважнее, поэтому он старается уложить в один день как можно больше неизбежных мероприятий. На прошлой неделе он оставил свою флотскую цитадель на острове Трук и вылетел в Рабаул, чтобы на месте руководить боевой операцией: волной массированных авианалетов на американские базы от Новой Гвинеи до Гуадалканала.
Воздушные налеты вроде бы успешны. Уцелевшие пилоты докладывают о большом количестве потопленных кораблей, о целых американских эскадрильях, уничтоженных прямо на взлетной полосе. Ямамото заранее знает, что все эти донесения на поверку окажутся непомерным бахвальством. Большая часть самолетов не возвращается — американцы вместе со своими не менее гнусными родичами, австралийцами, хорошо подготовились к налетам. Однако и в армии, и на флоте полно честолюбцев, которые из кожи вон лезут, чтобы преподнести Императору хорошие новости, пусть даже и не совсем правдивые. В итоге Ямамото недавно получил поздравительную телеграмму от самого государя. Его долг — облететь на «Бетти» расположение войск, помахать в воздухе священной телеграммой, передать бойцам благословение Императора.
Ноги болят адски. У Ямамото, как у всех остальных в радиусе тысячи миль, тропическая болезнь — в данном случае бери-бери. Это бич японцев и особенно моряков, потому что они едят слишком много очищенного риса, слишком мало рыбы и овощей. Нервные волокна изъедены молочной кислотой, поэтому руки дрожат. Слабое сердце недостаточно сильно гонит кровь, и ноги отекают. Ему надо несколько раз в день менять обувь, но здесь слишком тесно — мешает не только фонарь кабины, но и меч.
Они приближаются к воздушной базе Императорских военно-морских сил на острове Бугенвиль точно по расписанию, в 9.35. Сверху проносится тень; Ямамото, подняв глаза, видит в опасной близости самолет сопровождения. Кто этот кретин? Тут перед глазами возникает зеленый остров и синий океан: «Бетти» входит в крутое пике. Другой самолет проносится с ревом, заглушающим моторы «Бетти», и хотя это лишь стремительный росчерк, мозг фиксирует странный двухвостый силуэт: П-38 «Лайтнинг». Насколько адмиралу Ямамото известно, на вооружении японских ВВС таких нет.
По рации доносится голос адмирала Угаки из второй «Бетти», летящей у них в хвосте: он приказывает летчику Ямамото держать строй. Впереди только волны, бьющиеся о берег Бугенвиля, да стремительно приближающаяся зеленая стена леса. Ямамото моряк, а не летчик, но даже он знает: если во время боя не видишь перед собой самолетов, значит, плохи твои дела. Алые вспышки прочерчивают небо и уходят в туманные джунгли, «Бетти» начинает сильно дрожать. Периферическое зрение наполняется желтым светом: горит мотор. Пилот держит курс прямо на джунгли: то ли самолет потерял управление, то ли летчик уже убит, то ли его гонит атавистический инстинкт — скрыться, скрыться среди деревьев!
Они на горизонтальном полете входят в джунгли и на удивление долго летят, прежде чем во что-нибудь врезаться. Потом самолет с размаху ударяет в ствол красного дерева, как раненая ласточка — в бейсбольную биту, и Ямамото ясно — это конец. Фонарь вокруг адмирала разваливается, меридианы и параллели ломаются и гнутся, но это уже не самое страшное, потому что весь самолет объят пламенем. Кресло выпадает из разбитого купола и летит в пространство. Ямамото стискивает меч, чтобы не выронить священный клинок, не опозорить себя в последние мгновения жизни. Одежда и волосы в огне: он метеором летит через джунгли, сжимая меч своих предков.
Внезапно он кое-что понимает. Американцы совершили невозможное, взломали их коды. Это объясняет Мидуэй, объясняет море Бисмарка, Холландию, все. Это объясняет, почему адмирал Ямамото, вместо того чтобы пить зеленый чай и упражняться в каллиграфии под сенью прохладного сада, летит через джунгли со скоростью сто миль в час, преследуемый тоннами горящего металлолома. Надо сообщить, чтобы сменили коды!.. Вот о чем он думает, прежде чем врезаться головой в стофутовый ствол Octomelis sumatrana.

АНТЕЙ

Когда Лоуренс Притчард Уотерхауз впервые за несколько месяцев вступает на священный берег Альбиона, он с изумлением видит повсюду слабые намеки на весну. Местные жители выставили вдоль набережной вазоны с какой-то докембрийской декоративной капустой. Зрелище не греет душу, однако придает местности мрачно-друидический вид. Впечатление, что видишь отголоски некой культурной традиции, из которой вдумчивый антрополог способен вывести существование настоящих деревьев и лугов значительно дальше к югу. Здесь их заменяют лишайники, которые, поддавшись общему духу, оделись в лиловато-серое и зеленовато-серое многоцветье.
Они со старым приятелем-вещмешком тузят друг друга до самого вокзала и занимают место в «кукушке» на Манчестер. Часа два она разводит пары, и у Лоуренса есть время подумать.
Он работает над задачей из области теории информации, возникшей недавно* [После того как раскололи четырехдисковую «Энигму».] в результате желания американского и английского флотов усеять атлантическое дно разбомбленными и торпедированными «коровами». Это толстые немецкие подводные лодки, наполненные топливом, провиантом и боеприпасами. Они болтаются в Атлантике, редко выходят на радиосвязь и служат плавучими базами снабжения, чтобы боевым подлодкам не возвращаться в порт для заправки и пополнения припасов. То, что их усиленно топят, хорошо для конвоев, но наверняка насторожит таких, как Рудольф фон Хакльгебер.
Обыкновенно, исключительно для проформы, союзники посылают самолет-разведчик, который якобы случайно обнаруживает «корову». Однако немцы, если отбросить их политическую слепоту, ребята башковитые и когда-нибудь уловку разгадают. Если мы и дальше хотим топить их «коров», нам нужно более убедительное оправдание.
Уотерхауз сочинял оправдания весь конец зимы — начало весны и порядком притомился. Чтобы сочинять их грамотно, нужен математик, хотя задача не вполне математическая. Слава богу, ему хватило ума переписать шифровки из сейфа. Только на них он и держится.
В каком-то смысле это пустая трата времени: оригиналы давно переправлены в Блетчли-парк, где их наверняка расшифровали в первые же часы. Уотерхауз делает это не столько для победы над врагом, сколько чтобы не разучиться думать и может быть, добавить несколько страниц к новому изданию «Криптономикона». Добравшись до Блетчли, он поспрашивает и выяснит, что же было в этих шифровках.
Обычно он не опускается до жульничества, но листки с U-553 совершенно поставили его в тупик. Они зашифрованы не с помощью «Энигмы», однако расколоть их по крайней мере так же трудно. Обычно начинают с того, что по определенным признакам устанавливают, например, что это шифр перестановки или замены, дальше, скажем, что это апериодический шифр перестановки, в которой ключевые элементы постоянной длины используются для шифровки переменных по длине групп открытого текста, или наоборот. Как только ты классифицировал алгоритм, ты понимаешь, как взламывать код.
Уотерхауз не добрался даже до этой стадии. Он сильно подозревает, что сообщения закодированы с помощью одноразового шифрблокнота. Если так, их не прочтут даже в Блетчли-парке, разве что добудут экземпляр шифрблокнота. Он почти надеется услышать, что так оно и есть, и больше не биться головой в каменную стену.
В определенном смысле такой результат означал бы больше вопросов, чем ответов. Немцы считают «Тритон» — четырехдисковую «Энигму» — абсолютно надежной шифровальной машиной. Если так, зачем капитану U-553 понадобился отдельный шифр для каких-то сообщений?
Паровоз начинает тарахтеть, как Палата Лордов. Обитатели Внутреннего Йглма выходят из вокзала и занимают места. По вагону идет старикан, продает вчерашние газеты, курево, леденцы. Уотерхауз покупает всего понемногу. Поезд трогается. Взгляд Уотерхауза падает на аршинный заголовок во вчерашней газете: «В ТИХОМ ОКЕАНЕ СБИТ САМОЛЕТ ЯМАМОТО. АРХИТЕКТОР ПЕРЛ-ХАРБОРА ПРЕДПОЛОЖИТЕЛЬНО ПОГИБ».
— Допрыгались, — бормочет Уотерхауз и, прежде чем читать дальше, распечатывает пачку сигарет. Такое дело надо основательно перекурить.

Тонны смолы и никотина спустя Уотерхауз сходит с поезда и шагает из вокзала станции «Блетчли-парк» в исключительно яркий весенний день. Перед вокзалом цветут цветы, дует теплый южный ветер. Уотерхаузу тошно идти в душный корпус, однако он идет и слышит там, что никому в данный момент не нужен.

Предыдущая страница 16 Следующая страница


17 Нил Стивенсон

Посетив еще несколько корпусов по разным делам, он сворачивает на север, проходит три мили и открывает дверь кабачка «Корона». Здешняя хозяйка, миссис Рамшо, последние три года успешно привечает у себя бездомных кембриджских математиков.
Доктор Алан Матисон Тьюринг расположился за столиком у окна на двух или трех стульях. Поза с виду исключительно неудобна, но, надо полагать, весьма практична. На столике непочатая кружка чего-то красновато-бурого; Алан слишком занят, ему не до пива. В сигаретном дыму прорисован призматический столб света, падающий на огромную книгу. Алан держит ее одной рукой, другая прижата ко лбу, как будто информация поступает со страниц в мозг напрямую, минуя промежуточные стадии. Сигарета зажата между пальцами, столбик пепла опасно навис над темными волосами. Глаза застыли, не смотрят в книгу, устремлены куда-то в даль.
— Изобретаем новую машину, доктор Тьюринг?
Глаза обретают подвижность и поворачиваются на голос.
— Лоуренс, — тихо говорит Алан, идентифицируя лицо. Потом, душевнее: — Лоуренс! — Он с обычной живостью вскакивает и протягивает руку. — Какая чудесная встреча!
— Рад тебя видеть, Алан. — Уотерхауз, как всегда, приятно удивлен, насколько живо и остро Алан на все реагирует.
Еще он тронут искренней приязнью Алана. Алан нелегко сходится с людьми, но уж если дружит, как с Уотерхаузом, то без всякой оглядки на американские или гетеросексуальные представления о мужской сдержанности.
— Ты что, шел пешком от самого Блетчли? Миссис Рамшо, обслужите!
— Да тут всего три мили, — говорит Уотерхауз.
— Садись. — Алан внезапно замирает, хмурится и озабоченно глядит на Уотерхауза. — Откуда ты знаешь, что я изобретаю новую машину? Догадался, исходя из прошлых наблюдений?
— По тому, что ты читаешь. — Уотерхауз указывает на книгу. — «Справочник по радиолампам».
Алан хлопает глазами.
— Мы с ней неразлучны. Ты должен изучить радиолампы, Лоуренс! Без них твое образование неполно. Только подумать, сколько лет я убил на шестеренки! Господи!
— Ты про свою машину для дзета-функции? — спрашивает Лоуренс. — По-моему, она была прекрасна.
— Как многие другие музейные экспонаты, — говорит Алан.
— Это было шесть лет назад. Ты вынужден был обходиться имеющимися технологиями.
— Ах, Лоуренс! Ты меня удивляешь! Если на создание машины по имеющейся технологии уходит десять лет, а по новой — только пять и нужно всего два года на разработку новой технологии, можно уложиться в семь лет, если начать с разработки.
— Убедил.
— Вот она, новая технология. — Алан демонстрирует справочник, словно Моисей — Скрижали Завета. — Хвати у меня духа ее использовать, я бы построил машину для дзета-функции куда раньше, да и другие в придачу.
— Что за машину ты придумываешь теперь? — спрашивает Лоуренс.
— Я играю в шахматы с неким Дональдом Мичи — и постоянно проигрываю. Однако человек всегда создавал орудия, чтобы расширить свои возможности. Почему бы не построить машину, которая помогает играть в шахматы?* [Алан Тьюринг очень любил шахматы, но, несмотря на все свои невероятные усилия и гигантский интеллект, оставался довольно посредственным шахматистом. Вскоре после окончания войны он написал алгоритм, с помощью которого можно было бы обучить машину игре в шахматы. Поскольку на тот момент еще не существовало компьютера, способного выполнять подобные алгоритмы, он решил сам выступить в этой роли. Следуя своим же инструкциям, Тьюринг действовал как «человек-компьютер», и у него уходило более получаса на то, чтобы совершить один ход.
Дональд Мичи (р. 1923) — английский криптограф, работал вместе с Тьюрингом и Джеком Гудом над «Колоссом» и предложил способ программирования этой машины.]
— А у Дональда Мичи тоже будет машина?
— Пусть изобретет свою! — возмущается Алан.
Лоуренс внимательно оглядывает паб. Других посетителей нет, и трудно поверить, что миссис Рамшо — шпионка.
— Не имеет ли это отношения к... — Он кивает в сторону Блетчли-парка.
— Они строят — я помогал им строить — машину под названием «Колосс».
— Мне сразу подумалось, что это твой почерк.
— Она основана на старых идеях, тех, что мы обсуждали в Нью-Джерси, — говорит Алан. Тон резкий, лицо мрачное. Одной рукой он прижимает к сердцу справочник, другой чиркает в блокноте. Уотерхауз думает, что справочник, как ядро на цепи, тянет Алана назад. Работая с чистыми идеями, как положено математику, он бы двигался со скоростью мысли. Однако Алан увлечен воплощением математических идей в физическом мире. Математика, описывающая Вселенную, — как свет, бьющий в окно. Алан выпускает сигаретный дым, чтобы свет стал видимым. Он сидит на лугу, глядит на цветы и шишки, выводит математические закономерности их структуры и грезит об электронных ветрах, реющих между анодами и катодами радиоламп; ветры то затихают, то усиливаются, запечатлевая нечто, происходящее у него в мозгу. Тьюринг не смертный и не бог. Он — Антей. В том, что он соединяет математику с физическим миром, — его сила и его слабость.
— Что такой мрачный? — спрашивает Алан. — Над чем работаешь?
— Те же идеи в другом контексте. — В нескольких словах Уотерхауз итожит все, что сделал за это время для победы. — По счастью, я набрел на что-то по-настоящему занятное.
Алан сразу приободряется, как будто последние десять лет в мире не было ничего занятного и Уотерхауз чудом наткнулся на такую диковину.
— Рассказывай.
— Криптоаналитическая задача. Не «Энигма». — Он рассказывает про листки с U-553. — Сегодня утром я заглянул в Блетчли-парк и выяснил, что они все это время бьются над ней так же безрезультатно.
Алан разочарован.
— Должно быть, одноразовый шифрблокнот. — В голосе сквозит укоризна.
— Нет. Шифртекст не лишен закономерностей, — говорит Уотерхауз.
— Н-да? — отзывается Алан, встрепенувшись.
— Я искал закономерности по обычной методике «Криптономикона». Ничего определенного — просто намеки. В отчаянии я решил начать с чистого листа. Думать, как Алан Тьюринг. Обычно мы стараемся свести задачу к числам, а потом бросить на нее всю мощь математического анализа. Так что я стал переводить сообщения в цифры. Обычно это произвольный процесс. Присваиваешь каждой букве численное значение, как правило, от нуля до двадцати пяти, потом сочиняешь некий произвольный алгоритм, который превращает ряды маленьких чисел в большие. Однако это сообщение иного рода — в нем использованы тридцать два символа — степень двойки; у каждого символа есть единственное двоичное представление в пять разрядов длиной.
— Как в коде Бодо* [Код Бодо (международный телеграфный код) используется в телетайпах. Каждому из тридцати двух символов, включающих буквы и специальные знаки, присвоен определенный номер. Этот номер может быть представлен в виде пятизначного двоичного числа, то есть пятью нулями или единицами, а также (что практичнее) пятью пробитыми либо непробитыми дырочками в бумажной ленте. Кроме того, эти числа можно выразить чередованием плюсовых и минусовых электрических сигналов, которые передаются по проводам или через радиоволны и распечатываются на другом конце. В последнее время немцы используют зашифрованные телеграфные сообщения для связи между высокими командными постами, например, Берлином и штабами различных армейских соединений. В Блетчли-парке эта категория шифров зовется «Рыба»; «Колосс» строят специально для их расшифровки.], — говорит Алан. Он вновь проявляв сдержанный интерес.
— Поэтому я перевел каждую букву в число от одного до тридцати двух по коду Бодо. У меня получились длинные ряды маленьких чисел. Однако я хотел перевести все числа ряда в одно большое, просто чтобы узнать, есть ли в нем интересные закономерности. Но это проще пареной репы! Если первая буква R код Бодо для нее — 01011, а вторая — F, и для нее код — 10111, то я могу просто составить их в десятизначное двоичное число 0101110111. Потом могу взять код следующей буквы, приставить его сзади и получить пятнадцатизначное число. И так далее. Буквы написаны группами по пять — двадцатипятизначное двоичное число на группу. Шесть групп в строке — сто пятьдесят двоичных разрядов на строку. Двадцать строк на странице, всего три тысячи двоичных цифр. То есть о каждой странице можно думать не как о ряде из шестисот букв, но как о закодированном представлении одного числа, порядка двух в трехтысячной степени, или примерно десяти в девятисотой.
— Ладно, — говорит Алан. — Согласен, что использование тридцатидвухбуквенного кода предполагает двоичную схему шифровки. Согласен и с тем, что такая схема позволяет слить пятерки двоичных чисел в более длинные и даже, если идти до конца, слить все двоичные знаки на странице в одно исключительно большое число. Но что это дает?
— Не знаю, — сознается Уотерхауз. — Просто я интуитивно чувствую, что мы имеем дело с новой схемой шифровки, основанной на чисто математическом алгоритме. Иначе какой смысл переходить на тридцатидвухбуквенный алфавит? Подумай: тридцать две буквы годятся и даже необходимы для телетайпа, поскольку там нужны специальные символы, вроде возврата каретки или перевода строки.
— Ты прав, — говорит Алан, — очень странно, что они используют тридцать две буквы в схеме, которая явно шифруется с помощью карандаша и бумаги.
— Я тысячу раз прокручивал это в голове, — произносит Уотерхауз, — и вижу единственное объяснение: они переводят сообщение в большие двоичные числа и комбинируют с другими двоичными числами — скорее всего одноразовым шифрблокнотом.
— Тогда ты ничего не добьешься, — говорит Алан. — Одноразовый шифрблокнот взломать нельзя.
— Это верно, — возражает Уотерхауз, — только если шифрблокнот действительно случайный. Если для трехтысячезначного числа три тысячи раз бросают монетку и пишут единицу для орла и ноль для решки, то он случайный и абсолютно стойкий. Однако не думаю, что здесь так.
— Почему? В их шифрблокнотах закономерности?
— Может быть. Только намеки.
— Так почему ты думаешь, что они не случайны?
— Иначе нет смысла изобретать новую схему, — говорит Уотерхауз. — Все всю жизнь пользуются одноразовыми шифрблокнотами. Давно прописано, как их составлять. Нет никакого резона в разгар войны переходить на новую, исключительно странную систему.
— Так в чем, по-твоему, ее смысл? — Алан явно забавляется.
— Неудобство одноразового шифрблокнота в том, что надо составить два экземпляра и переправить их отправителю и получателю. Положим, ты в Берлине и хочешь послать сообщение кому-то на Дальнем Востоке! На подлодке, которую мы нашли, был груз — золото и много всего другого — из Японии. Представляешь, какая морока для Оси.
— Ага. — До Алана наконец дошло. Однако Уотерхауз все равно заканчивает мысль:
— Предположим, ты нашел математический алгоритм для генерации очень больших случайных чисел — во всяком случае, таких, которые выглядят случайными.
— Псевдослучайных.
— Да. Разумеется, ты должен хранить алгоритм в тайне. Но если ты передаешь его — алгоритм то есть — на другой край света своим адресатам, они смогут с этого дня сами выполнять вычисления и получать шифрблокноты конкретного дня или чего там еще.
По веселому лицу Алана пробегает тень.
— Однако у немцев уже есть «Энигма». Зачем утруждать себя новой схемой?
— Может быть, — предполагает Уотерхауз, — некоторые немцы не хотят, чтобы весь немецкий флот читал их переписку.
— M-м, — говорит Алан. Похоже, последние преграды рухнули. Теперь он воплощенная решимость. — Покажи сообщения!
Уотерхауз открывает портфель, в засохших брызгах и потеках морской воды от путешествия на Йглм и обратно, вытаскивает два больших конверта.
— Здесь копии, которые я снял, прежде чем отправить оригиналы в Блетчли-парк. — Он похлопывает по одному. — Они куда разборчивее оригиналов, — похлопывает по другому, — которые мне любезно одолжили, чтобы я мог изучить их еще раз.
— Покажи оригиналы! — требует Алан.
Уотерхауз толкает через стол второй конверт, покрытый штампами СОВСЕКРЕТНО.
Алан нетерпеливо разрывает конверт, выдергивает листки, раскладывает по столу. У него отвисает челюсть.
В первый миг Уотерхауз думает, что его друг неким олимпийским озарением расшифровал листки с первого взгляда.
Однако это не так. Алан совершенно ошарашен.
— Я знаю почерк.
— Да ты что?
— Видел его тысячу раз. Эти страницы написаны нашим старым другом по велосипедным прогулкам, Рудольфом фон Хакльгебером. Руди написал эти страницы.

Всю следующую неделю Уотерхауз мотается на заседания в Бродвей-билдингс. Всякий раз, как должны прийти штатские (особенно — с аристократическим прононсом), перед началом заседания появляется Чаттан и жутко бодро велит Уотерхаузу молчать в тряпочку, если только не зададут математический вопрос. Уотерхауз не в претензии. Его это вполне устраивает, потому что оставляет время для более важных занятий. На последнем заседании в Бродвей-билдингс он доказал теорему.
Примерно за три дня Уотерхауз вычисляет, что в самих заседаниях нет никакого смысла — обсуждения явно не могут ни во что вылиться. Он даже пытается доказать это с помощью формальной логики, но не силен в ней и знает слишком мало аксиом, чтобы достичь Q.E.D.
Впрочем, к концу недели он заключает, что все эти заседания — одно из следствий гибели Ямамото. Уинстон Спенсер Черчилль носится с Блетчли-парком как курица с яйцом, однако перехват адмиральского самолета пробил заметную брешь в завесе секретности. Головотяпы, допустившие этот промах, пытаются спасти положение, распространяя байку о туземных лазутчиках, которые якобы проведали о полете и сообщили по рации на Гуадалканал, откуда и взлетел роковой П-38. Однако баков П-38 еле-еле хватает на полет туда-обратно, значит, время взлета было рассчитано тютелька в тютельку. Если у японцев на плечах голова, а не кочан капусты, они не клюнут на эту сказочку. Уинстон Черчилль рвет и мечет, и все эти заседания — попытка его умиротворить и выдумать какой-то разумный поворот в политике.
Каждый вечер после заседания Уотерхауз едет на метро до Юстона, потом на поезде до Блетчли и допоздна сидит над шифрами Руди. Алан работает над ними днем, так что вместе они бьются над задачей почти круглые сутки.
Не все загадки математические. Например, какого дьявола немцы усадили Руди писать длинные числа? Если буквами и впрямь закодирована длинная последовательность цифр, значит, доктору Рудольфу фон Хакльгеберу отведена роль заурядного писаря. Трудно поверить, что хоть одна бюрократическая система способна на такую несусветную глупость. Кроме того, судя по скудным разведданным из Германии, Руди на самом деле занимает значительный пост — настолько значительный, что его работа полностью засекречена.
Алан предполагает, что Уотерхауз исходит из понятного, но абсолютно ложного допущения. Числа — не шифртекст, а скорее одноразовый шифрблокнот, с помощью которого капитан U-553 должен был кодировать определенные сообщения, слишком секретные, чтобы пускать их по обычным каналам «Энигмы». Эти одноразовые шифрблокноты по какой-то причине составил Руди.
Обычно составление одноразовых шифрблокнотов — такое же примитивное занятие, как и шифрование, работа для писарей, которые выбирают случайные буквы с помощью лототрона или стопки карточек. Однако Алан и Уотерхауз исходят из допущения, что столкнулись с совершенно новым изобретением, возможно, созданным Руди, и шифрблокнот генерируется не случайным образом, а по какому-то математическому алгоритму.
Другими словами, это какие-то вычисления, какая-то формула, которую придумал Руди. Задаешь некий параметр — вероятно, дату, возможно, какие-то другие данные, скажем, произвольную ключевую фразу или число. Проводишь последовательные вычисления и получаешь девятисотзначное число, то есть три тысячи двоичных знаков, что при переводе в код Бодо дает шестьсот букв (достаточно, чтобы исписать лист бумаги). Девятисотзначное десятичное число, трехтысячезначное двоичное и шестьсот букв — одно и то же абстрактное, чистое число в разных представлениях.
Тем временем твой адресат, возможно, на другом краю света выполняет те же вычисления, получает тот же одноразовый шифрблокнот и может раскодировать твое сообщение.
Если Тьюринг и Уотерхауз поймут, как вычисляется число они тоже смогут его прочесть.

ПЕРЕХВАТ

Дантист ушел, дверь заперта, телефон выдернут из розетки. Рэндалл Лоуренс Уотерхауз лежит голый на крахмальной простыне поверх непомерно большой кровати. Голова подперта подушкой, чтобы между раздвинутых ступней видеть телевизор: идет выпуск всемирных новостей Би-би-си. Десятидолларовое пиво из мини-бара под рукой. В Америке шесть утра, и, чем смотреть профессиональный баскетбол, он переключился на новости. Выпуск почти целиком посвящен Южной Азии. Материал о тайфуне, который вот-вот обрушится на Гонконг, сменяется длинным и трезвым отчетом о нашествии саранчи на индо-пакистанской границе. Король Таиланда потребовал, чтобы несколько наиболее коррумпированных чиновников буквально простерлись перед ним ниц. Азиатские новости всегда граничат с фантастикой, но все это на полном серьезе, без всяких тебе кивков и подмигиваний. Теперь рассказывают о заболевании нервной системы в Новой Гвинее, которое передается при употреблении в пищу мозга других людей. Заурядная каннибальская история. Неудивительно, что столько американцев, приехавших сюда по делу, исчезают навсегда — это все равно что войти на страницы «Классических комиксов».
В дверь стучат. Рэнди встает, надевает бархатный гостиничный халат. Смотрит в глазок, почти ожидая увидеть пигмея с трубочкой отравленных стрел, хотя не отказался бы от соблазнительной восточной куртизанки. Однако это всего лишь Кантрелл. Рэнди открывает дверь. Кантрелл заранее выставил ладони жестом: «Все, уже заткнулся».
— Не беспокойся, — предупреждает он. — О делах говорить не буду.
— В таком случае я не разобью эту бутылку о твою голову, — говорит Рэнди. Вероятно, оба чувствуют одно и то же: сегодня слишком много всего произошло, и единственный способ осмыслить события — не говорить о них. Мозг проделывает большую часть работы в то время, когда его хозяин думает о чем-то другом. Поэтому иногда нужно нарочно сочинять посторонние темы для разговора.
— Идем ко мне в номер, — говорит Кантрелл. — У меня Пекка.
— Финн, которого взорвали?
— Он самый.
— А чего он здесь?
— А чего ему здесь не быть? С тех пор как его взорвали, он ведет технокочевой образ жизни.
— Это просто совпадение или...
— Нет, — говорит Кантрелл. — Он помогает мне выиграть пари.
— Какое?
— Несколько недель назад я рассказал Тому Говарду про ван-эйковский перехват. Том ответил, что это сильно смахивает на брехню. Поспорил на десять акций корпорации «Эпифит», что я не смогу это сделать за пределами лаборатории.
— Пекка в таких вещах сечет?
Вместо того чтобы просто сказать «да», Кантрелл делает серьезное лицо и сообщает:
— Пекка пишет об этом главу в «Криптономикон». Он считает, что есть лишь один способ обороняться: осваивать технологии, которые могут использовать против нас.
Звучит как призыв к оружию. Отступать стыдно, и Рэнди влезает в брюки, которые так и стоят гармошкой, где он их сбросил, вернувшись от султана. От султана! По телевизору идет репортаж о пиратах в Южно-Китайском море, которые отправляют команду захваченного корабля прогуляться за борт.
— Весь континент, блин, один сплошной Диснейленд без мер безопасности, — замечает Рэнди. — Это только мне кажется сюрреалистическим?
Кантрелл ухмыляется.
— Если мы начнем про сюрреализм, то закончим сегодняшней встречей.
— Верно подмечено, — говорит Рэнди. — Пошли.

Прежде чем Пекка стал известен в Силиконовой Долине как «финн, которого взорвали», он назывался «чувак с виолончелью», потому что питал к своей виолончели почти аутистскую привязанность, таскал ее повсюду и все время старался запихать в верхнюю багажную сетку. Без всякой связи, его специальностью было радио, и занимался он аналоговыми штучками.
Когда пакетная радиосвязь стала серьезной альтернативой посылке данных по проводам, Пекка переехал в Менло-парк и основал фирму, оборудование для которой закупил на компьютерной барахолке. Так Пекка обзавелся девятнадцатидюймовым MultiSync-монитором с высоким разрешением, как раз под свои молодые глаза (ему было тогда двадцать четыре). Монитор он подключил к почти новому пентиуму, до отказа набитому оперативной памятью.
Еще он установил Finux, бесплатную операционку на базе UNIX'a, созданную финнами почти исключительно для того, чтобы показать всем «какие мы крутые», и распространяемую через сеть. Разумеется, Finux удивительно мощный и гибкий; в частности, позволяет контролировать цепь видеосигнала до энной степени, выбирать много разных частот развертки и полос пропускания видеоплаты, если вы таким увлекаетесь. Пекка увлекался и, как многие другие финуксоиды, настроил комп так, чтобы тот показывал уйму крохотных пикселей (помещается много информации, но утомительно для глаз) или меньшее число более крупных пикселей, а также разные промежуточные разрешения. Всякий раз, как он менял разрешение, экран на секунду гас и раздавался щелчок — пьезокристаллы переходили на другой диапазон частот.
Как-то в три часа ночи Пекка переключил режим. Экран погас, щелкнул и взорвался ему в лицо. Передняя часть кинескопа была, естественно, из толстого стекла — ее осколки вошли Пекке в лицо, тело, торс. Тот самый люминофор, который светился под бегущим электронным лучом, передавая информацию глазам Пекки, теперь впился в его тело. Один осколок уничтожил глаз и остановился, не дойдя до мозга самую малость. Другой перерезал связки, третий просвистел рядом с головой и выкусил аккуратный треугольник из левого уха.
Другими словами, Пекка стал первой жертвой Дигибомбера. Он едва не умер от потери крови, и его друзья-евтропийцы несколько дней толклись у больничной койки с баллонами фреона, готовые немедленно приступить к делу, если он умрет. Однако Пекка не умер и вызвал новую шумиху тем, что оказался не застрахован. Местные газеты долго заламывали руки по поводу того, как бедный наивный мальчик из страны бесплатной медицины не нашел в себе духа потратиться на медицинскую страховку. В итоге несколько хайтечных магнатов скинулись на оплату медицинских счетов и компьютерный голосовой аппарат, как у Стивена Хокинга.
И вот теперь Пекка сидит у Кантрелла в номере. Виолончель стоит в углу, в районе кобылки еще видна канифолевая пыль. К стене изолентой приклеены проволочные петли и загогулины. Они тянутся к каким-то явно самопальным платам, те, в свою очередь, подключены к ноутбуку.
«Здравствуй Рэнди поздравляю с успехом», — говорит компьютерно сгенерированный голос, как только за Кантреллом и Рэнди закрывается дверь. Это маленькое приветствие Пекка, очевидно, набрал заранее. Все вполне в порядке вещей, удивляет другое: Пекка думает, что корпорация «Эпифит» уже добилась каких-то успехов.
— Как продвигается? — спрашивает Кантрелл.
Пекка печатает ответ. Потом подносит одну руку к изуродованному уху, а другой жмет на кнопку голосового генератора: «Он в душе. (И впрямь слышно, как в стене шумят трубы.) Его компьютер излучает».
— Ой, — удивляется Рэнди. — Том Говард — в соседней комнате?
— Через стенку от нас, — кивает Кантрелл. — Я нарочно так попросил, чтобы выиграть пари. Его номер — зеркальное отражение моего, так что компьютер всего в нескольких дюймах, сразу за стеной. Идеальные условия для ван-эйковского перехвата.
— Пекка, ты прямо сейчас получаешь сигналы с его компьютера? — спрашивает Рэнди.
Пекка кивает, печатает, жмет кнопку: «Настраиваю. Калибрую». Вводное устройство голосового генератора — MIDI-клавиатура под одну руку, пристегнутая к бедру. Пекка вслепую пробегает по нему пальцами, через несколько мгновений слышится голос: «Нужен Кантрелл».
— Извини. — Кантрелл садится рядом с Пеккой. Рэнди некоторое время смотрит им через плечо. Он примерно понимает, что они делают.
Если положить лист белой бумаги на старый могильный камень и провести карандашом черту, вы получите одну горизонтальную линию, где-то темнее, где-то светлее, однако ничего особенного не означающую. Если провести вплотную вторую черту, и так раз за разом, начнет проступать рисунок. Технарь назвал бы этот процесс разверткой или сканированием. В обычном мониторе — электронно-лучевой трубке — электронный луч действительно пробегает по стеклу от шестидесяти до восьмидесяти раз за секунду, в дисплее ноутбука, как у Рэнди, ничего по-настоящему не бегает, отдельные пиксели включаются и выключаются прямую. Однако процесс развертки все равно имеет место: при этом считывается и отображается на дисплее определенная область компьютерной памяти, называемая экранным буфером. Содержимое экранного буфера должно передаваться на дисплей шестьдесят-восемьдесят раз за секунду, иначе (1) экран будет мерцать, (2) изображение — дергаться.
Компьютер, общаясь с вами, не управляет экраном непосредственно, а манипулирует с битами экранного буфера, зная, что другие подсистемы передадут информацию на реальный дисплей. Шестьдесят-восемьдесят раз за секунду система говорит себе: «Блин, пора обновлять экран», лезет в начало буфера — а это, не забывайте, просто часть памяти — и считывает первые несколько байтов, определяющих, какого цвета будет пиксель в верхнем левом углу экрана. Информация отправляется тем, кто, собственно обновляет экран, будь то электронный луч или что-то такое в ноутбуке. Потом считываются следующие несколько байтов, обычно для пикселя справа от первого, и так до правого края экрана. Проводится первая черта натирки с могильного камня.
Теперь, когда достигнут правый край экрана, в этом направлении пикселей больше нет. Значит, следующие несколько байтов отвечают за крайний левый пиксель второй строки. В электроннолучевой трубке возникает небольшая заминка: луч на правом краю экрана, а его просят нарисовать пиксель на левом краю. Он должен переместиться обратно. Это занимает время — небольшое, но дольше, чем на переход между соседними пикселями. Называется — время обратного хода по строке. Так продолжается, пока не будет достигнут последний пиксель в нижнем правом углу и натирка с могильного камня не будет завершена. Однако теперь пора начинать по новой; электронный луч (если он есть) должен скользнуть по диагонали к верхнему левому пикселю. Тут тоже налицо заминка, которая называется временем обратного хода по кадру.
Все это происходит от того, что реальный электронный луч по-настоящему движется в электронно-лучевой трубке. Для дисплея как в ноутбуке, который Том Говард поставил через стенку от Пекки, такие ограничения вроде бы сняты. Однако тайминг сигнала у такого дисплея все равно взят у электронно-лучевой трубки. (Просто потому, что старая технология всем, кому надо, понятна и нормально работает, под нее сделаны и протестированы все программные и электронные технологии, а лучшее враг хорошего, особенно если прибыль у тебя настолько мала, что различить ее можно только с помощью методов квантовой механики, и любые помехи в совместимости подкосят компанию на корню.)
В ноутбуке Тома каждая секунда разделена на семьдесят пять абсолютно одинаковых интервалов, в каждый из которых полностью укладывается натирка с могильного камня плюс время обратного хода по кадру. Как понял Рэнди из разговора Пекки с Кантреллом, они уже установили по идущему через стенку сигналу, что Том настроил дисплей на разрешение 768 строк и 1024 пикселя в строке. Для каждого пикселя из буфера считываются и передаются по проводу на экран четыре байта. (Том выставил максимальное цветовое разрешение. Это значит, что нужно по байту на яркость каждого из основных цветов — красного, зеленого и синего. Один байт лишний, но его все равно оставляют, потому что компьютеры любят степени двойки, а мощность и быстродействие у них сейчас такие, что лишний байт решительно ничего не меняет.) Каждый байт — восемь двоичных разрядов или битов, значит, 1024 раза за строку из экранного буфера считываются 4 х 8 = 32 бита.
Неведомо для Тома, его компьютер стоит рядом с антенной. Проволока, которую Пекка прилепил к стене, читает электромагнитные волны, постоянно испускаемые компьютером.
Томов ноутбук продавался как компьютер, а не как радиопередатчик, и может удивить, с какой стати он что-то испускает. Дело в том, что компьютеры — двоичные существа. Всякое общение чипа с чипом, подсистемы с подсистемой внутри машины — все, что движется по проволочкам, заключенным в плоские ленты, и тонюсеньким металлическим линиям на платах — состоит из переходов от нуля к единице и обратно. Биты получаются, когда вы меняете напряжение на проволочке туда-обратно, от нуля до пяти вольт. В учебниках эти скачки рисуются идеальными прямоугольными импульсами: у вас есть идеально ровная линия при V = 0, представляющая двоичный ноль, потом она прыгает вверх под идеально прямым углом, достигает V = 5, снова поворачивает ровно на девяносто градусов и остается на пяти вольтах, пока не приходит время снова скакнуть на ноль, и так далее.

Это платоновский идеал того, как работает цепь. Однако инженеры вынуждены строить реальные цепи в мрачном аналоговом мире. Куски металла и кремния не способны к платоническому поведению, описанному в книгах. Напряжение и впрямь перескакивает с нуля до пяти вольт, но если проследить за ним на осциллографе, вы увидите, что это не вполне прямоугольный импульс. Вашим глазам предстанет что-то примерно такое:

Затухающие колебания называются звон: переход между двоичным цифрами ударяет по цепи, как било по колоколу. Напряжение прыгает, потом еще некоторое время колеблется возле нового значения. Когда в проводнике вот так колеблется напряжение, значит, в пространство разбегаются радиоволны.
Соответственно каждая проволочка в работающем компьютере — маленький радиопередатчик. Сигналы, которые она посылает, полностью определяются тем, что происходит в машине. Поскольку проволочек не счесть, а происходит много чего разного, разобрать все радиопередачи со стороны практически невозможно. Большая часть того, что творится в машине, абсолютно неинтересна с точки зрения шпионажа. Однако есть некая последовательность сигналов, которая (1) вполне предсказуема, (2) являет собой именно то, что Пекка хочет увидеть. Это поток битов, считываемых с экранного буфера и отправляемый по проводу экранному железу. В случайном шуме из компьютера время обратного хода по строке и по кадру — как бой тамтама в густонаселенных джунглях. Теперь, когда Пекка настроится на этот ритм, он сможет ловить излучение кабеля, соединяющего экранный буфер с видеооборудованием, и переводить его обратно в последовательность нулей и единиц, которую можно вывести на собственный монитор. Тогда он увидит то же, что Том Говард, с помощью шпионского метода, называемого ван-эйковский перехват.
Все эти общие принципы Рэнди известны. Когда доходит до подробностей, оказывается, что Пекка и Кантрелл выше его на три головы. Через несколько минут ему становится скучно. Он садится Кантреллу на кровать (больше сесть некуда) и обнаруживает на столике наладонник — включенный, загрузившийся и соединенный с миром телефонным кабелем. Рэнди слышал о таких игрушках. Считается, что это первые сетевые компьютеры, поэтому при включении сразу загружается сетевой браузер. Сетевой браузер — интерфейс этой машинки.
— Можно залезть? — спрашивает Рэнди, и Кантрелл, не обернувшись, отвечает: «Да».
Рэнди заходит на один из больших поисковых сайтов (что занимает примерно минуту, потому что машинка должна сначала войти в сеть) и делает запрос по ключевым словам ((Энди OR Эндрю) Лоуб) AND «коллективный разум». Как всегда, выбрасываются десятки тысяч документов. Однако Рэнди без труда находит существенные.

ПОЧЕМУ ОНСО 9ЕОЗ ЯВЛЯЕТСЯ ВИДНЫМ ЧЛЕНОМ КАЛИФОРНИЙСКОЙ АССОЦИАЦИИ АДВОКАТОВ
ОНСО 11А4 испытывает двоякие чувства по поводу того, что ОНСО 9Е03 (в той мере, в какой он/она воспринимается атомизированным обществом в качестве индивидуального организма) является адвокатом. Без сомнения, противоречивые чувства ОНСО 11А4 вполне нормальны и объяснимы. Часть ОНСО 11А4 ненавидит юристов и юридическую систему в целом, как симптомы последней стадии смертельной болезни атомизированного общества. Другая часть понимает, что болезнь может содействовать оздоровлению мемофонда, убивая старый организм, неспособный к распространению своего мемотипа. Не следует обольщаться: юридическая система в ее современной форме является наихудшей системой решения общественных споров. Она вопиюще дорого обходится и в денежном выражении, и как бессмысленная трата способностей со стороны тех, кто избрал ее в качестве рода деятельности. Однако часть ОНСО 11А4 считает, что целей ОНСО 11А4 можно достичь, обратив наиболее одиозные особенности юридической системы против прогнившего атомизированного общества и таким образом ускорив его крах.

Рэнди щелкает по ОНСО 9Е03 и получает:

ОНСО 9Е03 это ОНСО, которое ОНСО 11А4 определяет произвольным битовым обозначением, в числовом выражении составляющим 9Е03 (в шестнадцатеричном представлении). Щелкните здесь, чтобы узнать больше о системе битовых обозначений, используемой ОНСО 11А4 для замены устаревшей номенклатурной системы «естественных языков». Щелкните здесь, чтобы обозначение ОНСО 9Е03 автоматически заменялось традиционным (фамилия, имя) при вашем перемещении по сайту.

Щелк.

С этого момента выражение ОНСО 9Е03 будет заменяться выражением Эндрю Лоуб. Предупреждаем: мы считаем такую номенклатуру фундаментально ошибочной и не рекомендуем ее использовать, но предоставляем в качестве услуги для тех, кто посещает наш сайт впервые и не привык мыслить в терминах ОНСО.

Щелк.

Вы щелкнули по Эндрю Лоуб — обозначение, которое атомизированное общество присвоило мемому ОНСО 9Е03...

Щелк.

...мемом — это набор мемов, определяющих физическую реальность ОНСО на углеродной основе. Мемы делятся на две большие категории: генетические и семантические. Генетические мемы это просто гены (ДНК), которые распространяются путем обычной биологической репродукции. Семантические мемы — это идеи (идеологии, религии, мода и т. п.), распространяемые путем общения.

Шелк.

Генетическая часть мемома Эндрю Лоуб на 99% идентична последовательности, установленной Проектом Генома Человека. Это не следует понимать как поддержку концепции разделения на виды (согласно которой континуум жизненных форм на углеродной основе может или должен произвольно подразделяться на парадигматические виды) вообще и теории о том, что существует вид под названием Гомо сапиенс, в частности.
Семантическая часть мемома Эндрю Лоуб по-прежнему неизбежно заражена многими примитивным вирусоподобными мемами, но они планомерно вытесняются новыми семантическими мемами, изначально генерируемыми в ходе рациональных процессов.

Щелк.

ОНСО означает относительно независимую субобщность. Термин может применяться по отношению к любой сущности, которая, с одной стороны, якобы четко ограничена от остального мира (как, впрочем, и клетки в теле), но, в более общем смысле, неразрывно связана с более крупной общностью (как клетки в теле). Например, биологические сущности, традиционно называемые «людьми», на самом деле всего лишь относительно независимые субобщности социального организма.
В диссертации, написанной под именем Эндрю Лоуб, который теперь обозначается как ОНСО 9Е03, указывается, что даже в умеренных климатических зонах ОНСО 0577, изобилующих водой и пищей, жизнь организмов, обозначавшихся в прежних мемосистемах как Гомо сапиенс, по большей части состояла из попыток съесть другие ОНСО. Такая узкая направленность препятствовала бы образованию высокоорганиэованных мемосистем (а именно цивилизаций в традиционном понимании). ОНСО этого типа могут функционировать на более или менее высоком уровне лишь в меру своей принадлежности к более крупному обществу, наиболее логичной эволюционной формой которого является коллективный разум.

Щелк.

Коллективный разум — это социальный организм, объединяющий ОНСО, способные вырабатывать семантические мемы («думать»). Это могут быть ОНСО на углеродной или кремниевой основе, которые, вливаясь в коллективный разум отбрасывают независимую личность (та в любом случае иллюзорна). Для удобства составляющим коллективного разума присваиваются битовые обозначения.

Щелк.

Битовое обозначение — случайная последовательность битов, используемая для однозначной идентификации ОНСО. Например, организму, традиционно обозначаемому как Земля (Терра, Гея), присвоено обозначение ОНСО 0577. Данный сайт поддерживается ОНСО 11А4, который является коллективным разумом. ОНСО 11А4 присваивает битовые обозначения с помощью генератора псевдослучайных чисел. Это отличается от практики, которую применяет самозваный «коллективный разум», именующий себя «Ист-бэйский проект коллективного разума», но обозначаемый (в системе, принятой ОНСО 11А4) как ОНСО Е772. Этот «коллективный разум» возник в результате раскола «коллективного разума один» (обозначаемого в системе ОНСО 11А4 как ОНСО 4032) на несколько меньших «коллективных разумов» («Ист-бэйский проект коллективного разума», «Сан-францисский коллективный разум», «Коллективный разум один-А», «Реформированный сан-францисский коллективный разум» и «Всемирный коллективный разум») в результате неразрешимых противоречий между различными семантическими мемами. Один из этих семантических мемов предполагает, что обозначения должны присваиваться по порядку, например, «коллективный разум один» должен обозначаться ОНСО 0001 и так далее. Другие считают, что числа должны располагаться в порядке значимости, чтобы, например, ОНСО, традиционно называемое «планета Земля», обозначалось ОНСО 0001. Другие семантические мемы согласны с этим утверждением, но настаивают, что нумерация должна начинаться не с 0001, а с 0000. И среди сторонников 0001, и среди сторонников 0000 имеются разногласия по поводу того, какому ОНСО присваивать первый номер: одни считают, что первым и наиболее важным ОНСО является Земля, другие — что более крупные единицы (Солнечная система, Вселенная, Бог) являются в некотором роде более всеохватывающими и универсальными.

У машинки есть интерфейс для электронной почты. Рэнди набирает:

Кому: root@eruditorum.org
От: dwarf@siblings.net
Тема: Re (2): Зачем?
Посмотрел сайт. Готов допустить, что Вы — не ОНСО 9Е03. Подозреваю, что Вы — Дантист, стремящийся к свободному обмену мнениями. Анонимная, электронно подписанная корреспонденция — единственный безопасный способ такого обмена.
Если хотите убедить меня, что Вы — не Дантист, объясните Ваш интерес к строительству Крипты.
Искренне Ваш

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т. д.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

— Идут биты, — говорит Кантрелл. — У тебя там что-нибудь важное?
— Ничего такого, что было бы жаль бросить.
Рэнди откладывает наладонник. Подходит, встает рядом с Пеккой. На экране у того несколько окон, самое большое и верхнее изображение другого компьютерного дисплея. Это рабочий стол окошками и значками. Причем рабочий стол Windows NT, что примечательно и (для Рэнди) неожиданно, поскольку у Пекки запущен Finux, а не Windows NT.
По рабочему столу Windows NT бегает курсор, вызывает меню нажимает кнопки. Однако рука Пекки не движется. Курсор замирает на значке Microsoft Word, который меняет цвет и разворачивается на все большое окно.

Данная версия Microsoft Word зарегистрирована на ТОМАСА ГОВАРДА.

— Получилось! — говорит Рэнди.
— Мы видим то же, что Том, — говорит Пекка. Открывается окно нового документа, в нем начинают выскакивать слова.

Пометка для себя: вот пусть «Письма в Пентхауз» опубликуют это!
Полагаю, что выпускники и выпускницы высших учебных заведений не такие уж выдающиеся любовники. Мы слишком много об этом думаем. Все должно быть вербализовано. Человек, считающий, что ебля — это сексуальный дискурс, просто не может быть хорош в постели.
У меня прикол по поводу чулок. Они должны быть гладко-черные, желательно со швом сзади. В тринадцать я спер в магазине черные колготки, просто чтобы их трогать. Когда я шел домой с колготками в рюкзачке, сердце у меня бешено колотилось, но волнение от кражи померкло в сравнении с тем, что я испытал, распечатав упаковку и прижав нейлон к пухлым подростковым щекам. Я даже попытался надеть их, на мои-то волосатые ноги, но абсолютно ничего не почувствовал. Я не хотел их носить. Я хотел, чтобы они были на ком-то другом. В тот день я мастурбировал четыре раза.
Меня это страшно волновало. Я был умненький мальчик. Считается, что умные мальчики — рационалисты. Поэтому в колледже я придумал рациональное объяснение. У нас в колледже девушки в чулках не ходили, но иногда я бывал в городе, видел, как хорошо одетые сотрудницы фирм идут в черных чулках, и научно изучал их ноги. Я приметил, что, когда чулок растягивается на более широкой части ноги, скажем, на икроножной мышце, он светлеет, как воздушный шарик, когда его надуваешь. Соответственно в более узких местах, например на щиколотке, он темнее. От этого икра кажется полнее, щиколотка — тоньше. Ноги в целом выглядят более здоровыми, намекая, что между ними можно найти ДНК более высокого класса.
Q.E.D. Мой прикол насчет чулок — высокоразумная адаптация. Я просто доказал, какой я умный, насколько рациональны даже самые иррациональные части моего мозга. Секс надо мной не властен, мне нечего бояться.
Это были глубоко школьные рассуждения, но в наши дни большинство образованных людей рассуждают, как школьники, до тридцати и позже, так что я надолго на этом застрял. У моей жены Вирджинии, вероятно, были такие же рациональные оправдания ее собственных сексуальных потребностей, о которых я узнал значительно позже. Неудивительно, что наша добрачная половая жизнь была очень так себе. Ни она, ни я в этом, разумеется, не признавались. Иначе я должен был бы признать, что все это — из-за нежелания Вирджинии носить черные чулки, а я слишком хотел быть чутким и современным. Я любил Вирджинию за ее ум. Каким надо быть нечутким извращенцем, чтобы отвергать ее за нежелание натягивать на ноги полупрозрачные нейлоновые трубки? Мне, пухлому школяру, крупно повезло такую заполучить.
На шестом году нашего брака я присутствовал на конференции «Комдекс» в качестве президента небольшой высокотехнологической компании. К тому времени я уже был не такой пухлый и не такой школяр. Я познакомился с девушкой из отдела маркетинга крупной сети по распространению программного обеспечения. Она носила гладкие черные чулки. Кончилось тем, что мы трахнулись у меня в номере. Это было что-то необыкновенное. Домой я вернулся обескураженный и пристыженный. После этого наша с Вирджинией жизнь совсем разладилась. За два года мы трахнулись раз десять, не больше.
У Вирджинии умерла бабушка, и мы поехали на похороны. Вирджинии пришлось надеть платье, а значит, побрить ноги и натянуть чулки, что с нашей женитьбы случалось всего несколько раз. Я едва не упал, когда ее увидел, и всю заупокойную службу мучился сильнейшей зудящей эрекцией, только и думая, куда бы Вирджинию затащить.
Бабуля жила одна в большом старом доме на холме, пока за пару месяцев до смерти не сломала шейку бедра и не оказалась в больнице. Все ее дети, внуки и правнуки съехались на похороны, так что в доме собралась уйма народу. Дом был красивый и хорошо обставленный. Правда, в последние годы бабулька стала страшной барахольщицей и распихивала повсюду кучи газет, писем и тому подобного. В конце концов мы вывезли несколько грузовиков мусора.
Во всем остальном бабка была очень организованная и оставила весьма подробное завещание. Мебель, посуда, ковры и безделушки — все это она четко расписала между родней. Добра было много, но и потомков — целая куча, так что каждому досталось всего ничего. Вирджинии бабка отписала черный комод орехового дерева с зеркалом, стоящий в нежилой спальне. Мы пошли его смотреть, и там-то я ее трахнул. Я стоял в спущенных штанах, а она сидела на комоде, и ее обтянутые черными чулками пятки вжимались мне в зад. Это было потрясающе. Хорошо, что родственники внизу ели, пили и разговаривали, не то они услышали бы, как она стонет и вопит.
Я наконец рассказал ей про чулки. Мне сразу полегчало. К тому времени я кое-что прочел про то, как развивается мозг, и смирился со своим приколом. Получалось, что в определенном возрасте, где-то между двумя и пятью годами, мозг просто застывает. Та часть, которая отвечает за секс, формируется в это время, и дальше ты живешь с ней до конца жизни. Все голубые, с которыми я говорил, утверждают, что осознали себя голубыми, или по крайней мере отличными от других, задолго до того, как начали думать о сексе, и все они согласны, что гомосексуалиста не сделаешь натуралом, и наоборот.
В этом возрасте часть мозга, отвечающая за секс, часто закорачивается на другие, никак не связанные отделы. Тогда-то и возникает ориентация на сексуальное подавление или подчинение, а у многих появляются очень специфические приколы — скажем, по поводу резины, перьев или обуви. Некоторые бедолаги западают на маленьких детей, и тогда пиши пропало — их можно только кастрировать или запереть до конца жизни. Никакое лечение тут не поможет.
То есть, если хорошенько взвесить, мне достался далеко не худший прикол. Все это я изложил Вирджинии по дороге домой и сам удивился, как спокойно она выслушала. Мне, идиоту, было невдомек, что она размышляет, как это относится к ней самой.
Когда мы вернулись, она честно пошла и купила несколько пар чулок, даже попыталась их носить, но это оказалось не так просто. Чулки предполагают определенный стиль жизни. Они выглядят глупо с джинсами и кроссовками. К чулкам нужны платье или юбка, и не просто джинсовая, а более красивая и парадная. Кроме того, нужны туфли, которых у Вирджинии не было. В чулках неудобно ездить на работу на велосипеде. Более того, чулки нельзя было носить у нас дома. Пока мы учились в аспирантуре, денег не хватало, и мебель мы покупали подержанную, а кое-что я сам соорудил из досок. Вся эта мебель оказалась в скрытых заусеницах, которые мы не замечали, пока ходили в джинсах, но чулки о них рвались в первые пятнадцать минут. Аналогично, у нашего недостроенного дома и развалюшной машины оказалась куча острых углов, цепляющих чулки. С другой стороны, когда мы летали в Лондон на юбилей свадьбы, ездили в черных такси, останавливались в хороших гостиницах, ели в дорогих ресторанах, мы целую неделю вращались в мире, идеально приспособленном для чулок. Это показывало, как сильно должна измениться наша жизнь, чтобы Вирджиния начала так одеваться.

Предыдущая страница 17 Следующая страница


Криптономикон (часть 1) 18

Короче, в припадке добрых намерений куча денег была потрачена на чулки. Какое-то количество раз мы трахнулись очень даже неплохо, хотя, похоже, удовольствие было больше с моей стороны. Вирджиния ни разу не испытала того звериного экстаза, что на бабулькиных похоронах. Чулки скоро изорвались, новые купить у Вирджинии все как-то не получалось, и через год мы вернулись к тому, с чего начали.
Однако наша жизнь понемногу менялась. Я продал кое-какие акции, мы купили новый дом на холме. Наняли грузчиков перевезти нашу обшарпанную мебель, которая в новом доме смотрелась еще плачевнее. Вирджиния сменила работу и теперь должна была ездить туда на машине. Я счел, что наша развалюха недостаточно безопасна, и купил ей маленький «лексус» с кожаными сиденьями и шерстяным ковриком, без всяких углов и зацепок. Скоро пошли дети, я продал старый пикап и купил минивэн.
Тем не менее меня жаба душила покупать новую мебель, пока не начались проблемы со спиной и я не понял, что все дело в продавленном матрасе, на котором мы спим. Поскольку речь шла о моей спине, я и отправился за покупкой.
Вообще-то мне легче прижечь себе язык сигаретой, чем идти что-нибудь покупать. Я представил, как буду обходить все большие мебельные салоны, сравнивая кровати, и мне захотелось умереть. Я хотел прийти в одно место, купить и покончить с этим раз и навсегда. Однако я не хотел дерьмовую кровать, на которую через год будет тошно смотреть, или дешевый матрас, который через пять лет промнется и боли в спине начнутся по новой.
Поэтому я направился прямиком в местную галерею «Гомера Болструда». Я слышал, как говорят о тамошней мебели, особенно женщины — у них сразу становятся такие приглушенные, религиозные голоса. Фабрика, где все это делают, вроде бы в Новой Англии, в том же здании, что и триста лет назад, а стружкой от Гомера Болструда, по слухам, разводили костры под ведьмами. «Гомер Болструд» — вот ответ на вопрос, который я задавал себе с самых похорон: откуда берется вся эта роскошная бабулькина мебель? В каждой семье молодые люди ездят к бабуле на День благодарения и другие нудные семейные торжества, а сами гадают, какой буфет смогут забрать, когда старушка откинет копыта. Некоторые не в силах дотерпеть и отправляются в антикварные магазины.
Однако если запас старинной мебели ограничен, то откуда возьмутся будущие бабули? Я представил, как полстолетия спустя наши с Вирджинией потомки передерутся из-за одного черного комода орехового дерева, а всю остальную нашу мебель свезут прямиком на свалку. Поскольку население растет, а запас старинной мебели не увеличивается, такие ситуации неизбежны. Должен быть источник новой бабулькиной мебели, иначе все будущие американцы обречены сидеть в виниловых креслах, из которых сыплется на пол пенопластовая крупа.
Ответ: «Гомер Болструд». Цена высока. Каждый стол и стул от «Гомера Болструда» должен бы по-хорошему продаваться в коробочке с бархатной подкладкой, как драгоценность. Поэтому я отправился в «Гомер Болструд», ворвался в дверь и налетел на секретаршу. В кроссовках и джинсах я сразу почувствовал себя оборванцем. Видимо, на ее глазах в эту дверь входило много разбогатевших компьютерщиков, потому что она не бухнулась в обморок, а спокойно пригласила пожилую женщину и сказала, что это будет мой личный консультант. Звали ее Маргарет. «Где кровати?» — спросил я. Маргарет поджала губы и объяснила, что это не такое место, где кровати в одном большом зале выставлены рядами, как свиные ноги в мясной лавке. Галерея «Гомера Болструда» состоит из шикарно обставленных комнат, в том числе спален, где, кроме всего прочего, есть кровати. Маргарет повела меня их смотреть. По пути из комнаты в комнату я не преминул заметить, что на Маргарет черные чулки с идеально прямым швом.
Мне стало неловко от эротического чувства к Маргарет, и некоторое время я перебарывал желание ляпнуть: «Просто продайте мне самую большую и дорогую кровать, какая у вас есть». Маргарет показала кровати различных стилей. Названия ничего мне не говорили. Одни выглядели современными, другие — под старину, я указал на очень большую, высокую кровать бабулькиного типа и сказал: «Беру».
Три месяца пришлось ждать, пока ее изготавливали вручную умельцы, работающие по тем же ставкам, что психоаналитики. Потом кровать привезли. Собирали ее рабочие в белых комбинезонах, как в цехе по производству микропроцессоров. Вирджиния вернулась домой с работы. Она была в джинсовой юбке, толстых носках и панталетах. Дети еще не пришли из школы. Мы трахнулись на новой кровати. Надеюсь, я был на должном уровне. Мне не удалось удержать эрекцию и пришлось доводить дело до конца, просунув голову между ее шершавыми бедрами. Хотя уши у меня были зажаты ее ляжками, я все равно слышал, как Вирджиния вопит и стонет. Под конец она забилась в таких судорогах, что чуть не свернула мне шею. Ее оргазм длился полных две или три минуты. Тогда я впервые понял, что Вирджиния может кончить только по соседству с (желательно на) драгоценным предметом мебели, ей лично принадлежащим.

Окно с изображением рабочего стола исчезает. Пекка щелчком отправил его в небытие.
— Больше не выдержу, — говорит электронно-бесстрастный голос.
— Предсказываю любовь втроем между Томом, его женой и Маргарет на кровати в мебельном магазине, страниц так через сто, — задумчиво произносит Кантрелл.
— Интересно, это Том? Или какой-то его вымышленный персонаж? — говорит Пекка.
— Означает ли это, что ты выиграл пари? — спрашивает Рэнди.
— Только если придумаю, как получить выигрыш, — отвечает Кантрелл.

ВПЛАВЬ

Над морем Бисмарка сгустились бурые миазмы, пахнущие мазутом и барбекю. Американские торпедные катера вырываются из смрадного тумана, едва касаясь воды корпусом, прочерчивают море изогнутыми шрамами белой пены и выстраиваются для атаки на последние транспорты, покрытые, как замшелая скала, бурым ковром солдат. Торпеды летят, словно стрелы из арбалета, выпущенные сжатым воздухом из труб под корабельными палубами. Они шлепаются в воду, выбирают удобную глубину, где море всегда спокойное, и, таща за собой хвост пузырей, несутся к транспортам. Гото Денго отворачивается и слышит, но не видит взрыв. Почти никто в японской армии не умеет плавать.
Потом самолеты возвращаются и обстреливают их с воздуха. Те, кто умеет нырять и догадывается это сделать, неуязвимы. Других довольно быстро не остается. Самолеты улетают. Гото Денго стаскивает спасжилет с трупа. До вечера еще много часов, а Гото уже обгорел на солнце, как никогда в жизни. Заимствует вдобавок гимнастерку, повязывает ее на голову, как бурнус.
Те, кто еще жив и умеет плавать, стараются сбиться в кучу. Прихотливые течения между Новой Гвинеей и Новой Британией тянут их в разные стороны. Некоторые медленно дрейфуют прочь, пытаясь докричаться до товарищей. В конце концов Гото Денго оказывается на краю тающего архипелага из, может быть, сотни пловцов. Многие цепляются за спасательные круги или доски. Волны гораздо выше головы, так что видно не очень далеко.
Перед закатом марево ненадолго рассеивается. Гото Денго видит солнце и впервые с начала дня понимает, где восток, а где запад. А самое замечательное: он видит над южным горизонтом горы, покрытые голубовато-белым льдом.
— Я поплыву к Новой Гвинее! — кричит он и начинает грести. Нечего и пытаться обсудить это с другими. Те, кто решает за ним последовать — в общей сложности, может быть, несколько десятков пловцов, — тоже принимаются работать руками и ногами. Море, как на удачу, удивительно тихое.
Гото Денго медленно, спокойно плывет на боку. Большинство пловцов барахтаются по-собачьи. Продвигаются ли они, сказать нельзя. Когда начинают зажигаться звезды, Гото переворачивается на спину и находит Полярную. Пока плывешь от нее, физически невозможно промахнуться мимо Новой Гвинеи.
Темнеет. Слабо светят звезды и месяц. Пловцы перекликаются, стараясь держаться вместе. Некоторых уносит течением: их слышно, но не видно. Остальные ничем не могут помочь, только слушают затихающие крики.
Акулы появляются около полуночи. Первая жертва — солдат, раскроивший себе лоб о край люка, когда выбирался с тонущего корабля. За ним с самого утра тянется розовая дорожка крови, она-то и вывела акул на пловцов.
Сперва акулы не знают, с кем имеют дело, поэтому постепенно выматывают его, откусывая по кусочку. Поняв, что добыча легкая, они приходят в боевое исступление, тем более фантастическое, что сами акулы скрыты черной водой. Крик обрывается на середине, человек исчезает рывком. Иногда над поверхностью взлетают нога или голова. У воды, захлестывающей в рот, появляется привкус железа.
Атака длится несколько часов. По-видимому, шум и запах привлекли несколько конкурирующих стай, потому что временами наступает затишье, затем — новая бойня. Гото Денго утыкается лицом в оторванный акулий хвост и впивается в него зубами. Акулы едят их — почему не ответить тем же. В токийских ресторанах за сасими из акулы берут кучу денег. Шкура на хвосте жесткая, но с оторванного края висят клочья мяса. Гото Денго вгрызается в него и уплетает за обе щеки.
У его отца была фетровая шляпа на бежевой шелковой подкладке и трубка, табак для которой приходилось выписывать из Америки. Отец уходил в горы, садился на камень, потуже натягивал шляпу, чтобы ветер не холодил лысину, раскуривал трубку и долго сидел так, просто глядя на мир.
— Что ты делаешь? — спрашивал маленький Денго.
— Созерцаю, — отвечал отец.
— Сколько ж можно смотреть на одно и то же?
— Бесконечно. Вот глянь. — Отец указывал чубуком. Из мундштука разматывался тонкий белый дымок, словно нить из шелковичного кокона. — Та полоса темной породы — рудоносная. Из нее можно добывать медь, может быть, попутно — свинец и цинк. Можно построить фуникулер вон до того плоского места, потом пройти наклонную штольню параллельно простиранию залежи... — Денго включался и придумывал, где будут жить горняки, где построить школу, а где разбить площадку для игр. Под конец разговора в долине вырастал воображаемый поселок.
В ту ночь у Гото Денго много времени для созерцания. Он заметил, что на оторванные части тела акулы практически не нападают. Тех, кто плывет быстрее, хватают первыми. Поэтому при появлении акул он неподвижно замирает на спине и не шевелит и мускулом, даже когда зазубренный край чьего-то ребра тычет его в лицо.
Наступает рассвет, через сто или двести часов после заката. Гото Денго никогда не бодрствовал целую ночь и потрясен, что такое огромное солнце ушло с одного края планеты и вышло с другой. Он — вирус, зародыш, живущий на поверхности неизмеримо огромных, стремительно движущихся тел. И, удивительное дело, он по-прежнему не один: еще трое пережили ночь и акул. Они подплывают ближе и поворачивают к снежным пикам Новой Гвинеи, нежно-розовым в свете зари.
— Они ничуть не приблизились, — говорит один.
— Они в глубине острова, — объясняет Гото Денго. — Мы плывем не к горам, а к берегу — гораздо ближе. Давайте приналяжем, пока не умерли от жажды. — Он начинает грести на боку.
Один из выживших — судя по выговору, уроженец Окинавы — отлично плавает. Они с Гото Денго легко оторвались бы от двух других, однако весь день держатся с ними вместе.
Один из тех, кто плывет медленно, перед этим неделю страдал поносом и, вероятно, уже был обезвожен. Когда солнце зависает прямо над ними, как огнемет, он начинает биться в судорогах, нахлебывается воды и идет ко дну.
Второй медленный пловец — из Токио. Он в гораздо лучшей физической форме, просто не умеет плавать. «Самое время научиться», — говорит Гото Денго. Примерно час они с окинавцем учат его грести на спине и на боку, потом возобновляют движение к югу.
Ближе к закату Гото Денго замечает, что окинавец большими глотками пьет морскую воду. Смотреть больно, главным образом оттого, что безумно хочется сделать то же самое. «Нет! Тебе будет плохо!» — говорит он. Голос слабый. Набрать в грудь воздуха, преодолевая безжалостное давление воды — труд непосильный. Каждая мышца ноет.
К тому времени, когда Гото Денго доплывает до окинавца того уже рвет. С помощью токийца Гото засовывает пальцы ему в глотку и помогает вытошнить остальное.
Парень совсем ослабел, он лежит на спине и бредит. Впрочем, посреди ночи, когда Гото Денго наконец решает его бросить, окинавец внезапно приходит в себя и спрашивает: «Где Полярная?»
— Сегодня облака, — говорит Гото Денго. — Но в них белое пятно — может быть, луна.
Ориентируясь по светлому пятну, они прикидывают, где может быть Новая Гвинея, и плывут дальше. Руки и ноги — как мешки с глиной; все трое галлюцинируют.
Вроде бы встает солнце. Они в паровой туманности, которая несется через отдаленные части галактики, излучая золотисто-розовый свет.
— Пахнет гнилью, — говорит один (Гото Денго не может разобрать который).
— Гангрена? — предполагает другой.
Гото Денго принюхивается, тратя на это половину оставшихся сил.
— Не мясо, — говорит он. — Растения.
Никто больше не может плыть, а если б и мог, то не знал бы куда — туман светится равномерно. В любом случае это ничего бы не изменило — течение гонит их, куда хочет.
Гото Денго некоторое время спит, а может быть — нет. Нога задевает о какой-то выступ. Слава богу. Акулы появились, чтобы их прикончить.
Волны становятся агрессивнее. Нога снова обо что-то задевает. Обожженная кожа вопит. Оно твердое и колючее.
Что-то торчит из воды прямо впереди, какие-то белые бугры. Верхушки кораллов.
Волна разбивается, подхватывает их и тащит через кораллы, обдирая половину кожи. Гото Денго ломает палец и считает, что ему еще повезло. Следующая волна, снимая оставшуюся кожу, выбрасывает его в лагуну. Что-то выталкивает ноги вверх, а поскольку все тело — обмякший мешок с дерьмом, то голова зарывается в воду и лицо втыкается в колкий коралловый песок. Руки и ноги забыли обычные движения, умеют только грести, и проходит некоторое время, прежде чем Гото, упершись в дно, поднимает голову над водой, потом на карачках ползет к берегу. Запах гниющей растительности повсюду, как будто провиант для целой дивизии оставили на неделю под солнцем.
Он находит песок, не залитый водой, поворачивается и садится. Окинавец чуть позади, тоже ползет на карачках. Токиец сумел встать и бредет к берегу, шатаясь под ударами волн. Он смеется.
Окинавец падает на песок рядом с Гото Денго и даже не пытается сесть.
Волна сбивает токийского паренька с ног. Тот со смехом валится в прибой, успевая выставить руку.
Смех резко обрывается. Токиец вскакивает. Что-то болтается у него на руке: извивающаяся змея. Он встряхивает ее, как плеть, змея отлетает в воду.
Испуганный, отрезвленный, токиец проходит последние пять-шесть шагов и падает ничком. Когда Гото Денго дотягивается до него рукой, он уже мертвее мертвого.
Трудно сказать, как долго Гото Денго собирается с силами. Может быть, он заснул сидя. Парнишка из Окинавы по-прежнему лежит и бредит. Гото Денго с усилием встает и, шатаясь, идет на поиски пресной воды.
Это не настоящий берег, просто береговой вал метров десять в длину и, может быть, три в ширину, поросший сверху какой-то высокой травой. Дальше начинается стоячая лагуна, стиснутая сплошным переплетением жизни, таким плотным, что пройти там невозможно. Поэтому, невзирая на то, что случилось с токийцем, Гото Денго бредет по лагуне, надеясь выйти к ручью.
Он идет примерно час, но лагуна вновь выводит его к морю. Он сдается и пьет воду, по которой шел, в надежде, что она будет чуть более пресной. Его долго тошнит, но потом, как ни странно, становится чуть легче. Идет в заросли, ориентируясь по шуму прибоя сзади, и примерно через час находит речушку с настоящей пресной водой. Напившись, чувствует в себе силы вернуться за товарищем и, если надо, нести его к ручью на себе.
Гото Денго возвращается на берег. Окинавца нет, но вокруг понатоптано следов. Песок сухой, следы невнятные. Наверное, это патруль! Товарищи узнали о нападении на конвой и прочесывают берег в поисках уцелевших. Где-то близко в джунглях должен быть бивуак!
Гото Денго идет по следам. Примерно через милю тропа пересекает мокрый глинистый пятачок, на котором следы отпечатались отчетливо. Все они оставлены босыми ступнями с огромными растопыренными пальцами. Следы людей, никогда не носивших обуви.
Следующие метров сто он продвигается осторожнее. Слышны голоса. В армии их научили, как проникать в джунгли, как бесшумно проползать ночью через вражеские ряды. Разумеется на тренировках в Японии его не жрали заживо москиты и муравьи, но Гото Денго уже почти все равно. За час кропотливого труда он выбирается на открытое место, откуда видна поляна, по которой вьется заболоченный ручеек. Над зловонной жижей высятся на сваях несколько домов, крытых охапками пальмовых листьев.
Прежде чем искать товарища, Гото Денго должен найти еду. Посреди поляны булькает на костре котел с белой кашей, но рядом — жилистые женщины в одних косматых юбочках, едва прикрывающих срам.
Из некоторых длинных домов тоже поднимается дым. Однако, чтобы попасть туда, надо карабкаться по тяжелой наклонной лестнице и ползком протискиваться в узкий лаз. Ребенок с палкой, встав там, сможет не впустить чужака. Перед некоторыми лазами висят тряпичные узлы (ткани у них, выходит, все-таки есть), наполненные чем-то круглым — кокосовыми орехами или другими припасами, подвешенными для защиты от муравьев.
Человек семьдесят собрались посреди поляны вокруг чего-то интересного. Они движутся, и Гото Денго временами различает за телами кого-то, возможно, японца: он сидит под пальмой, руки связаны за спиной. Лицо в крови, и он не шевелится. Собравшиеся в основном мужчины, почти все — с копьями. На них тоже юбочки из чего-то волокнистого, иногда выкрашенные в зеленый или красный цвет и еле-еле прикрывающие половые органы. У тех, кто постарше и покрупнее, на руках повязаны тряпичные полоски, у некоторых лица раскрашены светлой глиной, а в носовые перегородки просунуты различные предметы, иногда довольно крупные.
Все внимание приковано к окровавленному человеку, и Гото Денго решает, что сейчас единственный случай украсть еду. Он выбирает хижину подальше от поляны, влезает по лестнице и тянется к узлу над входом. Однако ткань старая, источенная болотной сыростью, а может — мириадами мух, которые жужжат вокруг; пальцы проходят прямо через нее. Большой кусок мешка отрывается, и содержимое валится к ногам Гото Денго: что-то темное и волосатое, как кокосовые орехи, но более сложной формы. Инстинктивное чувство — что-то не так! — возникает раньше, чем мозг узнает в них человеческие черепа. Их штук пять, обтянутых иссохшей кожей. Некоторые темные, с курчавыми черными волосами, как у туземцев, другие выглядят определенно японскими.
Какое-то время спустя к Гото Денго возвращается способность мыслить. Он не знает, сколько простоял тут, на виду у всей деревни, пялясь на черепа. Однако все по-прежнему заняты раненым под пальмой.
Со своего места Гото Денго видит, что это и впрямь окинавец. Руки его связаны по другую сторону ствола. Перед ним стоит мальчик лет, может быть, двенадцати, с копьем. Мальчик тычет наконечником в грудь раненому. Тот просыпается и начинает метаться. Мальчик в страхе отпрыгивает. Тогда мужчина постарше, в уборе из раковин каури, встает рядом с мальчиком, показывает, как держать копье, и направляет удар. Вдвоем они втыкают острие в сердце пленнику.
Гото Денго падает с лестницы.
Мужчины приходят в крайнее возбуждение и, подхватив мальчика на плечи, с прыжками и криками несут его по поляне, воинственно потрясая копьями. За ними бегут все, кроме самых маленьких детей. Гото Денго, в ушибах, но без переломов от падения на мягкую землю, отползает в джунгли и прячется. Женщины бегут к окинавцу с горшками и ножами и принимаются разделывать его с подозрительной сноровкой повара в суси-баре, пластающего тунца.
Одна занята исключительно головой. Внезапно она высоко подпрыгивает и пускается в пляс, размахивая чем-то блестящим. «Улаб! Улаб! Улаб!» — самозабвенно кричит она. Женщины и дети сбегаются посмотреть. Наконец она останавливается и протягивает руку в луч света, пробивающийся сквозь листву. На ладони — золотой зуб.
— Улаб! — повторяют женщины и дети. Один ребенок пытается выхватить зуб, женщина шлепает его по попке. Потом подбегает рослый мужчина с копьем, и женщина вручает трофей ему.
Теперь несколько мужчин собираются поглазеть на добычу.
Женщины возвращаются к окинавцу, и вскоре части его тела уже варятся в горшках на костре.

ВАКСА

Люди, которые верят, что чего-то добились словами, говорят иначе, чем те, для кого разговоры — напрасная трата времени. Всем, что Шафто умеет — чинить машину, свежевать оленя, играть в регби, разговаривать с женщинами, убивать нипов, — он обязан людям второго типа. Для них чего-то добиваться словами — все равно что стучать отверткой по гвоздю. Иногда, когда такой человек слушает собственную речь, у него на лице проступает бессильное отчаяние. Люди первого типа — те, для кого речь орудие труда, уверенные и говорливые, — не обязательно умнее или даже образованнее. Шафто потребовалось определенное время, чтобы это понять.
Так или иначе, все было четко и ясно, пока Бобби Шафто не встретил двух офицеров из подразделения 2702 — Еноха Роота и Лоуренса Притчарда Уотерхауза. Трудно объяснить, что его в них смущает. За недели, проведенные на Йглме, Бобби не раз слышал их разговоры и заподозрил, что есть третья категория людей, настолько редкая, что раньше он с ней не сталкивался.
Офицерам не положено запанибрата общаться с нижними чинами, так что Шафто нелегко продолжать изыскания. Впрочем, иногда обстоятельства перемешивают все звания. Отличный пример — тринидадский трамповый пароходик. Если кто не знает, трамп — это корабль, который доставляет грузы куда придется, а не курсирует между определенными портами.
Где они его раздобыли? — гадает Шафто. Неужто у правительства США стоит где-то в доке пяток тринидадских трамповых пароходиков, просто на всякий пожарный?
Вряд ли. Пароходик явно совсем недавно сменил хозяина. Это кладезь пожелтевшей, истрепанной, мультиэтнической порнографии, частью самой заурядной, частью настолько экзотической, что Шафто поначалу принимает ее за медицинскую литературу. В рубке и некоторых каютах валяются кипы исписанных бумаг. Шафто видит их краем глаза, потому что эти места — вотчина офицеров. Гальюны по-прежнему усеяны черными и курчавыми лобковыми волосами предшественников, провиантский склад набит экзотической карибской едой, которая стремительно портится. В трюме тюки чего-то бурого и жесткого — Шафто предполагает, что это исходный материал для спасательных жилетов.
Всем плевать, потому что бойцы подразделения 2702 последнее время мерзли на Дальнем Севере, а сейчас разгуливают по пояс голые. Короткий перелет, и они на Азорских островах. Здесь их без всяких проволочек, в кромешной ночи, отправили с летного поля на пароход в накрытом брезентом кузове. Однако даже просто теплый воздух, проникающий под брезент, был словно экзотический массаж в тропическом борделе. Как только порт скрылся из виду, их стали выпускать на палубу позагорать.
Для Бобби это случай поболтать с Енохом Роотом — отчасти, просто чтобы поточить лясы, отчасти — в надежде все-таки разобраться с этой третьей категорией людей. Нельзя сказать, что ему сопутствует успех.
— Мне не нравится слово «морфинист», поскольку оно несет в себе определенные коннотации, — говорит Роот, когда они однажды загорают на палубе. — Немцы, чем лепить ярлык, назвали бы тебя Morphiumsuchtig. Глагол suchen означает «искать». Suchtig можно вольно перевести как «искучий» или, еще более вольно, как «ищущий». Я предпочитаю «искучий», поскольку оно передает твою склонность искать морфий.
— Ни хрена не понял, — говорит Шафто.
— Ну, предположим, у тебя стул с подломленной ножкой. Значит, он падучий. Стул падучий всегда, даже если не падает в данный момент. Точно так же «искучий» означает, что ты склонен искать морфий, даже если в данную минуту его не ищешь. Однако я предпочитаю и то, и другое слову «морфинист», поскольку это определения, изменяющие Бобби Шафто, а не существительное, его уничтожающее.
— И к чему это все? — спрашивает Шафто. Он ждет, что Роот отдаст какое-нибудь распоряжение: все говоруны обычно этим заканчивают. Однако никаких распоряжений не следует: капеллану просто охота поговорить про слова.
Шафто практически не общался с Уотерхаузом, но заметил: люди, поговорив с ним, идут прочь, тряся головой — не отрицательно, а судорожно, как собака, которой слепень залетел в среднее ухо. Уотерхауз никогда не отдает прямых распоряжений, поэтому людям второго типа непонятно, как им себя вести. Однако, похоже, людям первой категории не легче. Эти обычно говорят, словно читают по бумажке и отмечают каждый пункт галочкой. Уотерхауз, в отличие от них, хочет не изложить готовые мысли, а по ходу дела наткнуться на что-нибудь интересненькое. И все время как будто ждет, что ты немедленно включишься в процесс. Никто не включается, кроме Еноха Роота.
После нескольких дней в море капитан (кавторанг Иден, тот самый бедолага, которому пришлось таранить Норвегию) выходит из каюты нетвердым шагом, хватаясь за что ни попадя. Заплетающимся языком он объявляет, что по приказу командования на палубе отныне можно появляться только в черных лыжных масках, черных перчатках и черных манишках под остальной одеждой. Все это немедленно выдают. Шафто доводит капитана до белого каления, трижды переспрашивая, точно ли тот понял приказы. Одна из причин, по которой Шафто так уважают рядовые — он умеет задавать подобные вопросы, формально не преступая воинского этикета. Капитан, надо отдать ему должное, не спускает на Шафто собак, а ведет его в каюту и показывает инструкцию в зеленом переплете:

ТАКТИЧЕСКОЕ ПЕРЕОДЕВАНИЕ НЕГРАМИ
ТОМ III
НЕГРЫ В КАРИБСКОМ МОРЕ

Приказ любопытный, даже по меркам подразделения 2702. Смущает и то, что капитан Иден пьян вдребезги, вернее, как он пьян — словно солдат времен войны Севера и Юга, которому полковой лекарь собрался отпилить ногу.
Шафто раздает манишки, перчатки и лыжные маски, приказывает бойцам, чтобы те заткнули хлебало и еще раз отработали шлюпочные учения, а сам находит Роота в импровизированном лазарете. Он чувствует, что пришло время для такого разговора, в котором пытаешься набрести на что-нибудь интересненькое, а если хочешь до чего-нибудь допереть, значит, тебе к Рооту.
— Знаю, вы думаете, я за морфием, — начинает Шафто, — но я просто поговорить.
— Н-да? — отвечает Роот. — Мне надеть капелланскую шляпу?
— Я, бля, протестант. Могу сам поговорить с Богом, когда приспичит.
Роот ошарашен такой внезапной вспышкой враждебности.
— Хорошо, о чем вы хотите поговорить, сержант?
— О нашем задании.
— Я ничего о нем не знаю.
— Ладно, тогда попробуем вычислить.
— Мне казалось, что твое дело — исполнять приказы, — говорит Роот.
— Я исполню.
— Не сомневаюсь.
— А пока у меня до хрена свободного времени, чего бы не разобраться? Капитан велел носить всю эту херню на палубе, где нас могут увидеть. Но какая собака нас здесь увидит.
— Самолет-разведчик?
— Нет здесь у немцев самолетов-разведчиков.
— Другой корабль? — риторически спрашивает Роот, проникаясь духом разговора.
— Мы увидим его в то же самое время и сто раз успеем переодеться.
— Значит, капитана волнуют подводные лодки.
— В яблочко, — говорит Шафто. — С подводной лодки нас можно увидеть в перископ, а мы ничего не заметим.
Однако в тот день им не удается дальше продвинуться в вопросе: зачем командованию надо, чтобы они выглядели неграми в глазах капитана немецкой подводной лодки.

На следующее утро капитан поднимается в рубку с явным намерением бдеть. Он трезвее вчерашнего, но по-прежнему угрюм. На нем яркая гавайка поверх черной рубашки и веревочные сандалии поверх черных носков. Время от времени он надевает черные перчатки, черную лыжную маску и выходит на палубу обозреть горизонт в бинокль.
После восхода солнца пароход еще некоторое время идет на запад, потом ненадолго поворачивает на север, затем с час движется на восток, потом снова на север и опять на запад. Они прочесывают квадрат, и капитану Идену явно не улыбается найти то, что они ищут. Шафто еще раз проводит шлюпочные учения, потом лично проверяет шлюпки и убеждается, что там есть все необходимые припасы.
Около полудня наблюдатель подает голос. Корабль меняет курс и движется теперь примерно на северо-восток. Капитан выходит из рубки и с видом предсмертной обреченности вручает Шафто ящик темно-коричневого сапожного крема и запечатанный пакет с подробными приказами.
Через несколько минут бойцы подразделения 2702 по приказу сержанта Шафто раздеваются до трусов и начинаются мазаться сапожным кремом. У них уже есть вакса, которую приказано втереть в волосы, если те недостаточно черные. Очередной пример того, как военное начальство обходится с маленьким человеком — за ваксу, между прочим, свои деньги плочены.
— Похож я на негра? — спрашивает Шафто Роота.
— Я немного путешествовал, — отвечает Роот, — и, на мой взгляд, ни капельки не похож. Однако для немца, который ни разу в жизни не видел настоящего чернокожего, к тому же в перископ, — чего бы нет? — Потом: — Как я понимаю, ты вычислил задание?
— Приказы, бля, прочел, — осторожно отвечает Шафто.
Они направляются к какому-то кораблю. Когда подходят ближе. Шафто одалживает подзорную трубу и вздрагивает, но не то чтобы очень удивляется, увидев, что кораблей на самом деле два и стоят они борт к борту. У обоих роковые обводы подводных лодок, но один потолще, и Шафто соображает, что это «корова».
Под ногами двигатели переходят на холостой ход. Внезапная тишина и сброс скорости не умиротворяют. Шафто испытывает обычное муторное, беспокойное, сосущее чувство, которое так электризует в бою.

Потрепанный тринидадский пароходик всю войну без особых приключений бороздил себе воды Атлантического океана, мотался между африканскими и карибскими портами, доходя иногда даже до Азор. Может быть, его время от времени замечали патрульные немецкие подлодки и жалели потратить торпеду. Однако сегодня ему крупно не повезло. Он по чистой случайности наткнулся на немецкую «корову» — подлодку снабжения кригс-марине Третьего рейха. Пестрая команда черных, как гуталин, негров столпилась у борта и пялится на странное зрелище: два сцепленных корабля посреди океана. Однако, подойдя ближе, они осознают, что один из кораблей — убийца, а второй несет флаг немецкого ВМФ.
Наступает минутное замешательство — для тупых негров на палубе это, может, и занятное зрелище, но умные негры в рубке поняли, что попали в беду — увидели то, что им видеть не полагалось. Они разворачивают пароходик и дают деру! Час они чешут на всех парах, однако подводная лодка неумолимо преследует их, рассекая воду, как финский нож. Штыревая антенна над рубкой следит за обычными частотами и слышит, как пароходик передает сигнал SOS. В коротком потоке точек и тире он сообщает координаты — свои и «коровы» — и тем подписывает себе смертный приговор.
Чертовы недочеловеки! Что натворили! В двадцать четыре часа «корову» засекут и потопят англичане, и с большой степенью вероятности попутно уничтожат несколько подлодок. Гадкая смерть, когда тебя несколько дней гоняют по океану, бомбя и обстреливая с воздуха. Вот когда до рядового оберторпедомаата доходит непостижимая мудрость фюрера, решившего найти и уничтожить всех, кто не родился немцем.
Тем временем наш средний капитан-лейтенант должен задавать себе вопрос: какова, черт возьми, вероятность, что трамповый тринидадский пароходик случайно наткнулся на нас и нашу «корову» посреди необъятного Атлантического океана?
Наверное, это можно рассчитать, имея нужные данные:
Nn = число негров на квадратный километр,
Nm = число «коров»,
AA = площадь Атлантического океана,
и так далее. Но погодите! Негры и «коровы» распределены неравномерно, и это осложняет вычисления. Слишком мудрено для капитан-лейтенанта, особенно если его мысли заняты тем, как резко уменьшить Nn.
Выстрелом из палубного орудия поперек курса лодка останавливает пароходик. Негры собрались на палубе, но медлят спускать шлюпки. Может, думают, что немцы этим ограничатся.
Сентиментальная глупость, типичная для недочеловеков! Немцы остановили их, чтобы легче было торпедировать пароход. Как только негры это понимают, они проводят впечатляющие шлюпочные учения. Удивительно уже то, что шлюпок хватает на всех, но сноровка, с которой их спускают на воду, просто феноменальна. Тут на секунду усомнишься в тупости черномазых.
Торпедирование — как в учебнике! Торпеда запускается на глубину. Когда она проходит под пароходиком, взрыватель чувствует изменение магнитного поля и приводит в действие заряд. Взрыв аккуратно срезает киль, переламывает кораблю хребет и отправляет его ко дну с невероятной скоростью. В следующие десять-пятнадцать минут из воды выпрыгивают тюки с чем-то бурым, придавая всей сцене неожиданно праздничный вид.
Иные командиры подлодок не побрезговали бы перестрелять уцелевших из пулемета, просто чтобы отвести душу.
Однако командир подлодки капитан-лейтенант Гюнтер Бишоф пока не член нацистской партии и, вероятно, никогда им не будет. С другой стороны, Бишоф в смирительной рубашке и накачан лекарствами до полубессознательного состояния.
Обязанности командира подводной лодки исполняет оберлейтенант-цур-зее Карл Бек. Он-то как раз член национал-социалистической партии, так что в других обстоятельствах не отказался бы в отместку пустить пару очередей. Увы, сейчас Карл Бек смертельно устал и очень встревожен. Он понимает, что вряд ли долго проживет после того, как их координаты сообщили в эфир. Поэтому не отдает приказа стрелять.
Негры выпрыгивают из шлюпок, плывут к тюкам и цепляются так, чтобы из воды торчали одни головы. Соображают, гады, что теперь их за сто лет не перестреляешь. Оберлейтенанту Беку известно, что сюда уже летят «каталины» и «либерейторы». Надо быстрее сматывать. Горючего достаточно, и он решает идти на юг, а дня через два, когда все успокоится, повернуть обратно на север. Так поступил бы капитан-лейтенант Бишоф, если бы не повредился в уме, а все на подлодке безгранично чтят командира.
Они идут в надводном положении, как всегда, когда не собираются прямо в данную секунду топить конвой. Так лодка может принимать и отправлять радиограммы. Бек составляет отчет о случившемся, вручает оберфункмаату Гуфферу, который передает его одному из функмаатов, тот садится перед «Энигмой», шифрует сообщение, используя ключ дня, а потом выстукивает по рации. Через час приходит ответная радиограмма непосредственно из штаба подводного флота в Вильгельмсхафене. Функмаат, пропустив ее через «Энигму», получает: «ЗАХВАТИТЬ УЦЕЛЕВШИХ ОФИЦЕРОВ».
Классический пример флотоводческого искусства: приди приказ раньше, его было бы крайне легко исполнить, но теперь, когда они в часе хода от потопленного корабля, это очень опасно и трудно. Приказ производит впечатление полного абсурда, и не сделано ни малейшей попытки его прояснить.
Поскольку время все равно упущено, Бек решает обойтись соблюдением проформы. По-хорошему надо развернуться и двигаться в надводном положении, что много быстрее, но граничит с самоубийством. Поэтому он приказывает задраить люки и погрузиться на перископную глубину. Теперь лодка ползет со скоростью семь узлов, и проходит три часа, прежде чем они возвращаются к атоллу из прыгающих бурых тюков.
Как оказывается, предосторожность была не лишней, потому что на месте другая подлодка забирает потерпевших. Британская. Это такая дикость, что волосы на загривке у Бека встают дыбом — волос там много, потому что Бек, как большинство подводников, не бреется неделями. Впрочем, нет такой нелепости, с которой не разобралась бы одна хорошо нацеленная торпеда. Через несколько минут субмарина взрывается, как бомба, — видимо, торпеда попала в погреб боеприпасов. Команда и большинство спасенных негров закупорены внутри — они не выберутся, даже если уцелели при взрыве. Субмарина рушится вниз, как останки «Гинденбурга» на Нью-Джерси.
— Gott in Himmel* [Боже на небесах (нем.).], — бормочет Бек, наблюдая все это в перископ, — и радуется успеху, пока не вспоминает, что получил конкретный приказ, где предписывалось вовсе не уничтожить все в поле зрения. Будет ли кого подбирать?
Он приказывает всплыть и вместе с офицерами идет в боевую рубку. Первым делом они убеждаются, что в небе нет «каталин», потом выставляют наблюдателей и медленно идут через море тюков, которые разметало по меньшей мере на квадратный километр. Темнеет, приходится включить прожекторы.
Занятие кажется достаточно безнадежным, пока луч прожектора не освещает уцелевшего — из воды торчат только голова, плечи и две руки, вцепившиеся в обвязку тюка. Человек не шевелится и никак не реагирует на приближение лодки; только когда волна опрокидывает тюк, становится видно, что все ниже солнечного сплетения отъедено акулами. Зрелище вызывает тошноту даже у команды заматерелых убийц. В наступившей тишине издали доносятся приглушенные голоса. После недолгих поисков удается найти двоих, явно разговорчивых негров. Оба цепляются за один тюк.
Когда луч прожектора выхватывает их из темноты, один негр выпускает тюк и ныряет под воду. Другой спокойно и выжидательно смотрит на свет. Глаза у негра светлые, почти бесцветные, и вдобавок у него какая-то кожная болезнь — местами он совсем белый.
Когда подлодка приближается, светлоглазый негр обращается к офицерам на безупречном немецком.
— Мой товарищ пытается утопиться, — говорит он.
— Это возможно? — спрашивает оберлейтенант-цур-зее Бек.
— Мы с ним только что обсуждали этот самый вопрос.
Бек смотрит на часы.
— Видимо, он и впрямь сильно хочет покончить с собой.
— Сержант Шафто очень серьезно относится к своему долгу. В некотором роде ирония судьбы. Его ампула с цианидом растворилась в морской воде.
— Боюсь, вся эта ирония меня утомила, — говорит Бек. Над водой всплывает тело. Это Шафто; он, по всей видимости, без сознания.
— Кто вы? — спрашивает Бек.
— Лейтенант Енох Роот.
— Мне приказано брать только офицеров. — Бек холодно глядит на спину сержанта Шафто.
— У сержанта Шафто исключительно широкие обязанности, — спокойно говорит лейтенант Роот. — В некоторых отношениях поважнее, чем у младших офицеров.
— Вытащите обоих. Принесите аптечку. Откачайте сержанта, — приказывает Бек. — Я поговорю с вами позже, лейтенант Роот. — Потом поворачивается спиной к пленным и направляется к ближайшему люку. Он собирается в следующие несколько дней побороться за свою жизнь против ВМФ США и Британии. Интересная задачка. Надо продумывать стратегию, но из головы не идет спина сержанта Шафто. Он ведь так и держал голову под водой! Если б его не вытащили, он бы, наверное, и впрямь утопился. Значит, такое все же возможно.

НАПАДЕНИЕ

К стоянке перед строительным участком Министерства информации продолжают подъезжать микроавтобусы, такси и лимузины. Эпифитовцев встречают, улыбаясь и кланяясь, юные японские девы с касками «Гото инжиниринг» в руках и на голове. Времени примерно восемь утра, здесь в горах еще не мучительно жарко, хотя и влажно. Все толкутся у входа в пещеру, держа каски в руках — никому не хочется первому надевать свою, чтобы не выглядеть идиотом. Японские сотрудники помоложе самозабвенно фотографируются с касками в руках. Доктор Мохаммед Прагасу переходит от одной группы к другой, рассеянно крутя на пальце вполне-таки настоящую потертую каску.
— Кто-нибудь просто спросил Прага, что за херня тут происходит? — интересуется Эб. Он редко ругается по-английски, а когда ругается, это звучит смешно.
Из всех эпифитовцев не улыбается только Кантрелл. Со вчерашнего дня он мрачен и погружен в себя. («Одно дело написать диссертацию про математические методы в криптографии, — сказал он по пути сюда на вопрос о том, что его тревожит, — а совсем другое — рисковать деньгами других людей на миллиарды долларов».
— Нам нужна новая категория, — заметил Рэнди. — Деньги других, нехороших людей.
— Кстати, — начал Том, но Ави оборвал его, выразительно глянув в затылок водителю.)

Кому: dwarf@siblings.net
От: root@eruditorum.org
Тема: Re (3): Зачем?
Рэнди,
Вы попросили меня оправдать мой интерес к созданию Крипты.
Мой интерес — признак моего рода занятий, то есть в некотором смысле того, чем я зарабатываю на жизнь.
Вы по-прежнему считаете меня кем-то из своих знакомых. Сегодня я у Вас Дантист, вчера был Эндрю Лоубом. Эта игра в отгадки скоро нас обоих утомит. Пожалуйста, поверьте на слово, что мы никогда не встречались.

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т. д.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

Кому: root@eruditorum.org
От: dwarf@siblings.net
Тема: Re (4): Зачем?
Черт, после того как Вы сказали, что зарабатываете этим на жизнь, я было подумал, что Вы — Геб или кто-то еще из друзей моей бывшей девушки.
Почему бы просто не назваться?

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т. д.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

Кому: dwarf@siblings.net
От: root@eruditorum.org
Тема: Re (5): Зачем?
Рэнди,
Я уже назвался, но мое имя ничего Вам не говорит, вернее, говорит совсем не то. Именам это свойственно. Лучший способ кого-то узнать — вступить с ним в разговор.
Занятно, что Вы сочли меня ученым.

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т. д.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

Кому: root@eruditorum.org
От: dwarf@siblings.net
Тема: Re (6): Зачем?
Поймал!
Я не писал, кто такой Геб. Однако Вы знаете, что друзья моей бывшей девушки — ученые. Если (как Вы утверждаете) мы не знакомы, то откуда Вам все это известно?

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т. д.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

Все поворачиваются к Прагу, у которого, похоже, сегодня проблемы с периферическим зрением.
— Праг нас избегает, — резко говорит Ави. — Это значит, что он будет абсолютно недоступен, пока все не кончится.
Том делает шаг к Ави, теснее стягивая корпоративный кружок.
— Есть что-нибудь из Гонконга?
— Некоторых опознали, другими занимаются, — говорит Ави. — Толстый филиппинский господин — казначей Маркоса. Именно он спрятал от филиппинского правительства пресловутые миллиарды. Тайванец — не Гарвард Ли, а другой — адвокат. У его семьи давние связи с Японией, еще с тех пор, как Тайвань входил в их империю. Он занимал различные правительственные посты, главным образом связанные с финансами и торговлей, а сейчас что-то вроде посредника при различных высокопоставленных тайваньских чиновниках.
— А китаец со шрамами?
Ави поднимает брови и тихонько вздыхает, прежде чем ответить.
— Генерал в Народно-освободительной армии. Последние пятнадцать лет возглавляет ее инвестиционное направление.
— Инвестиционное? В армии?! — взрывается Кантрелл. С каждой секундой он выглядит все более кисло.
— Народно-освободительная армия — исполинская деловая империя, — объясняет Берил. — Ей принадлежит крупнейшая фармацевтическая компания в Китае. Самая большая гостиничная сеть. Многие коммуникации. Железные дороги. Нефтеперегонные заводы. И, само собой, вооружение.
— Как насчет мистера Мобилы? — спрашивает Рэнди.
— Выясняют. Мой человек в Гонконге послал его фото коллеге в Панаму.
— Думаю, после того, что мы видели сегодня утром в холле, можно сделать кое-какие предположения, — говорит Берил*. [Полчаса назад, когда эпифитовцы встречались в холле, подкатил большой черный «мерс», прямо из аэропорта. «Боинги-747» садятся в Кинакуте четыре раза в сутки, и по времени, когда человек появляется у регистрационной стойки отеля, можно определить, из какого он города. Эти ребята прилетели из Лос-Анджелеса. Три латиноамериканца: один пожилой, важный, с ним молодой помощник и громила. В холле их встретил человек, который вчера на встрече говорил по мобильному.]

Кому: dwarf@siblings.net
От: root@eruditorum.org
Тема: Re (7): Зачем?
Рэнди,
Вы спросили, откуда я все про Вас знаю. Я много что мог бы по этому поводу сказать, но основной ответ: разведка.

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т. д.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

Рэнди решает, что лучшего времени задать вопрос не будет. Он дольше всех знаком с Ави, ему и спрашивать.
— Мы и впрямь хотим связываться с ними? Такова цель корпорации «Эпифит»?
Ави глубоко вздыхает, прежде чем ответить. Берил смотрит на него испытующе. Эб, Джон и Том изучают свои ботинки или высматривают в трехъярусных джунглях экзотических птиц.
— Знаете, во времена золотой лихорадки на каждом прииске в Калифорнии был умник с весами, — говорит Ави. — Пробирщик. Он целыми днями сидел в конторе. К нему приходили бандитские рожи, приносили мешочки золотого песка. Умник взвешивал золото, определял пробу и говорил, сколько оно стоит. Сойдя с весов, минерал, сор из земли, становился деньгами, которые принимают в любом банке, в любой лавке от Сан-Франциско до Лондона и Пекина. Благодаря специфическим знаниям умник ставил на сор свою санкцию и превращал его в деньги, точно так же мы имеем власть делать биты деньгами.
Так вот, умнику приходилось иметь дело с людьми худшего сорта. Алкашами. Беглыми преступниками. Психами, которые чуть что, начинали палить. Рабовладельцами. Теми, кто истреблял индейцев. Убежден, что в первый день, или неделю, или месяц, или год у него поджилки тряслись от страха. Вероятно, он мучился и моральными сомнениями — вполне оправданными. — Ави искоса смотрит на Рэнди. — Некоторые из умников бросали все и возвращались домой. Но знаете что? За исключительно короткое время все цивилизовалось, в городах появились церкви, школы и университеты, бандюки из числа первопроходцев ассимилировались или угодили за решетку, а именами умников теперь называются бульвары и оперные театры. Аналогия ясна?

Предыдущая страница 18 Следующая страница


19 Нил Стивенсон

— Ясна. — Том Говард напуган меньше всех, но он вообще человек другой — например, коллекционирует редкое автоматическое оружие.
Остальные молчат. Задавать неприятные вопросы — обязанность Рэнди.
— И скольких таких пробирщиков застрелили на улице недовольные клиенты? — спрашивает он.
— У меня нет цифр, — отвечает Ави.
— Я не совсем уверен, что мне это по-настоящему нужно, — говорит Рэнди.
— Все мы должны решить для себя этот вопрос, — произносит Ави.
— И потом проголосовать корпоративно, продолжать или отыграть назад? — спрашивает Рэнди.
Ави и Берил выразительно переглядываются.
— Отыграть назад на этой стадии будет... э-э... затруднительно, — говорит Берил, потом, видя физиономию Рэнди, поспешно добавляет: — Не для отдельных участников, которые захотят покинуть «Эпифит». Это легко. Никаких проблем. Но для «Эпифита» выйти из этой... э-э...
— Ситуации, — подсказывает Кантрелл.
— Дилеммы, — говорит Рэнди.
Эб бормочет какое-то слово на немецком.
— Возможности, — упорствует Ави.
— ...будет практически нереально, — заключает Берил.
— Послушайте, — говорит Ави. — Я не хочу, чтобы кто-то считал себя обязанным оставаться с нами в ситуации, которая смущает его морально.
— Или пугает угрозой скорой и неминуемой расправы, — подкидывает от щедрот Рэнди.
— Верно. Мы все вложили в дело чертову уйму труда, который чего-то, да стоит. Для полной ясности давайте повторю то, что записано в уставных документах: каждый может выйти из компании, мы купим его пай. После того что случилось за эти два дня, я уверен: денег мы наберем. Вы получили по меньшей мере столько же, сколько в Америке, работая за нормальную зарплату.
Молодые, менее опытные хайтечные предприниматели только бы фыркнули. Однако на эту команду произвело большое впечатление, что Ави сумел создать компанию и удержать ее на плаву хотя бы такое время, чтобы окупилась сделанная работа.
Подъезжает черный «мерс». Доктор Мохаммед Прагасу приветствует латиноамериканцев на вполне приличном испанском, с кем-то их знакомит. Разрозненные кучки бизнесменов начинают стягиваться ко входу в пещеру. Праг считает по головам, проверяет посещаемость.
Одна из помощниц Дантиста, в лиловых «лодочках» и с прижатым к уху мобильником, пробирается через толпу к Прагу. Рэнди откалывается от эпифитовцев и берет курс на столкновение. Он успевает расслышать, как девица говорит Прагу: «Доктор Кеплер присоединится к нам позже — спешное дело в Калифорнии. Он приносит свои извинения».
Доктор Прагасу бодро кивает, ухитряясь не взглянуть в глаза Рэнди (который стоит так близко, что мог бы почистить ему зубы), и, повернувшись, надевает каску.
— Пожалуйста, все за мной, — говорит Праг. — Экскурсия начинается.
Экскурсия скучна даже для тех, кто здесь впервые. Всякий раз, как Праг приводит их на новое место, все начинают озираться, пытаясь сориентироваться, разговор на десять-пятнадцать секунд затихает, потом возобновляется; большие люди тупо таращатся на каменные стены и переговариваются между собой, пока их консультанты пытают инженеров «Гото» умными вопросами.
Все строители из «Гото инжиниринг» и соответственно японцы. Еще один стоит особняком.
— Кто этот полный блондин? — спрашивает Рэнди у Тома Говарда.
— Немецкий строитель, которого пригласил Гото. Вроде бы занимается военной стороной.
— А есть военная сторона?
— Где-то на середине проекта Праг вдруг решил, что вся эта штука должна иметь защиту от бомб.
— Ничего себе. Случаем, не от ядерных?
— Думаю, сейчас он это объяснит, — произносит Том, подводя Рэнди ближе.
Кто-то только что спросил немецкого строителя, предусмотрена ли защита от ядерного взрыва.
— Суть в другом, — отмахивает тот. — Защитить от ядерного взрыва легко — конструкция должна всего лишь выдержать давление во столько-то мегапаскалей в течение короткого времени. Половина саддамовых бункеров была технически рассчитана на ядерное поражение. Однако, как доказали американцы, это не спасает от проникающих снарядов точного наведения. Вероятность их использования выше, чем вероятность ядерного удара — участие султана в ядерном конфликте пока не предполагается.
Это самое смешное из всего, что сказано за сегодняшний день. Раздаются смешки.
— По счастью, — продолжает немец, — скала над нами гораздо прочнее, чем железобетон. Мы не знаем проникающих снарядов, которые могли бы ее пробить.
— Как насчет научно-практических изысканий, которые американцы провели в Ливии? — спрашивает Рэнди.
— А, вы про нефтеперегонный завод? — неуверенно произносит немец.
Рэнди кивает.
— Там такая хрупкая порода, что ее можно разбить молотком, — говорит немец. — Здесь мы имеем дело с совершенно другой породой.
Рэнди переглядывается с Ави, у которого на лице написано «Молодец!», и уже собирается ухмыльнуться, но тут ловит на себе чей-то взгляд. Он оборачивается и встречается глазами с доктором Прагасу. У министра информации непроницаемое выражение лица, близкое к оскорбленному. Многие люди в этой части мира съежились бы под взглядом доктора Мохаммеда Прагасу, но для Рэнди он просто свой брат-компьютерщик.
Поэтому он смотрит прямо в глаза Прагу и ухмыляется.
Праг готов пригвоздить его взглядом. Засранец, ты подловил моего немца, за это ты умрешь! Однако убийственный взгляд не удается. Праг отводит глаза, отворачивается и подносит руку ко рту, как будто гладит бородку. Вирус иронии распространен в Калифорнии, как герпес, и, проникнув в мозг, остается там навсегда. Люди вроде Прага могут вернуться домой, сбросить кроссовки и молиться на Мекку пять раз в день, но бессильны истребить в себе эту заразу.
Экскурсия длится еще часа два. За время, что они были внутри, температура снаружи увеличилась вдвое. Едва они выходят из-под экранирующих сводов, разом начинают звонить десятка два сотовых и пейджеров. Ави с кем-то коротко и отрывисто говорит, потом дает отбой и собирает эпифитовцев к машине.
— Маленькая перемена в планах, — говорит он. — Надо обсудить одно дело, — и называет водителю какое-то незнакомое слово.
Через двадцать минут они гуськом входят на японское кладбище, зажатые между двумя потоками скорбных престарелых туристов.
— Любопытное место для собрания акционеров, — говорит Эберхард Фёр.
— Учитывая, с кем мы имеем дело, и допуская, что все наши номера, машины и ресторан в отеле прослушиваются...
Все замолкают. Ави ведет их по гравийной дорожке в укромный уголок сада.
Останавливаются в углу высокой каменной стены. Бамбуковая роща отделяет его от остального сада. Ветер умиротворяюще шелестит листьями, но практически не охлаждает потные лица. Берил обмахивается картой Кинакуты.
— Только что позвонила Энни-из-Сан-Франциско, — говорит Ави.
Энни-из-Сан-Франциско — их адвокат.
— Там сейчас... семь вечера. Перед концом рабочего дня к ней в офис вошел курьер, только что из Лос-Анджелеса, и вручил письмо из конторы Дантиста.
— Он подает на нас в суд, — говорит Берил.
— Он вот настолько от того, чтобы подать на нас в суд.
— За что?! — кричит Том Говард.
Ави вздыхает.
— В определенном смысле, Том, это не важно. Когда Кеплер считает, что в его интересах подать тактический иск, он находит предлог. Нельзя забывать, что речь не о правовых вопросах, а о тактике.
— Нарушение контракта? — предполагает Рэнди.
Все смотрят на него.
— Ты что-то знаешь, чего не знаем мы? — спрашивает Джон Кантрелл.
— Просто предположил, — мотает головой Рэнди. — В контракте сказано, что мы должны информировать его обо всех изменениях в ситуации, которые могут серьезно отразиться на деловом климате.
— Ужасно расплывчатая формулировка, — укоряет Берил.
— Я перефразирую.
— Рэнди прав, — вставляет Ави. — Суть иска в том, что должны были сообщить Дантисту о кинакутских делах.
— Но мы же не знали! — возмущается Эб.
— Не важно. Помните, что иск — тактический.
— Чего он хочет?
— Напугать нас, — говорит Ави. — Завтра или послезавтра он пришлет другого адвоката в роли доброго следователя, и тот сделает нам предложение.
— Какое? — спрашивает Том.
— Думаю, Кеплер хочет оттяпать от нас кусок. Ему нужна доля в нашей компании.
Все светлеют, кроме самого Ави: он почти все время сохраняет маску холодной сдержанности.
— Так что это плохая новость, хорошая новость, плохая новость. Плохая новость номер один: звонок Энн. Хорошая новость: после того, что случилось в последние два дня, «Эпифит» стал таким лакомым кусочком, что Кеплер готов драться за наши акции.
— В чем вторая плохая новость? — спрашивает Рэнди.
— Очень просто. — Ави на секунду отворачивается, проходит несколько шагов, пока не упирается в каменную скамью, потом снова оборачивается к остальным. — Утром я сказал, что сейчас «Эпифит» стоит достаточно, чтобы выкупить ваши доли за приличные деньги. Вы, вероятно, сочли это хорошей новостью. В определенном смысле так оно и есть. Однако маленькая и ценная компания в мире бизнеса — это яркая красивая птичка в джунглях, весело распевающая на ветке, так что слышно за много миль. Она привлекает питонов. — Ави на мгновение замолкает. — Обычно льготный период дольше. Вы набираете цену, но у вас есть время — недели или месяцы, — чтобы занять оборонительную позицию, пока питон еще не обвился вокруг ствола. В этот раз мы набрали цену, сидя практически над питоном. Мы уже ничего не стоим.
— Как это? — не понимает Эб. — Мы стоим ровно столько же, сколько сегодня утром.
— Маленькая компания, которой Дантист вчинил иск на прорву денег, совершенно точно ничего не стоит. Вероятно, у нее огромная отрицательная стоимость. Единственный способ снова перейти в плюс — предотвратить иск. Как видите, у Кеплера все козыри. После того, как блестяще Том вчера выступил, остальные участники встречи наверняка зарятся на нас не меньше Дантиста. Однако у него преимущество: он уже ведет с нами дела. Это дает ему предлог для иска.
— Так что, надеюсь, вы приятно провели утро на солнышке, хотя большая его часть прошла в пещере, — заключает Ави. Потом смотрит на Рэнди и скорбно понижает голос: — А если кто из вас хочет забрать свою долю, берите пример с Дантиста. Решайтесь и действуйте быстро.

ФУНКШПИЛЬ

Его будит адъютант полковника Чаттана. Первое, что Уотерхауз замечает, проснувшись: адъютант дышит часто и ровно, как Алан после пробежки.
— Полковник Чаттан просит как можно скорее прибыть в усадьбу.
Уотерхауза разместили в пяти минутах ходьбы от усадьбы Блетчли-парка. Быстрым шагом, на ходу застегивая рубашку, он преодолевает это расстояние за четыре. В двадцати шагах от цели его чуть не переезжает вереница «роллс-ройсов», скользящих в ночи тихо и бесшумно, как немецкие подводные лодки. Один автомобиль проносится так близко, что Уотерхауза обдает жаром двигателя; выхлопные газы забираются под штанину и конденсируются на коже.
Из «роллс-ройсов» вылезают министерские старперы и заходят в усадьбу. В библиотеке они подобострастно собираются вокруг телефона, который часто звонит, а когда снимают трубку, издает отрывистый металлический шум, который можно слышать по всей комнате, но нельзя разобрать. Уотерхауз прикидывает, что «роллс-ройсы» должны были мчаться из Лондона со скоростью примерно девяносто миль в час.
Прилизанные молодые люди в военной форме тащат из других комнат столы и протискивают их в библиотеку, сдирая краску с дверных косяков. Уотерхауз садится на произвольный стул за произвольным столом. Другой адъютант ввозит на тележке проволочные корзины. Папки в корзинах еще дымятся от стремительности, с какой их выдернули из бесконечных архивов Блетчли-парка. Будь это обычное заседание, документы бы заранее размножили на мимеографе и раздали каждому в отдельности. Однако все делается в слепой панике. Уотерхауз инстинктивно чувствует, что должен воспользоваться своим ранним приходом, если хочет хоть что-нибудь узнать. Он вытаскивает из тележки нижнюю папку, сочтя, что самое нужное снимали с полок в первую очередь. На папке написано: «U-691».
Первые страницы — просто формуляр, занесенные в таблицу данные подводной лодки. Половина граф пусты. Остальные заполнены разным почерком в разное время, со множеством подчисток, исправлений и добавлений на полях.
Дальше журнал, куда в хронологическом порядке занесено все, что известно про U-691. Первая запись — спуск на воду в Вильгельмсхафене 19 сентября 1940 года, далее список уничтоженных ею судов. Несколько месяцев назад внесена непонятная запись: «ОБОРУДОВАНА ЭКСПЕРИМЕНТАЛЬНЫМ УСТРОЙСТВОМ (ШНОРХЕЛЬ?)». После этого U-691 словно с цепи сорвалась: топила корабли в Чезапикском заливе, Маракайбо, на подходах к Панамскому каналу и еще в нескольких местах, которые Уотерхауз до сих пор знал лишь как зимние курорты для богатых людей.
Заходят и садятся еще двое: полковник Чаттан и молодой человек в помятом смокинге. По комнате тут же разносится слух, что это ударник из симфонического оркестра. Он явно старался стереть с лица губную помаду, но за левым ухом еще осталось. Таковы издержки военного времени.
Вбегает еще один адъютант с расшифровками «УЛЬТРА». Эти выглядят поинтереснее; Уотерхауз откладывает папку и принимается перебирать листки.
Каждый начинается с указания станции перехвата, времени, частоты и прочих мелких подробностей. Вся кипа сводится к разговору между двумя радиопередатчиками, растянувшемуся на несколько последних недель.
Один находится в берлинском районе под названием Шарлоттенбург, на крыше отеля в Штайнпляце, где временно расположилось командование подводного флота, недавно переведенное из Парижа. Большая часть радиограмм подписана гроссадмиралом Карлом Деницем. Уотерхауз знает, что Дениц недавно назначен Верховным главнокомандующим всего немецкого флота, но сохранил за собой звание главнокомандующего подводным флотом. У Деница слабость к подводным лодкам и тем, кто на них плавает.
Другие радиограммы переданы с той самой U-691. Они подписаны командиром, капитан-лейтенантом Гюнтером Бишофом.
Бишоф: Потопил очередное торговое судно. Эти их чертовы радары повсюду.
Дениц: Сообщение получено. Молодец.
Бишоф: Потопил еще танкер. Эти гады каким-то образом точно знают, где я. Слава богу, что есть шнорхель.
Дениц: Сообщение получено. Как всегда, выше всяких похвал.
Бишоф: Потопил торговое судно. Меня дожидались самолеты. Сбил один: он рухнул на нас и сжег троих моих матросов. Вы уверены, что «Энигма» и впрямь надежна?
Дениц: Молодцом, Бишоф! Вам еще медаль! Не волнуйтесь из-за «Энигмы», она — блеск.
Бишоф: Атаковал конвой, потопил три торговых судна, танкер и эсминец.
Дениц: Превосходно! Вам еще медаль!
Бишоф: Просто ради азарта вернулся и уничтожил то, что оставалось от конвоя. Тут появился эсминец и три дня бросал на нас глубинные бомбы. Мы полумертвые, сидим в собственном дерьме, как крысы, которые провалились в нужник и медленно тонут. Мозги гниют от вдыхания нашей собственной двуокиси углерода.
Дениц: Вы — герой рейха! Самому фюреру сообщили о Ваших блестящих успехах! Не будете ли так добры направиться на юг и потопить конвой на таких-то координатах? P.S. Пожалуйста, сократите длину радиограмм.
Бишоф: Вообще-то я не отказался бы от отпуска, но разумеется, о чем речь.
Бишоф (неделю спустя): Потопил Вам половину конвоя. Пришлось всплыть и обстрелять чертов эсминец из палубного орудия. Они не ожидали от нас такого самоубийственного маневра, в результате мы разнесли их на куски. Пора в отпуск.
Дениц: Вы теперь официально величайший командир-подводник всех времен. Возвращайтесь в Лорьян для заслуженного отдыха.
Бишоф: Вообще-то я собирался отдохнуть в Карибском море. В Лорьяне в это время года холодно и сыро.
Дениц: От Вас нет сообщений уже два дня. Пожалуйста, выйдите на связь.
Бишоф: Нашел прелестную укромную бухточку с белым песчаным пляжем. Предпочитаю не сообщать координаты, поскольку больше не верю в «Энигму». Рыбалка отличная. Загораю. Чувствую себя немного лучше. Команда весьма признательна.
Дениц: Гюнтер, я многое готов Вам спустить, но даже Верховный главнокомандующий должен отвечать за своих подчиненных. Пожалуйста, бросьте дурить и возвращайтесь.
U-691: Оберлейтенант-цур-зее Карл Бек, зам. командира U-691. С прискорбием сообщаю, что капитан-лейтенант Бишоф нездоров. Испрашиваю приказы. P.S. Он не знает, что я посылаю эту радиограмму.
Дениц: Примите командование. Возвращайтесь, но не в Лорьян, а в Вильгельмсхафен. Позаботьтесь о Гюнтере.
Бек: Капитан-лейтенант Бишоф отказывается сдавать командование.
Дениц: Введите ему снотворное и доставьте сюда, его не накажут.
Бек: Спасибо от меня и от команды. Мы на ходу, но горючего мало.
Дениц: Рандеву с U-414 [«корова»] на таких-то координатах.
В комнату заходят еще люди: дряхлый раввин, доктор Алан Матисон Тьюринг, крупный мужчина в твидовом пиджаке, которого Уотерхауз смутно помнит как оксфордского дона, и несколько человек из флотской разведки, вечно околачивающихся в четвертом корпусе. Чаттан призывает собрание к порядку и представляет одного из молодых людей. Тот встает и докладывает ситуацию:
— U-691, подводная лодка класса IXD/42 под номинальным командованием капитан-лейтенанта Гюнтера Бишофа, и. о. командира оберлейтенант-цур-зее Карл Бек, в 20.00 по Гринвичу послала радиограмму командованию подводного флота. В радиограмме сообщается, что через три часа после уничтожения тринидадского торгового корабля U-691 торпедировала и потопила британскую субмарину, которая забирала потерпевших. Бек взял в плен двух наших людей: сержанта МПФ Роберта Шафто, американца, и лейтенанта Еноха Роота, из АНЗАК.
— Как много эти люди знают? — спрашивает дон. Видно, что он изо всех сил пытается протрезветь.
Чаттан отвечает:
— Если Роот и Шафто расскажут все, что знают, немцы смогут сделать вывод, что мы прилагаем значительные усилия к сокрытию исключительно ценного источника разведданных.
— О дьявол, — бормочет дон.
Торопливо входит исключительно тощий и долговязый блондин в штатском — редактор отдела кроссвордов в одной из лондонских газет, а ныне — сотрудник Блетчли-парка. Теперь в комнате присутствуют больше половины людей из списка «Ультра-Мега».
Молодой аналитик продолжает:
— В 21.00 Вильгельмсхафен ответил радиограммой, в которой приказывалось немедленно допросить пленных. В 1.50 Бек сообщил, что, по его мнению, пленные принадлежат к некоему особому подразделению флотской разведки.
Пока он говорит, сидящим раздают только что отпечатанные машинописные экземпляры свежих расшифровок. Редактор отдела кроссвордов изучает листки, сильно наморщив лоб.
— Простите, может быть, об этом говорили до моего прихода — произносит он, — но откуда вообще в этой истории взялось тринидадское торговое судно?
Чаттан взглядом затыкает Уотерхаузу рот и отвечает:
— Не скажу. — (Все смеются, как будто он только что удачно сострил на светском рауте.) — Однако адмирал Дениц, читая радиограммы, вероятно, тоже пребывает в недоумении. Мы бы предпочли, чтобы в этом состоянии он и остался.
— Дано: Первое, он знает, что потоплено торговое судно, — подает голос Тьюринг и загибает палец. — Второе: он знает, что несколько часов спустя там же оказалась британская субмарина, и она тоже потоплена. Три: он знает, что из воды вытащили двух наших людей и что они, вероятно, относятся к разведке. На мой взгляд, это довольно широкая категория. Однако из этих двух кратких сообщений он не сможет вывести, с какого из кораблей — торгового или подлодки — наши люди.
— Ну, это очевидно, разве нет? — говорит Кроссворд. — Они с подлодки.
Чаттан отвечает чеширской улыбкой.
— Ой! — восклицает Кроссворд. У всех глаза лезут на лоб.
— По мере того как Бек шлет новые радиограммы, увеличивается вероятность того, что Дениц узнает что-то для нас нежелательное, — говорит Чаттан. — Вероятность станет практически стопроцентной, когда U-691 доберется до Вильгельмсхафена.
— Поправка! — кричит раввин. Все вздрагивают. Наступает долгая тишина, пока старик медленно привстает, держась за стол трясущимися руками. — Существенно не то, шлет ли Бек радиограммы! Существенно, верит ли им Дениц!
— Замечательно! Очень умно! — говорит Тьюринг.
— Совершенно верно! Спасибо за уточнение, герр Кан, — произносит Чаттан.
— Простите, — вмешивается дон, — но с какой стати он им не поверит?
Опять наступает долгая тишина. Дон заработал решающее очко и вернул всех к мрачной реальности. Раввин начинает что-то жалобно бормотать, однако его прерывает громовой голос со стороны двери:
— ФУНКШПИЛЬ!
Все глаза устремляются на человека, который стоит в дверях. Это крепкий мужчина лет пятидесяти, совершенно седой, в толстенных очках, которые увеличивают глаза; по темно-синему пиджаку метет вьюга перхоти.
— Доброе утро, Элмер! — произносит Чаттан с натужной веселостью психиатра, входящего в палату буйнопомешанных.
Элмер делает шаг вперед и поворачивается к собравшимся.
— ФУНКШПИЛЬ! — громогласно повторяет он.
Уотерхауз гадает, глухой Элмер, пьяный или то и другое вместе. Элмер поворачивается ко всем спиной и некоторое время пялится в шкаф, затем с изумленным видом оборачивается к собравшимся.
— Я думал, тут будет доска, — говорит он с техасским акцентом. — Что за аудитория без доски?
По комнате пробегает легкий смешок: все пытаются понять, Элмер так шутит или абсолютно не в себе.
— Это называется «радиоигры», — объясняет рабби Кан.
— Спасибо, сэр! — быстро и обиженно отвечает Элмер. — Радиоигры. Немцы ведут их с начала войны. Теперь наш черед.
Несколько минут назад Уотерхауз с тоской думал, какое здесь все британское, чужое, и мечтал, чтобы появился хотя бы один американец. Теперь, когда это желание исполнилось, ему хочется уползти на четвереньках.
— Как играют в эти игры, мистер... э-э... — начинает Кроссворд.
— Зовите меня Элмер! — грохочет Элмер. Все шарахаются.
— Элмер! — говорит Уотерхауз. — Перестаньте, пожалуйста, кричать.
Элмер поворачивается в его сторону и дважды моргает.
— Игра проста, — начинает он обычным человеческим голосом, но тут же снова приходит в волнение и продолжает по нарастающей: — Достаточно радиопередатчика и пары музыкантов с хорошими руками и хорошим слухом! — Он уже орет. Машет рукой в угол, куда запихнули девушку-альбиноса в наушниках и музыканта с помадой на левом ухе. — Объясните про почерк, мистер Шейлс.
Ударник встает.
— У каждого радиста есть определенная манера выстукивания — мы зовем ее почерком. Опытные сотрудники радиоперехвата различают немецких радистов по почерку — мы можем, например, сказать, когда кого-то из них переводят в другое подразделение. — Он кивает на девушку-альбиноса. — Мисс Лорд перехватывала многие радиограммы с U-691 и знает почерк их радиста. Более того, у нас есть записи последних сообщений с U-691, сделанные при помощи проволочного самописца, и мы их внимательно изучили. — Ударник собирается с духом и заканчивает: — Мы убеждены, что я могу подделать почерк U-691.
Вступает Тьюринг:
— А поскольку мы взломали «Энигму», мы можем составить какое угодно сообщение и зашифровать его так, как это сделала бы U-691.
— Превосходно! Превосходно! — восклицает один из министерских чиновников.
— U-691 будет по-прежнему слать свои сообщения, — напоминает Чаттан. — Мы бессильны этому помешать, разве что сумеем ее потопить, к чему сейчас прилагаются все усилия. Однако мы можем существенно замутить воду. Рабби?
Раввин снова начинает подниматься. Все замирают, ожидая, что он упадет, но ничего такого не происходит.
— Я составил сообщение на немецком флотском жаргоне. В переводе на английский там говорится примерно следующее: «Допрос пленных продвигается медленно испрашиваю разрешения применить пытки», потом несколько X в ряд и слова: «ОСТОРОЖНО ЗАСАДА U-691 ЗАХВАЧЕНА БРИТАНСКИМИ ДЕСАНТНИКАМИ».
Все ахают.
— А что, талмудисты обычно изучают современный немецкий сленг? — спрашивает оксфордский дон.
— Мистер Кан полтора года анализировал расшифровки в четвертом корпусе, — говорит Чаттан, — и назубок знает все их словечки. Мы зашифровали сообщение мистера Кана сегодняшним ключом «Энигмы», и мистер Шейлс имел время с ним попрактиковаться.
Мисс Лорд встает, как девочка, отвечающая урок в викторианской школе.
— Могу подтвердить, что исполнение мистера Шейлса неотличимо от манеры U-691.
Все глаза устремляются на Чаттана. Тот смотрит на старперов из Бродвей-билдингс. Они по-прежнему на телефоне: излагают происходящее кому-то, кого явно боятся до судорог.
— Разве у фрицев нет пеленгаторов? — спрашивает дон, словно выискивая огрехи в студенческой работе.
— Их пеленгаторная сеть куда хуже нашей, — отвечает один из молодых аналитиков. — Маловероятно, что они станут триангулировать сигнал, как предполагается, с их собственной подлодки, а поэтому вряд ли поймут, что передача ведется не из Атлантики, а из Бекингемшира.
— Тем не менее, мы предусмотрели такую возможность, — добавляет Чаттан, — и условились с несколькими нашими кораблями, а также рядом самолетов и наземных формирований, что они наполнят эфир переговорами. К началу ложной трансляции с U-691 немецкие пеленгаторные станции будут захлебываться от работы.
— Отлично, — бормочет дон.
Все сидят в церковном молчании, пока старший из министерских чиновников беседует с Кем-то на другом конце провода. Повесив трубку, он торжественно изрекает:
— Приказано исполнять.
Чаттан кивает молодым людям, те бросаются к телефонам и начинают спокойным, клиническим голосом диктовать счет крикетных матчей. Чаттан смотрит на часы.
— Потребуется несколько минут, чтобы создать дымовую завесу в эфире. Мисс Лорд, сообщите, когда уровень разговоров достигнет желаемой интенсивности.
Мисс Лорд делает реверанс и садится за рацию.
— РАДИОИГРА! — орет Элмер так, что остальные подпрыгивают. — Мы уже послали несколько других сообщений, якобы с британских кораблей. Зашифровали их кодом, который фрицы взломали пару недель назад. Радиограммы касаются операции — выдуманной операции, — в ходе которой наши десантники якобы захватили немецкую подводную лодку.
Из телефона снова слышится отрывистый лязг. Джентльмен, которому выпало несчастье снять трубку, переводит услышанное на более вежливый английский:
— Что, если исполнение мистера Шейлса не обманет радиста в Шарлоттенбурге? Что, если они не расшифруют ложных сообщений мистера Элмера?
Чаттан подходит к карте, приколотой на кульман в конце комнаты. На карте часть Атлантического океана, ограниченная с востока Испанией и Францией.
— Последний раз U-691 была замечена здесь. — Он указывает на булавку, воткнутую в нижнем левом углу карты. — Ей приказано вместе с пленными вернуться в Вильгельмсхафен. Она двинется так, — показывает красную нить, натянутую в направлении на север-северо-восток, — если не захочет идти Дуврским проливом*. [Сухой английский юмор, понятный всем в комнате. На этом этапе войны немецкая лодка так же не может пройти через Ла-Манш, как, скажем, подняться по Миссисипи, потопить несколько кораблей в Дубьюке и ускользнуть.]
— Тут как раз находится еще одна «корова», — продолжает Чаттан, показывая следующую булавку. — Одна из наших субмарин сможет добраться туда в двадцать четыре часа. Она подойдет на перископной глубине и выпустит торпеды. Велика вероятность, что «корова» будет уничтожена немедленно. Если она успеет передать радиограмму, то сообщит лишь, что ее атаковала подводная лодка. Уничтожив «корову», мы вновь обратимся к мистеру Шейлсу и попросим его отправить сообщение якобы с «коровы», где будет сказано, что на них напала U-691.
— Превосходно! — восклицает кто-то.
— К восходу, — заключает Чаттан, — на место придет цвет наших противолодочных сил. Легкий авианосец с несколькими противолодочными самолетами будет днем и ночью прочесывать океан, используя радар, визуальное наблюдение, ВЧРП и систему прожекторов «Ли Лайт». Вероятнее всего, U-691 удастся обнаружить и потопить на дальних подступах к континенту. Однако, если она все же прорвется через заграждение, немецкий флот с не меньшим рвением постарается ее уничтожить. Тем временем адмирал Дениц будет крайне недоверчиво воспринимать всю поступающую с нее информацию.
— Значит, — говорит Уотерхауз, — суть плана, вкратце, подорвать доверие ко всем сообщениям с U-691, а затем уничтожить ее и всех, кто на ней, пока они не добрались до Германии.
— Да, — отвечает Чаттан. — Первая задача упрощается тем, что с лодки уже сообщали о душевном расстройстве у капитана.
— Значит, похоже, наши ребята, Шафто и Роот, погибнут, — тихо произносит Уотерхауз.
Наступает долгое, ледяное молчание, как будто Уотерхауз за великосветским чаем издал непристойный звук.
Чаттан отвечает четким, надменным тоном, не скрывая досаду:
— Есть вероятность, что U-691, вступив в бой с нашими силами, будет вынуждена всплыть и сдаться.
Уотерхауз рассматривает стол. Лицо у него горит, в груди жарко.
Мисс Лорд встает и что-то говорит. Несколько важных голов оборачиваются к мистеру Шейлсу, тот пересаживается за стол в дальнем конце комнаты. Он крутит рацию, кладет на стол зашифрованное сообщение и набирает в грудь воздуха, как перед большим сольным концертом. Наконец кладет руку на ключ и начинает выстукивать, раскачиваясь из стороны в сторону и склоняя голову то на один, то на другой бок. Мисс Лорд слушает, сосредоточенно закрыв глаза.
Мистер Шейлс перестает стучать.
— Готово, — тихо говорит он и смотрит на мисс Лорд. Та улыбается.
Собравшиеся вежливо хлопают, как будто прослушали клавесинный концерт.
Лоуренс Притчард Уотерхауз не хлопает. Он только что услышал смертный приговор Еноху Рооту и Бобби Шафто.

ППХ

Кому: root@eruditorum.org
От: dwarf@siblings.net
Тема: Re (8): Зачем?
Позвольте подвести итог тому, что мне известно: Вы утверждаете, что спрашивать «зачем?» — часть Вашей профессии; Вы не ученый; Вы работаете в разведке. Мне трудно сложить целостную картину.

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т.д.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

Кому: dwarf@siblings.net
От: root@eruditorum.org
Тема: Re (9): Зачем?
Рэнди,
Я нигде не говорил, что сам, лично работаю в разведке. Однако я знаю людей, которые там работают. Прежде в государственном, а сейчас в частном секторе. Мы стараемся держать связь. Старая дружба и все такое. Сейчас мое участие в подобных вещах сводится к ковырянию в современных криптосистемах в качестве своего рода хобби.
Возвращаясь к тому, что я считаю главной темой нашего разговора. Вы предположили, что я — ученый. Было это искренне или просто попыткой меня «поймать»?
Я задаю вопросы, поскольку вообще-то принадлежу к духовному званию и, естественно, считаю своей работой спрашивать «зачем?». Мне казалось, Вам это будет очевидно. Хотя следовало учесть, что Вы человек не церковный. Это мое упущение.
Сейчас принято считать, что духовенство только совершает обряды на свадьбах и похоронах. Даже люди, которые по привычке ходят в церковь (или в синагогу, или куда там еще) спят во время проповеди. Причина в том, что ораторское искусство переживает упадок, и проповеди не слишком занимательны.
Однако были времена, когда такие места, как Оксфорд и Кембридж, существовали исключительно для подготовки священнослужителей, и обязанностью их было не только отправлять похоронные и свадебные обряды, но и будить мысль большого количества людей несколько раз в неделю. То были розничные поставщики философии.
Я по-прежнему считаю это главной обязанностью священника или по крайней мере самой интересной частью моей работы; отсюда мой вопрос Вам, который, не премину заметить, остался без ответа.

— НАЧАЛО МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —
(и т.д.)
— КОНЕЦ МАССИВА ЭЛЕКТРОННОЙ ЦИФРОВОЙ ПОДПИСИ ОРДО —

— Рэнди, что самое ужасное в человеческой истории?
Нетрудный вопрос, когда говоришь с Ави.
— Холокост, — послушно отвечает Рэнди.
Даже не знай он Ави так хорошо, ответ подсказала бы обстановка. Остальные эпифитовцы ушли в «Фут Меншн», готовиться к войне с Дантистом. Рэнди и Ави сидят на черной обсидиановой скамье над братской могилой японских солдат в Кинакуте, смотрят, как подъезжают и отъезжают туристические автобусы.
Ави вытаскивает из дипломата джи-пи-эску, ставит ее на камень.
— Верно! А какой самой высокой цели мы могли бы посвятить отпущенные нам годы?
— Э-э... увеличить прибыль акционеров?
— Очень смешно. — Ави раздосадован. Он выворачивает душу, что случается редко. Кроме того, он заносит в архив место одного из холокостов с маленькой буквы. Ясно, что он предпочел бы более серьезное отношение. — Несколько недель назад я был в Мексике.
— Искал место, где испанцы перебили столько-то ацтеков? — спрашивает Рэнди.
— Именно с этим я и борюсь, — продолжает Ави еще более раздраженно. — Нет, я не искал место, где испанцы перебили столько-то ацтеков. Ацтеки могут идти в жопу. Рэнди! Повторяй за мной: ацтеки могут идти в жопу.
— Ацтеки могут идти в жопу, — бодро говорит Рэнди.
Японский экскурсовод изумленно смотрит в его сторону.
— Для начала, я был в сотнях миль от Мехико, бывшей столицы ацтеков. На самом краю территории, которую они контролировали. — Ави снимает джи-пи-эску с камня и начинает нажимать кнопки, чтобы сохранить в памяти прибора широту и долготу. — Я искал, — продолжает он, — город науа, который ацтеки захватили за сотни лет до того, как испанцы высадились в Америке. Знаешь, что сделали эти сволочи ацтеки, Рэнди?
Рэнди двумя руками вытирает с лица пот.
— Что-то невообразимое?
— Ненавижу слово «невообразимое». Мы должны это вообразить.
— Так рассказывай.
— Ацтеки взяли в плен двадцать пять тысяч науа, пригнали их в Теночтитлан и перебили всех примерно за два дня.
— Зачем?
— Праздник у них был. Спортивное мероприятие. Не знаю. Суть в том, что они устраивали такую хрень постоянно. А сейчас, Рэнди, когда я говорю о геноциде в Мексике, ты мне лепечешь про испанцев! Почему? Потому что история искажена, вот почему.
— Только не говори, что ты готов принять сторону испанцев.
— Как потомок людей, изгнанных из Испании инквизицией, я на их счет не обольщаюсь, однако в свои худшие времена испанцы были в миллион раз лучше ацтеков. В смысле, это что-то говорит про ацтеков, если после того, как испанцы их всех на фиг вырубили под корень, там стало намного лучше.
— Ави?
— Да.
— Мы сидим в султанате Кинакута, строим информационный рай и одновременно пытаемся отбиться от недружественного поглощения со стороны зубного врача. Почему мы говорим про ацтеков?
— Я поднимаю твой боевой дух, — отвечает Ави. — Ты киснешь. Пинойграммы были классная штука, но теперь все заработало, и придумывать больше нечего.
— Верно.
— Однако Крипта — это действительно классно. Том, Джон и Эб в полном отпаде, и Тайные Обожатели со всего света засыпают меня своими резюме. Крипта — это то, чем бы ты хотел заниматься.
— Тоже верно.
— Даже если бы ты сейчас работал над Криптой, тебя терзали бы философские вопросы — насчет публики, с которой мы связались, наших потенциальных клиентов.
— Не спорю, философские вопросы есть, — говорит Рэнди. Внезапно у него возникает новая гипотеза: root@eruditorum.org — Ави!..
— А вместо этого ты прокладываешь кабель на Филиппинах. После того, о чем ты узнал вчера, эта работа для нашей корпоративной цели по сути не важна. Однако таково обязательство по контракту, и если мы отправим туда кого-нибудь помельче тебя, Дантист сумеет доказать самым придурочным присяжным, что мы сачкуем.
— Спасибо, что так ясно объяснил, почему мне должно быть кисло, — сдержанно говорит Рэнди.
— Поэтому, — продолжает Ави, — пойми: ты не просто клепаешь номерные знаки. И более того, Крипта — не аморальная затея. Вообще-то ты играешь огромную роль в самой что ни есть важной истории.
— Ты спросил меня, какой самой высокой цели мы можем посвятить свою жизнь. Очевидный ответ: предотвращению будущих Холокостов.
Ави мрачно смеется.
— Рад, что это очевидно тебе, мой друг. Мне уже казалось, что я один так думаю.
— Чего? Ави, очнись! Все постоянно вспоминают Холокост.
— Вспоминать Холокост — это не, не-не-не-не-не то же самое, что бороться за предотвращение будущих холокостов. Большинство тех, кто вспоминает, — просто нытики. Они думают, если люди будут скорбеть о прошлых холокостах, человеческая природа чудом преобразится и никто в будущем не захочет истребить целый народ.
— Я так понимаю, ты думаешь иначе?
— Посмотри на Боснию! — фыркает Ави. — Человеческая природа не меняется, Рэнди. Образование не помогает. Образованнейшие люди в мире превращаются в ацтеков или нацистов вот так. — Он щелкает пальцами.
— Так на что надеяться?
— Вместо того чтобы учить потенциальных палачей, мы будем учить потенциальных жертв.
— Чему учить?
Ави закрывает глаза и мотает головой.
— Черт, Рэнди, я могу говорить несколько часов — я составил целый учебный план.
— Ладно, давай отложим на потом.
— Сильно на потом. Сейчас самое главное, что все завязано на Крипту. Я способен собрать все мои идеи и вложить их в один блок информации, но почти любое правительство мира запретит распределять ее между своими гражданами. Надо построить Крипту, чтобы весь мир имел доступ к ППХ.
— Какому ППХ?
— Памятка по предупреждению Холокоста.
— О господи!
— Вот истинный смысл того, чем мы занимаемся, — говорит Ави, — поэтому очень прошу тебя — держись. Как только тебе станет скучно клепать номерные знаки на Филиппинах, подумай про ППХ. Подумай, что науа сделали бы с ацтеками, будь у них инструкция по предупреждению холокоста — учебник по тактике партизанской войны.
Рэнди какое-то время сидит в задумчивости.
— Надо пойти купить воды, — говорит он наконец. — Пока мы тут сидим, у меня с потом вытекло несколько литров.
— Можно просто вернуться в отель, — говорит Ави. — Я в основном закончил.
— Ты закончил, а я еще не начинал.
— Что не начинал?
— Рассказывать, почему мне точно не станет скучно на Филиппинах.
Ави моргает.
— Любовь, что ли?
— Нет! — хрипло отвечает Рэнди, подразумевая «да». — Ладно, пошли.
Они доходят до ближайшего «24 часа», покупают голубоватые пластиковые бутылки и, прихлебывая воду, бредут по улице, мимо соблазнительно пахнущих тележек с едой.
— Несколько дней назад я получил е-мейл от Дуга Шафто, — говорит Рэнди. — С его катера, по спутниковому телефону.
— Открытым текстом?
— Да. Я уговариваю его поставить «Ордо» и шифровать почту, но он ни в какую.
— Очень непрофессионально, — ворчит Ави. — Ему не помешала бы чуточка паранойи.
— Он такой параноик, что не доверяет даже «Ордо».
У Ави разглаживается лицо.
— Ладно, тогда все о'кей.
— В письме был глупый анекдот про Имельду Маркос.
— Ты потащил меня гулять, чтобы рассказать анекдот?
— Нет, нет. Анекдот — это условный сигнал. Дуг обещал послать е-мейл с анекдотом про Имельду, если произойдет определенная вещь.
— Какая?
Рэнди отхлебывает воды, набирает в грудь воздуха, собирается с духом.
— Больше года назад у нас был разговор. Во время приема, который Дантист закатил на борту «Руи Фалейро». Дуг хотел, чтобы мы наняли его фирму, «Семпер марин сервисис», для съемки дна под все следующие кабели. За это он обещал взять нас в долю, если при съемке наткнется на затонувшие сокровища.
Ави резко останавливается и двумя руками стискивает бутылку как будто боится ее выронить.
— Затонувшие сокровища? В смысле: йо-хо-хо и бутылка рома? Пиастры? Все такое?
— Примерно да, — говорит Рэнди. — Шафто — охотники за сокровищами. Дуг одержим мыслью, что на дне вокруг Филиппин покоятся несметные богатства.
— Откуда? С испанских галеонов?
— Нет. То есть вообще-то да, но Дуг ищет не их. — Они с Ави снова начинают идти. — Большая часть или гораздо более древние — фарфор с затонувших китайских джонок или совсем недавние — японское золото времен войны.
Как Рэнди и ожидал, слова про японское золото производят на Ави сильное впечатление. Рэнди продолжает:
— По слухам, японцы оставили здесь кучу золота. Считается, что Маркос нашел один из таких кладов в подземном туннеле — отсюда его богатство. Большинство считают, что у Маркоса было пять или шесть миллиардов долларов, но многие на Филиппинах уверены, что он нашел больше шестидесяти миллиардов.
— Шестидесяти миллиардов! — Ави напрягается всем телом. — Не может быть.
— Послушай, хочешь верь, хочешь нет, мне все равно, — говорит Рэнди. — Но поскольку казначей Маркоса будет одним из первых вкладчиков Крипты, тебе стоит про это знать.
— Продолжай, — говорит Ави, сразу загораясь интересом.
— Ладно. Так вот, есть люди, которые копают шурфы и прочесывают драгой морское дно в надежде отыскать легендарное японское золото. Дуг Шафто — из них. Проблема в том, что подробная гидролокационная съемка морского дна — штука дорогостоящая, требует больших начальных вложений. Разумеется, он за нас ухватился.
— Ясно. Очень умно, — одобрительно говорит Ави. — Возможность провести гидролокационную съемку, которая так и так нам будет нужна для прокладки кабеля.
— Может быть, чуть больше, чем необходимо, раз уж оказался на месте.
— Верно. Теперь я вспоминаю, как бдительные гарпии Дантиста возмущались, что съемка продолжается слишком долго и обходится слишком дорого. Они считали, что другая фирма выполнила бы те же работы быстрее и дешевле.
— Вероятно, так и есть, — соглашается Рэнди. — Ну так вот, Дуг обещал нам десять процентов от любого найденного сокровища. Больше, если мы решим участвовать в операции по подъему.
Внезапно у Ави расширяются глаза.
— Черт! Он хотел скрыть все это от Дантиста.
— Именно так. Потому что Дантист загреб бы себе все. Притом в силу обстоятельств его личной жизни Болоболо тоже оказались бы в курсе, а эти ребята с радостью убьют, чтобы добраться до золота.
— Ну, дела! — говорит Ави, мотая головой. — Знаешь, мне не хочется походить на трафаретных евреев из душещипательных кино. Однако в таких случаях я могу сказать только: «Ой, гевальт!»*. [О, горе мне! (идиш)]
— Я молчал по двум причинам. Во-первых, потому что мы вообще стараемся поменьше болтать. Во-вторых, потому что мы так и так собирались нанять «Семпер марин сервисис», независимо ни от каких сокровищ, и предложение Дуга Шафто ничего не меняло.
Ави задумывается.
— Поправка. Оно ничего не меняло, пока Дуг Шафто не нашел сокровища.
— Да. Я думал, что и не найдет.
— Ты ошибся.
— Я ошибся, — признает Рэнди. — Шафто нашел старую японскую подводную лодку.
— Откуда ты знаешь?
— Если бы он нашел китайскую джонку, то прислал бы мне анекдот про Фердинанда Маркоса. Если бы что-то времен воины, то про Имельду. Если бы это был надводный корабль, анекдот был бы про ее туфли. Если подводная лодка — про ее сексуальные привычки. Дуг прислал мне анекдот про сексуальные привычки Имельды.
— Ты ответил официально на его предложение.
— Нет. Я же сказал, оно ничего не меняло, мы все равно собирались его нанять. А потом, когда мы подписали контракт и стали составлять план работ, он рассказал про код, насчет Маркосов Я понял, он считает: раз мы его наняли, то договоренность подразумевается.
— Странный способ вести дела, — произносит Ави, морщась. — Он мог бы хоть что-то расписать подробнее.
— Дуг из тех, кто работает на доверии, — говорит Рэнди. — Если он обещал, значит, не обманет.
— Проблема с честными людьми в том, — замечает Ави, — что они ждут честности от всех остальных.
— Верно.
— Значит, теперь он считает, что мы его сообщники и поможем скрыть от Дантиста и Болоболо существование подводного клада.

Предыдущая страница 19 Следующая страница


Криптономикон (часть 1) 20

— Если не поставим их в известность прямо сейчас.
— В таком случае мы предаем Дуга Шафто, — говорит Ави.
— Всаживаем нож в спину бывшему десантнику, прошедшему Вьетнам. И не забудь его друзей-вояк по всему миру, — добавляет Рэнди.
— Черт, Рэнди! Я думал огорошить тебя рассказом про ППХ.
— Огорошил.
— А ты вываливаешь на меня такое!..
— Жизнь полна приключений, — изрекает Рэнди.
Ави задумывается.
— Короче, я так понимаю, вопрос сводится к тому, кого мы предпочитаем иметь на своей стороне в салунной перестрелке.
— Ответ может быть один: Дугласа Макартура Шафто, — говорит Рэнди. — Но это не значит, что мы выйдем из салуна живыми.

MORPHIUMSUCHTIG

Его затолкали в узкий промежуток между легким и прочным корпусами немецкой подводной лодки; ледяная вода бьет, как из брандспойта, тело колотит малярийная дрожь: кости трещат, суставы леденеют, мышцы сводит. Он зажат двумя неровными стальными поверхностями, изогнутыми так, как человек изогнуться не может; любое движение вызывает резкую боль. Кожа начинает обрастать ракушками — они вроде вшей, только крупнее и глубже вгрызаются. Кое-как удается глотнуть воздуха, ровно столько, чтобы не задохнуться и по-настоящему осознать, до чего все хреново. Шафто слишком долго дышал соленой морской водой: в горле саднит, в легких завелся планктон и жрет их изнутри. Он молотит по прочному корпусу, звука нет. Оттуда веет теплом и жаром, хочется внутрь, согреться. Наконец, по какой-то логике сна, удается отыскать люк. Течение подхватывает Шафто, выносит во влажный космос, подводная лодка с шипением уплывает. Нет ни низа, ни верха. Что-то бьет его по голове. Несколько черных цилиндров неумолимо движутся в воде, оставляя параллельные кометные следы пузырей. Глубинные бомбы.
Шафто просыпается и понимает, что его тело требует морфия. В первые мгновения он уверен, что снова в Окленде. Над койкой стоит лейтенант Рейган, готовится продолжить интервью.
— Добрый вечер, сержант Шафто, — говорит Рейган, почему-то с сильным немецким акцентом. Ну и шутники же эти актеры! Шафто чувствует запах мяса и другие, менее приятные запахи. Что-то тяжелое, но не совсем твердое, ударяет его по лицу. Отходит. Ударяет снова.

— Ваш товарищ — morphiumsuchtig? — спрашивает Бек.
Енох Роот слегка ошарашен; они на лодке всего восемь часов.
— Он что, буянит?
— Он в полубессознательном состоянии, — говорит Бек. — Кроме всего прочего, рассказывает об исполинских ящерицах.
— Для него это нормально, — с облегчением отвечает Роот. — Почему вы решили, что он morphiumsuchtig?
— По флакону с морфием и шприцу, которые нашли у него в кармане, — говорит Бек с каменной тевтонской иронией, — и по исколотой руке.
Роот думает, что лодка — как туннель, пробуренный в морской воде и тесно заставленный оборудованием. Каюта (если это можно так назвать) — самое большое открытое пространство, которое Роот на ней пока видел. Здесь почти что можно вытянуть руку, никого не задев и не повернув ненароком штурвал или рубильник. Есть даже деревянная мебель и кожаная занавеска, отделяющая каюту от коридора. В первый миг он принял ее за какую-то каптерку, но, оглядевшись, понимает, что это лучшее место на лодке: личная каюта капитана. Догадка подтверждается, когда Бек отпирает ящик и достает бутылку арманьяка.
— У завоевателей Франции есть свои привилегии, — говорит Бек.
— Да, — замечает Роот, — пограбить вы, ребята, умеете.

Лейтенант Рейган вернулся, тычет в Шафто стетоскопом, который предварительно, похоже, выдержали в жидком азоте. «Кашляй, кашляй, кашляй!» — твердит он. Наконец убирает инструмент.
Что-то мешается в ногах. Шафто хочет приподняться на локте и впечатывается мордой в раскаленную трубу. Придя в себя, осторожно приподнимает голову и видит, бля, целую скобяную лавку. Эти гады заковали его в кандалы!
Он укладывается обратно и получает в рожу болтающимся окороком. Сверху небосвод из труб и кабелей. Где он видел такое раньше? На рифе возле Йглма, вот где. Только эта лодка освещена, не тонет, и на ней полно немцев. Немцы спокойны и неторопливы. Никто из них не истекает кровью, не кричит. Черт! Лодка кренится, и гигантская кровяная колбаса лупит его в живот.
Он оглядывается, пробует сориентироваться. Кроме висящего мяса, почти ничего не видно. Каюта — шестифутовый отсек, узкий проход посередине зажат койками. На противоположной — грязный парусиновый мешок.
К черту все. Где ящичек с малиновыми пузырьками?

— Забавно читать радиограммы из Шарлоттенбурга, — говорит Бек, переводя разговор на расшифровки, которые разложены по столу. — Можно подумать, их писал этот еврей Кафка.
— Почему?
— Похоже, там не верят, что мы вернемся живыми.
— Что навело вас на эту мысль? — спрашивает Роот, стараясь не слишком явно наслаждаться арманьяком. Когда подносишь бокал к носу и вдыхаешь, аромат почти заглушает запахи мочи, блевоты, тухлятины и дизтоплива, которыми лодка пропитана на молекулярном уровне.
— Нас торопят с информацией о пленных. Вы их сильно заинтересовали, — говорит Бек.
— Другими словами, — осторожно произносит Роот, — от вас требуют, чтобы вы допросили нас прямо сейчас.
— Верно.
— И послали результаты по радио?
— Да, — кивает Бек. — Однако на самом деле мне надо думать о том, как выжить. Скоро взойдет солнце, и нам придется туго. Вспомните: перед тем как я вас потопил, ваш корабль передал координаты. Сейчас нас ищут все корабли и самолеты союзников.
— То есть если я не стану запираться, — говорит Роот, — вы сможете скорее заняться нашим спасением.
Бек пытается сдержать улыбку. Его тактика была грубой и очевидной с самого начала, и Роот ее уже разгадал. Вся эта история с допросом смущает Бека куда больше, чем Роота.
— Предположим, я скажу вам все, что знаю, — говорит Роот. — Чтобы послать это в Шарлоттенбург, вам придется вести передачу в надводном положении несколько часов кряду. Пеленгаторы засекут вас в первые несколько секунд, и все эсминцы и бомбардировщики в радиусе тысячи миль устремятся к вам.
— К нам, — поправляет Бек.
— Верно. Значит, если я и впрямь хочу остаться в живых, мне лучше придержать язык, — говорит Роот.

— Ты это ищешь? — спрашивает немец со стетоскопом. Шафто знает, что он не настоящий врач, а просто тип, которому доверили аптечку. Так или иначе, в руках у него оно. Оно самое.
— Дай! — Шафто слабо тянется к пузырьку. — Это мое!
— Вообще-то это мое, — поправляет медик. — Твое у капитана в каюте. Но я могу поделиться с тобой своим, если будешь отвечать на вопросы.
— Иди в жопу, — говорит Шафто.
— Отлично. Отложим на потом.
Медик кладет полный шприц с морфием на противоположную койку, так что Шафто может его видеть между двумя копчеными колбасами, но не может взять. И уходит.

— Почему у сержанта Шафто был при себе немецкий пузырек с морфием и немецкий шприц? — Бек изо всех сил старается вести якобы разговор, а не допрос, однако напряжение явно чрезмерно, и губы сами складываются в улыбку. Это улыбка побитого пса. Рооту становится немного не по себе, поскольку от Бека зависит, чтобы все на лодке остались живы.
— Для меня это новость, — признает Роот.
— Морфий строго контролируется, — продолжает Бек. — На каждом пузырьке есть номер. Мы сообщили номер пузырька в Шарлоттенбург, и там скоро узнают, откуда он взялся. Хотя нам могут не сказать.
— Отлично. Это на время их отвлечет. Почему бы вам не вернуться к управлению лодкой? — советует Роот.
— Сейчас затишье перед бурей, — говорит Бек, — и делать мне особенно нечего. Вот я и пытаюсь удовлетворить свое любопытство.

— Нам капец, да? — спрашивает немецкий голос.
— M-м? — отзывается Шафто.
— Я сказал, нам капец! Вы взломали «Энигму»!
— Какую «Энигму»?
— Не прикидывайся дурачком, — говорит немец.
У Шафто мурашки бегут по коже. Именно так в его представлении должен вести себя немец, прежде чем начать пытки.
Шафто делает вялое, придурковатое лицо, как всегда, когда хочет позлить офицера, и перекатывается на бок, насколько это возможно при скованных ногах. Он ожидает увидеть эсэсовца с орлиным носом, в черной форме, перчатках и сапогах, с черепом на нашивках, с хлыстом и, быть может, тисками для больших пальцев.
Однако рядом ровным счетом никого. Черт! Опять галлюцинация.
Тут холщовый мешок на противоположной койке шевелится. Шафто моргает и видит торчащую с одной стороны голову: светловолосую, с преждевременной лысиной, бледно-зелеными кошачьими глазами и неожиданно черной бородой. На человеке не совсем мешок, а скорее длинная холщовая куртка. Он обнимает себя руками.
— Ладно, — бормочет сосед. — Я просто пытаюсь завести разговор. — Поворачивает голову и чешет нос о подушку. — Можешь рассказывать мне любые секреты. Понимаешь, я уже сказал Деницу, что «Энигма» — говно. И ничего не изменилось. Только вот новое пальто получил.
Он поворачивается на бок и показывает Шафто спину. Рукава одежды зашиты и связаны за спиной.

Помощник отодвигает кожаную занавеску, виновато кивает и вручает Беку свежую расшифровку. Бек читает, поднимает брови и устало хлопает глазами. Кладет листок на стол, пятнадцать секунд смотрит в стену. Снова берет и читает еще раз, внимательно.
— Здесь сказано, чтобы я не задавал вам больше вопросов.
— Что?!
— Ни при каких обстоятельствах, — говорит Бек, — я не должен извлекать из вас новую информацию.
— Что это значит?
— Наверное, вам известно что-то такое, чего мне знать не положено.

* * *

Уже примерно лет двести в теле Шафто не было и следов морфия. Без этого он не может испытывать радость или даже покой.
Шприц холодной звездой сверкает на полке под чокнутым немцем. Лучше бы уж ногти вырывали.
Шафто знает, что расколется. Он думает, как бы расколоться, чтобы не погубить других морпехов.
— Я могу принести тебе шприц в зубах, — замечает сосед который назвался Бишофом.
Шафто обдумывает его слова.
— В обмен на что?
— Ты скажешь, расшифровали ли вы «Энигму».
— А. — Шафто облегченно вздыхает; он боялся, что Бишоф потребует ему отсосать. — Это ты про ту шифровальную хреновину, о которой мне рассказывал?
У них с Бишофом была масса времени травить баланду.
— Ага.
Шафто в отчаянии. Однако он еще и зол как черт, а это помогает.
— Думаешь, я поверю, что ты просто псих, повернутый на «Энигме», а не офицер, нацепивший смирительную рубашку, чтобы меня обмануть?
Бишоф вне себя:
— Говорю же, я давно сказал Деницу, что «Энигма» — дрянь! Если ты мне скажешь, что она — дрянь, это ничего не изменит!

— Тогда можно вопрос? — говорит Роот.
— Да? — Бек с заметным усилием поднимает брови, притворяясь, будто ему интересно.
— Что вы сообщили о нас в Шарлоттенбург?
— Имена, фамилии, звания, личные номера, обстоятельства захвата.
— Но все это вы сообщили вчера.
— Верно.
— А недавно?
— Ничего, только номер на пузырьке с морфием.
— И через какое время после этого поступил приказ остановить допрос?
— Через сорок пять минут, — отвечает Бек. — Поэтому, да, я очень бы хотел спросить, откуда взялся пузырек. Но не вправе.

* * *

— Я подумаю, ответить ли на твой вопрос про «Энигму», — говорит Шафто, — если ты скажешь, перевозят ли эти жестянки золото.
Бишоф морщит лоб: возникли проблемы с переводом.
— В смысле деньги? Geld?
— Нет. Золото. Дорогой желтый металл.
— Может быть, немного, — отвечает Бишоф.
— Не мелочь на карманные расходы, — говорит Шафто. — Тонны и тонны.
— Нет, подлодки не возят тонны золота, — твердо отвечает Бишоф.
— Зря ты так сказал, Бишоф. Я думал, мы подружимся. А ты взял и соврал мне, козел!
К изумлению и растущей досаде Шафто, Бишоф испытывает невероятный приступ веселья оттого, что его назвали «козлом».
— Какого рожна я буду тебе врать, Шафто! После того как ваши сволочи взломали «Энигму» и поставили радары на все, что движется, наши лодки топят, не успевают те выйти в море. С какой стати кригсмарине будет грузить тонны золота на лодку, которая точно отправится на дно?!
— Спросил бы у тех, кто грузил его на U-553.
— Ха! Ну я же сказал, ты несешь ерунду! U-553 потопили год назад, во время атаки на конвой.
— Ни хера. Я видел ее пару месяцев назад, — говорит Шафто. — У Йглма. Она была под завязку набита золотом.
— Чушь собачья, — возмущается Бишоф. — Что нарисовано на боевой рубке?
— Белый медведь с пивным бокалом.
Долгое молчание.
— Хочешь еще? Я был в каюте у капитана, — продолжает Шафто, — и там висела его фотография в компании дружков. Как я теперь припоминаю, один здорово смахивал на тебя.
— Что мы делали?
— Вы были в плавках, с блядями на коленях! — орет Шафто. — Если, конечно, они вам не жены, но тогда, уж прости, твоя жена — блядь.
— Хо-хо-хо-хо-хо! — Бишоф переворачивается на спину и некоторое время разглядывает трубы. Потом заводит по новой: — Хо-хо-хо-хо-хо!
— Я что, выдал какую-то тайну? Если так, чтоб тебе сдохнуть, падла, — говорит Шафто.
— Бек! — орет Бишоф. — Ахтунг!
— Что ты делаешь? — спрашивает Шафто.
— Добываю тебе морфий.
— А. Спасибо.
Через полчаса появляется командир. Довольно пунктуально для офицера. Они говорят с Бишофом по-немецки. Шафто несколько раз слышит слово «морфий». Наконец командир зовет медика, и тот вводит Шафто примерно полшприца морфия.
— Вы что-то хотели сказать? — спрашивает командир у Шафто. По всему, славный малый. Вообще они все теперь славные.
Первым делом Шафто обращается к Бишофу:
— Сэр! Прошу прощения за резкие слова, сэр!
— Все отлично, — говорит Бишоф. — Она и правда была блядь.
Командир нетерпеливо откашливается.
— Да. Мне просто интересно, — поворачивается к нему Шафто, — на этой лодке есть золото?
— Желтый металл?
— Да. В слитках.
Капитан ошарашен. Шафто испытывает некую озорную радость. Доводить офицеров не так здорово, как насыщать мозг высокоочищенным опиатом, но для крайности сойдет.
— А я думал, все подлодки его возят.
Бек отсылает медика. Потом они с Бишофом некоторое время говорят по-немецки. Посередине разговора Бек оглоушивает Бишофа какой-то новостью. Бишоф парализован и долго отказывается верить. Бек твердит, что это правда. Потом Бишоф вновь начинает похохатывать.
— Он не может задавать тебе вопросы, — говорит Бишоф. — Приказ из Берлина. Хо-хо-хо! А я могу.
— Валяй, — говорит Шафто.
— Расскажи еще про золото.
— Дайте еще морфия.
Бек зовет медика, тот вкалывает Шафто остаток шприца. Шафто хорошо, как никогда. Надо же так устроиться! Немцы дают ему морфий в обмен на немецкие военные тайны!
Бишоф начинает подробный допрос. Бек слушает. Шафто трижды пересказывает историю U-553. Бишоф заворожен. Бек огорчен и напуган. Когда Шафто упоминает, что на слитках были китайские значки, и Бек, и Бишоф офигевают. Лица у обоих вспыхивают, словно освещенные прожектором «Ли Лайт» в безлунную ночь. Бек начинает шмыгать носом, как будто у него насморк. Бля, да он плачет! Льет слезы стыда. Однако Бишоф по-прежнему зачарован.
Вбегает помощник и подает Беку радиограмму. Помощник трясется и смотрит не отрываясь, но не на Бека, а на Бишофа.
Бек берет себя в руки и читает радиограмму. Бишоф свешивается с койки, кладет подбородок Беку на плечо и тоже читает. Они похожи на двухголового циркового урода, который не мылся со времен президента Гувера. Оба молчат по меньшей мере минуту. Бишоф молчит, потому что шестеренки у него в мозгу крутятся со скоростью торпедного гироскопа. Бек молчит, потому что он на грани обморока. Слышно, как за переборками неведомая весть распространяется со скоростью звука. Кто-то кричит от ярости, кто-то рыдает, кто-то истерически хохочет. Может, Гитлера убили. Может, Берлин пал.
Бек заметно напуган.
Входит медик. Он по-военному расправил плечи — Шафто первый раз видит на лодке такую официальность. Медик коротко обращается к Беку на немецком. В продолжение его речи Бек несколько раз кивает. Потом они вместе с врачом вызволяют Бишофа из смирительной рубашки.
У Бишофа немного затекли руки и ноги, но кровь скоро расходится. Он ниже среднего роста, поджарый, широкоплечий и с койки спрыгивает по-кошачьи, как ягуар с дерева. Жмет руку медику, потом несчастному Беку и открывает люк к центральному посту. Полкоманды столпилось у выхода с трапа. При виде Бишофа все расцветают и разражаются ликующими возгласами. Бишоф жмет все протянутые руки и проходит на пост, как политик через толпу восторженных сторонников. Бек проскальзывает в другой люк и теряется в грохоте дизелей.
Шафто не понимает, что за херня творится, пока через четверть часа не приходит Роот. Он берет с палубы радиограмму и читает. Его постоянно озадаченное выражение, которое обычно раздражает, сейчас как нельзя кстати.
— Это радиограмма всем кораблям от верховного командования немецкого ВМФ, Тирпиц-уфер, Берлин. Тут сказано, что, U-691 — та самая лодка, на которой мы с тобой сейчас, Бобби, — захвачена британскими десантниками и уже потопила «корову» в Атлантике. Сейчас она движется к континентальной Европе с явным намерением проникнуть на немецкие базы и потопить еще корабли. Всем немецким морским и воздушным силам приказано искать U-691, а найдя, немедленно уничтожить.
— Бля, — говорит Шафто.
— Мы оказались на неудачной лодке в неудачное время, — замечает Роот.
— Что за ерунда с этим Бишофом?
— Его отстранили от командования, а сейчас вернули.
— Этот псих управляет лодкой?!
— Он — капитан, — говорит Роот.
— И куда же он нас доставит?
— Не уверен, что он сам это знает.

Бишоф заходит к себе, наливает бокал арманьяка и идет в штурманскую рубку, которую всегда предпочитал личной каюте. Штурманская рубка — единственное цивилизованное место на корабле. Здесь есть, например, красавец-секстан в полированном деревянном футляре. Сюда со всей лодки сходятся переговорные трубы, и, хотя сейчас никто не говорит в них непосредственно можно слышать обрывки разговора, далекий гул дизелей, шуршание тасуемой колоды, шипение свежих яиц на сковородке. Свежие яйца! Слава богу, что они успели встретиться с «коровой» до того, как ту потопили.
Бишоф разворачивает мелкомасштабную карту, на которой помещается вся северо-восточная Атлантика, расчерченная на квадраты с цифрами и буквами для охоты на конвои. Ему следует смотреть в южную часть, где они сейчас, однако взгляд вновь и вновь устремляется на север, к Йглмскому архипелагу.
Поместите его в центр циферблата. Великобритания между пятью и шестью часами, Ирландия на семи. Норвегия точно на востоке, то есть на трех. Дания к югу от Норвегии, на четырех. У основания Дании, там, где она соединяется с Германией, — Вильгельмсхафен. Франция, база большинства немецких подлодок, далеко на юге — не видать.
Когда подводная лодка ищет безопасное пристанище, ей самая дорога к французскому побережью Бискайского залива, скорее всего к Лорьяну. Добираться до германского Северного моря и балтийских портов куда опаснее и дольше. Придется огибать Великобританию. С юга пришлось бы идти Ла-Маншем. Не говоря о том, что это узкая щель, прошитая британскими радарами, сволочи англичане еще и понатопили там старых кораблей, чтобы затруднить движение, и наставили минных заграждений. На севере простора больше.
Предположим, Шафто не врет — а что-то в его рассказе должно быть правдой, иначе откуда бы взялся пузырек с морфием. В таком случае U-553 было бы проще всего обойти Великобританию с севера. Однако у всех подводных лодок есть какие-нибудь механические неполадки — особенно после долгого похода. В таком случае командир будет держаться поближе к берегу, избегая открытого моря, где при полном отказе двигателей уже не спастись. За последние года два немало вышедших из строя немецких подводных лодок осталось на берегах Ирландии или Исландии.
Предположим, поврежденная подводная лодка проходила мимо британской военно-морской базы на Йглме, как раз когда другая подводная лодка совершала там рейд. В таком случае высланные против второй лодки эсминцы и самолеты легко могли подбить U-553, особенно если ее способность к маневру была ограничена.
В рассказе Шафто есть две странности. Первая: лодка везла золото. Вторая: она направлялась в Германию, а не во Францию.
Однако, взятые вместе, они выглядят совсем не так странно, как по отдельности. У лодки, везущей столько золота, могут быть серьезные причины следовать прямиком к фатерлянду. Какие-то очень высокопоставленные люди хотят сохранить золото в тайне. Не только от врага, но и от остальных немцев.
За что японцы дают немцам золото? Наверное, немцы что-то шлют взамен: стратегические материалы, чертежи нового оружия, военных советников, что-нибудь такое.
Бишоф пишет радиограмму:

Дениц!
Это Бишоф. Я снова на посту. Спасибо за приятный отдых. Теперь я полностью восстановил силы.
С твоей стороны невежливо приказывать, чтобы меня потопили. Это какое-то недоразумение. Не обсудить ли его при личной встрече?
Пьяный белый медведь рассказал мне занимательнейшую историю. Может быть, я через часик выдам ее в эфир. А поскольку больше не верю в «Энигму», то и шифровать не стану.
С уважением,
Бишоф

Стайка белых V мигрирует к северу от Гибралтара по залитому солнцем морю. В вершине каждой V — маленькая черная вошка. Вошки — корабли, везущие мегатонны военного хлама и тысячи солдат из Северной Африки (где их услуги уже не требуются) в Англию. Так видят их летчики над Бискайским заливом. Все эти летчики и все эти самолеты — американские и британские. Союзники распоряжаются в Бискайском заливе, как у себя дома. Для команды немецкой подводной лодки пройти его — сущее испытание.
Большая часть V движется параллельным курсом на север, однако некоторые беспрестанно кружат и вертятся: это эсминцы, которые буквально вьются вокруг конвоя; а значит, пилоты вылетевшие на поиски U-691, могут ее здесь не высматривать.
Под ярким солнцем каждый корабль отбрасывает вперед черную тень. Для впередсмотрящих, чьи зрачки сужены до булавочных головок, а глаза сощурены от нестерпимого блеска, она непроницаема, как лист фанеры. Иначе бы они заметили, что у одного из больших транспортных судов в первом ряду появилось небольшое дополнение: труба, торчащая из воды чуть впереди и сбоку от носа. Вообще-то это даже несколько труб рядом: одна втягивает воздух, другая выбрасывает дизельный выхлоп, третья пропускает поток информации в виде отраженного от призм света. Проследите поток информации под воду — и попадете в оптический нерв капитан-лейтенанта Бишофа. Нерв ведет в мозг, и мозг этот работает с полной нагрузкой.
В эпоху гидролокаторов лодка Бишофа была крысой в темном, замусоренном, бесконечном подвале. Крыса пряталась от человека, у которого не было ни фонаря, ни факела, только два камня для высекания искр. В те дни Бишоф потопил множество кораблей.
Однажды, когда он шел в надводном положении, торопясь через Карибское море, из ниоткуда возникла «каталина». Она появилась в чистом голубом небе, и Бишоф успел заранее погрузиться. «Каталина» сбросила несколько глубинных бомб и улетела; видимо, горючее было на исходе.
Через два дня атмосферный фронт приблизился, небо затянули рваные облака, и Бишоф имел глупость расслабиться. Под прикрытием облаков их выследила другая «каталина», дождалась, когда U-691 выйдет на освещенную солнцем полоску моря, и спикировала, так что ее тень легла на мостик U-691. По счастью, Бишоф выставил двойное наблюдение за воздухом в солнечном секторе. На морском жаргоне это означает, что в любой конкретный момент времени два небритых, вонючих, голых по пояс загорелых матроса стоят на палубе и смотрят из-под руки в небо. Один что-то сказал недоумевающим тоном, и Бишофа это насторожило. Обоих наблюдателей разнесло ракетой. Еще пятерых подводников ранило артиллерийским огнем и ракетами прежде, чем Бишоф успел увести лодку на глубину.
На следующий день все небо от горизонта до горизонта обложили серые тучи. U-691 шла далеко от берега. Тем не менее Бишоф приказал старшему механику Хольцу подняться для начала на перископную глубину, внимательно изучил горизонт и, только убедившись, что никого нет, отдал приказ к всплытию. Задание было выполнено, они направлялись домой.
Через два часа из облаков вынырнула летающая лодка и сбросила на них узкое черное яйцо. Бишоф был на ходовом мостике, дышал свежим воздухом и успел крикнуть в переговорную трубу что-то про маневр уклонения. Мецер, рулевой, тут же переложил руль право на борт. Бомба зарылась в воду там, где только что была палуба U-691.
Так продолжалось, пока они не ушли далеко в океан. Кое-как дотянув до базы в Лорьяне, Бишоф с суеверным ужасом рассказал об этом начальству и услышал в ответ, что у противника появилась новая штуковина под названием радар.
Бишоф прочел разведданные: враг даже самолеты оборудовал этой дрянью! Они видят твой перископ!
Его лодка уже не крыса в темном погребе, а бескрылый слепень, ползущий по белоснежной скатерти в ярком дневном свете.
Дениц, дай ему бог здоровья, пытается строить новые лодки, которые могут все время идти под водой. Однако он должен выпрашивать каждую тонну стали и каждого инженера. А пока придумали временную меру, шнорхель: трубу, торчащую из воды. Она позволяет идти на дизельной тяге прямо под поверхностью. Шнорхель тоже видно на экране радара, но не так четко. Всякий раз, как U-691 всплывает более чем на час, Хольц приваривает к шнорхелю новые куски, стачивает старые, заматывает его резиной, которая должна поглощать радарные волны. Инженеры, установившие шнорхель в Лорьяне полгода назад, сейчас бы его не узнали: он эволюционировал, как землеройки эволюционировали в тигров. Если Бишоф приведет U-691 в порт, другие узнают о выдумках Хольца и несколько до сих пор не потопленных лодок смогут воспользоваться плодами эксперимента.
К черту. Вот так, наверное, офицеры гробятся и гробят людей: вспоминая прошлое, вместо того чтобы строить планы на ближайшее будущее. Для Бишофа подобные мысли ничуть не лучше онанизма. Надо сосредоточиться.
Можно не очень опасаться, что его потопят свои. Дениц отменил приказ, как только получил радиограмму с угрозой выдать в эфир информацию о золоте. Однако есть опасность, что какой-то корабль получил первый приказ и не получил второго. Следует быть начеку.
Та еще угроза. У Германии практически некому его топить. Думать надо про союзников. Они здорово разозлятся, когда поймут, что он два дня идет с их конвоем. Бишоф и сам злой как черт: конвой быстрый и все время делает зигзаги из соображений безопасности. Если U-691 не будет лавировать точно в унисон с кораблем, ее или раздавят, или заметят. Большая нагрузка на капитана и экипаж, заметный расход амфетамина из корабельных запасов. Зато они покрыли пятьсот миль! Скоро роковой Бискайский залив останется позади, справа будет Бретань и перед Бишофом встанет выбор: самоубийственный рывок через Ла-Манш, самоубийственный путь на север между Ирландией и Британией или самоубийственный крюк в обход Ирландии.
Разумеется, есть дружественная Франция, но от этой сирены надо всеми силами держаться подальше. Бишофу мало посадить лодку на мель у какого-нибудь безлюдного берега; он хочет привести ее на базу. Однако небеса над базами кишат «каталинами» а море освещено сатанинским светом радаров. Пусть лучше думают, что лодка идет во Францию, а он тем временем свернет в Германию.
По крайней мере так он считал два дня назад. Теперь неимоверная трудность плана его доканывает.
Тень корабля внезапно становится темнее и длиннее. Значит, либо земля заметно ускорила вращение и солнце светит теперь под другим углом, либо корабль поворачивает к ним. «Право на борт!» — тихо говорит Бишоф. Его голос по трубе попадает к человеку, который управляет рулем.
— Есть что в эфире? — спрашивает капитан.
— Нет, — отвечает функмаат.
Странно: обычно, когда корабли закладывают зигзаг, они координируются по радио. Бишоф поворачивает перископ и смотрит на транспорт, который по-прежнему надвигается. Проверяет курс: эта скотина повернула на целых девяносто градусов!
— Нас заметили, — говорит Бишоф. — Сейчас будем погружаться.
Однако, пока еще можно, он поворачивает перископ на все триста шестьдесят и убеждается, что мысленная карта конвоя верна. Да, все примерно так; ага, вот эсминец, справа, где он и думал. Бишоф останавливает перископ, дает пеленг цели. Торпедомаат повторяет цифры, вводя их в вычислитель системы наведения: новейшее, полностью аналоговое устройство. Бишоф командует: огонь, огонь, погружение. Все происходит почти так же быстро. Кузнечный хор дизелей, медленно доводивший их до умоисступления в последние два дня, сменяется неожиданной тишиной. Теперь они идут на аккумуляторах.
Как всегда бывает в таких случаях и как будет еще как минимум пятьдесят лет, аккумуляторы — барахло. Скорость лодки падает, и кажется, что конвой резко ускоряет ход. Сейчас эсминец может двигаться в пять раз быстрее подлодки. Это самое гадкое.
— Эсминец предпринял маневр уклонения, — говорит гидроакустик.
— Мы успели получить метеопрогноз?
— Вечером надвинется штормовой фронт. Завтра штормовая погода.
— Давайте попробуем продержаться до шторма, — говорит Бишоф. — А потом проведем эту банку с дерьмом через Ла-Манш прямо под жирной задницей Уинстона Черчилля, и если погибнем, то как мужчины.
Мощный грохот проносится по воде и достигает корпуса. Слышится жидкое «ура!». Они потопили еще корабль.
— Думаю, эсминец, — говорит гидроакустик, словно не веря своему счастью.
— Эти самонаводящиеся торпеды хороши, суки, — говорит Бишоф, — если только не поворачивают и не наводятся на тебя.
Один эсминец готов, три остались. Если потопить еще один, есть шанс уйти от оставшихся двух. Однако невозможно уйти от трех эсминцев.
— Не откладывай на потом то, что можешь сделать сейчас, — говорит он. — Перископная глубина! Посмотрим, что происходит, пока они не очухались.
Значит, так: один эсминец тонет, другой идет ему на помощь. Два других движутся туда, где U-691 была тридцать секунд назад, но медленно, потому что должны пробираться через конвой. Почти немедленно оба открывают огонь. Бишоф выпускает торпеды по эсминцу, который направляется к пострадавшему. Вода вокруг бурлит от снарядов. Он снова поворачивает перископ на полный круг, фиксируя в мозгу расположение кораблей.
— Погружение! — командует он. Тут ему приходит идейка получше.
— Отставить! Всплытие и полный вперед!
Сейчас другая команда перерезала бы ему глотку и сдалась. Однако эти ребята не колеблются: то ли они действительно его любят, то ли решили, что все одно погибать.
Двадцать секунд чистого ужаса. U-691 несется по поверхности, кренясь, как «мессершмитт», снаряды лупят по воде. Подводники высыпают из люков, похожие в свете дня на узников концлагеря, стараются не поскользнуться на палубе, которую качает то вправо, то влево, и зацепиться карабинами на страховочных линях за тросы, пока их не сбило с ног всплесками от снарядов. Они встают к орудиям.
Сейчас между ними и двумя эсминцами — большое транспортное судно. Короткая передышка. Бишоф в боевой рубке. Он разворачивается кормой и дает залп по третьему эсминцу, который отчаянно кружит, пытаясь уйти от самонаводящихся торпед.
Когда они наконец выходят из-за укрытия большого транспорта, Бишоф видит, что его мысленная картина конвоя более или менее точна. Он отдает приказ рулевому и машинному отделению. Раньше, чем эсминцы успевают открыть огонь, лодка занимает позицию между ними и большим транспортным судном: дряхлым океанским лайнером, наспех покрашенным в военный защитный цвет. Эсминцы не могут стрелять по нему, не разнеся к чертовой бабушке сотни своих же солдат. Но он-то может! Когда его люди видят над собой лайнер и смотрят через воду на бессильные эсминцы, они, кроме шуток, затягивают развеселую застольную песню.
U-691 сверху вооружена до зубов из-за угрозы с воздуха. Команда Бишофа бьет по эсминцам из всех больших и средних орудий, чтобы расчет палубной артиллерийской установки успел хорошенько прицелиться. При таком расстоянии есть опасность, что снаряд пройдет через корпус эсминца насквозь и не взорвется. Надо быть спокойным, не торопиться, целить в машинное отделение. Команда Бишофа это знает.
Артиллерийская установка выстреливает с грохотом, от которого чуть не лопаются барабанные перепонки. Снаряд несется над водой, поражает ближайший эсминец точно в котлы. Эсминец не взлетает на воздух, но замирает на месте. Они еще несколько раз стреляют по второму эсминцу.
Удается вывести из строя одно орудие и один бомбосбрасыватель глубинных бомб. Тут наблюдатели замечают в небе самолеты. Пора погружаться. Пока они не ушли на глубину, Бишоф в последний раз обводит сцену перископом и с удивлением видит, что эсминцу, который пытался уклониться от торпед, это таки удалось; по всей видимости, две повернули назад и вместо него поразили транспортные суда.
Опускаются сразу на сто шестьдесят метров. Эсминцы восемь часов бросают на них глубинные бомбы. Бишоф ложится вздремнуть. Когда он просыпается, вокруг рвутся глубинные бомбы, все отлично. Наверху, должно быть, темно и штормит. Плохая погода для «каталин». Он уклоняется от эсминцев, применяя (если совсем коротко) некоторые хитрости, которым научился на своей шкуре. Лодка тонкая, как вязальная спица и, если развернуть ее точно к радару или точно от него, практически не дает отражения. Надо только четко представлять себе, где ты относительно эсминцев.
Еще через час эсминцы прекращают охоту и уходят. Бишоф поднимает U-691 на шнорхельную глубину и направляет точно в середину Ла-Манша, как и было обещано. Он смотрит в перископ и убеждается, что погода, тоже как и было обещано, отвратная.
Эти сволочи воткнули в карту толстую красную булавку там, где эсминцы последний раз видели U-691. Час за часом они будут обводить булавку кругами все большего радиуса, охватывая все точки океана, в которых может быть сейчас лодка, исходя из их предположений о ее скорости. Число квадратных миль, которые надо прочесать, будет расти, как квадрат радиуса.
Идти через Ла-Манш под водой не получится: напорешься на какой-нибудь блокшип — старый корабль, затопленный бритами нарочно, чтобы здесь не ходили немецкие подводные лодки. Остается идти на поверхности, что к тому же значительно быстрее. Правда, возникает проблема самолетов. Самолеты ищут не саму лодку, маленькую и темную, а ее кильватерную струю. Струя белая и в спокойную погоду расходится на много километров. Сегодня за U-691 кильватерной струи не будет — вернее, будет, но она затеряется в случайном шуме куда более значительной амплитуды. Бишоф решает, что важнее пройти большее расстояние, нежели остаться незамеченным, поэтому поднимает лодку на поверхность и оттягивает дроссельную заслонку. Жуткий расход горючего; впрочем, его у U-691 на одиннадцать тысяч миль.
Примерно в полдень следующего дня U-691, борясь с жесточайшим штормом, пронзает Дуврский пролив и вырывается в Северное море. Она наверняка светится на всех радарных экранах Европы, но в такую погоду самолеты взлететь не могут.
— С вами хочет поговорить пленный Шафто, — докладывает Бек, вернувшийся на роль заместителя, как будто ничего не произошло. Война учит на многое закрывать глаза. Бишоф кивает.
Шафто заходит в кабину управления. С ним Роот в роли переводчика, духовного наставника и/или ироничного наблюдателя.
— Я знаю, куда мы можем отправиться, — говорит Шафто. Бишоф ошарашен. Он уже несколько дней не думает о том, чтобы куда-то отправиться. Концепция определенной цели практически выше его понимания.
— Какая... — Бишоф ищет слово, — трогательная забота.
Шафто пожимает плечами.
— Слышал, Дениц окунул тебя в дерьмо.
Бишоф с ходу оценивает народную мудрость американской деревенской метафоры.
— Да я и прежде был там. Только сейчас я стою на ногах а до этого был вниз головой.
Шафто смеется. Они теперь друзья-приятели.
— Есть карты Швеции?
Идейка кажется Бишофу хорошей, но несколько бредовой. Временно укрыться на нейтральной территории — отлично. Однако скорее всего напорешься на подводную скалу.
— Вот здесь есть бухта, возле этого поселка, — говорит Шафто. — Мы знаем глубины.
— Откуда?
— Сами ж ее и промеряли, бля, камнем на бечевке, месяца два назад.
— До того, как оказались на загадочной подводной лодке груженной золотом, или после? — спрашивает Бишоф.
— Незадолго до.
— Уместно ли мне спросить, как случилось, что рейдер морской пехоты США и капеллан австралийского экспедиционного корпуса проводили батиметрическую съемку в нейтральной Швеции?
Шафто не видит в вопросе ничего неуместного. После морфия у него отличное настроение. Он рассказывает очередную байку. Начинается она на норвежском берегу (сознательно не уточняется как они там оказались) и состоит в том, как Шафто вел Еноха Роота и еще человек двенадцать, в том числе одного с серьезной рубленой раной (Бишоф поднимает брови), на лыжах через всю Норвегию в Швецию, пачками отстреливая немецких преследователей. После того как с немцами покончено, рассказ утрачивает динамичность. Шафто видит, что Бишоф теряет интерес, и пытается оживить повествование. Он описывает, как развивается гангрена у офицера, не поладившего с топором (насколько может заключить Бишоф, в нем подозревают немецкого шпиона). Шафто уговаривает Роота рассказать, как тот последовательно ампутировал офицеру ногу до самого паха. Как раз когда Бишоф проникается искренним сочувствием к бедолаге, история совершает крутой поворот: отряд добирается до рыбачьего поселка на берегу Ботнического залива. Гангренозного офицера сдают на руки местному доктору. Шафто и его товарищи укрываются в лесу, где завязывают сложные отношения с финским контрабандистом и его дочерью. Теперь ясно, что Шафто добрался до любимой части рассказа, то есть до финской девушки. До сих пор его повествовательный стиль был груб, прост и функционален, как внутренность подводной лодки. Сейчас он улыбается, рассказ обрастает художественными подробностями. Несколько подводников, более или менее знающих английский, заинтересовавшись, подходят ближе. Рассказ окончательно сворачивает не в ту степь и, хотя сам по себе весьма занятен, решительно никуда не ведет. Наконец Бишоф перебивает: «А что раненый?» Шафто хмурится и прикусывает губу.
— Ах да, — говорит он наконец, — лейтенант умер.
— Камень на веревке, — подсказывает Енох Роот. — Помнишь? Ты с этого начал.
— Нас забрала маленькая субмарина. Так мы оказались на Йглме и увидели подлодку с золотом. Чтобы войти в бухту, нашим подводникам была нужна карта. Поэтому мы с лейтенантом Роотом с обычной лодки промерили глубины камнем.
— И карта у вас по-прежнему с собой? — скептически спрашивает Бишоф.
— Не-а, — отвечает Шафто с развязностью, которая могла бы взбесить, исходи она от человека менее обаятельного. — Однако лейтенант ее помнит. Он здорово запоминает цифры. Верно я говорю, сэр?
Енох скромно пожимает плечами.
Там, где я рос, единственным развлечением было запоминать число «пи».

Предыдущая страница 20


[i] Огл. 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20


%AuthorName%

На основную страницу

%Add_Title%

%Text%


%AuthorName% - Биография

%AuthorName%

На основную страницу

Биография

%Text%


%AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME] - %BookName%

%PageNumber% %AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME]

%Text%


%AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME] - %BookName%

Оглавление

%Text%


%AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME] - %BookName%

%PageNumber% %AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME]

%Text% [NAVIGATION]

[PREVIOUS_PAGE]Предыдущая страница [/PREVIOUS_PAGE]%PageNumber%[NEXT_PAGE] Следующая страница[/NEXT_PAGE]

[/NAVIGATION]


%AuthorName% - %BookName%

%AuthorName%
%SoAuthorName%

%BookName%

[SERIA]

Цикл: "%Seria%"[NUMBERINSERIA] - %NumberInSeria%[/NUMBERINSERIA]

[/SERIA] [TRANSLATION]
%Translate%

[/TRANSLATION] [ADD]
%Add_Title%

[/ADD] 		Читать книгу
[DISCRIPTION]

Аннотация

[/DISCRIPTION][BOOKCOVER] [image] [/BOOKCOVER] %Description%

[HEADER_FILE] Содержание [/HEADER_FILE] [BIOGRAPHY_FILE] Биография автора [/BIOGRAPHY_FILE]

[BOOK_CREATOR]Создание книги: %Book_Creator% [SITE_URL_OR_EMAIL] (%SiteName_or_Email%) [/SITE_URL_OR_EMAIL][/BOOK_CREATOR]
Программа: ChmBookCreator [SCANNED_BY]
Сканирование книги: %ScannedBy% [/SCANNED_BY] [READ_BY]
Исправление ошибок: %ReadBy% [/READ_BY] [SOURCE_FILE]
Файл взят с %Site_Url%[/SOURCE_FILE]
Над дизайном работали: Spider, Elfin, Angel


%AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME] - %BookName%

%BookName% %PageNumber%

%Text% [NAVIGATION]

[PREVIOUS_PAGE]Предыдущая страница [/PREVIOUS_PAGE]%PageNumber%[NEXT_PAGE] Следующая страница[/NEXT_PAGE]

[/NAVIGATION]


Оглавление

  • ПРОЛОГ (Страница 1)
  • ПУСТОШИ (Страница 1)
  • NOVUS ORDO SECLORUM (Страница 2)
  • ВОДОРОСЛЬ (Страница 2)
  • ОПЫТЫ (Страница 3)
  • ИНДИГО (Страница 3)
  • ПОТОМСТВО ОНАНА (Страница 4)
  • ГАРЬ (Страница 4)
  • ПЕШЕХОД (Страница 5)
  • ГАЛЕОН (Страница 5)
  • КОШМАР (Страница 6)
  • ЛОНДИНИУМ (Страница 6)
  • КОРРЕХИДОР (Страница 6)
  • ТУННЕЛЬ (Страница 7)
  • МЯСО (Страница 7)
  • ЦИКЛЫ (Страница 8)
  • НА ВЫСОТЕ (Страница 9)
  • НЕРАЗГЛАШЕНИЕ (Страница 9)
  • УЛЬТРА (Страница 10)
  • КИНАКУТА (Страница 10)
  • ЙГЛМСКИЙ ДВОРЕЦ (Страница 10)
  • «ЭЛЕКТРИКАЛ ТИЛЛ КОРПОРЕЙШН» (Страница 10)
  • КРИПТА (Страница 10)
  • ЯЩЕРИЦА (Страница 11)
  • ЗАМОК (Страница 11)
  • ЗАЧЕМ (Страница 12)
  • РЕТРОГРАДНЫЙ МАНЕВР (Страница 12)
  • ВЧРП (Страница 13)
  • СТРАНИЦЫ (Страница 13)
  • ТАРАН (Страница 13)
  • БДИТЕЛЬНОСТЬ (Страница 14)
  • СТРЕЛА (Страница 14)
  • МОРФИУМ (Страница 14)
  • КОСТЮМ (Страница 15)
  • ВЗЛОМЩИК (Страница 15)
  • СУЛТАН (Страница 15)
  • РИКОШЕТ (Страница 16)
  • ФОТОРОБОТ (Страница 16)
  • ЯМАМОТО (Страница 16)
  • АНТЕЙ (Страница 16)
  • ПЕРЕХВАТ (Страница 17)
  • ВПЛАВЬ (Страница 18)
  • ВАКСА (Страница 18)
  • НАПАДЕНИЕ (Страница 18)
  • ФУНКШПИЛЬ (Страница 19)
  • ППХ (Страница 19)
  • MORPHIUMSUCHTIG (Страница 20)


Нил Стивенсон

Криптономикон (часть 1)

 Читать книгу

Аннотация

Крипта. "Реальная" столица Сети. Рай хакеров. Кошмар корпораций и банков. "Враг номер один" всех мировых правительств. В сети нет ни стран, ни национальностей. Есть только свободные люди, готовые сражаться за свою свободу!..

Создание книги: maxx (http://smallweb.ru)
Программа: ChmBookCreator
Файл взят с http://www.oldmaglib.com/
Над дизайном работали: Spider, Elfin, Angel


Нил Стивенсон - Биография

Нил Стивенсон

На основную страницу

Биография

Нил Таун Стивенсон родился в Хэллоуин, 31 октября, 1959 года в Форт-Миде (штат Мериленд, США); отец его был профессором электротехники, а мать работала в биохимической лаборатории. Вырос в Иллинойсе и Айове, начинал учиться физике в Бостонском университете, но потом перешел на географическое отделение, мотивировав свой поступок тем, что "там круче компьютеры". Зарекомендовал себя способным программистом. С 1984 года живет в основном на Тихоокеанском побережье, пишет романы, время от времени публикует статьи в журналах. Нил Стивенсон - автор классического киберпанковского "Snow Crash", романов "The Diamond Age" (удостоен премии "Хьюго") и "Zodiac". Критики высоко оценивают Стивенсона за его почти провидческие прогнозы о развитии будущих технологий. Нил Стивенсон входит в число шести преподавателей, приглашенных Инновационным центром бизнеса Эрнста и Янга в Кембридже (Массачусетс).