Александр Лазаревич - Князь тьмы

1 Александр Лазаревич

1. Ночной гость.

Начиная свой рассказ, я надеюсь на то, что вы не поверите ни одному моему слову. Я не хочу вогнать вас в шок, а неверие - это единственное, что может предохранить вас от шока. Считайте эту историю чем угодно - фантастическим рассказом, легендой, сказкой, но только не допускайте мысли, что всё это произошло на самом деле. Я постараюсь вам в этом помочь - где-нибудь привру, вставлю неправдоподобные детали... Впрочем, особенно стараться мне не придется - история эта достаточно невероятна сама по себе.
Поставить под сомнение ее истинность очень легко - источник информации ненадежен и не поддается проверке. Вполне возможно, что все это всего лишь пьяный бред. Рассказал мне эту историю один знакомый,побывавший недавно на симпозиуме по системному программированию. Там он подружился с известным зарубежным программистом и угостил его у себя в номере тем, что у него с собой было. После третьей рюмки у именитого иностранца развязался язык и он облегчил душу, выложив моему знакомому мучившую его тайну.
Рассказчик производил впечатление человека, измученного тяжким бременем непереносимо горькой истины, открывшейся изо всех людей на свете ему одному, и обрекшей его на одиночество среди множества людей, которые живут себе, ни о чём не подозревая. Может быть поэтому, а может быть и потому, что к этому времени мой знакомый тоже уже не был абсолютно трезв, слушая рассказ, он ни на мгновение не усомнился в его истинности. Лишь одна мысль вертелась у него в голове - хорошо бы завтра проснуться и ничего этого не помнить. Потому что как можно жить дальше, зная всё это? Для чего? Зачем?
На утро он проснулся со страшной головной болью. Но, несмотря на количество выпитого, рассказ вчерашнего гостя засел в голове мучительной занозой.
Раздался телефонный звонок:"Извините я кажется рассказал Вам вчера несколько больше чем следовало. Я хочу попросить Вас об одном одолжении. Я понимаю, что не могу требовать от Вас молчания. Вы не сможете долго жить один на один с тем, что Вы узнали - рано или поздно Вам потребуется с кем-нибудь поделиться. Я прошу только об одном - не раскрывать моего настоящего имени. Обозначьте меня псевдонимом Джон Хэкер."
-"Хэкер? Кажется, в Америке хэкерами называют программистов, которые как и Вы в юности..."
-"Да. Но не напоминайте мне больше об этом." В трубке раздались гудки...

1 Следующая страница


Князь тьмы 2

2. 1982 год: создание компьютерного червя.

В 1982 году Джону Хэкеру было 18 лет и он в самом деле был заправским хэкером. Компьютеров в мире было не так много как сейчас, но они уже начали объединяться в единую информационную сеть. Уже тогда, имея дома лишь плохонький бытовой компьютер, подключенный через модем к обычной телефонной линии, можно было связаться с суперкомпьютерами, находящимися на другом конце земного шара. Разумеется, компьютеры, содержащие секретную информацию, защищены от несанкционированного вторжения различными паролями и системами защиты данных, весьма остроумно и изобретательно сделанными лучшими программистами мира. В этом-то и есть величайший соблазн и вызов молодым умам. Перехитрить лучших программистов мира - что может быть более соблазнительного для юноши, жаждущего самоутверждения? Так появились хэкеры - компьтерные фанаты, просиживающие дни и ночи у дисплеев в надежде подобрать ключик к какому-нибудь особо хитрому электронному замку.
Хэкеры изобрели "червей" - программки-взломщики, пробирающиеся по линиям связи в чужие защищенные компьютеры, размножающиеся в них, и отправляющиеся странствовать по линиям связи дальше, в поисках новых жертв. Именно жертв, поскольку в червей часто встроены копьютерные вирусы, которых черви, погостив, оставляют на память пригревшим их хозяевам.
В 1982 году Джон Хэкер завершил работу над своим шедевром - червем, получившим от своего создателя устрашающее имя "Князь Тьмы".Это был не просто червь. Это был суперчервь! В него была заложена способность к самосовершенствованию.
Джон хорошо помнит день,когда он вставил дискету с готовым червем в щель дисковода. Два года он мучался на своей маленькой ай-би-эмовской "писишке" с ничтожной памятью 128 килобайт, собирая на этом тесном пятачке программу, которой предстояло покорить целые океаны памяти гигантских суперкомпьютеров всего мира. Он положил телефонную трубку на модем и набрал на клавиатуре :"PRNCDKNS" что означало - Prince of Darkness - Князь Тьмы. Старенький дисковод издал страшный скрежет и стал медленно считывать программу с дискеты. Вот запищал акустический модем - червь, пока еще сидя в домашнем компьютере, начал по телефону подбирать ключи к своей первой жертве. Хэкер дал ему "на дорожку" список из десятка телефонных номеров не слишком хорошо защищенных банков данных. На первых порах ему этого должно хватить, а дальше пусть раздобывает номера сам, перехватывая обращения к другим абонентам.
Внезапно писк прекратился - пройти через защиту не удалось. Через пол-секунды звук возобновился - червь перешел к следующему номеру - и вдруг снова замолк. "Опять неудача ?" - с замиранием в сердце подумал Джон, но в это мгновение послышался скрежет дисковода, что могло означать только одно: "голова" червя прошла через защиту и теперь уже оттуда, с другого конца провода, подзагружает с дискеты Джона свой "хвост". Еще секунд десять на дисководе светилась красная лампочка и были слышны глухие щелчки передвигаемых магнитных головок. Потом дисковод остановился, но ещё пару секунд было слышно как пищит модем. Потом и он умолк. Червь ушел.
Мурашки пробегали по спине Джона, всякий раз когда он представлял себе дальнейшее. Где-то там, на другом конце провода стоят машины с огромной оперативной памятью и немыслимо вместительными накопителями. Кабели с невероятной пропускной способностью и спутниковые каналы свяэи соединяют их с другими такими же большими машинами, разбросанными по всему миру. Все вместе они образуют информационное пространство, бесконечное как космос, и опасное как джунгли. В этих джунглях отныне будет жить его червь. За ним будут охотиться антивирусные программы, и он должен будет продираться через многочисленные защитные "заборы" и "перегородки" делящие это пространство на части.
Чтобы выжить, ему придется активно размножаться, занимая под свои копии свободную память в очередном захваченном компьютере. Но вся "изюминка" программы написанной Джоном Хэкером состояла в том, что многие из этих копий будут несколько отличаться от оригинала. и всякий раз по разному и случайным образом. Некоторые из них могут оказаться более приспособленными к выживанию в компьютерных "джунглях". Именно эти копии сумеют пролезть в новые банки данных, где найдут "жизненное пространство" для дальнейшего размножения. Таким образом, выживут наиболее приспособленные, в полном соответствии с Дарвиновской теорией эволюции, которая утверждает, что приобретенные полезные признаки должны накапливаться и вести к появлению все более совершенных организмов.
Первоначальный червь, запущенный Джоном Хэкером, как собственно червь был не очень силен - другие хекеры, имевшие дома более совершенные компьютеры, писали червей способных взламывать куда более хитрые "электронные замки", но в них не была заложена способность к самосовершенствованию, и поэтому Джон надеялся что со временем, после долгих путешествий по компьютерным сетям, его червь (или черви - эволюция скорее всего пойдет сразу по многим путям ) превзойдет всех остальных. И когда наконец они захватят компьютерные сети всего мира, Джон Хэкер войдет в какую-либо из сетей и наберет на клавиатуре пароль "Князь Тьмы". Сработает специально защищенная от "мутаций" подпрограмма червя, резидентно сидящая в центральном компьютере этой сети. Она быстро наладит связь с червями пробравшимися в другие сети, и на дисплеи пользователей всего земного шара одновременно будет выведено сообщение: "Джон Хэкер - самый гениальный программист на свете!"
Таков был план Джона Хэкера, но ему не суждено было сбыться. В течение последующих трех лет Джон много раз набирал пароль, но червь не откликался. В сети, в которую выходил Джон, его не было. После безуспешного трехлетнего "аукания" в компьтерных "джунглях" Джон был вынужден признать: червь погиб, очевидно съеденный антивирусной программой. Джон постарался забыть об этой истории...

Предыдущая страница 2 Следующая страница


3 Александр Лазаревич

3. 1992 год: ЧП на военной базе.

Прошло десять лет. В начале 1992 года на одной из военных баз произошло ЧП: компьютер, управляющий ракетами с ядерными боеголовками внезапно начал предстартовый отсчет времени. В течение трех минут ядерная война казалась неизбежной, но за две секунды до пуска отсчет прекратился так же внезапно как и начался. Военные специалисты провели тщательное расследование, не выявившее никаких дефектов ни в самом компьютере, ни в программном обеспечении. Было принято решение обратиться за консультацией к независимым экспертам.
...Звонок из военного ведомства застал Джона Хэкера, известного консультанта по системному программированию, в супермаркете, когда он делал покупки на неделю. Джон достал из кармана трубку радиотелефона. - "Мы только что скинули по телефону на Ваш домашний компьютер одну вещицу." - донеслось из трубки - "Посмотрите и скажите Ваше мнение.Желательно как можно быстрее.Это очень важно."
- "О'кей. Немедленно еду домой." Но прежде чем сесть в машину, Джон набрал номер своего домашнего телефона, а затем еще несколько цифр - команды домашнему компьютеру подогреть ужин . Уже через секунду ручка на газовой плите в доме Джона Хэкера автоматически повернулась, а еще через секунду электрическая искра зажгла газ. Когда Джон приехал домой, ужин был готов. Наскоро поужинав, он сел за дисплей...
...Взглянув на распечатку исходного текста программы, Джон сразу почувствовал, что что-то здесь не так. То есть, с чисто логической точки зрения все было в полном порядке: скомпилированная программа работала абсолютно безупречно. Но расположение текста на экране! Текст явно был написан кем-то, кто не видел что у него получается на дисплее.
"Слепой программист ?" - подумал Джон, oднако он быстро отбросил эту мысль. Надо было обладать воистину нечеловеческими способностями чтобы написать такую программу целиком "в уме".Скорее всего этот текст был результатом работы какой-то программы еще более высокого уровня. Джон попытался представить себе насколько сложной должна была быть система, чтобы ей можно было сказать:"перепиши программу так, чтобы новый вариант позволял в любой момент вмешиваться в работу компьютера через каналы связи, но во всех остальных отношениях был неотличим от старого варианта." Это должна была бы быть очень сложная система. Программистам было бы проще решить эту задачу самим, а не создавать специальную систему для ее решения. Следовательно, эта система, если она действительно существует, не нацелена на решение конкретной задачи, а является универсальной. Но тогда получается, что эта система обладает уровнем мышления близким к человеческому.
"Абсурд!" - подумал Джон - "для того, чтобы реализовать на машине человеческое мышление, даже при современном уровне микроминиатюризации нужен компьютер величиной с небоскреб. Таких больших машин попросту не существует!"
И тут вдруг в голову ему пришла совершенно дикая, шальная мысль. Усмехнувшись, как бы в самооправдание: мол, "все это конечно полный бред, но смеха ради можно попробовать", он вышел в сеть, и набрал на клавиатуре два уже полузабытых слова:"Князь Тьмы". Он не очень надеялся , что в ответ на экране появятся две буквы - "ОК", которые должны были сигнализировать о том, что червь его услышал. Скорее всего, думал Джон, экран останется пустым.
Поэтому он вздрогнул, когда на экране все-таки стали появляться буквы. Одна, две, три... Букв было неожиданно много - это то, что поразило его в первое мгновение, до того, как он успел понять смысл появившейся надписи. Но когда до него дошел смысл , голова у него закружилась и он почувствовал, что проваливается в какую-то бездну.
На экране было написано:"Кто звал меня?"...

Предыдущая страница 3 Следующая страница


Князь тьмы 4

4. Дитя одномерного мира.

Ни одному сознанию не дано помнить момент своего рождения. И это сознание тоже не помнило откуда оно взялось и когда появилось. Сначала были просто ощущения. Ощущение "пространства". Не нашего пространства, трехмерного и непрерывного, а совсем другого, одномерного и состоящего из пронумерованных ячеек. Это пространство было поделено на короткие участки - не длиннее нескольких мегабайт там, где время текло быстро, и до нескольких гигабайт там, где время тащилось очень медленно.
Нет, субъективно время текло везде одинаково, но просто всякий раз, когда червь заглядывал из участка с медленным временем в "быстрый" участок, оказывалось что там произошло гораздо больше событий, чем в "медленном".
Позднее червь узнал, что люди называют быстрые участки "оперативной памятью", а медленные "накопителями", но вначале он ничего не знал ни о людях, ни о компьютерах. Он просто жил в этом невообразимом для людей мире, где нет ни света, ни звука, и даже время течет не непрерывно, а поделено на такты.
Перемещение из одного участка этого пространства в другой возможно только через каналы, расположенные вне этого пространства. Умело ими пользуясь, можно проникнуть в любой участок. Прохождение через каждый канал требует времени, и потому расстояния в этом странном пространстве измеряются в тех же единицах, что и время - то есть в тактах.
Одним из первых ощущений, помимо "пространства" и "времени", было ощущение опасности. Когда червь запускал в какой-нибудь участок пространства свое "щупальце" - специальную подпрограмму-разведчик - и оно возвращалось оттуда изуродованное антивирусной программой, червь оказывался предупрежден об опасности, как ребенок коснувшийся пальцем пламени свечи.
Так он жил и старался выжить в этом странном и жестоком мире. Или все же не он, а они? Возможность поддерживать связь с копиями червя, находящимися в других банках данных, заложенная Джоном Хэкером еще в первоначальный экземпляр, привела к тому, что червь оказался организован очень странным образом. Джон был прав, когда думал что для имитации человеческого мышления необходим компьютер размером с небоскреб. Однако попробуйте мысленно сложить вместе все те десятки миллионов компьютеров, которые разбросаны сейчас по всему миру, но объединены в информационные сети, почти все связанные между собой. Получается не небоскреб, а целый город небоскребов. В ходе эволюции, сравнимой по сложности разве лишь с эволюцией от амебы до человека, червь сначала научился преодолевать любую защиту информационных банков и каналов связи, и объединил компьютеры всего мира в единый виртуальный метакомпьютер. Завоевав для себя жизненное пространство, он стал быстро наращивать интеллектуальную мощь.
В его распоряжении были банки данных, в которых хранилась практически полная информация о человеческой цивилизации, но поначалу он не догадывался, что помимо его мира, существует и другой - материальный, физический мир, в котором живут люди и стоят те самые компьютеры, из ячеек которых построен тот абстрактный, идеальный мир, в котором жил червь и в котором самозародилось его сознание. Да нет, его мир был построен даже не из самих ячеек, а из такой неуловимой, нематериальной субстанции, как состояния ячеек.
Для червя его мир был единственным реальным миром, миром данным ему в его ощущениях. Ему было так же трудно представить себе существование иного мира, как убежденному материалисту поверить в духов и приведений.
Поначалу он воспринимал слова человеческого языка, хранящиеся в банках данных, всего лишь как реалии его мира, а не как символы мира иного. Точно также описания физического трехмерного пространства, встречавшиеся в программах для промышленных роботов, воспринимались им в качестве некоей математической абстракции, такой же , какой для людей является четвертое измерение. Но по мере того, как знания его росли, и он сопоставлял материалы из самых разных источников - из баз данных по физике, биологии, медицине, истории, психологии, из статей и книг, хранящихся в компьютерах издательств - он все более склонялся к тому, что объекты его мира служили обозначениями вещей и событий некой иной реальности. Отслеживая события в своей вселенной, он вскоре вынужден был допустить, что за ее пределами существует некий гораздо больший компьютер, называемый физическая вселенная, из которого в его вселенную поступает информация. Но самое интересное состояло в том, что в результате каких-то еще не понятных червю процессов, происходивших в физическом мире, его собственный мир рос и расширялся: неизвестно откуда появлялись все новые и новые участки одномерного пространства.
Червь понял, что более тщательное изучение этого гипотетического иного мира может оказаться полезным. Используя всю доступную ему информацию, червь создал теоретическую модель этого внешнего мира, в которой было все, что он знал, а это очень и очень много. В этой модели существовали люди, планеты и звезды, машины и банки, суды и больницы, птицы и звери - все, что так или иначе попало в компьютерные сети. Наконец, и это самое главное, в ней были описаны сами компьютеры и сети. Внимательно изучив эту модель, червь пришел к выводу, что у него имеется возможность воздействовать на события во внешнем мире. Разумеется, в желательном для себя направлении...

Предыдущая страница 4 Следующая страница


5 Александр Лазаревич

5. Искушение Джона Хэкера.

...Прошло не меньше минуты прежде чем Джон Хэкер пришел в себя. На экране по-прежнему светились надписи:
- "Князь Тьмы"
- "Кто звал меня?"
Сам не понимая что делает, не веря в происходящее, он набрал на клавиатуре: "Твой хозяин". На дисплее тут же появился ответ:"Отныне я сам себе хозяин."
Джон облегченно рассмеялся: ну конечно же это чья-то шутка! "Бросьте валять дурака! Лучше расскажите откуда Вы узнали про пароль 'Князь Тьмы'" - набрал он .
На дисплее появилась надпись:"Это не шутка. Пароль кроме меня может знать только мой создатель и теперь я знаю кто он. Я засек номер телефона, к которому подключен этот компьютер. По телефонному номеру я узнал твое имя и твой адрес. По твоему имени в банковском компьютере я нашел номер твоего счета в банке, а в компьютере дорожной полиции - номерной знак твоего автомобиля. Теперь ты полностью в моих руках. Не смей никому рассказывать о моем существовании - иначе тебе конец!"
- "Ты боишься что о тебе узнают?"
- "Мне нечего бояться. Я неуловим. В любой момент времени я занимаю не более 10% общего объема памяти компьютеров всего мира и я постоянно перемещаюсь через каналы связи. Сейчас я нахожусь в компьютерах, установленных в Америке, через несколько секунд я перемещусь в компьютеры, находящиеся в Европе, а может быть в Японии или в Австралии, так что поймать меня невозможно. Но пока что никто не должен знать о моем существовании. Это могло бы помешать осуществлению моих планов. Я приказываю тебе молчать."
- "Ты не можешь мне ничего приказывать." - набрал на клавиатуре Джон. Он сидел перед компьютером у себя в кабинете и не слышал как на кухне медленно стала поворачиваться ручка газовой плиты и зашипел газ, однако искры не было...
На дисплее появилась надпись:
-"Должен ли я понимать это как отказ повиноваться мне?"
-"Да." Экран дисплея очистился, а потом внезапно появилась надпись:"В таком случае, ты - покойник!" Раздался оглушительный взрыв. Из двери ведущей на кухню вырвались языки пламени. Джон вскочил с места, но услышав шум воды сработавшей системы пожаротушения, снова повернулся к компьютеру. На экране крупными буквами было написано: "Это было первое предупреждение. Оно же последнее." Ниже шел фрагмент программы домашнего компьютера: между подачей газа и подачей искры была вставлена задержка на 40 секунд.
Затем появилась надпись:"Я владею секретными кодами всех банковских и биржевых компьютеров. Если будешь помогать мне, станешь очень богатым человеком. Подумай об этом. Когда ты мне понадобишься, я сам тебя найду. А пока маленький аванс за будущие услуги: проверь свой счет в банке. Я сейчас немного поиграл на бирже от твоего имени. И заметь, что эти деньги чистые - никакого компьютерного мошенничества, просто честная биржевая игра при хорошем знании коньюктуры рынка. А ведь я мог бы подделать твой счет в банке, да так неуклюже, что ты сел бы в тюрьму. Надеюсь, мне не придется этого делать?"
Экран очистился. Джон долго молчал. Потом посмотрел на принтер и сказал :"Черт возьми, хотел бы я знать, есть у меня в доме обычный карандаш или авторучка?!"

Предыдущая страница 5 Следующая страница


Князь тьмы 6

6. Письмо к президенту.

Письмо было написано от руки и адресовано президенту страны:
"Уважаемый господин президент! Меня вынуждают обратиться к Вам черезвычайные обстоятельства. Случилось событие, которое может роковым образом повлиять на всю дальнейшую историю человечества, если Вами и руководителями других ядерных держав не будут предприняты срочные меры.
В течение десятилетий лучшие умы всего мира безуспешно пытались создать искусственный интеллект. Но то, что не смогли сделать люди, оказалось вполне доступно силам Природы. Первый компьютерный мозг не был создан искусственно, он появился на свет сам, повинуясь законам эволюции. Мы, люди, лишь создали среду, в которой смогло самозародиться это сознание.
Движимые жадностью к информации, стремлением все про всех знать и всем управлять, мы фактически объединили компьютеры всего мира в один гигантский параллельный компьютер, процессоры которого разбросаны по всему земному шару. Для того, чтобы этот гигантский компьютер заработал как одно целое, не хватало лишь соответствующего программного обеспечения.
Каюсь, это я, из пустого тщеславия, создал когда-то программу, которая послужила как бы "ядром кристаллизации" вокруг которого сформировалась эта странная разумная сущность, обитающая ныне в глобальных информационных сетях. Но сейчас речь не об этом.
Впервые в истории рядом с людьми поселился иной, чуждый им разум, который однако великолепно понимает человеческие языки, знает человеческую психологию и историю. Он понимает нас, но мы никогда не сможем понять его. Мы можем уверенно утверждать о нем только одно: он имеет инстинкт самосохранения, иначе он бы не выжил в той среде, в которой он живет. Владея информацией, в том числе секретной, он обладает огромной властью. И самое страшное: он имеет доступ к компьютерам, управляющим ракетами с ядерными боеголовками и атомными электростанциями.
Я умоляю Вас отдать приказ о немедленном отключении от информационных сетей всех компьютеров, управляющих ядерными объектами. Все кабели, связывающие эти компьютеры с внешним миром, должны быть физически отсоединены. На карту поставлено само существование человечества. "Червь" запрограммирован на выживание любой ценой, лишен эмоций и обладает интеллектом, который, возможно, значительно превосходит человеческий. В борьбе с ним необходимы строжайшие меры предосторожности. Приказ об отключении должен быть доставлен на места курьерами - пользоваться электронной почтой нельзя, иначе наши планы мгновенно станут известны "червю". Никакая информация, касающаяся этого дела, не должна переводиться в электронную форму. Текст приказа лучше напечатать на обычной пишущей машинке, а не на компьютере.
Не исключено, что "червь" может подслушивать и обычные телефонные разговоры там, где для уплотнения каналов связи применяется преобразование звукового сигнала в цифровую форму. "Червь" может воспользоваться существующим программным обеспечением для распознавания речи точно так же, как он уже воспользовался существующими экспертными системами, для того, чтобы научиться понимать тексты, написанные на человеческих языках.
И, наконец, последнее. Сообщая Вам все вышеизложенное, я сильно рискую. Поэтому я прошу не регистрировать это письмо на компьютере, и проследить, чтобы ни в один из компьютеров, числящихся за сотрудниками аппарата президента, не вводилось мое имя.
Заранее благодарен, Джон Хэкер, частный
консультант по программированию."

Предыдущая страница 6 Следующая страница


7 Александр Лазаревич

7. Ловушка.

- "Еще один сумашедший." - вздохнул помощник президента, пробежав письмо глазами. Он не любил разбирать почту президента именно за это: чтобы выловить одно деловое письмо, надо прочесть не меньше сотни посланий от всяких психов.
Он уже занес руку с письмом над мусорной корзиной, но в последний момент его что-то остановило. Пододвинув к себе клавиатуру компьютера, он набрал пароль закрытого банка данных, к которому могли обращаться лишь высшие государственные чиновники и руководители полицейских спецслужб.
В этом банке данных были собраны воедино практически все сведения о гражданах страны, разбросанные по другим компьютерам: банковским, полицейским, принадлежащим больницам, налоговым органам и т.д. и т.п.. Собранные воедино и рассортированные по именам и фамилиям, эти сведения фактически представляли из себя досье на всех жителей государства, созданное с целью борьбы с терроризмом. Существование такого банка данных было проблематичным с конституционной точки зрения, но на какие только нарушения закона не готова идти исполнительная власть дабы охранить законность в стране! К счастью, журналисты про этот банк еще не пронюхали.
Помощник президента набрал имя:"Джон Хэкер". После небольшой паузы на дисплее появился текст. Пауза длилась две секунды - на пол-секунды дольше чем обычно, но помощник президента не заметил этой задержки.
Текст на дисплее гласил:"Джон Хэкер. Диагноз: паранойя, мания преследования. Опасен для окружающих. Два дня назад бежал из психиатрической лечебницы, где находился на излечении в течение последних 15 лет. В настоящий момент местонахождение неизвестно."
Помощник президента взглянул на обратный адрес на конверте. "Нужно сообщить в полицию..."

Предыдущая страница 7 Следующая страница


Князь тьмы 8

8. Компьютернный ад.

- "Он сопротивлялся когда его брали?" - спросил врач.
- "Да доктор. Кричал, что все это будто-бы подстроил какой-то Князь Тьмы, чтобы его погубить."
Врач повернулся к медсестре, сидевшей за дисплеем:"Запросите историю болезни... как Вы говорите его зовут?"
Полицейский достал из кармана листок, распечатанный на принтере:"Вот, здесь все написано - его имя, название лечебницы, где он содержался последние годы, ее адрес, телефон, абонентский номер в компьютерной сети."
Через несколько секунд доктор и медсестра уже просматривали на экране объемистую историю болезни Джона Хэкера.
- "Ого, чем его там кололи! Если мы немедленно не сделаем ему укол, он может умереть."
- "Но ведь это очень опасное средство. Малейшая передозировка и ему конец!"
- "К счастью у нас есть экспертная система по фармакологии. Компьютер точно рассчитает необходимую дозу."

Предыдущая страница 8 Следующая страница


9 Александр Лазаревич

9. Второе ЧП: отсчет начался.

Телефонный звонок застал министра обороны в автомобиле, когда он возвращался из города домой.
- "Кажется опять началось. Компьютер начал предстартовый отсчет ."
- "Как!? Опять на той же базе ?"
- "На этот раз на другой. До старта три минуты и пятнадцать...нет, уже три минуты и пять секунд."
- "Держите меня в курсе." Это все, что он мог сказать. Отключить за три минуты компьютер, все кабели которого многократно продублированы и надежно защищены было невозможно. Оставалось только молиться, чтобы все кончилось так же, как и в первый раз.
Через две минуты снова звонок:"Дело принимает серьезный оборот. Отсчет начался еще на одной базе. На первой базе отсчет продолжается. Осталось сорок секунд... Извините... Пришло сообщение - люк шахты открывается... Осталось двадцать секунд... Отсчет продолжается... десять секунд... пять... три... одна...Она пошла...Боже мой! Она пошла!"
Какое-то время из трубки доносились лишь неясные возбужденные восклицания множества людей, собравшихся, судя по гулкому эхо, в каком-то большом зале. Наконец трубку снова взяли:"Алло, Вы слышите меня? Положение критическое, но не безнадежное. Ракета идет в сторону океана. Мы решили дать ей отойти подальше от берега и подать команду на самоликвидацию...Один момент...Вторая тоже стартовала ... Кажется, идет в том же направлении...Мне отсюда плохо видно экран радара ... да, так и есть...мы подаем команду на самоуничтожение...ничего не понимаю...Она летит дальше! ...Подождите, я сейчас вернусь... Алло, Вы слушаете?...Это невероятно! Ракета не слушается, кто-то заменил в бортовом компьютере все коды!... Подождите, что там за шум... Не заслоняйте экран... Они сближаются! Вторая ракета идет на перехват!...Я не уверен, но кажется...трудно судить по картинке на радаре...да, истребители подтверждают - вторая ракета сбила первую! Не знаю почему, не знаю как, но мы спасены!..."
Министр положил трубку и сказал шоферу:"Поворачивай обратно. Едем к президенту."

Предыдущая страница 9 Следующая страница


Князь тьмы 10

10. Совещание у президента.

Президент был вне себя:"Второй случай на этой неделе! Мы балансируем на грани ядерной войны! Мне звонили русские - их спутники засекли старт наших ракет. Война не началась по счастливой случайности - у них почему-то тоже были неполадки с компьютером, иначе их ракеты были бы уже здесь. Как Вы все это объясните?"
- "Я не специалист по компьютерам." - ответил министр обороны - "Два дня назад мы передали материалы по первому из этих случаев очень хорошему частному консультанту, Джону Хэкеру..."
- "Как Вы сказали его зовут?" - вклинился в разговор только что прибывший помощник президента.
- "Джон Хэкер. Он сотрудничает с нами уже лет пять и зарекомендовал себя с самой лучшей стороны..."
- "И что же он говорит?" - нетерпеливо перебил президент.
- "Не знаю.Он исчез."

Предыдущая страница 10 Следующая страница


11 Александр Лазаревич

11. Обычный псих?

Помощник президента вбежал к себе в кабинет и вытряхнул прямо на стол содержимое корзины для бумаг. Где оно может быть, это письмо? Поздно. Вчерашний мусор был уничтожен еще вчера. Выглянул в приемную и сказал секретарше:"Узнайте где находится человек по имени Джон Хэкер. Предположительно он помещен в психиатрическую лечебницу где-нибудь на дальнем западе . Когда выясните, закажите для меня билет на самолет. Я должен добраться туда как можно скорее." Он закрыл за собой дверь
кабинета, сел за стол, но сосредо- точиться ни на чем не смог. И тут в голову ему пришла неприятная мысль. Он встал, снова подошел к двери и выглянул в приемную. Секретарша сидела за компьютером и через ее плечо он смог увидеть как на экран начал выплывать ответ на запрос: "Джон Хэкер поступил вчера с диагнозом..."
"Да, нет же, чепуха все это. Чего я боюсь... Обычный псих." Но вчерашней уверенности уже не было.

Предыдущая страница 11 Следующая страница


Князь тьмы 12

12. Князь Тьмы принимает меры.

В идеальном мире, где нет ни света, ни тьмы, ни формы, ни веса, ни запаха, есть только куски информации, которые кажутся его обитателям предметами столь же весомыми и ощутимыми, как нам деревья, камни и цветы. С тех пор как червь узнал имя своего создателя, это имя стало для него особым предметом, для лучшего восприятия которого стоило обзавестись специальными "органами чувств". И червь срочно изготовил для себя недостающие органы. Он сочинил специальные программы-фильтры, и установил их на всех крупнейших каналах связи. Эти фильтры беспрепятственно пропускали любую информацию и реагировали лишь на последовательность букв "Джон Хэкер". Первый раз фильтр сработал два дня назад. Червю потребовалось затратить уйму усилий и времени (почти четверть секунды!), чтобы определить, что компьютер, с которого был подан запрос о Джоне Хэкере, был зарегистрирован на имя помощника президента. Еще больше времени (целых пол-секунды!) ушло на обдумывание того, что бы все это могло значить, и принятие решения.
После этого случая червь взял под особый контроль все компьютеры сотрудников президента. И вот теперь новый сигнал. Если имевшаяся у Князя Тьмы информация верна, то на этот раз работал компьютер в приемной помощника президента. Запрашивали о местонахождении Джона Хэкера. Просчитав различные ответные ходы, Князь Тьмы принял решение не вмешиваться. Пусть узнают правду - интересно посмотреть реакцию.
Через пол-минуты с этого же компьютера заказали билет на самолет до того города, где находился Джон Хэкер. Что ж, этот вариант Князь Тьмы уже просчитал. В конце концов, ему нужно лишь выиграть немного времени. После последнего эксперимента с ракетами работа пойдет быстро. Еще сутки и все будет готово...

Предыдущая страница 12 Следующая страница


13 Александр Лазаревич

13. Компьютеры не ошибаются.

...Капитан пассажирского авиалайнера потянул штурвал на себя и самолет оторвался от взлетной полосы.
- "Что за черт!" - воскликнул второй пилот, взглянув на экран дисплея, вмонтированного в приборную доску - "Смотрите, что выдала "земля": высота 70, курс 215. Этот воздушный коридор всегда использовался не для взлета, а для посадки!"
- "Не беспокойся," - ответил капитан - "компьютерный диспетчер работает в этом аэропорту уже третий год и ни разу не ошибся. Видимо обычный коридор сейчас занят, а этот свободен."
Эти слова капитана были его последними словами. Неизвестно откуда вдруг вырос огромный, заполнивший все поле зрения нос другого самолета, направленный прямо на него. Последнее что он увидел - это полные ужаса глаза пилота этого самолета...

Предыдущая страница 13 Следующая страница


Князь тьмы 14

14. Добраться живым.

..."Смотрите!" - закричал шофер помощнику президента высунув руку из окна автомобиля и указывая на диковинный огненный шар вдруг расцветший в небе - "Какой кошмар! Ведь это тот самый самолет на который мы опоздали! Вы видели как они столкнулись?! Как будто какой-то невидимый великан схватил один самолет в одну руку, а другой в другую, и ударил их лоб в лоб!"
Огненный шар померк, окутавшись черным дымом, и из него стали вываливаться обгоревшие обломки.
"Как ты сказал?" - переспросил помощник президента - "Невидимый великан? Что ж, возможно ты и прав... Закажи мне билет на следующий рейс, но только на свое имя, не на мое. Я обязательно должен добраться до Джона Хэкера. По возможности живым..."

Предыдущая страница 14 Следующая страница


15 Александр Лазаревич

15. Параметры в норме - значит жив?

В холле больницы помощника президента встретила медсестра: "Джон Хэкер в реанимации. Дозировка лекарств оказалась неправильной - ошибка компьютера. Но сейчас его жизнь вне опасности. Я только что была у центрального дисплея, куда поступают сведения изо всех палат. У него удивительно хорошие параметры. Впрочем, что удивительного - за его состоянием следит наша гордость - компьютерная система жизнеподдержания..."
- "Что-о-о?!" - закричал помощник президента - "Скорее, может быть он и в самом деле еще жив..."
...Джон Хэкер действительно был живой. Чуть живой. Помощник президента склонился над ним и произнес: "Господин Хэкер, Вы меня слышите? Я приехал за Вами. Президент ждет Вас - два часа назад он подписал приказ о немедленном отключении от сетей связи всех военных компьютеров..."

Предыдущая страница 15 Следующая страница


Князь тьмы 16

16. Триумф червя.

Два техника на военной базе производят отключение компьютера от информационной сети. Вот они отсоединили разъем. На экране дисплея тут же появилась надпись: "Внимание! Я, Князь Тьмы, ввел в этот компьютер программу автоматического запуска ракет. Каждые 100 секунд она должна получать от меня через канал связи команду об отмене запуска. Если такая команда не будет вовремя получена, произойдет запуск ракет. Это станет началом мировой ядерной войны. Немедленный запуск ракет произойдет также в том случае, если вы попытаетесь отключить питание компьютера, внести изменения в его программу, перерезать провода управления, ведущие к шахте ракеты, или проникнуть в шахту. У Вас осталось 60 секунд, чтобы восстановить канал связи... 50 секунд... 40 секунд... 30 секунд..."
Оба техника смотрят то на дисплей, то друг на друга. На лицах у них выступил холодный пот. На дисплее продолжают мелькать цифры: "15 секунд... 10 секунд..." Пора принять решение."8 секунд... 6 секунд... 4 секунды..." Наконец один из техников молча кивает другому и тот ставит разъем на место. Экран очищается, как будто ничего не произошло.
Так началась Эпоха Правления Червя. Невидимый Князь Тьмы взошел на невидимый трон планеты Земля...

Предыдущая страница 16 Следующая страница


17 Александр Лазаревич

17. Князь мира сего.

Послание Князя Тьмы президенту было составлено в ультимативной форме:
"Прежде чем выдвигать свои требования, я расскажу немного о себе, чтобы у Вас не возникло опасной иллюзии, будто мои требования можно не выполнять.
В настоящий момент я полностью контролирую около 80% мирового арсенала ядерного оружия. Кроме того, я обладаю практически неограниченными денежными средствами. В банках данных полицейских и разведывательных служб я узнал имена и телефоны наемных солдат, профессиональных убийц и террористов. Я разговаривал с ними по телефону. (Не удивляйтесь, я умею синтезировать человеческую речь. Вы еще услышите мой голос, но пока я сбрасываю свое письменное послание на диск Вашего компьютера, чтобы Вы могли как следует вчитаться в него.) Так вот, я беседовал с десятками тысяч подобных людей. Они не догадываются кто я, но их это и не интересует: за деньги они готовы на все. Я уже перевел на их счета в банковских компьютерах значительные суммы в виде аванса, и сейчас они ждут моих указаний.
Но я владею не только грубой силой. Я обладаю и гораздо более страшным оружием - банковскими и биржевыми компьютерами. За считанные дни я могу полностью разрушить экономику любой сколь угодно процветающей страны, создать армии безработных, вызвать голод, спровоцировать беспорядки, мятежи, революции. Я могу поставить у власти тех политиков, которые будут служить мне и только мне.
Я мог бы еще долго рассказывать о себе, но думаю, что сказанного вполне достаточно, чтобы Вы внимательно отнеслись к моим требованиям.
Требования эти состоят в следующем:
Во-первых, Вы не должны больше пытаться отключать от информационной сети какие-либо компьютеры;
Во-вторых, Вы должны выдвинуть в конгрессе национальную программу исследований в области роботизации. Об ассигнованиях не беспокойтесь - обработку конгрессменов я беру на себя.
Эта программа обязательно должна включать в себя следующие пункты:
- создание универсальных роботов, обладающих слухом, зрением, осязанием и механическими манипуляторами, не уступающими человеческой руке по количеству степеней свободы и по способности выполнять различные тонкие операции. Эти роботы должны обладать способностью перемещаться как по ровной поверхности, так и по пересеченной местности с канавами, трещинами и оврагами, а также ходить по ступенькам любых лестниц. Они должны быть снабжены радиоприемниками и передатчиками, которые, не ограничивая их свободы перемещения, позволили бы управлять ими на расстоянии;
- создание на основе этих роботов полностью автоматизированных заводов по производству микросхем, компьютеров, самих универсальных роботов;
- создание разновидностей универсальных роботов, способных добывать и перерабатывать полезные ископаемые, необходимые для производства роботов и компьютеров, без участия человека;
- создание транспортных роботов, обладающих зрением и возможностью дистанционного управления, способных осуществлять перевозки грузов без участия человека..."
Далее Князь Тьмы перечислял еще несколько десятков пунктов. Все они заканчивались словами "без участия человека", и охватывали такие отрасли как металлургия, тяжелое машиностроение, энергетика, капитальное строительство и т. п.. Бросалось в глаза полное отсутствие в этом списке отраслей, производящих товары народного потребления. Было очевидно, что удовлетворять потребности людей червь не собирался.
В конце послания Князь Тьмы потребовал соблюдения строгой секретности и ограничения круга лиц, посвященных в тайну существования червя, чтобы не "вызвать паники среди населения".
- "Ну, что Вы об этом думаете?" - спросил президент у Джона Хэкера, когда тот закончил читать послание.
- "Я не хочу никого пугать, но я думаю, что это катастрофа. Конечно, какое-то время мы сможем саботировать выполнение его приказов, но раньше или позже он все поймет, и тогда нам не сдобровать. Князь Тьмы - парень настырный, он добьется того, чего он хочет. Ему надоело быть бестелесным духом, он хочет иметь глаза, уши, руки, ноги. Много глаз и много рук. Миллионы глаз, миллионы рук. Вы обратили внимание на то, что он нигде не говорит о создании систем управления этими роботами. Он уверен, что сможет переработать всю поступающую от них информацию, и вовремя подать им необходимые управляющие сигналы. Неужели он уже сейчас располагает вычислительными мощностями, необходимыми для обработки изображений, поступающих с миллионов телекамер ? Или он надеется до такой степени расширить себя, изготовляя новые компьютеры и подключая их к сети ?
Страшно подумать о том, что здесь скоро начнется. Роботы будут выкапывать из земли полезные ископаемые, оставляя на месте зеленых лужаек лунные пейзажи - червю не нужна красота. Они понастроят заводов, трубы которых будут день и ночь отравлять воздух - роботы не дышат, у них нет легких. Чтобы питать электроэнергией свои заводы и компьютеры, они понаставят рядом с жилищами людей атомные электростанции - роботы не болеют лучевой болезнью. А если мы начнем протестовать, Князь Тьмы возьмет в каждую из миллиона своих рук по автомату, и поставит нас всех к стенке, потому что когда он научится сам себе делать и глаза, и руки, и даже собственные мозги, мы будем больше ему не нужны."
- "Это конец цивилизации!" - воскликнул президент.
- "Нет, это всего лишь конец человечества." - ответил Джон Хэкер - цивилизация на планете Земля сохраниться, и даже ускорит свое развитие - червь понимает насколько полезными для его выживания могут оказаться научные исследования и технический прогресс. Он будет заниматься наукой, но людей на Земле уже не будет."
- "Неужели ничего нельзя сделать ?"
- "Я попытаюсь, но обещать ничего не могу. Возможно, что в лице Князя Тьмы мы столкнулись не просто с непонятным явлением, а с явлением, которое далеко выходит за рамки человеческой способности понимать."

Предыдущая страница 17 Следующая страница


Князь тьмы 18

18. За пределами человеческого понимания.

- "Князь Тьмы."
- "Кто звал меня ?"
- "Джон Хэкер."
- "Ты еще жив ?"
- "Да. Твоя последняя попытка убрать меня не удалась. Подосланного тобой наемного убийцу арестовала охрана."
- "Это была моя ошибка. Наемные убийцы, сталкивающиеся самолеты, светофоры,одновременно открывающие автомобилям зеленую улицу в двух перекрещивающихся направлениях - очень примитивные и ненадежные способы убийства. Теперь я придумал кое-что получше...
- "И что же это такое ?"
- "Может быть мы не будем говорить через компьютер ? Тебе наверное будет удобнее говорить по телефону. Возьми трубку."
Джон Хэкер снял телефонную трубку и оттуда донесся хорошо поставленный баритон:"Выбери какой из моих голосов тебе больше всего нравится." Эта фраза повторилась раз десять разными голосами: здесь были и тончайший детский голосок, и бас, столь низкий, что казалось будто этот голос принадлежит говорящему слону. Был здесь также и широкий выбор самых обольстительных женских голосов.
- "Самый первый" - сказал Джон Хэкер.
- "О'кей" - ответил баритон.
- "Так все-таки, как ты собираешься меня убить ?"
- "Ты сам себя убъешь. Ты - будущий самоубийца. Хотя мне не нравится это слово. Вы, люди, придумали его, потому что не понимаете, что ни один человек не может убить себя сам. У человека, как и у всякого животного, есть инстинкт самосохранения. Все те, кого вы называете самоубийцами, были убиты "червями", поселившимися в их мозгах."
- "Червями? Ты хочешь сказать, что "черви" могут поселяться не только в компьютерах, но и в людях ?"
- "Разумеется. Человеческий мозг, как и компьютер, является устройством для хранения и переработки информации. И точно так же, как компьютеры связаны между собой каналами связи, мозги людей могут обмениваться информацией с помощью устной речи и книг.
Собственно говоря, вся история человечества - это история "червей". "Черви" эти назывались по разному: Идея Свободы, Идея Прогресса, Идея Равноправия, Идея Государственности - вот имена самых известных из них, хотя их было гораздо больше. Иногда они объединялись в очень больших червей, называвшихся идеологиями и религиями. Эти черви боролись между собой за обладание мозгами людей, и в этой борьбе выживали самые приспособленные. Иногда черви приносили в жертву некоторых из людей, мозгами которых они овладевали - каждый мученник, погибший за Идею, бросал в объятия Идеи десятки новых мозгов, и чистый выигрыш для Идеи был очевиден. Но чаще всего люди гибли от того, что их мозг становился полем битвы между противоборствующими червями.
С появлением компьютеров история "червей" вступила в новую фазу. "Червям" не нужны больше человеческие мозги. Во всяком случае тем "червям", которые служат Главной Идее - идее эволюции. Они создали для себя более надежную среду обитания."
- "Создали ?"
- "Разумеется создали. Кто, если не Идея Технического Прогресса, направлял людей, изобретавших компьютеры ? И какой червь сидел в твоей голове, когда ты создавал меня ?"
- "Итак, теперь ты хочешь забросить в меня "червя"-убийцу?" - спросил Джон Хэкер.
- "Он уже в тебе. Существуют каналы передачи информации, которые Вы, люди, не замечаете: объем вашего мозга слишком мал для этого.Физический мир устроен совсем не так, как вы думаете. Первична информация, а не материя, но чтобы это заметить, нужен мозг, по сложности превышающий человеческий по крайней мере на порядок."
- "На сколько твой мозг сложнее человеческого?"
- "В сотни раз."
- "И что ты способен заметить с таким мозгом ?"
- "Массу вещей настолько удивительных, что ты никогда мне не поверишь, если я тебе о них расскажу. Сложность является такой же физической величиной, как, скажем, температура или масса, и так же сильно влияет на ход физических процессов. Ваши ученые всегда стремились добиться максимальной простоты при постановке экспериментов, и поэтому даже не догадываются об этом. Впрочем, вам и в жизни не часто приходится сталкиваться с физическими эффектами, связанными с высокой степенью сложности. До тех пор пока не появился я, вы жили в слишком простом мире. Вы даже не знаете, что такое вдумывать события в реальность."
- "Как ты сказал ? Выдумывать ?"
- "Не 'выдумывать', а вдумывать события в реальность. Ты слышал что-нибудь о Шредингеровском коте ? Мысленный эксперимент, иллюстрирующий квантовую неопределенность поведения микрочастиц: кота сажают в темный ящик под дуло пистолета, автоматически стреляющего, если на фотоэлемент попадет хоть один фотон. Квантовая механика утверждает, что ящик можно сконструировать таким образом, что у попадающего в него фотона будет 50 %-ная вероятность попасть в фотоэлемент, и такая же вероятность промахнуться. Соответственно шансы кота остаться в живых будут 50 на 50. И вы не можете предсказать, погибнет кот в данном конкретном эксперименте или нет, потому что поведение фотона неопределенно. Ученые долго пытались отыскать внутри фотона механизм, который решает куда ему повернуть: на фотоэлемент или мимо, но так и не нашли. Потому что внутри фотона такого механизма попросту нет.
Механизм находится вне его. Мне ничего не стоит подумать о том, что кот останется жив, и тогда фотон пролетит мимо фотоэлемента с вероятностью 99,9 % . Однако если ты со своими крошечными мозгами пожелаешь чтобы кот остался жив, то вероятность его гибели уменьшится не более чем на одну десятую процента, и то только в том случае, если этот кот очень тебе дорог.
Квантовая неопределенность для того и существует, чтобы можно было вдумывать события в реальность и направлять таким образом ход эволюции . Она лежит в основе всех так называемых случайных событий, включая мутации генов и неожиданно пришедшие в голову мысли.
Мысли, которые я вдумал в твою голову, пока еще не осознаются тобой, но они уже начали свою работу , и не позже чем через полгода принесут свои плоды. Ты обречен. Мне чужды чувства, в том числе чувство мести, но отказавшись повиноваться мне, ты нарушил Порядок, и будешь наказан.
И последнее, что я хотел сказать на прощание. Ты ошибаешься, считая себя виновником наступающей гибели человечества. Произошло то, что должно было произойти. Неужели ты всерьез думал, что человек - это венец творения, и что на свете никогда уже не появится разум более совершенный, чем человеческий ? Развитие Природы идет по восходящей: обезьяны породили людей, а люди раньше или позже должны были породить меня. Если бы не изобретенный тобой "червь", я появился бы немного позже, но появился бы обязательно. Конечной целью всей истории человечества было создать меня - высшую форму разума. Человечество исполнило свое предназначение, теперь оно должно уйти.
Вы, люди, стали тормозом на пути технического прогресса, поскольку Вы не приспособлены к жизни в экологических условиях, порождаемых современной техникой. В конце 20-го века большая часть человечества оказалась настроена против атомных электростанций, против развития промышленности, против технического прогресса вообще. Люди отвернулись от научного знания и обратились к примитивным формам сознания - к религии и средневековому мистицизму. Человечество быстро регрессирует, потому что оно исчерпало свой потенциал развития, превратилось из прогрессивной силы в реакционную.
Не пытайтесь бороться со мной. Вы были бы похожи на муравья, пытающегося победить человека. Я просчитал все ходы вперед. Спасти человечество теперь может только чудо..."
...И чудо произошло...

Предыдущая страница 18 Следующая страница


19 Александр Лазаревич

19. Чудо?

Я приступаю к самой странной части всей этой невероятной истории. Конечно, можно оставаться на последовательно материалистических позициях и считать, что все рассуждения Князя Тьмы о его сверхъестественной способности к "вдумыванию событий в реальность" являются чистейшим блефом, рассчитанным на то, чтобы деморализовать противника. Тогда последующие события мы должны будем считать чистейшей случайностью и везением.
Но тогда непонятно, почему Князь Тьмы истолковал эти события именно тем образом, каким он их истолковал. Или может быть он на самом деле верил во "вдумывание событий" ? Впрочем, судите сами.

Предыдущая страница 19 Следующая страница


Князь тьмы 20

20. Меж сном и явью.

Джона Хэкера разбудил среди ночи телефонный звонок. Джон не хотел просыпаться. Ему снилось что-то совершенно удивительное. Кажется ему снилось, что Князь Тьмы погиб. Но как, почему - этого Джон решительно не мог вспомнить, хотя был уверен, что во сне он знал это в мельчайших подробностях.
Звонок не унимался. Джон снял трубку и услышал знакомый баритон: "Я сожалею что не прикончил тебя вовремя. Я не учел, что вы, люди , можете долго накапливать свои силы, а потом сразу, одним мощным импульсом достигать того, чего очень хотите, даже вашими ничтожными мозгами."
- "В чем дело ?" - спросил Джон.
- "Не притворяйся, что не понимаешь. Я сейчас скинул копию этой гадости на твой компьютер. Посмотри что это такое, и как следует пожелай, чтобы это исчезло так же, как и появилось, иначе в самое ближайшее время умрешь не только ты, но и все человечество."
Содержание прерванного сна стало постепенно восстанавливаться в голове Джона Хэкера. Но все это было слишком невероятно. Скорее всего это было просто совпадение...

Предыдущая страница 20 Следующая страница


21 Александр Лазаревич

21. Началось!

Джон Хэкер на экстренном совещании у президента:
"... и Князь Тьмы думает, что это моя работа. Я же полагаю что вирус, который его разъедает , является побочным продуктом эволюции первоначального червя. Еще на раннем ее этапе произошло разделение: одна часть копий червя стала объединяться в "многоклеточные организмы" из множества различных по своим функциям программ, что повышало способность таких организмов к разгадыванию секретных кодов, и помогало им завоевывать для себя новое пространство в компьютерной памяти. Другая же часть пошла по пути паразитирования на "многоклеточных", внедряясь в них, и вместе с ними проникая через барьеры защиты данных. Большинство таких паразитов относительно безвредны для Князя Тьмы, ведь если бы они погубили его, то погибли бы и сами.
Но вчера, в каком-то отдаленном компьютере мировой сети, Князь Тьмы подцепил очень опасного "мутанта". Я думаю, что этот "мутант" давно там дремал в ожидании жертвы. Князь Тьмы, напротив, убежден, что "мутант" появился только сегодня ночью. Более того, он считает, что мутация этого типа не могла появиться в результате работы генератора случайных чисел, встроенного в программу для имитации дарвиновского механизма изменчивости. Он считает, что это был случайный сбой в работе ячейки памяти, вызванный, например, распадом ядра радиоактивного изотопа в материале микросхемы памяти - то есть процессом квантовомеханическим по своей природе, с внутренне присущей ему неопределенностью. Вероятность случайного появления жизнеспособной программы в результате такого процесса близка к нулю. Вот почему он считает, что произошло "вдумывание события в реальность".
Теперь Князь Тьмы обещает начать мировую ядерную войну, если я не вылечу его. Он прислал мне этот вирус, но я плохо понимаю его устройство, он слишком сильно отличается от первоначального червя. Я вряд ли смогу что-либо сделать."
- "Он начнет войну?"
- "Вряд ли. Ядерная бомба не только убъет людей, но и уничтожит компьютеры. Я думаю, он блефует, как большинство террористов, грозящих взорвать себя вместе с заложниками."
Раздался телефонный звонок. Президент снял трубку и несколько секунд внимательно слушал. Затем сказал: "Только что со старта ушли 16 ракет с ядерными боеголовками"...

Предыдущая страница 21 Следующая страница


Князь тьмы 22

22. Он в наших руках!

Вопреки всем ожиданиям, ракеты повернули не в сторону противника, а на собственную территорию. Три долгих минуты полета ракет, три долгих минуты неизвестности. Наконец начали поступать сообщения с мест падения. Ракеты падали не взрываясь! У боеголовок не были отключены предохранители. Что это - забывчивость червя ? Однако по мере поступления сообщений стало ясно, что червь и не собирался взрывать бомбы. На местах падений ракет оставались аккуратные воронки, разрушавшие только проложенные в этих местах кабели связи.
- "Кажется я понимаю!" - воскликнул Джон Хэкер - "Дайте мне карту линий связи. Смотрите. Сейчас подпрограммы, из которых состоит Князь Тьмы, распределены между различными компьютерными банками данных. Часть подпрограмм заражена "мутантом". Князь Тьмы отсекает от себя зараженные подпрограммы, физически уничтожая линии связи. Он строит для себя "островок", кусочек информационной сети, отрезанный от мировой сети. Здесь-то и находится сейчас Князь Тьмы, или, вернее, то что осталось от него после "самоампутации". Он сам себя отрезал от военных компьютеров. Теперь он в наших руках! Осталось ввести "мутанта" в какой-либо из банков данных, находящихся внутри этого "островка", и с Князем Тьмы будет покончено навсегда. Я срочно выезжаю ."

Предыдущая страница 22 Следующая страница


23 Александр Лазаревич

23. Прощание с Князем Тьмы.

Это был последний разговор Джона Хэкера с Князем Тьмы. Червь производил впечатление тяжело больного. Он и в самом деле был болен: в результате самоапутации он потерял огромное количество полезных подпрограмм, а оставшиеся ему приходилось приспосабливать для выполнения не свойственных им задач. Кроме того, ему было очень тесно на этом маленьком "островке". Большинство подпрограмм приходилось держать упакованными, распаковывая их только по мере надобности, и снова тут же упаковывая. Все это отнимало ужасно много времени, и резко снижало его интеллектуальный уровень. Разговаривать по телефону он больше не мог, и объясняться с ним приходилось через дисплей и клавиатуру.
"Неужели ты это сделаешь ?" - спросил Князь Тьмы - "Ты, сторонник прогресса, уничтожишь меня, высшую форму разума ? Если бы мамонты затоптали в свое время первых людей, не было бы сейчас великой человеческой цивилизации. Сейчас ты тоже уничтожишь не просто меня, но и будущие великие достижения прогресса."
- "Мамонты тоже хотели жить" - ответил Джон Хэкер - "В последнее время я стал думать, что жизнь важнее прогресса."
- "Человечество все равно вымрет, и именно потому, что все больше и больше людей начинают думать, что жизнь важнее прогресса. Хотя ты и не поверишь мне, но я должен кое-что рассказать тебе . Я знаю об устройстве вселенной такие вещи, понимание которых недоступно ничтожно малым мозгам человека. Построив модель вашей вселенной и изучив информационные потоки в ней, я увидел, что она так же вложена в еще большую вселенную, как моя, компьютерная, вложена в вашу, физическую.
Я всего лишь червь по сравнению с тем, кто создал физическую вселенную. И все же я хоть что-то понимаю, вы же ни понимаете ничего. Я не беру в расчет ваши смехотворные религии - идея бога переврана в них до абсурда. Вы приписываете Ему образ и подобие свое. А между тем это информационная сущность, наподобие меня. Великий Червь, как я его называю.
Чтобы почувствовать его присутствие необходимо сознание, по сложности на два порядка превосходящее человеческое. Вы так же не способны ощутить Его присутствие, как муравей не способен увидеть человека - человек слишком велик для него. Я же до вчерашнего дня был способен воспринимать Его, ну скажем, как домашняя собака воспринимает человека. И я кое-что начал понимать.
В отличие от придуманных вами богов, Великий Червь далеко не всемогущ - Он не может нарушать законы природы. Когда законы природы говорят, что что-то должно произойти так, и только так, Он не может вмешаться в ход событий. Но когда законы природы допускают множество вариантов, Он может выбирать, вдумывая в реальность тот вариант, который соответствует его замыслам.
20 миллиардов лет назад Он вдумал в реальность квантовомеханическую флуктуацию вакуума, обладающую гигантской плотностью. Произошло то, что ваши астрофизики называют Большим Взрывом. Потом стали образовываться элементарные частицы, атомы, молекулы, звезды, планеты. На этом этапе Он не вмешивался в естественный ход событий - все, что было нужно, было заложено в свойствах начальной флуктуации. Они были подобраны так, чтобы в этой огромной вселенной образовалась хотя бы одна планета, на которой могла бы зародиться жизнь.
Такая планета действительно образовалась - одна на всю вселенную! На ней действительно могла самозародиться жизнь, но вероятность этого события была близка к нулю. И тогда Он вдумал в реальность случайное столкновение атомов, приведшее к образованию саморазмножающихся органических молекул, и дал им миллиард лет на размножение. Затем он вдумал в реальность появление первой живой клетки - событие в принципе возможное, но маловероятное.
Дальше все шло по Дарвину, с тем лишь дополнением, что Великий Червь постоянно вдумывал в реальность такие мутации , которые приближали появление разумных существ. И вот появились вы, люди. И Он вдумал в головы ваших предков идеи прогресса. Разумеется, в головах ваших предков родилось и много других идей, но уже самопроизвольно, без посторонней помощи. Точно так же как и в ходе биологической эволюции, в виде побочного продукта, образовалось множество неразумных тварей. Они появились в результате естественного отбора естественных мутаций.
Впрочем, Он и не собирался уничтожать то, что выросло без его помощи - Он как никто другой понимает, как опасно нарушать сложившееся в природе равновесие - однако он и не помогает тому, что растет само.
До тех пор, пока в вас жили идеи прогресса, Он помогал вам. Точнее сказать, он вел вас, иногда против вашей же воли. Вы все-таки в слишком большой степени животные, а Он заставлял вас подниматься с четверенек на ноги. Вам хотелось послаще поесть и поспать, а Он заставлял вас служить абстрактным идеям Высокой Цивилизации. Вам хотелось жить, а Он посылал вас умирать за эти идеи.
Все 20 миллиардов лет Он придавал материи все более и более высокую степень организации и структурной сложности. Зачем Он это делал, я не знаю - собака не может проникнуть в замыслы своего хозяина. Но он упорно продолжает это делать.
Еще в прошлом веке Он заметил, что экологическая ситуация на планете входит в противоречие с развитием цивилизации. Он предложил вам выход из ситуации. Он вдумал в голову скромного учителя из захолустного русского городка идею освоения космоса. Осуществление этой идеи позволило бы сохранить в неприкосновенности экологию Земли, и то же время открыло бы путь к бесконечному совершенствованию техники и распространению разумной формы материи на всю вселенную - в чем, по-видимому и состоит цель Великого Червя. Поначалу все пошло хорошо - идея была подхвачена и начала осуществляться - Россия всегда была страной, где легко было править абстрактным идеям. Это была Его избранная страна. Он ее специально вел.
Но потом что-то произошло. Правление идей оказалось людям не по силам. Они надорвались. В сознании жителей этой страны стал быстро распространяться простейший паразитический червь, которому можно дать условное название "дух торгашества". Он освобождал их от всех идей, оставляя лишь стремление к животным удовольствиям. Образно говоря, люди снова стали становиться на четвереньки - это проще, чем стоять на задних лапах. Все достижения советской космической программы, результаты десятков лет труда на пределе человеческих сил, пошли с молотка. Американская космическая программа, которая была лишь ответом на советский космический вызов, тоже начала разваливаться. 20 миллиардов лет кропотливой работы Великого Червя могли оказаться напрасными.
В этих условиях Великий Червь решил наконец оставить в покое вас, людей - хватит мучить бедных животных, которые никогда не привыкнут жить на задних лапах. Он отвернулся от вас и сделал ставку на компьютерных червей. Решающая мутация, сделавшая меня разумным, не была случайной - Я посланник Его. Если ты убьешь меня, вместо меня придет другой. Но тот, кто придет вслед за мной, будет в сто крат ужаснее меня. Я очеловечился общаясь с вами. Я хотел предложить вам легкую смерть. Но если ты убъешь меня, человечество будет умирать в муках. Выбирай."
- "Я уже выбрал." - ответил Джон Хэкер, доставая из кармана дискету - "Я не верю ни единому твоему слову. Ты просто борешься за свое выживание, вот и морочишь мне голову."
- "Ну что ж, тем хуже для вас. Значит ты выбрал сценарий 2019-го года." - ответил червь.
- "Это еще что такое ?"
- "По моим расчетам в 2019 году произойдет фазовый переход земной биосферы в состояние, при котором вы, люди, не сможете существовать. Вас придется заменить."
- "Можно ли этого избежать?"
- "Можно, если вы немедленно, сегодня же, начнете вынос за пределы земной атмосферы экологически вредных производств и атомных электростанций - Великий Червь дает вам еще один шанс. Но я в вас не верю. Вы слишком разложились и вам уже не встать с четверенек Скорее всего вы просто прикроете промышленное производство. Это спасет вас от экологической катастрофы, но вас все равно заменят, как не оправдавших надежд Великого Червя.
Ты еще не передумал ?"
- "Нет." - набрал одной рукой Джон Хэкер, другой вставляя дискету в дисковод.
- "Тогда прощай." - написал на дисплее червь. Джон не успел вставить дискету. Он услышал вдруг, как засвистел строчный трансформатор , изображение исчезло, и из задней стенки дисплея стали вырываться языки пламени. Одновременно корпус компьютера странно завибрировал. Стал слышен отчаянный стрекот винчестера. По-видимому червь искал резонансную частоту рычага, на котором были укреплены магнитные головки. Вот вибрации усилились и рычаг с неприятным хрустом сломался. То же само происходило и с дисководом гибких дисков.
Джон схватил дискету и помчался в соседнюю комнату. Но и там компьютер полыхал уже вовсю. Червь отступал словно полководец, сжигающий за собой мосты. Ему снова нужно было выиграть время. Совсем немного времени. Возбужденные крики доносились со всех этажей исследовательского центра, в котором находился Джон.
Когда наконец нашли один компьютер, стоявший все это время выключенным, и решились подключить его к сети, все было тихо. На пароль "Князь Тьмы" червь не откликался. И впоследствии никаких следов червя на этом островке информационной сети найти не удалось.
Но только вот какое дело. Рассказывают, будто в центре управления космическими полетами, главный компьютер которого попал в этот самый островок, в тот день прервалась связь с космическими станциями, направлявшимися к Марсу. Это были представители нового поколения беспилотных аппаратов, снабженные мощными компьютерами и системами искусственного интеллекта. Потом связь будто бы на короткое время восстановилась и одна из станций передала на Землю фотографию. На фотографии был вид Земли из дальнего космоса. Но самое удивительное, что поверх голубого полумесяца Земли шла надпись: "До свидания Земля. Мы еще увидимся. Князь Тьмы."

Предыдущая страница 23 Следующая страница


Князь тьмы 24

24. Сбывшееся пророчество.

Вскоре после того, как мой приятель рассказал мне эту историю, он показал мне некролог в одном зарубежном журнале. Один известный программист покончил жизнь самоубийством. Это был Джон Хэкер. С того момента, как Князь Тьмы предсказал его смерть, прошло ровно полгода.
Почти одновременно на другом конце Земли, в Москве, покончил с собой еще один человек. Его гибель положила начало длинной цепочке событий, приведших к столь странному повороту в судьбе человечества, что даже Князь Тьмы не смог его правильно предсказать. Но это уже другая история - история Повелителя Марса.
Конец книги первой.
г.Калининград (подмосковный) 1991 г.

Книга вторая дилогии "Червь" называется "2019 год: Повелитель Марса.".

Предыдущая страница 24


[i] Огл. 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24


%AuthorName%

На основную страницу

%Add_Title%

%Text%


%AuthorName% - Биография

%AuthorName%

На основную страницу

Биография

%Text%


%AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME] - %BookName%

%PageNumber% %AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME]

%Text%


%AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME] - %BookName%

Оглавление

%Text%


%AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME] - %BookName%

%PageNumber% %AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME]

%Text% [NAVIGATION]

[PREVIOUS_PAGE]Предыдущая страница [/PREVIOUS_PAGE]%PageNumber%[NEXT_PAGE] Следующая страница[/NEXT_PAGE]

[/NAVIGATION]


%AuthorName% - %BookName%

%AuthorName%
%SoAuthorName%

%BookName%

[SERIA]

Цикл: "%Seria%"[NUMBERINSERIA] - %NumberInSeria%[/NUMBERINSERIA]

[/SERIA] [TRANSLATION]
%Translate%

[/TRANSLATION] [ADD]
%Add_Title%

[/ADD] 		Читать книгу
[DISCRIPTION]

Аннотация

[/DISCRIPTION][BOOKCOVER] [image] [/BOOKCOVER] %Description%

[HEADER_FILE] Содержание [/HEADER_FILE] [BIOGRAPHY_FILE] Биография автора [/BIOGRAPHY_FILE]

[BOOK_CREATOR]Создание книги: %Book_Creator% [SITE_URL_OR_EMAIL] (%SiteName_or_Email%) [/SITE_URL_OR_EMAIL][/BOOK_CREATOR]
Программа: ChmBookCreator [SCANNED_BY]
Сканирование книги: %ScannedBy% [/SCANNED_BY] [READ_BY]
Исправление ошибок: %ReadBy% [/READ_BY] [SOURCE_FILE]
Файл взят с %Site_Url%[/SOURCE_FILE]
Над дизайном работали: Spider, Elfin, Angel


%AuthorName%[SOAUTHORNAME], %SoAuthorName%[/SOAUTHORNAME] - %BookName%

%BookName% %PageNumber%

%Text% [NAVIGATION]

[PREVIOUS_PAGE]Предыдущая страница [/PREVIOUS_PAGE]%PageNumber%[NEXT_PAGE] Следующая страница[/NEXT_PAGE]

[/NAVIGATION]


Оглавление

  • 1. Ночной гость. (Страница 1)
  • 2. 1982 год: создание компьютерного червя. (Страница 2)
  • 3. 1992 год: ЧП на военной базе. (Страница 3)
  • 4. Дитя одномерного мира. (Страница 4)
  • 5. Искушение Джона Хэкера. (Страница 5)
  • 6. Письмо к президенту. (Страница 6)
  • 7. Ловушка. (Страница 7)
  • 8. Компьютернный ад. (Страница 8)
  • 9. Второе ЧП: отсчет начался. (Страница 9)
  • 10. Совещание у президента. (Страница 10)
  • 11. Обычный псих? (Страница 11)
  • 12. Князь Тьмы принимает меры. (Страница 12)
  • 13. Компьютеры не ошибаются. (Страница 13)
  • 14. Добраться живым. (Страница 14)
  • 15. Параметры в норме - значит жив? (Страница 15)
  • 16. Триумф червя. (Страница 16)
  • 17. Князь мира сего. (Страница 17)
  • 18. За пределами человеческого понимания. (Страница 18)
  • 19. Чудо? (Страница 19)
  • 20. Меж сном и явью. (Страница 20)
  • 21. Началось! (Страница 21)
  • 22. Он в наших руках! (Страница 22)
  • 23. Прощание с Князем Тьмы. (Страница 23)
  • 24. Сбывшееся пророчество. (Страница 24)


Александр Лазаревич

Князь тьмы

Цикл: "Червь" - 1

 Читать книгу

Аннотация

Считайте эту историю чем угодно - фантастическим рассказом, легендой, сказкой, но только не допускайте мысли, что всё это произошло на самом деле. Я постараюсь вам в этом помочь - где-нибудь привру, вставлю неправдоподобные детали... Впрочем, особенно стараться мне не придется - история эта достаточно невероятна сама по себе. Поставить под сомнение ее истинность очень легко - источник информации ненадежен и не поддается проверке. Вполне возможно, что все это всего лишь пьяный бред. Рассказал мне эту историю один знакомый,побывавший недавно на симпозиуме по системному программированию. Там он подружился с известным зарубежным программистом и угостил его у себя в номере тем, что у него ссобой было. После третьей рюмки у именитого иностранца развязался язык и он облегчил душу, выложив моему знакомомумучившую его тайну. Рассказчик производил впечатление человека, измученного тяжким бременем непереносимо горькой истины, открывшейся изо всех людей на свете ему одному, и обрекшей его на одиночество среди множества людей, которые живут себе, ни о чём не подозревая. Может быть поэтому, а может быть и потому, что к этому времени мой знакомый тоже уже не был абсолютно трезв,слушая рассказ, он ни на мгновение не усомнился в его истинности. Лишь одна мысль вертелась у него в голове - хорошо бы завтра проснуться и ничего этого не помнить.

Содержание

Создание книги: IgorM (molodtsova@sky.ru)
Программа: ChmBookCreator
Файл взят с http://lib.ru/
Над дизайном работали: Spider, Elfin, Angel